Can I run two separate versions of the LabVIEW Run - Time Engine on a PC?

Hello, I am curious to know if anyone knew if it is possible to install and use the two separate versions of the LabVIEW Run-Time Engine on a PC?  I have currently 2009 runtime engine installed on a machine, and I wanted to install the runtime for 2011 as well. I know that you can run two separate versions of the LabVIEW program on the same machine, but what about the Run-Time Engine?

Thank you!

Advertisement

No problem at all. I currently have the engines of execution for 8.2, 8.6, 2009, 2010 and 2011 on my computer. Multiples are no problem at all. Go ahead and load.

Rob

Tags: NI Software

Similar Questions

  • How can I add a separate apple for the iphone and ipad wife id

    How can I add a separate apple for the iphone and ipad wife id

    Hi, are the measures already implemented? If they are, you need to configure them again and establish a Apple ID at this time.

    Apple ID - Support official Apple

  • How can I create a separate page in the menu bar?

    How can I create a separate page in the menu bar?

    I want to create a page that does not contain the bar, other pages, and I don't want other pages to include this new page in their menu bars.

    I want to create a different page (s) completely independent in an existing menu bar and maybe add it's own menu bar...

    Is there a way to do it?

    Yes, you can right click the page you want to have separate and select "exclude of the Menu.

  • How can I combine two PDF files on the same page?

    How can I combine two PDF files on the same page? Please share any ideas you may have. Thank you.

    The term for what you want to do is called "page imposition.  There are third party tools that can do it for you like this: quite large: home page

  • Requirements for the Labview 8.6 run-time engine

    Hello

    are there system requirements for the LabVIEW 8.6 run-time engine? for example, same system requirements for LabVIEW 8.6? Internet Explorer 5 is perfect? or Internet Explorer version 6.0 or later is good? It works for Firefox on a Linux Athena mechine?

    Thank you

    Cynitha

    The system requirements can be found in the Release Notes. Pages 2 and 3 indicate the specific requirements for the Run-Time Engine by platform.

  • Improved LabVIEW 8 to 2013 and VI asked now to find the installation package for Run-Time Engine 7.0

    I recently installed LabVIEW 2013 on a computer (running Windows XP 32-bit).  The machine has also of LabVIEW 8 is installed, which is what I used before the upgrade.  I opened a VI has been created in LV8 and then saved it and all its subVIs in LV2013.  Now when I open the VI in LV2013 and try to run it, a window opens asking me to find the installation package 'lvruntimeeng.msi' for LabVIEW Run-Time Engine 7.0.  If I cancel this dialog box, and the subsequent message, indicating that the installion files were not, the VI appears (at least of the initial inspection) to function normally.

    I have closed LabVIEW, downloaded Run-Time Engine 7.0 on the site of NOR and tried to install it, but I received a message saying that it is already installed (as I had suspected).  How can I determine what part of the VI and/or its subVIs tries to make use of Run-Time Engine 7.0?  If not, how can I get LabVIEW to use instead the Run-Time Engine 2013 that was installed when I upgraded to LabVIEW 2013?

    Bob_Schor wrote:

    You run your VI of a project?  If so, you can watch the dependencies and get an idea of what live "in charge", you might have.  There may be "something old" in your code in LabVIEW 8, which was replaced in 2013, but ' plane still around "-If you can identify it, you can probably replace it with its"more modern"equivalent

    If you do not have the VI in a project, you can simply open LabVIEW, create a blank project and add your first level VI.  If all of your relevant screws are in a single folder, add the entire folder.  Now look in the dependencies.

    BS

    Yes, I run the VI from within a project of LV.  After some more research in the knowledge base OR I could solve the problem by using the following procedure:

    1. use the measurement and Automation Explorer to uninstall Run-Time Engine 7.0

    2. restart the PC

    3. open the project, close the project by choosing "save all".

    4. restart the PC

    5 reinstall the Run-Time Engine 7.0 using a file downloaded from ni.com

    6. restart the PC

    7. open the project, close the project by choosing "save all".

    8. open the project and run the VI.  No more messages on LabVIEW, trying to find the Run-Time Engine 7.0.

  • ??? Insert the "NI LabVIEW Run-Time Engine 7.1.1.

    OK everyone, I'm "dead in the water" when launch LabVIEW 2014 SP1 after a long night of installing updates to Developer Suite 2014 DS2 SRL 2015 DS1 SRL

    Search Forum has this old thread

    http://forums.NI.com/T5/LabVIEW/error-1334-in-LabVIEW-run-time-engine-7-1-1-Setup-when-launching/TD-...

    Since 2008

    NOTE: at least its looking for a CD ROM is not a floppy disk!

    Hooray!

    I've recovered from that.  And Yes, I'll tell you how that you can do it yourself if this happens to you:

    From the control panel select programs and features, then National Instruments software.

    Scroll to "LabVIEW Run - Time Engine 7.1.1" and select Repair

    You will need the following:

    • Device drivers OR August 2014
    • C:\ProgramData\National Instruments\Update Service\Installers\NI_20150630_0736
    • NEITHER Developer Suite 2015 Encarta software
    • Patience
  • Where the last installation program LV2010 Run-Time Engine?

    Sorry for this absurd question, but after a half hour of roaming the site I can't find an installer LV2010 RTE.

    Would it not be this difficult?

    Could someone tell me please in the right direction?

    Thanks in advance!

    http://lmgtfy.com/?q=+LV2010+RTE+Installer

    Sorry, but I love this site sometimes.  I found the search function OR be so difficult.

    Or click on Support Services & > NOR drivers > software > LabVIEW Run - time Engine

  • Unable to locate labview run time engine

    Hi all

    I have a problem while trying to run a simple labview software on a Tablet PC.

    My development machine is under win 7 64 bit with labview 2010 sp1 10.0.1

    My computer is a win 7 32 bit based tablet.

    I installed labview runtime engine TEN 2011 standard 32-bit sp1 but I get the following text: «unable to locate labview run-time engine...» "

    I tried to install sp1 64-bit of the 2011 standard RTE because one of the items suggested, but windows is not allowing to install 64-bit applications...

    Should which version of the Runtime I install!

    You did not say, but I'm assuming that you are using LabVIEW 2010 sp1 32 bit to develop and build the application.

    You can include the 2010 sp1 Runtime when you build the Setup program, or you can download it (here) and install it separately.

    (The runtime version must match the development system, so time to run from 2011 will not work. Even the 2010 (non - SP1) could cause problems)

    Kobi Kalif wrote:

    I tried to install sp1 64-bit of the 2011 standard RTE because one of the items suggested, but windows is not allowing to install 64-bit applications...

    Can you tell me what position suggested to install an operating time of the wrong version of 64-bit. That makes no sense at all! Please provide a link.

    (You can only install the runtime on a 64 bit OS, 64-bit, and he will agree only if the application has been developed in 64-bit LabVIEW to the same version.)

  • License OR VISION Run-Time Engine

    Hello

    I send you this question because despite the number of doc that I could find in relation to my question, I have not had a clear answer to my pb:

    I have an application that has been developed with LV 8.2.1 using NI IMAQ 3.7 from functions. (Very briefly the program acquires images from a camera, performs simple operations on images and saves the results of these operations, so other images).

    I would like to know what are the licenses I need to purchase pour installer of the compiled version of my prog on client pc (which does not have LV). (I know I'll have to buy for each client PC licensed IMAQ 3.7 but regarding the treatment of these images can I just no VISION Run - Time Engine 8.2.1 which seems to me is free in the same way that NEITHER LABVIEW Run-Time Engine 8.2.1)

    Pour your response thanks in advance that I help him nothing I hope to see more clearly between the IMAQ vision, vision performance, VISA Run-time...

    Normal 0 21 false false false FR X-NONE X-NONE MicrosoftInternetExplorer4 / * Style Definitions * / table. MsoNormalTable {mso-style-name : « Tableau Normal » ; mso-tstyle-rowband-taille : 0 ; mso-tstyle-colband-taille : 0 ; mso-style-noshow:yes ; mso-style-priorité : 99 ; mso-style-qformat:yes ; mso-style-parent : » « ;" mso-rembourrage-alt : 0 cm 5.4pt cm 0 5.4pt ; mso-para-marge-haut : 0 cm ; mso-para-marge-droit : 0 cm ; mso-para-marge-bas : 10.0pt ; mso-para-marge-gauche : 0 cm ; ligne-hauteur : 115 % ; mso-pagination : widow-orphelin ; police-taille : 11.0pt ; famille de police : « Calibri », « sans-serif » ; mso-ascii-font-family : Calibri ; mso-ascii-theme-font : minor-latin ; mso-fareast-font-family : « Times New Roman » ; mso-fareast-theme-font : minor-fareast ; mso-hansi-font-family : Calibri ; mso-hansi-theme-font : minor-latin ; mso-bidi-font-family : « Times New Roman » ; mso-bidi-theme-font : minor-bidi ;}

    Hello fabrice91,

    The Runtime of NOR-VISION is available to download for free, however during the installation you have to activate it. When you create an executable LabVIEW AAFC is not automatically run time engine, this is why you need to create an installer that will contain the TENS of LabVIEW and NI of VISION. If you run the executable on the development computer it is normal that your application turns car you have all the necessary Runtime on this post. However if you try to run your application on a machine where there is no software OR your executable will not have to work and that's your Installer. Pour the know National Instruments programs installed on a PC you have several opportunities either through Measurement & Automation Explorer either start > Control Panel > Add/Remove Programs > software from National Instruments.

  • LabView Run - Time Engine 2009 installation failure

    Hello

    I have problem to install Labview Run - Time Engine 2009.

    This error occurs:

    Die Installation von NI VC2008MSMs x 86 ist auf Grund of the following Fehlers fehlgeschlagen.

    Auf den Windows-Installationsdienst konnte nicht rarely werden.

    Die kann occurrence, wenn Sie Windows im abgesicherten Modus implement oder der

    Windows-install extension installed ist nicht. Wenden Sie sich an den Support, um Hilfe zu receive.

    (The installation of the NC is VC2008MSMs x 86 has failed due to the following error.

    The Windows Installer Service could not be accessed. That may occur when you run

    Windows in safe mode or Windows Installer is not correctly installed.

    Contact your support team.)

    I tried to reinstall and reregistrate program windows installation, I tried to upgrade the installer from windows to version 4.5

    I installed Microsoft Visual C++ 2008 Redistributable-x 86.

    IM runing Windows XP Service Pack 3

    (Microsoft Windows Version 5.1 (Build 2600.xpsp_sp3_gdr.100427 - 1636_ Service Pack 3))

    I have no problem installing other programs, for example, can I install runtime labview 7.1.1.

    So my question is:

    How do to solve this problem, how can I make a Labview Run-Time Engine 2009 installation on this computer which gives me the error described at the beginning?

    Best regards

    Simon

    Now I have solved my problem.

    The solution was to raise and to build my code in Labview 2010.

    But the question of the installation contains yet to install LabView Run-Time Engine 2009.

    I don't think it's associated Windows Installer, because I can install everything on my computer in addition to LabView Run-Time Engine 2009.

    I can even install LabView Run - Time Engine 7.1.1 and LabView Run-Time Engine 2010.

    So, my solution was to jump using LabView 2009 and install LabView 2010.

    Best regards

    Simon

  • NI-VISA run-time engine

    When 'building' a LabVIEW program containing NI-VISA under VI (for example to connect with USB), I had problems to get the code 'built' to find my devices NOR VISA, even if the NI VISA's USB drivers are correctly installed on the computer 'target'.

    (The code 'built' will run if the target machine has an installation of LabVIEW to this topic, including NI-VISA)

    -The NI-VISA run-time engine will automatically appear in the 'Build' (because of the Sub - NI VISA VI), or should I specify myself - and how?

    Thank you. Peter.

    Create an installer as you did the executable version.  The installation program will be for the executable, not for the original project.

    What version of LabVIEW are you using?

  • VISA writing differs between TS and LV Run - Time Engine development agencies

    Hi all

    I made a request on LabVIEW to test the BERs (Bit error rate), and I used the Write VISA between two COM ports to Exchange data.

    Everything works great using just of LabVIEW.

    Later, I used TestStand to call my application (VI). Adapters of LabVIEW TestStand have been set by default on the development system , and everything works OK!

    Finally, I had to disable the development system and to define the types of adapters LabVIEW of TestStand for LabVIEW Run-Time Engine and I noticed that the speed of the exchange of data between two COM ports significantly decreased.

    The only difference was the speed... because all data (changed slowly in this case) happened correctly on the other COM port too.

    The symptom was the same that decrease baud rate... but baud rate and all other configurations remained the same. The only difference was the change between the development system for the runtime to notice this reduced speed between the data exchanged using VISA Write.

    All the solutions for this?

    Thanks in advance

    João

    Hi all!

    I'm sorry, I forgot to reply to this thread...

    Solution was change the way VISA WRITE of "asynchronous" to "synchronous" to book a thread just to WRITE visa.

    The problem here was something like this (?): TestStand used all available threads and when we wanted to WRITE of VISA, the thread has been busy and VISA would wait until the wire emerges. After changing to syncrhonous, there was a thread dedicated to this process (?).

    Now, everything works the same using LabVIEW Run-Time Engine or system deployment.

    Thanks for the help Chris and Norbert :-)

    João

  • NI Vision Run - Time Engine (incompatible with already installed products)

    Hi people - I created an installer for a simple application using LabVIEW and Vision 2010 SP1 64-bit.  The application works fine in Win7/64-bit OS development environment.  Failed to install on another computer with the same operating system, which gives the following message is displayed.

    The additional setup only I checked is the Vision Run-time Engine 2010 SP1.  I've completely updated all my products OR with the last set level DVD, which is for 32-bit products.  I can send the LLB from the source code if someone from NI Vision support staff needs this.

    Help!

    Thank you

    Don

    In prior OR components unistalling and then put it back, we have able to install this application.

    NOR can give a message more informative than the screenshot, I showed, as try uninstalling some components OR already residing on the machine, so we know where to start.

    Thank you

    Don

  • Run-Time Engine error

    I created an automated test and had to run as an executable on a test computer stand alone. I've updated my LabView 8.6.1 software. I just made some changes to the test and recompiled it. When I tried to run it on the computer of stand alone it gave me an error about the missing LabVIEW 8.6.1 run-time engine. I thought when the project was built all the files related to execution it were also built in the folder. Someone at - it run in which could offer some advice.

    Thank you

    Chirs

    Did you create an installer, or simply build the exe? If you have built only the exe file, you will need to install the runtime on the target computer. If you have created an installation program, you can include the installation of runtime as part of the Setup program.

Maybe you are looking for