Even with "ask to save tabs" unchecked, Firefox keeps asking to save tabs

Firefox for Linux 32.0.

The option "warn me when closing multiple tabs" is disabled in my preferences, but every time I close many tabs Firefox request "Do you want Firefox saves your tabs for the next time."

I then check "do not ask next time", and when I restart the browser, the "warn me when closing multiple tabs" is always disabled, but still asking to save the tabs in Firefox.

Also, in my remarks: the browser.tabs.warnOnClose config displays "false".
However, Firefox does not seem to respect that.

So in fact, Firefox remembers my settings, but doing the opposite?

How can I get Firefox to respect the settings and disable this close tab warning message?

There are also these prefs:

  • browser.tabs.warnOnCloseOtherTabs
  • browser.showQuitWarning
  • browser.warnOnQuit

Tags: Firefox

Similar Questions

  • Firefox used bandwidth even if no other tabs are loading, or even with only a blank tabs

    Occur the slow browsing experience this couple of days,

    It uses all of the bandwidth, even if I close any tab and just a tab in white (and have to restart the browser for the departure of the bandwidth to normal).

    Browsing experience start normally, but after that I started watching some videos on Youtube, it starts late as hell, even if I close the Youtube videos (and it slows all the site browsing experience).
    I found out through the firewall log and check who.is on accessible IP are Google-owned.

    I tried to install the re - install, able and disabled, plugins already disable add-ons etc now I just my usual module for web development & games (that I installed along time and has not caused any problems)

    also tried about: config and set to false on the IPC, the problem happens again

    I google search and not found a solution, I hope it can be resolved here. (to compare, the navigation using chrome has no such problems)

    Update:

    -Now, it only downloads not only of google IP, also of AOL & my IP from the Internet Service provider

    -J' I scan my PC with COMODO antivirus & malware bytes before and after, the problem happens again

    -This is the IP than to access the 172.194.49.43, 111.94.248.80, 74.125.96.181, 74.125.96.144, 74.125.96.241, 74.125.96.136

    -The source that access intellectual property uses different port, at first he uses 80, now he's using the 58279 to 58283 port, such as 192.168.1.104:58279

    Have you tried a new profile?

  • Why has disappeared from my saved passwords, and now, even with private browsing, I can not Firefox to save passwords again. Care to help on that?

    The latest version of Firefox just loaded on my computer and all of my saved passwords previously disappeared. To top it off, I went the parameters of confidentiality and off the incognito in order to start saving my passwords again once and it will not save, it doesn't even give me the pop up to ask if I want to record. Care to help here? I am beyond angry right now, some of these passwords were pretty unique and I'm having a hard time recalling their exactly so don't not looking forward to having to reset the...

    You can force Firefox to re-import the file signons.sqlite passwords.

    • reset the signon.importedFromSqlite pref on the topic: config page by default via the context menu
    • Delete the logins.json file in the closed Firefox with Firefox profile folder

    When you restart Firefox, then you should have the pref signon.importedFromSqlite with the value set to true and you should have the passwords into password manager, unless he could have errors.

    You can use this button to go to the Firefox profile folder currently in use:

    You can open the topic: config page via the address bar.
    You can accept the warning and click on "I'll be careful" to continue.

  • I'm having a problem where Firefox keeps asking for my password to Amazon, even if I tell Firefox NOT to remember this password. In Firefox options, Amazon is clearly recognized as a site for which does not save passwords.

    I'm having a problem where Firefox keeps asking for my password to Amazon, even if I tell Firefox NOT to remember this password. In Firefox options, Amazon is clearly recognized as a site for which does not save passwords.

    Do not remove the navigation, search and download history on Firefox to clear the "Site preferences".

    Compensation of the "Site Preferences" clears all exceptions for cookies, images, windows pop up, installation of software and passwords.

  • By clicking on an icon home re - opens a lot of tabs from a previous session, even if I closed with "Exit and save" with only two legs

    For the comm.

    I'm a little frustrated. I had a session with maybe 20 open tabs. I closed the browser by selecting just "Quit". Whenever a new start, all these tabs open again. So - I delete them all and let two tabs open. My home page and my email page say. Then I left and select "Save and Quit".

    I start again - and all is well. Only two tabs there. I support on ^ T to open another tab. Do something and get tired of deicide both to display my home page in this tab - so I click on the Home icon below the menu bar - and guess what - all those f * k 20. tablets reappear remember all these ugly sites I looked at weeks.

    Can you please clean this behavior?

    Thank you

    I do not see that in the post - so I will add here:

    Version 3.8.6 on Windoz 7.

    Check your list of home pages, Firefox can store many home pages.

    How to set the home page

  • Firefox 4.0 than flash menus as a key on the keyboard is pressed. Can not access even with all the plugins turned off. Same issue on multiple machines with different versions of Windows. How this can be solved?

    FF 4.0. Flash menus such as a key is maintain pressed making it inaccessible. The problem persists with all the plugin disabled. Firefox box top left appears. The old logo FF show instead.

    Fact to uncheck use hardware acceleration helps in the Firefox menu > options then in the window of Options - Advanced tab > uncheck the box 'use hardware acceleration when available' stop the problem does not happen.

    Advanced panel - accessibility, navigation, network, updates, and other advanced settings in Firefox

  • Firefox browser opens with the same 9 tabs

    Win 7, 64 bit, dv8t laptop, latest version of firefox-

    What is happening recently started -

    When I open firefox, it opens with the 9 same tabs that I closed it with.

    I don't get the option that I used to get the next time firefox opening you want to reopen that browsing session?

    It just constantly reopens the same 9 tabs.

    I tried to uninstall and reinstall firefox. I tried to close each tab separately and then close window

    When there is just the last open tab...

    Any suggestions?
    Thank you

    Billy

    Hello

    You can save your bookmarks as follows.

    Launch Firefox, click bookmarks, click on "Show all bookmarks", click Import & backup in the toolbar and then click on Export HTML - choose a name for the file, select a destination and save this file.

    After you have completely uninstalled firefox and then reinstalled, click bookmarks, click on "Show all bookmarks", click Import & backup in the toolbar and then click Import HTML, navigate to the location of the file and click open to restore your bookmarks.

    Concerning

    DP-

  • Why Firefox always opens with the last session tabs?

    When I open firefox always opens with the last session tabs? How can I solve this problem?

    You can check if you have a user.js file in the Firefox profile folder that affects the pref browser.sessionstore.resume_session_once true value.

    The user.js file is present than if you or another software has created this file and normally it wouldn't be here.
    You can check its contents with a text editor (right click: 'Open with'; do not double-click).
    The user.js file is read whenever Firefox is started and initializes the preferences to the specified value in this file, so the preferences set via user.js can be changed temporarily for the current session.

    You can remove the user.js file if you do not create this file yourself.

    You can use this button to go to the Firefox profile folder currently in use:

    Windows hides certain default file extensions.
    Among them are .html, .ini and .js, .txt, so you can see only file name without the file extension.
    You can see the type of actual file (file extension) in the properties of the file via the context menu in Windows Explorer.

  • Why most of the tabs open empty with the label "New tab" and "topic: vacuum ' in the address line to the restart of Firefox since installing Firefox 28?"

    I have a system dual-bootable Windows Vista SP2 and Firefox updated to 28 on both systems. Since the update of the tabs more reopen empty with the label "New tab" and "topic: vacuum" in the address line of Firefox is restarted. The tabs that open correctly seem to be those who in fact, I was at the session of prefious. I can recover the missing tabs using the Session Manager to pick up a previous session, but of course it does not pick up the tabs open in future sessions. It seems that the tabs that I go to the session recovered are saved correctly, as indicated above, but which are not revisited in the context of the use of the session retrieved will drop the URL next time that I open Firefox it again.

    jdgale:

    I don't have the time to do it. However, 29 is just around the corner and we will put in the channel of exit 29, then hope that the issue is not you.

    P.S. I had originally chosen your last answer as the solution that you have migrated more to 29 but it seems that you have taken off. I'll be marking your last answer as the solution so that we can get out of the queue.

  • Is a version of Firefox that is compatible with a Samsung Galaxy Tab 3 to come forth?

    The Firefox for Android that is currently available is not compatible with my Samsung Galaxy Tab 3. Is there a new version in the works that would be compatible?

    Update:

    The mobile Firefox 26.0 published on 10 December and is on Google game now takes supported mobile chipsets Intel x 86. You don't need to test beta versions more in order to use Firefox on Intel as Galaxy Tab 3 tablets.

    https://blog.Mozilla.org/futurereleases/2013/12/10/Firefox-for-Android-optimized-for-devices-that-support-Intel-x86-chipsets/

  • Firefox crashes in typing or by clicking check box or the radio button, even with all the plugins / extensions removed. Check with many types of malware scanners.

    Firefox crashes in typing or by clicking check box or the radio button, even with all the plugins / extensions disabled, then deleted. Sometimes it hangs for five minutes. I checked the PC with several types of scanners of evil-ware, but none to be found. All hidden and deleted cookies, all DELETED & extension plugins. Remove all instances of Firefox PC and registry, then restored to bookmarks. The only thing that I did not is to remove and reinstall not my favorites.
    Windows Vista (yes I know) and FF 13.0.1

    Try disabling hardware acceleration in Firefox.

  • My laptop volume is very low, even with the maximum setting. It also has a very annoying echo

    I tried every setting available on this laptop, go all together if not try several changes in all settings. The volume is still low and has a very annoying reverberation and echo effect, even with these settings turned off. I got it for a week, and I was very happy with any other accept the audio. The reasons for buying this model were media processing and so far I have and become more disgusted daily with her. It is a Pavilion dv6 and it has beat audio software. If anyone has a solution, it would be much appreciated.

    Hello

    One thing that can help is the following.  Do a right-click the speaker icon in the taskbar and select "playback devices".  Left click the device once to highlight default (it is usually 'speakers and headphones') and then click the properties button.  Click the enhancements tab and put a check mark in the box "Loudness equalization.  Click on apply to save the changes and then click OK in all other windows and see if allowed at all.

    Kind regards

    DP - K

  • How to stay with a clear new tab and not the search page of Yahoo every time?

    Years, I used Firefox with claire of new tabs and achieved this in the menu Options, general tab, display an empty Page - and the next line, remains empty. This has always worked, so far. Today, each new tab navigation takes me directly to the Yahoo Search page, which I certainly don't want.

    So, still today, I then passed to the 'Search' tab (in the Options menu) and removed all search engines from the list, including the option checked "Yahoo." However, each new tab again takes me to a "Yahoo" search page

    How can I stop this now and forever?

    I look forward to your solution.

    Thanks a lot for your help, Mark.

    You can watch the pref browser.newtab.url the topic: config page and set this pref to the URL of your preferred the new tab page.

    • the new default tab with the tiles page is on: newtab
    • the default homepage is Subject: Home
    • to a blank page, you can use Subject: vacuum

    The pref browser.newtabpage.enabled must be set to true to use the page defined through browser.newtab.url like the new tab page.

    You can open the topic: config page via the address bar.
    You can accept the warning and click on "I'll be careful" to continue.

    See also;

  • Firefox keeps opening links and new tab

    During the navigation, if I long - click on a hyperlink and select "Open in new tab" in the menu that follows, even if it opens the tab it also follows the hyperlink in the source tab. How do you prevent to open the link in my active tab?

    Sorry, this seems to be a problem on some pages having the scripts associated with the links. Workaround in a previous thread (for Gizmodo) was to drag your finger down a line or two when the menu appears so that when you lift your finger is not on any link. See: https://support.mozilla.org/questions/1011061#answer-604851

  • FF31: When I only have a tab open, even empty and close the tab window closes.

    FF31: When I only have a tab open, even empty and close the tab window closes.

    Type of topic: config in the address bar and press enter.
    Accept the warning.

    browser.tabs.closeWindowWithLastTab

    Double click to switch to false and then restart Firefox.

    Now, if you close the last tab of that window (or Firefox) does not close, but a new tab will be there.

Maybe you are looking for