Firefox off telling me to upgrade to the new version of the flash plugin. I can't upgrade to the latest Adobe flash player 11, because it does not support Windows Vista 64-bit. So now what am I supposed to do?

I have Windows Vista 64-bit. I can not play online games on Pogo. I have already contacted Pogo & they have update me of flash player. Firefox disabled by the Flash plugin. I can't update Adobe flash player because it does not support 64-bit.

See:

Tags: Firefox

Similar Questions

Maybe you are looking for