How can I activate the zoom pinch after calling preventDefault();?

I created a chart in the edge animate which should work correctly on both the iPad and desktop computers. The html file that I create will be then fired in an iframe on a Web site as part of a larger page. I've included touch events and mouse for interactive elements, and most of the time it works fine on the desktop and iPads - except for when it is not.

I found in my tests that sometimes a mouseOver/mouseEnter or even a click event fires despite my use of the e.preventDefault (); in my events touchStart or touchstart (I tried both). The behavior is not coherent enough for me to determine why this is happening so I have a solution for the moment - I've added preventDefault(); to touchStart in document.compositionReady:

$(document) .one ('touchend', Function {}

e.preventDefault ();


I understand that this is not ideal, but with deadlines and all that noise, it's the best solution I found to this day.

It works perfectly, but as expected, it also disables the pinch zoom and pan. I don't care panoramic, but the zoom is necessary because the data points on the graph are on the small side. Can someone help me with the code, I would need to enable pinch zoom after call preventDefault()?: Or the conditional statement that would go preventDefault(); on a regular/single touch but not a pinch of touch zoom?

I use v2014.1.1 to edge host CC on a Windows 7 machine, if it is useful.

I cannot share my code because of the confidentiality agreement to my company, although if necessary I can probably model a simple sample - I'm hoping someone out there with more experience in the development of contact devices can point me in the right direction.

Thank you!!



This refurbished - Box version handles the events of iOS. See private message.

Tested: iPad (iOS 8.1.3) and MacBook (Mac OS 10.10.2) and Safari 8.0.3

I will post a final version to improve the change of color and the text box.

Tags: Edge Animate

Similar Questions

Maybe you are looking for