How to open a new tab and opens automatically to my homepage

When I open a new tab, it goes straight to the snapdo.com. How can I change this so when I opened a new tab it opens directly to google without having to type in, or clicking on a bookmark button?

There is a setting for new tabs...

(1) in a new tab, type or paste Subject: config in the address bar and press ENTER. Click on the button promising to be careful.

(2) in the search above the list box, type or paste newtab and make a pause so that the list is filtered

(3) double-click the preference browser.newtab.url and enter your favorite page:

  • (Default) page thumbnails = > subject: newtab
  • Blank tab = > subject: empty
  • Built-in Firefox homepage = > topic: welcome
  • Any other page = > full URL of the page

Note: when changing to Google, use a full URL ultimate as https://www.google.com/ - if you use a partial URL, there will be a few seconds while Google Firefox redirects this ultimate URL.

Press Ctrl + t to open a new tab and check that it worked. Fixed?

Two traps:

  • If Firefox ignores the setting, one of your extensions may be substitution of her. You can consult, disable and/or remove extensions on the addons page:

    Tools menu > Modules > in the left column click on Extensions
  • If the amendment works but at the next startup is back at Google, you might have a user.js file in your personal settings Firefox (your Firefox profile folder). This article describes how to track down and delete the file: How to fix preferences that will not save.

A little luck?

Tags: Firefox

Similar Questions

  • How can I open a new tab and enter automatically in the address bar and not in the Firefox search engine?

    When I open a new tab I see Google search smooth with large beautiful Firefox logo on the top center of research, and makes me automatically type in this research. Is there a way to automatically enter address bar when a new tab is opened? Just moved to Firefox and it's quite annoying.
    Thanks to all the advice.
    -Karl

    Looks like you have set browser.newtab.url to Subject: House which opens the default home page in each new tab. The simplest thing to do is to reset this preference so that instead of the new tab page:

    1. Type of topic: config in the address bar and press ENTER.
    2. To ignore the warning, press the big button "I'll be careful, I promise!
    3. In the search box, paste browser.newtab.url
    4. In the search results, click browser.newtab.url , and then choose reset.

    Otherwise,.

    1. Custom installation tab.

    2. Open the modules (Ctrl + Shift + A Manager; Mac: Command + shift + A), then the Extensions category.
    3. Next to the new custom label, click on the Options button.
    4. The value of any page you want to open in each new tab (topic: newtab is the value default; about: home is the default home page) and make sure that "Focus in the URL bar" is not checked.
  • How to stop multiple self-switching to the address bar every time I open a new tab and try typing something anywhere outside the address bar?

    How to stop multiple self-switching to the address bar every time I open a new tab and try typing something anywhere outside the address bar? As something just wants me to use this integrated search when you type something non-Web-address in the address bar and press to enter. And the most ridiculous thing is that happens repeatedly on as every second, as I just got off the address bar and start typing again, but still he passes me in the address bar, then 3, 4 times like that. And the result is that I don't see the address of this page.

    I think that its has something to do with my AVG Antivirus, because it started the same time a Nation AVG started to appear in each new tab I opened (and which is irritating as me, I've read here on support.mozilla.org and it seems that the only solution is to completely reinstall Firefox, but I don't want to lose all my settings) but when I type something in the address bar and press enter It opens the search results in Google.

    Please try to help me, I love Firefox but I have to switch to Chrome until I fix this.

    Thanks in advance

    First of all, please update Firefox 32. 22 is no longer support is not safe. So, let us know if you still have this problem. Update Firefox to the latest version

  • I am trying to download the free track of Photoshop CC. It will open a new tab and show places of loading spinning. Then they disappear and remains white. How to make it so I can download it?

    I am trying to download the free track of Photoshop CC. It will open a new tab and show places of loading spinning. Then they disappear and remains white. How to make it so I can download it?

    Please try using another web browser or deleting the browser history and cookies, then try again.

    Kind regards

    Hervé Khare

  • How can I get FF to open a web site in a new tab and keep the old tab so I can come and go?

    If I'm in a web site that contains other links, I want to be able to open the new link in a new tab and keep the original tab so I can switch back.

    When you click on a link that is on a right click of the Web page and click on "Open link in a new tab" this will open the new page in a new tab and keep your old tab open. If you want to open a new tab without clicking on a link on a web page, click on the button "+" near your tabs currently open.

  • right click on google for, open a new tab and switch to it immediately

    When I select a Word and choose in google for right click, firefox opens a new tab and switch to it immediately. I don't want firefox to go immediately to the tab I maybe other words to highlight and click on google search for it.

    so, how do you not move immediately to the tabs in firefox open the right click on google for? also as a note in my options on the tab firefox immediately switch to tab is disabled and I use the latest version.

    You can set the Boolean pref browser.search.context.loadInBackground true on the topic: config page.

  • How to set the new tab to open a homepage

    After the recent update to version 44.0.1 I lost the ability to open a new tab and open the new tab homepage. Someone can help me.

    Thank you

    Do you mean when you open a new tab, you want to see your regular home page instead of the page of the new integrated tab on Firefox?

    41 of Firefox is no longer uses the browser.newtab.url setting in about: config because he was constantly attacked by malware. From 41 of Firefox, you need an add-on to change the new tab page.

    Here are a few options (I'm learning more all the time):

    • If you are already using the "Restorer of classic theme" or "Tab Mix Plus" extension: There is an option somewhere (!) in his dialogues of the parameters to select another page in the new tab.

    Use only one of these methods at the same time, otherwise there may be conflicts and dysfunctions.

    Setting up substitute new tab and new tab custom

    After installing one of these extensions, you must use the Options page to set the new desired tab page (instead of use subject: config).

    Open the page modules using either:

    • CTRL + SHIFT + a (Mac: Cmd + shift + a)
    • "3-bar" menu button (or tools) > Add-ons

    In the left column, click Extensions. Then on the side right, find the new tab replace or custom new tab and click on the Options button. (See first screenshot attached).

    New tab Override

    Depending on the size of your screen, you may need to scroll down to enter the address in the form. (See second screenshot attached). For example:

    • (Default) page thumbnails = > subject: newtab
    • Blank tab = > subject: empty
    • Built-in Firefox homepage = > topic: welcome
    • Any other page = > full URL of the page

    Then tab or click this form field and you can test using Ctrl + t.

    Custom new tab

    It is easy to enter your favourite homepage address. If you check either of the boxes, the expansion will set the focus in the page as well, for example, the cursor will be in the Google search box. (See third screenshot attached). I had to leave Firefox and start it up again before new custom tab started working, but this may have been due to tests so many extensions back to back.

    Success?

  • Hi, I have a problem with FF, when I click on a google site, opening in a new tab and I don't want to, can you help me?

    Hi, I have a problem with FF, when I click on a google site, opening in a new tab and I don't want to, can you help me?

    Hello, this may be a preference in your google search parameters. go to google.com/preferences and disable the option to search results open in a new browser window.

  • Why most of the tabs open empty with the label "New tab" and "topic: vacuum ' in the address line to the restart of Firefox since installing Firefox 28?"

    I have a system dual-bootable Windows Vista SP2 and Firefox updated to 28 on both systems. Since the update of the tabs more reopen empty with the label "New tab" and "topic: vacuum" in the address line of Firefox is restarted. The tabs that open correctly seem to be those who in fact, I was at the session of prefious. I can recover the missing tabs using the Session Manager to pick up a previous session, but of course it does not pick up the tabs open in future sessions. It seems that the tabs that I go to the session recovered are saved correctly, as indicated above, but which are not revisited in the context of the use of the session retrieved will drop the URL next time that I open Firefox it again.

    jdgale:

    I don't have the time to do it. However, 29 is just around the corner and we will put in the channel of exit 29, then hope that the issue is not you.

    P.S. I had originally chosen your last answer as the solution that you have migrated more to 29 but it seems that you have taken off. I'll be marking your last answer as the solution so that we can get out of the queue.

  • Why you spend the "open in a new tab' and 'open in a new window' when you right click on a link?

    Why you spend the "open in a new tab' and 'open in a new window' when you right click on a link? This has happened with the latest version

    See also [/questions/791244? page = 2 #answer-161497]

  • I click on the new tab, and it does not open

    I click on the + to a new tab and nothing happens no new tab.

    Uninstall the toolbar Ask and it should work again. There is a compatibility issue with the Ask and Firefox toolbar that prevents the opening of new tabs.

    There are a few places to check for the Ask toolbar:

  • Why in the context menu of the "open in a new tab" and the "open in a new window" - buttons change of place? And you can change it back?

    With the Firefox 4 RC, the 'open in a new tab' and the 'open in a new window' - buttons have changed places. This is quite annoying because I normally do without looking, but now it always opens in a new window instead of a new tab. Is it possible to restore it? Perhaps in your own settings?

    You can use the menu editor extension to reorganize menu items - https://addons.mozilla.org/firefox/addon/menu-editor

  • There is a problem when I click on the tab '+' to 'open a new tab' nothing happens. It allows to open new tabs, and now it does nothing.

    There is a problem when I click on the tab '+' to 'open a new tab' nothing happens. It allows to open new tabs, and now it does nothing. Even when I go to 'File' and 'New tab' it still does nothing. The only time wherever I can get a new tab to open is if I go to 'Help' and click "Firefox Help" then opens a new tab with firefox help.

    Please disable or uninstall the extension "Ask Toolbar". He has a known compatibility issue with the latest update of Firefox.

  • How to stay with a clear new tab and not the search page of Yahoo every time?

    Years, I used Firefox with claire of new tabs and achieved this in the menu Options, general tab, display an empty Page - and the next line, remains empty. This has always worked, so far. Today, each new tab navigation takes me directly to the Yahoo Search page, which I certainly don't want.

    So, still today, I then passed to the 'Search' tab (in the Options menu) and removed all search engines from the list, including the option checked "Yahoo." However, each new tab again takes me to a "Yahoo" search page

    How can I stop this now and forever?

    I look forward to your solution.

    Thanks a lot for your help, Mark.

    You can watch the pref browser.newtab.url the topic: config page and set this pref to the URL of your preferred the new tab page.

    • the new default tab with the tiles page is on: newtab
    • the default homepage is Subject: Home
    • to a blank page, you can use Subject: vacuum

    The pref browser.newtabpage.enabled must be set to true to use the page defined through browser.newtab.url like the new tab page.

    You can open the topic: config page via the address bar.
    You can accept the warning and click on "I'll be careful" to continue.

    See also;

  • suddenly I'm asking as a new tab and not google search - driving me crazy

    Ask the home page is driving me crazy. I want my google search customary as that which opens when I press on the new tab. I was everywhere on the internet to try to fix this. nothing works.

    Since there are different options/settings of the standard page in a new window or a new tab, could you confirm if you have one or two of these problems:

    • Ask if poster at the start, in a new window (Cmd + n), and when you click the Home button
    • Ask appears when you open a new tab in the same window (Cmd + t)

    For these two problems, the first thing to check is an unwanted extension. You can view, disable and often remove the extensions on page modules. Either:

    • CMD + SHIFT + a (Windows: Ctrl + Shift + a)
    • "3-bar" menu button (or tools) > Add-ons

    In the left column, click Extensions. Then take a critical look at the extensions listed on the right side. If in doubt, disable or remove if possible. Remember that all extensions are optional, none come with Firefox.

    Often, a link will appear above at least an extension disabled to restart Firefox. You can complete your work on the tab and click one of the links in the last step.

    Which allows you to regain control of your homepage and view the standard Firefox new tab page?

    If so, here are the details on how to restore your preferred homepage:

    If you find that it works in your session (Cmd + n and give you good home page), but after leaving Firefox and commissioning once again you have bad home page, look for an optional settings file named user.js in your profile (personal settings folder) folder. Firefox uses the settings in this file at startup to override your preferences since the previous session. You can check and delete the file by following the steps in this article: How to fix preferences that will not save (there is a specific section on the user.js files).

    Display Google in a new tab page requires a different approach. From Firefox 41, the browser.newtab.url parameter is no longer used because it was constantly attacked by malware. Now, you need an add-on to change the new tab page.

    Here are a few options (I'm learning more all the time):

    • If you are already using the "Restorer of classic theme" or "Tab Mix Plus" extension: There is an option somewhere (!) in his dialogues of the parameters to select another page in the new tab.

    Use only one of these methods at the same time, otherwise there may be conflicts and dysfunctions.

    Setting up substitute new tab and new tab custom

    After installing one of these extensions, you must use the Options page to set the new desired tab page (instead of use subject: config).

    Open the page modules using either:

    • CTRL + SHIFT + a (Mac: Cmd + shift + a)
    • "3-bar" menu button (or tools) > Add-ons

    In the left column, click Extensions. Then on the side right, find the new tab replace or custom new tab and click on the Options button. (See first screenshot attached).

    New tab Override

    Depending on the size of your screen, you may need to scroll down to enter the address in the form. (See second screenshot attached). For example:

    • (Default) page thumbnails = > subject: newtab
    • Blank tab = > subject: empty
    • Built-in Firefox homepage = > topic: welcome
    • Any other page = > full URL of the page

    Then tab or click this form field and you can test using Ctrl + t.

    Custom new tab

    It is easy to enter your favourite homepage address. If you check either of the boxes, the expansion will set the focus in the page as well, for example, the cursor will be in the Google search box. (See third screenshot attached). I had to leave Firefox and start it up again before new custom tab started working, but this may have been due to tests so many extensions back to back.

    Success?

Maybe you are looking for