Switching problems

Hello

I wrote a simple code to execute test sequences and it works great except for the scenario when the user wants to cancel the test while sequence in the process.  I have tried several different methods to achieve this, but were not successful.

The desired effect when you push the Abort button is for the timer to be delivered to 0, the progress bar to be reset to 0 and the throttle to be reset to 0.  Structures of cases are not the method to use for what I'm trying to achieve?  Can anyone suggest a better way to do it?

Attached are the main VI 'hot test' and the Subvi "Throttle control.

Thank you

You can post your attempt of a state machine? An example of a state machine to the upper loop is attached. It is the file called machine.vi to the State, and is called by state machine demo.vi.

Take a look at the machine.vi State. The first thing you should notice is that this is a time loop with a constant real wired to stop. Is the loop will run for an iteration and will come out of the VI. If you look through the structure of the case, you will see that there is no wait function. The VI will run and immediately return but next time they call it he knows what State to go to. So if someone presses the button abandon so the next time that the VI is called it will be in the "completed" State This State defines your indicators to the way you want to and sets the next State to 'out '. In this way the appellant knows the end state of the execution machine.

The thing to keep in mind if you want a machine in order to be "abortable" in a short period of time is to make sure that you have no State that take a long time as far as possible.

I suggest you open the block machine.vi state diagram and turn on execution of climax. Then run the demo.vi of State machine. You should be able to understand what is happening.

I used a string for the State. Many people will use enums. Make sure that if you do use an enum you indicate a def type.

Tags: NI Software

Similar Questions

  • Language on macOS Sierra switch problem

    I just upgraded to macOS Sierra and I have a problem with switching languages.

    I have both English and Russian, but I just need to do the Cmd + space to more than an hour to change language and when I do, I can get the American icon in the status bar, but the language is passed to the Russia and vice versa.

    Any thoughts on how to solve this problem?

    Is this another discussion help:

    input source indicator does not

  • 2910al - 48G Switch: problem with the VLAN

    Hi all,

    I write a new message because I don't know what is happening on my SW series 2910al - 48G and v1910 - 48G.

    I put on the main core SW VLAN 610 and I put to this VLAN IP addreess 100.110.10.1 24-bit etc and it worked fine until yesterday. I change only PLEASE and I enebale STP - loop protect for ports in the range 1-52. (now I rolback this settings as was before)

    STP configuration

    Now, every PC that has for a long time what IP range 100.110.10.1 24-bit works fine, but new PC have problem with to get the new IP address. I tested it add a static and same address does not work.

    Introduced in second v1910 SW - 48 G VLAN as below

    I connect this flexible switch this \port SW 2910 - G 48, 46 (Vlan 610 tag) <>- at v1910-48G\ port 50 SW (Vlan 610 tahgged) other ports on this switch I put not marked.

    Configuration file for sw v1910 - 48G looks to below:

    #
    activate default domain system
    #
    LLDP enable

    #
    domain system
    disable the access limit
    Active state
    Disable Idle-cut
    self-service-url disable

    #
    rstp STP mode
    enable STP
    #
    NULL0 interface
    #
    GigabitEthernet1/0/1 interface
    hybrid type port link
    port hybrid vlan tagged 610 620
    untagged port hybrid vlan 1
    #
    interface GigabitEthernet1/0/2
    access port vlan 610
    #
    interface GigabitEthernet1/0/3
    access port vlan 610
    #
    interface GigabitEthernet1/0/4
    access port vlan 610
    #
    interface GigabitEthernet1/0/5
    access port vlan 610
    #
    interface GigabitEthernet1/0/6
    access port vlan 610
    #
    interface GigabitEthernet1/0/7
    access port vlan 610
    #
    interface GigabitEthernet1/0/8
    access port vlan 610
    #
    interface GigabitEthernet1/0/9
    access port vlan 610
    #
    interface GigabitEthernet1/0/10
    access port vlan 610
    #

    #
    interface GigabitEthernet1/0/49
    hybrid type port link
    port hybrid vlan tagged 610 620
    port hybrid vlan 1 10 untagged
    #
    interface GigabitEthernet1/0/50
    hybrid type port link
    port hybrid vlan tagged 610 620
    port hybrid vlan 1 10 untagged
    #
    interface GigabitEthernet1/0/51
    hybrid type port link
    port hybrid vlan tagged 610 620
    untagged port hybrid vlan 1
    #
    interface GigabitEthernet1/0/52
    hybrid type port link
    port hybrid vlan tagged 610 620
    untagged port hybrid vlan 1

    etc...

    Could you help me when I made a mistake?

    THX

    The problem was that solve this problem.

    I have blocked all ports. It was a problem. I change several settings and everything works well.

  • Equium A100-027 - switch problem ON / OFF wireless

    Hi all

    This problem has been irritates me for some time...

    I've literally just installed MCE 2005 after removing the Vista OS and I ve installed all drivers except for the purposes of ConfigFree.
    I noticed that the switch to turn on/off my wireless card now does not, because it allows me to scan/connect to networks, even when it is in the off position, with the led does not illuminate.

    When I ran before ConfigFree, I noticed that switch was correct entry in the application, but I still couldn't windows to disable the wireless adapter once I turned off.

    I played around with shortcut keys and I ve you press FN + F8 (the symbol wireless) and I've made countless times, but have had no result.
    If anyone knows what is the problem?

    Thank you very much

    Matt

    Great info!

    I noticed that most of the WiFi problems can be solved by upgrading the WLan driver.

    Thanks again for this useful detail!

  • LAN N450 connection through a switch problem

    I replaced my router from Time Warner Ubee with a Netgear N450. I have 2 desktop computers and TV and PS3 in my basement that is connected to a Netgear GS108 switch 8 gigabit ports. Everything worked fine until I swapped the router. All my wireless devices work and the office in our head office that is connected directly to the N450 work. A desktop running Win XP Pro, the other works under Win 7. I don't get "LAN was not a valid IP configuration errors. I rebooted everything, turn off DHCP and tried to manually enter the IP information, power off the pc from the wall outlet, etc. and spent several hours on researching this issue. Any ideas would be useful.

    Problem solved. I brought the Win 7 PC upstairs and connected directly to the router. The PC immediately recognised and connected to my home network. Then, in order to eliminate potential problems with the switch itself or wiring, I brought the upstairs switch and connected between the router and the PC Win 7. Same results as above - connected to the network home and Internet. Took everything back down and voila - both PC is now successfully connected to the host and the internet using DHCP network automatically. Not sure why it worked. I went through this simple process to diagnose potential hardware issues.

  • HP pavilion dm4: removing the battery / output switch problem

    MY hp dm4 Clubhouse has a switch relese battery does not move and so I can't remove the battery.

    What can I do to take out the battery?

    I was able to remove my battery, even if the trigger will not move

    I have read the documents under the next heading

    "Laptop battery seems to be stuck.

    He pointed out that my problem was very common

    BATTERY REMOVAL PROCEDURE

    As suggested-

    I inserted a piece of thin stiff plastic

    (for example on the size of a credit card but a little thinner)

    in the crack between the battery and the output switch

    I pushed the upper part of the plastic down

    and then I pushed up in the direction of the battery

    up until the crack of batttery widened to the point where I could use

    my nails in the battery of crack to pull the battery.

    I don't have to much force to make

    The angled battery to easily

    BATTERY INSERTION PROCEDURE

    As suggested-

    To avoid the problem of gel battery switch

    Move the latch of the battery in the middle of its sliding range

    When reinserting the battery first tilting the battery

    so that the side of the battery to the side of the computer case

    is first inserted into the battery compartment

    Then push down the other side of the battery in its compartment

    in the end, release the battery button while he spingngs to its normal resting position.

    I hope that this explanation is useful

  • Router RV130W + SG92 - 24 Switch problems

    Hey Cisco community,

    I just finished wiring a small office with LAN and connected 24 / SG92. I double checked CAT5 connections with a cable Tester and there is no problem. The wireless is connected to the internet and works fine, however if I try to use a cat5 connection in one of the LAN ports it doesn't seem to work, I get the connection to the router (I can acess 192.168.1.1) but I can't connect to internet through it, am I missing something? If the wireless works very well so in theory the LAN should work too, Ive tried to connect directly to the router and still no luck.

    Current configuration:

    Modem-> router RV130W-of SG92 - 24 Switch-> desktop computers >

    Hope I can fix this problem quickly

    Tim

    can you do ping google.com or any Web site?
    If it is resolved, there must be something wrong with your computer

    Also, as far as I know an RV is also a decent firewall?
    Make sure your policy it allows HTTP, HTTPS, DNS and optionally, ICMP to ping test

  • FI6248 FC connectivity with MDS SAN switches problem

    Hello

    We have two FI6248 in a cluster must be connected to two MDS SAN switches, using FC ports.

    However, I am not able to configure the ports on the FI.

    There is no "Set up as FC storage Port" option. I don't see what "configure as FCoE storage Port."

    I have the FC SFP (DS-SFP-FC8G - SW--> 8 Gbps Fibre Channel SW SFP +, LC) installed on the two FI6248 on the first 16 ports.

    No idea what is the problem?

    Kind regards

    The 6248UP unified ports.  The ports can be configured as Ethernet Ports or FC ports.  By default, all ports are of type Ethernet.  The ports that you configure is currently an Ethernet port.  You need config of the ports as FC ports.  Ethernet ports will be on the left side of your FI and FC ports will be on the right side.

    The following link explains how to convert a port UP Ethernet CF.  Since it's on your FI and not a plug-in, you have to restart the FI in last step.

    Configuration of the Port Modes for a fabric interconnect 6248

    http://www.Cisco.com/en/us/docs/unified_computing/UCS/SW/GUI/config/Guide/2.0/b_UCSM_GUI_Configuration_Guide_2_0_chapter_0101.html#task_3161F8BE44DA49F6BA9068A5D7594A6C

    Thank you

    Responsible Dan

    Need help with implementation?

    http://www.Cisco.com/go/pdihelpdesk

  • Switchport access and trunk on Layer 3 switch problems

    Hi all

    I was building a network design just for practice and I came across a problem that I didn't understand. Can someone please help. I have attached a picture to clarify things.

    Please let me know if you need information to answer my question. Thank you

    Francis

    Yes the router on a stick. However only vlan 100 is necessary because you have between multilayer switch and router ospf.

    Please don't forget to rate and select the correct answer

  • SelectOneChoice show the correct value with switching problem

    Hello

    I use JDeveloper 11.1.1.5.0 and I have a non-trivial application of SelectOneChoice.

    Here's my usecase:

    I have to show LOV to set the State according to the connected person.

    So, I implemented attribute LOVs view that each filtered for in the light of the type of person (owner or non-owner).

    I created switcher LOV for attribute as java method in module impl invoked by EL expression adf.source.getApplicationModule () .getTaskStateLOVSwitcher (adf.object, CreatedByIdFk);

    to get connected user binded query parameter id.

    public static String getTaskStateLOVSwitcher (ViewRowImpl, String createdById, time stamp dateInsert vri) {}
    ViewObject vo = vri.getApplicationModule () .findViewObject ("TaskViewParTaskTypeIdEx1");
    String userId = getBindValue (vo, "BindProcessedByUserId") m:System.NET.SocketAddress.ToString ();
    Output string;
    If (createdById.trim () .equals (userId)) {}
    output = "LOV_TaskStateIdFkOwner";
    } else
    output = "LOV_TaskStateIdFkNotOwner";
    return output;
    }

    I've used this many fragments of jsff perspective.

    There are fragments where it works fine (but I still don't understand why the switch method is called 3 times)

    And there are fragments where it fails. When there are two lines with different LOV to show SelectOneChoice shows an incorrect value.

    I can see the newspaper that LOV switcher method is called 6 or more times and first 3 times it works with values previously selected line and next time, it runs with the current line.

    He result is SelectOneChoice sets the value of the line previously selected in the first round and goes the LOV index.

    I found in the < getViewPort > ADFc log < ControllerState > message: no port view found ID...

    Is the source of the problem and what is the solution?

    Thank you.

    After eliminating all the differences between 'good' and 'bad' fragments I found a problem in the fragments of masters who defined a real line of iterator.

    Define RangeSize = 10 (not 25) table completely setting to change this behavior in common sense.

  • vCenter Migration and vDistributed switch problem

    Hi all

    I spend vcenter box intel AMD box. So this means that I won't be able to vmotion right?

    In this sense, I installed a new server vcenter on AMD box and added ESX servers one by one on the new vcenter server except those relating to the vDistributed switch.

    .

    I had problems with vDistributed switch cause if I try to remove a server from the cluster HA, vcenter gives an error because it has connection with the vDistributed switch.

    Please let me know how could remove the old vcenter servers and add new server vcenter.

    Thank you!

    Maybe the article will be useful

    http://KB.VMware.com/kb/1029498

  • Builder and switch problem?

    / * Okay guys .my problem is there are a 3 cases of first and second case I get entries and in the third and fourth cases I need to call a method that is in another class .this method does some calculations that must both user values enter in first case and 2 e case

    My problem is how I'm going to call my constructor in third case.if I say (it's not logic so) investmentM = new investments (principal, interestRate); I usually calculate correctly.well I found a way of my method to calculate the result correctly but at that moment, when I turn back on the menu at this time, he reset the values and mess up everything.if I get all values in a case its ok but I need to get them from case 1 and case 2.
    in case 3 and case 4 I just did up to these manufacturer it may give you an idea what my problem is.i stuck there.do you guys have an idea of what could be the solution?

    Thank you.
    */
    switch(choice)
              {
    case 1:
                   double principal=1.0;
                   double interestRate=0.1;
                   Investment investmentM;
                   
                   
              System.out.print("Please enter the starting balance : ");
              principal=sr.nextDouble();
              System.out.print("Please enter the interest rate : ");
              interestRate=sr.nextDouble();
              System.out.print("\n");
              
              investmentM.setPrincipal(principal);
              investmentM.setInterestRate(interestRate);
              investmentM=new Investment(principal,interestRate);
               
                    
              
              
              
              break;
              case 2:
                   int    numberOfYears=1;
                   int    numberOfTimes=1;
              
                   System.out.print("Please enter the number of years : ");
                   numberOfYears=sr.nextInt();
                   System.out.print("Please enter the number of times : ");
                   numberOfTimes=sr.nextInt();
                   
                   Investment investmentA;
    
                   investmentA=new Investment(numberOfYears,numberOfTimes);
                   investmentA.setNumberOfYears(numberOfYears);
                   investmentA.setNumberOfTimes(numberOfTimes); 
                   
              
              case 3:
                   
                   Investment fi=new Investment(principal,interestRate,numberOfYears,numberOfTimes);
                   
                   investmentA.getFutureValueMontly();
    menu();
    break;
    case 4:
                   Investment f=new Investment(principal,interestRate,numberOfYears,numberOfTimes);
                   
                   fi.getFutureValueAnnual();
    
                   
              break;
    }

    878144 wrote:
    My problem is how I'm going to call my constructor in third case.if I say (it's not logic so) investmentM = new investments (principal, interestRate); I usually calculate correctly.well I found a way of my method to calculate the result correctly but at that moment, when I turn back on the menu at this time, he reset the values and mess up everything.if I get all values in a case its ok but I need to get them from case 1 and case 2.
    .. do you guys have any idea of what could be the solution?

    Yes: Do not use a switch statement to control this. It is clearly a sequential process, so force the user to enter the values first, and then ask them what they want to do with them.

    I would also break this process in steps to methods, but this has more to do with style.

    Winston

  • Radio satellite 1135-S1552 switch problem

    I need to know how to activate my Radio switch.

    I installed a mini-PCI Intel 2200 wireless card on my laptop, and all the hardware drivers are recognized by the computer.

    There is a switch on the left side of the laptop that is for radio, but without function. Turn it on, or turn OFF, does NOTHING. There are no LED lights that lights up when activated.

    In addition, in Device Manager, I am able to open my Intel 2200 and in the Advanced tab properties, there is an option to disable/enable the Radeo switch, but when I click it, it says: "this didn't come into force if the power button on the adapter is turned."

    HOW TO MOVE THE ADAPTER?

    Help, please.

    Ted

    Hello

    you have installed a piece of origin option Toshiba or did you buy a 3rd Wifi card part of any provider?

    Finally do you have something set wrong? Have you used a manual? Perhaps you forgot to plug in a connection?

    Theo75 Bye

  • T61: cover and non-functioning lights switch problem

    My T61 (type 6465) is coming for three years and has recently developed some minor but annoying flaws. The main problem is that the most reliable laptop will remain suspended: closing the lid does not have to be suspended in the first place and if I use Fn + F4 to suspend, it seems that clutching the back edge of the laptop (that you could do to pick it up and put it in a bag) cause him back on the suspension. Accordingly, I found the cell phone on when you remove it from my backpack, even if I was sure that I had hung before storing.

    The other symptoms, is that some of the green lights have stopped working. Namely, the green lights of power, battery, caps lock num and caps lock seem to have stopped running, but wireless, hard drive and activity to suspend lights continues to work. In addition, the orange battery light works very well.

    Other that the system continues to work perfectly: the battery is still good and maintain the load, the power supply charges the battery and powers the system properly. Power management applications show the correct information about the power status of the system (i.e. on current AC or battery-operated).

    I try to work if this is likely to be a hardware failure or a software problem initially. Has anyone seem to similar symptoms, or may suggest that the problem could be based on my description?

    See you soon,.

    -Mark.

    non-functioning lights is most likely a hardware problem.

  • WLC4402 - switch problem

    Hello, Im new in the wireless. IM want to connect AIR-WLC4402-25-K9 in my lab with switch cisco 3560. WLC I have two 1000Base-T RJ-45 ports connected to GigE

    switch Cisco 3560 (FastEthernet). WLC I LAG activated interface an ap - manager in the same network as the interface of the Manager. I have two FastEthernet with configuration switch cisco 3560:

    interface FastEthernet0/1

    switchport trunk encapsulation dot1q

    switchport trunk allowed vlan 3,10,40,70

    switchport mode trunk

    Speed 100

    full duplex

    channel-group mode 5 on

    interface FastEthernet0/2

    switchport trunk encapsulation dot1q

    switchport trunk allowed vlan 3,10,40,70

    switchport mode trunk

    Speed 100

    full duplex

    channel-group mode 5 on

    Interface Port-channel5

    switchport trunk encapsulation dot1q

    switchport trunk allowed vlan 3,10,40,70

    switchport mode trunk

    but on my WLC I status link down:

    Cisco controller) > show port summary

    STP Admin physical physical link link Mcast

    Type of PR Stat Mode Mode trap POE device status

    -- ------- ---- ------- ---------- ---------- ------ ------- --------- -------

    1 normal Disa down Auto Enable enable Enable n/a

    2 normal Disa Enable Auto down Activate activate s/o

    Please help, how to establish a connection between the switch and WLC.

    Nesha cordially

    Unfortunately, FastEthernet is not an option with the WLC4400s. They require 1000/Full interfaces or they will not come to the top. You must connect the WLC gigabit interfaces.

  • RMAN switch problem.

    Hi guys, I use a CAR with 2 nodes, Oracle Database 10 g Enterprise Edition Release 10.2.0.5.0 with Linux [a test environment].
    I train in RMAN situations... I was using the comand of switch.
    I did this:
    RUN {
    BACKUP DATAFILE 77;
    SQL 'ALTER TABLESPACE NOVO_TBS OFFLINE';
    SET NEWNAME FOR DATAFILE 77 TO '/u01/backup/rman/teste/dfile77_novotbs.abc'
    RESTORE DATAFILE 77;
    SWITCH DATAFILE 77;
    RECOVER DATAFILE 77;
    SQL 'ALTER TABLESPACE NOVO_TBS ONLINE'
    }
    It worked, the data file left ASM to the file system.
    I've done some DML statements in the segments of this data file, and it worked as expected.

    Later, another person tried to do a select dba_tablespaces and got this error:
    ORA-01157: cannot identify/lock data file 77 - see DBWR trace file
    ORA-01110: data file 77: ' / u01/backup/rman/teste/dfile77_novotbs.abc'

    Then, I tried in my machine and it is so.
    I know that I could put this data file offline and kept operating normally or even upgrade the data file to ASM [works].

    But I want to test it on the file system.

    I checked it on the rman:
    rman target /
    report schema;
    List of permanent data files
    ===========================
    Size (MB) Tablespace RB segs Datafile file name
    75 10 BRUNO * +DATA/atrac/datafile/bruno.335.780773973
    77 100 NOVO_TBS * /u01/backup/rman/teste/dfile77_novotbs.abc
    78 1000 SYSTEM * +DATA/atrac/datafile/system.338.783883557

    Anyone know the reason?

    Thanks in advance.

    Best regards.

    Published by: BSalesRashid on 12/14/2012 11:52

    Hi Bruno.
    Forget the semaphores and file descriptors for now.
    I suppose that when you move the file to the ASM files/u01 system you can only see on Atrac1 or Atrac2 but not on both (Please also check the timstamp of the file).
    RAC to your data files on the cluster file systems so that both instances can read and update files.
    Kind regards
    Tycho

Maybe you are looking for