Why AE distributes incorrect DNS

I have the latest Airport Extreme the latest version of the software running.  My AE is set to do the routing for my local network.  Then I have a modem/DSL router that is configured in Bridge mode that goes for my AE.  When devices connect to my network via DHCP, EI gave them an address.  But the DNS number, he gives them is the address of route it (192.168.2.1).  Thus, when devices try to access the internet, they can get.  In the configuration of EI, I have two DNS numbers provided by my ISP.  It seems that it should provide these numbers for connected devices.  A connection device, I can go and manually change the DNS to one of the two figures provided by my ISP and this device can then access the internet very well.  So, how can I get EI to distribute DNS suitable for devices to connect to my local network.  Any help would be greatly appreciated.

Advertisement

If your LAN access point is really in bridge mode, then the DHCP service that is provided by the ISP should provide appropriate directly to your AirPort Extreme base station 802.11ac IP addresses. Of course, I guess that the extreme is in its default configuration, which is a DHCP client.

AirPort Utility, select the extreme. What are the values for: IP address and LAN IP address in the pop-up window? Note: Do not actually send the IP addresses, it is enough to note. The IP address must NOT start with 10, 172 or 192. The LAN IP address must be: 10.0.1.1. Are these two true in your case?

Tags: Wireless

Similar Questions

  • Why host program accesses DNS server

    I used the communication wizard to generate the TCL, NPL and HOST part. I'm behind a VPN router that I can disconnect from the outside world. The RT and the HOST system are connected to the VPN. I can start the RT part (TCL &)
    NPL) host through the interface Project RT. But, when I try to start the part host and internet is busy, I have a second 6-8 downtime (a break from any activity on the host computer). The loop of the HOST is a one shot which goes on in an another VI. So the possibility of a break gets greater. The break is always there if I disconnect the VPN from the outside world. Error message "Waiting for motor RT to respond ', which will expire after 6 to 8 seconds and displayed data. On one of the forums, said that host go to 192.168.1.1 and 127.0.0.1 by using the DNS lookup. Why is there a DNS lookup?
    Passing the address of the VPN gateway is 192.168.1.1. The glass by pulling the process cannot afford 6-8 second delay. Is there a solution? Attached file cannot be completed.

    Thanks for your help.

    Thomas Szebenyi
    Research technician
    Cornell University

    By the intermediary of Trey B. or support:

    "I think the DNS lookup occurs because the Phar Lap ETS OS on the PC in real time like to reverse things search DNS that communicate with him."
    You say that your IP addresses are fixed/static.  Have you tried filling 0.0.0.0 for the RT target?  You can do this in MAX under remote systems, as seen in the attachment.

    If you use the TCP screws, you can force the operating system not to solve the remote addresses, as shown here:

    http://digital.NI.com/public.nsf/allkb/011F5615859F5694862572580080C501?OpenDocument ".

    I put the DNS and gateway on the RT to 0.0.0.0 and most (99%) to hang it to the top has disappeared. even with ethernet to the outside world disconnected. The host has still some crash (ie. something tries to access the Ethernet (call)). What I still have to study.

    Thanks for your help

    Tom

  • How to purge incorrect DNS names in Apple Remote Desktop Version 3.8 (A 380, 95)

    Environment: Community College, Microsoft DHCP 2012/DDNS network

    Question:

    I've got ~ 140 iMacs with 13% to appear in my Apple Remote Desktop (ARD) scans as having correspondence name vs DNS name of the network.

    I suspect this affects refusal to license for our products Adobe CC. How can I clear the fields name DNS ARD again be filled properly?

    Hi gwanupnorth,

    After checking with file-> Refresh in ARD Admin and there are still agents machine correct without DNS:

    -Check in the list of the scanners of ARD Admin, if the machines of 18 or more are detected it with the correct DNS name.

    -If Yes, click on each one and update the username: password: and it should update the corresponding entry in all computers.

    HTH,

    Cheers, dwbrecovery

  • Why am I messages DNS error since upgrading to El Capitan?

    Since I upgraded my OS to El Capitan I was making (Yahoo Search page) DNS error pages when I use an Internet link to leave my email to another site. Its pretty boring and I have to use Safari where it happens. I like FireFox, but if I can't solve this problem I will be forced to stop using it. Help, please. Thank you, Michael.

    You might have installed something more. On Mac, this problem is associated with some extensions Spigot, especially one named Searchme.

    Open the page modules using either:

    • CMD + SHIFT + a
    • "3-bar" menu button (or tools) > Add-ons

    In the left column, click Extensions. Then on the side right, remove or disable Searchme - and anything else that you don't need, like all the other Spigot/MyBrowserBar extensions. Keep in mind that all extensions are optional and none is included with Firefox when you get it first.

    Often, a link will appear above at least an extension disabled to restart Firefox. You can complete your work on the tab and click one of the links in the last step.

    Is that what helps you regain control?

    This could be the tip of an iceberg of malware. When you install free software, you often get the options grouped under silence. I don't know the best way to 'clean up' a Mac of these elements, but you may want to consider the issue.

  • Why is the incorrect page layout?

    My page appears perfect (three lines in three columns) on my desk and a cell phone and Dreamweaver all previews: HERE

    But on my laptop, the layout looks like this (no matter the magnification of screen.)  No matter what < div > copy and paste, it pushes everything out of this second line first column.2016-07-10 (2).png

    Thanks for any help!

    Because the first frame contains more text than the two following a line, the fourth image will take the place that is closest to the top of the page.

    Out of this is to create columns of same height according to the Bootstrap 3 sensitive same height columns · Minimit or equal height columns Bootstrap example

  • You try to reset iPad mini, but it keeps saying incorrect password, the password that I use has never been changed, is there a default one?

    You try to reset ipad mini, but it keeps saying incorrect password, I have not changed my password so can't understand why it says incorrect sound, is it a defect or something?

    If you did not, then someone else (who also knew the access code).   Or there is a kind of corruption of the aircraft at low altitude.  Article in support of Apple on the forgotten passwords This usually medium-sized States a reset of the device and a backup restore - anything on the device that is not already been saved will be lost.

  • EA6500 - devices get weird IPs and DNS servers

    Hi all

    I have just installed, updated firmware, but even if many problems have arisen, let me please you the list of people:

    (1) cable devices get weird IPs, the printer for instange to 10.168.122.100 always, it happens THAT the devices wired; the QNAP server had once 192.168.100.100, when it happens that of course devices do not appear on the network.
    My understanding is that all devices, related or not, must get the IPs between 192.168.1.100 and 155, it is the default value for the same router;

    (2) my laptop when telegraphed Gets an appropriate IP (192.168.1.xxxx), but STILL Gets a number of strange DNS, 10.168.122.1 server, and the Internet becomes unstable. It only happens in wireframe, when in the wireless, it gets the number of server DNS the same number of IP from the router (192.168.1.1), and the wifi works perfectly. Why get this strange DNS server number in wireframe only?

    (3) my phone VOIP Comwave gets no IP address at all, I tried everything (disconnect, repluigging each device in waiting 5 minutes etc.), nothing worked. She always returns 0.0.0.0

    (4) I tried both Open DNS numbers, and also numbers of DNS of Norton, as well to go through them but IP of the router always appear as a third option.

    Please, does anyone know what is happening?

    Thank you very much

    Mongao

    Hello world

    Thank you for helping; in fact, I think that I understand the question... I'm the one to blame!

    I had connected the LAN terminal VOIP to the router, not the correct terminal WAN; so I think that VOIP box polluted network transmission inside the weird IP numbers; shame on me

    I quickly tested last night and it seems that it works properly now;

    I do not have the issue of the third DNS number (the same as IP routers) appearing in all my devices, even after turning the pair of numbers to OpenDNS in the EA6500;

    Thank you very much

    Mongao

  • Cisco 877W DHCP does not automatically fill the Windows/Mac customers with DNS server entries

    I have a 877W which was operational on Verizon for about 5 years. It never automatically distributed info DNS server for customers who get DHCP issued IP address. I have to manually enter the DNS entries to each client.  What happened to other sites where I've got installed on AT & T as well as 877 unified communications.

    Here is the config. Thanks in advance for the help.

    Building configuration...

    Current configuration: 7987 bytes
    !
    version 12.4
    no service button
    tcp KeepAlive-component snap-in service
    a tcp-KeepAlive-quick service
    horodateurs service debug datetime localtime show-timezone msec
    Log service timestamps datetime localtime show-timezone msec
    encryption password service
    sequence numbers service
    !
    Cod of hostname
    !
    boot-start-marker
    boot-end-marker
    !
    logging buffered debugging 51200
    recording console critical
    enable secret 5 jSwA $1$ $ 3B5lJNqm0ewh
    !
    AAA new-model
    !
    !
    AAA authentication local-to-remote login
    local remote of the AAA authorization network
    !
    AAA - the id of the joint session
    !
    resources policy
    !
    PCTime-6 timezone clock
    PCTime of summer time clock day April 6, 2003 02:00 October 26, 2003 02:00
    IP subnet zero
    IP cef
    No dhcp use connected vrf ip
    DHCP excluded-address IP 192.168.7.1 192.168.7.19
    DHCP excluded-address IP 192.168.7.70 192.168.7.254
    !
    IP dhcp pool sdm-pool1
    import all
    network 192.168.7.0 255.255.255.0
    router by default - 192.168.7.1
    DNS-server 68.238.96.12 68.238.112.12
    !
    !
    inspect the IP name DEFAULT100 cuseeme
    inspect the IP name DEFAULT100 ftp
    inspect the IP h323 DEFAULT100 name
    inspect the IP icmp DEFAULT100 name
    inspect the IP name DEFAULT100 netshow
    inspect the IP rcmd DEFAULT100 name
    inspect the IP name DEFAULT100 realaudio
    inspect the name DEFAULT100 rtsp IP
    inspect the IP name DEFAULT100 esmtp
    inspect the IP name DEFAULT100 sqlnet
    inspect the name DEFAULT100 streamworks IP
    inspect the name DEFAULT100 tftp IP
    inspect the tcp IP DEFAULT100 name
    inspect the IP udp DEFAULT100 name
    inspect the name DEFAULT100 vdolive IP
    synwait-time of tcp IP 10
    IP domain name cods.com
    name of the IP-server 68.238.96.12
    name of the IP-server 68.238.112.12
    property intellectual ssh time 60
    property intellectual ssh authentication-2 retries
    !
    !
    Crypto pki trustpoint TP-self-signed-437228204
    enrollment selfsigned
    name of the object cn = IOS - Self - signed - certificate - 437228204
    revocation checking no
    rsakeypair TP-self-signed-437228204
    !
    !
    TP-self-signed-437228204 crypto pki certificate chain
    certificate self-signed 01
    30820254 308201BD A0030201 02992101 300 D 0609 2A 864886 F70D0101 04050030
    2 060355 04031325 494F532D 53656 C 66 2 AND 536967 6E65642D 43657274 30312E30
    69666963 34333732 32383230 34301E17 303731 30313632 33333131 0D 6174652D
    395A170D 2E302C06 1325494F 03550403 32303031 30313030 30303030 5A 303031
    532D 5365 6C662D53 69676E65 4365 72746966 69636174 652 3433 37323238 642D
    06092A 86 4886F70D 01010105 32303430 819F300D 00308189 02818100 0003818D
    BF73E16C 24A3FB0B A44C83C8 45ACEC75 163C2F0A 87836F7F A43FEB72 0EF26AFA
    C7F35ED6 CBCC6853 5E82B0A6 1FD8020B F3630023 AB30B870 B3155EE6 86988910
    4ACF5121 1CBFF4DC B705DF1E 5D0D698F 06493 D 3DD8D036 42 FE450D21 E26A4DAF
    CE6BA806 81A9F451 0246698E DA7B49E3 160F115C E1104FA9 31FA3C15 CD 782 279
    02030100 01A37E30 7C300F06 03551 D 13 0101FF04 05300301 01FF3029 0603551D
    20821E63 11042230 6F64732E 6F666472 63697479 6E677370 69707069 72696E67
    732E636F 6D301F06 23 04183016 24 D 77493 80142FA3 03551D 52CF7094 B847B6EB
    1385E2E5 0F3A301D 0603551D 0E041604 142FA324 D7749352 CF7094B8 47B6EB13
    85E2E50F 3A300D06 092 HAS 8648 01040500 03818100 076EE499 12F46D79 86F70D01
    375B7EA6 C9279DA4 B32723B5 908C9FB8 D42CB978 BB24A8FE 73579A3D CA 5130, 87
    B7716644 7E13710D C6E6360C D0A36F7B F62540E2 0C33523B E50396B9 2EF66FA7
    56519E62 E55EAF3C E1D9BEC9 3AE67B59 75E61F06 B649E90A 2798F755 7A020F0A
    F8BDABFA 1EE37B6A A918560D DA45AD70 801BC66E 94D1468E
    quit smoking
    username privilege 15 secret $5 [email protected]#l4yTtLtYoEZbh/Wl steal551.
    !
    !
    door-key crypto vpn_ddaus
    pre-shared key address 0.0.0.0 0.0.0.0 - key stealthfortyfor5
    door-key crypto vpn_rmlfk
    address of pre-shared-key 205.30.134.22 key stealthfortyfor5
    !
    crypto ISAKMP policy 10
    md5 hash
    preshared authentication
    Group 2
    !
    crypto ISAKMP policy 30
    BA 3des
    preshared authentication
    Group 2
    invalid-spi-recovery crypto ISAKMP
    ISAKMP crypto keepalive 20
    !
    Configuration group isakmp crypto VPNRemote client
    key ConnectNow45
    pool ippool
    ISAKMP crypto vpnclient profile
    VPNRemote identity group match
    client authentication list for / remote
    Remote ISAKMP authorization list
    client configuration address respond
    Crypto isakmp CODS_DDAUS profile
    key ring vpn_ddaus
    function identity address 0.0.0.0
    Crypto isakmp CODS_RMLFK profile
    key ring vpn_rmlfk
    function identity address 205.30.134.22 255.255.255.255
    !
    !
    Crypto ipsec transform-set esp-3des esp-sha-hmac RIGHT
    !
    Crypto-map dynamic dynmap 10
    Set transform-set RIGHT
    vpnclient Set isakmp-profile
    Crypto-map dynamic dynmap 12
    Set transform-set RIGHT
    CODS_DDAUS Set isakmp-profile
    !
    !
    MYmap 1 ipsec-isakmp crypto map
    defined by peer 205.30.134.22
    Set transform-set RIGHT
    CODS_RMLFK Set isakmp-profile
    match address CODS_to_RMFLK
    map mymap 65535-isakmp ipsec crypto dynamic dynmap
    !
    Bridge IRB
    !
    !
    interface Loopback10
    IP 1.1.1.1 255.255.255.0
    !
    ATM0 interface
    no ip address
    route IP cache flow
    No atm ilmi-keepalive
    DSL-automatic operation mode
    !
    point-to-point interface ATM0.1
    Description $FW_OUTSIDE$ $ES_WAN$
    Check IP unicast reverse path
    inspect the DEFAULT100 over IP
    NAT outside IP
    IP virtual-reassembly
    PVC 0/35
    aal5snap encapsulation
    !
    Bridge-Group 2
    !
    interface FastEthernet0
    !
    interface FastEthernet1
    !
    interface FastEthernet2
    !
    interface FastEthernet3
    !
    interface Dot11Radio0
    no ip address
    no ip-cache cef route
    no ip route cache
    !
    encryption vlan 1 tkip encryption mode
    !
    SSID tsunami
    VLAN 1
    open authentication
    authentication wpa key management
    Comments-mode
    WPA - psk ascii 7 14231A0E01053324363F363B36150E050B08585E
    !
    base speed - 1.0 2.0 basic basic-5, 5 6.0 9.0 basic-11, 0 12.0 18.0 24.0 36.0 48.0 54.0
    root of station-role
    !
    interface Dot11Radio0.1
    encapsulation dot1Q 1 native
    no ip route cache
    no link-status of snmp trap
    No cdp enable
    Bridge-Group 1
    Bridge-group subscriber-loop-control 1
    Bridge-Group 1 covering-disabled people
    Bridge-Group 1 block-unknown-source
    No source of bridge-Group 1-learning
    unicast bridge-Group 1-floods
    !
    interface Vlan1
    Description $ETH - SW - LAUNCH, INTF-INFO-HWIC $$ $4ESW $FW_INSIDE$
    no ip address
    IP tcp adjust-mss 1452
    Bridge-Group 1
    !
    interface BVI1
    Description $ES_LAN$ $FW_INSIDE$
    192.168.7.1 IP address 255.255.255.0
    IP nat inside
    IP virtual-reassembly
    route IP cache flow
    IP tcp adjust-mss 1412
    !
    interface control2
    IP 70.14.49.134 255.255.255.0
    NAT outside IP
    IP virtual-reassembly
    crypto mymap map
    !
    local pool IP 10.10.10.1 ippool 10.10.10.254
    IP classless
    IP route 0.0.0.0 0.0.0.0 70.14.49.1
    !
    IP http server
    local IP http authentication
    IP http secure server
    IP http timeout policy slowed down 60 life 86400 request 10000
    overload of IP nat inside source list 133 interface control2
    !
    CODS_to_RMFLK extended IP access list
    IP 192.168.7.0 allow 0.0.0.255 192.168.1.0 0.0.0.255
    !
    recording of debug trap
    access-list 1 permit 192.168.7.0 0.0.0.255
    access-list 100 remark self-generated by the configuration of the firewall Cisco SDM Express
    Access-list 100 = 1 SDM_ACL category note
    access-list 100 deny ip 70.14.49.0 0.0.0.255 any
    access-list 100 deny ip 255.255.255.255 host everything
    access-list 100 deny ip 127.0.0.0 0.255.255.255 everything
    access ip-list 100 permit a whole
    access-list 101 permit ip 192.168.7.0 0.0.0.255 192.168.3.0 0.0.0.255
    access-list 133 deny ip 192.168.7.0 0.0.0.255 192.168.1.0 0.0.0.255
    access-list 133 deny ip 192.168.7.0 0.0.0.255 10.10.10.0 0.0.0.255
    access-list 133 deny ip 192.168.7.0 0.0.0.255 192.168.10.0 0.0.0.255
    access-list 133 deny ip 192.168.7.0 0.0.0.255 192.168.3.0 0.0.0.255
    access-list 133 allow ip 192.168.7.0 0.0.0.255 any
    not run cdp
    mymap permit 10 route map
    corresponds to the IP 111
    set ip next-hop 1.1.1.2
    !
    !
    control plan
    !
    Bridge Protocol ieee 1
    1 channel ip bridge
    Bridge Protocol ieee 2
    IP road bridge 2
    connection of the banner ^ CAuthorized access only!
    Unplug IMMEDIATELY if you are not an authorized user. ^ C
    !
    Line con 0
    no activation of the modem
    telnet output transport
    line to 0
    telnet output transport
    line vty 0 4
    privilege level 15
    transport input telnet ssh
    !
    max-task-time 5000 Planner
    Scheduler allocate 4000 1000
    Scheduler interval 500
    end

    Hello

    Can you try to remove the IMPORT ALL of the dhcp pool

    RES
    Paul

    Sent by Cisco Support technique iPad App

  • Distributed database

    Hello

    I'm sorry if my question does not exist in the right place.

    in fact, I need some information for my graduation project:

    What is the distributed database?

    Why we distribute the database?

    is the link db how to distribute the database?

    What about the stream, is the way to do the same things?

    are we distribute database for replication? or what?

    is there a relationship between the cars and the distributed database?

    Please I need titles or point to understand that these issues of departure

    Best regards

    Published by: excalibur on February 9, 2010 17:20

    Watercourse is a method to replicate of the data.
    ACR is not the database distributed, because it is a unique database, accessed by two or more nodes (servers).

    In terms of Oracle, the database is the set of files that contain the data.

    A user can see data access from multiple sources - his 'logic' database is distributed across multiple physical databases. Using the Oracle code, they could be related with DBLinks.
    However, you can have an application that allows separate connections to disparate databases and presents a logical point of view to the user.

    Also, consult databases Federated - who are the independent databases. You would see these implementations IBM DB2 (and SQLServer, although IBM and Microsoft implementations may differ).

    Hemant K Collette
    http://hemantoracledba.blogspot.com

    Hemant K Collette

  • Airport connection issues

    I have an Airport Extreme, connected to a Comcast Modem. I extended my system with an Airport Express and Airport Time Capsule. I use a DHCP/Nat # 192.168.1 to system configuration and each unit module is defined to EXTEND the current system. When I use DHCP to obtain the IP address, the default value of the units to a 172.le addressing scheme. In order to get a good address 192, I need to manually insert the ip address, the subtask and DNS servers. Why create it incorrect IPv4 addressing scheme is displayed?

    What is the brand and model of your modem provided by Comcast? How about you, the exact model of each of your Apple base stations numbers? Extend the two base stations using wired or wireless to extend AirPort Extreme?

  • BIOS update killed my Satellite Pro A210-1AZ

    Hello

    Today Tempro gave me an alert that there is a new update of the BIOS (bios-20100215113621). I duly installed in the usual way. During the restart, the machine came with a message from sum of CONTROL INCORRECTE.

    While I was reading the message machine gave a sharp sqeak and dies quickly. It won't restart or answer.

    Toshiba may explain why they distribute updates of Slayers and offer on how to get my machine back to life.

    Two identical machines so we leave my wife running on the old bios.

    The one you have any good ideas?

    Hello

    This s pity companion
    Looks like the BIOS update procedure has failed, which means that you need a help of a technician of the ASP
    I hope that the ROM module was not too bad. In most cases, should be reflash the ROM BIOS again

    In any case, this procedure needs a crisis BIOS disk that would help to Flash the module.

    Welcome them

  • . MDLP instead of .dmg

    Why Adobe distribute a .mdlp instead of a .dmg file file during the installation of the (stupid) Flash Player?

    We do not have.  For some reason, the installation of Matlab program sometimes seems to corrupt a preference in Safari, which then causes Safari incorrectly Add .mdlp at the end of some names of downloaded files.

    If you rename the Setup program ending in .dmg, her guests he performed as expected.

    You will probably need to Reset Safari to factory settings to operate this new.

  • Problems with the use of variables at the time of the SV - Loudness.vi

    Hello

    I'm rather new to Labview and will have questions, get my Time-Varying Loudness calcuations out correctly. Attached is my current VI and a .csv file of my data set (calibrated in PA. sampling frequency = 50 kHz for 5 seconds). It does not produce what I expected when I run the VI. Here are my questions:

    Time-Varying Loudness:

    (1) what are the signals so much? There are hundreds of lines, but I only expect one.

    (2) why my category axis are not a range from 1 to 24 years as bark should be?

    1/3 octave Band Analsysis:

    (1) why is it incorrect? Them should not be a linear increase the frequency...

    Data on the one hand be hurry and make a squeek. It is a transient noise that happens about 2 seconds. But, how could I go do a waterfall (Time (s), Frequency (Hz), Amplidtude (sones)) of this signal? Is there an easy way? or do I have to do all three signals and add to make a parcel?

    Thank you very much for your help! Let me know if you need more infromation,

    -Troy

    p.s. I have included a picture of the results as well.

    Hi Troy,

    (1) the SV specific volume VI 'chunks' given in blocks of 2 ms and returns then these as individual plots specific Loudness vs. Sone.  The colored lines that you see in your chart are representative of the 2 500 2 periods of time ms in your acquisition of five seconds.  Each of these plots contains 241 points, however they are ten sample "gradually", one for each sone.  The digital filter buffer takes a bit to fill and kick in properly, however, so you can give your first rows (0-. 02 seconds or more) scrutiny before using them - you can see a number of unexpected zeros around the lower sones.

    2) since you use a chart, the x-axis will be increments every race following (the previous data is stored.)  If you only want to display the most recent data, I would recommend switching to a chart, which is found in the chart controls palette.  Also, see above (#1) why the x axis are longer than 24 points.

    (3) remember that dB is a unitless measure and cannot be used in reference to another value. A typical reference for sound is 20 uPa, but you will probably need even out your data entry and determine/set dB reference.  You can take a look at the voltage from the snout to the Cloaca EU.vi scale (EU means equalized units) and from the snout to the Cloaca Set dB reference.vi.  In your case, I think the plot of Octave shows your dB from a default value of 1.  The values should be accurate with respect to the other, but you must provide a reference value to calibrate the scale.

    (4) I think that this VI is a good example how to do to create a cascade:

    Display cascading for Octave (DAQmx)

    http://zone.NI.com/DevZone/CDA/EPD/p/ID/5562

    You will need to break up of your waveform into pieces, just like the specific volume VI, but the basic concept is roughly the same (take piece of waveform, take octave measure of the piece, add octave output measure cluster to cluster table, repeat for the rest of the waveform display)

    Phew!  It was a bit of information.  Let me know if this makes sense and don't be intimidated by the detail and/or unknown functions or methods - you're definitely on the right track, or to ask it to at least the right questions.

  • DirectInput with LabWindows/CVI

    Hello

    I'm trying to use DirectInput to obtain data on the position of a USB joystick in LabWindows/CVI. CVI 2013 comes with headers and libs for direct entry into its subfolder of the sdk and the DirectX SDK comes with a very simple example.

    However, already the first step in opening creating a directinput handle fails to compile - it is essentially copied verbatim from directInput documentation or the joystick sample provided with the DirectX SDK.

    #include
    #define DIRECTINPUT_VERSION 0x0800
    #include 'dinput.h.

    int main (int argc, char * argv [])
    {
    LPDIRECTINPUT8 di;
    HRESULT hr;

    HR = hr = DirectInput8Create (GetModuleHandle (NULL), DIRECTINPUT_VERSION, IID_IDirectInput8, (VOID *) & di, NULL);

    return 0;
    }

    60, 42 error: from 'const GUID' (aka "const struct _GUID") to the inconsistent type parameter ' const IID *' (aka ' const struct _GUID *')

    18, 1 in file included from c:\Users\tpaprotta\Documents\National Instruments\CVI\Command-line Application.c:18:

    "dinput.h" (2682,83) c:\program files (x 86) \national instruments\cvi2013\sdk\include\dinput.h:2682:83: Note: passing argument to the parameter "riidltf" here ".

    The same code compiles without problem under Visual Studio 2012.

    Therefore, it is / was a number of questions. Yes, the example in question is C++, so instead of the call

    DirectInput8Create (GetModuleHandle (NULL), DIRECTINPUT_VERSION, IID_IDirectInput8, (VOID *) & di, NULL);

    To call

    DirectInput8Create (GetModuleHandle (NULL), DIRECTINPUT_VERSION, & IID_IDirectInput8, (VOID *) & di, NULL);

    (IID_IDirectInput8 is defined differently depending on if C or C++ calls).

    However, if we make this change, the _IID_IDirectInput8 symbol is not found. The symbol is not in dinput8.lib (which is included with CVI), but rather in the dxguid.lib (which I couldn't find in the records of OR). It is distributed with the DirectX SDK - so I'm now a link against it. I'm curious, however, why NOT distribute dinput8.lib / dll and not other required libraries, which seem to be necessary to use.

  • loading personal settings is slow

    Loading personal settings is very slow

    If he is a member of the domain computer, you have incorrectly DNS. See your IT Department.

    If there is a computer at home, something you have from Windows is slowing down things. It could be legitimate, or it could be malicious. Since you have not provided all the information about your computer, start with the basics of troubleshooting:

    The first Question of troubleshooting: If the problem is new, what has changed between the time things worked and the time they do not have?

    The second issue of Windows troubleshooting: what is the status of virus/malware of the machine? If you think it's clean, what programs (and versions) allows you to determine this?

    Make sure that the computer is clean:
    http://www.elephantboycomputers.com/page2.html#Removing_Malware

    Once you are sure that the computer is free of virus/malware - and ONLY after you have done - if the problem persists, manage your Startup:

    Start > run > msconfig [Enter]

    This will open the System Configuration utility. Look under the Startup tab and find the likely culprit. Uncheck the box next to its name, apply and OK out. You don't need to restart immediately, but next time you do, you will get a dialog box saying that you have used the utility. Just check the box that says in effect, "don't mind to this subject again".

    If you can't do the work yourself (and there is no shame in admitting this isn't your cup of tea), take the machine to a professional computer repair shop (not your local equivalent of BigComputerStore/GeekSquad). If possible, have all your data backed up before taking the machine into a shop. MS - MVP - Elephant Boy computers - don't panic!

Maybe you are looking for


HashFlare