How to put an Excel line at a time?

Hi all

In fact, the subject should be "How to set Excel import preferences?", but I am reluctant to change the old topic.

The problem is that app.excelImportPreferences does not define import preferences. The code ignores the setting of the Excel import preferences and uses the previous InDesign preferences. I tried to change the table formatting to InDesign. I tried app.excelImportPreferences.rangeName = "A3:H3";

Below is the code. Help appreciated!

Greetings,

bgfrhlp

P.S. I tried to locate the help forum and the internet, without success.

doc = app.open (filePath = "d:/base.indt");

newFrame = doc.textFrames.add({geometricBounds:[6,28,37,84]});)

setExcelImportPrefs ();

excelFile = new File ("d/file.xlsx");

newFrame.place (excelFile);

function setExcelImportPrefs() {}

{with (App.excelImportPreferences)}

alignmentStyle = AlignmentStyleOptions.spreadsheet;

decimalPlaces = 4;

preserveGraphics = true;

Enter the range you want to import as "start cell cell: end".

rangeName = "A3:H3";

sheetIndex = 1;

showHiddenCells = false;

tableFormatting = TableFormattingOptions.excelFormattedTable;

useTypographersQuotes = false;

viewName = ' ';

}

}

Post edited by: bgfrhlp

The code works well with the old Excel (.xls, Mac OS X) files. Maybe Adobe should do some update...

P.S. I filed a bug report today.

P.S.S. also works under Windows 7 with the .xls files.

Post edited by: bgfrhlp

Tags: InDesign

Similar Questions

  • How to put in different lines

    I received a file where I swap shows the data in the rows into columns using transposes table 2D. The problem is now, now, it shows all in a single line. How do I divide it into several lines?

    From:

    Simplex-link duplex-link
    n1                n0
    n0                n0
    10 10
    20 20
    DropTail DropTail

    It should display:

    Simplex-link 10 20 DropTail n0 n1

    duplex-link n0 n0 10 20 DropTail

    But it gives me:

    Simplex-link n1 n0 10 20 DropTail duplex-link n0 n0 10 20 DropTail

    Any advice where I did wrong?

    Thank you

    Hello

    I have the version of LabVIEW 8.0. I'm trying to understand your problem and make a new vi who reads all the conc file.txt. I do vi that meets your needs. You can take a look below imgaes

    Thank you

    Viru

  • How to put a new line in the text block using jsx?

    Hello guys,.

    I am concatenating the content of the text block using two JSX, but I want separator as a new line. I have tried \n but does not work please help how to do that.

    var  seperator = "\n" 
    frame1.textItem.contents + seperator + text;
    

    Hi UpendraSengarr,

    Try this:

    var frame1 = app.activeDocument.activeLayer;
    var  seperator = "\r";
    frame1.textItem.contents = frame1.textItem.contents + seperator + "text";
    

    Have fun

  • How to put a bold line in a classic report

    I'm new to APEX.

    After having browsed the forum and other pages, the following should work to make the text "under totals" "BOLD", but it doesn't.

    What I am doing wrong?

    Select *.

    BeO

    Select BH, AC, DFV, SP, PR

    of du_RAAR_3c_DI_v1

    )

    Union

    Select

    '< b >"|' Under totals |' < _ / b_ > '

    NULL,

    Sum (DFV),

    Sum (SP),

    Round (Sum (SP) /Sum (DFV) * 100)

    of du_RAAR_3c_DI_v1

    order by 2

    (change b b and _ / b_ to / b)

    Thank you

    Hello

    Your code is fine, but you need to assign to the column of the report to display as a standard report column.

    Go to your page > report definition > report attributes > column attributes > display as.

    Kind regards

    Vincent

  • How to put the menu in the cells or the lines of a web form

    Simple question: How can I put the menu in cells or rows of a web form?
    Would be - this "menu" in the form of web?

    I don't think you can put a menu on the 'data cells' form. You can put them on line members or column. I think this is the area of the 'required dimension' when you change the content of the menu that determines where you right click on the form to get the menu. But still, I don't think that you can configure it to work on a data cell. You right click a member in the rows or columns.

    We use them mainly to connect shapes and launch business rules. In general we are connecting to some sort of form summarized in a more detailed form, or a form where users can make adjustments.

    -Jake

  • How to put 2 A5 flyers on a page A4 Pages

    How to put 2 A5 flyers on a page A4 in Pages? On iMac

    Hi Billy,

    5.6.1 the pages.

    If your flyer is in a text box, resize the box to fit a half page A4. Copy, paste, and then drag the copy down half of the A4 page.

    Alignment guides can help (Menu > Pages > Pages Preferences > leaders):

    Also Menu > view > show rules.

    You can drag a Guide of alignment (orange line in the following screen shot) of the horizontal rule (not to print the Guides).

    Menu > View > Show presentation in order to see the page margins and the header and footer.

    50% of the zoom for a small screenshot.

    File > Menu > print... to confirm the layout

    Kind regards

    Ian.

    Edit: You can drag a Guide to align the horizontal rule (orange line in the following screenshot).

  • How to make an excel file opens automatically whenever I start my computer? ___

    How to make an excel file opens automatically whenever I start my computer?

    Put a shortcut to the file in your startup folder.

  • How to put all through traffic the easy vpn client VPN server

    Hi people

    I want to ask you, how to put all of the server the easy vpn client VPN traffic through.

    I mean, I have a server vpn at home, and if I connect to the vpn from outside server, to be with an IP address of my home.

    There is the configuration up to now. Where is the problem?

    ROUTER1 #sh running-config

    Building configuration...

    Current configuration: 5744 bytes

    !

    ! Last configuration change at 19:51:18 UTC Wed Sep 4 2013 by cska

    !

    version 15.1

    horodateurs service debug datetime msec

    Log service timestamps datetime msec

    no password encryption service

    !

    ROUTER1 hostname

    !

    boot-start-marker

    usbflash0:CVO boot-BOOT Setup. CFG

    boot-end-marker

    !

    !

    !

    AAA new-model

    !

    !

    AAA authentication login ciscocp_vpn_xauth_ml_1 local

    AAA authorization ciscocp_vpn_group_ml_1 LAN

    !

    !

    !

    !

    !

    AAA - the id of the joint session

    !

    Service-module wlan-ap 0 autonomous bootimage

    Crypto pki token removal timeout default 0

    !

    Crypto pki trustpoint TP-self-signed-1604488384

    enrollment selfsigned

    name of the object cn = IOS - Self - signed - certificate - 1604488384

    revocation checking no

    !

    !

    TP-self-signed-1604488384 crypto pki certificate chain

    certificate self-signed 01

    3082022B 30820194 02020101 300 D 0609 2A 864886 F70D0101 04050030 A0030201

    2 060355 04031326 494F532D 53656 C 66 2 AND 536967 6E65642D 43657274 31312F30

    69666963 31363034 34383833 6174652D 3834301E 170 3133 30383239 31313539

    32395A 17 0D 323030 31303130 30303030 305A 3031 06035504 03132649 312F302D

    4F532D53 5369676E 656C662D 43 65727469 66696361 74652 31 36303434 65642D

    38383338 3430819F 300 D 0609 2A 864886 01050003, 818, 0030, 81890281 F70D0101

    8100CD 57 F1436ED2 8D9E8B99 B6A76D45 FE56716D D99765A9 1722937C F5603F9F

    528E27AF 87A24C3D 276FBA1C A5E7C580 CE99748E 39458C 74 862C 2870 16E29F75

    7A7930E1 15FA5644 D7ECF257 BF46C470 A3A17AEB 7AB56194 68BFB803 144B7B10

    D3722BDD D1FD5E99 8068B77D A1703059 9F0578C7 F7473811 0421490D 627F25C5

    4 HAS 250203 010001A 3 53305130 1 130101 FF040530 030101FF 301F0603 0F060355

    551 2304 18301680 141B 1326 C111DF7F 9F4ED888 EFE2999A 4C50CDD8 06 12301

    03551D0E 04160414 1B1326C1 11DF7F9F 4ED888EF E2999A4C 50CDD812 300 D 0609

    2A 864886 04050003 81810096 BD0C2B16 799DB6EE E2C9B7C4 72FEAAAE F70D0101

    FF87465C FB7C5248 CFA08E68 522EA08A 4B18BF15 488D D53D9A43 CB400B54 8006

    CB21BDFB AA27DA9C C79310B6 BC594A7E D6EDF81D 0DB7D2C1 9EF7251B 19A 75403

    211B1E6B 840FE226 48656E9F 67DB4A93 CE75045B A986F0AD 691EE188 7FB86D3F

    E43934FA 3D62EC90 8F37590B 618B0C

    quit smoking

    IP source-route

    !

    !

    !

    !

    CISCO dhcp IP pool

    import all

    network 192.168.1.0 255.255.255.0

    DNS-server 195.34.133.21 212.186.211.21

    default router 192.168.1.1

    !

    !

    IP cef

    No ipv6 cef

    !

    Authenticated MultiLink bundle-name Panel

    license udi pid CISCO892W-AGN-E-K9 sn FCZ1530C209

    !

    !

    username privilege 15 secret 5 cska $1$ $8j6G 2sMHqIxJX8MQU6vpr75gp1

    !

    !

    !

    !

    !

    !

    crypto ISAKMP policy 1

    BA 3des

    preshared authentication

    Group 2

    !

    Configuration group customer isakmp crypto VPNGR

    vpngroup key

    DNS 212.186.211.21 195.34.133.21

    WINS 8.8.8.8

    domain chello.at

    pool SDM_POOL_1

    ACL 120

    netmask 255.255.255.0

    ISAKMP crypto ciscocp-ike-profile-1 profile

    match of group identity VPNGR

    client authentication list ciscocp_vpn_xauth_ml_1

    ISAKMP authorization list ciscocp_vpn_group_ml_1

    client configuration address respond

    virtual-model 1

    !

    !

    Crypto ipsec transform-set esp-SHA-ESP-3DES-3des esp-sha-hmac

    !

    Profile of crypto ipsec CiscoCP_Profile1

    security association idle time 86400 value

    game of transformation-ESP-3DES-SHA

    set of isakmp - profile ciscocp-ike-profile-1

    !

    !

    Bridge IRB

    !

    !

    !

    !

    interface Loopback0

    192.168.4.1 IP address 255.255.255.0

    IP nat inside

    IP virtual-reassembly in

    !

    interface BRI0

    no ip address

    encapsulation hdlc

    Shutdown

    Multidrop ISDN endpoint

    !

    interface FastEthernet0

    !

    interface FastEthernet1

    !

    interface FastEthernet2

    !

    interface FastEthernet3

    !

    interface FastEthernet4

    !

    interface FastEthernet5

    !

    FastEthernet6 interface

    !

    interface FastEthernet7

    !

    interface FastEthernet8

    no ip address

    Shutdown

    automatic duplex

    automatic speed

    !

    type of interface virtual-Template1 tunnel

    IP unnumbered Loopback0

    ipv4 ipsec tunnel mode

    Tunnel CiscoCP_Profile1 ipsec protection profile

    !

    interface GigabitEthernet0

    Description Internet

    0023.5a03.b6a5 Mac address

    customer_id GigabitEthernet0 dhcp IP address

    NAT outside IP

    IP virtual-reassembly in

    automatic duplex

    automatic speed

    !

    wlan-ap0 interface

    description of the Service interface module to manage the embedded AP

    192.168.9.2 IP address 255.255.255.0

    ARP timeout 0

    !

    interface GigabitEthernet0 Wlan

    Description interface connecting to the AP the switch embedded internal

    !

    interface Vlan1

    no ip address

    Bridge-Group 1

    Bridge-Group 1 covering-disabled people

    !

    interface BVI1

    IP 192.168.1.1 255.255.255.0

    IP nat inside

    IP virtual-reassembly in

    !

    local IP SDM_POOL_1 192.168.4.3 pool 192.168.4.245

    IP forward-Protocol ND

    !

    !

    IP http server

    local IP http authentication

    IP http secure server

    overload of IP nat inside source list 110 interface GigabitEthernet0

    IP nat inside source static tcp 192.168.1.5 3389 interface GigabitEthernet0 3389

    IP nat inside source static udp 192.168.1.5 3389 interface GigabitEthernet0 3389

    IP nat inside source static tcp 192.168.1.5 21 interface GigabitEthernet0 21

    IP nat inside source static udp 192.168.1.5 21 interface GigabitEthernet0 21

    IP nat inside source static tcp 192.168.1.4 3389 interface GigabitEthernet0 3390

    IP nat inside source static udp 192.168.1.4 3389 interface GigabitEthernet0 3390

    overload of IP nat inside source list 120 interface GigabitEthernet0

    IP route 0.0.0.0 0.0.0.0 dhcp

    !

    exploitation forest esm config

    access list 101 ip allow a whole

    access-list 110 permit ip 192.168.1.0 0.0.0.255 any

    access list 111 permit tcp any any eq 3389

    access-list 120 allow ip 192.168.4.0 0.0.0.255 any

    !

    !

    !

    !

    !

    !

    !

    control plan

    !

    Bridge Protocol ieee 1

    1 channel ip bridge

    !

    Line con 0

    line 2

    no activation-character

    No exec

    preferred no transport

    transport of entry all

    transport output pad rlogin udptn ssh telnet

    line to 0

    line vty 0 4

    privilege level 15

    preferred transport ssh

    entry ssh transport

    transportation out all

    !

    Thanks in advance

    To do this you must make the following changes:

    (1) disable split Tunneling by deleting the ACL of your configuration of the client group.
    (2) enable NAT for VPN traffic by adding 'ip nat inside' to your virtual model of the client network to the ACL that controls your PAT.

    Edit: Theses are the changes to your config (also with a little cleaning):

    Configuration group customer isakmp crypto VPNGR

    No 120 LCD

    !

    type of interface virtual-Template1 tunnel

    IP nat inside

    !

    no nat ip inside the source list 120 interface GigabitEthernet0 overload

    !

    access-list 110 permit ip 192.168.4.0 0.0.0.255 any

    no access-list 120 allow ip 192.168.4.0 0.0.0.255 any

    Sent by Cisco Support technique iPad App

  • How to put different images (image by record type) in native obiee table

    Hi, how to put different images (image by record type) in native obiee table?

    for example, the image is for the banana (record 1, row1)
    Picture B is for orange (record2, line 2)

    I know it's possible in mode narrative but I must manually apply CSS

    Thank you!

    Please take a look at this post on top of this message to activate the image column value interaction with target report i.e. (record 1, row1)

  • How to remove the black line with a canvas stacked at run time?

    Hi all
    I developed a canvas stacked in a table of content, when I run the form takes the apeared canvas stacked with a black line.
    How to remove this line, or how to remove this line at run time?
    I tried to do by putting (no line) in the Toolbox of the line color tool after selecting black line one and after selecting the stacked another painting once, but this has not solved the problem!

    I need something else:
    I put the canvas stacked to the block of data in detail and did not appear since I run the query in the database block
    How to make appear stacked directly canvas before you run the query in the master data block?

    What is your version of forms? I don't know what black line you're talking about.

    Regarding the display of the canvas, first make sure it isn't about who has the focus and she rides (located under the canvas completely or partially) your canvas stacked, this will cause to the canvas to hide in order to display the item that has the focus. And you can also try using SHOW_VIEW ('your_stacked_canvas'); in your form, this will show the stacked canvas.

    Tony

  • How can I change the line spacing?

    I looked everywhere to find how I can change the line spacing in my e-mail address when sending. Can't find any dishes. CAM help me?

    The answer is probably some handmade css coding which is not a trivial thing to do.

    Why you want to change the line spacing? A larger or smaller font would be useful for you?

  • How to develop and reduce lines or groups of lines in figures?

    How to develop and reduce lines or groups of lines in figures?

    Thank you

    Casey

    Select the rows (or columns):

    Then, place the cursor on one of the row headings (the numbers on the left):

    so that you see the carat facing downwards, then click here to bring up the context menu for the lines:

    then select "hide selected rows.

  • How to put an impulse on a guitar track?

    Hello!

    Logic Pro 10.2.2. I remember in earlier versions of the logic, you can simply move WAV file pulse to the designer of the space.

    But now it doesn't work at all, so the question is how to put a pulse of WAV ready (ready) on the guitar track?

    Thanks before!

    You use the context menu in the user interface:

    Or you can open the IR utility, drag it there, make some changes (denoising, for example) and create SpaceDesigner setting. Then, it appears in the menu presets.

    Best,

    DaCaptain

  • How to put bookmarks in the left side of the screen forever?

    I use every night, 64-bit laptop.
    How to put bookmarks in the left side of the screen for good to keep them here? I couldn't believe how you hide this option. Other browsers requires a simple click.
    THX

    To open or close the bookmarks bar, do one of the following:

    • CTRL + B
    • tap the ALT key, the Menu Bar temporarily displays, click on view > sidebar > bookmarks
    • Hold DOWN the ALT key while pressing the VEB keyboard letters

    If the bookmark sidebar is open when you exit Firefox (Firefox button > output OR file > exit), it should be there when you restart Firefox.

    Also see-> https://support.mozilla.com/en-US/kb/common-questions-after-upgrading-firefox-36

    If this answer solved your problem, please click 'Solved It' next to this response when connected to the forum.

  • How to put in place measures in the application of health?

    How to put in place measures in the application of health?

    What do you mean 'the configuration steps? If you want steps if poster on the health dashboard, tap on health at the bottom of the screen data. Tap fitness. Tap measures. The value "Show on dashboard" on.

    The health app is really more than one application storage and synchronization. You can't do things as targets for a particular metric. If you want to set a goal of step and follow it, use one of the many followed apps available that can extract data from health. Map My Fitness, My Fitness Pal, Jawbone UP and Fitbit (both can be used with the phone if you have an iPhone 5 or a later version). If you like to compete with others, the Club activities is fun.

Maybe you are looking for