How to reach all children during the use of Propagation of the event?

Hello

I use the Propagation of the event in order to change the alpha of each child on MOUSE_OVER and MOUSE_OUT MOUSE_DOWN to help...

evt. Target.Alpha

More alpha of the child increases of 0-0.5.

On OUT it is 0.5-0.

On down, he goes to 0.5 and stays there even with a MOUSE_OUT.

I want to do then is add a button to the main stage, that reduces the visibility of all children to 0, a base type of the clear button.

I have a way to do where I list each child in a function (all 9!). But I can re - write this so that all children are required to write code so much?

Ideally, I would like to send a request to find the number of children (9), then use this variable to write a function that says (where n is the name of the Instance of each child) than n(0-numChildren).alpha = 0

Here is my code - very - long breath:

clearBtn.addEventListener (MouseEvent.CLICK, ContainerAlpaReset, false, 0, true);

musicContainer.addEventListener (MouseEvent.MOUSE_OVER, onMusicOver, false, 0, true);

musicContainer.addEventListener (MouseEvent.MOUSE_OUT, onMusicOut, false, 0, true);

musicContainer.addEventListener (MouseEvent.MOUSE_DOWN, onMusicClick, false, 0, true);

var i: Number = 0.5

function onMusicOver(evt:MouseEvent):void {}

if (evt.target.alpha == 0)

evt.target.alpha = 0.5;

}

function onMusicOut(evt:MouseEvent):void {}

if (evt.target.alpha == I)

evt.target.alpha = 0;

else (evt.target.alpha = 1);

}

function onMusicClick(evt:MouseEvent):void {}

evt.target.alpha = i + 0.5;

}

function ContainerAlpaReset(evt:MouseEvent):void {}

musicContainer.n1.alpha = 0;

musicContainer.n2.alpha = 0;

musicContainer.n3.alpha = 0;

musicContainer.n4.alpha = 0;

musicContainer.n5.alpha = 0;

musicContainer.n6.alpha = 0;

musicContainer.n7.alpha = 0;

musicContainer.n8.alpha = 0;

musicContainer.n9.alpha = 0;

removeEventListener (MouseEvent.CLICK, ContainerAlpaReset);

}

Is there a simple way to write the part in bold? That is to say:

musicContainer. Children? .alpha = 0;?

Or better yet, can I use numChildren count and then write a generic piece of code that adds each count to the n #?

Thank you for all the answers!

Try

function ContainerAlpaReset(evt:MouseEvent):void {}

for (var i: uint = 1; i<10;>

musicContainer ["n" + String (i)] .alpha = 0;

}

removeEventListener (MouseEvent.CLICK, ContainerAlpaReset);

}

Tags: Adobe Animate

Similar Questions

  • How to delete all children of the ComboBox?

    In my application, when you change the base state, all my drop-down list boxes are populated with the data.

    I would like to 'reset' the drop-down list boxes when the State returns to the base.

    I've written a loop that traverses all the children of a hBox (btnContainer) when the state changes back to the base.

    I can reset a combobox as follows: colChart.ccCombo.data = null. Works well.

    When I loop on children, I get a series of IDisplayObjects and I can not use the property data to set to null.

    How can I set each ComboBox to null in the loop?

    private function doDispose (): void {}
    var ccTemp:ComboBox;

    for (var i: int = 0; i < colChart.btnContainer.numChildren; i ++) {}
    If (colChart.btnContainer.getChildAt (i) is ComboBox) {}
    trace (colChart.btnContainer.getChildAt (i). (Name)

    does not work

    ccTemp = colChart.getChildAt (i) as ComboBox;
    ccTemp.data = null;
    }
    }

    }

    Try:

    ComboBox (colChart.getChildAt (i)) .dataProvider = null;

    Alex Harui

    Flex SDK Developer

    Adobe Systems Inc..

    Blog: http://blogs.adobe.com/aharui

  • How to reach all reports to the user in discoverer

    Hello
    I need to attach all the reports in discoverer user. How can I do this? Its urgency.
    Thank you

    Hello

    Through this link you will get step by step to set the workbook to the end user. In this viewer and more access with e-business suite.

    [http://ascbi.com/third_party_documents.htm]

    Hope this helps you.award points.

    Best wishes
    Murielle.

  • How to remove all information from the computer so I can sell it?

    How to remove all information from the computer so I can sell it?

    Hello

    You will want to format the hard disk:

    1. you can use DBAN - http://www.dban.org/

    or

    2. you can follow this tutorial to clean install up to the step where you format the disk, in which you would then STOP (because you just want to get rid of the files on the hard drive, do not install Windows) - http://www.sevenforums.com/tutorials/1649-clean-install-windows-7-a.html

    Kind regards

    Patrick

  • guys, how can I stop backup during I use cellular data

    guys, how can I stop backup during I use cellular data

    iCloud backup requires a wi - fi connection. It does not backup when only cellular data are available. See: get help from backup of your device in iCloud - Apple Support

  • Exception occurred during the event dispatching: java.lang.NoSuchMethodError

    Hello

    We have upgraded to the latest Oracle Application Server version 10.1.2.3.0 and webutil version 1.0.6.

    But we are facing the following error while accessing the web link. Message captured from the Java Console.
    Please suggest if you have a solution/idea about this error. Thank you!

    Oracle JInitiator: Version 1.3.1.22
    Using JRE version 1.3.1.22- internal Java hotspot Client VM
    Maximum size: 50 MB
    Compression level: 0 -.
    c: clear console window
    f: finalize objects on the finalization queue
    g: garbage collection
    h: display this help message
    l: dump classloader list
    m: print memory usage
    q: Hide console
    S: dump system properties
    t: dump thread list
    x: delete the cache of class loaders
    0-5: set the level of trace to < n >
    ----------------------------------------------------
    Download http://si02938.in.irt.com:7778/forms/java/frmall_jinit.jar to JAR cacheDownloading http://si02938.in.irt.com:7778/forms/java/frmwebutil.jar to JAR cacheDownloading http://si02938.in.irt.com:7778/forms/java/jacob.jar to JAR cacheDownloading http://si02938.in.irt.com:7778/forms/java/FileInformation.jar to JAR cacheDownloading cacheproxyHost = nullproxyPort = 0connectMode = HTTP, native.
    Version forms cmdlet is: 10.1.2.3
    Exception occurred during the event dispatching: java.lang.NoSuchMethodError at oracle.forms.webutil.common.VBeanCommon.init(VBeanCommon.java:281) at oracle.forms.handler.UICommon.instantiate (Unknown Source) at oracle.forms.handler.UICommon.onCreate (Unknown Source) at oracle.forms.handler.JavaContainer.onCreate (Unknown Source) at oracle.forms.engine.Runform.onCreateHandler (Unknown Source) at oracle.forms.engine.Runform.processMessage(Unknown Source) at oracle.forms.engine.Runform.processSet(Unknown Source) at oracle.forms.engine.Runform.onMessageReal(Unknown Source) at oracle.forms.engine.Runform.onMessage(Unknown Source) at oracle.forms.engine.Runform.processEventEnd(Unknown Source) at oracle.ewt.lwAWT.LWComponent.redispatchEvent(Unknown Source) at oracle.ewt.lwAWT.LWComponent.processEvent(Unknown Source) at java.awt.Component.dispatchEventImpl (unknown Source) at java.awt.Container.dispatchEventImpl (unknown Source) at java.awt.Component.dispatchEvent (unknown Source) at the java.awt.EventQueue.dispatchEvent (Unknown Source) at java.awt.EventDispatchThread.pumpOneEventForHierarchy (unknown Source) at the java.awt.EventDispatchThread.pumpEventsForHierarchy (Unknown Source) at java.awt.EventDispatchThread.pumpEvents (unknown Source) at java.awt.EventDispatchThread.run (Unknown Source)

    Published by: user12233243 on November 16, 2009 22:28

    Published by: user12233243 on November 16, 2009 22:29

    Hello

    Your welcome, but you need to mark it as correct or relatively useful because other users will be able to solve their problems.

    Sarah

  • How we prevent persistent reboots during the day on desktop

    You need to restart our computer of the two or three times during the day.  Turn us your computer in the morning and leavit turn it on during the day, then it turn off during the night.  What is going on???

    Looks like you may have a virus or other malware. Get your updated antivirus program and boot into Safe Mode. Note that some viruses can hide from your normal antivirus program, so you really need to scan in Safe Mode. To enter in Safe Mode when you turn on first, press F8 on every seconds until you get the menu, and then select Safe Mode. Then run a complete system scan.

    -

    Microsoft has suggestions and offerings to

    http://Windows.Microsoft.com/en-us/Windows7/how-do-I-remove-a-computer-virus

    -

    Moderator Forum Keith has a few suggestions along this line to

    http://answers.Microsoft.com/en-us/Windows/Forum/Windows_7-performance/Windows-Explorer-has-stopped-working/6ab02526-5071-4DCC-895F-d90202bad8b3

    -

    If that suits him fine. If this is not the case, use system restore to go back to an earlier date at the beginning of the problem. To run system restore, click Start-> programs-> Accessories-> System Tools-> system restore. Click on the box that says show more restore points.

    -

    You can check the corrupted system files. Open an administrator command prompt and run SFC if the above does not help. Click START, and then type CMD in the search box, right-click on CMD. EXE and click run as administrator. Then, from the command prompt type sfc/scannow.

    -

    Finally if all else fails, you can look at the rather cryptic system event log. To do that click on start-> Control Panel-> administration-> event viewer tools. Once in Event Viewer system log-click and scroll entries looking for these "error" with indicator see if you can find guidance on where the problem may be.

    `

    When you get your system in good working condition, I invite you to back up your system up to an external hard drive and make it regular periodic updates.

    -

    I hope this helps. Good luck.

  • ADF Table retrieves all lines during the loading of the page

    Hello

    We have a requirement where we need run the query programmatically by giving the query column and its value.

    I used the code below in the AMimpl.java and calling this method during the click on the button Search my Search Page.

    I am able to get the features you want on the search page by clicking the search button.

    The question now is when the page initially loads, the table fetches all rows of the VO by default.

    Can you please let me know where I need to change so that the table will get no line on the initial load of the page?

    ' public void setVoParams (String columnName, String columnValue) {}

    ViewObject mapVO = this.getFusionSapMapping1 ();

    String whereClause = "MappingEO." + columnName + "" as: colValue ";"

    mapVO.setWhereClause (whereClause);

    mapVO.defineNamedWhereClauseParam ("colValue", null, null);

    mapVO.setNamedWhereClauseParam ("colValue", columnValue);

    mapVO.executeQuery ();

    }

    Hello

    You don't tell us your version of JDeveloper.

    An easier approach to implement your condition is to use the property refreshCondition of your iterator. Here is an example of how do: https://blogs.oracle.com/shay/entry/delay_method_execution_when_us

    Antonis

  • How to remove all items in the download under bookmark folder in the shortest time?

    I understand that all downloads from the internet and yahoo/google mail are stored in the "Download" folder I bookmarked when I want to delete. I think that if the download folder is never empty, then my mac will slow down. So I want to remove these downloads that I've seen. How can I remove all THE items in the shortest time? Deleting items, even in groups, takes a long time. Is there a method I can use so that all the items in the folder are deleted in one fell swoop?
    Thank you.
    Unguja

    Yes, it worked. Thank you very much.
    Unguja

  • How do 'Enum Control' disabled during the execution of an executable application and make activated when the application is stopped/abandoned?

    Hello

    I use a "Enum control" on the façade of an executable application built with application builder for LabVIEW 2013 full professional development system. I want Enum control remains activated prior to execution of this request so that I can choose any value from the list of available numeric values, but when I run this application; Enum control should become disabled so that the user can not select another value in the list of data during application execution values so that the default setting remains unchanged during the execution of this application. Enum control must also be activated when the application is stopped/abandoned so that the user can select any value.

    Could someone pls suggest a solution to this problem?  If I select the active state' to 'Disabled' in appearance tab then all listed values becomes disabled.

    Concerning

    Jamal

    I suggest to use the node property of persons with reduced mobility.  You can then disable the enum at the beginning of the program and then activate it in the judgment.

  • component AF:chooseDate - how to disable all dates in the past.

    Hi, I need to disable all dates in the af:chooseDate component.

    I should probably use DateListProvider for that, but don't know how.

    Thank you.

    KT - thank you very much.

    My bad, I completely missed the af minDate property: chooseDate.

    Exactly what I needed.

  • ADF: How to get all rowKeys for the table displayed in the page

    Hello

    I have table "COMPANY" where the 'COMPANY_ID' column is the primary key. I created a page simple jspx with:

    (1) a text entry to accept new IDs of company

    (2) Insert button.

    (3) af:table which displays all available in "SOCIETY" company ID

    When the user tries to enter a company code that is already present in the table I want to compare with the keys of the row of the table displayed below and if it's an already existing, I would like to send a friendly message for the user and put an end to the movement.

    So, how to extract all line keys to compare?

    Thanks in advance.

    Here's a way to check if you use the OperationBinding exception class:

    operationBinding.execute ();

    If (! operationBinding.getErrors () .isEmpty ()) {}

    There is an error

    List errors = operationBinding.getErrors ();

    Browse the list of hollow and see if there is an exception of your restrictions

    }

  • Z10 blackBerry how to remove all entries from the Local calendar?

    My calendar shows my email entered account and all is well.  However, I think that when I transferred all of my Bold 9900 he faces a bunch of entries in the local calendar (House) that I don't want.  I would like to delete all entries in the local calendar.  How can I do this?  Thank you!

    Unfortunately you can't remove individual events right now. The fastest way to remove events is the 'Month' tab, then tap and hold events in the list and select 'Delete' from the side menu.

  • How to put all through traffic the easy vpn client VPN server

    Hi people

    I want to ask you, how to put all of the server the easy vpn client VPN traffic through.

    I mean, I have a server vpn at home, and if I connect to the vpn from outside server, to be with an IP address of my home.

    There is the configuration up to now. Where is the problem?

    ROUTER1 #sh running-config

    Building configuration...

    Current configuration: 5744 bytes

    !

    ! Last configuration change at 19:51:18 UTC Wed Sep 4 2013 by cska

    !

    version 15.1

    horodateurs service debug datetime msec

    Log service timestamps datetime msec

    no password encryption service

    !

    ROUTER1 hostname

    !

    boot-start-marker

    usbflash0:CVO boot-BOOT Setup. CFG

    boot-end-marker

    !

    !

    !

    AAA new-model

    !

    !

    AAA authentication login ciscocp_vpn_xauth_ml_1 local

    AAA authorization ciscocp_vpn_group_ml_1 LAN

    !

    !

    !

    !

    !

    AAA - the id of the joint session

    !

    Service-module wlan-ap 0 autonomous bootimage

    Crypto pki token removal timeout default 0

    !

    Crypto pki trustpoint TP-self-signed-1604488384

    enrollment selfsigned

    name of the object cn = IOS - Self - signed - certificate - 1604488384

    revocation checking no

    !

    !

    TP-self-signed-1604488384 crypto pki certificate chain

    certificate self-signed 01

    3082022B 30820194 02020101 300 D 0609 2A 864886 F70D0101 04050030 A0030201

    2 060355 04031326 494F532D 53656 C 66 2 AND 536967 6E65642D 43657274 31312F30

    69666963 31363034 34383833 6174652D 3834301E 170 3133 30383239 31313539

    32395A 17 0D 323030 31303130 30303030 305A 3031 06035504 03132649 312F302D

    4F532D53 5369676E 656C662D 43 65727469 66696361 74652 31 36303434 65642D

    38383338 3430819F 300 D 0609 2A 864886 01050003, 818, 0030, 81890281 F70D0101

    8100CD 57 F1436ED2 8D9E8B99 B6A76D45 FE56716D D99765A9 1722937C F5603F9F

    528E27AF 87A24C3D 276FBA1C A5E7C580 CE99748E 39458C 74 862C 2870 16E29F75

    7A7930E1 15FA5644 D7ECF257 BF46C470 A3A17AEB 7AB56194 68BFB803 144B7B10

    D3722BDD D1FD5E99 8068B77D A1703059 9F0578C7 F7473811 0421490D 627F25C5

    4 HAS 250203 010001A 3 53305130 1 130101 FF040530 030101FF 301F0603 0F060355

    551 2304 18301680 141B 1326 C111DF7F 9F4ED888 EFE2999A 4C50CDD8 06 12301

    03551D0E 04160414 1B1326C1 11DF7F9F 4ED888EF E2999A4C 50CDD812 300 D 0609

    2A 864886 04050003 81810096 BD0C2B16 799DB6EE E2C9B7C4 72FEAAAE F70D0101

    FF87465C FB7C5248 CFA08E68 522EA08A 4B18BF15 488D D53D9A43 CB400B54 8006

    CB21BDFB AA27DA9C C79310B6 BC594A7E D6EDF81D 0DB7D2C1 9EF7251B 19A 75403

    211B1E6B 840FE226 48656E9F 67DB4A93 CE75045B A986F0AD 691EE188 7FB86D3F

    E43934FA 3D62EC90 8F37590B 618B0C

    quit smoking

    IP source-route

    !

    !

    !

    !

    CISCO dhcp IP pool

    import all

    network 192.168.1.0 255.255.255.0

    DNS-server 195.34.133.21 212.186.211.21

    default router 192.168.1.1

    !

    !

    IP cef

    No ipv6 cef

    !

    Authenticated MultiLink bundle-name Panel

    license udi pid CISCO892W-AGN-E-K9 sn FCZ1530C209

    !

    !

    username privilege 15 secret 5 cska $1$ $8j6G 2sMHqIxJX8MQU6vpr75gp1

    !

    !

    !

    !

    !

    !

    crypto ISAKMP policy 1

    BA 3des

    preshared authentication

    Group 2

    !

    Configuration group customer isakmp crypto VPNGR

    vpngroup key

    DNS 212.186.211.21 195.34.133.21

    WINS 8.8.8.8

    domain chello.at

    pool SDM_POOL_1

    ACL 120

    netmask 255.255.255.0

    ISAKMP crypto ciscocp-ike-profile-1 profile

    match of group identity VPNGR

    client authentication list ciscocp_vpn_xauth_ml_1

    ISAKMP authorization list ciscocp_vpn_group_ml_1

    client configuration address respond

    virtual-model 1

    !

    !

    Crypto ipsec transform-set esp-SHA-ESP-3DES-3des esp-sha-hmac

    !

    Profile of crypto ipsec CiscoCP_Profile1

    security association idle time 86400 value

    game of transformation-ESP-3DES-SHA

    set of isakmp - profile ciscocp-ike-profile-1

    !

    !

    Bridge IRB

    !

    !

    !

    !

    interface Loopback0

    192.168.4.1 IP address 255.255.255.0

    IP nat inside

    IP virtual-reassembly in

    !

    interface BRI0

    no ip address

    encapsulation hdlc

    Shutdown

    Multidrop ISDN endpoint

    !

    interface FastEthernet0

    !

    interface FastEthernet1

    !

    interface FastEthernet2

    !

    interface FastEthernet3

    !

    interface FastEthernet4

    !

    interface FastEthernet5

    !

    FastEthernet6 interface

    !

    interface FastEthernet7

    !

    interface FastEthernet8

    no ip address

    Shutdown

    automatic duplex

    automatic speed

    !

    type of interface virtual-Template1 tunnel

    IP unnumbered Loopback0

    ipv4 ipsec tunnel mode

    Tunnel CiscoCP_Profile1 ipsec protection profile

    !

    interface GigabitEthernet0

    Description Internet

    0023.5a03.b6a5 Mac address

    customer_id GigabitEthernet0 dhcp IP address

    NAT outside IP

    IP virtual-reassembly in

    automatic duplex

    automatic speed

    !

    wlan-ap0 interface

    description of the Service interface module to manage the embedded AP

    192.168.9.2 IP address 255.255.255.0

    ARP timeout 0

    !

    interface GigabitEthernet0 Wlan

    Description interface connecting to the AP the switch embedded internal

    !

    interface Vlan1

    no ip address

    Bridge-Group 1

    Bridge-Group 1 covering-disabled people

    !

    interface BVI1

    IP 192.168.1.1 255.255.255.0

    IP nat inside

    IP virtual-reassembly in

    !

    local IP SDM_POOL_1 192.168.4.3 pool 192.168.4.245

    IP forward-Protocol ND

    !

    !

    IP http server

    local IP http authentication

    IP http secure server

    overload of IP nat inside source list 110 interface GigabitEthernet0

    IP nat inside source static tcp 192.168.1.5 3389 interface GigabitEthernet0 3389

    IP nat inside source static udp 192.168.1.5 3389 interface GigabitEthernet0 3389

    IP nat inside source static tcp 192.168.1.5 21 interface GigabitEthernet0 21

    IP nat inside source static udp 192.168.1.5 21 interface GigabitEthernet0 21

    IP nat inside source static tcp 192.168.1.4 3389 interface GigabitEthernet0 3390

    IP nat inside source static udp 192.168.1.4 3389 interface GigabitEthernet0 3390

    overload of IP nat inside source list 120 interface GigabitEthernet0

    IP route 0.0.0.0 0.0.0.0 dhcp

    !

    exploitation forest esm config

    access list 101 ip allow a whole

    access-list 110 permit ip 192.168.1.0 0.0.0.255 any

    access list 111 permit tcp any any eq 3389

    access-list 120 allow ip 192.168.4.0 0.0.0.255 any

    !

    !

    !

    !

    !

    !

    !

    control plan

    !

    Bridge Protocol ieee 1

    1 channel ip bridge

    !

    Line con 0

    line 2

    no activation-character

    No exec

    preferred no transport

    transport of entry all

    transport output pad rlogin udptn ssh telnet

    line to 0

    line vty 0 4

    privilege level 15

    preferred transport ssh

    entry ssh transport

    transportation out all

    !

    Thanks in advance

    To do this you must make the following changes:

    (1) disable split Tunneling by deleting the ACL of your configuration of the client group.
    (2) enable NAT for VPN traffic by adding 'ip nat inside' to your virtual model of the client network to the ACL that controls your PAT.

    Edit: Theses are the changes to your config (also with a little cleaning):

    Configuration group customer isakmp crypto VPNGR

    No 120 LCD

    !

    type of interface virtual-Template1 tunnel

    IP nat inside

    !

    no nat ip inside the source list 120 interface GigabitEthernet0 overload

    !

    access-list 110 permit ip 192.168.4.0 0.0.0.255 any

    no access-list 120 allow ip 192.168.4.0 0.0.0.255 any

    Sent by Cisco Support technique iPad App

  • How to make all audio at the same level?

    I have a sequence of many clips in first pro, and I could swear I've heard of a way to make all audio on the same level or db. Is there a way to do this? I have a few clips in the timeline with different levels and should be old enough to go to manually balance their volume.

    There is a way to do what you want, but it must be used with caution.  If you open the Audio Mixer Panel, select mixer of track and the track that your clips are on.  Click on the arrow at the top left of the track work (you may need to do it twice) and and access the small white window that goes down.  (See using Adobe https://helpx.adobe.com/pdf/premiere_pro_reference.pdf page 365 if you have not done this before) In the right side of this window, right-click on one of the spikes back arrow and select Amplitude and Compression and dynamics.

    The word dynamic appears in the white window at the top of channel mixer.  Left click on the word dynamic and select Edit.  I pasted below the appropriate settings.

    If you are not familiar with Compressor/Limiter, use the parameter above.

    Now read your timeline and listen carefully while I look at the counters this setting should be good for normally recorded material, and I hope that you do have to do something more. If there is still following problems may be necessary. Schedule audio below (2) drag any clip that's too soft.  All that is too strong to do drag on the calendar below that (3). For the dynamic audio editing 2 repeat the process with the effect but change the makeup to 12.00dB.  For editing audio 3 change the makeup to 0dB setting.  It's not perfect, but it should give you a low-tech solution.   I hope this helps.

Maybe you are looking for