I try to sync a new phone 6 s with tunes11.4 and receive an error message saying that the phone unusable because it requires a more recent version of the air.  can anyone help?

I try to sync a new phone 6 s with tunes11.4 and receive an error message saying that the phone cannot be used because it requires a newer version of itunes.  I've updated the phone and itunes.  can anyone help?

Sorry, iphone and itunes.

Tags: iPhone

Similar Questions

Maybe you are looking for