Push on BES run but not on BIS.

Hello

I have develop a widget to push, test it with a sample MDS push provide with a PAP performance message well.

Then, I check in to the BlackBerry Push Essentials service for push BIS.

I try the same app with push on BIS after the SDK, I also use a PHP code to send my push message.

Got a response from the gateway push:

Response CODE: 1001
Response / / DESC: the request has been accepted for processing.

But the device never receive push them.

Y at - it something wrong in my implementation of the commissary.

';
        }

        // create a new cURL resource
        $err = false;
        $ch = curl_init();
        $messageid = microtime(true);

        $data = '--mPsbVQo0a68eIL3OAxnm'. "\r\n" .
        'Content-Type: application/xml; charset=UTF-8' . "\r\n\r\n" .
        '
        http://www.openmobilealliance.org/tech/DTD/pap_2.1.dtd">
        
        '
        . $addresses .
        '
        
        ' . "\r\n" .
        '--mPsbVQo0a68eIL3OAxnm' . "\r\n" .
        'Content-Type: text/plain' . "\r\n" .
        'Push-Message-ID: ' . $messageid . "\r\n\r\n" .
        stripslashes($message) . "\r\n" .
        '--mPsbVQo0a68eIL3OAxnm--' . "\r\n";

        // set URL and other appropriate options
        curl_setopt($ch, CURLOPT_URL, "https://pushapi.eval.blackberry.com/mss/PD_pushRequest");
            curl_setopt($ch, CURLOPT_PORT , 443);
            curl_setopt($ch, CURLOPT_SSLVERSION, 3);
            curl_setopt($ch, CURLOPT_CAINFO, getcwd()."/cacert.pem");
            curl_setopt($ch, CURLOPT_SSL_VERIFYPEER, FALSE);

        curl_setopt($ch, CURLOPT_HEADER, false);
        curl_setopt($ch, CURLOPT_USERAGENT, "My BB Push Server/1.0");
        curl_setopt($ch, CURLOPT_HTTP_VERSION, CURL_HTTP_VERSION_1_1);
        curl_setopt($ch, CURLOPT_HTTPAUTH, CURLAUTH_BASIC);
        curl_setopt($ch, CURLOPT_USERPWD, $appid . ':' . $password);
        curl_setopt($ch, CURLOPT_POST, 1);
        curl_setopt($ch, CURLOPT_POSTFIELDS, $data);
        curl_setopt($ch, CURLOPT_RETURNTRANSFER, true);

        $__extra_Headers = array(
            "Content-Type: multipart/related; boundary=mPsbVQo0a68eIL3OAxnm; type=application/xml",
            "Accept: text/html, image/gif, image/jpeg, *; q=.2, */*; q=.2",
            "Connection: keep-alive",
            "X-Rim-Push-Dest-Port: ".$appport,
            "X-RIM-PUSH-ID: ".$messageid,
            "X-RIM-Push-Reliability-Mode: APPLICATION"
        );
        curl_setopt($ch, CURLOPT_HTTPHEADER, $__extra_Headers);

        // grab URL and pass it to the browser
        $xmldata = curl_exec($ch);
        if($xmldata === false){
            echo 'Erreur Curl : ' . curl_error($ch)."\n";
        }else{
            echo 'L\'opération s\'est terminée sans aucune erreur'."\n";
        }

        // close cURL resource, and free up system resources
        curl_close($ch);

        //Start parsing response into XML data that we can read and output
        $p = xml_parser_create();
        xml_parse_into_struct($p, $xmldata, $vals);
        $errorcode = xml_get_error_code($p);
        if ($errorcode > 0) {
            echo xml_error_string($errorcode)."\n";
            $err = true;
        }
        xml_parser_free($p);

        echo 'Our PUSH-ID: ' . $messageid . "
\n"; if (!$err && $vals[1]['tag'] == 'PUSH-RESPONSE') { echo 'PUSH-ID: ' . $vals[1]['attributes']['PUSH-ID'] . "
\n"; echo 'REPLY-TIME: ' . $vals[1]['attributes']['REPLY-TIME'] . "
\n"; echo 'Response CODE: ' . $vals[2]['attributes']['CODE'] . "
\n"; echo 'Response DESC: ' . $vals[2]['attributes']['DESC'] . "
\n"; } else { echo '

An error has occured

' . "\n"; echo 'Error CODE: ' . $vals[1]['attributes']['CODE'] . "
\n"; echo 'Error DESC: ' . $vals[1]['attributes']['DESC'] . "
\n"; } } catch (Exception $e) { var_dump($e->getMessage()); } exit(); // --------------------------------------------------------------------------------------------------------------- ?>

I think I found my mistake.

In fact, I think that it is not possible to test the record push of the Simulator.
My tests of the Simulator has failed every time, but on a real device tests succeed every time.

Tags: BlackBerry Developers

Similar Questions

  • I can't open firefox running but not responding not window opens and says to close the existing window. I can't do that the computer does nothing to help. I did all the suggestions here. I uninstalled and reinstalled firefox

    Firefox does not open. I get firefox is already running but not responding no window... I tried to restart without help. I tried to put an end to the process via Ctrl + Shift + Esc and nothing firefox is registered to complete. I tried to find the application via the icon data run in the start window, I have no icon running on this system (Acer with windows vista (?)

    This has happened

    Each time Firefox opened

    The computer was hard to close and made an incorrect scan stop when it has restarted

    User Agent

    Mozilla/4.0 (compatible; MSIE 7.0; Windows NT 6.0; FunWebProducts; GTB6.5; SLCC1; .NET CLR 2.0.50727; Media Center PC 5.0; .NET CLR 3.5.30729; .NET CLR 3.0.30729)

    Uninstall and re - install Firefox does not affect your personal data and settings in your Firefox profile folder, unless specifically, you select this option when Firefox un0installing - but which removes "all your personal data and customizations.

    Have you tried to create a new profile after a cold start?
    http://KB.mozillazine.org/Creating_a_new_Firefox_profile_on_Windows

  • Reinstal Cloud but not uninstal not possible as long as the app running, but not other applications in the Task Manager

    Hello

    I need to reinstall the Cloud but uninstal is not possible as long as the app running, but not other applications in the Task Manager.

    Windows 7

    Uninstaller: "another version of office of creative cloud or an installer Adobe is running...". »

    TaskManager: browser runs only.

    Windows Installer / change: "unable to désinstaller creative cloud to desktop. You still have creative Cloud computer applications that need it.

    So, how I re install this, thank you

    Safe mode using the application of Creative Cloud Uninstaller has worked.

  • iTunes is running but not visible in Windows 10 icon

    iTunes works fine, but the window does not appear. When I run iTunes, I don't see anything. The task manager says it is running, but it does not appear in the taskbar. Do you think that there is a way to make the iTunes icon visible on the taskbar and display the iTunes window?

    I recommend that you get in touch with Apple customer, because they are the company that makes iTunes.

  • Clone fails - auxiliary database listener running but not no projection in LSNRCTL

    Hello

    I'm a DBA again working with databases Oracle 11.2.0.2 on Solaris.

    With RMAN, I'm trying to clone a database of production of server1 to the database of test on server2. The RMAN process fails with the error: RMAN-04006: auxiliary database error: ORA-12528: TNS:listener: all appropriate instances are blocking new connections.

    When I look at the auxiliary database (test), it is up and running, I can't tnsping it. However, under the heading 'lsnrctl services' I noticed that the corresponding listener is missing... even though when I check the running processes using ' ps - ef | grep LSNR", I can see the process.

    I can start and stop the listener for this database successfully, but it is still not listed under lsnrctl show or lsnrctl services. The entry for this database in the listener.ora file corresponds to the exact same format as other listeners of DB on the same server that display correctly.

    The use of generic names, the entry is:

    LOGGING_LSNR_XXXX = OFF

    LSNR_XXXX =
    (DESCRIPTION_LIST =
    (DESCRIPTION =
    (ADDRESS_LIST =
    (ADDRESS = (PROTOCOL = TCP (PORT = 1529))(HOST = server2))
    )
    )
    )

    SID_LIST_LSNR_XXXX =
    (SID_LIST =
    (SID_DESC =
    (GLOBAL_DBNAME = XXXX.domain.LOCAL)
    (SID_NAME = XXXX)
    (ORACLE_HOME = u01/app/oracle/product/11.2.0.2/dbhome_1)
    )
    )

    TRACE_LEVEL_LSNR_XXXX = OFF

    Our previous DBA is not available for assistance.

    I would greatly appreciate any ideas or advice.

    Thank you.

    user13258951 wrote:
    I've renamed the listener.ora and stopped and restarted the listener, wait a minute, as you suggest. All databases on the server, but two appear in the commands below. One of the two that does not appear is the database in question. Is this provides additional clues? Thank you.

    It suggests to me that two missing databases have a value assigned to their 'LOCAL_LISTENER' init parameter, pointing to the non-standard port.

    It gives to think that the missing DBA has tried to look at things and created an environment unnecessarily complex.

    A single listener, with the default name for LISTENER, using the default port of 1521 is quite capable of--indeed, was designed for - several databases of several versions of several ORACLE_HOMEs service. Try to "name" a listener or put it on a default undefined port does nothing but confuse those who come behind.

    But I digress from the topic of your immediate problem. Return the listener.ora file, restart your receiver. Then note what JohnWatson said about the way of lsnrctl commands addressed to this non-standard listener.

    Published by: EdStevens on 8 may 2013 14:23

  • Command line query runs, but not Planner

    Control-M allows us to schedule some shell scripts to be run on a Solaris server. Some of the scripts need access to an Oracle database and in this case our security team will include the DB user and password in the script, then encrypt and sys admin team plans the script encrypted with Control-M. That works very well, but we tried to have the DB user and the password on a separate encrypted file so that we don't have to ask for the encryption of file each time it is necessary to modify a script (it is a test environment).

    We have the script in ~/system_name/scripts, the query to ~/system_name/sql and the encrypted file and the key to ~/system_name/keys. SQLPlus call in the script is:

    $(ORACLE_HOME) / bin/sqlplus "' decrypt - a 3des - k. /... /Keys/Key.3DES.System - i. /... /Keys/login.system'"@instance_name < < EOF.
    @$ {DIR_SQL} / TEST_QUERY. SQL
    quit smoking
    EXPRESSIONS OF FOLKLORE

    The security analyst has successfully tested is command line, but when we schedule with Control-M job abends and we get the following in the DD:

    + decrypt - a 3des - k. /... /Keys/Key.3DES.System - i. /... / Keys/login. System
    decrypt: cannot open the. /... /Keys/Key.3DES.System
    decrypt: invalid key.
    + /u00/app/oracle/product/11.1.0/db_1/bin/sqlplus @instance_name
    + 0 < <
    @/ sistemas/HMP/system_name/sql/TEST_QUERY. SQL
    quit smoking

    SQL * more: version 11.1.0.6.0 - Production on Mon May 3 09:41:55 2010

    Copyright (c) 1982, 2007, Oracle. All rights reserved.

    SP2-0310: cannot open the file 'instance_name.sql '.
    Enter the user name: SP2-0306: invalid option.
    Usage: CONN [ECT] [connection] [AS {SYSDBA |}] SYSOPER | SYSASM}]
    where < logon >: = < user > [< password >] [@ < connect_identifier >] [edition = valu\
    e] | /
    SP2-0306: invalid Option.
    Usage: CONN [ECT] [connection] [AS {SYSDBA |}] SYSOPER | SYSASM}]
    where < logon >: = < user > [< password >] [@ < connect_identifier >] [edition = valu\
    e] | /
    Enter the password:
    ERROR:
    ORA-12545: Connect failed because target host or object does not exist


    SP2-0157: unable to connect to ORACLE after 3 attempts, leaving SQL * more

    0000000080

    Any ideas?

    Looks like the order is subdivided in some way - connecting to sqlplus is performed before finishing the entire string
    He seems to see the @instance_name as a script to run instead of a database to connect to.

    Is the database on the same server as the script?
    If so, try to set your environment to the correct databsae, so that you can omit the syntax @instance_name part and see if it helps

    Just noticed also the refusal to open the script to decrypt. It would seem that uyou do not use a full path name. Have you checked that the scheduled task directroy starts in? You may try to run some environment specific scripts first.

    Published by: Guy on May 5, 2010 07:43

  • FFis already running but not responding do not mistake... Cannot delete the parent.lock "in use" what to do now?

    I keep getting FF or error that responded to the questionnaire. When I close it I get "your FF profile cannot be loaded.

    I read about the removal of the parent.lock. When I try to delete told me "can not delete the file because it is being used.

    So what do I do now to get FF going

    You can delete the file immediately after the computer starts?

    Help if you start Windows Explorer as an administrator?

    You can create a new profile as a test to see if your profile is the source of the problem.

    See "create a profile":

    If the new profile works then you can transfer files from a profile already used in the new profile, but be careful not to copy files corrupted to avoid transporting more problems.

  • 5324 SSH running but not asking not password and not running through my firewall

    I picked up a Dell Powerconnect 5324 off ebay and wiped the configs, updated the firmware and got it mostly set up for what are my needs but I don't know why good SSH than active and working locally on the same subnet as the ip of the vlan has the following two issues:

    1 SSH works but only ask "open as:" then "user name:" and never will prompt you for the password. It just goes straight to an enable command prompt

    2. I can't work through my firewall DNAT. It's not critical, but I removed the access list that I had just to test and still no go.

    Here is my config:

    interface port-channel 1
    Description Fiber4GE
    FlowControl auto
    output
    interface port-channel 2
    Description Copper2GE
    FlowControl auto
    output
    interface port-channel 1
    switchport mode trunk
    output
    interface port-channel 2
    switchport mode trunk
    output
    serial interface ethernet g(19-20)
    switchport mode trunk
    output
    database of VLAN
    VLAN 96,172,192
    output
    interface ethernet g1
    switchport access vlan 96
    output
    Beach port-channel interface (1 - 2).
    switchport trunk allowed vlan add 96
    output
    Beach port-channel interface (1 - 2).
    switchport trunk allowed vlan add 172
    output
    serial interface ethernet g(2-18)
    switchport access vlan 192
    output
    Beach port-channel interface (1 - 2).
    switchport trunk allowed vlan add 192
    output
    interface ethernet g1
    switchport forbidden vlan add 192
    output
    interface vlan 96
    name Comcast
    output
    interface vlan 172
    name iSCSI-SAN
    output
    interface vlan 192
    network name
    output
    serial interface ethernet g(19-20)
    Auto mode channel-group 2
    output
    serial interface ethernet g(21-24)
    Auto mode channel-group 1
    output
    interface vlan 192
    192.168.1.251 IP address 255.255.255.0
    output
    line console
    exec-timeout 20
    output
    ssh line
    exec-timeout 20
    output
    ssh line
    password * redacted * encrypted
    output
    line console
    password * redacted * encrypted
    output
    enable level 15 password * redacted * encrypted
    username admin password * redacted * encrypted
    password username davery * redacted * level encrypted 15
    property intellectual ssh server
    The https server IP
    clock timezone-8
    customer SNTP enable vlan 192
    clock source sntp
    unicast SNTP client enable
    unicast SNTP client survey
    survey of SNTP server 192.168.1.1
    IP - local.dom domain name

    I think I see what is missing, we must add this command so that he can ask for the password.

    Console (config) # aaa authentication login default line

    Console (config) # line ssh

    default authentication logon console(config-Line) #.

    Let me know if it works

  • Firfox download for Win 7 - get "run" but not the start - cannot load Firefox

    My rd Hard Drive crashed... I installed Win 7 64 bit again. I can't get Firefox to install. It happens at installation and stops - it won't work.
    I had Firefox for years and have run it fine on the 64 bit of Windows 7 without problem...
    What can I do to get Firefox on my PC?

    Try the complete installation program.

  • Dreameaver CS3 running but not able to update the software.

    The updater is always answer "there is no update at this time." I think it's a thing of firewall with my pc windows 7 (that I can't change it). Dreamweaver is currently the 3481 version and I know that there are at least build 5861. Y at - it a link to download the latest version of adobe manually?

    Hi Ken,

    Please visit the link below and find the update for Dreamweaver.

    Updates

    Thank you

    Atul Saini

  • I accidentally hit some keys on the keyboard and firfox is now lost at the top of the screen, I do not see the menu items if I push the slider to the top of some of the best appear on my screen, but not all please can you help me?

    I accidentally hit some keys on my keyboard. I don't know what keys hit my hand, but it caused Firefox to go beyond my screen visible at the top. The basis of Firefox is always correct and views correctly. The Chief is absent, but I can't access my menus such as bookmarks etc Articles. The screen drops down, if I push my cursor upwards, but not enough to show menu items. Can you please help?

    Press F11 to exit full-screen.

  • Firefox is already running but is not responding. The old process of Firefox must be closed to open a new window.

    When I try to open Firefox, I get this message:
    "Firefox is already running but is not responding. The old process of Firefox must be closed to open a new window. »
    I then clicked close firefox, but the problem was solved not so I uninstalled and reinstalled firefox, but it's the same thing.
    At this point, I went to support Mozilla and tried the steps described in the article, "Firefox is already running but is not responsible for - How to fix error message", but the firefox.exe process was not in the processes tab in windows Task Manager. While he was in the Details tab, when I tried to put an end to the process, I received this message:

    "The operation could not be completed. Access is denied. "

    What can I do to fix this?

    Thank you.

    Usually when you stop and restart Windows, Firefox is not running and can be started normally.

    Firefox is set to start automatically with Windows? Microsoft has a utility to investigate what is set to happen at startup: https://technet.microsoft.com/en-us/sysinternals/bb963902.aspx

    It is possible that something is triggering a process in your default browser and it is the hanging of Firefox. You can try to change your default browser to IE (IE can offer to do when you start) before the shutdown and restart Windows to see if it makes a difference.

  • I get a message "Firefox is already running but is not responding.". I did everything here Inc. uninstalled and re-installed. Help!

    I am using a HP desktop computer with Vista Home premium. I get a "Firefox is already running, but does not." message. I did everything on the other forums and it did not help. I even uninstalled and reinstalled Firefox. I still get the same message.

    You are able to start Firefox in Safe Mode or start the Profile Manager?

    (1) safe Mode

    It is a standard diagnostic tool to disable some advanced features of Firefox and extensions. More info: questions to troubleshoot Firefox in Safe Mode.

    You can start Firefox in Safe Mode by holding down the SHIFT key when you start Firefox. (If you get directly in a new window, you must exit all Firefox Windows first).

    A small dialog box should appear. Click on 'Start mode safe' (not reset).

    It will start?

    (2) the Profile Manager

    This assumes that firefox.exe is not running.

    Start in Manager profiles using Start > Search box (or run):

    firefox.exe -P
    

    When you get the Profile Manager window, do not delete anything!

    No matter what time you want to switch profiles, you exit Firefox and return to this dialog box.

    If you select your default profile and click Start, Firefox start?

  • Thunderbird is already running but is not responding. To open a new window, you must close the current Thunderbird process, or restart your system.

    Thunderbird doesn't start and gives this message in a message window

    Thunderbird is already running but is not responding. To open a new window, you must close the current Thunderbird process, or restart your system.

    Any help would be appreciated.

    See:

  • Firefox is already running but is not

    I started my computer and I tried to open firefox but a windows appears and say Firefox is already running, but does not. To open a new window, you must close the existing windows, and try again.

    The problem is that he is not running. I opened my task manager and there are no programs running, I have check the processes running and nothing to do with Mozilla firefox is here. How can it already be running if it is not open?

    I actually fixed. I was looking for in c:\users/myname/appdata/local/mozilla/firefox/profiles

    I looked in
    c:\Users/MyName/appdata/roaming/Mozilla/Firefox/profiles and found the profile.locked file and deleted. Works fine again.

Maybe you are looking for