Access to a component (ImageView) inside the ListView

I have a ListView in which there is an ImageView. When any item is typed, I manage onTriggered Signal. At this signal, I want access the ImageView the ListItem that is typed. How to do this?

I think that the best workaround is using your own object as a data model to the image property. Then you can change it in onTriggered signal just like that ListItemData.imageSource = newImageSource

for example:

// If you are using JSON add a new property which is a imageSource

model.append({"name": "bla bla", "imageSource": "bla bla"})

or write a derivered of QObject class as in this example

https://developer.BlackBerry.com/native/reference/Cascades/bb__cascades__GroupDataModel.html

but hope that you use GroupDataModel

Another solution is to write your own function and use instead onTriggered

for example (I like examples of the )

ListView{

    function myOwnFunction(indexPath, imageView){
        var item = dataModel.data(indexPath);
        if (item){
            // set new image
        }
    }
}

// And access it from ListItemComponent

ListItemComponent {
    type: ""
    Container {
        id: root

        onTouch{
            root.ListItem.view.myOwnFunction(root.ListItem.indexPath, imageView)
        }
    }

Tags: BlackBerry Developers

Similar Questions

  • Change the State of all the Image inside the list view toggle button when a list is tap

    Hi, please help, is there a way to change the State of a toggle button to image inside the listview where in when you type a list, the toggle button in the list state change and the other toggle button will be set to their default image? the list has a defined Image toggle button to check both...

    
    ListView {
    
                        layout: GridListLayout {
                            cellAspectRatio: 1.4
                        }
    
                        id: denominationList
                        dataModel: _model.denominationModel
    
                        listItemComponents: [
    
                            ListItemComponent {
    
                                id: component
                                type: "item"
                                CustomListItem {
    
                                    id: itemRoot
                                    dividerVisible: false
                                    highlightAppearance: HighlightAppearance.None
    
                                    Container {
                                        id: fieldContainer
                                        topPadding: 5
                                        leftPadding: 10
                                        rightPadding: 10
                                        bottomPadding: 5
                                        //maxWidth: 270
    
                                        layout: DockLayout {}
    
                                        Container {
                                            id: amountContainer
                                            //topPadding: 
    
                                            layout: DockLayout {}
                                            background: Color.create("#ffffff")
                                            horizontalAlignment: HorizontalAlignment.Center
                                            verticalAlignment: VerticalAlignment.Center
    
                                            ImageView {
                                                id: amountBorder
                                                preferredWidth: 400
                                                imageSource: "asset:///images/flux/amount-border-other.png"
                                            }
    
                                            Container {
                                                horizontalAlignment: HorizontalAlignment.Center
                                                verticalAlignment: VerticalAlignment.Center
                                                layout: StackLayout {
                                                    orientation: (!(ListItemData.name > 4) ? LayoutOrientation.TopToBottom : LayoutOrientation.LeftToRight)
                                                }
    
                                                Container {
                                                    horizontalAlignment: HorizontalAlignment.Center
                                                    verticalAlignment: VerticalAlignment.Top
                                                    visible: (ListItemData.name.length > 4)
    
                                                    preferredHeight: 60
    
                                                    Label {
                                                        id: loadPromoName
                                                        textFit.mode: LabelTextFitMode.FitToBounds
                                                        //multiline: true
                                                        visible: (ListItemData.name.length > 4)
    
                                                        textStyle{
                                                            fontSize: FontSize.Medium
                                                            fontWeight: FontWeight.W300
                                                            color: Color.create("#b9babe")
                                                            textAlign: TextAlign.Center
                                                        }
    
                                                        text: ListItemData.name
                                                    }
                                                }
    
                                                Container {
                                                    verticalAlignment: VerticalAlignment.Center
                                                    topPadding: 8
                                                    rightPadding: 0
                                                    ImageView {
                                                        visible: (ListItemData.name.length <= 4)
                                                        preferredHeight: 40
                                                        imageSource: "asset:///images/flux/pesosign-amount.png"
                                                    }
                                                }
    
                                                Container {
                                                    verticalAlignment: ((ListItemData.name.length > 4) ? VerticalAlignment.Center : VerticalAlignment.Bottom)
                                                    horizontalAlignment: HorizontalAlignment.Center
                                                    leftPadding: 0
    
                                                    Label {
                                                        id: amountLabel
                                                        textFit.mode: LabelTextFitMode.FitToBounds
    
                                                        textStyle{
                                                            fontSize: FontSize.XLarge
                                                            fontWeight: FontWeight.W300
                                                            color: Color.create("#b9babe")
                                                            textAlign: TextAlign.Center
                                                        }
    
                                                        text: ListItemData.amount
                                                    }
                                                }
                                            }
                                        }
                                    }
                                }
                            }
                        ]
                        onTriggered: {
                            var selectedItem = dataModel.data(indexPath);
    
                        }
                    }
                }
    

    link the button to a property of an element, and then change all the elements in the datamodel. ListView reflects these changes.

  • ListView with TextField inside the component and requestFocus()

    Hello

    I'm trying to implement the logical: when the page with ListView is indicated - start editing (see the keyboard) in the field of specific text that is part of the agenda of the ListView.

    TextField.requestFocus () works very well if it is called some time later, after loading the page (assuming that when ListView load model and created the UI elements).

    How to identify when requestFocus() is success? onCreationCompleted for TextField/ListView does not work.

    It can be done with QTimer but I want to keep it as a backup plan.

    Thank you

    Can you try to add to your Page (or your ListView):
    attachedObjects:]
    {RenderFence}
    raised: true
    onReached: textFieldName.requestFocus)
    }
    ]

  • Access CPP of the ListView in QML function

    ListView {
                id: listView
                dataModel: dataModel
                listItemComponents: [
                    ListItemComponent {
                        type: "item"
                        StandardListItem {
                            title: ListItemData.title
                            description: app.formatDate(ListItemData.pubDate);
                        }
                    }
             ]
    }
    

    and in the PRC

    QString ApplicationUI::formatDate(QString date) {
        return "bla";
    }
    

    Function call leave outer ListView works well, but I cannot access any function defined outside ListView!

    In this case, I get asset:///blabla.qml:16: ReferenceError: can't find variable: app

    How can I call it?

    For some strange reason the listItemComponents are outside the normal code flow. But you can bypass. Give your listItemComponent a name/id. You can reference it trough the parent ListView. Something like this should work:

    StandardListItem {
     id: mscurli
     title: ListItemData.OriginalTitle;
     description: ListItemData.TheatreAndAuditorium
     status: mscurli.ListItem.view.getShowTime(ListItemData.dttmShowStart);
    }
    

    I used a set inside my ListView simple helper function to get the C++ code:

    function getShowTime(str) {
     return _myapp.formatTime(str);
    }
    
  • To access the values from the row outside the ListView ListItem

    Hello

    I spent two hours browsing the forums and documentation with no chance of finding a solution on how to access the list item data from outside the listview.

    Let explain me my code. It is marked with I work and what does not work and its expected behavior.

    Should work behavior


    Tapping & getting data

    The arrayDataModel is filled with 4 rows. Firstly the list item, second item in the list... etc.

    • Tapping on the order of the day, label with the id of triggeredText displays the value of a threaded list item.
    • The index of the tapped icon appears in the label with the id of triggerredIndex.

    Incrementing Index using ActionItems onBar

    By pressing action items 'previous' and 'next', you can increment the index value to the label with the id of triggeredIndex. The order of the index is 0-4, even as total of the items in the list.

    How to extract data from the index when the value of triggeredIndex?

    Buttons

    The buttons at the bottom of the screen... Select 1, select the 2nd, 3rd Select should select indexes 0,1,2 of the list and display the value in triggeredText and triggeredIndex. They do not work.

    How did I pull the values when you click the buttons?

    import bb.cascades 1.3
    
    TabbedPane {
        id: root
        showTabsOnActionBar: false
    
        Tab {
            id: mainTab
            title: "Test List"
                Page {
                    id: mainPage
                    titleBar: TitleBar {
                        title: "List Traversal Test"
                    }
                    actions: [
                        ActionItem {
                            title: "Previous"
                            ActionBar.placement: ActionBarPlacement.OnBar
                            onTriggered: {
                                // get current selected index from list=
                                var currentIndex = parseInt(triggeredIndex.text);
    
                                if(currentIndex <= 0){
                                    //do nothing already at first item
                                }else{
                                    // subtract 1 from index ( ci - 1) ?
                                    var newIndex = parseInt(triggeredIndex.text) - 1;
    
                                    // show data from new selected index
                                    // ???
    
                                    // triggeredItem.text = XXX // the data
                                    // ???
    
                                    // triggeredIndex.text = X // the current index
                                    triggeredIndex.text = newIndex;
                                }
                            }
                        },
                        ActionItem {
                            title: "Next"
                            ActionBar.placement: ActionBarPlacement.OnBar
                            onTriggered: {
                                // get current selected index from list=
                                var currentIndex = parseInt(triggeredIndex.text);
    
                                if(currentIndex == 4){
                                    //do nothing already at lastitem
                                }else{
                                // add 1 to index ( ci + 1) ?
                                var newIndex = parseInt(triggeredIndex.text) + 1
    
                                // show data from new selected index
                                // ???
    
                                // triggeredItem.text = XXX // the data
                                // ???
    
                                // triggeredIndex.text = X // the current index
                                triggeredIndex.text = newIndex;
                            }
                            }
                        },
                        ActionItem {
                            title: "Clear"
                            ActionBar.placement: ActionBarPlacement.OnBar
                            onTriggered: {
                                // set current index to 0 (top item in list)
                            }
                        }
    
                    ]
                    Container {
                        preferredHeight: maxHeight
                        layout: StackLayout {
                            orientation: LayoutOrientation.TopToBottom
                        }
    
                        Label{
                            id: triggeredItem      // value of listitem from current index
                            text: "0"
                        }
                        Label{
                            id: triggeredIndex    // current index
                            text: "0"
                            onTextChanged: {
                                // set triggeredItem.text to contents of selected ListItem with same index
                                // STUCK HERE cannot access ListItem.dataModel(indexPath) from here....
                            }
    
                        }
                        Container{
                            ListView {
    
                                id: theList
                                objectName: "dalist"
                                dataModel: ArrayDataModel {
                                    id: theListModel
                                }
                                listItemComponents: ListItemComponent {
                                    StandardListItem {
                                        id: itemRoot
                                        title: ListItemData
                                    }
    
                                }
                                onTriggered: {
                                    var si = dataModel.data(indexPath);
                                    triggeredItem.text = "LIST ITEM CONTENT: " + si;  //set content when user taps on item
                                    triggeredIndex.text = "LIST ITEM INDEX INDEX: " + indexPath;  // set index when user taps
                                }
    
                                onSelectionChanged: {
                                    //console.log(selected);
                                }
    
                                onCreationCompleted: {
    
                                    //add some data to the listview
                                    theListModel.append("First List Item");
                                    theListModel.append("Second List Item");
                                    theListModel.append("Third List Item");
                                    theListModel.append("Fourth List Item");
                                }
                            }
    
                        }
                        Container{
                            layout: StackLayout {
                                orientation: LayoutOrientation.LeftToRight
                            }
                        Button{
                            text: "Select 1st"
                            onClicked: {
                                theList.clearSelection();
                                theList.select(0);
    
                            }
                        }
                        Button{
                            text: "Select 2nd"
                            onClicked: {
                                theList.clearSelection();
                                theList.select(1);
    
                            }
                        }
    
                        Button{
                            text: "Select 3rd item"
                            onClicked: {
    
                                //expected behaviour is to show data from Third List Item
    
                                // triggeredIndex.text = INDEX 3
                                // triggeredText.text = (DATA FROM THIRD LIST ITEM)
    
                                // THIS IS NOT WORKING ....
                                theList.clearSelection();
                                theList.select(2);
                                console.log(theList.dataModel(3));
                                triggeredItem.text = theListModel.dataModel(3);
    
                            }
                        }
                    }
                   }
                }
            }//tab
    }
    

    Thank you and have a happy and healthy 2015!

    Your help will be greatly appreciated.

    I ran and got this:

    asset:///main.qml:161: TypeError: Result of expression 'theList.dataModel' [bb::cascades::ArrayDataModel(0x1091a838)] is not a function.
    

    But it works

    theListModel.data([3])
    

    But this isn't the solution, you have a more serious problem. You select a value, you trigger. If you add this in onTriggered you select it (and you can see that it changes color when it is selected).

    theList.select(indexPath);
    

    If you want to use option to deselect

    theList.select(indexPath, !theList.isSelected(indexPath));
    

    And if you want to have that one chose this

    theList.clearSelection();
    theList.select(indexPath);
    

    Inside the button 'Select the 3rd point' allows to select programmatically

    theList.select([2]);
    

    It works but I'm not sure what you're trying to do

  • To access the instance of the ListView onTriggered event ListItemComponent

    Hello

    I'm pulling out my hair with this!

    I have a ListItemComponent in my ListView, and I want to access the component instance in the onTriggered of my ListView. I have the row, but I can't work on how to find the actual view.

    Simple example:

    {To ListView

    ID: myListView

    dataModel: myDataModel

    layout: {FlowListLayout}
    listItemComponents:]
    {ListItemComponent}
    type: 'imageItem.
    {GalleryImages}
    }

    ]

    onTriggered: {}

    It's easy

    var point = dataModel.data (row);

    BUT HOW to ACCESS the GalleryImages instance for the row?

    }

    ...

    I'm sure it's really simple, but have been hitting my head against it for 2 days!

    C

    https://developer.BlackBerry.com/Cascades/reference/bb__cascades__listview.html

    your variable 'point' reference the underlying data in the datamodel - it does not refer to the list Visual element (i.e. ListItemComponent).

    You need to move your manager in the ListItemComponent - and probably change in notecard or anything that supports your component of GalleryImages.

  • Selection of setting inside the component af:table LOV

    Hi all

    I use Jdev 12 c.

    I can't find anything on the definition of the selection of a component of SelectOneChoice when it is inside a table.

    My use case: I'm iteration in a list of serial numbers, and ask a CreateWithParams liaison to a number of different parameters.  Those new lines appear in an af:table component.  One of these parameters can take the values 1, 2 or empty.  For this attribute, I have set up a selectOneChoice with a fixed/static LOV to the choice.  Now, the CreateWithParams is correctly set the value of the ViewObject line, but I don't know how to set the selection SelectOneChoice the correct value.  It is not done automatically.  Y at - it a way I can get the RichSelectOneChoice component in my managed java bean for each line so that I can manually set the selection of the component?

    Thanks for reading.

    Lance

    Solved the problem with a static list display object.  It was with my link layer.  The LOV was not part of the binding of the tree, so he was not updated correctly.  For those who have this problem in the future, put in place a static list view object and access it like a LOV in the view object related to af: table.

  • Why can't I access object inside the ListItemComponent.onCreationCompleted C++... ?

    Hello world

    My application has a HTTP connection to retrieve the XML stream and insert data to the ListView using DataSource and DataModel, and I want to hear at each of its ListView ListItem is created and completely to use a ListItemData for my c++ object. So I write my code like this

    In main.cpp

    int main (int argc, char * argv)

    {

    App app (argc, argv);

    new MyApp (&app);)

    returnApplication::exec();

    }

    In MyApp.cpp

    MyApp::MyApp (bb::cascades:Application * app): //constructor

    {QObject (app)}

    QmlDocument * qml = QmlDocument::create("asset:///main.qml").parent(this);

    QML-> setContextProperty ("app", this);

    AbstractPane * stream = qml-> createRootObject)

    App-> setScene (NCA);

    }

    void MyApp::doMyFunction (const QString & someData) {}

    qDebug()< "yes!!="">

    }

    In main.qml
    {Page}

    {Of container

    {To ListView

    dataModel: myDataModel

    listItemComponents:]

    {ListItemComponent}

    type: 'point '.

    {Of container

    onCreationCompleted: {}

    Console.log ("-LISTITEM ONCREATION COMPLETED");

    app.doMyFunction (ListItemData.someData);    //<  but="" console="" print="" about="" "can't="" find="" variable="" "app"="">

    }

    }

    }

    ]

    } //end listview

    } //end container

    onCreationCompleted: {}

    myDataSource.load ();

    }

    attachedObjects:]

    {GroupDataModel}

    ID: myDataModel

    },

    DataSource {}

    ID: myDataSource

    Source: "some URLs to get RSS... blah blah."

    type: DataSource.Xml

    onDataLoaded: {}

    myDataModel.clear ();

    myDataModel.insertList (data);

    }

    ]

    }

    I try to run mycode. But a console is printed on "can't find variable: app". " How can I solve this problem?

    Thanks for any suggestions.
    MAZ

    Its because the listitem is not in the same document as the Page tree really, he lives with ListView and does not have direct access to the elements of the Page.

    What you can do is create a javascript function in the ListView, and then the listitemcomponent facing, which in turn can relay to your environment variable "app."

    int listitemcomponent add id: itemContainer your container can
    itemContainer.ListItem.view.someFunctionDefinedInTheListView (data)

    in the listview:

    function somefunctiondefinedinlistview (data) {}
    app.doMyFunction (data)
    }

  • ASA 5505 VPN established, cannot access inside the network

    Hi, I recently got an ASA 5505, and I spent weeks to find a way to set up a VPN on it.

    After a few days, I finally found the solution to connect to my ASA with a VPN client yet and cannot access devices that are connected to the ASA.

    Here is my config:

    ASA Version 8.2 (5)
    !
    hostname asa01
    domain kevinasa01.net
    activate 8Ry2YjIyt7RRXU24 encrypted password
    2KFQnbNIdI.2KYOU encrypted passwd
    names of
    !
    interface Ethernet0/0
    switchport access vlan 2
    !
    interface Ethernet0/1
    !
    interface Ethernet0/2
    !
    interface Ethernet0/3
    switchport access vlan 5
    !
    interface Ethernet0/4
    !
    interface Ethernet0/5
    !
    interface Ethernet0/6
    !
    interface Ethernet0/7
    !
    interface Vlan1
    nameif inside
    security-level 100
    IP 192.168.1.1 255.255.255.0
    !
    interface Vlan2
    nameif outside
    security-level 0
    IP address dhcp setroute
    !
    interface Vlan5
    No nameif
    security-level 50
    IP 172.16.1.1 255.255.255.0
    !
    passive FTP mode
    DNS server-group DefaultDNS
    domain kevinasa01.net
    permit same-security-traffic intra-interface
    Remote_Kevin_splitTunnelAcl list standard access allowed 192.168.1.0 255.255.255.0
    inside_nat0_outbound to access ip 192.168.1.0 scope list allow 255.255.255.0 192.168.254.0 255.255.255.240
    inside_nat0_outbound list of allowed ip extended access all 192.168.254.0 255.255.255.0
    inside_nat0_outbound list of allowed ip extended access entire 192.168.1.0 255.255.255.0
    sheep - in extended Access-list allow IP 192.168.254.0 255.255.255.0 192.168.1.0 255.255.255.0
    access extensive list ip 192.168.254.0 outside_access_in allow 255.255.255.0 any
    access extensive list ip 192.168.254.0 inside_access_in allow 255.255.255.0 any
    pager lines 24
    asdm of logging of information
    Outside 1500 MTU
    Within 1500 MTU
    pool pool 192.168.254.1 - 192.168.254.10 255.255.255.0 IP mask
    ICMP unreachable rate-limit 1 burst-size 1
    don't allow no asdm history
    ARP timeout 14400
    Global 1 interface (outside)
    NAT (outside) 1 192.168.254.0 255.255.255.0
    NAT (inside) 0 access-list sheep - in
    NAT (inside) 1 192.168.1.0 255.255.255.0
    NAT (inside) 1 0.0.0.0 0.0.0.0
    Access-group outside_access_in in interface outside
    Timeout xlate 03:00
    Timeout conn 01:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
    Sunrpc timeout 0:10:00 h323 0:05:00 h225 mgcp from 01:00 0:05:00 mgcp-pat 0:05:00
    Sip timeout 0:30:00 sip_media 0:02:00 prompt Protocol sip-0: 03:00 sip - disconnect 0:02:00
    Timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute
    timeout tcp-proxy-reassembly 0:01:00
    Floating conn timeout 0:00:00
    dynamic-access-policy-registration DfltAccessPolicy
    Enable http server
    http 192.168.1.0 255.255.255.0 inside
    No snmp server location
    No snmp Server contact
    Server enable SNMP traps snmp authentication linkup, linkdown cold start
    Crypto ipsec transform-set esp-SHA-ESP-3DES-3des esp-sha-hmac
    Crypto ipsec transform-set ESP-3DES-MD5-esp-3des esp-md5-hmac
    Crypto ipsec transform-set ESP-DES-MD5 esp - esp-md5-hmac
    Crypto ipsec transform-set ESP-AES-128-SHA aes - esp esp-sha-hmac
    Crypto ipsec transform-set ESP-AES-192-SHA esp-aes-192 esp-sha-hmac
    Crypto ipsec transform-set ESP-AES-128-MD5-esp - aes esp-md5-hmac
    Crypto ipsec transform-set ESP-AES-192-MD5 esp-aes-192 esp-md5-hmac
    Crypto ipsec transform-set ESP-AES-256-SHA 256 - aes - esp esp-sha-hmac
    Crypto ipsec transform-set ESP-AES-256-MD5 esp-aes-256 esp-md5-hmac
    Crypto ipsec transform-set ESP-DES-SHA esp - esp-sha-hmac
    life crypto ipsec security association seconds 28800
    Crypto ipsec kilobytes of life - safety 4608000 association
    crypto dynamic-map SYSTEM_DEFAULT_CRYPTO_MAP 65535 pfs Group1 set
    Crypto dynamic-map SYSTEM_DEFAULT_CRYPTO_MAP 65535 value transform-set ESP-AES-128-SHA ESP-AES-128-MD5 ESP-AES-192-SHA ESP-AES-192-MD5 ESP-AES-256-SHA ESP-AES-256-MD5 ESP-3DES-SHA MD5-ESP-3DES ESP-DES-SHA ESP-DES-MD5
    outside_map card crypto 65535-isakmp dynamic ipsec SYSTEM_DEFAULT_CRYPTO_MAP
    outside_map interface card crypto outside
    crypto ISAKMP allow outside
    crypto ISAKMP policy 10
    preshared authentication
    3des encryption
    sha hash
    Group 2
    life 86400
    Telnet timeout 5
    SSH timeout 5
    Console timeout 0
    management-access inside
    dhcpd outside auto_config
    !
    dhcpd address 192.168.1.5 - 192.168.1.36 inside
    dhcpd allow inside
    !

    a basic threat threat detection
    Statistics-list of access threat detection
    no statistical threat detection tcp-interception
    WebVPN
    internal Remote_Kevin group strategy
    attributes of Group Policy Remote_Kevin
    value of server DNS 192.168.1.12 192.168.1.13
    VPN - connections 3
    Protocol-tunnel-VPN IPSec
    Split-tunnel-policy tunnelspecified
    value of Split-tunnel-network-list Remote_Kevin_splitTunnelAcl
    kevinasa01.NET value by default-field
    username kevin mz6JxJib/sQqvsw9 password encrypted privilege 0
    username kevin attributes
    VPN-group-policy Remote_Kevin
    type tunnel-group Remote_Kevin remote access
    attributes global-tunnel-group Remote_Kevin
    address-pool
    Group Policy - by default-Remote_Kevin
    IPSec-attributes tunnel-group Remote_Kevin
    pre-shared key *.
    !
    class-map inspection_default
    match default-inspection-traffic
    !
    !
    type of policy-card inspect dns preset_dns_map
    parameters
    maximum message length automatic of customer
    message-length maximum 512
    Policy-map global_policy
    class inspection_default
    inspect the preset_dns_map dns
    inspect the ftp
    inspect h323 h225
    inspect the h323 ras
    inspect the rsh
    inspect the rtsp
    inspect esmtp
    inspect sqlnet
    inspect the skinny
    inspect sunrpc
    inspect xdmcp
    inspect the sip
    inspect the netbios
    inspect the tftp
    Review the ip options
    inspect the icmp
    inspect the icmp error
    !
    global service-policy global_policy
    context of prompt hostname
    no remote anonymous reporting call
    Cryptochecksum:2bb1da52d1993eb9b13c2f6dc97c16cd
    : end

    Thank you

    Hello

    I read your message quickly through my cell phone. I don't know why you have spent your config twice. Maybe a typo issue.

    I see the acl sheep in the wrong way. I mean 192.168.254 are your pool VPN and 192.168.1.0 your local LAN.

    The acl must be:

    sheep - in extended access-list permit ip 192.168.1.0 255.255.255.0 192.168.254.0 255.255.255.0

    For nat (inside), you have 2 lines:

    NAT (inside) 1 192.168.1.0 255.255.255.0 ==> it is redundant as the 1 below does the same thing with more networks if there is inside side. You can delete it.
    NAT (inside) 1 0.0.0.0 0.0.0.0

    Why are you doing this nat (outside)?

    NAT (outside) 1 192.168.254.0 255.255.255.0

    Here are the first questions that I have seen by reading through my mobile. Let's change this and let me know. I'll take a look later with a computer (tonight or tomorrow)

    Thank you.

    PS: Please do not forget to rate and score as good response if this solves your problem.

  • Since the reinstallation of Windows 7 I have same Wifi access so my laptop and I heard a small noise from inside the Tower

    Since the reinstallation of Windows 7 I have Wifi access even if my laptop and tablet of my wife can become if the router is OK. Also, it restarts or freeze without reason. Sometimes I hear a metallic noise inside the Tower, but not always. My friend suggests a hardware problem, but has no suggestions on how to solve it.

    Original title: Windows

    Since the reinstallation of Windows 7 I have Wifi access even if my laptop and tablet of my wife can become if the router is OK. Also, it restarts or freeze without reason. Sometimes I hear a metallic noise inside the Tower, but not always. My friend suggests a hardware problem, but has no suggestions on how to solve it.

    Hello

    After a reinstall of the operating system, you must reinstall the latest drivers from your computer manufacturer's website:

    Go to the website to make your computer > Driver and Software Support Section > search your computer or hardware model number > then your operating system > locate the correct drivers > download and install.

    ________________________________________

    And you do not tell us why you did a reinstall and if there reboot/freeze before you did this reinstall.

    FYI: Desktop computers normally are Wi - fi unless you install additional hardware for this.

    ________________________________________

    Noise inside a desktop computer can be caused by fan/s or harddrives about to fail.

    Go to the website of your computer manufacturer > search your computer specifications > know brand of hard drive > access the Hard Drive manufacturer's Web site > find and download hard drive Diagnostic software and make a record of start of it on the computer that you use to get here, following their instructions > test your hard drive...

    See you soon.

  • PIX501 customer VPN - cannot access inside the network with VPN Session

    What follows is based on the config on the attached link:

    http://www.Cisco.com/en/us/Partner/Tech/tk583/TK372/technologies_configuration_example09186a008009442e.shtml

    PIX Ver 6.2 (3) - VPN Client 3.3.6(A) - Windows XP Client PC

    We can establish the VPN to the PIX501 session, but we cannot access the network private behind the pix.

    Here is the config - I can't determine why it does not work, we are desperate to get there as soon as POSSIBLE!

    We have the same problem with the customer 4.0.3(c)

    Thanks in advance for any help!

    =======================================

    AKCPIX00 # sh run

    : Saved

    :

    6.2 (3) version PIX

    ethernet0 nameif outside security0

    nameif ethernet1 inside the security100

    hostname AKCPIX00

    domain.com domain name

    fixup protocol ftp 21

    fixup protocol http 80

    fixup protocol h323 h225 1720

    fixup protocol h323 ras 1718-1719

    fixup protocol they 389

    fixup protocol rsh 514

    fixup protocol rtsp 554

    fixup protocol smtp 25

    fixup protocol sqlnet 1521

    fixup protocol sip 5060

    fixup protocol 2000 skinny

    fixup protocol sip udp 5060

    names of

    access-list 101 permit ip 192.168.1.0 255.255.255.0 10.0.0.0 255.255.255.0

    pager lines 24

    interface ethernet0 10baset

    interface ethernet1 10full

    Outside 1500 MTU

    Within 1500 MTU

    external IP address #. #. #. # 255.255.240.0

    IP address inside 192.168.1.5 255.255.255.0

    alarm action IP verification of information

    alarm action attack IP audit

    IP local pool akcpool 10.0.0.1 - 10.0.0.10

    history of PDM activate

    ARP timeout 14400

    Global 1 interface (outside)

    (Inside) NAT 0-list of access 101

    NAT (inside) 1 0.0.0.0 0.0.0.0 0 0

    Route outside 0.0.0.0 0.0.0.0 #. #. #. # 1

    Timeout xlate 03:00

    Timeout conn 01:00 half-closed 0: 10:00 udp 0:02:00 CPP 0: h323 from 10:00 0:05:00 sip 0:30:00 sip_media 0:02:00

    Timeout, uauth 0:05:00 absolute

    GANYMEDE + Protocol Ganymede + AAA-server

    RADIUS Protocol RADIUS AAA server

    AAA-server local LOCAL Protocol

    the ssh LOCAL console AAA authentication

    No snmp server location

    No snmp Server contact

    SNMP-Server Community public

    No trap to activate snmp Server

    enable floodguard

    Permitted connection ipsec sysopt

    No sysopt route dnat

    Crypto ipsec transform-set esp - esp-md5-hmac RIGHT

    Crypto-map dynamic dynmap 10 transform-set RIGHT

    map mymap 10-isakmp ipsec crypto dynamic dynmap

    mymap outside crypto map interface

    ISAKMP allows outside

    part of pre authentication ISAKMP policy 10

    encryption of ISAKMP policy 10

    ISAKMP policy 10 md5 hash

    10 2 ISAKMP policy group

    ISAKMP life duration strategy 10 86400

    vpngroup address akcpool pool akcgroup

    vpngroup dns 192.168.1.10 Server akcgroup

    vpngroup akcgroup by default-domain domain.com

    vpngroup split tunnel 101 akcgroup

    vpngroup idle 1800 akcgroup-time

    vpngroup password akcgroup *.

    vpngroup idle 1800 akc-time

    Telnet timeout 5

    SSH #. #. #. # 255.255.255.255 outside

    SSH timeout 15

    dhcpd address 192.168.1.100 - 192.168.1.130 inside

    dhcpd dns 192.168.1.10

    dhcpd lease 3600

    dhcpd ping_timeout 750

    dhcpd allow inside

    Terminal width 80

    Cryptochecksum:XXXXX

    : end

    AKCPIX00 #.

    Config looks good - just as domestic mine to my local network. The only thing I can think is that you may have entered commands in the wrong order - which means, you could have isakmp or encryption before the config map was complete. Write memory, then reloading the pix is a way to reset everything. If you do not want downtime:

    mymap outside crypto map interface

    ISAKMP allows outside

    Enter these two commands should be enough to reset the ipsec and isakmp.

  • Inside the interface of access IPSec on PIX

    Hi all

    I need advice with the following problem.

    I have PIX 515E with 3 interfaces inside.

    DMZ and outside, to 6.3 (3). Is it possible to access DMZ more inside the interface with IPSec of CISCO VPN client? IPSec creates a tunnel, the customer

    has a new address of the address pool, but

    in the paper, I have a message: not found translation etc... When I try to

    reach any device in the DMZ. The reason seems

    be with nat (dmz) 0, which should be inside the DMZ (social security social security 50 0). Even if I use nat (dmz) 0-list of remote access apart from it does not work. Any tips?

    Thank you

    Zdenek

    Hello

    Can you check if you are able to access the DMZ from the inside? If so, then u shud be able to access DMZ to connect remotely. This is because once the VPN client obtains the IP address of the inside pool, it's as good as he is in your home LAN. You can try putting inside DMZ natting... I mean put this command nat 0 because inside the DMZ, which will allow access to DMZ devices inside.

  • Cannot access the kuller or the bookhouse inside the adobe programs, they say I am disconnected (e) the cloud, but I'm registered, what can I do?

    Cannot access the kuller or the bookhouse inside the adobe programs, they say I am disconnected (e) the cloud, but I'm registered, what can I do?

    Taylor the last update the cloud did, I can't access any library, no kuller, the cloud in illustrator I didn't say soul sighed, but I am enrolled in the cloud, I can download programs, what is wrong. ? Help

    OK - In Illustrator get to HELP.   Sign in with your username there.  Restart Illustrator.   That's the question is!  Hope this helps

  • access to the original inside the proxy service message

    I have the proxy (serviceType = Web Service, WSDL) service that is available to the client endpoint and I want to record the incoming message to the file on the disk. However, I want to persist any incoming message exectly (at the byte level) as it was sent by the sender (so with the envelope).
    Inside of the proxy service I have access to variables such as header, body etc. However, they are not good for my purpose because they differ from the corresponding parts of the original message. For example xmlns:soapenv = namespace "http://schemas.xmlsoap.org/soap/envelope/" in the original message
    defined only at the level of the envelope and not the header or body. But in the header and body available inside the proxy service variables they (namespaces) are visible. Mayby there are more differences, but this one is visible at a time.
    It is therefore possible to access (in order to save it) original message somehow? Any magical variable? Or mayby there is a way of saying the osb to be persisted (incoming query) in file? (it would be enough for me (of course I need file name).) I manage file by myself more far away).
    All advice appreciated

    If you choose the type of service that WSDL based or service of any SOAP, then OSB motor deconstruct the incoming SOAP envelope and complete parts of the envelope (header, body etc) to automatically correct context variables. This occurs before the flow of messages of proxy service is initiated, so you can't do anything. In the proxy service, you will receive the deconstructed only SOAP message.
    If you wish to record the exact message that has been received by the OSB, then change the type of service to (or create another proxy service in front of the existing proxy) type Messaging with text or binary content. Or you can also choose AnyXML service type, in which case the incoming SOAP envelope will be available inside variable $body in mail flow.

  • Find a component inside the jsf fragment using javascript in adf

    Hi all

    I use jdeveloper 11.1.1.5.
    I want to find a component inside my frgament of jsf using javascript.
    Inside the jspx page, I was able to find the component using
    AdfPage.PAGE.findComponentByAbsoluteId ("ID");

    Now my requirement is I have a fragment of jsf, and I want to find the component within jsf frgament using javascript.

    I'm looking for the component.


    Please suggest

    Thank you

    Published by: Navin K December 21, 2011 16:24

    Hello

    fragments are displayed in the ADF regions, which are containers of naming. So a good strategy would be to first find the region

    var region = AdfPage.PAGE.findComponentByAbsoluteId("regionId");
    
    if(region != null){
    
      var comp = region.findComponent("ID");
      ...
    } 
    

    Another option would be

      var comp = AdfPage.PAGE.findComponentByAbsoluteId("regionId:ID"); 
    

    If you have a side handle server for the component, and then a third option exists, which is to call getClientId on this element and pass the customer ID to the JavaScript (for example af:clientAttribute)

    Frank

Maybe you are looking for

  • The product for Satellite Pro U300 XP Pro SP3 recovery disk

    Never had to use recovery with this laptop and worried to be wrong! Nero Backitup allows you to save all the files and settings, but feel that I need to format the c drive to get rid of the gremlins. My drive recovery reinstalls the operating system

  • set the second screen as the main screen

    I have an external monitor connected to my macbook pro. Is it possible to put this external monitor as the main screen. It seems that El Captain only opens new windows and applications on Macbook Pro screen.

  • DeskJet 3634: Deskjet 3634

    Bought with & Windows 8 PC. Updated to 8.1. Warned by Microsoft, updated to 10. This printer had worked. Continued to work. Just - once in a great while, usually when I run out of paper, it crashes. I go into my files for 'HP Printer Wizard.exe Insta

  • Firewall Windows PCI compatible?

    Can someone tell me if Windows Firewall meets the PCI compatible rules?

  • Obsolete ATI drivers for T400 crash coming 4 of Firefox and IE 9

    I have a T400 running 32-bit Windows 7. I downloaded the latest graphics drivers from the support page for my graphics card: ATI Mobility Radeon HD 3400 Series. Pilots seem to be outdated if they date from 24/08/2009 and have the following version nu