Flex Mobile: View parent access within the itemrenderer component Variable

I have several images in a list and I want to display 4 of them both on the screen with a provision in mosaic with the width of each image = 50% of the height and width of screen = 50% screen height.

I was able to do this with the code below.

< s:List id = "list1" width = "100%" height = "100%" >

< s:ArrayCollection >

< fx:Object id = "img1" img_url = ' assets/1 - 1.png' title = "Image 1" / >

< fx:Object id = "img2" img_url = "assets/1 - 2.png" title = "Image 2" / >

< fx:Object id = "img3" img_url = "assets/2 - 1.png" title = "Image 3" / >

< fx:Object id = "img4" img_url = "assets/2 - 2.png" title = "Image 4" / >

< / s:ArrayCollection >

< s:layout >

< s:TileLayout

columnAlign = "justifyUsingWidth" horizontalAlign = "center" verticalAlign = "middle".

paddingBottom = paddingLeft '0' = '0' paddingRight = paddingTop = "0" "0".

horizontalGap = "0" verticalGap = "0".

/ >

< / s:layout >

< s:itemRenderer >

< fx:Component >

< s:ItemRenderer >

"< s:Group width ="160"height ="240">" "

< s:BitmapImage source = "{data.img_url}" scaleMode = "stretch" smooth = 'true' "

Width = "100%" height="100%"/ >

< s:Label text = "{data.title}" left = low "0" = "0" width = "100%" / > "

< / s:Group >

< / s:ItemRenderer >

< / fx:Component >

< / s:itemRenderer >

< / s:List >

However, I don't want to hard code the width and height values.

I am able to get the screen specify height and width in the event viewAcivate of the view, as shown below.

protected function view1_viewActivateHandler(event:ViewNavigatorEvent):void

{

ScreenWidth = screen.width;

ScreenHeight = screen.height;

}

How to apply these values for width/height of the group properties in the itemrenderer?

Something like...

< s:ItemRenderer >

"< s:Group width ="{ScreenWidth/2}"height ="{ScreenHeight/2}' > ' "

< s:BitmapImage source = "{data.img_url}" scaleMode = "stretch" smooth = 'true' "

Width = "100%" height="100%"/ >

< s:Label text = "{data.title}" left = low "0" = "0" width = "100%" / > "

< / s:Group >

< / s:ItemRenderer >

parentDocument.height

Tags: Flex

Similar Questions

  • nondeterministic accessibility within the wifi network

    My configuration:

    -router with internet connection

    -laptop

    -BB 9000

    My goal:

    The BB device opens a TCP socket via wifi and laptop connects with this Jack.

    Actually I'm working and I am able to transfer data, but the behavior is not deterministic and sometimes there are problems that are not understandable (at least for me). Including the connection string and the IP that I use are correct.

    The problem:

    The BB is able to open the plug when it is connected with the router and I am able to interrogate my IP. But I'm not able to reach the appliance with the laptop:

    -J' try to connect with my desktop or PuTTY

    -J' I try to ping the device: destination unreachable host

    The laptop is connected to the router and able to access the internet. And the device is connected to the router, otherwise open the plug would result in an exception (tunnel failure).

    My solution:

    I use the browser on the device to connect to a Web site. I try to ping the device again. If it's not accessible I connect to another internet site until the device is 'who responded. " Can I use my desktop application to connect to the Jack and it works great!

    But the solution is not acceptable to the final application, so I need to fix this. But I can't find a solution.

    -The router is working and the Internet works fine when I use it with my laptop.

    -L' device is able to access the internet via wifi without problem.

    -L' connected to the router, otherwise he would not be able to open the socket.

    So there must be some sort of locking mechanism within the device that does not transmit the ping requests or the connection of the laptop until I connect to an internet site. Maybe some sort of mechanism of energy efficiency or safety.

    Any ideas?

    New results:

    The problem does not occur when I use another router. So, I'm quite sure, that it is based on the first router or its configuration.

    @MSohn: thanks for the support!

  • Photoshop Script - layout of the interface user access within the variable?

    Hello

    I have the following variable as a layout of the user interface of a window, I have button access to the btn_one , but without success.

    var w = new Window("dialog {  \
        margins: 15, \
            btn_one: Button { \
                text: 'Button', \
                size: [100,25], \
                alignment:['right', 'center'] \
            }, \
        }");
    

    Any help to achieve this goal? I need to try the following, it does not work.

    btn_one.onClick = function(){
    }
    

    Thank you

    In your case, this may work:

    w.btn_one. OnClick();

    Not sure because I never build windows like that. I first create the window, then add the button on a separate line.

  • setCurrentState() substitute within the itemRenderer

    Well, as advised, I split separated the itemRenderer in a few VGroups, each with an includeIn = "stateName" attribute, in addition, there are a few defined States (im not not using standard names for the States). In the data property of the converter, I use a field of the object provided to decide which State to use, and I put the State using setCurrentState (stateName", false). When running, this will raise an error as soon as I have to refer to a component of a particular State (which must have been defined) because all references are null, so I googled and learned that I need some kind of substitute for setCurrentState() method and perhaps also the getCurrentState method. Don't know what im supposed to put into substitutions.

    Any ideas?

    Thank you

    Forget it, I'm going with itemRendererFunction

  • How to use methods within the itemRenderer

    Hello

    I have basic itemRenderer as a component:

    < mx:Component id = "ColorRenderer" >
    < mx:Label
    Text = "{rgb2hex (255,100,50)} ' / / this gives error: 1180: call to a method may be undefined rgb2hex"
    / >
    < / mx:Component >

    My method works if I use it with a 'normal' tag < mx:Label = "22" x = "12" text = "{rgb2hex (255,100,50)}" width = "150" / > "
    but it does not work inside the itemRenderer?

    What I'm missing here?

    When you use the tag you define a new variable scope. In this context, the rgb2hex does not exist. You need to qualify: { outerDocument.rgb2hex (255,100,50)}

  • Is it possible to amend an application within the onSessionEnd function variable?

    within the onSessionEnd only service a copy of the Application scope exists, so I'm not sure rellay so you can change a variable indoor onSessionEnd Application

    Read the docs:
    http://www.Adobe.com/LiveDocs/ColdFusion/7/htmldocs/wwhelp/wwhimpl/common/html/wwhelp.htm? Context = ColdFusion_Documentation & file = part_cfm.htm
    In the tag for the attribute "name":
    «For the Application and Session variables: required.»

    In addition, you must create all application variables in SystemFramework and create all session variables in onSessionStart. The first documentation I showed also said to use a name of the lock to access the Application variables, which you don't. Adding statements will help you track if your application calls these methods, even. And there is no way for onSessionEnd to output anything whatsoever, so coming out.

    Restructure as below:

  • Model of ADF for use within the declarative component project

    Hello

    JDev 11.1.2.4

    I created a project for my declarative components. I want to create an element with an attribute of type oracle.jbo.Row, but this class is not recognized. What are the libraries I need to include if I want to use the object Row.

    Some basic information: my declarative component is bound to a managed bean.

    Import oracle.jbo.Row;

    @ManagedBean (name = "audit")

    @RequestScoped

    public class AuditBean {}

    Online Privacy;

    public AuditBean() {}

    Var UIXDeclarativeComponent = (UIXDeclarativeComponent) JSFUtils.resolveExpression("#{comp}");

    If (vars == null) {}

    again, throw PropertyNotFoundException ("could not find the name of the attribute [comp] component declarative Vars.");

    }

    line = vars.getAttributes () .get ("row");

    }

    }

    Most of our table have the same fields of audit, and we want to create a component that displays audit information. The component would take the line and check if the attributes are present, if so, display them.

    Thank you

    Hello

    Line belongs to the ADF runtime library. However, your declarative component seems to have another flaw, that is, it uses a bean managed within the scope of the request. She should better use backingBean range (a range of task flow) so it can be used multiple times on a page without the substitution of a previous rendering information. Maybe this isn't a problem if the component cannot forget his condition after rendering

    Frank

  • How to get the width and height of Flex Mobile view?

    Hello

    The following instructions can get the width and height of the current Flex app:

    var request: UIComponent = FlexGlobals.topLevelApplication as UIComponent;

    trace (application. Width);

    trace (application. Height);

    But I don't know how to get the width and height of mobile display Flex current (i.e. the content size excludes bar action and the Navigation bar). Why the "this.width" always returns 0?

    Thank you!

    Looks like you're running in this bug: https://bugs.adobe.com/jira/browse/SDK-30070

  • Trainer to date within the ItemRenderer list...

    I am trying to format the date timestamp of a mySQL database that I display within a list in a mobile application. The trainer also works perfectly... However, when I call in the item list converter, no dice... I'm sure it's a syntax error, but I don't seem to be able to understand:

    Here is my IconItemRenderer for the list:

    <s:IconItemRenderer xmlns:fx="http://ns.adobe.com/mxml/2009" 
                        xmlns:s="library://ns.adobe.com/flex/spark"  labelField="displayLongDTF.format(date)" 
                        messageField="username" iconWidth="32" iconHeight="32" decorator="@Embed('assets/button-help-32x32.png')" >
    </s:IconItemRenderer>
    

    Here's my decleration of rendering engine:

    <s:DateTimeFormatter id="displayLongDTF" dateTimePattern="EEE, MM / dd, yyyy h:mm a"/>
    

    And when I run... It is simply void where the date should be...

    Yes, you need something like this:

    http://ns.Adobe.com/MXML/2009.

    xmlns:s = "library://ns.adobe.com/flex/spark".

    labelFunction = "dateLabelFunction."

    ... >

    private void dateLabelFunction(item:Object):String

    {

    Return someformatter.format (item.date);

    }

    ]]>

  • AnyConnect to ASA 5505 ver 8.4 unable to ping/access within the network

    My AnyConnect VPN to connect to the ASA, but I can not access my home network hosts (tried Split Tunnel and it didn't work either). I intend to use a Split Tunnel configuration, but I thought I would get this job until I've set up this configuration. My inside hosts are on a 10.0.1.0/24 network and networks 10.1.0.0/16. My AnyConnect hosts use 192.168.60.0/24 addresses.

    I saw the messages of others who seem similar, but none of these solutions have worked for me.  I also tried several configurations NAT and ACLs to allow my internal network to the ANYConnect hosts and return traffic shaping, but apparently I did it incorrectly.  I undestand what this worm 8.4 is supposed to be easier to achieve, NAT and others, but I now have in the IOS router it is much simpler.

    My setup is included below.

    Thanks in advance for your help.

    Jerry

    *************************************************************

    ASA Version 8.4 (4)

    !

    hostname mxfw

    domain moxiefl.com

    activate the (deleted) password

    !

    interface Ethernet0/0

    switchport access vlan 2

    !

    interface Ethernet0/1

    !

    interface Ethernet0/2

    !

    interface Ethernet0/3

    Shutdown

    !

    interface Ethernet0/4

    Shutdown

    !

    interface Ethernet0/5

    switchport trunk allowed vlan 20.22

    switchport mode trunk

    !

    interface Ethernet0/6

    Shutdown

    !

    interface Ethernet0/7

    Shutdown

    !

    interface Vlan1

    nameif inside

    security-level 100

    IP 10.0.1.1 255.255.255.0

    !

    interface Vlan2

    nameif outside

    security-level 0

    IP address dhcp setroute

    !

    interface Vlan20

    nameif dmz

    security-level 50

    IP 172.26.20.1 255.255.255.0

    !

    interface Vlan22

    nameif dmz2

    security-level 50

    IP 172.26.22.1 255.255.255.0

    !

    passive FTP mode

    DNS lookup field inside

    DNS domain-lookup outside

    DNS server-group DefaultDNS

    name-server 208.67.222.222

    Server name 208.67.220.220

    domain moxiefl.com

    permit same-security-traffic inter-interface

    network of the Generic_All_Network object

    subnet 0.0.0.0 0.0.0.0

    network of the INSIDE_Hosts object

    10.1.0.0 subnet 255.255.0.0

    network of the AnyConnect_Hosts object

    192.168.60.0 subnet 255.255.255.0

    network of the NETWORK_OBJ_192.168.60.0_26 object

    255.255.255.192 subnet 192.168.60.0

    network of the DMZ_Network object

    172.26.20.0 subnet 255.255.255.0

    network of the DMZ2_Network object

    172.26.22.0 subnet 255.255.255.0

    pager lines 24

    Within 1500 MTU

    Outside 1500 MTU

    MTU 1500 dmz

    dmz2 MTU 1500

    local pool VPN_POOL 192.168.60.20 - 192.168.60.40 255.255.255.0 IP mask

    no failover

    ICMP unreachable rate-limit 1 burst-size 1

    don't allow no asdm history

    ARP timeout 14400

    NAT dynamic interface of Generic_All_Network source (indoor, outdoor)

    NAT (inside, outside) static source INSIDE_Hosts INSIDE_Hosts static destination AnyConnect_Hosts AnyConnect_Hosts-route search

    NAT (inside, outside) static source any any static destination NETWORK_OBJ_192.168.60.0_26 NETWORK_OBJ_192.168.60.0_26 non-proxy-arp-search to itinerary

    NAT (dmz, outside) dynamic interface of Generic_All_Network source

    NAT (dmz2, outside) dynamic interface of Generic_All_Network source

    Route inside 10.1.0.0 255.255.0.0 10.0.1.2 1

    Timeout xlate 03:00

    Pat-xlate timeout 0:00:30

    Timeout conn 01:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02

    Sunrpc timeout 0:10:00 h323 0:05:00 h225 mgcp from 01:00 0:05:00 mgcp-pat 0:05:00

    Sip timeout 0:30:00 sip_media 0:02:00 prompt Protocol sip-0: 03:00 sip - disconnect 0:02:00

    Timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute

    timeout tcp-proxy-reassembly 0:01:00

    Floating conn timeout 0:00:00

    dynamic-access-policy-registration DfltAccessPolicy

    identity of the user by default-domain LOCAL

    the ssh LOCAL console AAA authentication

    AAA authentication http LOCAL console

    Enable http server

    http 10.0.0.0 255.0.0.0 inside

    No snmp server location

    No snmp Server contact

    Server enable SNMP traps snmp authentication linkup, linkdown warmstart of cold start

    Crypto ipsec ikev2 AES256 ipsec-proposal

    Protocol esp encryption aes-256

    Esp integrity sha - 1, md5 Protocol

    Crypto ipsec ikev2 ipsec-proposal AES192

    Protocol esp encryption aes-192

    Esp integrity sha - 1, md5 Protocol

    Crypto ipsec ikev2 ipsec-proposal AES

    Esp aes encryption protocol

    Esp integrity sha - 1, md5 Protocol

    Crypto ipsec ikev2 proposal ipsec 3DES

    Esp 3des encryption protocol

    Esp integrity sha - 1, md5 Protocol

    Crypto ipsec ikev2 ipsec-proposal OF

    encryption protocol esp

    Esp integrity sha - 1, md5 Protocol

    crypto dynamic-map SYSTEM_DEFAULT_CRYPTO_MAP 65535 define ikev2 AES256 AES192 AES 3DES ipsec-proposal OF

    outside_map card crypto 65535-isakmp dynamic ipsec SYSTEM_DEFAULT_CRYPTO_MAP

    outside_map interface card crypto outside

    Crypto ca trustpoint ASDM_TrustPoint0

    registration auto

    domain name full anyconnect.moxiefl.com

    name of the object CN = AnyConnect.moxiefl.com

    Keypairs AnyConnect

    Proxy-loc-transmitter

    Configure CRL

    string encryption ca ASDM_TrustPoint0 certificates

    certificate 439 has 4452

    3082026c 308201d 5 a0030201 9a 445230 02020443 0d06092a 864886f7 0d 010105

    05003048 06035504 03131641 6e79436f 6e6e6563 742e6d6f 78696566 311f301d

    6c2e636f 312530 2306092a 864886f7 0d 010902 1616616e 79636f6e 6e656374 6 d

    2e6d6f78 6965666c 2e636f6d 31333039 32373037 32353331 5a170d32 301e170d

    33303932 35303732 3533315a 3048311f 301D 0603 55040313 16416e79 436f6e6e

    6563742e 6d6f7869 65666c2e 636f6d31 86f70d01 09021616 25302306 092a 8648

    616e7963 6f6e6e65 63742e6d 6f786965 666c2e63 6f6d3081 9f300d06 092 has 8648

    86f70d01 01010500 03818d 00 30818902 8181009a d9f320ff e93d4fdd cb707a4c

    b4664c47 6d2cc639 4dc45fed bfbc2150 7109fd81 5d6a5252 3d40dc43 696360d 5

    fbf92bcc 477d19b8 5301085c daf40de5 87d7e4aa f81b8d7f 8d364dfa 0a6f07d7

    6a7c3e9b 56e69152 aa5492d8 e35537bd 567ccf29 7afbeae8 13da9936 9f890d76

    1d56d11d da3d039a 0e714849 e6841ff2 a3633061 03010001 300f0603 b 5483, 102

    1301 01ff0405 30030101 ff300e06 03551d0f 0101ff04 86301f06 04030201 551d

    23 04183016 80142f27 7096c4c5 e396e691 e07ef737 af61b71f 64f1301d 03551d

    0603551d 0e041604 142f2770 96c4c5e3 96e691e0 7ef737af 61b71f64 f1300d06

    092a 8648 86f70d01 01050500 03818100 8f777196 bbe6a5e4 8af9eb9a 514a 8348

    5e62d6cd e430a758 47257243 2b 367543 065d4ceb 582bf666 08ff7be1 f89287a2

    ac527824 b11c2048 7fd2b50d 6aa00675 e4df7859 f3590596 b1d52426 ca 35, 3902

    226 dec 09 713f7ba9 80bdf7bb b52a7da2 4a68b91b 455cabba 4e77f4b0 1e97a52c

    0cc4c6f3 f244f7d9 0a6e32fb 31ce7e35

    quit smoking

    IKEv2 crypto policy 1

    aes-256 encryption

    integrity sha

    Group 2 of 5

    FRP sha

    second life 86400

    IKEv2 crypto policy 10

    aes-192 encryption

    integrity sha

    Group 2 of 5

    FRP sha

    second life 86400

    IKEv2 crypto policy 20

    aes encryption

    integrity sha

    Group 2 of 5

    FRP sha

    second life 86400

    IKEv2 crypto policy 30

    3des encryption

    integrity sha

    Group 2 of 5

    FRP sha

    second life 86400

    IKEv2 crypto policy 40

    the Encryption

    integrity sha

    Group 2 of 5

    FRP sha

    second life 86400

    Crypto ikev2 activate out of service the customer port 443

    Crypto ikev2 access remote trustpoint ASDM_TrustPoint0

    Telnet timeout 5

    SSH 10.0.0.0 255.0.0.0 inside

    SSH timeout 5

    SSH group dh-Group1-sha1 key exchange

    Console timeout 0

    dhcpd dns 208.67.222.222 208.67.220.220

    dhcpd outside auto_config

    !

    dhcpd addresses 10.0.1.20 - 10.0.1.40 inside

    dhcpd dns 208.67.222.222 208.67.220.220 interface inside

    dhcpd allow inside

    !

    dhcpd address dmz 172.26.20.21 - 172.26.20.60

    dhcpd dns 208.67.222.222 208.67.220.220 dmz interface

    dhcpd enable dmz

    !

    dhcpd address 172.26.22.21 - dmz2 172.26.22.200

    dhcpd dns 208.67.222.222 208.67.220.220 dmz2 interface

    dmz2 enable dhcpd

    !

    a basic threat threat detection

    Statistics-list of access threat detection

    no statistical threat detection tcp-interception

    SSL-trust outside ASDM_TrustPoint0 point

    WebVPN

    allow outside

    AnyConnect essentials

    AnyConnect image disk0:/anyconnect-win-3.0.2052-k9.pkg 1

    AnyConnect profiles AnyConnect_client_profile disk0: / AnyConnect_client_profile.xml

    AnyConnect enable

    tunnel-group-list activate

    internal GroupPolicy_AnyConnect group strategy

    attributes of Group Policy GroupPolicy_AnyConnect

    WINS server no

    value of server DNS 208.67.222.222 208.67.220.220

    client ssl-VPN-tunnel-Protocol ikev2

    moxiefl.com value by default-field

    WebVPN

    AnyConnect value AnyConnect_client_profile type user profiles

    password username user1 $ $ encrypted privilege 15

    password username user2 $ $ encrypted privilege 15

    tunnel-group AnyConnect type remote access

    tunnel-group AnyConnect General attributes

    address VPN_POOL pool

    Group Policy - by default-GroupPolicy_AnyConnect

    tunnel-group AnyConnect webvpn-attributes

    enable AnyConnect group-alias

    !

    class-map inspection_default

    match default-inspection-traffic

    !

    !

    type of policy-card inspect dns preset_dns_map

    parameters

    maximum message length automatic of customer

    message-length maximum 512

    Policy-map global_policy

    class inspection_default

    inspect the preset_dns_map dns

    inspect the ftp

    inspect h323 h225

    inspect the h323 ras

    Review the ip options

    inspect the netbios

    inspect the rsh

    inspect the rtsp

    inspect the skinny

    inspect esmtp

    inspect sqlnet

    inspect sunrpc

    inspect the tftp

    inspect the sip

    inspect xdmcp

    inspect the icmp

    !

    global service-policy global_policy

    context of prompt hostname

    no remote anonymous reporting call

    call-home

    Profile of CiscoTAC-1

    no active account

    http https://tools.cisco.com/its/service/oddce/services/DDCEService destination address

    email address of destination [email protected] / * /

    destination-mode http transport

    Subscribe to alert-group diagnosis

    Subscribe to alert-group environment

    Subscribe to alert-group monthly periodic inventory

    monthly periodicals to subscribe to alert-group configuration

    daily periodic subscribe to alert-group telemetry

    Cryptochecksum:f2c7362097b71bcada023c6bbfc45121

    : end

    Hello

    You may have problems with the NAT configurations

    Look at these 2 high page configurations

    NAT dynamic interface of Generic_All_Network source (indoor, outdoor)

    NAT (inside, outside) static source INSIDE_Hosts INSIDE_Hosts static destination AnyConnect_Hosts AnyConnect_Hosts-route search

    The solution is either to reconfigure the dynamic PAT with the lowest priority (goes tearing down the current normal outbound connections) OR reposition the exempt NAT / configurations NAT0

    Dynamic change of PAT could be done with

    no nat dynamic interface of Generic_All_Network source (indoor, outdoor)

    NAT automatic interface after (indoor, outdoor) dynamic source Generic_All_Network

    NAT0 configuration change could be done with

    no nat source (indoor, outdoor) public static INSIDE_Hosts static destination INSIDE_Hosts AnyConnect_Hosts AnyConnect_Hosts-route search

    NAT (inside, outside) 1 static source INSIDE_Hosts INSIDE_Hosts static destination AnyConnect_Hosts AnyConnect_Hosts-route search

    Changing the order of the NAT0 configurations as described above is probably the simplest solution and does not cause a teardown of connections for users. Of course change the dynamic configuration PAT would avoid future problems if it can generate. For example, it could overide static PAT (Port Forward) configured with Auto NAT configurations.

    Try option suites you best and let know us if it solved the problem

    Remember to mark a reply as the answer if it answered your question.

    Feel free to ask more if necessary

    -Jouni

  • DW CS4 Live View - no access to the admin pages?

    Hello

    I've searched the forums, do not know if I ask the question properly.

    I'm still working on CS4 - I know that this feature has been added to the CS5, but I can't afford to update my entire system right now.

    I have the Live View installed correctly on my localhost and it works with my PHP pages.

    I don't know how to get the sections protected by password admin (CMS backend) of Live View?

    I found this help topic for custom URL requests, but honestly I have a usage example of this (provide the username and password?)

    http://help.Adobe.com/en_US/Dreamweaver/10.0_Using/WSC4A30901-005C-4721-B1DD-16F86D081698a .html

    can someone explain it to me in plain English? Thank you!

    Because the authentication of users requires SESSION VARIABLES, I am skeptical that you will be able to get to these pages in DW.  When I build things, I put the authentication on the very last step, after all the view of the page/Live layout issues have been addressed.

  • IP overlapping between VPN remote access and within the interface

    Hi all

    I tried to replace an ASA and configured vpn for remote access using cisco VPN client.

    Remote access users are not able to access within the network, but have no problem accessing the network through a VPN site-to site.

    One thing to note is that remote access VPN users are assigned an ip address of 10.X.3.1 - 10.X.3.200 mask 255.255.255.0. The inside interface is on 10.X.1.2 255.255.0.0.

    Remote access users will have no problem to access within the network if the pool of the vpn client is changed to 192.168.1.1 to 192.168.1.100.

    ASA errors

    6 January 7, 2012 16:25:08 302013 10.X.3.1 27724 3389 10.X.1.66 built of TCP connections incoming 20940 for outside:10.X.3.1/27724 (10.X.3.1/27724)(LOCAL\Cisco) at inside:10.X.1.66/3389 (10.X.1.66/3389) (Cisco)

    6 January 7, 2012 16:25:08 106015 10.X.1.66 3389 10.X.3.1 27724 Deny TCP 10.X.1.66/3389 to 10.X.3.1/27724 flags SYN ACK on dmz interface (no link)

    I understand that the overlap between access ip address range remote vpn network interface network and inside will cause routing problems, but why the syn - ack makes its appearance in the DMZ interface? The interface of the DMZ is on ip address 172.16.Y.1 255.255.255.0.

    I intend to reduce the interface 10.X.0.0 255.255.254.0 inside if it is in fact a routing problem due to the IP address that overlap, but I understand why the syn - ack comes from the dmz interface and the diagnosis of the problem is correct. I check with the customer and was informed that the existing design works on an another ASA with no such problems.

    I agree what you said and also tried, but it does not work.

    http://www.Cisco.com/en/us/products/ps6120/products_tech_note09186a00807e0aca.shtml#overlap

    Solution, that you already know

    Solution

    Always ensure that the IP addresses in the pool should be assigned to VPN, network clients internal head unit and the internal network to the VPN Client must be in different networks. You can assign the same major network with different subnets, but sometimes the routing problems.

    Thank you

    Ajay

  • How to get individual columns within an itemrenderer?

    Hey,.

    I was wondering if it is possible to get the column of a datagrid in an itemrenderer? I have a datagrid with 4 columns. I would use an itemrenderer for each of them. Is it possible within the itemrenderer which gets the individual column for me. For example

    ItemRenderer:

    DataGrid1 = datagrid (parentDocument as file name);

    If (datagrid1. "selectedColumn"(==0) {} "

    doThis();

    }

    If (datagrid1. "selectedColumn"(==1) {} "

    doThat();

    }

    Is something like this?

    Thank you!

    Concerning

    Kat

    If your converter implements the IDropInListItemRenderer, you can figure out the column that you represent by examining the listData property

    Alex Harui

    Flex SDK Developer

    Adobe Systems Inc..

    Blog: http://blogs.adobe.com/aharui

  • Access to the data in a list of MouseOver.

    I got this idea where I could display some data from an itemRender briefly in a list once it is highlighted of the mouse. I tried to find a way that I could go to do that, but I'm kinda stuck. Is there a a way to trigger an event that will pull data from an element highlighted while separating a selected item?

    It just occurred to me that some people may thinkl I am eager to do something within the itemRenderer, which I know how to do. What I want to accomplish is to provoke an external image holder in the list to take the location of the image in the list of dataProvider according to the item highlighted in the list.

    Is this possible?

    private void list_itemRollOverHandler(event:ListEvent):void
    {
    var point: Object = list.dataProvider [event.rowIndex];
    }

  • Need help for an itemrenderer component data

    I have a datagrid populated by a dataprovider (collection arrayCollection). No question here

    I have a Custom itemRenderer (as a component) dateField and therefore filled very well, no issue there either.

    However I can't seem to find a way to get the data out (it can be changed, so it is no longer the original data). I can get the original data, but not the new data.

    I can't use an event as there are hundreds of lines I need to handle to write to the database. I just want to get all such values as displayed in the datagrid control.

    I want to just loop through the datagrid and pull data, as written in the object to the itemrenderer component. In debug mode, I can see

    event->-> mycustomecomponent-> text-> [legacy] itemrenderer. I can't get to work.

    Any ideas. There has got to be simple, and just miss him I guess.

    In your ItemRenderer, assign the new value once completed editing your data.yourDataFieldHere. This will then allow you to loop through the dataProvider in the main application and get all the required values.

    function onEdit(evt:Event):void {}

    data.yourDataField = evt.currentTarget.text; Or use of any property of the modified element you need here.

    }

    Chris

Maybe you are looking for

  • Why when I send imessage effects to my friend, he sees them, but when he sends them to me, they appear as words?

    When he sends an effect in return, it does not appear. He says only, (sent with Slam effect) or whatever is the effect. How can I fix it?

  • No sound from my laptop Satellite Pro

    Hello Can one of you kind folk help please? I have a Satellite Pro laptop computer 8 months, up to now, I have never needed to use the speakers or reading.However, I now need to use iTunes and windows drive but for some reason that I can't not all th

  • Set multiple home tabs in safari

    There is a feature in Firefox and Internet Explorer (I'm moving from a PC) where I can put several home tabs in the browser so that when I open the browser open all the tabs.  This is very useful for what I do as I work with various Web sites through

  • Forces, "sleep" mode

    Hello, whenever someone calls me on Skype it forces my pc mode "sleep" and I can not wake him, so I have to restart. I recently installed 64-bit windows. I tried to update Skype, update my gpu driver, I even tried the regsvr32 jscript.dll regsvr32 vb

  • touch of virus stop lenovo onekey

    There is a virus on my PC when I try to use the key onekey. the screen goes black. I tried 5 programs different anti-virus scan. All have failed. OneKey touch fails. even when I try to start it. do you know all the patches?