How to filter all records if user check all option in the box.

Hi friend

I created the search box to filter the report so I created check box for filtering and implemented agent under SQL query in the list of values

SELECT NAME, CODE R FROM AGENT_MAS

UNION

SELECT 'ALL', 'ALL' D DOUBLE R

and my area code are below

SELECT AGENT, CODE, TYPE FROM AGENT_MAS WHERE (to_char (ARR_DATE, 'MM') > '04' = and to_char (ARR_DATE, 'MM') < = "12")

and to_char (ARR_DATE, 'RRRR') =: P10_YEAR

and ((: P10_AGENT is not null and (instr (': ' |: P10_AGENT |': ',' :'||)))) AGENT_CODE: ': ', 1) > 0)) or: P10_AGENT is null)

and

((: P10_MARKET is not null and (instr (': ' |: P10_MARKET |': ',' :'||)))) MARKET_CODE: ': ', 1) > 0)) or: P10_MARKET is null)

AND

((: P10_MONTHS is not null and (instr (': ' |: P10_MONTHS |': ',' :'|| to_char (ARR_DATE, 'MY'): ':', 1) > 0)) or: P10_MONTHS is null)

GROUP BY AGENT

filter work well, but I must add filter with 'EVERYTHING' if the user select EVERYTHING in the box, then all the registration should be filter.

How to view all archives if user check all checkbox option.

Thank you

Hi Maxence,

CORINE wrote:

Hi friend

I created the search box to filter the report so I created check box for filtering and implemented agent under SQL query in the list of values

SELECT NAME, CODE R FROM AGENT_MAS

UNION

SELECT 'ALL', 'ALL' D DOUBLE R

and my area code are below

SELECT AGENT, CODE, TYPE FROM AGENT_MAS WHERE (to_char (ARR_DATE, 'MM') > '04' = and to_char (ARR_DATE, 'MM'))<>

and to_char (ARR_DATE, 'RRRR') =: P10_YEAR

and ((: P10_AGENT is not null and (instr (': ' |: P10_AGENT |': ',' :'||)))) AGENT_CODE: ': ', 1) > 0)) or: P10_AGENT is null)

and

((: P10_MARKET is not null and (instr (': ' |: P10_MARKET |': ',' :'||)))) MARKET_CODE: ': ', 1) > 0)) or: P10_MARKET is null)

AND

((: P10_MONTHS is not null and (instr (': ' |: P10_MONTHS |': ',' :'|| to_char (ARR_DATE, 'MY'): ':', 1) > 0)) or: P10_MONTHS is null)

GROUP BY AGENT

filter work well, but I must add filter with 'EVERYTHING' if the user select EVERYTHING in the box, then all the registration should be filter.

How to view all archives if user check all checkbox option.

Thank you

To view all the archives, if the user has checked all THE option in the box, you will need to modify your report to:

SELECT AGENT
    , CODE
    , TYPE
  FROM AGENT_MAS
WHERE ( TO_CHAR(ARR_DATE,'MM') >= '04' AND TO_CHAR(ARR_DATE,'MM') <= '12' )
  AND TO_CHAR(ARR_DATE,'RRRR') = :P10_YEAR
  AND ( 1 = ( CASE
                WHEN (:P10_AGENT IS NOT NULL AND (:P10_AGENT = 'ALL'))
                  THEN 1
                WHEN (:P10_AGENT IS NOT NULL AND (INSTR(':'|| :P10_AGENT ||':',':'||AGENT_CODE||':',1) > 0 ))
                  THEN 1
                ELSE
                  0
              END ))
  AND ((:P10_MARKET IS NOT NULL AND (INSTR(':'|| :P10_MARKET ||':',':'|| MARKET_CODE||':',1) > 0 ) )  OR :P10_MARKET IS NULL )
  AND ((:P10_MONTHS IS NOT NULL AND (INSTR(':'|| :P10_MONTHS ||':',':'|| TO_CHAR(ARR_DATE,'MON')||':',1) > 0 ) )  OR :P10_MONTHS IS NULL )
GROUP BY AGENT

I changed the filter AGENT to include all THE option.

I hope this helps!

Kind regards

Kiran

Tags: Database

Similar Questions

  • How to remove all information from the computer so I can sell it?

    How to remove all information from the computer so I can sell it?

    Hello

    You will want to format the hard disk:

    1. you can use DBAN - http://www.dban.org/

    or

    2. you can follow this tutorial to clean install up to the step where you format the disk, in which you would then STOP (because you just want to get rid of the files on the hard drive, do not install Windows) - http://www.sevenforums.com/tutorials/1649-clean-install-windows-7-a.html

    Kind regards

    Patrick

  • How do I enter recorded meetings? When I click on the "meetings" tab it says I don't have permission

    How do I enter recorded meetings? When I click on the "meetings" tab it says I don't have permission

    Meeting records will have a direct URL, as well as meeting rooms and the content in Connect. You probably not a member of the host of the meeting or Group Admin group in this Connect account, so you do not have the permissions to access the library of the meeting.

    You will need either the host of the meeting room as you are looking for the registration you get the link and make sure you have the appropriate permissions to view, or switch the recording to the content library where it can be placed in a folder that you have viewing permissions.

  • Where the log file is located (Win Vista) for the actions of OTHER USERS have taken to using the boxes in user account control?

    Where the log file is located (Win Vista) for the actions of OTHER USERS have taken to using the boxes in user account control?

    I use the version of Vista Home Premium.

    While I don't really like how the UAC area enters the information that tells it when to display the box tell me about your work of things on the UAC (I know an article exist on the web), is not how to answer this question.

    There is no log of UAC elevation file.

  • Failed to create a 3D text (or 3D nothing else) all options in the 3D Panel are grayed out. With the help of CC 2015.1.2 on Mac Pro

    Failed to create a 3D text (or 3D nothing else) all options in the 3D Panel are grayed out. With the help of CC 2015.1.2 on Mac Pro (end 2013)

    Thanks for the update.

    Go to the Photoshop preferences > 3D > check whether it shows VRAM than 3072 MB

    Look for the system updates and see if there are updates waiting for your graphics card drivers.

    And make sure that the document you are opening is in RGB and CMYK mode not.

  • Cannot read media files by clicking on 'Play All' option in the management of the music in any folder that contains media files, even if Windows Media Player is set as default player.

    When I need to play all media files in any folder by clicking on the play all option in the management of the music I do not get windows media player running or set of files I just need to play only one unique file double clicking or by creating a playlist. Very annoying sound play a single every time file. Help, please! Thks

    Can you try to select all files (Ctrl + A) > with the button right, select 'Open with' > select Windows Media Player

    This step will open all the music?
    See you soon

    Engineer Jason Microsoft Support answers visit our Microsoft answers feedback Forum and let us know what you think.

  • How can we create a promotion that is not out of the box?

    Hello
    How can we create a promotion that is not out of the box?

    Hello

    You can create a new descriptor from point to point in atg/commerce/pricing/pricingModels.xml.

    ~ Abdelali

  • Does anyone know how to filter all the items in an XMLListCollection?

    I have a tree with the following structure.
    <>node
    < Node1 >
    < node2 >
    < node3 / >
    < node4 / >
    < Noeud5 / >
    < / node2 >
    < / node1 >
    < / node >

    I need to be able to filter on node 3, 4 and 5 and then after the filter if they do not exist, get rid of the node 2 level and make then another function to check if the node levels 2 is here and if not filter... then filter node levels 1. Basically it is an ascendant of the filter. Flas 2.0 I would filter base level by removing the knots... then move to the next level and to check if they had children or not... If they did not then I would remove the... and then I would repeat the step for the last level.
    Does anyone know how to do this without having to remove the items from the collection... Basically, perform a filter rather than a deletion. I know that the filter function only returns the first element in the xml structure... which is annoying. If anyone can help me I would appreciate it of course?

    Thank you

    I guess that the filtering on a tree passes only in the lymph nodes of the root... It's very lame on part of Flex. Basically, I had to make my own functions to remove the nodes dynamically.
    Remember that this only works on a dynamic array element.
    Delete list ;

    To make this work, I have a main TreeCollection... and that I made a copy. Treecollection.Copy () and deletions of the struct stuff copied. After that the destructions were I made then assigned the copy to the MyTree.dataprovider = copy.

  • ADF: How to get all rowKeys for the table displayed in the page

    Hello

    I have table "COMPANY" where the 'COMPANY_ID' column is the primary key. I created a page simple jspx with:

    (1) a text entry to accept new IDs of company

    (2) Insert button.

    (3) af:table which displays all available in "SOCIETY" company ID

    When the user tries to enter a company code that is already present in the table I want to compare with the keys of the row of the table displayed below and if it's an already existing, I would like to send a friendly message for the user and put an end to the movement.

    So, how to extract all line keys to compare?

    Thanks in advance.

    Here's a way to check if you use the OperationBinding exception class:

    operationBinding.execute ();

    If (! operationBinding.getErrors () .isEmpty ()) {}

    There is an error

    List errors = operationBinding.getErrors ();

    Browse the list of hollow and see if there is an exception of your restrictions

    }

  • How to put all through traffic the easy vpn client VPN server

    Hi people

    I want to ask you, how to put all of the server the easy vpn client VPN traffic through.

    I mean, I have a server vpn at home, and if I connect to the vpn from outside server, to be with an IP address of my home.

    There is the configuration up to now. Where is the problem?

    ROUTER1 #sh running-config

    Building configuration...

    Current configuration: 5744 bytes

    !

    ! Last configuration change at 19:51:18 UTC Wed Sep 4 2013 by cska

    !

    version 15.1

    horodateurs service debug datetime msec

    Log service timestamps datetime msec

    no password encryption service

    !

    ROUTER1 hostname

    !

    boot-start-marker

    usbflash0:CVO boot-BOOT Setup. CFG

    boot-end-marker

    !

    !

    !

    AAA new-model

    !

    !

    AAA authentication login ciscocp_vpn_xauth_ml_1 local

    AAA authorization ciscocp_vpn_group_ml_1 LAN

    !

    !

    !

    !

    !

    AAA - the id of the joint session

    !

    Service-module wlan-ap 0 autonomous bootimage

    Crypto pki token removal timeout default 0

    !

    Crypto pki trustpoint TP-self-signed-1604488384

    enrollment selfsigned

    name of the object cn = IOS - Self - signed - certificate - 1604488384

    revocation checking no

    !

    !

    TP-self-signed-1604488384 crypto pki certificate chain

    certificate self-signed 01

    3082022B 30820194 02020101 300 D 0609 2A 864886 F70D0101 04050030 A0030201

    2 060355 04031326 494F532D 53656 C 66 2 AND 536967 6E65642D 43657274 31312F30

    69666963 31363034 34383833 6174652D 3834301E 170 3133 30383239 31313539

    32395A 17 0D 323030 31303130 30303030 305A 3031 06035504 03132649 312F302D

    4F532D53 5369676E 656C662D 43 65727469 66696361 74652 31 36303434 65642D

    38383338 3430819F 300 D 0609 2A 864886 01050003, 818, 0030, 81890281 F70D0101

    8100CD 57 F1436ED2 8D9E8B99 B6A76D45 FE56716D D99765A9 1722937C F5603F9F

    528E27AF 87A24C3D 276FBA1C A5E7C580 CE99748E 39458C 74 862C 2870 16E29F75

    7A7930E1 15FA5644 D7ECF257 BF46C470 A3A17AEB 7AB56194 68BFB803 144B7B10

    D3722BDD D1FD5E99 8068B77D A1703059 9F0578C7 F7473811 0421490D 627F25C5

    4 HAS 250203 010001A 3 53305130 1 130101 FF040530 030101FF 301F0603 0F060355

    551 2304 18301680 141B 1326 C111DF7F 9F4ED888 EFE2999A 4C50CDD8 06 12301

    03551D0E 04160414 1B1326C1 11DF7F9F 4ED888EF E2999A4C 50CDD812 300 D 0609

    2A 864886 04050003 81810096 BD0C2B16 799DB6EE E2C9B7C4 72FEAAAE F70D0101

    FF87465C FB7C5248 CFA08E68 522EA08A 4B18BF15 488D D53D9A43 CB400B54 8006

    CB21BDFB AA27DA9C C79310B6 BC594A7E D6EDF81D 0DB7D2C1 9EF7251B 19A 75403

    211B1E6B 840FE226 48656E9F 67DB4A93 CE75045B A986F0AD 691EE188 7FB86D3F

    E43934FA 3D62EC90 8F37590B 618B0C

    quit smoking

    IP source-route

    !

    !

    !

    !

    CISCO dhcp IP pool

    import all

    network 192.168.1.0 255.255.255.0

    DNS-server 195.34.133.21 212.186.211.21

    default router 192.168.1.1

    !

    !

    IP cef

    No ipv6 cef

    !

    Authenticated MultiLink bundle-name Panel

    license udi pid CISCO892W-AGN-E-K9 sn FCZ1530C209

    !

    !

    username privilege 15 secret 5 cska $1$ $8j6G 2sMHqIxJX8MQU6vpr75gp1

    !

    !

    !

    !

    !

    !

    crypto ISAKMP policy 1

    BA 3des

    preshared authentication

    Group 2

    !

    Configuration group customer isakmp crypto VPNGR

    vpngroup key

    DNS 212.186.211.21 195.34.133.21

    WINS 8.8.8.8

    domain chello.at

    pool SDM_POOL_1

    ACL 120

    netmask 255.255.255.0

    ISAKMP crypto ciscocp-ike-profile-1 profile

    match of group identity VPNGR

    client authentication list ciscocp_vpn_xauth_ml_1

    ISAKMP authorization list ciscocp_vpn_group_ml_1

    client configuration address respond

    virtual-model 1

    !

    !

    Crypto ipsec transform-set esp-SHA-ESP-3DES-3des esp-sha-hmac

    !

    Profile of crypto ipsec CiscoCP_Profile1

    security association idle time 86400 value

    game of transformation-ESP-3DES-SHA

    set of isakmp - profile ciscocp-ike-profile-1

    !

    !

    Bridge IRB

    !

    !

    !

    !

    interface Loopback0

    192.168.4.1 IP address 255.255.255.0

    IP nat inside

    IP virtual-reassembly in

    !

    interface BRI0

    no ip address

    encapsulation hdlc

    Shutdown

    Multidrop ISDN endpoint

    !

    interface FastEthernet0

    !

    interface FastEthernet1

    !

    interface FastEthernet2

    !

    interface FastEthernet3

    !

    interface FastEthernet4

    !

    interface FastEthernet5

    !

    FastEthernet6 interface

    !

    interface FastEthernet7

    !

    interface FastEthernet8

    no ip address

    Shutdown

    automatic duplex

    automatic speed

    !

    type of interface virtual-Template1 tunnel

    IP unnumbered Loopback0

    ipv4 ipsec tunnel mode

    Tunnel CiscoCP_Profile1 ipsec protection profile

    !

    interface GigabitEthernet0

    Description Internet

    0023.5a03.b6a5 Mac address

    customer_id GigabitEthernet0 dhcp IP address

    NAT outside IP

    IP virtual-reassembly in

    automatic duplex

    automatic speed

    !

    wlan-ap0 interface

    description of the Service interface module to manage the embedded AP

    192.168.9.2 IP address 255.255.255.0

    ARP timeout 0

    !

    interface GigabitEthernet0 Wlan

    Description interface connecting to the AP the switch embedded internal

    !

    interface Vlan1

    no ip address

    Bridge-Group 1

    Bridge-Group 1 covering-disabled people

    !

    interface BVI1

    IP 192.168.1.1 255.255.255.0

    IP nat inside

    IP virtual-reassembly in

    !

    local IP SDM_POOL_1 192.168.4.3 pool 192.168.4.245

    IP forward-Protocol ND

    !

    !

    IP http server

    local IP http authentication

    IP http secure server

    overload of IP nat inside source list 110 interface GigabitEthernet0

    IP nat inside source static tcp 192.168.1.5 3389 interface GigabitEthernet0 3389

    IP nat inside source static udp 192.168.1.5 3389 interface GigabitEthernet0 3389

    IP nat inside source static tcp 192.168.1.5 21 interface GigabitEthernet0 21

    IP nat inside source static udp 192.168.1.5 21 interface GigabitEthernet0 21

    IP nat inside source static tcp 192.168.1.4 3389 interface GigabitEthernet0 3390

    IP nat inside source static udp 192.168.1.4 3389 interface GigabitEthernet0 3390

    overload of IP nat inside source list 120 interface GigabitEthernet0

    IP route 0.0.0.0 0.0.0.0 dhcp

    !

    exploitation forest esm config

    access list 101 ip allow a whole

    access-list 110 permit ip 192.168.1.0 0.0.0.255 any

    access list 111 permit tcp any any eq 3389

    access-list 120 allow ip 192.168.4.0 0.0.0.255 any

    !

    !

    !

    !

    !

    !

    !

    control plan

    !

    Bridge Protocol ieee 1

    1 channel ip bridge

    !

    Line con 0

    line 2

    no activation-character

    No exec

    preferred no transport

    transport of entry all

    transport output pad rlogin udptn ssh telnet

    line to 0

    line vty 0 4

    privilege level 15

    preferred transport ssh

    entry ssh transport

    transportation out all

    !

    Thanks in advance

    To do this you must make the following changes:

    (1) disable split Tunneling by deleting the ACL of your configuration of the client group.
    (2) enable NAT for VPN traffic by adding 'ip nat inside' to your virtual model of the client network to the ACL that controls your PAT.

    Edit: Theses are the changes to your config (also with a little cleaning):

    Configuration group customer isakmp crypto VPNGR

    No 120 LCD

    !

    type of interface virtual-Template1 tunnel

    IP nat inside

    !

    no nat ip inside the source list 120 interface GigabitEthernet0 overload

    !

    access-list 110 permit ip 192.168.4.0 0.0.0.255 any

    no access-list 120 allow ip 192.168.4.0 0.0.0.255 any

    Sent by Cisco Support technique iPad App

  • How to remove all items in the download under bookmark folder in the shortest time?

    I understand that all downloads from the internet and yahoo/google mail are stored in the "Download" folder I bookmarked when I want to delete. I think that if the download folder is never empty, then my mac will slow down. So I want to remove these downloads that I've seen. How can I remove all THE items in the shortest time? Deleting items, even in groups, takes a long time. Is there a method I can use so that all the items in the folder are deleted in one fell swoop?
    Thank you.
    Unguja

    Yes, it worked. Thank you very much.
    Unguja

  • Z10 blackBerry how to remove all entries from the Local calendar?

    My calendar shows my email entered account and all is well.  However, I think that when I transferred all of my Bold 9900 he faces a bunch of entries in the local calendar (House) that I don't want.  I would like to delete all entries in the local calendar.  How can I do this?  Thank you!

    Unfortunately you can't remove individual events right now. The fastest way to remove events is the 'Month' tab, then tap and hold events in the list and select 'Delete' from the side menu.

  • component AF:chooseDate - how to disable all dates in the past.

    Hi, I need to disable all dates in the af:chooseDate component.

    I should probably use DateListProvider for that, but don't know how.

    Thank you.

    KT - thank you very much.

    My bad, I completely missed the af minDate property: chooseDate.

    Exactly what I needed.

  • How to make all audio at the same level?

    I have a sequence of many clips in first pro, and I could swear I've heard of a way to make all audio on the same level or db. Is there a way to do this? I have a few clips in the timeline with different levels and should be old enough to go to manually balance their volume.

    There is a way to do what you want, but it must be used with caution.  If you open the Audio Mixer Panel, select mixer of track and the track that your clips are on.  Click on the arrow at the top left of the track work (you may need to do it twice) and and access the small white window that goes down.  (See using Adobe https://helpx.adobe.com/pdf/premiere_pro_reference.pdf page 365 if you have not done this before) In the right side of this window, right-click on one of the spikes back arrow and select Amplitude and Compression and dynamics.

    The word dynamic appears in the white window at the top of channel mixer.  Left click on the word dynamic and select Edit.  I pasted below the appropriate settings.

    If you are not familiar with Compressor/Limiter, use the parameter above.

    Now read your timeline and listen carefully while I look at the counters this setting should be good for normally recorded material, and I hope that you do have to do something more. If there is still following problems may be necessary. Schedule audio below (2) drag any clip that's too soft.  All that is too strong to do drag on the calendar below that (3). For the dynamic audio editing 2 repeat the process with the effect but change the makeup to 12.00dB.  For editing audio 3 change the makeup to 0dB setting.  It's not perfect, but it should give you a low-tech solution.   I hope this helps.

  • How to enlarge all images in the document using a script?

    Hello

    I used the script ImageCatalog to place a 1000 + images of different dimensions in the document. In the ImageCatalog dialog box, I unchecked the proportional and the frame option content to place images at 100%. I'm looking for a way to extend all the frames graphics to reveal images that he placed on the document. When you double-click the bottom right handle, will expand the framework to see all the content. (it would be your time when you do this one by one)

    Let me know. Thank you very much.

    If I understand you correctly, you have placed images without using frame to adapt to the content and that you now try fix this? Do you find that a fair executives greater and, at this point, can do their overlap others? If this is going to be a problem, just run the script again but this time with the correct settings...

    In any case. Typing on my iPad so I can't check. but something in the lines of

    g = app.activeDocument.allGraphics;

    for (i = 0; i

    g [i] .fit (FitOptions.FRAME_TO_CONTENT);

    See http://jongware.mit.edu/idcsjs5.5/pc_Graphic.html#fit

Maybe you are looking for

  • How to restore the files on my iMac?

    Try to make my window smaller files on my iMac, the window disapeered. I can simply not take the line that has to drag that bag. I only continue to reshape the Thunderbird window as a whole.Groeten,Hannie

  • Memory external flash for iPhone 5

    IS it advisable, and if it works well if memory external flash like sandisk SanDisk iXpand Flash drive for iPhone 5-16 GB and 2-32GB iPad? good work means: all types of ll of audits and usable on hardware videos files, can a being exchanged between e

  • What has changed on the edge of the glass around FF4 in Win7?

    In general, I don't have my FF4 (RC1) maximized window if I see the trim around the window of FF glass. However, I noticed that Microsoft tweaks than glass garnish with a lighter shade upwards on the sides and a darker shade on the lower part of the

  • Do not install the automatic updates Windows XP, download error 0 x 80246008

    Have failed several times - have bits set @ auto - confident to rectify, not lack of computer knowledge and seems almost impossible to get thru to Microsoft - who are looking for an easy solution / single or coordinated for Microsoft - T.I.A Got erro

  • Windows XP won't start in normal mode

    When you start the computer normally, he will just stay at the Windows loading screen forever. It allows me to start safe mode and I did a system restore, but this does not solve the problem. I don't know what other steps can I take to get my compute