xfa.host.gotoURL () in Adobe Reader / dynamic Tables to AcroForms?

Hi all

I have a dynamic array in my form of life cycle. Each row in the table contains a button that connects to an external PDF file (using xfa.host.gotoURL). The links work fine in Acrobat Pro 8, so far, so good... But when you click on the buttons in Reader 8, nothing happens. No error message or a security warning, nothing...

I searched on the web and some forums for this problem and read between the lines of some posts, I came to guess that my lifecycle of the form will not work in Adobe Reader unless I have purchase the license of life cycle of the respective Extensions... :-/

What exactly are my options now? I cannot get the buttons to work in Adobe Reader somehow (using JS) without having to buy the Reader Extensions? Or can I somehow to recreate the dynamic table of the form of the lifecycle using AcroForms in Acrobat 8 Pro to avoid the problem I have? If so, how can I add such a table using Acrobat form... Tools?

Thanks for your help,
Marcus

Advertisement

You can use:

app.openDoc (FilePath.rawValue);

to open another form of Adobe.

Tags: Adobe LiveCycle

Similar Questions

  • xfa.host.exportData("",0); may not work in adobe reader, why?

    Form1. Config.Button1 [0]: click - (JavaScript, client)

    xfa.host.exportData("",0);

    export .xml file, it works in format adobe acrobat, XI.

    In adobe reader, click on the button, may not work.

    Why?

    Thank you ~.

    Player cannot export data from form unless the document has been activated with the use of import/export of straight form with LiveCycle Reader Extensions. Acrobat cannot activate the document with this right of use.

  • Dynamic PDF is more made in Adobe Reader 11.0.07

    We have a number of dynamic forms of XFA (PDF) we sent to end users. These end users are in the process of upgrading to Adobe Reader 11.0.07 (Windows, published on 5/13). However during the upgrade, users when you open the form get a number of modal dialog boxes with a notice stating "Invalid parameter." There may be several dialog boxes with this same error, one after the other. When the errors stop, instead of the actual shape displayed, a boilerplate message notify the user that they need to upgrade to Adobe Reader 8 appears (see below).

    bad parameter.png

    boilerplate.png

    I tried to change a number of form fields and settings, but nothing seems to affect the outcome. Does anyone else have this problem?

    I think I found the culprit of the error in the XML view:

    http://www.XFA.org/schema/XFA-template/3.3/ DisplayDocTitle:1? >

    I removed the part DisplayDocTitle:1 of the tag and the error disappeared. Would be nice if Adobe error actually tells you which parameter was wrong instead of having to study by trial and error.

  • Errors appear in the profile of host and Adobe reader does not work, but works fine in profile comments?

    Errors appear in the profile of the host, but nobody else. Problems with the bar side in the profile of the host, but box for comments function profile works very well. Adobe reader software also works at the end of comments, but does not work in the profile of the host...

    You probably have a corrupt user profile.

    This article gives instructions on how to deal with it.

    http://Windows.Microsoft.com/en-us/Windows-Vista/fix-a-corrupted-user-profile

  • Dynamically read the table name in the query update

    Hi all

    I am trying to run the updated sql query where the name of the table should be read dynamically from another table below.

    Please let me what wrong with my request.

    setting a day (select CONCAT('T',schemaid) from outline, which the name = 'Analyzer') set c7 = 99;

    "outline" is a table that contains two columns name and schemaid.

    all the table created in our database with the prefix 't' T4345 for example.

    I did as suggested by you

    No, you didn't.  I did not any package creation code in my example, in order to better that you you point the finger.

    Your syntax is invalid for creating a package with the code like this, please read on creating packages and procedures within them if that's what you want to do.

    In addition, your package creation statement is to create a package specification, but you put in the code which must be in a package body, not a notebook loads.

    It should be something like (untested since I don't have your tables)...

    create or replace package my_packg as
    procedure dowhatever.
    end;
    /

    create or replace package body my_packg as
    dowhatever procedure is
    TBL varchar2 (30);
    Start
    Select 't' | SchemaId
    in tbl
    of outline
    where name = 'Analyzer ';
    run immediately 'Update'. "TBL |' set c7 = 99;
    end;
    end my_packg;
    /

    and then call this procedure by calling my_packg.dowhatever ();

  • XFA dynamix form into something else then adobe reader

    Hello

    We are currently having problems with people not not with adobe reader as their standard program to view pdf files.

    Most of them use NitroPDF. The problem is that this viewer does not support XFA forms.

    Is there a way to force, for example using javascript, to use adobe reader? (software definition adobe reader as standrad in the OS drive is not an option)

    Kind regards

    Nothing

    You can't force them, but you can try to educate them.

    basically if a form cannot be accessed in Adobe not viewers/readers, it would still show a (a.k.a pagezero) page that shows a default message.

    You can customize this page to inform users that the XFA forms do not work in other players.

    customization of the help available here: help forms AEM 6.0 | Change Page zero content in the designer of

  • Recommended for users of a Web site hosted in Windows server 2008 r2, the versions of Adobe Reader

    We have a web application that is hosted on a server in Windows 2008 R2 where users download PDF documents. What versions of Adobe readers should be informed as the minimum configuration.

    Hey user11203456,

    The version that I mentioned is specific to Windows 2008 R2 server. In the link provided when you select the version of the platform & the language, it will offer you the suitable Adobe Reader version.

    Kind regards

    Nicos

  • Unable to render dynamic forms in Adobe Reader 11.0.2.0 for Firefox

    Hello

    I had just updated my browser (Firefox) plugin from Adobe Reader to the latest version of 11.0.2.0, and it seems that he is unable to make the PDF DYNAMIC forms created by Adobe Livecycle after that. However the STATIC forms are correct.

    Is there anyone face the same problem? Adobe is aware of this?

    Thank you.

    Using Firefox 19?  If so, see http://forums.adobe.com/thread/1158136

  • I can't open file of police control Victoria, it keeps saying updating Adobe reader but I have already the latest version. How can I fix it?

    I can't open file of police control Victoria, it keeps saying updating Adobe reader but I have already the latest version. How can I fix it?

    Some PDFs (dynamic XFA forms) created in Adobe LiveCycle can be opened in Adobe Reader and Adobe Acrobat. When you try to open these files in an alternative PDF reader, then you will see this error message.

    Unfortunately, it is not easy to remove this message and change the PDF file so that it can be opened in the alternative PDF viewers. The person who created the original form must recreate the shape using the options that do not restrict viewers PDF can open and view the file.

    Adobe has made the decision that since very few non-Adobe products are supported on these PDF files special, it is best to show this message - and require the user to download Adobe Reader or Adobe Acrobat - that is to let the PDF Viewer try to view the document. You can ask the user to drive - extend documents so that you can view it with Adobe Reader.

    To ensure that the browser is configured to use the software Acrobat Reader plugin, please see KB: configuration of browser using Adobe Acrobat PDF plugin

    Kind regards

    Rave

  • Adobe Reader [iOS]

    I have an Air of IPad and trying to display my electronic statement online, it is said that I need to install the latest version from Adobe, but it is already installed. What can I do to make this work? Thanks for the help!

    Hello

    When you open the PDF form, you see a message like this?

    Please wait... If this message is not subsequently replaced by the good content of the document, your PDF reader isn't able to display this type of document. You can upgrade to the latest version of Adobe Reader for Windows®, Mac, or Linux® by visiting http://www.adobe.com/go/reader_download.

    Your PDF form is a special type of form called "dynamic XFA form. The message appears when dynamic content is not supported by a PDF Viewer.

    Currently, mobile products Acrobat DC (for iOS and Android) do not support any static or dynamic XFA forms created with Adobe LiveCycle Designer.

    Please use the drive on a Mac or Windows computer desktop version to open and complete the XFA form.  Sorry for the inconvenience.

  • Using Script to check the version of Adobe Reader software

    Hello. I am now currently using LiveCycle Designer to create a form that allows users to attach attachments. We found that if a user uses Adobe Reader 7.0 or below, there is a problem on fixing attachments. Accordingly, we would like to add a script to check the version of the Adobe Reader client in a ready state of the form. If a user uses Adobe 7.0 or below, the message box opens and suggests the user to download a more recent version of the Adobe Reader software. I would like to know is possible to do so. Thank you very much

    Hello

    the script might look like:

    If (typeof (app.viewerVersion)! = "undefined")

    If (app.viewerVersion<>

    {

    xfa.host.messageBox ("your Version of Adobe Reader is old...");

    }

    }

    You can use it in the docReady:Event of your form to inform users.

  • function xfa.host.exportData

    Hi all

    I have a problem with the xfa.host.exportDatafunction:


    My script is as follows:

    -J' made a form with several fields.

    -A user determined open this form and fill in the fields.

    -That the user is able to send the form via PDF or save in XML format.

    In Acrobat 8 Professional, there is no problem to make these features but in Acrobat Reader 9, the user cannot save data in XML format.

    I placed the xfa.host.exportData("",0) function in the click event of a checkbox.

    I would like to know if it is possible to get the same functionality in Adobe Reader as Adobe Professional.

    Thanks in advance.

    Best regards.

    Hello

    You can apply rights Reader Acrobat 9 Standard or above, but these are limited.

    LiveCycle Reader Extensions is a server product, which is part of the suite LiveCycle. See here:

    http://www.Adobe.com/UK/products/LiveCycle/readerextensions/

    It does not require Acrobat in particular, because it is not 'on' for installed Acrobat. You must contact Adobe sales at your location to know the costs and components required.

    If you want to export the XML data, then you are looking at all the users with the full version of Acrobat (option 1) or you want to apply rights to drive using LC Reader Extensions (option 4).

    Hope that helps,

    Niall

    Ensure the dynamics

  • "Extend the functionality of Adobe Reader" causes additional lines to appear in pdf format

    Afternoon,

    I have a table set in place where I add/remove lines to 3 points in the table, as I have 3 columns within the table.  It was created in Adobe LiveCycle Designer 8.2... I want the form on the next page that works very well, it is saved as XML dynamic.

    Now, I need the form to be completed by users using Adobe Reader 9 and to do this I open the form in Adobe Acrobat 9 and then save a copy after selecting "extend features in Adobe Reader... However now when I go and open this file, the lines that were not initially in the form appear under the buttons of the rank final Add/Remove... as if someone has press Add line 10 times.

    Any ideas what is causing the form to change?

    Thanks in advance for your help,

    Jason

    I need to see your form template to know what is happening... often send you it to [email protected] and I'll have a look when I get the chance.

    Please include a description of how to reproduce the problem with email.

    Thank you

    Paul

  • If I use the adobe reader 7.0 software to open LiveCycle Designer ES2, what will happen?

    Hello

    I intend to recommend adobe LiveCycle Designer ES2 as a software designer of forms for a client company. But it seems that the client always uses the old version of adobe reader 7.0.

    So I need to know that it is essential to use the adobe reader 9.0 for designer ES2 software and if Adobe reader 7.0, this problem would happen?

    It is very useful, if there is detailed information on this subject.

    Thank you

    Shoku en

    Hello

    When you design a form in LC Designer ES2, you can set the version target of Acrobat/Reader software in the file > properties > default values tab.

    While you can target v7, be aware that some features in LC Designer ES2 is not supported in Reader v7. For example in LC Designer, you can define the presence of an object "(screen visible only)", but it is not supported in Reader v7, so would cause a problem. So for each form you will need to set the version of the target, and then check the warnings palette to see if there are problems.

    See the post by John Brinkman discussing Acrobat X, as it's a very handy table for the versions of the specification of the designer/XFA LC and Acrobat/Reader: Acrobat X and XFA 3.3

    XFA Version Acrobat/Reader
    2.1 6.02
    2.2 7.0
    2.3 7.0.1 7.02
    2.4 7.0.5, 7.0.7
    2.5 8.0
    2.6 8.1, 8.1.1
    2.8 9.0
    3.0 9.1, 9.2, 9.3
    3.3 10.0

    You can see there are a lot of changes around v7 and if the user has v7.0.7 Reader, you can use the features of 2.4 XFA specification.

    The other question to know is that users with the player will NOT be able to save data in the form, UNLESS the form has been enabled for reader until the form is deployed.

    The form can be active player in two ways:

    • Using Acrobat Standard v9 or Acrobat Professional v7 or v8. A license restrictions, see the EULA.
    • With the help of a server product called Adobe LiveCycle Reader Extensions ES2. Extra charge.

    Here is a summary of the options available for users with the player, depending on whether the form is activated to drive AND how she has been activated:

    There is a post here and a summary in PDF:

    http://assurehsc.IE/blog/index.php/2010/05/using-LiveCycle-Forms-in-Acrobat-and-reader/

    Hope that helps,

    Niall

  • How to activate Adobe Reader software call Webserices

    Hello

    I use the code following javascript in a PDF file to call a WebService (dataconnection)

    xfa.host.messageBox ("connect call. Run");
    xfa.connectionSet.guidConn.execute (0)
    xfa.host.messageBox ("Done");

    When I run the present in Acrobat Professional, it works very well and called the webserivce and returns the data. But when I open the PDF using Acrobat Reader, the webserivce does not run. I only get messagebox frist and then the execution stops. I already tried the 'characteristics Extend in Adobe Reader', but it does not help.

    Is there anything else needs to be done so that Adobe reader can call Web services? Or is it even possible at all?

    Thank you

    Marie Pascale

    You must purchase/license a copy of Adobe LiveCycle Reader Extensions Server to allow SOAP/webservices for forms in Adobe Reader.

Maybe you are looking for

  • Error code 643 update (Microsoft Silverlight KB979202)

    Update for Microsoft Silverlight (KB979202) fails with the error code 643; several test update.

  • Emailing executables

    Hello I currently have a problem emailing my executable that I generated. Gmail, or Outlook will allow me to attach my .exe file and send it.  Does anyone know how to fix this? Thank you Mmoon

  • I broke my Bios and the pc does not start

    I'm a gamer and was thrown my Bios operating system when my pc restarted to power up I have a screen white im course I messed up something in the bios and would like to know if anyone knows a way to fix it so I can put my bios failure to OC'ing {sick

  • Try to install Microsoft Flight, download error: 0x8007000d

    I try to install MS Flight and receive an error extraction failed.  Here is the log.  Please advise, thank you. -------------------------------Logging started: 03/03/2012 12:07:35Source file: C:\Users\USER\DownloadsOS v6.1 Service Pack 1 (build 7601)

  • Can I pass a second var to the listener function.

    new to actionscript and it can not find on google... I don't know it exists, but I have worked around him twice and really want to do it now and do not know how. When you add an event listener mybutton.addEventListener(MouseEvent.Mouse_UP, myListener