Action JavaFX class 8

I'm migrating Swing to JavaFX and noticed that there is no replacement for the category 'Action' of the Swing. This one is nice because it encapsulates the work to be done with a clear name and a Boolean value disabled. I reinvented the wheel to get the same thing in JavaFX right now. That intention is missing or is he expected to come in a future release?

Unfortunately, it seems that the dialogs API does not contain an Action API. At least I've found in the last set of changes. What a pity. in any case, I already programmed by own framework for Action which serves well, so I just have to stick to it.

Tags: Java

Similar Questions

  • The JavaFX class hierarchy

    I have a question about the architecture of the JavaFX class. In fact, she should follow the pattern of composite named design looking for this http://en.wikipedia.org/wiki/Composite_pattern way somehow.

    However if I want to draw the composite model of the JavaFX package I find myself sort of this way:

    It seems that I can add children to buttons or labels. It was also possible with SWING. Why it has not been repaired? Is this a feature? On the other side window and the steps are now outside the model. In fact, they should be Parents I think. Why is it designed this way?

    Hope someone can enlighten me upward. Thank you very much for your answers in advance.

    > Actually it must follow the model of composite named design somehow.

    I think you are trying to simplify things.

    The JavaFX scene graph is a composite structure, but its design is subtler than a model composite vanilla.

    The basic concept of the presentation of JavaFX is a scene graph.  A scene contains a node tree, which forms the scene graph.  Any node that is not a leaf is a parent.  The parent base has a public method getChildrenUnmodifable and a protected getChildren method.  This means that you cannot add outwardly new nodes to a Parent unless you provide additional APIs.  The only thing that can add children to the mother is the Parent or the subclass of the Parent.  So, there's some cache information to go on.

    Some subclasses that act like editable containers expose their list of children to be publicly editable.  Usually, this is done by providing a public getChildren method.  A component, which is the root layout manager class, so in general, you can change the children of any pane layout is an example of such a class.  Conversely, if you have something that does not expose its getChildren method publicly, then external components cannot directly change the children of this thing.

    Region and the control are examples of nodes that extend from Parent and do not provide a public API getChildren.  As a button is a control, if you can not directly change her children through the public API.  The only way to change the control's children is to provide your own skin or to use additional modifier of APIs that control could provide.  For example, a button can have a chart, you can set the button and thus provide an arbitrary node or node tree to the button.  However, that is not quite the same Exhibitor getChildren button, because the graph is just a node, and layout in the button can be handled by the button through the display of the content of the button setting.

    OK, so JavaFX should not have had this complexity.  He could really go for a simpler approach where everything is a node, there are only a few types of nodes and HTML node types are not extensible example.  But he did not do this.  Instead, he went for a more detailed breakdown of the nodes of types, with each type supported by an object model providing State and functionality.  It's just a different approach.

    > It seems that I can add children to buttons or labels.

    Have you tried to do this by calling getChildren on one of them to get the list of children so you can change?  I bet that you could not do.

    > Window and steps are now outside the model.

    Yes, they are not part of the scene.

    All this is just a metaphor for the theatre.  Imagine that you go to the theater to watch Romeo and Juliet.  You sit in your Chair and watch the scene, the curtain has just unveiled the first scene.  The scene contains a background (a square of city to Verona in Italy), some accessories (swords and a fountain) and actors (nobles) who move and speak and go away.  These things in the scene are the nodes of the scene.  The curtain goes down and another scene appears, then again and another scene.  Finally, you arrive at the scene of the balcony where Romeo climbs the wall to join Juliette.  Whenever the curtain goes down, a new scene is assembled, and when the curtain rises the new scene appears.  All the time, the scene never changes.  This isn't a part of the scene.  The scene is the scaffolding in which many different scenes will appear.

  • How to pass values from a Java class to a class of JavaFX?

    Hi Forum,
    I get nuts on this problem:
    I designed a program with Java and JavaFX classes. JavaFX classes handle the GUI and Java classes mix program logic. I think that's the way it is supposed to be. My program calculates something, so in my JavaFX GUI, I have a button to run this calculation. It's not a problem to call the start function calculation (which is in my Java class) on click of a button. But now I want to display the result of this calculation in my GUI. I can't just simply pass the result to my class of JavaFX GUI. I tried to import the JavaFX class in my Java class to call a set function, but I can't import them with the import statement. So my question is, how do I make the results to my GUI? What is the right way to do it?
    I hope someone can help, thanks in advance :)

    Two ways, either:

    -your JavaFX class asks the Java class for the result once the task completed in exactly the same way he instantiated to start the task. Of course, you should regularly check the completion of the task (a mere PauseTransition).

    - or your JavaFX class implements a Java INTERFACE and your Java class accepts (whether through the method or constructor) a variable of type of this interface. For example, you can set a reference to the subject of JavaFX itself in the Java object using the interface.
    When the task is completed, your Java class calls a method defined in the INTERFACE to set the result in the object of JavaFX.

    In addition, JavaFX 1.3.x provides an API to start asynchronous and be notified when a task is completed in the javafx.async package that allows you to run the task of basic Java (you mind that the class is named...) JavaTaskBase, see also the RunnableFutre interface) in a separate thread.

  • Difference between an ActionScript file and ActionScript class

    Hello

    Could you get it someone please let me know what is the difference between a file Action and the Action Script class

    On the Flex Builder it offers the possibility to create an ActionScript file as well as
    an ActionScript class.

    Can someone please let me know what is the difference between these two?


    Thanks in advance.

    Kiran,

    ActionScript file is basically something that you can include in your mxml file is similar as you write the code in the tag. Where class actionscript will behave as an object for which you can create the new instance.

    Ankur Arora

    Project Manager (Flash and Flex)

    http://flashdeveloper.blogspot.com

    http://www.Ankur-Arora.com

  • I can't seem to grasp how FXML and data binding is useful beyond basic, static views

    The markup is not any sort of logic/iteration as the additional taglibs in JSP capabilities (i.e. < c:forEach var = "${model.") (Person}"> < c: out >$ {person.name} < / c:forEach >) so you're stuck making the dynamic aspects of the UI in pure Java (unless you are supposed to use < fx:script > to do this, that there is little or no documentation/examples/etc.).  Makes organizing difficult associated classes because you so specific to the logical view of the controller (i.e. for each complexItem - create a graph of node that represents a complexItem, add to the list;). It seems that this sort of thing belongs to the "view" class  What happens if the complexItem is a custom control specified in FXML.  What grade is supposed to handle the onMouseClicked event when the user clicks on complexItem.  The controller class that supports that the first of the complexItem, or the controller class displayed several complexItems in the list?  You're supposed to pass the event in the chain of controllers, each parent is to know?

    I can't just wrap your head around this design and how it can be used to create a correct application of the MV * with a clean design.  FXML basically breaks controllers me by exposing specific UI widgets.  Looks like there should be a separate view class that stores the FXML.  Especially in cases where you need to "Finish" the view because all you want to do, cannot be expressed in FXML (like using half of the ControlsFX controls).  So you want a separate controller class to manage the model update (and switch to the update view in the case of Passive View or update the properties in the case of Supervising Controller) and managing events behaviors.  It works well, because FXML and the associated RAD tools requires you to use one and fx:controller only category excluded.

    I want to as JavaFX, I don't really have, but the lack of attention in this area, it's mind-boggling.  I read through tons of blog posts and it seems that there are tons of questions and debates but few answers and resolutions.  I even bought two books on JavaFX8 Apress and or design a model address other than a small introductory text or two and a reference to Afterburner and Dolphin something or other.  It seems that no one has proved a solid design with lots of views/controllers/presenters/viewmodels nested... I don't know even what term used more because it's so confusing.

    > The markup is not any sort of logic/iteration as the additional taglibs in JSP capabilities (i.e. ${person.name}) so you're stuck making the dynamic aspects of the UI in pure Java

    Taglibs themselves are implemented in Java.  You can implement a custom control in fxml, which could allow you to get similar functionality.  Personally I don't really make sense in XML, I think it is better expressed in a procedural or functional programming language and just leave XML for declarative programming; that is for straight definitions of things.

    If you really want to combine JSF taglib features with JavaFX style, you should look into CaptainCasa, that serves as a front end of JavaFX for JSF applications (I've never used this framework).

    > unless you are supposed to be used for this

    Yes, you are made to define custom controls, use the logic of the controller or use scripts (in whatever language please).  The model is the same that javascript html (which is also usually XML based like FXML), which I think turned out based on how many javascript/html is there.  I'm not a big fan of the javascript/xml model, but at least with JavaFX, you have a little more flexibility based on the ability to choose between several languages for scripts and controllers, a collection more complete and accurate the confrontations of control in element names widget and a possiblity to extend the basic elements to create your own custom elements to incorporate the new controls and layouts rather than continuously replace the div and span.

    > It seems that this sort of thing belongs to the "view" class

    I don't really know what the view class is in your definition.  There is no view defined in JavaFX class.  The closest thing is probably a control's appearance, but I feel that is different from what you are suggesting.  The FXML system was built not to be opinionated concerning the architecture used to build applications with it (like an anti-RAILS framework).  The reason for this is that it's just a basic shipped with Java runtime component and not a framework for application complete.  You can always build a style of RAILS framework that had such notions as the view classes and operate with FXML.  There are samples of these frames if you are interested; JRebirth, Griffin.  And there are others who do not use FXML at all; for example FXForm.  Perhaps my favorite and start studying is Afterburner.fx because of its simplicity.

    > What happens if complexItem is a custom control specified in FXML.

    I guess that there are different types of "custom controls", those who actually extend its control and provide an API and control skin following the architecture of JavaFX controls.  In this case the control generally encapsulates the view state (for example who did, how event handlers are defined) and delegates to the skin and a pattern of behavior (interface keyboard controls, etc.) to manage the predetermined nodes, etc.  In many cases for the application code, such a complicated configuration is unnecessary and can make your code more difficult to understand due to the increase of indirection involved by the model.

    The other type of control is something a controller FXML that loads its definition of layout of the user interface in FXML and encapsulates its hierarchy and control node interface in a class that can be instantiated in FXML, as defined in the tutorial Oracle Mastering FXML.

    Both types of controls have their place in a JavaFX application, with extensions of control usually from libraries such as ControlsFX instead of the application code.

    > What grade is supposed to handle the onMouseClicked event when the user clicks on complexItem.  The controller class that supports that the first of the complexItem, or the controller class displayed several complexItems in the list?

    Initially, a UI (node) element that represents your complexItem will receive the mouse click event.  One way to do it is to have a class of skin (encapsulating nodes) associated with your model (or the view in some modern managers model) and which may have observable properties that are set when the actions are performed on the node.  Then your view model/presenter can observe the changing properties in the skin to react based on the observable properties.  You can see many examples of this model in the JavaFX controls source code base or this app of TIC-TAC-TOE (most of these samples are not based FXML).  Most simple, is often to encapsulate the nodes and the event handlers in a single class (e.g. the FXML controller), as is done in the FXML connected mastering tutorial above.

    > Are you supposed to pass the event in the chain of controllers, each parent is to know?

    Generally not, I would say.  Treatment of JavaFX event will automatically events up and down the hierarchy of nodes.  Your controllers (or skins) according to what is in fact linked with the nodes, can add appropriate listeners and filters which react to the events of the UI and update your State application model directly or set the observable properties that domain not associated with GUI logic could listen and react on.  You can also introduce a bus event to propagate and manipulate events (if your application warranted and such an architecture is consistent with your app needs).  If you want to be really sophisticated, then you slap on an Messaging model-based architecture, but by then you're really in a lot of complexity and really need to know what you're doing.

    > I can not just wrap your head around this design and how it can be used to create a correct application of the MV * with a clean design.  FXML basically breaks controllers me by exposing specific UI widgets.  Looks like there should be a separate view class that stores the FXML.

    Well what are the 'controllers' FXML.  Maybe just don't call them controllers.  They don't really control anything, unless you put the logic in them to do (and you don't need to).  By default, they are just holding FXML and Java classes link to allow references to JavaFX nodes and events related to the FXML Java handlers.  You do not even need to call your controllers to controllers in your code, you might call them just something like myItemUIBinding.  Again, I suggest that you take the time to look at afterburner.fx, to see how a more 'opinionated' framework defines a simple architecture to help impose a stronger separation of concerns than the standard vanilla to FXML controller installation.

    > Then you want a separate controller class to manage the model update (and switch to the update view in the case of Passive View or update the properties in the case of Supervising Controller) and managing events behaviors.  It works well, because FXML and the associated RAD tools requires you to use one and fx:controller only category excluded.

    I guess I don't understand that.  You can incorporate several controllers of the child.  You can create your own controllers.  You can set the listenable properties on the controllers.  You can pass objects to model to the controllers.   You can bind a controller to a skin or you can use an Ombudsman model to create a controller supervisor.  Acquired some of these things may be obvious or not clearly demonstrated in tutorials.  There is no equivalent (well used) JavaFX to say spring or Play that sets common criteria in a unique setting and open source large scale the application based on it you could read or derive best practices of.

    > No one has proved a solid design with lots of views/controllers/presenters/viewmodels nested, it seems...

    Agreed is that there is a lack of scale large source code public for applications that rely heavily on FXML and demonstrate an architecture for building complex applications based on it.  Is perhaps the closest, you can find the source code of SceneBuilder, but, unless you create a development such as scenebuilder tool, you can see that some of the reasons he doesn't quite apply to your use case.

  • PlayStation Network sucks!

    I'm Livid angry. My games doesn't work on the PSN anymore and PSN decided to try to violate my constitutional right to civil action through class action. These freaks sent a 3000 + terms of service for my son 13 years and his daughter as if they would be subject to outrageous conditions and ridiculous games consoles. No judge in the United States must respect the clause of shit. For more than a week I couldn't play RE5 do online glitches in servers. I know it's servers, so not even worth trying to excuse it by me. My brother was head of home computer for the US Army during the desert storm and my brother-in-law is a specialist in the hardware store. I always three bars during playback and I know that playstation has done something to make this happen. I think you jerking me a virus and I think it was on purpose and I think it's in my ps3 now. I hate Sony now, I would not buy another Sony product if they were the last ones on Earth.

    Thanks for your post, but the forums here are for products Sony Vaio and consumer only. PlayStation support have their own separate forums and therefore are better qualified to deal with any problems or questions you may have on the PSN, PlayStation products and devices and games - here is the link:

    http://community.us.PlayStation.com

  • QoS policy &amp; policy-card entry on marking interface

    Dear experts from Cisco,

    I am deploying QoS on a WAN. On the LAN to the interface of a 3845 router, I need police and mark traffic between the local network. I tried to add two separate policies of the interface, but this was rejected.

    So my questions are;

    1. is it possible to have two incoming policies on an interface? If so, how?

    2. If the above is not possible how the above is possible using nested policies?

    Here's my policy:

    Policy-map MARKING
    class VOICE
    set ip dscp ef
    class in time REAL-INTERACTIVE
    set ip dscp af41
    class CRITICISM-DATA-AF31
    set ip dscp af31
    class CRITICISM-DATA-AF21
    set ip dscp af21
    SIGNALLING of class
    set ip dscp cs3
    the class of DATA MASS
    set ip dscp af13
    class SCAVENGER
    set ip dscp cs1
    NETWORK-CONTROL class
    set ip dscp cs6
    class class by default

    !

    POLICE policy-map
    class VOICE
    Police cir 5000000
    EF game-dscp-transmit action in line
    EF exceed the action set-dscp-transmit
    failure to send set-dscp action violate

    This is the error I get when you try to add the second sheet of policy to the interface:

    Router (config) #int IM 0/0/0
    Router(Config-if) #service - political POLICING entry
    Political map of MARKING is already attached

    Thanking you in advance for your help and your time.

    Kind regards

    Paul

    Disclaimer

    The author of this announcement offers the information in this publication without compensation and with the understanding of the reader that there is no implicit or explicit adequacy or adaptation to any purpose. Information provided is for information purposes only and should not be interpreted as making the professional advice of any kind. Use information from this announcement is only at risk of the reader.

    RESPONSIBILITY

    Any author will be responsible for any wha2tsoever of damage and interest (including, without limitation, damages for loss of use, data or profits) arising out of the use or inability to use the information in the view even if author has been advised of the possibility of such damages.

    Poster

    Only one service entry and/or authorized release policy.

    You don't need a strategy nested.  Change class of your MARKING policy VOICE to be what you have for your POLICE policy VOICE class.

    i.e.

    Policy-map MARKING
    class VOICE
    set ip dscp ef

    Police cir 5000000
    EF game-dscp-transmit action in line
    EF exceed the action set-dscp-transmit
    failure to send set-dscp action violate
    class in time REAL-INTERACTIVE
    set ip dscp af41
    class CRITICISM-DATA-AF31
    set ip dscp af31
    class CRITICISM-DATA-AF21
    set ip dscp af21
    SIGNALLING of class
    set ip dscp cs3
    the class of DATA MASS
    set ip dscp af13
    class SCAVENGER
    set ip dscp cs1
    NETWORK-CONTROL class
    set ip dscp cs6
    class class by default

    ! You can also set a default class marking

    ! MAYBE

  • configuration Cisco No. 2851 IPS intrusion prevention system

    Hi, I wonder - could someone guide me to the implementation of IPS intrusion prevention system. I'm new to the world of cisco and still did not have my head around it. for the intrusion prevention system IPS I put 0/1 (lan) entrants and g 0/0 as a wan?

    Hello

    You must be careful when activating the IP address of your router. Category will activate you more cpu/memory will be used, and your router may crash.

    I'll write all the config as directly here, because it is a good step by step by Cisco:

    http://www.Cisco.com/c/en/us/products/collateral/security/iOS-intrusion-...

    I'll also join a best practice document from Cisco.

    IPS/signature of software should be found on the Cisco's Web site: https://software.cisco.com/download/release.html?mdfid=282941564&reltype...

    To answer your question, you can do inbound and outbound on your WAN interface (attacks should come first to the outside).

    If you have enough power, why not do as well on the LAN but I will recommend doing it on the WAN, organize and when you're comfortable, you can create one for the LAN interface.

    Here is a config I made for a cisco 892 router which works fine:

    IP IP config flash card: ips try again 1
    IP IP address notify CETS
    IPS the ips name iosips IP list
    !
    category-signature IP ips
    all categories
    true retreat
    category ios_ips base
    fake retirement
    category all-ddos ddos
    fake retirement
    enabled true
    products-alert event-action connection tcp reset-deny-package-inline connection inline deny deny-attacker-inserted
    category, any adware/spyware-adware/spyware
    fake retirement
    enabled true
    products-alert event-action connection tcp reset-deny-package-inline connection inline deny deny-attacker-inserted
    category virus/worms/trojans botnet
    fake retirement
    enabled true
    products-alert event-action connection tcp reset-deny-package-inline connection inline deny deny-attacker-inserted
    category virus/worms/trojans all-viruses/worms/trojans
    fake retirement
    enabled true
    products-alert event-action connection tcp reset-deny-package-inline connection inline deny deny-attacker-inserted
    category models internet_edge
    Advanced ios_ips category
    fake retirement
    !

    ips-setting IP to auto update
    occur - 0 0 06 weekly
    Cisco
    username password xxxxxx xxxxx

    !

    !

    IPS extended IP access list
    allow a full tcp
    allow a udp
    allow icmp a whole
    allow an ip

    I don't know if you have a firewall on your local network, but when I do IPS on a cisco router if there is no firewall, I recommend you to activate ZBF on router itself. This allows to add a little more security.

    Just in case, under a ZBF configuration for home router (like the 892 series):

    extended access IP MANAGEMENT list
    permit tcp any any eq 22
    allow icmp a whole
    !
    Underisable extended IP access list
    deny ip host fragments 224.0.0.5


    deny ip host fragments 224.0.0.6
    refuse the host ip 224.0.0.5 no fragment
    refuse the host ip 224.0.0.6 no fragment
    permit icmp any any fragment
    allow udp any any fragment
    permit tcp any any fragment
    permit tcp any RST eq 639
    permit tcp any RST bgp eq
    IP enable any no fragment
    !
    zbf-wan-to-lan extended IP access list
    permit tcp any host 192.168.0.1 eq 3389 ===> internal of the server accessible from the internet (port forwarding)
    !
    type of class-card inspect entire game Internet
    group-access name zbf-wan-to-lan game
    class-map correspondence class-mgmt
    match the name of group-access MANAGEMENT
    unwanted match class-map
    match the name of group-access Underisable
    type of class-card inspect entire game All_Protocols
    tcp protocol match
    udp Protocol game
    match icmp Protocol
    !
    type of policy-card inspect Trusted_to_Internet
    class type inspect All_Protocols
    inspect
    class class by default
    drop
    type of policy-card inspect Trusted
    class class by default
    Pass
    copp-policy policy-map
    unwanted class
    drop
    class class-mgmt
    to comply with-police action 2048000 pass drop action exceeds
    class class by default
    type of policy-card inspect Internet_to_Trusted
    class type inspect Internet
    inspect
    class class by default
    drop
    !
    !
    Trusted zone security
    Security for the Internet zone
    Trusted zone-pair security-> trusted destination trust Trusted source
    traffic LAN to LAN Description
    type of service-strategy inspect Trusted
    Trusted zone-pair security-> Trusted Internet source Internet destination
    Description LAN for Internet traffic
    type of service-strategy inspect Trusted_to_Internet
    security Internet zone - pair-> Trusted Internet source Trusted destination
    Description WAN for Internet traffic
    type of service-strategy inspect Internet_to_Trusted
    !
    the g0/0 interface (WAN)
    the Member's area Internet Security
    !
    G0/1 of the interface (LAN)
    approved members area security
    !

    Thank you

  • Cisco SR520 - no outgoing access

    This is the current configuration of the router. Can someone tell me why my (192.168.x.x) clients cannot access the internet through that router?

    See the race
    Building configuration...

    Current configuration: 10699 bytes
    !
    version 12.4
    no service button
    horodateurs service debug datetime msec
    Log service timestamps datetime msec
    no password encryption service
    !
    hostname SR520
    !
    boot-start-marker
    boot-end-marker
    !
    forest-meter operation of syslog messages
    enable secret 5 $1$ K5vy$ E90Ebf679MAMz.wglbYsJ.
    !
    No aaa new-model
    clock timezone STD - 7
    clock to summer time recurring MDT
    !
    Crypto pki trustpoint TP-self-signed-1548662293
    enrollment selfsigned
    -More - name of the object cn = IOS - Self - signed - certificate - 1548662293
    revocation checking no
    rsakeypair TP-self-signed-1548662293
    !
    !
    TP-self-signed-1548662293 crypto pki certificate chain
    certificate self-signed 01
    3082024E 308201B 7 A0030201 02020101 300 D 0609 2A 864886 F70D0101 04050030
    2 060355 04031326 494F532D 53656 C 66 2 AND 536967 6E65642D 43657274 31312F30
    69666963 31353438 36363232 6174652D 3933301E 170 3039 30383231 31393030
    33335A 17 0D 323030 31303130 30303030 305A 3031 06035504 03132649 312F302D
    4F532D53 5369676E 656C662D 43 65727469 66696361 74652 31 35343836 65642D
    36323239 3330819F 300 D 0609 2A 864886 01050003, 818, 0030, 81890281 F70D0101
    8100B9BC 7D728F83 7D6059FD 49210310 F04FB968 4440ACD0 B16C927B 8AA215C2
    829 166FC 79F9CF75 ADAADACE 97292EA9 3C7DAFF6 EA5F6B8C 1FD00813 144DB9E8
    613744 D 47D1BCEF 344B268B 4 CBDA8579 A8B3D367 480CD3E0 687ACBF1 3E578E7A
    5583BE8C 9DD04F27 4060299E 0F212CF5 50F1F237 BDFC3CE6 87385AD8 D403A9E1
    36510203 010001A 3 76307430 1 130101 FF040530 030101FF 30210603 0F060355
    551D 1104 1A 301882 16535235 32302E64 6F6D6169 6E2E6163 7464736C 746 7030 D
    1 230418 30168014 DB9949FB 24128D3B 7528E6F3 8DBE4409 D4342BAF 1F060355
    301D 0603 551D0E04 160414DB 9949FB24 128D3B75 28E6F38D BE4409D4 342BAF30
    010104 05000381 8100B95F C4A4AC82 57974A6D 181D601F 0D 864886F7 0D06092A
    A2189179 25D9764A FBA8513B 94FC17E4 34F2D097 C40DD507 F0595CB5 B 538, 0296
    -Other - 39866542 F1DA78C0 A09B469F 739C2FB0 A54B1367 DA88ECFF D51FE907 56E8E06D
    33412A9D C9A57B60 2DAF85E1 B5A84E60 C740962B 525D72B3 883BBBC1 47A5AD4A
    F8F25292 813AEC2B BD37B55A 96A2A177 666TH
    quit smoking
    dot11 syslog
    IP source-route
    !
    !
    !
    !
    IP cef
    name of the IP-server 209.161.4.218
    !
    No ipv6 cef
    Authenticated MultiLink bundle-name Panel

    parameter-card type urlfilter SDM_URLFILTER_MAP
    exclusive-domain license wendell.k12.id.us
    exclusive-domain license mail.wendellschools.com
    exclusive-domain license k12.id.us
    exclusive-area permit www.teenbiz3000.com
    exclusive-domain license mail.safelink.net
    exclusive-domain license www.sd232.k12.id.us
    -More - exclusive mail.wendellschools.org allowed domain
    exclusive-area permit bing.com
    exclusive-domain license google.com
    license exclusive-domain yahoo.com
    parameter-card type regex sdm-regex-nonascii
    model [^ \x00-\x80]

    type of parameter-map protocol-info msn servers
    Server name messenger.hotmail.com
    Server name gateway.messenger.hotmail.com
    Server name webmessenger.msn.com

    type of parameter-card aol-server protocol-info
    Server name login.Oscar.AOL.com
    Server name TOC.Oscar.AOL.com
    Server name oam - d09a.blue.aol.com

    type of parameter-map protocol-info yahoo servers
    Server name SCS.msg.Yahoo.com
    Server name SCSA.msg.Yahoo.com
    Server name scsb.msg.Yahoo.com
    Server name SCSC.msg.Yahoo.com
    Server name scsd.msg.Yahoo.com
    -More - cs16.msg.dcn.yahoo.com server name
    Server name cs19.msg.dcn.Yahoo.com
    Server name cs42.msg.dcn.Yahoo.com
    Server name cs53.msg.dcn.Yahoo.com
    Server name cs54.msg.dcn.Yahoo.com
    Server name ads1.VIP.SCD.Yahoo.com
    Server name radio1.launch.VIP.DAL.Yahoo.com
    Server name in1.msg.VIP.RE2.Yahoo.com
    Server name Data1.my.VIP.SC5.Yahoo.com
    Server name address1.PIM.VIP.mud.Yahoo.com
    Server name edit.Messenger.Yahoo.com
    Server name Messenger.Yahoo.com
    Server name http.pager.Yahoo.com
    Server name privacy.Yahoo.com
    Server name CSA.Yahoo.com
    Server name CSB.Yahoo.com
    Server name CSC.Yahoo.com

    !
    !
    username admin privilege 15 secret 5 $1$ $9EbE 21QHkuUvg3blkmWNXibqM1
    !
    !
    --More--                           !
    Archives
    The config log
    hidekeys
    !
    !
    !
    type of class-card inspect any match of sdm-app-smtp smtp
    corresponds to the length of the gt 5000000 data
    type of class-card inspect any match http sdm-app-nonascii
    req-resp header sdm-regex-nonascii regex match
    type of class-card inspect any match of sdm-app-imap imap
    match zero-order
    type of class-card inspect all match sdm-cls-Protocol-p2p
    edonkey signature Protocol game
    match the signature of the gnutella Protocol
    match the signature of Protocol kazaa2
    match the signature of the fasttrack Protocol
    match the signature of bittorrent Protocol
    type of class-card inspect all SDM-voice-enabled game
    h323 Protocol game
    Skinny Protocol game
    sip protocol game
    -More class-map type - inspect correspondence sdm-protocol-pop3
    pop3 Protocol game
    type of class-card inspect all match sdm-cls-icmp-access
    match icmp Protocol
    tcp protocol match
    udp Protocol game
    type of class-card inspect all match sdm-cls-Protocol-im
    yahoo-servers Protocol ymsgr match
    msnmsgr msn-protocol servers match
    match aol aol-protocol servers
    type of class-card inspect all sdm-cls-insp-traffic game
    dns protocol game
    https protocol game
    match icmp Protocol
    match the imap Protocol
    pop3 Protocol game
    tcp protocol match
    udp Protocol game
    type of class-card inspect any match of sdm-app-pop3 pop3
    match zero-order
    type of class-card inspect correspondence sdm-Protocol-p2p
    corresponds to the class-map sdm-cls-Protocol-p2p
    type of class-card inspect any match http sdm-http-blockparam
    -More - match request port-abuse im
    request game port-bad use p2p
    match request port-abuse tunneling
    req-resp-violation of Protocol game
    type of class-card inspect correspondence sdm-Protocol-im
    corresponds to the class-map sdm-cls-Protocol-im
    type of class-card inspect correspondence sdm-invalid-src
    game group-access 100
    type of class-card inspect the correspondence dhcp_out_self
    match access-group name dhcp-RESP-licensing
    type of class-card inspect the correspondence dhcp_self_out
    match access-group name dhcp-req-licensing
    type of class-card inspect any match http sdm-app-httpmethods
    request method bcopy game
    request method bdelete game
    request method bmove game
    request method bpropfind game
    request method bproppatch game
    method of application for game connect
    match request method copy
    delete the method of application of game
    match request edit method
    match request method getattribute
    -More - match request getattributenames method
    match request getproperties method
    is the index of request method
    request method lock game
    match request mkcol method
    match request mkdir method
    method of application for game go
    method of application for match report
    match the options request method
    survey method match request
    request method post game
    match request propfind method
    match request proppatch method
    put request method match
    match request method revadd
    match request method revlabel
    match method revlog request
    request method revnum game
    method of application for game save
    is looking for the query method
    match request method setattribute
    request method startrev game
    match request method stoprev
    -More - match request method to subscribe
    match request method trace
    match unedit request method
    method of application for game unlock
    unsubscribe request to match method
    type of class-card inspect correspondence sdm-Protocol-http
    http protocol game
    type of class-card inspect correspondence sdm-protocol-smtp
    smtp Protocol game
    type of class-card inspect correspondence sdm-Protocol-imap
    match the imap Protocol
    !
    !
    type of policy-card inspect sdm-permits-icmpreply
    class type inspect dhcp_self_out
    Pass
    class type inspect sdm-cls-icmp-access
    inspect
    class class by default
    Pass
    type of policy-card inspect http sdm-action-app-http
    class type inspect http http-sdm-blockparam
    Journal
    -More - reset
    class type inspect http sdm-app-httpmethods
    Journal
    reset
    class type inspect http sdm-app-nonascii
    Journal
    reset
    type of policy-card inspect sdm-action-smtp smtp
    class type inspect sdm-app-smtp smtp
    reset
    type of policy-card inspect sdm-action-imap imap
    class type inspect sdm-app-imap imap
    Journal
    reset
    type of policy-card inspect sdm-action-pop3 pop3
    class type inspect sdm-app-pop3 pop3
    Journal
    reset
    type of policy-map inspect sdm - inspect
    class type inspect sdm-cls-insp-traffic
    inspect
    class type inspect SDM-voice-enabled
    Pass
    -More class type - inspect sdm-invalid-src
    Drop newspaper
    class type inspect sdm-Protocol-http
    inspect
    policy-service http sdm-action-app-http
    class type inspect sdm-protocol-smtp
    inspect
    policy-service smtp sdm-action-smtp
    class type inspect sdm-Protocol-imap
    inspect
    SDM-action-imap imap service-policy
    class type inspect sdm-protocol-pop3
    inspect
    SDM-action-pop3 pop3 service-policy
    class type inspect sdm-Protocol-p2p
    Drop newspaper
    class type inspect sdm-Protocol-im
    Drop newspaper
    class class by default
    drop
    type of policy-card inspect sdm-inspect-voip-in
    class type inspect SDM-voice-enabled
    Pass
    -More - default class
    drop
    type of policy-card inspect sdm-enabled
    class type inspect dhcp_out_self
    Pass
    class class by default
    drop
    !
    security of the area outside the area
    safety zone-to-zone
    safety zone-pair sdm-zp-self-out source destination outside zone auto
    type of service-strategy inspect sdm-permits-icmpreply
    safety zone-pair sdm-zp-out-in source out-area destination in the area
    type of service-strategy inspect sdm-inspect-voip-in
    source of sdm-zp-out-auto security area outside zone destination auto pair
    type of service-strategy inspect sdm-enabled
    safety zone-pair sdm-zp-in-out source in the area of destination outside the area
    type of service-strategy inspect sdm - inspect
    !
    !
    !
    interface FastEthernet0
    switchport access vlan 75
    --More--                           !
    interface FastEthernet1
    switchport access vlan 75
    !
    interface FastEthernet2
    switchport access vlan 75
    !
    interface FastEthernet3
    switchport access vlan 75
    !
    interface FastEthernet4
    Description $FW_OUTSIDE$
    DHCP IP address
    NAT outside IP
    IP virtual-reassembly
    outside the area of security of Member's area
    automatic duplex
    automatic speed
    !
    interface Vlan1
    no ip address
    !
    interface Vlan75
    -Description $FW_INSIDE$ more.
    the IP 192.168.0.1 255.255.252.0
    IP nat inside
    IP virtual-reassembly
    Security members in the box area
    !
    IP forward-Protocol ND
    IP route 0.0.0.0 0.0.0.0 FastEthernet4
    !
    IP http server
    local IP http authentication
    IP http secure server
    IP http timeout policy slowed down 60 life 86400 request 10000
    the IP nat inside source 1 list the interface FastEthernet4 overload
    !
    IP access-list extended dhcp-req-enabled
    Remark SDM_ACL = 1 category
    allow udp any eq bootpc any eq bootps
    IP access-list extended dhcp-RESP-enabled
    Remark SDM_ACL = 1 category
    allow udp any eq bootps any eq bootpc
    !
    access-list 1 permit 192.168.0.0 0.0.0.255
    -More - access list 100 remark SDM_ACL category = 128
    access-list 100 permit ip 255.255.255.255 host everything
    access-list 100 permit ip 127.0.0.0 0.255.255.255 everything
    !
    !
    !
    !
    !
    control plan
    !
    connection of the banner ^ CSR520 basic Config - MFG 1.0 ^ C
    !
    Line con 0
    local connection
    no activation of the modem
    line to 0
    line vty 0 4
    privilege level 15
    local connection
    transport input telnet ssh
    !
    max-task-time 5000 Planner
    end
    -More-
    SR520 #.

    OK, I heard about this once before, where the default basic configuration has been changed at the beginning of the life cycle of this product and WAN access problems were solved using a newer base from config.  Depending on your router, I have attached the default config, you can start with (or compare to yours).

    I'm not sure what has changed (I'm sorry)

    https://www.myciscocommunity.com/docs/doc-5167

  • Access VPN HELP

    I have my ASA 5505 VPN access installation... I am finally able to connect and receive and the IP address of it.  But now I'm stumped on why I can't access my network.  My network is as follows: Cable Modem---> ASA 5505---> router Cisco 3660---> Cisco Switch 2900XL---> Windows 2008 Server---> client PC.  Can someone help me understand where I'm going wrong?

    ASA 5505 Running Config:

    ASA Version 8.2 (3)
    !
    ciscoasa hostname
    activate the encrypted password of DQucN59Njn0OjpJL
    2KFQnbNIdI.2KYOU encrypted passwd
    names of
    !
    interface Ethernet0/0
    switchport access vlan 2
    !
    interface Ethernet0/1
    !
    interface Ethernet0/2
    !
    interface Ethernet0/3
    !
    interface Ethernet0/4
    !
    interface Ethernet0/5
    !
    interface Ethernet0/6
    !
    interface Ethernet0/7
    !
    interface Vlan1
    nameif inside
    security-level 100
    IP 192.168.2.1 255.255.255.0
    !
    interface Vlan2
    nameif outside
    security-level 0
    DHCP IP address
    !
    passive FTP mode
    inside_nat0_outbound to access extended list ip 192.168.2.0 allow 255.255.255.0 192.168.3.0 255.255.255.240
    pager lines 24
    Enable logging
    exploitation forest asdm warnings
    Within 1500 MTU
    Outside 1500 MTU
    mask 192.168.3.0 - 192.168.3.10 255.255.255.0 IP local pool HomeVPN
    ICMP unreachable rate-limit 1 burst-size 1
    don't allow no asdm history
    ARP timeout 14400
    Global 1 interface (outside)
    NAT (inside) 0-list of access inside_nat0_outbound
    NAT (inside) 1 0.0.0.0 0.0.0.0
    !
    router RIP
    network 192.168.1.0
    network 192.168.2.0
    192.168.3.0 network
    default information are created
    version 2
    !
    Route outside 0.0.0.0 0.0.0.0 174.56.139.1 1
    Route inside 192.168.1.0 255.255.255.0 192.168.2.2 1
    Route inside 192.168.3.0 255.255.255.0 192.168.2.2 1
    Timeout xlate 03:00
    Timeout conn 01:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
    Sunrpc timeout 0:10:00 h323 0:05:00 h225 mgcp from 01:00 0:05:00 mgcp-pat 0:05:00
    Sip timeout 0:30:00 sip_media 0:02:00 prompt Protocol sip-0: 03:00 sip - disconnect 0:02:00
    Timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute
    timeout tcp-proxy-reassembly 0:01:00
    dynamic-access-policy-registration DfltAccessPolicy
    Enable http server
    http 192.168.2.0 255.255.255.0 inside
    http 192.168.1.0 255.255.255.0 inside
    No snmp server location
    No snmp Server contact
    Server enable SNMP traps snmp authentication linkup, linkdown cold start
    Crypto ipsec transform-set esp-SHA-ESP-3DES-3des esp-sha-hmac
    Crypto ipsec transform-set ESP-AES-256-MD5 esp-aes-256 esp-md5-hmac
    Crypto ipsec transform-set ESP-DES-SHA esp - esp-sha-hmac
    Crypto ipsec transform-set ESP-DES-MD5 esp - esp-md5-hmac
    Crypto ipsec transform-set ESP-AES-192-MD5 esp-aes-192 esp-md5-hmac
    Crypto ipsec transform-set ESP-3DES-MD5-esp-3des esp-md5-hmac
    Crypto ipsec transform-set ESP-AES-256-SHA 256 - aes - esp esp-sha-hmac
    Crypto ipsec transform-set ESP-AES-128-SHA aes - esp esp-sha-hmac
    Crypto ipsec transform-set ESP-AES-192-SHA esp-aes-192 esp-sha-hmac
    Crypto ipsec transform-set ESP-AES-128-MD5-esp - aes esp-md5-hmac
    life crypto ipsec security association seconds 28800
    Crypto ipsec kilobytes of life - safety 4608000 association
    crypto dynamic-map SYSTEM_DEFAULT_CRYPTO_MAP 65535 pfs Group1 set
    Crypto dynamic-map SYSTEM_DEFAULT_CRYPTO_MAP 65535 value transform-set ESP-AES-128-SHA ESP-AES-128-MD5 ESP-AES-192-SHA ESP-AES-192-MD5 ESP-AES-256-SHA ESP-AES-256-MD5 ESP-3DES-SHA MD5-ESP-3DES ESP-DES-SHA ESP-DES-MD5
    outside_map card crypto 65535-isakmp dynamic ipsec SYSTEM_DEFAULT_CRYPTO_MAP
    outside_map interface card crypto outside
    crypto ISAKMP allow outside
    crypto ISAKMP policy 10
    preshared authentication
    3des encryption
    sha hash
    Group 2
    life 86400
    enable client-implementation to date
    Telnet timeout 5
    SSH timeout 5
    Console timeout 0
    dhcpd dns 8.8.8.8 8.8.4.4 interface inside
    !

    a basic threat threat detection
    Statistics-list of access threat detection
    no statistical threat detection tcp-interception
    WebVPN
    internal VPNHome group strategy
    attributes of Group Policy VPNHome
    value of server DNS 192.168.1.14 8.8.8.8
    Protocol-tunnel-VPN IPSec
    wood.homeserv.com value by default-field
    user name, password of encrypted WsMCHUiqvEuA9Gmb privilege 0 Jonathan
    user name Jonathan attributes
    VPN-group-policy VPNHome
    type tunnel-group VPNHome remote access
    attributes global-tunnel-group VPNHome
    address pool HomeVPN
    Group Policy - by default-VPNHome
    IPSec-attributes tunnel-group VPNHome
    pre-shared key *.
    !
    class-map inspection_default
    match default-inspection-traffic
    !
    !
    type of policy-card inspect dns preset_dns_map
    parameters
    maximum message length automatic of customer
    message-length maximum 512
    Policy-map global_policy
    class inspection_default
    inspect the preset_dns_map dns
    inspect the ftp
    inspect h323 h225
    inspect the h323 ras
    inspect the rsh
    inspect the rtsp
    inspect esmtp
    inspect sqlnet
    inspect the skinny
    inspect sunrpc
    inspect xdmcp
    inspect the sip
    inspect the netbios
    inspect the tftp
    Review the ip options
    !
    global service-policy global_policy
    context of prompt hostname
    Cryptochecksum:214676358ccd68b2acb313ffcd92c6fa
    : end

    Cisco 3660 router configuration:

    Building configuration...

    Current configuration: 5921 bytes
    !
    version 12.4
    horodateurs service debug datetime msec
    Log service timestamps datetime msec
    no password encryption service
    !
    router host name
    !
    boot-start-marker
    boot-end-marker
    !
    enable secret 5 $1$.7Q9$mJ4Y0sVUoAw8QZ/33g1JD/
    activate the henry999 password
    !
    AAA new-model
    !
    !
    AAA authentication login default local
    AAA authorization exec default local
    !
    AAA - the id of the joint session
    !
    !
    IP cef
    No dhcp use connected vrf ip
    DHCP excluded-address IP 192.168.1.1 192.168.1.7
    DHCP excluded-address 192.168.1.1 IP 192.168.1.10
    DHCP excluded-address IP 192.168.1.11 192.168.1.19
    DHCP excluded-address IP 192.168.1.1 192.168.1.19
    !
    IP dhcp pool 192.168.1.0/24
    network 192.168.1.0 255.255.255.0
    default router 192.168.1.1
    Server DNS 8.8.8.8 8.8.4.4
    !
    IP dhcp pool 192.168.1.2/24
    !
    !
    inspect the IP name SDM_LOW cuseeme
    inspect the IP dns SDM_LOW name
    inspect the IP name SDM_LOW ftp
    inspect the IP h323 SDM_LOW name
    inspect the IP name SDM_LOW https
    inspect the IP icmp SDM_LOW name
    inspect the IP name SDM_LOW imap
    inspect the IP name SDM_LOW pop3
    inspect the IP name SDM_LOW netshow
    inspect the IP rcmd SDM_LOW name
    inspect the IP name SDM_LOW realaudio
    inspect the name SDM_LOW rtsp IP
    inspect the IP name SDM_LOW esmtp
    inspect the IP name SDM_LOW sqlnet
    inspect the name SDM_LOW streamworks IP
    inspect the name SDM_LOW tftp IP
    inspect the tcp IP SDM_LOW name
    inspect the IP udp SDM_LOW name
    inspect the name SDM_LOW vdolive IP
    list of time of inactivity-60 eapoudp of IP admissions name of the NAC1 NAC
    property intellectual ips homeless location flash://SDF autosave
    IP IP address notify CETS
    IP IP name sdm_ips_rule
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    username privilege 15 secret 5 woodjl $1$ w.xT$ cFJweRcOx29N9hKafqu4h1
    username wooldjl privilege 15 secret 5 $1 $4o6 / $IO13XCGj9XXjIAGTsN3Yj0
    !
    !
    !
    class-map match-all SDM-transactional-1
    af21 dscp match
    match dscp af22
    af23 dscp match
    class-map match-all SDM-signaling-1
    match dscp cs3
    match dscp af31
    class-map match-all SDM-routing-1
    cs6 dscp match
    class-map match-all SDM-voices-1
    match dscp ef
    class-map match-all SDM-management-1
    match dscp cs2
    !
    !
    Policy-map SDM-QoS-policy-1
    SDM-voices-1 class
    percentage of priority 33
    police CIR 33000000
    issuance of the share are consistent
    decline of the action exceeds
    SDM-signaling-1 class
    percentage of bandwidth 5
    Police cir 5000000
    issuance of the share are consistent
    decline of the action exceeds
    SDM-routing-1 class
    percentage of bandwidth 5
    Police cir 5000000
    issuance of the share are consistent
    decline of the action exceeds
    SDM-management-1 class
    percentage of bandwidth 5
    Police cir 5000000
    issuance of the share are consistent
    decline of the action exceeds
    SDM-transactional-1 class
    percentage of bandwidth 5
    Police cir 5000000
    issuance of the share are consistent
    decline of the action exceeds
    class class by default
    Fair/fair-queue
    random detection
    Police cir 22000000
    issuance of the share are consistent
    decline of the action exceeds
    !
    !
    !
    Configuration group customer isakmp crypto HomeUsers
    henrydixie7153 key
    192.168.1.14 DNS 8.8.8.8
    wood.homeserv.com field
    pool SDM_POOL_1
    include-local-lan
    Max-users 5
    netmask 255.255.255.0
    !
    !
    Crypto ipsec transform-set esp-3des esp-sha-hmac SDM_TRANSFORMSET_1
    !
    Profile of crypto ipsec HomeVPN
    game of transformation-SDM_TRANSFORMSET_1
    !
    !
    map HomeVPN 1 ipsec-isakmp crypto
    defined peer 192.168.3.1
    Set the security association idle time 7200
    game of transformation-SDM_TRANSFORMSET_1
    PFS Group1 Set
    match address VPN1
    !
    !
    !
    !
    interface FastEthernet0/0
    Description $FW_OUTSIDE$
    IP 192.168.2.2 255.255.255.0
    IP access-group 101 in
    Check IP unicast reverse path
    NAT outside IP
    inspect the SDM_LOW over IP
    admission of the IP of the NAC
    sdm_ips_rule IP IP addresses in
    sdm_ips_rule IP IP addresses on
    IP virtual-reassembly
    automatic duplex
    automatic speed
    !
    interface FastEthernet0/1
    Description $FW_INSIDE$
    IP 192.168.1.1 255.255.255.0
    IP access-group 100 to
    Check IP unicast reverse path
    IP nat inside
    sdm_ips_rule IP IP addresses in
    sdm_ips_rule IP IP addresses on
    IP virtual-reassembly
    automatic duplex
    automatic speed
    service-policy output SDM-QoS-policy-1
    !
    router RIP
    version 2
    passive-interface FastEthernet0/0
    passive-interface FastEthernet0/1
    network 192.168.1.0
    No Auto-resume
    !
    local IP SDM_POOL_1 192.168.3.1 pool 192.168.3.10
    IP http server
    local IP http authentication
    no ip http secure server
    IP http timeout policy inactive 600 life 86400 request 10000
    IP forward-Protocol ND
    IP route 0.0.0.0 0.0.0.0 192.168.2.1
    !
    !
    192.168.1.1 IP nat pool house 192.168.1.24 netmask 255.255.255.0
    !
    !
    NAC1 extended IP access list
    Note of the NAC
    Remark SDM_ACL = 64 category
    Note the rule of the NAC
    IP 192.0.0.0 allow 0.255.255.255 everything
    list of IP - VPN access scope
    Note the VPN access
    Remark SDM_ACL = 4 category
    Note VPN
    allow an ip
    VPN1 extended IP access list
    Note the VPN access
    Remark SDM_ACL = 4 category
    allow an ip host 192.168.3.1
    access-list 100 remark self-generated by the configuration of the firewall SDM
    Access-list 100 = 1 SDM_ACL category note
    access-list 100 deny ip 192.168.2.0 0.0.0.255 any
    access-list 100 deny ip 255.255.255.255 host everything
    access-list 100 deny ip 127.0.0.0 0.255.255.255 everything
    access ip-list 100 permit a whole
    access list 101 remark self-generated by the configuration of the firewall SDM
    Note access-list 101 = 1 SDM_ACL category
    access-list 101 deny ip 192.168.1.0 0.0.0.255 any
    access-list 101 permit icmp any host 192.168.2.2 echo-reply
    access-list 101 permit icmp any host 192.168.2.2 exceeded time
    access-list 101 permit icmp any unreachable host 192.168.2.2
    access-list 101 deny ip 10.0.0.0 0.255.255.255 everything
    access-list 101 deny ip 172.16.0.0 0.15.255.255 all
    access-list 101 deny ip 192.168.0.0 0.0.255.255 everything
    access-list 101 deny ip 127.0.0.0 0.255.255.255 everything
    access-list 101 deny ip 255.255.255.255 host everything
    access-list 101 deny host ip 0.0.0.0 everything
    access-list 101 deny ip any any newspaper
    SNMP-server 192.168.1.1 RO community
    Enable SNMP-Server intercepts ATS
    !
    !
    !
    !
    control plan
    !
    !
    !
    !
    !
    !
    !
    !
    !
    Line con 0
    transportation out all
    line to 0
    transportation out all
    line vty 0 4
    Henry of password
    transport telnet entry
    transportation out all
    !
    !
    end

    Since you already have a default to the ASA route, you don't need one more specific.

    But, the most recent ASA config that you posted, I think that there is some confusion about the config of split tunnel.

    You have

    access-list VPNWoodHome_splitTunnelAcl standard permit 192.168.2.0 255.255.255.0 access-list WoodVPN_splitTunnelAcl standard permit 192.168.2.0 255.255.255.0 access-list Split_Tunnel_List standard permit 192.168.1.0 255.255.255.0

    But only one of these is actually used in the group-policy.

    group-policy WoodVPN attributes
      split-tunnel-network-list value WoodVPN_splitTunnelAcl
    So my suggestion is to add:

    access-list WoodVPN_splitTunnelAcl standard permit 192.168.1.0 255.255.255.0
    (and remove the other 2 access-lists unless they're used for something else)

    hth
    Herbert

  • How can I get a name of another widget setting?

    I'm new to coding. I apologize now for any ignorance shown!

    I am trying to create a picture button widget which, on mouse down, load a URL into a widget of the iFrame. Who will be on the same page as the button.

    How can I get the two images to load URLtoTarget into iFrameURL on the mouse down? Thank you

    Settings button:

    < Parameters >

    < file name = "img1" label = 'Location of the before Image' filterLabel = 'Images' file types = "*.jpg; *.JPEG; *.gif, *.png"fileRequiredForOutput ="true"/ >

    < name of text = "desc1" multiline = "true" label = "Description" defaultValue = "Before" / >

    < file name = "img2" label = 'Return Image location' filterLabel = 'Images' file types = "*.jpg; *.JPEG; *.gif, *.png"fileRequiredForOutput ="true"/ >

    < name of text = 'desc2' multiline = "true" label = "Description" defaultValue = "Return" / >

    "< name of text ="URLtoTarget"label ="Target URL"defaultValue ="http://www.hotgeckomedia.com"/ > " "

    < name of text = "iFrameTargetName" label = "iFrame target name" defaultValue = "myiFrame" / >

    < name builtIn = "width" / >

    < name builtIn = 'height' / >

    < / Parameter >

    <! [CDATA]

    < div class = "muFlipCard" >

    < img src = "{param_img1}" alt = "{param_desc1}" class = "muSide1" >

    < img src = "{param_img2}" alt = "{param_desc2}" class = "muSide2" >

    < / div >

    []] >

    iFrame parameters:

    < Parameters >

    "< name url ="iFrameURL"label ="iFrame URL"defaultValue ="http://www.hotgeckomedia.com"/ > " "

    < name builtIn = "width" / >

    < name builtIn = 'height' / >

    < / Parameter >

    Hey Ross,

    To target a class in Javascript using document.getElementByClassName ('class'). action or $('.class'). action in JQuery. You better use an ID, however, you would have only one instance per page. It would address using document.getElementById ('id'). action / $("#id"). action.

    David

    Creative muse

  • Orchestration empty to preprocess EventHandler to the deletion of the user?

    Hello

    I have an eventhandler preprocess on 'Clear the user' who gets called successfully.

    The corresponding xml files are:

    plugin.XML:

    <? XML version = "1.0" encoding = "UTF-8"? >

    " < oimplugins xmlns: xsi =" http://www.w3.org/2001/XMLSchema-instance ">

    < pluginpoint = "oracle.iam.platform.kernel.spi.EventHandler plugins" >

    < pluginclass plugin = "preprocess. RenameAtDelete"version ="1.0 ".

    name = "RenameAtDelete" / >

    < / plugins >

    < / oimplugins >

    EventHandler.xml:

    <? XML version = "1.0" encoding = "UTF-8"? >

    " < eventhandlers xmlns =" http://www.Oracle.com/schema/OIM/platform/kernel "" xmlns: xsi = " http://www.w3.org/2001/XMLSchema-instance " xsi: schemaLocation = " http://www.Oracle.com/Schema/OIM/Platform/kernel orchestration - handlers.xsd" >

    < action handler class = "preprocess. Type of entity-RenameAtDelete"="User"operation = 'CLEAR' name ="setMN"Stadium ="preprocess"order ="1050"sync ="TRUE"/ >

    < / eventhandlers >

    My java class is named preprocess. RenameAtDelete and is essentially defined as follows:

    bunch of pre-treat;

    ...

    / public class RenameAtDelete implements PreProcessHandler {}

    public EventResult run (long processId, long eventId,

    Orchestration of the orchestration) {}

    ...

    However, orchestriation is just empty.

    Is there something obvious that I forget?

    If it's supposed to happen?

    Thank you very much

    C

    Hello

    Thanks, I solved the problem. It wasn't exactly your code that solved, but you pointed me in the right direction. Thank you!

    This is what worked for me:

    HashMap interEvData = orchestration.getInterEventData ();

    The user delUser = (User) interEvData.get ("CURRENT_USER");

    String connection = delUser.getAttribute ("User Login") m:System.NET.SocketAddress.ToString ();

    Kind regards

    C

  • ERROR - method of payment must be selected

    Payment method must be selected.

    When I check using 30 day account option form works very well.

    BUT

    When the start with eror credit card above rises even hough CC is selected

    Can someone help me?

    Checkout < h1 > < / h1 >

    < class p = "required-h1-tip" > < span > * </span > < /p > required field

    < p > please fill the required fields, delivery address and payment fields. < /p >

    < hr / >

    < section class = 'form-container of checkout' >

    < name of the form = "catwebformform42059" class = "form-generic-a checkout, one" id = "catwebformform42059" onsubmit = "return checkWholeForm42059 (this)" action = "/ FormProcessv2.aspx? WebFormID = 10850 & amp; OID = {module_oid} & amp; OTYPE = {module_otype} & amp; EID = {module_eid} & amp; CID = {module_cid}' enctype = "multipart/form-data" method = "post" >

    < fieldset >

    < h2 class = "a" > 1. Account number < / h2 >

    <!-< div class = "row" >

    < class p = "on the ground, a field" >

    < label for 'username' = > username < em > * < /em > < / label >

    < input type = "text" value = "{module_username}" id = "f-username" class = "text" name = "UserName" / >

    < /p >

    < class p 'field field b' = >

    < label for = "password" > password < em > * < /em > < / label >

    < span class = "half" >

    < input type = "password" value = "{module_password}" id = 'f - password' class = "text" name = "Password" / >

    </span > < / p >

    < class p 'field field b' = >

    < label for = 'Confirm password' > Confirm < em > * < /em > < / label >

    < span class = "half" >

    < input type = "password" value = "{module_password}" id = "f - password - confirmation" class = "text" name = "PasswordConfirm" / >

    </span > < / p >

    < / div >-->

    < div class = "row" >

    < class p = "on the ground, a field" >

    < label for = "FirstName" > name < em > * < /em > < / label >

    < input type = "text" name = "FirstName" class = 'text' id = value "f-first-name" = "{module_firstname}" / >

    < /p >

    < class p = "on the ground, a field" >

    < label for = "name" > < em > family name * < /em > < / label >

    < input type = "text" name = "LastName" class = 'text' id = "LastName" value = "{module_lastname}" / >

    < /p >

    < / div >

    < div class = "row" >

    < class p = "on the ground, a field" >

    < label for 'email' = > email < em > * < /em > < / label >

    < input type = "text" name = "EmailAddress" class = 'text' id = value "f-email" = "{module_emailaddress}" / >

    < /p >

    < class p = "on the ground, a field" >

    < label for = 'phone' > phone number < em > * < /em > < / label >

    < input type = "text" name = "HomePhone" class = 'text' id = value 'f-phone"="{module_homephone}"/ >

    < /p >

    < / div >

    < div class = "row checkbox" > < span class = "tick" >

    < input type = "checkbox" name = "CampaignList_20945" class = "tick" id = "f-updates" / >

    </span >

    < label for 'bulletin of information-a' = > keep me updated on product information, sales and special offers. < / label >

    < / div >

    < / fieldset >

    < hr / >

    < fieldset >

    < h2 class = "a" > 2. Shipping address < / h2 >

    < div class = "row" >

    < class p = "on the ground, a field" >

    < label for = "ShippingAttention" > name of expedition: < em > * < /em > < / label >

    < input type = "text" class = "text" id = "ShippingAttention" name = "ShippingAttention" / >

    < /p >

    < / div >

    < div class = "row" >

    < class p = "on the ground, a field" >

    < label for = "transport-addr-1" > address line 1 < em > * < /em > < / label >

    < input type = "text" class = "text" id = "ShippingAddress" name = "ShippingAddress" / >

    < /p >

    < class p = "on the ground, a field" >

    < label for 'transport-addr-2' = > address line 2 < / label >

    < input type = "text" class = "text" id = "ShippingAddress2" name = "ShippingAddress2" / >

    < /p >

    < / div >

    < div class = "row" >

    < class p = "on the ground, a field" >

    City of < label for = "Transport-city" > < em > * < /em > < / label >

    < input type = "text" class = "text" id = "ShippingCity" name = "ShippingCity" / >

    < /p >

    < class p = "on the ground, a field" >

    State of < label for = "transport-State" > < em > * < /em > < / label >

    < input type = "text" class = "text" id = "ShippingState" name = "ShippingState" / >

    < /p >

    < / div >

    < div class = "row" >

    < div class = "on the ground, a field" >

    < class p 'field-b' = >

    < label for = "ShippingZip" > Zip / Postal Code < em > * < /em > < / label >

    < input type = "text" class = "text" id = "ShippingZip" name = "ShippingZip" / >

    < /p >

    < / div >

    <!-< class p = "on the ground, a field" >

    < label for = "transport-phone" > phone number < em > * < /em > < / label >

    < input type = "text" id = "transport-phone" name = "transport-phone" / >

    < /p >->

    < / div >

    < / fieldset >

    < hr / >

    < fieldset >

    < h2 class = "a" > 3. Billing address < / h2 >

    < div class = "row checkbox" > < span class = "tick" >

    < input type = "checkbox" class = "tick" value = "1" id = 'f-shipping-same' name = "same_shipping" / >

    </span >

    < label for = "billing-same-as-delivery" > check this box if the billing address is the same as the shipping address. < / label >

    < / div >

    < div class = "row" >

    < class p = "on the ground, a field" >

    < label for = "billing-addr-1" > address line 1 < em > * < /em > < / label >

    < input type = "text" value = "{module_homeaddress}" id = "BillingAddress" class = "text" name = "BillingAddress" / >

    < /p >

    < class p = "on the ground, a field" >

    < label for 'billing-addr-2' = > address line 2 < em > * < /em > < / label >

    < input type = "text" class = "text" id = "BillingAddress2" name = "BillingAddress2" / >

    < /p >

    < / div >

    < div class = "row" >

    < class p = "on the ground, a field" >

    City of < label for = "Billing-city" > < em > * < /em > < / label >

    < input type = "text" value = "{module_homecity}" id = "BillingCity" class = "text" name = "BillingCity" / >

    < /p >

    < class p = "on the ground, a field" >

    State of < label for = "billing-State" > < em > * < /em > < / label >

    < input type = "text" value = "{module_homestate}" id = "BillingState" class = "text" name = "BillingState" / >

    < /p >

    < / div >

    < div class = "row" >

    < class p 'field field b' = >

    < label for = "BillingZip" > Zip / Postal Code < em > * < /em > < / label >

    < input type = "text" value = "{module_homezip}" id = "BillingZip" class = "text" name = "BillingZip" / >

    < /p >

    < / div >

    < / fieldset >

    < hr / >

    < fieldset id = 'credit-card-information' >

    < h2 class = "a" > 4. Payment options < / h2 >

    < div class = "row" >

    < h4 > approved 30 client DayAccount < / h4 >

    < class p 'field' = > please select

    < /p >

    < input type = "radio" name = "PaymentMethodType" id = "PaymentMethodType" value = "8" / > < span style = "font size: 18px;" color: #ffff00; "> </span > only account holders < hr / >

    < h2 > pay by credit card < / h2 >

    < class p 'row row accepted cards' = >

    "We accept the following credit cards: < img alt =" "src =" temp/cards.png "/ > < / p >

    < label for = "card type" > map Type < em > * < /em > < / label >

    < span class = "select" >

    < select name = 'CardType' class = 'text' id 'type-cc-f' = >

    Visa < option selected = "selected" value = "1" > < / option >

    < option value = "2" > Master Card < / option >

    < option value = "4" > American Express < / option >

    < / select > < / span >

    < / div >

    < div class = "row" >

    < class p = "on the ground, a field" >

    < label for = "name on card" > name on card < em > * < /em > < / label >

    < input type = "text" name = 'CardName' class = 'text' id = "f-cc-name" / >

    < /p >

    < class p = "on the ground, a field" >

    < label for 'card number' = > card number < em > * < /em > < / label >

    < input type = "text" name = 'CardNumber' class = 'text' id = 'number-cc-f' / >

    < /p >

    < / div >

    < div class = "row" >

    < class p = "card-expiration field" >

    < label for 'card-exp-months' = > card Expiration < span class 'offset' = > month </span > < em > * < /em > < / label >

    < span class = "SΘlectionner one" >

    < select name = "CardExpiryMonth" class = "s" id = "f-cc-exp-month" >

    < option selected = "selected" value = "1" > January < / option >

    < option value = "2" > February < / option >

    < option value = "3" > Tue < / option >

    < option value = "4" > after < / option >

    < option value = "5" > < / option >

    < option value = "6" > Jun < / option >

    < option value = "7" > Jul < / option >

    < option value = "8" > August < / option >

    < option value = "9" > Ms < / option >

    < option value = "10" > Oct < / option >

    < option value = "11" > Nov < / option >

    < option value = "12" > Dec < / option >

    < / select >

    </span >

    < class label = 'offset' for 'card-exp-year' = > card Expiration year < em > * < /em > < / label >

    < span class = "select" >

    < select name = "CardExpiryYear" class = "xs" id = "f-cc-exp-year" >

    < option value = '2015' > 2015 < / option >

    < option value = "2016" > 2016 < / option >

    < option value = "2017" > 2017 < / option >

    < option value = "2018" > 2018 < / option >

    < option value = "2019" > 2019 < / option >

    < option value = '2020' > 2020 < / option >

    < option value = "2021" > 2021 < / option >

    < option value = "2022" > 2022 < / option >

    < / select >

    </span > < / p >

    < / div >

    < div class = "row" >

    < div style = "" display: none; ">"

    < input type = "radio" name = "PaymentMethodType" class = "tick" id = "f-payment-method-cc" value = "1" / >

    < input type = "radio" name = "PaymentMethodType" id = "PaymentMethodType_9" value = "10" / >

    < / div >

    < / div >

    < div class = "row" >

    < class p = 'field ccvn' >

    < label for 'ccv-number' = > CCV number < em > * < /em > < / label >

    < span class = "ccv" >

    < input type = "text" name = "CardCCV" class = "text" id = 'cvv-cc-f' / >

    </span > < / p >

    < / div >

    < / fieldset >

    < div class = "total wrap" >

    < class p = 'sum' > Total: < strong > < span class = "amountSpan" > < / span > < / strong > < / p >

    < class p = 'action' > < button class = "a button" type = "submit" > Checkout < button / > < / p >

    < / div >

    < input type = "hidden" name = "Amount" class = "cat_textbox" id = 'Amount' readonly = "readonly" / >

    "< script type =" text/javascript"src="/CatalystScripts/ValidationFunctions.js "> < / script >

    < script language = "javascript" type = "text/javascript" >

    <! [CDATA]

    var submitcount42059 = 0; function checkWholeForm42059 (theForm) {var why = ""; if (theForm.Username) why += isEmpty (theForm.Username.value, "Username");} If (theForm.Password & & theForm.PasswordConfirm) {why += isEmpty (theForm.Password.value, "Password");} Why += isEmpty (theForm.PasswordConfirm.value, "Confirm Password"); If (theForm.Password.value! = theForm.PasswordConfirm.value) why appendBreak += ("-password and its confirmation do not match."); If (theForm.Password.value.length < 6) why appendBreak += ("-password must be 6 characters or more.") ;} If (theForm.FirstName) why += isEmpty (theForm.FirstName.value, "Name"); If (theForm.LastName) why += isEmpty (theForm.LastName.value, "Last name"); If (theForm.HomePhone) why += isEmpty (theForm.HomePhone.value, "phone number"); If (theForm.EmailAddress) why += checkEmail (theForm.EmailAddress.value); If (theForm.ShippingAttention) why += isEmpty (theForm.ShippingAttention.value, "Name"); If (theForm.ShippingAddress) why += isEmpty (theForm.ShippingAddress.value, "delivery address"); If (theForm.HomePhone) why += isEmpty (theForm.HomePhone.value, "phone number"); If (theForm.ShippingState) why += isEmpty (theForm.ShippingState.value, "Shipping status");  If (theForm.ShippingCity) why += isEmpty (theForm.ShippingCity.value, 'City of shipping');  If (theForm.ShippingZip) why += isEmpty (theForm.ShippingZip.value, "shipping Zipcode");

    If (theForm.BillingAddress) why += isEmpty (theForm.BillingAddress.value, "Billing address");  If (theForm.BillingState) why += isEmpty (theForm.BillingState.value, "Billing State");  If (theForm.BillingCity) why += isEmpty (theForm.BillingCity.value, "City of billing");  If (theForm.BillingZip) why += isEmpty (theForm.BillingZip.value, 'Billing postal Code');

    If (! theForm.PaymentMethodType: getRadioSelected (theForm.PaymentMethodType) == 1) {if (theForm.CardName) why += isEmpty (theForm.CardName.value, "Name on card"); if (theForm.CardNumber) why += isNumeric (theForm.CardNumber.value, "card number");} If (theForm.Amount) why += isCurrency (theForm.Amount.value, "Amount") ;} If (theForm.PaymentMethodType) why += checkSelected (theForm.PaymentMethodType, "payment method"); If (why! = "") {alert (why);} return false ;} If (submitcount42059 == 0) {submitcount42059 ++; theForm.submit (); return false ;}; else {alert ("the form submission is in course."); return false ;}}}}

    Info credit card is not required if you pay by PayPal, hosted credit card, COD etc.

    function ShowCCFields (val) {}

    If (! document.getElementById ('paymentdiv'))

    return;

    If (val! = 1).

    document.getElementById('paymentdiv').style.display = 'none ';

    on the other

    document.getElementById('paymentdiv').style.display = 'inline ';

    }

    []] >

    < /script >

    < / make >

    < / section >

    To add further to Robert:

    This bit you hid. You have no script to pre-select on anything in the code you have posted.

  • 4.2 Hyperic and admin helper plugin

    Hello...

    I try to install the admin helper plugin in a new installation of hyperic EA 4.2. However, when starting, an excecption is thrown:

    2009-12-21 13:22:32, 639 INFO [hand] [org.hyperic.hq.hqu.rendit.RenditServer@107] loading plugin in [/ home/people/bjoern/hyperic/server-4.2.0-EE/hq-engine/server/default/deploy/hq.ear/hq.war/hqu/adminhelper]
    2009-12-21 13:22:32, 639 INFO [hand] [org.hyperic.hq.hqu.rendit.PluginWrapper@126] loading plugin [/ home/people/bjoern/hyperic/server-4.2.0-EE/hq-engine/server/default/deploy/hq.ear/hq.war/hqu/adminhelper] with chargers for: [file:/home/people/bjoern/hyperic/server-4.2.0-EE/hq-engine/server/default/deploy/hq.ear/rendit_sys/]
    2009-12-21 13:22:35, 886 WARN [hand] [org.hyperic.hq.ui.server.session.UIStartupListener@95] unable to add the plugin in [/ home/people/bjoern/hyperic/server-4.2.0-EE/hq-engine/server/default/deploy/hq.ear/hq.war/hqu/adminhelper]
    org.hyperic.hq.hqu.rendit.PluginLoadException: could not load the plugin
    at org.hyperic.hq.hqu.rendit.RenditServer.loadPlugin(RenditServer.java:140)
    at org.hyperic.hq.hqu.rendit.RenditServer.addPluginDir(RenditServer.java:109)
    to org.hyperic.hq.ui.server.session.UIStartupListener$ 1.fileAdded(UIStartupListener.java:93)
    at org.hyperic.hq.ui.server.session.UIStartupListener.initPlugins(UIStartupListener.java:112)
    in org.hyperic.hq.ui.server.session.UIStartupListener.access$ 100 (UIStartupListener.java:44)
    to org.hyperic.hq.ui.server.session.UIStartupListener$ UIPluginInitializer.pluginsDeployed (UIStartupListener.java:66)
    at sun.reflect.NativeMethodAccessorImpl.invoke0 (Native Method)
    at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
    at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
    at java.lang.reflect.Method.invoke(Method.java:597)
    to org.hyperic.util.callback.CallbackType$ 1.callListeners(CallbackType.java:50)
    to org.hyperic.util.callback.CallbackDispatcher$ CallbackHandler.invoke (CallbackDispatcher.java:89)
    to $Proxy380.pluginsDeployed (Unknown Source)
    at org.hyperic.hq.product.server.mbean.ProductPluginDeployer.handleNotification(ProductPluginDeployer.java:226)
    at sun.reflect.NativeMethodAccessorImpl.invoke0 (Native Method)
    at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
    at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
    at java.lang.reflect.Method.invoke(Method.java:597)
    at org.jboss.mx.notification.NotificationListenerProxy.invoke(NotificationListenerProxy.java:153)
    to $Proxy234.handleNotification (Unknown Source)
    at org.jboss.mx.util.JBossNotificationBroadcasterSupport.handleNotification(JBossNotificationBroadcasterSupport.java:127)
    at org.jboss.mx.util.JBossNotificationBroadcasterSupport.sendNotification(JBossNotificationBroadcasterSupport.java:108)
    at org.jboss.system.server.ServerImpl.sendNotification(ServerImpl.java:916)
    at org.jboss.system.server.ServerImpl.doStart(ServerImpl.java:497)
    at org.jboss.system.server.ServerImpl.start(ServerImpl.java:362)
    at org.jboss.Main.boot(Main.java:200)
    to org.jboss.Main$ 1.run(Main.java:508)
    at java.lang.Thread.run(Thread.java:619)
    Caused by: org.hyperic.hq.hqu.rendit.PluginLoadException: could not load the plugin
    at org.hyperic.hq.hqu.rendit.PluginWrapper.loadPlugin(PluginWrapper.java:162)
    at org.hyperic.hq.hqu.rendit.RenditServer.loadPluginInternal(RenditServer.java:166)
    to org.hyperic.hq.hqu.rendit.RenditServer.access$ 000 (RenditServer.java:52)
    to org.hyperic.hq.hqu.rendit.RenditServer$ 1.run(RenditServer.java:136)
    at org.hyperic.hq.hibernate.SessionManager.runInSessionInternal(SessionManager.java:79)
    at org.hyperic.hq.hibernate.SessionManager.runInSession(SessionManager.java:68)
    at org.hyperic.hq.hqu.rendit.RenditServer.loadPlugin(RenditServer.java:130)
    ... more than 27
    Caused by: org.codehaus.groovy.control.MultipleCompilationErrorsException: failed to start, /home/people/bjoern/hyperic/server-4.2.0-EE/hq-engine/server/default/deploy/hq.ear/hq.war/hqu/adminhelper/app/EEManager.groovy: 21: unable to solve the com.hyperic.hq.bizapp.shared.action.EnableAlertDefActionConfig class
    @ line 21, column 1.
    import com.hyperic.hq.bizapp.shared.action.EnableAlertDefActionConfig
    ^
    Home/People/Bjoern/Hyperic/Server-4.2.0-EE/HQ-Engine/Server/default/deploy/HQ.ear/HQ. War/hqu/adminhelper/App/EEManager.groovy: 117: unable to solve the com.hyperic.hq.bizapp.shared.action.EnableAlertDefActionConfig class
    @ line 117, column 3.
    eaa.setAlertDefId (rMeasurementId)
    2009-12-21 13:22:32, 639 INFO [hand] [org.hyperic.hq.hqu.rendit.RenditServer@107] loading plugin in [/ home/people/bjoern/hyperic/server-4.2.0-EE/hq-engine/server/default/deploy/hq.ear/hq.war/hqu/adminhelper]
    2009-12-21 13:22:32, 639 INFO [hand] [org.hyperic.hq.hqu.rendit.PluginWrapper@126] loading plugin [/ home/people/bjoern/hyperic/server-4.2.0-EE/hq-engine/server/default/deploy/hq.ear/hq.war/hqu/adminhelper] with chargers for: [file:/home/people/bjoern/hyperic/server-4.2.0-EE/hq-engine/server/default/deploy/hq.ear/rendit_sys/]
    2009-12-21 13:22:35, 886 WARN [hand] [org.hyperic.hq.ui.server.session.UIStartupListener@95] unable to add the plugin in [/ home/people/bjoern/hyperic/server-4.2.0-EE/hq-engine/server/default/deploy/hq.ear/hq.war/hqu/adminhelper]
    org.hyperic.hq.hqu.rendit.PluginLoadException: could not load the plugin
    at org.hyperic.hq.hqu.rendit.RenditServer.loadPlugin(RenditServer.java:140)
    at org.hyperic.hq.hqu.rendit.RenditServer.addPluginDir(RenditServer.java:109)
    to org.hyperic.hq.ui.server.session.UIStartupListener$ 1.fileAdded(UIStartupListener.java:93)
    at org.hyperic.hq.ui.server.session.UIStartupListener.initPlugins(UIStartupListener.java:112)
    in org.hyperic.hq.ui.server.session.UIStartupListener.access$ 100 (UIStartupListener.java:44)
    to org.hyperic.hq.ui.server.session.UIStartupListener$ UIPluginInitializer.pluginsDeployed (UIStartupListener.java:66)
    at sun.reflect.NativeMethodAccessorImpl.invoke0 (Native Method)
    at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
    at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
    at java.lang.reflect.Method.invoke(Method.java:597)
    to org.hyperic.util.callback.CallbackType$ 1.callListeners(CallbackType.java:50)
    to org.hyperic.util.callback.CallbackDispatcher$ CallbackHandler.invoke (CallbackDispatcher.java:89)
    to $Proxy380.pluginsDeployed (Unknown Source)
    at org.hyperic.hq.product.server.mbean.ProductPluginDeployer.handleNotification(ProductPluginDeployer.java:226)
    at sun.reflect.NativeMethodAccessorImpl.invoke0 (Native Method)
    at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
    at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
    at java.lang.reflect.Method.invoke(Method.java:597)
    at org.jboss.mx.notification.NotificationListenerProxy.invoke(NotificationListenerProxy.java:153)
    to $Proxy234.handleNotification (Unknown Source)
    at org.jboss.mx.util.JBossNotificationBroadcasterSupport.handleNotification(JBossNotificationBroadcasterSupport.java:127)
    at org.jboss.mx.util.JBossNotificationBroadcasterSupport.sendNotification(JBossNotificationBroadcasterSupport.java:108)
    at org.jboss.system.server.ServerImpl.sendNotification(ServerImpl.java:916)
    at org.jboss.system.server.ServerImpl.doStart(ServerImpl.java:497)
    at org.jboss.system.server.ServerImpl.start(ServerImpl.java:362)
    at org.jboss.Main.boot(Main.java:200)
    to org.jboss.Main$ 1.run(Main.java:508)
    at java.lang.Thread.run(Thread.java:619)
    Caused by: org.hyperic.hq.hqu.rendit.PluginLoadException: could not load the plugin
    at org.hyperic.hq.hqu.rendit.PluginWrapper.loadPlugin(PluginWrapper.java:162)
    at org.hyperic.hq.hqu.rendit.RenditServer.loadPluginInternal(RenditServer.java:166)
    to org.hyperic.hq.hqu.rendit.RenditServer.access$ 000 (RenditServer.java:52)
    to org.hyperic.hq.hqu.rendit.RenditServer$ 1.run(RenditServer.java:136)
    at org.hyperic.hq.hibernate.SessionManager.runInSessionInternal(SessionManager.java:79)
    at org.hyperic.hq.hibernate.SessionManager.runInSession(SessionManager.java:68)
    at org.hyperic.hq.hqu.rendit.RenditServer.loadPlugin(RenditServer.java:130)
    ... more than 27
    Caused by: org.codehaus.groovy.control.MultipleCompilationErrorsException: failed to start, /home/people/bjoern/hyperic/server-4.2.0-EE/hq-engine/server/default/deploy/hq.ear/hq.war/hqu/adminhelper/app/EEManager.groovy: 21: unable to solve the com.hyperic.hq.bizapp.shared.action.EnableAlertDefActionConfig class
    @ line 21, column 1.
    import com.hyperic.hq.bizapp.shared.action.EnableAlertDefActionConfig
    ^
    Home/People/Bjoern/Hyperic/Server-4.2.0-EE/HQ-Engine/Server/default/deploy/HQ.ear/HQ. War/hqu/adminhelper/App/EEManager.groovy: 117: unable to solve the com.hyperic.hq.bizapp.shared.action.EnableAlertDefActionConfig class
    @ line 117, column 3.
    eaa.setAlertDefId (rMeasurementId)

    Any tips?

    Björn

    I met the same problem, and the EnableAlertDefActionConfig has been moved to the org.hyperic.hq.bizapp.shared.action package.  You should be able to change as an import in the EEManager.groovy and redeploy the new plugin from AdminHelper without any error.  I just did (took half an hour, and it was mainly to ensure that I lacked no other changes).

  • table in the browser

    Hello

    I continue to meet a problem with some of my pages that causes the main table move slightly when I navigate to another page. However this is about a particular browser, in this case safari.

    Here is a link to the page. If you click on the button home once on the page (and safari), you will see the page move slightly to the left.

    Skycrest Quality Foods Ltd

    Here is the html code. I had this problem a lot, sometimes I correct the problem by changing the rows and columns, but I still do not understand why this is.

    Is this a common problem? any help would be greatly received.

    < body bgcolor = "#FFFFFF" text = "#000000" >

    < table width = "1024" cellpadding = "0" cellspacing = "0" class = "border1" >

    < b >

    < td width = "709" height = "331" >

    < table width = "100%" border = "0" cellspacing = "0" cellpadding = "0" >

    < b >

    "" < td colspan = "2" > < img src = "... / graphics and info2/homepage_03.png" width = "996" height = "220" > < table >

    < /tr >

    < b >

    < td width = "110" > < table >

    < td width = "522" > < form name = "form1" method = "post" action = "" > < div class = "AJXCSSMenubCPHTcD" > <!-AJXFILE:... Jumpmenu.CSS->

    < ul >

    "< class li ="tfirst"> < a href ="... / index2.html "> HOME < /a > < /li >"

    < class li = "tsub" > < a class = "ajxsub" href = "aboutus.html" > ABOUT US < /a >

    < ul >

    < class li = "obama'sfirst" > < a href = "our - story.html" > Our Story < /a > < /li >

    < /ul >

    < /li >

    < class li = "tsub" > < a class = "ajxsub" href = "#" > PRODUCTS < /a >

    < ul >

    < class li = "obama'sfirst" > < a class = "ajxsub" href = "canapes.html" > < /a > dirty sofas

    < ul >

    < class li = "obama'sfirst" > < a href = "Empanades.html" > Empanades, Pasties, turnovers < /a > < /li >

    < li > < a href = "Frittata.html" > Frittata, Samosas, dirty cakes < /a > < /li > ""

    < li > < a href = "pies.html" > pasta, brioche sausages < /a > < /li > ""

    < li > < a href = "quiche.html" > basics of Quiche, Quiches, Savoury tart < /a > < /li > ""

    < /ul >

    < /li >

    < li > < a href = "#" > Savoury entry / hand < /a > < /li >

    < li > < a class = "ajxsub" href = "sweet.html" > < /a > SWEET

    < ul >

    < class li = "obama'sfirst" > < a href = "accompaniments.html" > support < /a > < /li > ""

    < li > < a href = "assiettes.html" > plates, 4 small & amp; "" Puddings < /a > < /li >

    < li > < a href = "cakes.html" > cakes: 7 cm, 8 cm & amp; "" Fried homes < /a > < /li >

    < li > < a href = "Meringue - rolls.html" > Meringue Rolls & amp; Muffins < /a > < /li >

    < li > < a href = "Sweet - loaves.html" > Sweet loaves & amp; Make Christmas < /a > < /li >

    < li > < a href = "Sweet - tarts.html" > Sweet Tarts < /a > < /li >

    < /ul >

    < /li >

    < li > < a href = "tartlets.html" > TARTS < /a > < /li > ""

    < /ul >

    < /li >

    < class li = "tsub" > < a class = "ajxsub" href = "#" > < /a > PRICING

    < ul >

    < class li = "obama'sfirst" > < a href = "#" > dirty sofas < /a > < /li >

    < li > < a href = "#" > Savoury entry / hand < /a > < /li >

    < li > < a href = "#" > Sweet < /a > < /li >

    < li > < a href = "tarts - price.html" > tarts < /a > < /li >

    < li > < a href = "#" > print < /a > < /li >

    < /ul >

    < /li >

    < li > < a href = "testimonials.html" > STORIES < /a > < /li > ""

    < li > < a href = "contact.html" > CONTACT < /a > < /li > ""

    < /ul >

    < br >

    < / div >

    < / form > < table >

    < /tr >

    < b >

    < td colspan = "2" > < class p = "header1" > < / p >

    < class p = "header1" > Sweet products < /p >

    < table width = "100%" border = "0" cellpadding = "0" cellspacing = "0" >

    < b >

    "" < class td = "text1" > < img src = "... / graphics and info2/spacer.gif" width = "55" height = "10" alt = "spacer" > < table >

    < class td = "text1" > < p > why not have your cake and eat it too? Here at Skycrest we respond to your sugar cravings if you hunt for the age-old traditional or the deliciously different, no point slaving over a hot stove, when Skycrest it can do for you! < /p >

    < p > see the links for our exhaustive (but not exclusive) list of what we currently do for different traders, businesses and restaurants below. Have a flavor/product, you & rsquo; t see here in our list? Just give us a call - we'd love to welcome you. < /p > < table >

    "" < class td = "text1" > < img src = "... / graphics and info2/spacer.gif" width = "55" height = "10" alt = "spacer" > < table >

    < /tr >

    < b >

    < td > < table >

    < class td = "anchor links" > < p > < / p >

    < p > < a href = "accompaniments.html" > support < /a > < br / > ""

    < br >

    < a href = "assiettes.html" > plates, 4 small & amp; Puddings < /a > < br >

    < br >

    < a href = "cakes.html" > cakes: 7 cm, 8 cm & amp; Self Saucing < /a > < br >

    < br >

    < a href = "Meringue - rolls.html" > Meringue Rolls & amp; Muffins < /a > < br >

    < br >

    < a href = "Sweet - loaves.html" > Sweet loaves & amp; Make Christmas < /a > < br >

    < br >

    < a href = "Sweet - loaves.html" > Sweet Tarts < /a > < br >

    < br >

    < /p > < table >

    < td > < table >

    < /tr >

    < b >

    < td = '99' height > < table >

    < td > < table >

    < td > < table >

    < /tr >

    < b >

    < td > < table >

    < td > < table >

    < td > < table >

    < /tr >

    < / table > < table >

    < /tr >

    < b >

    < td height = "5" colspan = "2" bgcolor = "#660000" > < div > < span class = 'text-white' > Copyright 2014. Skycrest Quality Foods Ltd. All rights reserved. </span > < / span > < / span > < / div > < table >

    < /tr >

    < /table >

    < table >

    < /tr >

    < /table >

    < / body >

    < / html >

    I suspect that 'change' that you see is the appearance of scrollbars on long pages and the lack of them on a few pages.   To make all the pages have a scroll bar channel, add this to your global style sheet.

    HTML {overflow-y: scroll}

    Nancy O.

Maybe you are looking for

  • Search application restore in Time Machine is empty

    I was looking for in Time Machine to restore an earlier version of Pages, but when I opened the time Machine in the Applications section is empty. Other files (Documents, downloads) watch the content, but only applications have nothing to show. What

  • Pavilion 500: PC does not start.

    I recently installed Windows 10 preview alongside Windows Enterprise 8.1, due to the fact that I could not install the latest version of Windows 10 preview 10041 I tried fiddling around with my boot partition, consiquently I can't boot my machine at

  • Series read, store queue and time-evenly continues treatment, but the data is mixed now

    Hello, all,. I send MCU APR data to the PC via a serial interface, 16bytes each time interval of 50 ms, if I donot use queue, the data read visa are the same as sent. But reading and in turn within a while loop is not time efficiently as the multiple

  • Why has my Sibelius 6 suddenly stopped working on Windows Vista?

    It worked fine until a few weeks ago. Now, when I try to start Sibelius 6, I immediately get the message "Sibelius has stopped working - a problem caused blocking the program works properly...". Help! I have topped up Sibelius 6; My PC is not large e

  • BlackBerry 10 blank homescreen - why do I need when I close my apps?

    I'm a kind of a user who cares about the battery life and tries to preserve as much as possible. Which means that I turn my apps turned off as soon as I'm done with them. With the latest version of the OS, which leaves me with a screen completely bla