Debugging 64-bit OS of the tiara script functions

Hello

I have installed Diadem 12 on my laptop HP OS to 64-bit (version 12.0.0f4911) and noticed that the script debugging buttons are grayed out. My old portable 32-bit HP has the same software, but that's ok.

I also installed it on a DELL 64-bit workstation and this also has the same problem, it's not the aptop.

Can anyone help?

Karoline

Thank you, Brad.

Laurence Colvin
(National Instruments Applications Engineering) also responded to my request through technical support.

Thank you both for the quick response.

ADE K

Tags: NI Software

Similar Questions

  • How to enable the Java Script function in APEX 4.2.6 running on the result of an Xquery query.

    How to take a SQL query result in the source section of an APEX "agenda of the page" field and allow this request to be formatted using XML in an HTML format for a Java Script file to perform a function on the result?

    Currently I have the following text:

    To query the DB table and format the result as HTML:

    SELECT XMLELEMENT ("UL id ="ticker01"', XMLAGG (XMLFOREST (Scroll_Mess AS LI))") "item UL' OF Web_Ticker where Mess_Id < 10 order by Mess_Id;


    That displays the following:


    < UL id = "ticker01" > < LI > HELLO < /LI > < LI > HELLO < /LI > < /UL id = "ticker01" >

    I need the output of this to be visible to a JScript function that is currently called the "head of page", but there doesn't seem to be its scope? The function works correctly if there is a list in the page field items 'Text element Pre' but does not work correctly when used in conjunction with the query to generate a table form.

    If everyone is happy to help I would be grateful .

    James.

    Solved!

    In order for the request to be part of the DOM of the page of the APEX, the Java Script allows to perform its function on the result marked "HTML" to query, you must set page of the apex on which the query resides and then add the inner text of this page to a second variable for which the function of web ticker can run on as follows:

    $(function() {})

    var x = $("#P9_TICKER_DATA");

    var y = x [0] .innerText;

    x.Append (y);

    $("UL#ticker01").liScroll ();

    });

    From there, on the Java script is able to properly see the result of the query in HTML format.

  • Create the Java script function

    Hello

    I try to create the following java script function to retrieve a character string:

    String.prototype.left = function (findWhat)

    {

    try

    {

    var = this.search (findWhat) position;

    If (position > - 1).

    Return this.substr (0, position);

    }

    catch (e)

    {

    / / alert (e.message);

    }

    return "";

    };

    var text = "myText-description";

    var separator = "-";

    In this example, I try to extract the word on the left before the "-" delimiter (mtText)

    But I get the following error message: failed to add a property to an object sealed: left

    My question is how can I create a simple js function in the Orchestrator in the following example

    Thank you

    Hello

    You can try the code to retrieve a string from left to right below the delimiter.

    
    searchstr();
    
    function searchstr() {
       try{
       var str = "angela.soni"
       var pos = str.indexOf("."); // Currently this is hard coded, you can pass delimiter as an input parameter.
       if(pos>-1) {
          var substr = str.substring( 0, pos );
          System.log(substr);
       }
       else {
          System.error("Delimiter not found");
       }
      }
      catch (e) {
       System.error("Search failed: " + e);
      }
    }
    

    I hope this would help you.

    Thank you!

    Angela

  • How access to the registry of the tiara script window?

    Access to registry windows (read-write) of the script of tiara?  Could someone give me some examples?

    Thank you

    That's right, but

    Dim wsh: wsh value = CreateObject ("WScript.Shell")
    WSH. Popup "it's a script.

    would work.

    The wscript object is not available in tiara. It is available only if you start a vbs by wscript.exe

  • How to close the tiara after executing the script

    Hello

    I'm tiara of batch file with command-line startscript option to run a VBS do certain things. Now the tiara rises gently and running the VBS everything very well. HOWEVER, the tiara is started as a fork daemon, which means that the lot does not expect that it ends the script VBS and don't FARM not automatically after the script. Somehow do that in the end VBS automatically? Or I can do it via batch file?

    Hello

    try to call ProgramExit() or call the ApplicationExit() at the end of the script.

    GEMÜ

  • The tiara 10.2 is supported in Windows 7 (64-bit)

    The tiara 10.2 is supported in Windows 7 (64-bit)

    Have you tried a search?

    National Instruments for Microsoft Windows 7 product compatibility

  • Permission denied error when you use the Matlab script

    I have the following simple running a Matlab script in Labview.

    K = 5;
    Matrix = randn (4,4);
    matlab.io.saveVariablesToScript ('Parameters.m', {'K', 'Matrix'})

    the last command saves the variables 'K' and 'Matrix' in the m-settings file that I can then use to load the settings 'K' and 'Matrix' to a 'Control Design and Simulation Model'.

    When I run the now from Matlab everything works fine. When I run this LabVIEW so I get the following error:

    LabVIEW: An error has occurred during execution of the script. Error message from the server?: Error using matlab.io.saveVariablesToScript
    Parameters.m: Could not open the file: permission denied.

    I use Matlab 2015 and LAbview 2015 in a 64-bit windows computer 7.

    Any help would be really appreciated.

    For those who have the same permission denied errors, I found the solution.

    I had to specify the current working directory in the matlab script (this is the directory to which you saved your LAbview VI).

    For example, if you have saved your labview vi to C:\Example_Folder

    then you must add the following command in your matlab script node before the command that causes the error

    CD (' c:/Example_Folder')

    I hope this will help.

  • Tiara script: Goto &amp; continue do not work

    Hi all

    I have trouble using 'Goto' and 'Continue For' lines in the script of DIAdem.  Does anyone know if these are disabled in DIAdem or if I'm doing something wrong.  Take for example these examples below:

    Goto:

    option explicit
    dim a,b
    b=""
    for a=1 to 50
      if a=10 then goto Printer
      b=b&" "&a
    next 'a
    
    Printer:
    msgbox(b)
    

    an error directly after the text "goto".

    Continue:

    option explicit
    dim a,b
    b=""
    for a=1 to 50
      if a=10 then continue for
      b=b&" "&a
    next 'a
    
    Printer:
    msgbox(b)
    

    An error right after the text of "continue".

    Please enlighten us on that.  Thank you!

    Hello GT_Mark,

    VBS is only associated "GoTo" "On Error Resume Next '. In all other cases "GoTo" and "Continue" are not part of the VBS command set. (Please keep in mind that the tiara supports VBS and no VBA or VB.) Your example can be changed as follows:

    Option Explicit
    
    dim a,b
    b=""
    a = 0
    do while (a < 10)
      a = a + 1
      b=b&" "&a
    loop 'a
    
    msgbox(b)
    

    Greetings

    Walter

  • 802. 1 x with the login script

    Hello

    Before you set the 802. 1 x with ISE. Logon user with a script to map the network drive.

    We deployed the 802. 1 x with ip phone and your PC successfully, but the logon script does not work now.

    Whatever measures are necessary to make the login script work?

    ISE:2.1

    switch: 3750 with 12.2 (55) SE10

    PC:Win7 (to connect to the ip phone)

    IP phone: 6921 (connect to switch f 1/0/4)

    Switch configuration is to see more:

    !
    version 12.2
    no service button
    tcp KeepAlive-component snap-in service
    a tcp-KeepAlive-quick service
    horodateurs service debug datetime localtime show-timezone msec
    Log service timestamps datetime localtime show-timezone msec
    no password encryption service
    Service linenumber
    sequence numbers service
    !
    hostname ISESW01
    !
    boot-start-marker
    boot-end-marker
    !
    enable password 7 xxxxxxxxxxxxxxxxxxxxxx
    !
    username password 7 xxxxxxxxxxxxxxxxxxxx xxxxxxxxxxx
    !
    !
    AAA new-model
    !
    !
    RADIUS AAA server group ISE
    auth-port 1645 10.202.152.91 Server acct-port 1646
    auth-port 1645 10.202.152.92 Server acct-port 1646
    !
    default AAA dot1x ISE authentication group
    AAA authorization network default group ISE
    AAA authorization auth-proxy default group ISE
    accounting AAA periodic update 5
    accounting dot1x default start-stop group AAA ISE
    AAA accounting system by default start-stop group ISE
    !
    !
    AAA server RADIUS Dynamics-author
    customer 10.202.152.91
    customer 10.202.152.92
    !
    AAA - the id of the joint session
    switch 1 supply ws-c3750v2-48ps
    mtu 1500 routing system
    VTP transparent mode
    DHCP excluded-address IP 10.202.21.1 10.202.21.10
    DHCP excluded-address IP 10.202.121.196
    !
    IP dhcp pool testingdhcp
    Network 10.202.19.0 255.255.255.0
    router by default - 10.202.19.1
    10.202.152.21 DNS server
    !
    !
    analysis of IP device
    !
    MLS qos map policed dscp 0 10 18 24 46-8
    MLS qos map cos-dscp 0 8 16 24 32 46 48 56
    MLS qos srr-queue input bandwidth 70 30
    MLS 1 80 90 qos srr-queue input threshold
    priority-queue input bandwidth 2 30 MLS qos srr-queue
    queue threshold 1 MLS qos srr-queue input cos-map 2 3
    queue threshold 1 MLS qos srr-queue input cos-map 3 6 7
    queue threshold 2 MLS qos srr-queue input cos-map 1 4
    queue threshold 1 MLS qos srr-queue input dscp-map 2 24
    queue threshold 1 MLS qos srr-queue input dscp-map 3 48 49 50 51 52 53 54 55
    queue threshold 1 MLS qos srr-queue input dscp-map 3 56 57 58 59 60 61 62 63
    queue threshold 2 MLS qos srr-queue input dscp-map 3 32 33 40 41 42 43 44 45
    -More - mls qos srr-queue input dscp-map 2 3 46 47 threshold queue
    queue threshold cos 1-map of MLS qos srr-queue output 3 4 5
    queue threshold cos 2-map of MLS qos srr-queue output 1 2
    queue threshold 2 cos-MLS qos srr-queue output 2 3 card
    queue threshold cos 2-map of MLS qos srr-queue output 3 6 7
    queue threshold cos 3-map of MLS qos srr-queue output 3 0
    queue threshold 4 cos-MLS qos srr-queue output 3 1 card
    queue threshold 1 dscp-map of MLS qos srr-queue output 3 32 33 40 41 42 43 44 45
    queue threshold 1 dscp-map of MLS qos srr-queue output 3 46 47
    queue threshold 2 dscp-map of MLS qos srr-queue output 1 16 17 18 19 20 21 22 23
    queue threshold 2 dscp-map of MLS qos srr-queue output 1 26 27 28 29 30 31 34 35
    queue threshold 2 dscp-map of MLS qos srr-queue output 1 36 37 38 39
    queue threshold 2 dscp-map of MLS qos srr-queue output 2 24
    queue threshold 2 dscp-map of MLS qos srr-queue output 3 48 49 50 51 52 53 54 55
    queue threshold 2 dscp-map of MLS qos srr-queue output 3 56 57 58 59 60 61 62 63
    queue threshold 3 dscp-map of MLS qos srr-queue output 3 0 1 2 3 4 5 6 7
    queue threshold 4 dscp-map of MLS qos srr-queue output 1 8 9 11 13 15
    queue threshold 4 dscp-map of MLS qos srr-queue output 2 10 12 14
    MLS qos all the output queue 1 1 100 100 50 200 threshold
    MLS qos queue of output 1 all threshold 2 125 125 100 400
    MLS qos queue of output 1 all threshold 3 100 100 100 400
    MLS qos queue of output 1 all 4 60 150 50 200 threshold
    MLS qos all the output queue 1 15 25 40 20 buffers
    MLS qos
    !
    Crypto pki trustpoint TP-self-signed-1210376576
    enrollment selfsigned
    name of the object cn = IOS - Self - signed - certificate - 1210376576
    revocation checking no
    rsakeypair TP-self-signed-1210376576
    !
    !
    TP-self-signed-1210376576 crypto pki certificate chain
    certificate self-signed 01
    xxxxxxxxx
    quit smoking
    Auto qos srnd4
    control-dot1x system-auth
    dot1x critical eapol
    !
    !
    !
    !
    pvst spanning-tree mode
    spanning tree extend id-system
    VLAN spanning tree priority 819 61440
    !
    internal allocation policy of VLAN ascendant
    !
    VLAN 121
    name Voice_Vlan
    !
    VLAN 819
    name 19F_VLAN
    !
    VLAN 888 899
    !
    !
    class-map correspondence AUTOQOS_VOIP_DATA_CLASS
    match ip dscp ef
    class-map correspondence AUTOQOS_DEFAULT_CLASS
    match the name of access by DEFAULT ACL-AUTOQOS group
    class-map correspondence AUTOQOS_VOIP_SIGNAL_CLASS
    match ip dscp cs3
    class-map correspondence AutoQoS-VoIP-RTP-Trust
    match ip dscp ef
    class-map correspondence AutoQoS-VoIP-control-Trust
    match ip dscp cs3 af31
    !
    !
    Policy-map AUTOQOS-SRND4-CISCOPHONE-POLICY
    class AUTOQOS_VOIP_DATA_CLASS
    DSCP ef Set
    128000 8000 exceed-action of the police controlled-dscp-transmit
    class AUTOQOS_VOIP_SIGNAL_CLASS
    DSCP Set cs3
    32000 8000 exceed-action of the police controlled-dscp-transmit
    class AUTOQOS_DEFAULT_CLASS
    Set default dscp
    10000000 8000 exceed-action of the police controlled-dscp-transmit
    Policy-map AutoQoS-Police-CiscoPhone
    class AutoQoS-VoIP-RTP-Trust
    DSCP ef Set
    320000 8000 exceed-action of the police controlled-dscp-transmit
    class AutoQoS-VoIP-control-Trust
    DSCP Set cs3
    32000 8000 exceed-action of the police controlled-dscp-transmit
    !
    !
    !
    !

    interface FastEthernet1/0/4
    switchport access vlan 819
    switchport mode access
    switchport voice vlan 121
    authentication event fail following action method
    action of death event authentication server allow voice
    no response from the authentication event action allow vlan 889
    living action of the server reset the authentication event
    multi-domain of host-mode authentication
    authentication order dot1x mab
    authentication priority dot1x
    Auto control of the port of authentication
    MAB
    added mac-SNMP trap notification change
    deleted mac-SNMP trap notification change
    dot1x EAP authenticator
    dot1x tx-time 10
    spanning tree portfast
    !

    !
    interface Vlan1
    no ip address
    !
    interface Vlan819
    IP 10.202.19.11 255.255.255.0
    !
    default IP gateway - 10.202.19.1
    IP classless
    IP http server
    IP http secure server
    !
    !
    IP access-list extended by DEFAULT ACL-AUTOQOS
    allow an ip
    IP access-list extended redirection
    deny udp any eq bootpc any eq bootps
    deny udp any any eq bootps
    deny udp any any eq field
    deny ip any host 10.202.154.192
    allow an ip
    !
    !
    SNMP - server RO Cisco123 community
    RADIUS attribute 6 sur-pour-login-auth server
    Server RADIUS attribute 8 include-in-access-req
    RADIUS attribute 25-application access server include
    dead-criteria 30 tent 3 times RADIUS server
    RADIUS-server host 10.202.152.91 auth-port 1645 acct-port 1646 borders 7 xxxxxxxxxxxxxxxxxxxxxxxx
    RADIUS-server host 10.202.152.92 auth-port 1645 acct-port 1646 borders 7 xxxxxxxxxxxxxxxxxxxxxxx
    RADIUS vsa server send accounting
    RADIUS vsa server send authentication

    I had a similar problem the workstations where the value "of the computer or user authentication" in the PEAP protocol settings. What is happening is that list DACL that served as of when the computer account has been authenticated restricted just DCs etc, but don't understand the locations required for the login script. It seems that Windows 7 user logon script runs before the dot1x presents the user credentials to the switch.

    Thus, in our case, we have modified the DACL is in place for the computer account to allow access to the locations required for the login script (i.e. the network sharing servers), and everything works.

  • Using the shell script sql variable

    OS: Oracle Linux 5.10

    DB Oracle 11.2.0

    I have need to query the database and assign the return value to a variable of shell, but it does not work.

    create table imr_env (key varchar2(1000), value varchar2(1000) ;
    insert into imr_env values('TblspcUsagePct','90');
    commit;
    

    Here is the shell script:

    #!/bin/bash
    echo "in script"
    ORACLE_HOME=/u01/app/oracle/product/11.2.0/db_1 ; export ORACLE_HOME
    ORACLE_SID=IMR1 ; export ORACLE_SID
    export PATH=$PATH:$ORACLE_HOME/bin
    
    pct=`sqlplus -S app/manager <<END
           set serveroutput on
           declare
              output_val number ;
           BEGIN
              select value into output_val from imr_env where key = 'TblspcUsagePct' ;
              dbms_output.put_line('output_val: ' || to_char(output_val)) ;
           END ;
           /
           exit;
    END`
    
    ## another sqlplus connection, use $pct in the where clause
    
    echo "var value is $pct"
    
    

    Here is the result:

    SQL> ./test.sh
    in script
    var value is 
    
    output_val: 90
    

    Why isn't the shell variable is populated with the value retrieved from the database?

    I need to use $pct in another query that will be storage spaces that are at least 90% full.

    I had to change to a korn shell - I couldn't get the "READ" command in shell or bash.

    But it is not only "READ" command:

    SQL > select * from IMR_ENV;

    THE KEY VALUE

    ------------------------- -----

    TblspcWarningLimit 90

    TblspcUsagePct 50

    SQL > exit

    Disconnected from the database to Oracle 11 g Enterprise Edition Release 11.2.0.3.0 - 64 bit Production

    With partitioning, OLAP, Data Mining and Real Application Testing options

    $ cat test.sh

    VAL = $(sqlplus-S test/test)<>

    Set feedback off

    set the position

    Select (value) from imr_env, including the key to_number = "TblspcUsagePct";

    Select (value) from imr_env, including the key to_number = "TblspcWarningLimit";

    "exit";

    EXPRESSIONS OF FOLKLORE

    )

    set $VAL

    Echo $1

    Echo $2

    $./test.sh

    50

    90

    $ echo $SHELL

    / bin/bash

    $

  • the 32-bit version of the plugin does not work after filterSelectorParameters

    Hello!

    I have a working version of the 64-bit plugin tested PS CC 2015. It manages only the filterSelectorStart and the filterSelectorAbout, and it works well. To compile as a 32-bit version, that I modified the caviggia file from

    CodeWin64X86 {'PluginMain'},

    TO

    #ifdef _WIN64

    CodeWin64X86 {'PluginMain'},

    #else

    CodeWin32X86 {'PluginMain'},

    #endif

    Then I compiled 32-bit version of the plugin and have started testing in PS CC (not 20xx, just CC). Before I tried to debug plugin has caused an error in allocating memory, debugging showed me this call stack.Call stack.png

    WHY is it produces, why 64-bit plugin works well and 32 bits can not? I tried to maxSpace value 0 or a low value, but in any case filterSelectorParameters branch has been called, and then there was an exception in the depths of the PS.

    Please help me fix this strange problem. Thanks in advance!

    Thank you very much Tom for assistance!

    During the long search I found a core of the problem: it is my love for the __stdcall calling convention. It looks like PluginMain must be __cdecl, so if you like __stdcall too, set at least CC of PluginMain to __cdecl. No other problems were detected.

  • How the photoshop script can call an applescript script

    I realize, maybe it's a bit of a messy way around it, but I need to get the photoshop script to call an applescript script. Basically so that I can have it become a menu item in photoshop.

    Is - this show applescript can in the same way photoshop script?

    If this isn't the case, I thought I could get either photoshop script to call the applescript or even more messy, I could use Photoshop to run a Terminal command to call the applescript.

    All thoughts

    Matt

    For those who come through it

    Save your applescript as an application, and then you can use

    App.System ("' open ' / path/to/script_as_an_app.app'" ");

    then everything works

  • VMware View customers logout - log for debugging PCoIP shows "sessionDisconnectTimer: set the timer to 2147480 seconds.

    I have operators who are still on my desktop 24/7/365.  Assuming that there are no other problems, they get kicked out of their sessions from view after about 24 days.  We use Thin Clients HP running ThinOS and VMware View Client.  When I check the log for debugging on the Windows 7 VM, I see that when the connection is established, he wrote the following line:

    2014-09-09 08:44:30, 807 DEBUG < MessageFrameWorkDispatch > [wsnm_desktop] sessionDisconnectTimer: set the timer to 2147480 seconds

    After the expiration of the time limit, I get the following messages in the same newspaper and the client disconnects:

    2014-09-09 08:30:08, 571 DEBUG < TimerService > [wsnm_desktop] sessionDisconnectTimer: triggered timer, session is disconnected.

    2014-09-09 08:30:08, 571 DEBUG < TimerService > [wsnm_desktop] session::SessionDisconnectTimedOut: Disconnect message posted on the desktop

    Where it becomes this timer of?  The global setting on the display server is maxed at 9 999 999 minutes.

    The host is EXSi 5.0.0

    VMware View Server is 5.0.0 - 481677

    See Agent 5.0.1

    Operating system is Windows 7 Pro running on the virtual version 7 machine

    It is a known problem that has been fixed in 5.3.2 view - the global time-out in minutes is converted to a time in milliseconds, which then overflows a 32-bit counter. See Overview of VMware View Release Notes

    A desktop session is timeout and be disconnected after about 24 days, 20 hours and 31 minutes, even if the Session time-out setting has been set to a higher value.

    Mike

  • Effect of NLS_LANG in the SQL scripts

    DB version: 11.2.0.2
    Platform: RHEL 5.6


    We have a software provider who occasionally sends SQL scripts to deploy.

    The scripts contain usually few CFDS and many LMD

    Textpad, I can see, the LMD (inserts, updates) in the SQL Script. It usually contains some non-English characters (Dutch, German, French) as
    'Übersicht Buchungssätze' .
    'Fehler beim Löschen der zugeordneten Referenzen!'
    They always ask us set NLS_LANG as follows.
    export NLS_LANG="AMERICAN_AMERICA.WE8ISO8859P15"
    After INSERTION, I questioned the inserted values of PL/SQL Developer. Values appear exactly as it appears in the SQL Script text file as shown above.
    So, what was the effect of the NLS_LANG setting? What would have happened if I had not set NLS_LANG?


    NLS in the DB Info
    SQL > select * from nls_Database_parameters;
    
    PARAMETER                      VALUE
    ------------------------------ ----------------------------------------
    NLS_LANGUAGE                   ENGLISH
    NLS_TERRITORY                  UNITED KINGDOM
    NLS_CURRENCY                   #
    NLS_ISO_CURRENCY               UNITED KINGDOM
    NLS_NUMERIC_CHARACTERS         .,
    NLS_CHARACTERSET               AL32UTF8
    NLS_CALENDAR                   GREGORIAN
    NLS_DATE_FORMAT                DD-MON-RR
    NLS_DATE_LANGUAGE              ENGLISH
    NLS_SORT                       BINARY
    NLS_TIME_FORMAT                HH24.MI.SSXFF
    NLS_TIMESTAMP_FORMAT           DD-MON-RR HH24.MI.SSXFF
    NLS_TIME_TZ_FORMAT             HH24.MI.SSXFF TZR
    NLS_TIMESTAMP_TZ_FORMAT        DD-MON-RR HH24.MI.SSXFF TZR
    NLS_NCHAR_CHARACTERSET         AL16UTF16
    NLS_DUAL_CURRENCY              ?
    NLS_COMP                       BINARY
    NLS_LENGTH_SEMANTICS           BYTE
    NLS_NCHAR_CONV_EXCP            FALSE
    NLS_RDBMS_VERSION              11.2.0.2.0
    
    20 rows selected.

    If our supplier had chosen to save the script with the UTF-8 encoding, then, we have set NLS_LANG. Right?

    Evil. You need to AMERICAN_AMERICA. AL32UTF8. If you don't set NLS_LANG, it uses default AMERICAN_AMERICA. US7ASCII. Therefore, only pure ASCII 7-bit scripts can be executed in such environment. The Oracle Client does not use the default database character. It uses the platform default (usually US7ASCII) or UTF-16 in the case of JDBC, ODBC (Unicode mode) and ODP .NET pilots.

    -Sergiusz

  • I don't have the button 'export the layer to files. In any case to redownload the default scripts?

    Well I'm doing a flip book House in Photoshop CS5 and tries to save the images.

    I imported a video and converted into individual layers for each image.

    Now I'm trying to save it by going in "file > Scripts > layer export to files and there is no option in my Scripts tab at all."

    When I go on "file > Scripts all that are in there is just 'Browse'."

    Then when I click on 'Browse' it just takes me to the folder where I opened the PS file.

    Anyone has an idea on how I can get back the default scripts?

    I have even not all scripts to export layers, which is something I do often.

    Location depending on the version of the OS and Photoshop script must be in the Photoshop presets for example, Scripts Windows 7

    "C:\Program Files\Adobe\Adobe Photoshop CS6 (64 Bit) \Presets\Scripts\Export layers to Files.jsx"

    Do a search on your drive to "Export layers to Files.jsx" where the file has been moved.  Other wise get it back from your backup system or reinstall Photoshop on top of itself to recover the missing files.  You won't lose you Photoshop preferences and responsible actions etc. your setting is not overwritten.

Maybe you are looking for