Hash SHA256 MAC

I want to generate a key hash value using the HMAC method and the SHA256 hash algorithm using Security Builder API, but I can not get the desired result and found no example in the documentaion or forum on how to do this.

It is the call to hu_HMACSHA256End that actually generates the hash for you. All you need to do is put this line above where you define QByteArray password_hash_data.

Tags: BlackBerry Developers

Similar Questions

  • File hash SHA256, to upload to the server cloud. IM lost...

    Yet once here, bother this time because I have a problem in Cryptography (which I've never really worked).

    Well, I have to create a hash SHA256 from any file I want to download from a web server in the cloud, why? Because one of the parameters of the header that make me: x-filehash - A SHA256 hash of the file.

    I googled on how to do it and I found two ways to perform this task, the first is the native (using the husha2.h library) and the second is a library called polarssl.

    When I go through polarssl I noticed it's almost equal to the native form, so I finished it by selecting husha2.h.

    The problem is that I don't know much about the 3 or 4 functions to create a SHA256 hash and less for an entire file. So I wanted to ask if a kind soul among most here, has a small example to use this library, but I at least to explain a bit what each of the settings and what would be the order in which you must use the functions.

    Thank you and sorry for the inconvenience.

    I tried the same sequence of calls you (I've hard-coded the HMAC key and input data) and I got consistent results every time. Here is my piece of code (I called once, the onInitSecurity() onMakeHash() several times and onEndSecurity() once) - I use emit message() to send to QML on my screen. Did you check the return codes from each call? I have SB_SUCCESS on them. Variables beginning _... are the ones class instance.

    void ApplicationUI::onInitSecurity() {
    
        emit message("XXXX onInitSecurity");
    
        int returnCode = SB_SUCCESS; /* Return Code */
    
        /* Create SB Contexts */
    
        returnCode = hu_GlobalCtxCreateDefault(&_sbCtx);
    
        if (returnCode != SB_SUCCESS) {
            emit message("XXXX makeHash ERROR creating SB contexts:" + Utilities::intToHex(returnCode));
            return;
        } else {
            emit message("XXXX makeHash SUCCESS creating SB contexts");
        }
    
        returnCode = hu_RegisterSbg56(_sbCtx);
        if (returnCode != SB_SUCCESS) {
            emit message("XXXX makeHash ERROR calling hu_RegisterSbg56:" + Utilities::intToHex(returnCode));
            return;
        } else {
            emit message("XXXX makeHash SUCCESS calling hu_RegisterSbg56");
        }
    
        returnCode = hu_InitSbg56(_sbCtx);
        if (returnCode != SB_SUCCESS) {
            emit message("XXXX makeHash ERROR calling hu_InitSbg56:" + Utilities::intToHex(returnCode));
            return;
        } else {
            emit message("XXXX makeHash SUCCESS calling hu_InitSbg56");
        }
    }
    
    //...
    
    void ApplicationUI::onMakeHash() {
    
        bool doHmac = true;
    
        QString input_data("1234567890");
        unsigned char messageDigest[SB_SHA256_DIGEST_LEN];
        unsigned char messageDigestHMAC[SB_HMAC_SHA256_256_TAG_LEN];
        unsigned char hmacKey[SB_HMAC_SHA256_256_TAG_LEN] = {0x1C, 0x85, 0xC9, 0xBB, 0x25, 0xBA, 0xFB, 0xE9,
                                                             0xFC, 0xE7, 0xB1, 0x3B, 0x9B, 0x53, 0x6F, 0x40,
                                                             0x79, 0x4F, 0x13, 0x3B, 0x60, 0x96, 0xF7, 0x44,
                                                             0x0B, 0x62, 0x39, 0xFB, 0xCA, 0x4A, 0xA3, 0xB6
                                                            };
    
        emit message("XXXX onMakeHash:" + input_data + " (" + QString::number(input_data.length()) + ")");
    
        /* Initialize variables */
    
        int returnCode = SB_SUCCESS; /* Return Code */
    
        QByteArray input_bytes = input_data.toUtf8();
        unsigned char* hash_input = reinterpret_cast(input_bytes.data());
    
        if (doHmac) {
            returnCode = hu_HMACSHA256Begin(SB_HMAC_SHA256_256_TAG_LEN, hmacKey, NULL, &_hmacContext, _sbCtx);
            if (returnCode != SB_SUCCESS) {
                emit message("XXXX makeHash ERROR initialising HMAC-SHA-256 context:" + Utilities::intToHex(returnCode));
                return;
            } else {
                emit message("XXXX makeHash SUCCESS initialising HMAC-SHA-256 context");
            }
    
            /* Hash Message */
    
            returnCode = hu_HMACSHA256Hash(_hmacContext, (size_t) input_bytes.length(), hash_input, _sbCtx);
            if (returnCode != SB_SUCCESS) {
                emit message("XXXX makeHash ERROR creating HMAC:" + Utilities::intToHex(returnCode));
                return;
            } else {
                emit message("XXXX makeHash SUCCESS creating HMAC");
            }
    
            /* Complete HMAC-SHA-256 Hashing */
    
            returnCode = hu_HMACSHA256End(&_hmacContext, SB_HMAC_SHA256_256_TAG_LEN, messageDigestHMAC, _sbCtx);
            if (returnCode != SB_SUCCESS) {
                emit message("XXXX makeHash ERROR completing HMAC:" + Utilities::intToHex(returnCode));
                return;
            } else {
                QString digest;
                for (int i = 0; i < SB_HMAC_SHA256_256_TAG_LEN; ++i) {
                    digest.append(QString("%1").arg(QString::number((uint)messageDigestHMAC[i], 16), 2, QChar('0')));
                }
                emit message("XXXX makeHash SUCCESS completing HMAC");
                emit message("XXXX HMAC = " + digest);
            }
        } else {
    //...
    }
    
    //...
    
    void ApplicationUI::onEndSecurity() {
        emit message("XXXX onEndSecurity");
        hu_GlobalCtxDestroy(&_sbCtx);
    }
    
  • compare 2 files for the same, but different

    I have 2 files TrueCrypt 7.1 Mac OS X.dmg and TrueCrypt 7.1 Mac OS X (2) the .dmg that compare with hash sha256 identical (04db58b737c05bb6b0b83f1cb37a29edec844b59ff223b9e213ee1f4e287f586) and compared with the help of the cmp command. The two compare properly.

    When I try to install 1 file I get the message "error truecrypt requires Mac OS X 10.4 or later", but the other recipes to install correctly. Why, if the files are the same?

    The problem was with the security and privacy settings. Because Truecrypt is not an application recognized by Apple, it concerned differently for one file on the other. I suspect because I had already tried to install the previous file.

  • Help ID for rtmfp streams based video app

    In the article:

    http://www.Adobe.com/devnet/flashplayer/articles/rtmfp_cirrus_app.html

    I need help understanding the following section:

    " Now create the receiver NetStream:

    private var recvStream:NetStream;

    recvStream = new NetStream (netConnection, id_of_publishing_client);

    recvStream.addEventListener (NetStatusEvent.NET_STATUS, netStreamHandler);

    recvStream.play ("media");

    At this point, you hear audio and you can create a video object to display the video. To create the receiver NetStream, you must know the peer ID of 256 bits of the Editor (id_of_publishing_client). In order to receive audio/video, you must know the name of the stream being published. »

    ***

    I do not understand what "client id_of_publishing" is supposed to be?

    Where can I find where how do they produce? Is this string that the user can enter in a text field on the flash object and when two chains corresponding produces a connection between the two?

    Is there a system of hash I have to pass the string in to generate a 256-bit of a string that is entered peer id or use the one that is given to me through workshops for adobe?

    Y at - it report any with the creation of a network group?

    I have the dev_key and address cirrus to access the cirrus service provided by adobe, Im just stuck on the part ID that I can't quite understand the article, need a database to store and manage the ID in a simple application?

    Im trying to develop a very basic program that uses the examples provided in the article, rtmfp but Im stuck here, I would appreciate anyones assistance. In addition, I looked at the example of cirrus phone that uses the cgi file to manage identifiers but I find it still more painful with so I have resorted to make a very basic example that avoid to create an ID database or use my own FMS.

    Thanks in advance for your help.

    the "id_of_publishing_client" is the ID of the peer of the editor.  a peer ID is a unique identifier of encryption that has each instance RTMFP. It's the NetConnection.nearID of an RTMFP NetConnection object. the idea is that you use a method (for example a web service database or copy - paste between two windows on your development computer) to transfer the peer ID of a Publisher (a peer with a NetStream in DIRECT_CONNECTIONS mode) to a Subscriber for use in the NetStream constructor.

    Peer ID of a Flash Player NetConnection is the hash SHA256 of the RTMFP certificate, which contains (among other things) a Diffie-Hellman public key.  the public/private key pair DH is made fresh every time that you make a new NetConnection RTMFP on number Pseudo-aleatoires source cryptographic of your computer (example: / dev/urandom on Linux/Unix/Mac computers), and these keys are used (with other data) to create the encryption keys & symmetric decryption for AES, which allows to encrypt all communications between counterparts RTMFP.  a client peer ID is impossible to forge * because you must have the private key that matches the public key to generate the same AES keys that are using your peers. without the private key, the communication will work. implementation of the discrete logarithm of a public key of 1024-bit DH to get the private key or to find a collision to SHA256 is both "quite difficult" to claim that peer IDs are impossible to forge.

  • BSOD - Locale ID: 1033 - BCCode: 4A - Win7 Ultimate 64-bit

    OS version: 6.1.7601.2.1.0.768.3
    Locale ID: 1033

    More information about the problem:
    BCCode: 4A
    BCP1: 0000000076FE132A
    BCP2: 0000000000000002
    BCP3: 0000000000000000
    BCP4: FFFFF88002B07C60
    OS version: 6_1_7601
    Service Pack: 1_0
    Product: 768_1

    Files helping to describe the problem:
    C:\Windows\Minidump\031714-49187-01.dmp
    C:\Users\User\AppData\Local\Temp\WER-12861986-0.SysData.XML

    Identification of file

    Name file 031714-49187 - 01.dmp
    256,00 KB file size
    Type of Windows 64 bit memory dump file
    MIME Type application/octet-stream
    D79aaa15cf6ad71e8743a4afd6064656 MD5 hash
    Hash SHA1 B271bc39e5aebd8aa545e82304c8b68b56d2505d
    Hash SHA256 A907f45fd970fa94dab365061b758c5fd84fe91e39924f6484a4302067136a2c

    DMP file to: https://my.pcloud.com/#page=publink&code=XZRudZWpuiRqa7c4VbkVhdmxmTSHMzz0uV

    Hello

    The attached file of the DMP is the verification of bug IRQL_GT_ZERO_AT_SYSTEM_SERVICE (4A) .

    This indicates that a thread returns to the user returned by a system call when its IRQL level is always above PASSIVE_LEVEL.

    BitDefender is known to cause this bug check (0x4A), please remove and replace BitDefender with Microsoft Security Essentials to temporary troubleshooting purposes, as it is likely to cause conflicts:

    Removal-BitDefender http://www.BitDefender.com/support/how-to-uninstall-BitDefender-333.html

    -MSE http://Windows.Microsoft.com/en-us/Windows/Security-Essentials-download 

    Kind regards

    Patrick

  • How does Card Crypto knows what ISAKMP policy to use?

     ip access-list extended ACL_SITE1_TO_SITE2 permit ip 10.0.12.0 0.0.0.255 10.0.22.0 0.0.0.255 ! crypto isakmp policy 10 encr aes hash sha256 authentication pre-share group 14 crypto isakmp policy 20 encr aes 256 hash sha512 authentication pre-share group 16 crypto isakmp key cisco123 address 200.0.2.2 ! crypto ipsec transform-set [TRANS_SET]PHASE_2 esp-aes esp-sha256-hmac mode tunnel ! crypto map [CRYPT_MAP]VPN_SITE1_TO_SITE2 11 ipsec-isakmp set peer 200.0.2.2 set transform-set [TRANS_SET]PHASE_2 match address ACL_SITE1_TO_SITE2 ! interface FastEthernet0/0 ip address 200.0.1.1 255.255.255.0 crypto map [CRYPT_MAP]VPN_SITE1_TO_SITE2

    How does Card Crypto knows what ISAKMP policy to use, or use of the ISAKMP policy at all?

    It comes from "ipsec-isakmp?

    I mean... I do not see any "set isakmp policy 10" in the Crypto map

    This is what he chooses just the top-down approach?

    As part of the negotiation of the phase 1 and is a top-down proposal based on the sequence number.  You can get the details in tunnel using configuration:

    Debug crypto ISAKMP

    Cisco IOS has built/strategies default ISAKMP, but the pre 15.x versions were terrible default.  New default values are strong, although I still like to configure them myself.

  • Traffic is failed on plain IPSec tunnel between two 892 s

    Have a weird case and you are looking for some suggestions/thougs where to dig because I have exhausted the options.

    Note: I replaced the Networkid real to a mentined below.

    Topology: a classic IPSec VPN tunnel between two 892 s of Cisco, with pre-shared key and no GRE. A 892 (branch_892) has access to the Internet using PPPoE and has three network / VLAN behind it. A VLAN is coordinated to the PPPoE internet access. Access to the other two VLAN - VL92 (100.100.200.0/24) and VL93 (100.100.100.0/24) is performed via the VPN tunnel.

    Second 892 (892_DC) has just one interface - WAN on Gigabit enabled/connected and a static route to the default GW. It doesn't have any defined interal network. If the router is strictly used to send traffic to VL92/VL93 to the domestic 892 via IPSec tunnel.

    Here's the problem: access to VL93 (100.100.100.0/24) works, however for VL92 (100.100.100.0/24) - does not work.

    Devices in VL92 I ping IP address of 892_DC through the VPN tunnel. The 892_DC router I can ping devices in VL92. However, I can't VL92 ping any device beyond the 892_DC and at the same time the packets arriving on 892_DC for VL92 are not sent through the VPN tunnel.

    I took the package trace on 892_DC using capture point/buffer to nathalie caron to VL92 packages and saw that the traffic coming to the 892_DC. I run the nathalie caron even on Branch_892, and there was not a single package.

    So... What's the problem? More interesting, I modified the way left on VL92 access list and still - no packets are sent through the tunnel.

    Any idea? Two routers config are below

    -------

    892_DC #show ru

    !

    crypto ISAKMP policy 10

    BA aes 256

    hash sha256

    preshared authentication

    Group 2

    isakmp encryption key * address 1.2.3.4

    ISAKMP crypto keepalive 10 periodicals

    !

    address of 1.2.3.4 crypto isakmp peers

    Description of-COIL-892

    !

    !

    Crypto ipsec transform-set IT-IPSec-Transform-Set esp - aes 256 sha256-esp-hmac

    Crypto ipsec df - bit clear

    !

    map IT ipsec - IPSec crypto - Crypto - map 10-isakmp

    defined peer 1.2.3.4

    disable the kilobytes of life together - the security association

    86400 seconds, life of security association set

    the transform-set IT-IPSec-Transform-Set value

    match a lists 101

    market arriere-route

    QoS before filing

    !

    interface GigabitEthernet0

    IP 10,20,30,40 255.255.255.240

    IP 1400 MTU

    IP tcp adjust-mss 1360

    automatic duplex

    automatic speed

    card crypto IT-IPSec-Crypto-map

    !

    IP route 0.0.0.0 0.0.0.0 10.20.30.41

    !

    access list 101 ip allow any 100.100.100.0 0.0.0.255 connect

    access list 101 ip allow any 100.100.200.0 0.0.0.255 connect

    -------------------------------------------------------------------------------------

    Branch_892 #sh run

    !

    crypto ISAKMP policy 10

    BA aes 256

    hash sha256

    preshared authentication

    Group 2

    isakmp encryption key * address 10,20,30,40

    ISAKMP crypto keepalive 10 periodicals

    !

    address peer isakmp crypto 10,20,30,40

    !

    !

    Crypto ipsec transform-set IT-IPSec-Transform-Set esp - aes 256 sha256-esp-hmac

    Crypto ipsec df - bit clear

    !

    map IT ipsec - IPSec crypto - Crypto - map 10-isakmp

    defined peer 10,20,30,40

    disable the kilobytes of life together - the security association

    86400 seconds, life of security association set

    the transform-set IT-IPSec-Transform-Set value

    match address 101

    market arriere-route

    QoS before filing

    !

    FastEthernet6 interface

    Description VL92

    switchport access vlan 92

    !

    interface FastEthernet7

    Description VL93

    switchport access vlan 93

    !

    interface GigabitEthernet0

    Description # to WAN #.

    no ip address

    automatic duplex

    automatic speed

    PPPoE-client dial-pool-number 1

    !

    interface Vlan1

    Description # local to #.

    IP 192.168.1.254 255.255.255.0

    IP nat inside

    IP virtual-reassembly in

    !

    interface Vlan92

    Description fa6-nexus e100/0/40

    IP 100.100.200.1 255.255.255.0

    !

    interface Vlan93

    Description fa7-nexus e100/0/38

    IP 100.100.100.1 255.255.255.0

    !

    interface Dialer0

    no ip address

    No cdp enable

    !

    interface Dialer1

    IP 1.2.3.4 255.255.255.248

    IP mtu 1454

    NAT outside IP

    IP virtual-reassembly in max-pumping 256

    encapsulation ppp

    IP tcp adjust-mss 1414

    Dialer pool 1

    Dialer-Group 1

    Authentication callin PPP chap Protocol

    PPP chap hostname ~ ~ ~

    PPP chap password =.

    No cdp enable

    card crypto IT-IPSec-Crypto-map

    !

    Dialer-list 1 ip protocol allow

    !

    access-list 101 permit ip 100.100.100.0 0.0.0.255 any

    access-list 101 permit ip 100.100.200.0 0.0.0.255 any

    !

    IP route 0.0.0.0 0.0.0.0 Dialer1

    Yes correct sounds - so another possible problem is the routing is routing 100% correct on both sides? Can you put the two sides config for review?

  • VM simple Load Balancing with 4 physical network adapters

    I have one main server with 4 cards of physical network dedicated to this server in a vSwitch. I wanted to know the proper way to balancing configuration in vSphere to allow a theoretical throughput of 4 Gbit/s. The options I have, as you know:

    1. Port according to ID - this the method by default when you have 2 or more physical NIC connected to a virtual switch. The VM traffic is realized on a physical NETWORK card based on the VMs virtual port ID and is incremented in the style of round robin. So if you have 2 NICs physical network, the first drop of will traffic VMs that the first NIC, the second VM shuts down to the second NIC, third comes out first NETWORK card and operating system on - host ESXi does not resemble the traffic so if VMs 1,3,5 are heavy network users they will go on the same NETWORK adapter even if the second NETWORK card can be totally unused
    2. Address based MAC - based similar to port, but the physical NETWORK adapter is selected according to the MAC address of virtual machines
    3. IP hash database - the physical NETWORK adapter is selected based on the starting and destination IP address - so if a virtual machine connect to several IP addresses that traffic will be disttibuted on all physical network cards - note this will require LACp be configured on the physical spend this ost ESXi connects to

    The first two sound me as they would give me what I want from the physical NIC selection is based on the virtual source, not the destination machine. So, since I have only a virtual computer, the LB would never use a physical NIC and I'd be stuck with 1 Gbps.

    The third option seems more promising, but I do not have much exposure to the management switch. LACP would be similar to the creation of a trunk on my 3Com switch 2848 reference? It seems likely, but I wanted to run it by the experts to make sure.

    Thank you!

    EDIT: I think I just found the killer. Cited in the manual for my switch:

    The switch does not support the aggregation of links
    Protocol LACP (Control), which is specified in the IEEE standard
    802.3ad.

    Does that mean I'm desperate to do my 4 Gbps with the swithc and I MUST get a LACP switch?

    You will need either LACP or EtherChannel on your switch upstream to support IP hash configuration, install, configure, manage Volume 1 book for ESXi 5.0. With hash IP, MAC address of the virtual computer may appear on any of the physical interfaces available for the vSwitch (at least for the outbound traffic), which would cause problems on the side of the physical switch unless a method of aggregation (LACP or EtherChannel) link type is enabled.

    Mike

  • confused about nearid, farid, nearNonce etc.

    I'm confused on different ID

    NearId equals farid on the other end

    What is nearNonce id

    I found an explanation of the high level architecture that beautifully explained how P2P works all in all.

    Are there more articles with a detailed explanation of how all pieces fit the puzzle together?

    Thanks for the help

    A book that guides me through various puzzle pieces would be a blessing. Is there any book of Cirrus over there?

    the event.info.neighbor is the address of 'group' of the neighbor.  event.info.peerID is the ID of the peer of the neighbor. You can convert ID equal to a group address, but not the reverse, as the group address is a hash SHA256 of the ID of peers (and other data).

  • Channel Port LACP with VMWare ESXi IP hash Message: % SW_MATM-4-MACFLAP_NOTIF: &lt; MAC &gt; host in the vlan 1 is flapping between port

    Hello

    Currently I have a VMWare ESXi host with 2 network including 6 cards (3 of each) ports are connected to a X 3750.  I configured LACP on the switch and the Port of vDS group road based on IP Hash (802.3ad), my looks of config as follows:-

    src-dst-ip port-channel load-balance

    Interface Port-channel15

    switchport trunk encapsulation dot1q

    switchport mode trunk

    !

    interface GigabitEthernet1/0/15

    switchport trunk encapsulation dot1q

    switchport mode trunk

    bandwidth share SRR-queue 10 70 25 5

    form of bandwidth SRR-queue 10 0 0 0

    priority queue

    MLS qos trust dscp

    spanning tree portfast

    channel-protocol lacp

    active in mode channel-group 15

    !

    interface GigabitEthernet1/0/16

    switchport trunk encapsulation dot1q

    switchport mode trunk

    bandwidth share SRR-queue 10 70 25 5

    form of bandwidth SRR-queue 10 0 0 0

    priority queue

    MLS qos trust dscp

    spanning tree portfast

    channel-protocol lacp

    active in mode channel-group 15

    !

    interface GigabitEthernet1/0/17

    switchport trunk encapsulation dot1q

    switchport mode trunk

    bandwidth share SRR-queue 10 70 25 5

    form of bandwidth SRR-queue 10 0 0 0

    priority queue

    MLS qos trust dscp

    spanning tree portfast

    channel-protocol lacp

    active in mode channel-group 15

    !

    interface GigabitEthernet1/0/18

    switchport trunk encapsulation dot1q

    switchport mode trunk

    bandwidth share SRR-queue 10 70 25 5

    form of bandwidth SRR-queue 10 0 0 0

    priority queue

    MLS qos trust dscp

    spanning tree portfast

    channel-protocol lacp

    active in mode channel-group 15

    !

    interface GigabitEthernet1/0/19

    switchport trunk encapsulation dot1q

    switchport mode trunk

    bandwidth share SRR-queue 10 70 25 5

    form of bandwidth SRR-queue 10 0 0 0

    priority queue

    MLS qos trust dscp

    spanning tree portfast

    channel-protocol lacp

    active in mode channel-group 15

    !

    interface GigabitEthernet1/0/20

    switchport trunk encapsulation dot1q

    switchport mode trunk

    bandwidth share SRR-queue 10 70 25 5

    form of bandwidth SRR-queue 10 0 0 0

    priority queue

    MLS qos trust dscp

    spanning tree portfast

    channel-protocol lacp

    active in mode channel-group 15

    Currently I see many MAC beat in the log of the switch.  From my understanding, I expect the MAC address out all ports, because that's what'd ESXi when you use 'route based on the hash of the IP.  I'm worried about the impact this might have on the CPU / switch.

    August 6, 09:42:05.700 TSB: % SW_MATM-4-MACFLAP_NOTIF: 0050.569e.0939 to host in the vlan 1 is flapping between port gi1/0/16 and article gi1/0/15

    August 6, 09:42:16.479 TSB: % SW_MATM-4-MACFLAP_NOTIF: 0050.569e.28e4 to host in the vlan 1 is flapping between port gi1/0/20 and 0/article gi1/17

    August 6, 09:42:18.719 TSB: % SW_MATM-4-MACFLAP_NOTIF: 0050.569e.7f6a to host in the vlan 1 is flapping between port gi1/0/19 and article gi1/0/20

    August 6, 09:42:20.766 TSB: % SW_MATM-4-MACFLAP_NOTIF: 0050.569e.0939 to host in the vlan 1 is flapping between port gi1/0/16 and article gi1/0/15

    Is it by design, if so can I disable the message?  If this isn't the case, please can you advise where I can check/change the configuration?

    Thank you

    Peter

    It is really gud who... .you mentioned your solution here.

    Can you please mark this question as answered, thatâ so it can help the other guys.

    Concerning

    Please rate if this can help.

  • SHA256 Encryption in Blackberry

    I'm looking for SHA encrypt a string value in the BB, but some of the classes BB shows some samples which returns the length of the hMAC

    That is to say,

    private static int sampleSHA256HMAC (byte [] hashKey, text of byte [], byte [] digestData)
    throws CryptoException, IOException
    {
    Create the hash key function key
    HMACKey key = new HMACKey (hashKey);

    Create an instance of a HMAC
    HMAC hMac is new HMAC (key, new SHA256Digest());.
            
    Now, create the output stream of MAC for easy use
    MACOutputStream macStream = new MACOutputStream (hMac, null);
                    
    Write the text to the stream
    macStream.write (plain text);
            
    Copy the summary in the array of bytes digestData data and
    Returns the length of
    hMac.getMAC (digestData, 0);
    Return hMac.getLength ();
    }

    Is it possible Sha encrypt a string to return a string value (hash value) of the string as string itself.

    Hello.

    If you consider what peter_strange said to not be an encriptación algorithm and you want to continue using it, try this method. It returns a string

    private String sign(String content) throws Exception {
      HMAC sha256 = new HMAC(new HMACKey(secretAccessKey.getBytes()),
        new SHA256Digest());
      sha256.update(content.getBytes());
      byte[] signed = new byte[sha256.getLength()];
      sha256.getMAC(signed, 0);
    
      String signedbase64 = Base64OutputStream.encodeAsString(signed, 0, signed.length, false, false);
    
      return signedbase64;
    }
    

    Well, it actually returns a URLUTF8 Encoder Base64 string version but you get the idea.

    The secretAccessKey object is a string needed to chop your content. I guess that you will place your own key here.

    In summary:

    -Create the HMAC object using your key.

    -Fill with your content.

    -Create a byte [] to place the hash.

    -Complete the table with the ground content.

    -Convert the bytes to a string (I used the base-64 but I guess you could just use String (byte [])) new

    I hope it helps.

    See you soon.

  • The incognito in 39 of Firefox for Mac does not work

    When I connect to Gmail with Firefox for the Mac sha256 39 - 7da80d615390fc65f0f5540ac2fbaa6e5d8e8e0b and close the tab, then immediately open gmail again it automatically logs me on my same Gmail account if I use private browsing.
    Private browsing is not suppose t maintain all information so how is able to access my Gmail account without my entered password?

    I don't know how the private browsing mode works on Mac because you can close all the tabs, but still operating application Firefox (the menu bar is here), so it is likely that you have not finished the session mode PB.
    You will need to close and restart Firefox to get rid of cookies that make the site remember you.
    Closing tabs does not seem to be enough.

  • My Mac Pro 2013 will sleep is no longer

    A month or there is my Mac Pro 2013 is no longer sleeps, even if I try to sleep it manually. I have enabled and changed the setting of Sleep/Power Nap in energy-saving.

    I looked at the article Apple and that did not help. I have reset the SMC and booted without failure. I haven't changed any connected equipment or internal. The console log does not help me, but here's the most recent when I sleep manually it. I have bolded the line that started the sleep/low power mode and the line where it was released

    20/05/16 2:00:42.429 PM CommCenter [435]: CSI telling to go to low power.

    20/05/16 2:00:42.429 PM AirPlayUIAgent [588]: 2016-05-20 02:00:42.428658 PM [AirPlayUIAgent] BecomingInactive: NSWorkspaceWillSleepNotification

    20/05/16 com.apple.cts [430 2:00:42.431 PM]: com.apple.suggestions.harvest: scheduler_evaluate_activity told me to run this job. However, but the start is no time for 33136 seconds.  Ignorant.

    20/05/16 com.apple.cts [430 2:00:42.431 PM]: com.apple.icloud.fmfd.heartbeat: scheduler_evaluate_activity told me to run this job. However, but the start is no time for 468717 seconds.  Ignorant.

    20/05/16 2:00:42.435 PM sharingd [469]: 14:00:42.435: scan BTLE turned off

    20/05/16 2:00:42.435 PM sharingd [469]: 14:00:42.435: scan BTLE turned off

    20/05/16 2:00:42.567 PM identityservicesd [442]: IMMacNotificationCenterManager: 0x7ff29b548b80 >: Observer of notification: notification com.apple.iChat: __CFNotification 0x7ff29d120e10 {name = _NSDoNotDisturbEnabledNotification}

    20/05/16 2:00:42.567 PM image [497]: IMMacNotificationCenterManager: 0x7ff2339135f0 >: Observer of notification: notification com.apple.FaceTime: __CFNotification 0x7ff2327077c0 {name = _NSDoNotDisturbEnabledNotification}

    20/05/16 2:00:42.588 PM identityservicesd [442]: IMMacNotificationCenterManager: 0x7ff29b548b80 >: NC disabled: NO

    20/05/16 2:00:42.588 PM image [497]: IMMacNotificationCenterManager: 0x7ff2339135f0 >: NC disabled: NO

    20/05/16 2:00:42.588 PM sharingd [469]: 14:00:42.588: purged hashes contact

    20/05/16 2:00:42.589 PM sharingd [469]: 14:00:42.588: discoverable mode changed to Off

    20/05/16 2:00:42.589 PM sharingd [469]: 14:00:42.588: Scan stopped BTLE

    20/05/16 2:00:42.598 PM WindowServer [180]: device_generate_desktop_screenshot: authw 0x7ff54a014c00 (2000), shield 0x7ff54d055c00 (2001)

    20/05/16 2:00:42.598 PM WindowServer [180]: device_generate_lock_screen_screenshot: authw 0x7ff54a014c00 (2000) [0, 0, 0, 0] shield 0x7ff54d055c00 (2001), dev [1920,1080]

    20/05/16 2:00:42.598 PM WindowServer [180]: no sleep for WillPowerOffWithImages image

    20/05/16 2:00:42.599 PM WindowServer [180]: device_generate_desktop_screenshot: authw 0x7ff54a014c00 (2000), shield 0x7ff54d055c00 (2001)

    20/05/16 2:00:42.599 PM WindowServer [180]: no sleep for WillPowerOffWithImages image

    20/05/16 2:00:42.602 PM image [497]: IMMacNotificationCenterManager: 0x7ff2339135f0 >: DND enabled: YES

    20/05/16 2:00:42.602 PM identityservicesd [442]: IMMacNotificationCenterManager: 0x7ff29b548b80 >: DND enabled: YES

    20/05/16 2:00:42.602 PM image [497]: IMMacNotificationCenterManager: 0x7ff2339135f0 >: update enabled: No. (subjects: ())

    ))

    20/05/16 2:00:42.602 PM identityservicesd [442]: IMMacNotificationCenterManager: 0x7ff29b548b80 >: update enabled: No. (subjects: ())

    ))

    20/05/16 2:00:48.000 PM kernel [0]: IOUSBHostHIDDevice@00223000,0 074948.944989: IOUSBHostHIDDevice::interruptRetry: resetting the device due to failures of IO

    20/05/16 2:00:48.000 PM kernel [0]: USB device 0BDA030700640000 - fConsecutiveResetCount = 1.

    20/05/16 2:00:48.000 PM kernel [0]: USB device 0BDA030700640000 - PortLogging (Disable) = kIOReturnNotReady.

    20/05/16 2:00:49.000 PM kernel [0]: en2: BSSID changed to 48:f8:b3: this: e7:3 c

    20/05/16 2:00:49.000 PM kernel [0]: en2: channel changed to 161,80

    20/05/16 2:00:49.000 PM kernel [0]: IO80211AWDLPeerManager::setAwdlOperatingMode setting the AWDL SUSPENDED auto operating mode

    20/05/16 2:00:49.000 PM kernel [0]: IO80211AWDLPeerManager::setAwdlSuspendedMode() suspension AWDL, enterQuietMode (true)

    20/05/16 2:00:49.000 PM kernel [0]: Airport: RSN full on en2 handshake

    20/05/16 2:00:49.000 PM kernel [0]: IO80211AWDLPeerManager::setAwdlOperatingMode setting the AWDL of SUSPENSION auto operating mode

    20/05/16 2:00:49.000 PM kernel [0]: IO80211AWDLPeerManager::setAwdlAutoMode AWDL recovery

    20/05/16 2:00:49.000 PM kernel [0]: ARPT: 74949.082534: wl0: roamed or channel switching, #0, bssid 48:f8:b3 reason: this: e7:3 c, last RSSI-65

    20/05/16 2:00:49.000 PM kernel [0]: en2: BSSID changed to 48:f8:b3: this: e7:3 c

    20/05/16 2:00:49.000 PM kernel [0]: en2: channel changed to 161,80

    20/05/16 2:00:49.000 PM kernel [0]: changed en2::IO80211Interface:postMessage bssid

    20/05/16 2:00:49.000 PM kernel [0]: AppleUSB20Hub@00220000 074949.251405: AppleUSBHub::deviceRequest: reset because of persistent errors

    20/05/16 2:00:49.221 PM Google Chrome [443]: [14:00:49.221] < < < < AVCaptureHALDevice > > > >-[AVCaptureHALDevice _removePropertyListeners]: removing an observer living device < AVCaptureHALDevice: 0x7fc08348d880 [Yeti Stereo Microphone] [AppleUSBAudioEngine:Blue Microphones: Yeti stereo Microphone: 210000:2, 1] > has failed (560947818)

    20/05/16 2:00:49.221 PM Google Chrome [443]: [14:00:49.221] < < < < AVCaptureHALDevice > > > >-[AVCaptureHALDevice _removePropertyListeners]: removing observer device format < AVCaptureHALDevice: 0x7fc08348d880 [Yeti Stereo Microphone] [AppleUSBAudioEngine:Blue Microphones: Yeti stereo Microphone: 210000:2, 1] > has failed (560947818)

    20/05/16 2:00:49.221 PM Google Chrome [443]: [14:00:49.221] < < < < AVCaptureHALDevice > > > >-[AVCaptureHALDevice _removePropertyListeners]: remove observer data source for device < AVCaptureHALDevice: 0x7fc08348d880 [Yeti Stereo Microphone] [AppleUSBAudioEngine:Blue Microphones: Yeti stereo Microphone: 210000:2, 1] > has failed (560947818)

    20/05/16 2:00:49.221 PM Google Chrome [443]: [14:00:49.221] < < < < AVCaptureHALDevice > > > >-[AVCaptureHALDevice _removePropertyListeners]: removal of observer source of the device data < AVCaptureHALDevice: 0x7fc08348d880 [Yeti Stereo Microphone] [AppleUSBAudioEngine:Blue Microphones: Yeti stereo Microphone: 210000:2, 1] > has failed (560947818)

    20/05/16 2:00:52.429 PM loginwindow [102]: CoreAnimation: attention, removed the wire with CATransaction uncommitted; Set CA_DEBUG_TRANSACTIONS = 1 in the environment connect backtrace.

    20/05/16 2:00:52.479 PM loginwindow [102]: CoreAnimation: attention, removed the wire with CATransaction uncommitted; Set CA_DEBUG_TRANSACTIONS = 1 in the environment connect backtrace.

    20/05/16 2:01:10.304 PM CommCenter [435]: CSI by saying to the low power output.

    20/05/16 2:01:10.308 PM loginwindow [102]: ERROR | -[LWBuiltInScreenLockAuthLion closeAuthAndReset:] | Attempted to remove an observer by observing

    Hello..

    Sorry to hear that your Mac Pro is upward...

    If you have not yet tried, Reset NVRAM on your Mac.

  • Mac Mini Late 2012 restarts randomly

    I use a Mac Mini Late 2012 (standard loadout MD387 except for an upgrade to 8 GB of RAM) as a small home server.

    It is essentially:

    Plex Server

    File server

    Print Server (AirPrint incl.)

    TM Server

    VPN server

    I would say that it is completely idle about 75% of the day.

    Every now and then it just restarts with the message: "your computer restarted because of a problem."

    This is the dump of the error:

    Anonymous UUID: 1B864DED-9FEC-7705-A672-CF239C87781C

    Thu May 19 17:29:40 2016

    Panic report *.

    panic (cpu 3 0xffffff802f11f544 appellant): "zalloc: map exhausted during the allocation of the kalloc.8192 area, probably because of the memory leak in the kalloc.64 area (2797558848 bytes, 43711800 elements allocated)"@/Library/Caches/com.apple.xbs/Sources/xnu/xnu-3248.40.184/osfmk/ker n / zalloc.c:2628).

    Backtrace (CPU 3), frame: return address

    0xffffff803afe3c50: 0xffffff802f0dab12

    0xffffff803afe3cd0: 0xffffff802f11f544

    0xffffff803afe3e00: 0xffffff802f0c1df7

    0xffffff803afe3e30: 0xffffff802f0df21e

    0xffffff803afe3e60: 0xffffff802f0c28b8

    0xffffff803afe3ea0: 0xffffff802f0d2665

    0xffffff803afe3f10: 0xffffff802f1b8bda

    0xffffff803afe3fb0: 0xffffff802f1eca96

    Name of the BSD corresponding to the current thread process: launchd

    Mac OS version:

    15E65

    Kernel version:

    15.4.0 Darwin kernel version: Fri Feb 26 22:08:05 PST 2016; root:XNU-3248.40.184~3/RELEASE_X86_64

    Kernel UUID: 4E7B4496-0B81-34E9-97AF-F316103B0839

    Slide kernel: 0x000000002ee00000

    Text of core base: 0xffffff802f000000

    Text __HIB base: 0xffffff802ef00000

    Name of system model: Macmini6, 1 (Mac-031AEE4D24BFF0B1)

    Availability of the system in nanoseconds: 270115669158850

    Area name heart size free size

    VM 31872960 1816080 objects

    machine virtual object hash 4224000 18080 entirely

    VM 3874640 405680 map entries

    PageTable anchors 1167360 0

    pv_list 24539136 11664

    VM 130328896 13376 pages

    Kalloc.32 1149120 161952

    3140928 65088 Kalloc.48

    Kalloc.64 2797558848 3648

    Kalloc.80 3100000 84320

    2580768 9984 Kalloc.96

    2781184 343424 Kalloc.128

    3485696 539904 Kalloc.256

    Kalloc.512 5853184 25088

    4292608 84992 Kalloc.1024

    Kalloc.2048 2240512 100352

    2752512 Kalloc.4096 0

    6258688 8192 Kalloc.8192

    mem_obj_control 1693440 11072

    SCHED groups 1581120 129600

    3288480 426240 of the IPC ports

    1666736 267472 discussions

    x 86 fpsave State 1073280 194688

    31705680 2640 nodes

    13814880 2112 namecache

    Node 43315680 1181456 HFS

    Fork 13512704 1357440 HFS

    cluster_write 4048600 84568

    buf.4096 4358144 0

    buf.8192 110182400 0

    ubc_info 9256104 979616 area

    vnode pager 3860000 97960 structur

    1671168 11264 compressor_segment

    The 3194880 kernel stacks

    PageTables 90726400

    Kalloc.Large 40423309

    Backtrace suspected leakage: (bytes pending: 14784)

    0xffffff802f11f97f

    0xffffff802f5a1bfe

    0xffffff7fafc80c6e

    0xffffff802f711bf8

    0xffffff802f627fa1

    Extensions of core in backtrace:

    com Apple.Security.Quarantine (3.0) [FEC5D575-4604-37D6-B550-83B7D17E3E76] @ ff7fafc7e000-0xffffff7fafc86fff > 0xffff

    dependency: com.apple.kext.AppleMatch (1.0.0d1) [F2211BA2-E656-3187-B06E-CF9D6A3A3B5A] @ ff7fafc5b000 0xffff

    dependency: com.apple.security.sandbox (300.0) [9CDE1775-6450-32D0-A275-5B27716AA896] @0xfffff f7fafc60000

    last load kext to 158900953437173: com.apple.nke.l2tp 1.9 (addr 0xffffff7fb1d44000 size 32768)

    Finally unloaded kext to 19831706194816: com.apple.driver.IOBluetoothHIDDriver 4.4.4f4 (addr 0xffffff7fb14a5000 size 73728)

    kexts responsible:

    com Apple.nke.L2TP 1.9

    com.apple.driver.AudioAUUC 1.70

    com.apple.driver.AGPM 110.21.18

    com.apple.driver.ApplePlatformEnabler 2.6.0d0

    com.apple.driver.X86PlatformShim 1.0.0

    com Apple.filesystems.autofs 3.0

    com.apple.driver.AppleOSXWatchdog 1

    com.apple.driver.AppleMikeyHIDDriver 124

    com.apple.driver.AppleHDA 274.7

    com.apple.driver.AppleUpstreamUserClient 3.6.1

    com.apple.driver.AppleMikeyDriver 274.7

    com.apple.driver.AppleMCCSControl 1.2.13

    com Apple.Driver.pmtelemetry 1

    com.apple.iokit.IOUserEthernet 1.0.1

    com.apple.iokit.IOBluetoothSerialManager 4.4.4f4

    com.apple.Dont_Steal_Mac_OS_X 7.0.0

    com.apple.driver.AppleThunderboltIP 3.0.8

    com.apple.driver.AppleLPC 3.1

    com.apple.iokit.BroadcomBluetoothHostControllerUSBTransport 4.4.4f4

    com.apple.driver.AppleIntelHD4000Graphics 10.1.4

    com.apple.driver.AppleHV 1

    com.apple.driver.AppleIntelSlowAdaptiveClocking 4.0.0

    com.apple.driver.AppleSMCPDRC 1.0.0

    com.apple.driver.AppleIntelFramebufferCapri 10.1.4

    com.apple.driver.AppleIRController 327,5

    com.apple.iokit.SCSITaskUserClient 3.7.7

    com.apple.driver.Oxford_Semi 3.7.1

    com.apple.AppleFSCompression.AppleFSCompressionTypeDataless 1.0.0d1

    com.apple.AppleFSCompression.AppleFSCompressionTypeZlib 1.0.0

    com.apple.BootCache 38

    2.8.5 com.apple.iokit.IOAHCIBlockStorage

    com.apple.driver.AppleSDXC 1.7.0

    com.apple.iokit.AppleBCM5701Ethernet 10.2.0

    com.apple.driver.AirPort.Brcm4360 1040.1.1a6

    com.apple.driver.AppleFWOHCI 5.5.2

    com.apple.driver.AppleAHCIPort 3.1.8

    com.apple.driver.usb.AppleUSBEHCIPCI 1.0.1

    com.apple.driver.AppleRTC 2.0

    com.apple.driver.AppleACPIButtons 4.0

    com.apple.driver.AppleHPET 1.8

    com.apple.driver.AppleSMBIOS 2.1

    com.apple.driver.AppleACPIEC 4.0

    com.apple.driver.AppleAPIC 1.7

    com.apple.driver.AppleIntelCPUPowerManagementClient 218.0.0

    com Apple.NKE.applicationfirewall 163

    com Apple.Security.Quarantine 3

    com.apple.security.TMSafetyNet 8

    com.apple.driver.AppleIntelCPUPowerManagement 218.0.0

    com Apple.nke.PPP 1.9

    com Apple.kext.Triggers 1.0

    com.apple.driver.DspFuncLib 274.7

    com.apple.kext.OSvKernDSPLib 525

    com.apple.iokit.IOSerialFamily 11

    com.apple.driver.AppleSMBusController 1.0.14d1

    com.apple.iokit.IOFireWireIP 2.2.6

    com.apple.driver.CoreCaptureResponder 1

    com.apple.driver.X86PlatformPlugin 1.0.0

    com.apple.iokit.IOBluetoothHostControllerUSBTransport 4.4.4f4

    com.apple.iokit.IOBluetoothFamily 4.4.4f4

    com.apple.iokit.IOSurface 108.2.1

    com.apple.driver.AppleHDAController 274.7

    com.apple.iokit.IOHDAFamily 274.7

    com.apple.iokit.IOAudioFamily 204.3

    com.apple.vecLib.kext 1.2.0

    com.apple.driver.AppleSMBusPCI 1.0.14d1

    com.apple.driver.AppleSMC 3.1.9

    com.apple.iokit.IOSlowAdaptiveClockingFamily 1.0.0

    com.apple.driver.IOPlatformPluginFamily 6.0.0d7

    com.apple.iokit.IONDRVSupport 2.4.1

    com.apple.iokit.IOAcceleratorFamily2 205.3

    com.apple.AppleGraphicsDeviceControl 3.12.6

    com.apple.iokit.IOGraphicsFamily 2.4.1

    com.apple.iokit.IOUSBHIDDriver 900.4.1

    com.apple.iokit.IOUSBMassStorageDriver 1.0.0

    com Apple.Driver.USB.cdc 5.0.0

    com.Apple.Driver.USB.Networking 5.0.0

    com.apple.driver.usb.AppleUSBHostCompositeDevice 1.0.1

    com.apple.iokit.IOSCSIBlockCommandsDevice 3.7.7

    com.apple.driver.usb.AppleUSBHub 1.0.1

    com.apple.iokit.IOFireWireSerialBusProtocolTransport 2.5.1

    com.apple.iokit.IOSCSIArchitectureModelFamily 3.7.7

    com.apple.iokit.IOFireWireSBP2 4.2.7

    com.apple.driver.AppleThunderboltDPInAdapter 4.1.3

    com.apple.driver.AppleThunderboltDPAdapterFamily 4.1.3

    com.apple.driver.AppleThunderboltPCIDownAdapter 2.0.2

    com.apple.driver.AppleThunderboltNHI 4.0.4

    com.apple.iokit.IOThunderboltFamily 6.0.2

    com.apple.iokit.IOEthernetAVBController 1.0.3b3

    com.apple.iokit.IO80211Family 1110.26

    com.apple.driver.mDNSOffloadUserClient 1.0.1b8

    com.apple.iokit.IONetworkingFamily 3.2

    com Apple.Driver.corecapture 1.0.4

    com.apple.iokit.IOFireWireFamily 4.6.0

    com.apple.driver.usb.AppleUSBXHCIPCI 1.0.1

    com.apple.driver.usb.AppleUSBXHCI 1.0.1

    com.apple.iokit.IOAHCIFamily 2.8.1

    com.apple.driver.usb.AppleUSBEHCI 1.0.1

    com.apple.iokit.IOUSBFamily 900.4.1

    com.apple.iokit.IOUSBHostFamily 1.0.1

    com.apple.driver.AppleUSBHostMergeProperties 1.0.1

    com.apple.driver.AppleEFINVRAM 2.0

    com.apple.driver.AppleEFIRuntime 2.0

    com.apple.iokit.IOHIDFamily 2.0.0

    com.apple.iokit.IOSMBusFamily 1.1

    com Apple.Security.sandbox 300.0

    com.apple.kext.AppleMatch 1.0.0d1

    com.apple.driver.AppleKeyStore 2

    com.apple.driver.AppleMobileFileIntegrity 1.0.5

    com.apple.driver.AppleCredentialManager 1.0

    com.apple.driver.DiskImages 417.2

    com.apple.iokit.IOStorageFamily 2.1

    com.apple.iokit.IOReportFamily 31

    com.apple.driver.AppleFDEKeyStore 28.30

    com.apple.driver.AppleACPIPlatform 4.0

    com.apple.iokit.IOPCIFamily 2.9

    com.apple.iokit.IOACPIFamily 1.4

    com.apple.kec.Libm 1

    com Apple.KEC.pthread 1

    com Apple.KEC.corecrypto 1.0

    Model: Macmini6, 1, MM61.0106.B0A of BootROM, 2 processors, Intel Core i5 2.5 GHz, 8 GB, MSC 2.7f1

    Graphics card: Intel Graphics HD 4000, 4000, Intel HD graphics card integrated

    Memory module: DIMM0/0 BANK, 4 GB DDR3, 1600 MHz, 0 x 0198, 0x393930353432382D3038352E4130304C4620

    Memory module: DIMM0/1 BANK, 4 GB DDR3, 1600 MHz, 0 x 0198, 0x393930353432382D3038352E4130304C4620

    Airport: spairport_wireless_card_type_airport_extreme (0x14E4, 0x10E), Broadcom BCM43xx 1.0 (7.21.95.175.1a6)

    Bluetooth: Version 4.4.4f4 17685, 3 services, 27 aircraft, 1 incoming serial ports

    Service network: Ethernet, Ethernet, en0

    Serial ATA Device: APPLE HARD HTS545050A7E362, 500,11 GB disk

    USB device: USB 2.0 Bus

    USB device: Hub

    USB device: Hub

    USB Device: IR receiver

    USB device: Hub BRCM20702

    USB Device: USB Bluetooth host controller

    USB device: USB 2.0 Hub [MTT]

    USB device: 5744 FW:1.1597

    USB device: 5744 FW:1.1597

    USB device: 5744 FW:1.1597

    USB device: 5744 FW:1.1597

    USB device: 5744 FW:1.1597

    USB device: USB 2.0 Bus

    USB device: Hub

    USB device: USB 3.0 Bus

    FireWire devices: my book, WD, up to 800 Mb/s

    Bus crush: Mac mini, Apple Inc., 23.4

    Important info:

    I have 8 connected external drives (USB 2.0 and USB 3.0 and FW 800)

    There is no screen, the mouse or the connected KB I only access it via the remote control.

    The most recent version of Mac OS X is installed. Thank you very much for your advice!

    Do you have what specific memory installed?

    If you have the original memory try reinstalling that and see if the problem persists.

  • Mini Mac end of 2012 restarts unexpectedly

    Hello

    Unfortunately it here some time I am faced with random restarts my computer. Fixing the kernel panic report below. I've seen similar post here but who but can if I do to have apparently all 3rd party kexts, or devices, in addition to monitors. Any help will be greatly appreciated.

    Anonymous UUID: D88EF38C-6175-B157-0699-C5730EEDA0FD

    Thu May 19 23:46:29 2016

    Panic report *.

    panic (cpu 4 0xffffff802fd1f5a4 appellant): "zalloc: map of exhausted area during the allocation of the kalloc.8192 area, probably because of the memory leak in the area kalloc.8192 (4633780224 bytes, 565647 elements allocated)"@/Library/Caches/com.apple.xbs/Sources/xnu/xnu-3248.50.21/osfmk/kern /zalloc.c:2628.

    Backtrace (4 CPU), Frame: Return address

    0xffffff820e0fb8a0: 0xffffff802fcdab12

    0xffffff820e0fb920: 0xffffff802fd1f5a4

    0xffffff820e0fba50: 0xffffff8030239a3b

    0xffffff820e0fba70: 0xffffff7fb241189b

    0xffffff820e0fba90: 0xffffff7fb23953fc

    0xffffff820e0fbac0: 0xffffff7fb2380f95

    0xffffff820e0fbb40: 0xffffff7fb238624c

    0xffffff820e0fbba0: 0xffffff7fb238728c

    0xffffff820e0fbbe0: 0xffffff80302dfa07

    0xffffff820e0fbd20: 0xffffff802fd97eb0

    0xffffff820e0fbe30: 0xffffff802fcdf283

    0xffffff820e0fbe60: 0xffffff802fcc28b8

    0xffffff820e0fbea0: 0xffffff802fcd2665

    0xffffff820e0fbf10: 0xffffff802fdb8dca

    0xffffff820e0fbfb0: 0xffffff802fdecc86

    Extensions of core in backtrace:

    com.apple.iokit.IOAcceleratorFamily2 (205.10) [949D9C27-0635-3EE4-B836-373871BC62 47]@0xffffff7fb2371000-> 0xffffff7fb23dcfff]

    dependency: com.apple.iokit.IOPCIFamily (2.9) [D8216D61-5209-3B0C-866D-7D8B3C5F33FF] @ 7fb052c000 0xffffff

    dependency: com.apple.iokit.IOGraphicsFamily (2.4.1) [172C2960-EDF5-382D-80A5-C13E97D74880] @0 xffffff7fb1069000

    com.apple.driver.AppleIntelHD4000Graphics (10.1.4) [89FAD7AF-CC24-33DE-B6E0 - 46C 90 EE44129]@0xffffff7fb23eb000-> 0xffffff7fb2453fff]

    dependency: com.apple.iokit.IOSurface (108.2.1) [B5ADE17A-36A5-3231-B066-7242441F7638] @ ff7fb0ed2000 0xffff

    dependency: com.apple.iokit.IOPCIFamily (2.9) [D8216D61-5209-3B0C-866D-7D8B3C5F33FF] @ 7fb052c000 0xffffff

    dependency: com.apple.iokit.IOGraphicsFamily (2.4.1) [172C2960-EDF5-382D-80A5-C13E97D74880] @0 xffffff7fb1069000

    dependency: com.apple.iokit.IOAcceleratorFamily2 (205.10) [949D9C27-0635-3EE4-B836-373871BC62 47]@0xffffff7fb2371000

    Corresponding to the current thread BSD process name: Xcode

    Mac OS version:

    15F34

    Kernel version:

    15.5.0 Darwin kernel version: kills Apr 19 18:36:36 PDT 2016; root:XNU-3248.50.21~8/RELEASE_X86_64

    Kernel UUID: 7E7B0822-D2DE-3B39-A7A5-77B40A668BC6

    Slide kernel: 0x000000002fa00000

    Text of core base: 0xffffff802fc00000

    Text __HIB base: 0xffffff802fb00000

    Name of system model: Macmini6, 2 (Mac-F65AE981FFA204ED)

    Availability of the system in nanoseconds: 42893988669289

    Area name heart size free size

    objects of VM 198830640 720

    machine virtual object hash 29696000 248640 made

    VM 54579200 331760 map entries

    PageTable anchors 1425408 0

    pv_list 43425792-7056

    VM 262380096 57216 pages

    Kalloc.16 36888768 3264

    2201472 322368 Kalloc.32

    88494336 2016 Kalloc.48

    Kalloc.64 81986688 0

    2316000 149600 Kalloc.80

    2913120 175392 Kalloc.96

    294268928 3584 Kalloc.128

    6990720 989600 Kalloc.160

    440815616 2816 Kalloc.256

    Kalloc.288 8853984 153216

    37314560 3646976 Kalloc.512

    7139328 1135616 Kalloc.1024

    Kalloc.2048 4689920 352256

    Kalloc.4096 10620928 0

    Kalloc.8192 4633780224 0

    mem_obj_control 11878272 99328

    SCHED groups 1959552 181440

    95022880 7200 IPC ports

    2402576 684448 discussions

    x 86 fpsave State 1636544 533312

    1439920 474288 uthreads

    63162480 2160 nodes

    25695840 1536 namecache

    Node 86326320 508728 HFS

    Fork 26468352 1336320 HFS

    cluster_write 1178496 13640

    buf.4096 2826240 0

    buf.8192 19988480 0

    ubc_info 18086640 910712 area

    Knote 117360 1121904 area

    vnode pager 7812000 4760 structur

    35016704 395968 compressor_pager

    16855040 857088 compressor_segment

    The 3522560 kernel stacks

    PageTables 225550336

    Kalloc.Large 59094166

    Backtrace suspected leakage: (bytes in circulation: 2007040)

    0xffffff802fd1f9df

    0xffffff8030239a3b

    0xffffff7fb241189b

    0xffffff7fb23953fc

    0xffffff7fb2380f95

    0xffffff7fb238624c

    0xffffff7fb238728c

    0xffffff80302dfa07

    0xffffff802fd97eb0

    0xffffff802fcdf283

    0xffffff802fcc28b8

    0xffffff802fcd2665

    0xffffff802fdb8dca

    Extensions of core in backtrace:

    com.apple.iokit.IOAcceleratorFamily2 (205.10) [949D9C27-0635-3EE4-B836-373871BC62 47]@0xffffff7fb2371000-> 0xffffff7fb23dcfff]

    dependency: com.apple.iokit.IOPCIFamily (2.9) [D8216D61-5209-3B0C-866D-7D8B3C5F33FF] @ 7fb052c000 0xffffff

    dependency: com.apple.iokit.IOGraphicsFamily (2.4.1) [172C2960-EDF5-382D-80A5-C13E97D74880] @0 xffffff7fb1069000

    com.apple.driver.AppleIntelHD4000Graphics (10.1.4) [89FAD7AF-CC24-33DE-B6E0 - 46C 90 EE44129]@0xffffff7fb23eb000-> 0xffffff7fb2453fff]

    dependency: com.apple.iokit.IOSurface (108.2.1) [B5ADE17A-36A5-3231-B066-7242441F7638] @ ff7fb0ed2000 0xffff

    dependency: com.apple.iokit.IOPCIFamily (2.9) [D8216D61-5209-3B0C-866D-7D8B3C5F33FF] @ 7fb052c000 0xffffff

    dependency: com.apple.iokit.IOGraphicsFamily (2.4.1) [172C2960-EDF5-382D-80A5-C13E97D74880] @0 xffffff7fb1069000

    dependency: com.apple.iokit.IOAcceleratorFamily2 (205.10) [949D9C27-0635-3EE4-B836-373871BC62 47]@0xffffff7fb2371000

    last load kext to 244831376997: com.apple.filesystems.msdosfs 1.10 (addr 0xffffff7fb2933000 size 69632)

    Finally unloaded kext to 739253060551: com.apple.filesystems.msdosfs 1.10 (addr 0xffffff7fb2933000 size 61440)

    kexts responsible:

    com.apple.driver.AudioAUUC 1.70

    com.apple.driver.AppleBluetoothMultitouch 90.3

    com.apple.driver.AGPM 110.22.0

    com.apple.driver.ApplePlatformEnabler 2.6.0d0

    com.apple.driver.X86PlatformShim 1.0.0

    com Apple.filesystems.autofs 3.0

    com.apple.driver.AppleOSXWatchdog 1

    com.apple.driver.AppleMikeyHIDDriver 124

    com.apple.driver.AppleHDA 274,9

    com.apple.driver.AppleUpstreamUserClient 3.6.1

    com.apple.driver.AppleMCCSControl 1.2.13

    com.apple.driver.AppleMikeyDriver 274,9

    com Apple.Driver.pmtelemetry 1

    com.apple.iokit.IOUserEthernet 1.0.1

    com.apple.iokit.IOBluetoothSerialManager 4.4.5f3

    com.apple.Dont_Steal_Mac_OS_X 7.0.0

    com.apple.driver.AppleIntelHD4000Graphics 10.1.4

    com.apple.driver.AppleHV 1

    com.apple.iokit.BroadcomBluetoothHostControllerUSBTransport 4.4.5f3

    com.apple.driver.AppleSMCPDRC 1.0.0

    com.apple.driver.AppleThunderboltIP 3.0.8

    com.apple.driver.AppleLPC 3.1

    com.apple.driver.AppleIntelFramebufferCapri 10.1.4

    com.apple.driver.AppleIntelSlowAdaptiveClocking 4.0.0

    com.apple.driver.AppleIRController 327,6

    com.apple.AppleFSCompression.AppleFSCompressionTypeDataless 1.0.0d1

    com.apple.AppleFSCompression.AppleFSCompressionTypeZlib 1.0.0

    com.apple.BootCache 38

    2.8.5 com.apple.iokit.IOAHCIBlockStorage

    com.apple.driver.AppleSDXC 1.7.0

    com.apple.iokit.AppleBCM5701Ethernet 10.2.0

    com.apple.driver.AirPort.Brcm4360 1040.1.1a6

    com.apple.driver.AppleFWOHCI 5.5.4

    com.apple.driver.AppleAHCIPort 3.1.8

    com.apple.driver.usb.AppleUSBEHCIPCI 1.0.1

    com.apple.driver.AppleACPIButtons 4.0

    com.apple.driver.AppleRTC 2.0

    com.apple.driver.AppleHPET 1.8

    com.apple.driver.AppleSMBIOS 2.1

    com.apple.driver.AppleACPIEC 4.0

    com.apple.driver.AppleAPIC 1.7

    com.apple.driver.AppleIntelCPUPowerManagementClient 218.0.0

    com Apple.NKE.applicationfirewall 163

    com Apple.Security.Quarantine 3

    com.apple.security.TMSafetyNet 8

    com.apple.driver.AppleIntelCPUPowerManagement 218.0.0

    com.apple.driver.AppleBluetoothHIDKeyboard 181

    com.apple.driver.AppleHIDKeyboard 181

    com.apple.driver.IOBluetoothHIDDriver 4.4.5f3

    com.apple.driver.AppleMultitouchDriver 304.12

    com.apple.driver.AppleHIDTransport 5

    com Apple.kext.Triggers 1.0

    com.apple.driver.DspFuncLib 274,9

    com.apple.kext.OSvKernDSPLib 525

    com.apple.iokit.IOSerialFamily 11

    com.apple.iokit.IOSurface 108.2.1

    com.apple.driver.CoreCaptureResponder 1

    com.apple.driver.AppleSMBusController 1.0.14d1

    com.apple.iokit.IOFireWireIP 2.2.6

    com.apple.iokit.IOBluetoothHostControllerUSBTransport 4.4.5f3

    com.apple.iokit.IOBluetoothFamily 4.4.5f3

    com.apple.driver.AppleHDAController 274,9

    com.apple.iokit.IOHDAFamily 274,9

    com.apple.iokit.IOAudioFamily 204.4

    com.apple.vecLib.kext 1.2.0

    com.apple.driver.AppleSMBusPCI 1.0.14d1

    com.apple.driver.X86PlatformPlugin 1.0.0

    com.apple.driver.IOPlatformPluginFamily 6.0.0d7

    com.apple.iokit.IOAcceleratorFamily2 205,10

    3.12.8 com.apple.AppleGraphicsDeviceControl

    com.apple.driver.AppleSMC 3.1.9

    com.apple.iokit.IONDRVSupport 2.4.1

    com.apple.iokit.IOGraphicsFamily 2.4.1

    com.apple.iokit.IOSlowAdaptiveClockingFamily 1.0.0

    com.apple.iokit.IOSCSIArchitectureModelFamily 3.7.7

    com.apple.iokit.IOUSBHIDDriver 900.4.1

    com Apple.Driver.USB.cdc 5.0.0

    com.Apple.Driver.USB.Networking 5.0.0

    com.apple.driver.usb.AppleUSBHostCompositeDevice 1.0.1

    com.apple.driver.usb.AppleUSBHub 1.0.1

    com.apple.driver.AppleThunderboltDPInAdapter 4.1.3

    com.apple.driver.AppleThunderboltDPAdapterFamily 4.1.3

    com.apple.driver.AppleThunderboltPCIDownAdapter 2.0.2

    com.apple.driver.AppleThunderboltNHI 4.0.4

    com.apple.iokit.IOThunderboltFamily 6.0.2

    com.apple.iokit.IOEthernetAVBController 1.0.3b3

    com.apple.iokit.IO80211Family 1110.26

    com.apple.driver.mDNSOffloadUserClient 1.0.1b8

    com.apple.iokit.IONetworkingFamily 3.2

    com Apple.Driver.corecapture 1.0.4

    4.6.1 com.apple.iokit.IOFireWireFamily

    com.apple.iokit.IOAHCIFamily 2.8.1

    com.apple.driver.usb.AppleUSBEHCI 1.0.1

    com.apple.driver.usb.AppleUSBXHCIPCI 1.0.1

    com.apple.driver.usb.AppleUSBXHCI 1.0.1

    com.apple.iokit.IOUSBFamily 900.4.1

    com.apple.iokit.IOUSBHostFamily 1.0.1

    com.apple.driver.AppleUSBHostMergeProperties 1.0.1

    com.apple.driver.AppleEFINVRAM 2.0

    com.apple.driver.AppleEFIRuntime 2.0

    com.apple.iokit.IOHIDFamily 2.0.0

    com.apple.iokit.IOSMBusFamily 1.1

    com Apple.Security.sandbox 300.0

    com.apple.kext.AppleMatch 1.0.0d1

    com.apple.driver.AppleKeyStore 2

    com.apple.driver.AppleMobileFileIntegrity 1.0.5

    com.apple.driver.AppleCredentialManager 1.0

    com.apple.driver.DiskImages 417,4

    com.apple.iokit.IOStorageFamily 2.1

    com.apple.iokit.IOReportFamily 31

    com.apple.driver.AppleFDEKeyStore 28.30

    com.apple.driver.AppleACPIPlatform 4.0

    com.apple.iokit.IOPCIFamily 2.9

    com.apple.iokit.IOACPIFamily 1.4

    com.apple.kec.Libm 1

    com Apple.KEC.pthread 1

    com Apple.KEC.corecrypto 1.0

    Model: Macmini6 2, MM61.0106.B0A of BootROM, 4 processors, Intel Core i7, 2, 3 GHz, 16 GB, MSC 2.8f1

    Graphics card: Intel Graphics HD 4000, 4000, Intel HD graphics card integrated

    Memory module: BANK 0/DIMM0, 8 GB, DDR3, 1600 MHz, 0x859B, 0x43543130323436344246313630422E543136

    Memory module: BANK 1/DIMM0, 8 GB, DDR3, 1600 MHz, 0x859B, 0x43543130323436344246313630422E543136

    Airport: spairport_wireless_card_type_airport_extreme (0x14E4, 0x10E), Broadcom BCM43xx 1.0 (7.21.95.175.1a6)

    Bluetooth: Version 4.4.5f3 17904, 3 services, 27 aircraft, 1 incoming serial ports

    Service network: Ethernet, Ethernet, en0

    Serial ATA Device: Samsung SSD 840 EVO 250GB 250,06 GB

    USB device: USB 2.0 Bus

    USB device: Hub

    USB device: USB 2.0 Bus

    USB device: Hub

    USB device: Hub

    USB Device: IR receiver

    USB device: Hub BRCM20702

    USB Device: USB Bluetooth host controller

    USB device: USB 3.0 Bus

    Bus crush: Mac mini, Apple Inc., 23.4

    Take a look at this article, it can help you

    OS x: when your computer spontaneously restarts or displays "your computer restarted because of a problem." - Apple supp...

Maybe you are looking for

  • Satego x 200-BIOS does not detect SSD but windows 7 for OS usage

    need help here, I got the latest bios 2.50 and my bios does not detect the SSD but an I start windows 7 from my hard drive it is detected and I want to use the ssd as boot drive, please help

  • Slow Satellite Pro A300-1NT

    OK Then my ordered device an A300-1nt and a Dell e4300 for two members of our staff who arrived yesterday. Our IT Department managed the purchase and he restored to XP for us and all of our institutional and all software on board. The a300 is really,

  • Laptop HP Envy M7-109DX: updates

    This is probably a silly question, but if I put the computer to sleep or set the display turns off after so all will be minutes I get my Norton Security, Windows, or HP updates during this period?

  • I need free space in my Mac Air looking at 'about my Mac"it looks like I have 40 GB as backup, but I can't find it with the ODS

    I need free space in my Mac Air I used "about my Mac' and TI - s telling me I have 40 GB as backup, but I can't find with ODS (OmniDiskSweeper) ODS tells me I have just 30-40 GB busy. I can find a way to release the backup file? I m also helps TimeCa

  • IMPOSSIBLE to uninstall quick time

    When I try to uninstall "quick time" using the Control Panel, add or remove an it comes up with "a network error occurred trying to read the file C:\windows\installer\quicktime.msi."  and when I approved it I get 'Add / Remove Programs "fatal error d