HTTP timeout

Hi all

I'm trying to set the timeout on my http connection; This code works fine on the Simulator, but survey java.io.IOException: invalid url parameter.

on the real device (storm). Any ideas would be greatly appreciated! and yes I look the http missions... Here is my code-

StreamConnection streamConn;
If {(_longTimeouts)
streamConn = (StreamConnection) Connector.open
(urlstring + ";" ConnectionTimeout = 60000; deviceside = false');
} else {}
streamConn = (StreamConnection) Connector.open
(urlstring + ";" ConnectionTimeout = 10000; deviceside = false');
}
HttpConnection hc = (HttpConnection) streamConn;

Thank you

UDI

Hi Doug,.

On the money! rather than delete, I had to change the deviceside = true, works like magic

Thank you!

UDI

Tags: BlackBerry Developers

Similar Questions

  • Uniform HTTP Timeout setting?

    Hi all
    I used HttpConnection for a few years and now I have a need to set the timeout for HTTP connections within 2 minutes. I searched in this forum and elsewhere and learned that I should use either ConnectionFactory, who has the ability to set a timeout, or can I use HttpConnection and the timer and interrupt the flow of HTTP.

    BUT - as far as I know, these two methods have varying results. HttpConnection/Timer methods and the ConnectionFactory seem to work differently in the OS 5, 6 and 7 appear to better work in simulators than devices physical (I tested on OS5 and OS7.1 BlackBerry).

    My best results occur when I use ConnectionFactory and has my timeout value, setTimeLimit(), and setConnectionTimeout(), and then I add a Timer to the same timeout value. The code checks the sufficient connectivity using getCoverageStatus() just before trying to open the HTTP connection. It seems to work well on OS5, 6 and 7 sims and on live devices for OS5 and OS7.1.

    I'm still having a problem. There are moments where nothing stops the connection before HTTP mark two minutes. This happens when I simulate bad reception, just as the connection starts. I simulate the threshold of reception by starting the connection and then placing the BlackBerry in one box to cut the front desk. Most of the time, the works of timeout. My timeout is set to 16 seconds. On a live device 5.0, the timeout takes more than 30 seconds (not what I want, but it says my code is to have an effect).

    But if I open the box for 30 seconds and check every 15 seconds with a quick glance, I had the timeout of 2 minutes and 40 seconds - much longer than the time limit of 2 minutes by default. I connect where it happens and the 02:40 delay occurs inside this section of code:

    ConnectionFactory myConFactory = new ConnectionFactory();
    myConFactory.setTimeLimit (myFactoryTimeout);
    myConFactory.setConnectionTimeout (myFactoryTimeout);
    ConnectionDescriptor myConDesc = myConFactory.getConnection (pURL);

    Ignorant if I emphasize connectivity incorrectly performing this test at all, my questions for the experts of the forum are:
    I'm doing something wrong, and is there anything else I can do to get a specific time frame in all cases?
    Is there an explanation for this failure of timeout?

    The code follows. I've slightly simplified. Thank you!

    Request code:

    public static String HttpGetResponseString (String pURL, int pConnectionTimeoutSeconds)
    throws IOException {UnanticipatedHttpResponseException}
    String myReturn = "";
    HttpConnection myConn = null;
    InputStream myInput = null;
    Timer connectionTimerConnect = null;
    long myConnectionTimeoutSeconds = pConnectionTimeoutSeconds * 1000;
    long myFactoryTimeout = myConnectionTimeoutSeconds;
        
    try {}
    If the internet is not available.
    If (! getIsCoverageSufficient())
    throw new UnanticipatedHttpResponseException ("no cover available");

    HttpTimerTask timerTaskConnect = new HttpTimerTask (null);
    connectionTimerConnect = new Timer();
    connectionTimerConnect.schedule (timerTaskConnect, myConnectionTimeoutSeconds); Kill demand after x seconds
            
    If (Constants.DEBUG_MODE)
    Prefs.getInstance () .writeErrorLog ("Start Timer:" + myConnectionTimeoutSeconds + "ms");

    Connection request
    ConnectionFactory myConFactory = new ConnectionFactory();
    myConFactory.setTimeLimit (myFactoryTimeout);
    myConFactory.setConnectionTimeout (myFactoryTimeout);
    ConnectionDescriptor myConDesc = myConFactory.getConnection (pURL);
    If (myConDesc is nothing)
    throw new Exception ("factory connections do not return a descriptor");

    If (timerTaskConnect.hasInterrupted ())
    throw new UnanticipatedHttpResponseException("Interrupted-Open");
            
    myConn = (HttpConnection) myConDesc.getConnection ();
            
    final int responseCode = myConn.getResponseCode ();
            
    If (timerTaskConnect.hasInterrupted ())
    throw new UnanticipatedHttpResponseException ("Interrupted-response code');

    If (responseCode! = HttpConnection.HTTP_OK) {}
    throw new UnanticipatedHttpResponseException ("Invalid ResponseCode:" + Integer.toString (responseCode));
    } else {}
    myInput = myConn.openInputStream ();
    ResponseData = new ubyte [] byte [10000];
    int length = 0;
    StringBuffer rawResponse = new StringBuffer();
                
    {While (-1! = (length = {myInput.read (responseData)))}
    rawResponse.append (new String (responseData, 0, length));
    If (timerTaskConnect.hasInterrupted ())
    throw new UnanticipatedHttpResponseException("Interrupted-Read");
    }
    myReturn = rawResponse.toString ();
    }

    } catch (Exception e) {}
    Prefs.getInstance () .writeErrorLog ("Exception:" + e.getMessage ());
    throw new UnanticipatedHttpResponseException (e.getMessage ());
            
    } {Finally
    If (connectionTimerConnect! = null)
    {
    connectionTimerConnect.cancel ();
    connectionTimerConnect = null;
    }
            
    try {}
    If (myInput! = null) {}
    myInput.close ();
    myInput = null;
    }

    } catch (Exception e) {}
             
    try {}
    If (myConn! = null) {}
    myConn.close ();
    myConn = null;
    }
    } catch (Exception e) {}
    Closed connection Exception
    }
    }
    Return myReturn;
    }

    The Timertask:

    SerializableAttribute public class HttpTimerTask extends TimerTask {}
    HttpConnection _myConn = null;
    Thread _myThread = null;
    Boolean _myHasInterrupted = false;
        
    public HttpTimerTask (HttpConnection myConn)
    {
    _myConn = myConn;
    _myThread = Thread.currentThread ();
    }
    public boolean hasInterrupted()
    {
    Return _myHasInterrupted;
    }
    public void run() {}
    String myErrorName = "HttpTimerTask:"; "
    try {}
    If (_myConn! = null)
    {
    _myConn.close ();
    _myConn = null;
    If (Constants.DEBUG_MODE)
    Prefs.getInstance () .writeErrorLog (myErrorName + "Closed connection");
    }
    If (_myThread! = null)
    {
    _myThread.interrupt ();
    _myHasInterrupted = true;
    If (Constants.DEBUG_MODE)
    Prefs.getInstance () .writeErrorLog (myErrorName + "Interrupts the thread");
    }
                
    } catch (IOException e) {}
    }
    }

    Ok.

    «... Add a second timer.

    It is probably more effective if you can get your first Timer to perform the two functions, i.e. giving him the connection when you have an and the code check to see if there is a connection of paving?  I'm always hesitant to start further discussions on a camera like the BB.

    Please let us know how you go, because your logic could provide a good model for others.

  • weird http timeout problem

    OK, maybe not weird, but weird. It's WL7sp7.

    In the std newspapers in our production environment, we see the following message "the server could not send the HTTP message during the timeout value configured. The socket has been closed. ». You can see this message only to a second interval specific than a minute... that is, in the log below, extract as the second "33" (11: 52:33, 11:55:33, 12:11:33, etc..). After a reboot, we will see only this message to the second "21" (15: 13:21, 3:21:21 PM PST, etc.).

    The problem, it is a DOTNET fact http post for this app WL application... If the messages at the wrong time DOTNET application (e.. g, to the second '33' minute) the http post fails. The DOTNET application logs the remote server took of disconnection. If you look at the logs to stdout for the same time, we see the connection timeout message. The post and the response would only last a second or two and little almost always succeeds wait for these applications, which falls on the 'bad' (milli?) second of the minute.

    I don't know if I've explained clearly this strange phenomenon. If this is not the case, let me know. An excerpt from our newspapers std:

    grep /tmp/WLPRODSVR04-stdout.log "the server could not send the HTTP message"
    # < 5 November 2008 11:52:33 AM PST > < Info > < HTTP > < credpwy01swlc04 > < WLPRODSVR04 > < ExecuteThread: '2' for the queue: 'default' > < identity kernel > <>< 101325 > < server could not send the HTTP message during the timeout value configured. The socket has been closed. >
    # < 5 November 2008 11:55:33 AM PST > < Info > < HTTP > < credpwy01swlc04 > < WLPRODSVR04 > < ExecuteThread: '20' to the queue: 'default' > < identity kernel > <>< 101325 > < server could not send the HTTP message during the timeout value configured. The socket has been closed. >
    # < 5 November 2008 12:11:33 PM PST > < Info > < HTTP > < credpwy01swlc04 > < WLPRODSVR04 > < ExecuteThread: '22' to queue: 'default' > < identity kernel > <>< 101325 > < server could not send the HTTP message during the timeout value configured. The socket has been closed. >
    # < 5 November 2008 12:34:33 PM PST > < Info > < HTTP > < credpwy01swlc04 > < WLPRODSVR04 > < ExecuteThread: '4' for queue: 'default' > < identity kernel > <>< 101325 > < server could not send the HTTP message during the timeout value configured. The socket has been closed. >
    # < 5 November 2008 12:42:33 PM PST > < Info > < HTTP > < credpwy01swlc04 > < WLPRODSVR04 > < ExecuteThread: '2' for the queue: 'default' > < identity kernel > <>< 101325 > < server could not send the HTTP message during the timeout value configured. The socket has been closed. >
    # < 5 November 2008 12:53:34 PM PST > < Info > < HTTP > < credpwy01swlc04 > < WLPRODSVR04 > < ExecuteThread: '23' for the queue: 'default' > < identity kernel > <>< 101325 > < server could not send the HTTP message during the timeout value configured. The socket has been closed. >
    # < 5 November 2008 12:57:34 PM PST > < Info > < HTTP > < credpwy01swlc04 > < WLPRODSVR04 > < ExecuteThread: '26' for the queue: 'default' > < identity kernel > <>< 101325 > < server could not send the HTTP message during the timeout value configured. The socket has been closed. >
    ....
    [reboot]
    .....
    # < 5 November 2008 3:13:21 PM PST > < Info > < HTTP > < credpwy01swlc04 > < WLPRODSVR04 > < ExecuteThread: '30' for queue: 'default' > < identity kernel > <>< 101325 > < server could not send the HTTP message during the timeout value configured. The socket has been closed. >
    # < 5 November 2008 3:21:21 PM PST > < Info > < HTTP > < credpwy01swlc04 > < WLPRODSVR04 > < ExecuteThread: '26' for the queue: 'default' > < identity kernel > <>< 101325 > < server could not send the HTTP message during the timeout value configured. The socket has been closed. >
    # < 5 November 2008 3:29:21 PM PST > < Info > < HTTP > < credpwy01swlc04 > < WLPRODSVR04 > < ExecuteThread: '23' for the queue: 'default' > < identity kernel > <>< 101325 > < server could not send the HTTP message during the timeout value configured. The socket has been closed. >
    # < 5 November 2008 3:30:21 PM PST > < Info > < HTTP > < credpwy01swlc04 > < WLPRODSVR04 > < ExecuteThread: '26' for the queue: 'default' > < identity kernel > <>< 101325 > < server could not send the HTTP message during the timeout value configured. The socket has been closed. >
    # < 5 November 2008 3:38:21 PM PST > < Info > < HTTP > < credpwy01swlc04 > < WLPRODSVR04 > < ExecuteThread: '23' for the queue: 'default' > < identity kernel > <>< 101325 > < server could not send the HTTP message during the timeout value configured. The socket has been closed. >
    # < 5 November 2008 16:30:21 PST > < Info > < HTTP > < credpwy01swlc04 > < WLPRODSVR04 > < ExecuteThread: '29' for the queue: 'default' > < identity kernel > <>< 101325 > < server could not send the HTTP message during the timeout value configured. The socket has been closed. >
    # < 6 November 2008 16:41:21 AM PST > < Info > < HTTP > < credpwy01swlc04 > < WLPRODSVR04 > < ExecuteThread: '27' for queue: 'default' > < identity kernel > <>< 101325 > < server could not send the HTTP message during the timeout value configured. The socket has been closed. >
    # < 6 November 2008 17:56:21 AM PST > < Info > < HTTP > < credpwy01swlc04 > < WLPRODSVR04 > < ExecuteThread: '26' for the queue: 'default' > < identity kernel > <>< 101325 > < server could not send the HTTP message during the timeout value configured. The socket has been closed. >
    # < 6 November 2008 18:01:21 AM PST > < Info > < HTTP > < credpwy01swlc04 > < WLPRODSVR04 > < ExecuteThread: '26' for the queue: 'default' > < identity kernel > <>< 101325 > < server could not send the HTTP message during the timeout value configured. The socket has been closed. >
    # < 6 November 2008 18:08:21 AM PST > < Info > < HTTP > < credpwy01swlc04 > < WLPRODSVR04 > < ExecuteThread: "28" for queue: 'default' > < identity kernel > <>< 101325 > < server could not send the HTTP message during the timeout value configured. The socket has been closed. >
    # < 6 November 2008 18:55:21 AM PST > < Info > < HTTP > < credpwy01swlc04 > < WLPRODSVR04 > < ExecuteThread: '29' for the queue: 'default' > < identity kernel > <>< 101325 > < server could not send the HTTP message during the timeout value configured. The socket has been closed. >
    # < 6 November 2008 19:11:21 AM PST > < Info > < HTTP > < credpwy01swlc04 > < WLPRODSVR04 > < ExecuteThread: '22' to queue: 'default' > < identity kernel > <>< 101325 > < server could not send the HTTP message during the timeout value configured. The socket has been closed. >
    # < 6 November 2008 19:50:21 AM PST > < Info > < HTTP > < credpwy01swlc04 > < WLPRODSVR04 > < ExecuteThread: '30' for queue: 'default' > < identity kernel > <>< 101325 > < server could not send the HTTP message during the timeout value configured. The socket has been closed. >
    # < 6 November 2008 8:00:21 AM PST > < Info > < HTTP > < credpwy01swlc04 > < WLPRODSVR04 > < ExecuteThread: '24' to queue: 'default' > < identity kernel > <>< 101325 > < server could not send the HTTP message during the timeout value configured. The socket has been closed. >
    # < 6 November 2008 8:07:21 AM PST > < Info > < HTTP > < credpwy01swlc04 > < WLPRODSVR04 > < ExecuteThread: '30' for queue: 'default' > < identity kernel > <>< 101325 > < server could not send the HTTP message during the timeout value configured. The socket has been closed. >
    # < 6 November 2008 8:20:21 AM PST > < Info > < HTTP > < credpwy01swlc04 > < WLPRODSVR04 > < ExecuteThread: "28" for queue: 'default' > < identity kernel > <>< 101325 > < server could not send the HTTP message during the timeout value configured. The socket has been closed. >
    # < 6 November 2008 9:15:21 AM PST > < Info > < HTTP > < credpwy01swlc04 > < WLPRODSVR04 > < ExecuteThread: '25' to queue: 'default' > < identity kernel > <>< 101325 > < server could not send the HTTP message during the timeout value configured. The socket has been closed. >
    # < 6 November 2008 9:34:21 AM PST > < Info > < HTTP > < credpwy01swlc04 > < WLPRODSVR04 > < ExecuteThread: '29' for the queue: 'default' > < identity kernel > <>< 101325 > < server could not send the HTTP message during the timeout value configured. The socket has been closed. >
    # < 6 November 2008 9:41:21 AM PST > < Info > < HTTP > < credpwy01swlc04 > < WLPRODSVR04 > < ExecuteThread: that of the "31" to queue: 'default' > < identity kernel > <>< 101325 > < server could not send the HTTP message during the timeout value configured. The socket has been closed. >
    # < 6 November 2008 10:14:21 AM PST > < Info > < HTTP > < credpwy01swlc04 > < WLPRODSVR04 > < ExecuteThread: '22' to queue: 'default' > < identity kernel > <>< 101325 > < server could not send the HTTP message during the timeout value configured. The socket has been closed. >
    # < 6 November 2008 10:17:21 AM PST > < Info > < HTTP > < credpwy01swlc04 > < WLPRODSVR04 > < ExecuteThread: '21' for queue: 'default' > < identity kernel > <>< 101325 > < server could not send the HTTP message during the timeout value configured. The socket has been closed. >
    # < 6 November 2008 10:24:21 AM PST > < Info > < HTTP > < credpwy01swlc04 > < WLPRODSVR04 > < ExecuteThread: '24' to queue: 'default' > < identity kernel > <>< 101325 > < server could not send the HTTP message during the timeout value configured. The socket has been closed. >
    # < 6 November 2008 10:38:21 AM PST > < Info > < HTTP > < credpwy01swlc04 > < WLPRODSVR04 > < ExecuteThread: '30' for queue: 'default' > < identity kernel > <>< 101325 > < server could not send the HTTP message during the timeout value configured. The socket has been closed. >
    # < 6 November 2008 11:04:21 AM PST > < Info > < HTTP > < credpwy01swlc04 > < WLPRODSVR04 > < ExecuteThread: '25' to queue: 'default' > < identity kernel > <>< 101325 > < server could not send the HTTP message during the timeout value configured. The socket has been closed. >
    # < 6 November 2008 11:09:21 AM PST > < Info > < HTTP > < credpwy01swlc04 > < WLPRODSVR04 > < ExecuteThread: '21' for queue: 'default' > < identity kernel > <>< 101325 > < server could not send the HTTP message during the timeout value configured. The socket has been closed. >
    # < 6 November 2008 11:28:21 AM PST > < Info > < HTTP > < credpwy01swlc04 > < WLPRODSVR04 > < ExecuteThread: '23' for the queue: 'default' > < identity kernel > <>< 101325 > < server could not send the HTTP message during the timeout value configured. The socket has been closed. >
    # < 6 November 2008 11:49:21 AM PST > < Info > < HTTP > < credpwy01swlc04 > < WLPRODSVR04 > < ExecuteThread: '30' for queue: 'default' > < identity kernel > <>< 101325 > < server could not send the HTTP message during the timeout value configured. The socket has been closed. >
    # < 6 November 2008 12:20:21 PM PST > < Info > < HTTP > < credpwy01swlc04 > < WLPRODSVR04 > < ExecuteThread: '29' for the queue: 'default' > < identity kernel > <>< 101325 > < server could not send the HTTP message during the timeout value configured. The socket has been closed. >
    # < 6 November 2008 12:47:21 PM PST > < Info > < HTTP > < credpwy01swlc04 > < WLPRODSVR04 > < ExecuteThread: '20' to the queue: 'default' > < identity kernel > <>< 101325 > < server could not send the HTTP message during the timeout value configured. The socket has been closed. >
    # < 6 November 2008 12:56:21 PM PST > < Info > < HTTP > < credpwy01swlc04 > < WLPRODSVR04 > < ExecuteThread: '22' to queue: 'default' > < identity kernel > <>< 101325 > < server could not send the HTTP message during the timeout value configured. The socket has been closed. >
    # < 6 November 2008 1:10:21 PM PST > < Info > < HTTP > < credpwy01swlc04 > < WLPRODSVR04 > < ExecuteThread: that of the "31" to queue: 'default' > < identity kernel > <>< 101325 > < server could not send the HTTP message during the timeout value configured. The socket has been closed. >
    # < 6 November 2008 1:18:21 PM PST > < Info > < HTTP > < credpwy01swlc04 > < WLPRODSVR04 > < ExecuteThread: '21' for queue: 'default' > < identity kernel > <>< 101325 > < server could not send the HTTP message during the timeout value configured. The socket has been closed. >
    # < 6 November 2008 3:29:21 PM PST > < Info > < HTTP > < credpwy01swlc04 > < WLPRODSVR04 > < ExecuteThread: "28" for queue: 'default' > < identity kernel > <>< 101325 > < server could not send the HTTP message during the timeout value configured. The socket has been closed. >
    # < 6 November 2008 16:19:21 PST > < Info > < HTTP > < credpwy01swlc04 > < WLPRODSVR04 > < ExecuteThread: '30' for queue: 'default' > < identity kernel > <>< 101325 > < server could not send the HTTP message during the timeout value configured. The socket has been closed. >
    # < 7 November 2008 5:23:17 AM PST > < Info > < HTTP > < credpwy01swlc04 > < WLPRODSVR04 > < ExecuteThread: '30' for queue: 'default' > < identity kernel > <>< 101325 > < server could not send the HTTP message during the timeout value configured. The socket has been closed. >
    # < 7 November 2008 17:59:17 AM PST > < Info > < HTTP > < credpwy01swlc04 > < WLPRODSVR04 > < ExecuteThread: "28" for queue: 'default' > < identity kernel > <>< 101325 > < server could not send the HTTP message during the timeout value configured. The socket has been closed. >
    # < 7 November 2008 18:31:17 AM PST > < Info > < HTTP > < credpwy01swlc04 > < WLPRODSVR04 > < ExecuteThread: '24' to queue: 'default' > < identity kernel > <>< 101325 > < server could not send the HTTP message during the timeout value configured. The socket has been closed. >
    # < 7 November 2008 6:51:17 AM PST > < Info > < HTTP > < credpwy01swlc04 > < WLPRODSVR04 > < ExecuteThread: '23' for the queue: 'default' > < identity kernel > <>< 101325 > < server could not send the HTTP message during the timeout value configured. The socket has been closed. >
    # < 7 November 2008 19:24:17 AM PST > < Info > < HTTP > < credpwy01swlc04 > < WLPRODSVR04 > < ExecuteThread: '26' for the queue: 'default' > < identity kernel > <>< 101325 > < server could not send the HTTP message during the timeout value configured. The socket has been closed. >
    # < 7 November 2008 19:31:17 AM PST > < Info > < HTTP > < credpwy01swlc04 > < WLPRODSVR04 > < ExecuteThread: '26' for the queue: 'default' > < identity kernel > <>< 101325 > < server could not send the HTTP message during the timeout value configured. The socket has been closed. >
    # < 7 November 2008 19:41:17 AM PST > < Info > < HTTP > < credpwy01swlc04 > < WLPRODSVR04 > < ExecuteThread: "28" for queue: 'default' > < identity kernel > <>< 101325 > < server could not send the HTTP message during the timeout value configured. The socket has been closed. >
    # < 7 November 2008 8:00:17 AM PST > < Info > < HTTP > < credpwy01swlc04 > < WLPRODSVR04 > < ExecuteThread: '30' for queue: 'default' > < identity kernel > <>< 101325 > < server could not send the HTTP message during the timeout value configured. The socket has been closed. >
    # < 7 November 2008 8:21:17 AM PST > < Info > < HTTP > < credpwy01swlc04 > < WLPRODSVR04 > < ExecuteThread: '24' to queue: 'default' > < identity kernel > <>< 101325 > < server could not send the HTTP message during the timeout value configured. The socket has been closed. >
    # < 7 November 2008 8:47:17 AM PST > < Info > < HTTP > < credpwy01swlc04 > < WLPRODSVR04 > < ExecuteThread: that of the "31" to queue: 'default' > < identity kernel > <>< 101325 > < server could not send the HTTP message during the timeout value configured. The socket has been closed. >
    # < 7 November 2008 9:15:17 AM PST > < Info > < HTTP > < credpwy01swlc04 > < WLPRODSVR04 > < ExecuteThread: '22' to queue: 'default' > < identity kernel > <>< 101325 > < server could not send the HTTP message during the timeout value configured. The socket has been closed. >
    # < 7 November 2008 9:20:17 AM PST > < Info > < HTTP > < credpwy01swlc04 > < WLPRODSVR04 > < ExecuteThread: '23' for the queue: 'default' > < identity kernel > <>< 101325 > < server could not send the HTTP message during the timeout value configured. The socket has been closed. >
    # < 7 November 2008 9:34:17 AM PST > < Info > < HTTP > < credpwy01swlc04 > < WLPRODSVR04 > < ExecuteThread: '22' to queue: 'default' > < identity kernel > <>< 101325 > < server could not send the HTTP message during the timeout value configured. The socket has been closed. >
    # < 7 November 2008 10:06:17 AM PST > < Info > < HTTP > < credpwy01swlc04 > < WLPRODSVR04 > < ExecuteThread: "28" for queue: 'default' > < identity kernel > <>< 101325 > < server could not send the HTTP message during the timeout value configured. The socket has been closed. >
    # < 7 November 2008 10:12:17 AM PST > < Info > < HTTP > < credpwy01swlc04 > < WLPRODSVR04 > < ExecuteThread: '21' for queue: 'default' > < identity kernel > <>< 101325 > < server could not send the HTTP message during the timeout value configured. The socket has been closed. >
    # < 7 November 2008 10:54:17 AM PST > < Info > < HTTP > < credpwy01swlc04 > < WLPRODSVR04 > < ExecuteThread: "28" for queue: 'default' > < identity kernel > <>< 101325 > < server could not send the HTTP message during the timeout value configured. The socket has been closed. >
    # < 7 November 2008 11:05:17 AM PST > < Info > < HTTP > < credpwy01swlc04 > < WLPRODSVR04 > < ExecuteThread: that of the "31" to queue: 'default' > < identity kernel > <>< 101325 > < server could not send the HTTP message during the timeout value configured. The socket has been closed. >
    # < 7 November 2008 11:12:17 AM PST > < Info > < HTTP > < credpwy01swlc04 > < WLPRODSVR04 > < ExecuteThread: that of the "31" to queue: 'default' > < identity kernel > <>< 101325 > < server could not send the HTTP message during the timeout value configured. The socket has been closed. >
    # < 7 November 2008 11:28:17 AM PST > < Info > < HTTP > < credpwy01swlc04 > < WLPRODSVR04 > < ExecuteThread: '27' for queue: 'default' > < identity kernel > <>< 101325 > < server could not send the HTTP message during the timeout value configured. The socket has been closed. >
    ....
    [reboot]
    .....
    # < 7 November 2008 12:24:09 PM PST > < Info > < HTTP > < credpwy01swlc04 > < WLPRODSVR04 > < ExecuteThread: that of the "31" to queue: 'default' > < identity kernel > <>< 101325 > < server could not send the HTTP message during the timeout value configured. The socket has been closed. >
    # < 7 November 2008 12:31:09 PM PST > < Info > < HTTP > < credpwy01swlc04 > < WLPRODSVR04 > < ExecuteThread: "14" for queue: 'default' > < identity kernel > <>< 101325 > < server could not send the HTTP message during the timeout value configured. The socket has been closed. >
    # < 7 November 2008 12:31:09 PM PST > < Info > < HTTP > < credpwy01swlc04 > < WLPRODSVR04 > < ExecuteThread: "14" for queue: 'default' > < identity kernel > <>< 101325 > < server could not send the HTTP message during the timeout value configured. The socket has been closed. >
    # < 7 November 2008 12:35:09 PM PST > < Info > < HTTP > < credpwy01swlc04 > < WLPRODSVR04 > < ExecuteThread: '16' for queue: 'default' > < identity kernel > <>< 101325 > < server could not send the HTTP message during the timeout value configured. The socket has been closed. >
    # < 7 November 2008 1:14:09 PM PST > < Info > < HTTP > < credpwy01swlc04 > < WLPRODSVR04 > < ExecuteThread: '17' for queue: 'default' > < identity kernel > <>< 101325 > < server could not send the HTTP message during the timeout value configured. The socket has been closed. >
    # < 7 November 2008 1:15:09 pm PST > < Info > < HTTP > < credpwy01swlc04 > < WLPRODSVR04 > < ExecuteThread: '10' for queue: 'default' > < identity kernel > <>< 101325 > < server could not send the HTTP message during the timeout value configured. The socket has been closed. >
    # < 7 November 2008 1:32:10 PST > < Info > < HTTP > < credpwy01swlc04 > < WLPRODSVR04 > < ExecuteThread: '19' for queue: 'default' > < identity kernel > <>< 101325 > < server could not send the HTTP message during the timeout value configured. The socket has been closed. >
    # < 7 November 2008 2:03:10 PM PST > < Info > < HTTP > < credpwy01swlc04 > < WLPRODSVR04 > < ExecuteThread: '15' for queue: 'default' > < identity kernel > <>< 101325 > < server could not send the HTTP message during the timeout value configured. The socket has been closed. >
    # < 7 November 2008 2:12:10 PM PST > < Info > < HTTP > < credpwy01swlc04 > < WLPRODSVR04 > < ExecuteThread: '11' for queue: 'default' > < identity kernel > <>< 101325 > < server could not send the HTTP message during the timeout value configured. The socket has been closed. >
    # < 7 November 2008 2:12:10 PM PST > < Info > < HTTP > < credpwy01swlc04 > < WLPRODSVR04 > < ExecuteThread: '11' for queue: 'default' > < identity kernel > <>< 101325 > < server could not send the HTTP message during the timeout value configured. The socket has been closed. >
    # < 7 November 2008 2:24:10 PM PST > < Info > < HTTP > < credpwy01swlc04 > < WLPRODSVR04 > < ExecuteThread: '24' to queue: 'default' > < identity kernel > <>< 101325 > < server could not send the HTTP message during the timeout value configured. The socket has been closed. >
    # < 7 November 2008 3:39:10 PM PST > < Info > < HTTP > < credpwy01swlc04 > < WLPRODSVR04 > < ExecuteThread: '29' for the queue: 'default' > < identity kernel > <>< 101325 > < server could not send the HTTP message during the timeout value configured. The socket has been closed. >

    Its a known problem with WLS 7.0 SP7 (CR300032 and CR196369) associated with CompleteHTTPMessageTimeout. WebLogic Server closes a connection intermittently while responding to the slow clients. If you have a support contract, you can open a service request and download the patch and details of the Czech Republic.

  • HTTP Timeout - Explorer vs Firefox

    I discovered that if you make a request, using URLLoader or other type of request objects, if the connection fails to connect browsers react differently. The issue I encountered is with Firefox, it does not appear any time. If she fails to connect you will never get an onFault, or response onComplete.

    Has anyone else seen elsewhere? Is my best option to create my own Timer with a time-out?

    To reproduce: you can use the code example provided on:
    http://livedocs.Adobe.com/Flex/2/langref/Flash/NET/URLRequest.html#includeExamplesSummary

    Change URLRequest ("XMLFile.xml") to URLRequest ("' http://www.google.com" "), disable your network connection, run your Flex application with Firefox and explore and see the difference.

    Thank you

    In my view, using a timer is the best solution. Please this file as a bug in our new public bugbase for Flex at http://bugs.adobe.com/flex and mention that it's really a problem of browser/player. The team of the player is not currently a public bugbase.

  • Automatic logout after inactivity of 180 seconds (http and https)

    All of my N4032 and N3024 switches with 6.2.7.2 firmware automaticlly break http and https session after ~ 180 seconds of inactivity. Controls:

    line telnet
    exec-timeout x

    do not work
    Does anyone have a similar experience?
    Is this a known issue?

    Looking through the firmware release notes, it looks like it was a known, only http/https problem did not follow the exec-timeout parameter. # Ip http timeout-political order, has been added to 6.2.6.6. I would test change the time-out setting by using the command # ip http timeout policy.

    Example of release notes:

    Console (config) #ip http idle timeout-political 3600 life 86400

    Let us know if it works.

  • WebVPN not works of harbors (https or http) with IOS - 12, 4 (24) T5

    I have a router with IOS-12-877, 4 (24) T5

    My problem is when I try to connect to https (or http) from outside to open the web portal to connect using WebVPN (SSL VPN)

    He never answers!

    I can connect to the public IP address of the inside of LAN, instead may open the webvpn Portal download anyconnect and establishing the SSL VPN.

    I can connect to my local network using Cisco VPN Client from outside and I have a VPN from Site to Site also works.

    This is my config (without data):

    ---------------------------------------------------------------------------------------------

    ---------------------------------------------------------------------------------------------

    877_Feria #.

    877_Feria #show run

    Building configuration...

    Current configuration: 7756 bytes

    !

    version 12.4

    no service button

    horodateurs service debug datetime msec

    Log service timestamps datetime msec

    no password encryption service

    !

    hostname 877_Feria

    !

    boot-start-marker

    boot-end-marker

    !

    forest-meter operation of syslog messages

    logging buffered 52000

    !

    AAA new-model

    !

    !

    AAA authentication login ciscocp_vpn_xauth_ml_1 local

    AAA authentication login ciscocp_vpn_xauth_ml_2 local

    AAA authorization ciscocp_vpn_group_ml_1 LAN

    !

    !

    AAA - the id of the joint session

    clock timezone Paris 1

    summer time clock Paris date March 30, 2003 02:00 October 26, 2003 03:00

    !

    Crypto pki trustpoint SSL

    enrollment selfsigned

    full domain name no

    name of the object CN = vpnferia

    crl revocation checking

    rsakeypair SSL_FERIA

    !

    !

    pki encryption SSL certificate chain

    self-signed certificate 03

    3082020E 30820177 02020103 300 D 0609 2A 864886 F70D0101 04050030 A0030201

    13311130 0F060355 04031308 76706E66 65726961 31313033 31343037 301E170D

    5A170D32 33353338 30303130 31303030 3030305A 30133111 55040313 300F0603

    0876706E 66657269 300 D 0609 2A 864886 F70D0101 01050003 6130819F 818D 0030

    81009F30 81890281 1B5E0CF6 F3376884 9C8D3749 237D3F13 CB9728D1 B 0712, 635

    7293B 978 6BE81A2F 06951D 72 C30178C0 91B4786B 7E701B59 62622 HAS 31 96D023C1

    BDB82295 E4E77FC8 97BF34CA 16B03F53 5EC21F5E 88BA12E1 E5D12729 58136 HAS 53

    76E35D33 1A99EF9F E7B034D6 EB3CF17C A73ECAA1 326573DE 164BB1F3 5EA8EE17

    4AB73CD3 22950203 010001A 3 72307030 1 130101 FF040530 030101FF 0F060355

    0603 551 1104 16301482 12383737 5F466572 69612E66 65726961 301D 2E657330

    1 230418 30168014 51E4D8C7 6347B08A D3CB8F2E F4E4C400 061DB6B4 1F060355

    301D 0603 551D0E04 16041451 E4D8C763 47B08AD3 CB8F2EF4 E4C40006 1DB6B430

    010104 05000381 81008160 0AAD04E3 D247EA6C C1F6E93C 0D 864886F7 0D06092A

    5D0B4C8F 25319E30 8EBABE6F 50E53F7D 57DE0F8A 13BB3212 642C4EAC A32610A6

    75D6568E DA5CEF92 E59D511B 80186AF8 73CC11E6 F1E82065 C47E6B60 82BCA939

    9FF3F06D E3858349 3007AFC2 A2F0CE59 809FA1E1 F2B7FEA1 9B13E8AA 1FEF6AF1

    96E627FC 481642F4 A466EFE7 C 8124, 374 044F

    quit smoking

    dot11 syslog

    IP source-route

    DHCP excluded-address IP 10.10.10.1

    !

    DHCP IP CCP-pool

    import all

    Network 10.10.10.0 255.255.255.248

    default router 10.10.10.1

    Rental 2 0

    !

    !

    IP cef

    IP domain name feria.net

    name of the IP-server 192.168.254.3

    !

    !

    !

    !

    username privilege 15 secret 5 user1 zMca $1$ $ 0AkwxrsfBY63XPUHxv31N0

    username userVPN secret 5 $1$ $8iKr 8WV5IhFUmI671.XGp3Gb11

    username userWebVPN secret 5 $1$ $3HPK tvFjfrQd86iAoHGsa5Uu01

    !

    !

    crypto ISAKMP policy 1

    BA 3des

    preshared authentication

    Group 2

    ISAKMP crypto keys interkey address 8.2.24.3

    !

    Configuration group isakmp crypto CiscoVPN client

    key 123456

    pool ippool

    10 Max-users

    netmask 255.255.255.0

    ISAKMP crypto ciscocp-ike-profile-1 profile

    identity CiscoVPN group match

    client authentication list ciscocp_vpn_xauth_ml_1

    ISAKMP authorization list ciscocp_vpn_group_ml_1

    client configuration address respond

    virtual-model 2

    !

    !

    Crypto ipsec transform-set esp-SHA-ESP-3DES-3des esp-sha-hmac

    Crypto ipsec transform-set ESP-3DES-SHA1 esp-3des esp-sha-hmac

    !

    Profile of crypto ipsec CiscoCP_Profile1

    game of transformation-ESP-3DES-SHA1

    set of isakmp - profile ciscocp-ike-profile-1

    !

    !

    map SDM_CMAP_1 1 ipsec-isakmp crypto

    Description Tunnel to8.2.24.3

    defined by peer 8.2.24.3

    game of transformation-ESP-3DES-SHA

    match address 101

    !

    Archives

    The config log

    hidekeys

    !

    !

    property intellectual ssh source interface Vlan1

    !

    !

    !

    ATM0 interface

    no ip address

    No atm ilmi-keepalive

    waiting-224 in

    !

    point-to-point interface ATM0.1

    IP 8.3.8.6 255.255.255.240

    NAT outside IP

    IP virtual-reassembly

    PVC 8/32

    aal5snap encapsulation

    !

    map SDM_CMAP_1 crypto

    Crypto ipsec df - bit clear

    !

    interface FastEthernet0

    !

    interface FastEthernet1

    !

    interface FastEthernet2

    !

    interface FastEthernet3

    !

    interface virtual-Template1

    ATM0.1 IP unnumbered

    !

    tunnel type of interface virtual-Template2

    ATM0.1 IP unnumbered

    ipv4 ipsec tunnel mode

    Tunnel CiscoCP_Profile1 ipsec protection profile

    !

    interface Vlan1

    Description $ETH - SW - LAUNCH, INTF-INFO-HWIC $$ $4ESW

    IP 192.168.254.240 255.255.255.0

    IP nat inside

    IP virtual-reassembly

    IP tcp adjust-mss 1452

    !

    IP local pool ippool 192.168.253.1 192.168.253.10

    no ip forward-Protocol nd

    IP route 0.0.0.0 0.0.0.0 ATM0.1

    IP http server

    access-class 2 IP http

    local IP http authentication

    IP http secure server

    IP http timeout policy slowed down 60 life 86400 request 10000

    !

    IP nat inside source map route SDM_RMAP_1 interface ATM0.1 overload

    !

    access-list 1 permit 192.168.254.0 0.0.0.255 connect

    access-list 2 allow one

    access-list 23 allow 10.10.10.0 0.0.0.7

    Note access-list 100 CCP_ACL category = 19

    Note access-list 100 IPSec rule

    access-list 100 deny ip 192.168.254.0 0.0.0.255 192.168.0.0 0.0.0.255

    access ip-list 100 permit a whole

    Note access-list 101 category CCP_ACL = 4

    Note access-list 101 IPSec rule

    access-list 101 permit ip 192.168.254.0 0.0.0.255 192.168.0.0 0.0.0.255

    !

    !

    !

    allowed SDM_RMAP_1 1 route map

    corresponds to the IP 100

    !

    !

    control plan

    !

    !

    Line con 0

    no activation of the modem

    line to 0

    line vty 0 4

    access-class 100 in

    privilege level 15

    connection of authentication AutClient

    transport input telnet ssh

    !

    max-task-time 5000 Planner

    !

    WebVPN gateway gateway_1

    hostname 877_Feria

    IP address 8.3.8.6 port 443

    redirect http port 80

    trustpoint SSL SSL

    development

    !

    WebVPN install svc flash:/webvpn/anyconnect-dart-win-2.5.2017-k9.pkg sequence 1

    !

    WebVPN context VPN-Feria

    secondary-color white

    color of the title #FF9900

    text-color black

    SSL authentication check all

    !

    !

    policy_1 political group

    functions compatible svc

    SVC-pool of addresses "ippool.

    SVC Dungeon-client-installed

    virtual-model 1

    Group Policy - by default-policy_1

    AAA authentication list ciscocp_vpn_xauth_ml_2

    Gateway gateway_1 field vpnferia

    10 Max-users

    development

    !

    end

    ---------------------------------------------------------------------------------------------

    ---------------------------------------------------------------------------------------------

    This who can miss?

    Thank you all!

    Try adding a NAT statement for outdoors.

    IP nat inside source static tcp 8.3.8.6 443 8.3.8.6 443

    assuming that 8.3.8.6 is your public IP address.

    -Brian

  • How to set the timeout property Web Service partner link in the new version of the SOA Suite, it is missing

    Hello

    I have a use case in which I'll call synchronous external Web Service and the form of this service, I get the answer after 80 seconds.

    I know that this console form EM soa-infra-> SOA Administration-> BPEL proprieties-> under 'more BPEL Configuration Properties..' in SyncMaxWaitTime can I change the default 45 second in 80 seconds, but it will apply to all synchronous services in this area, and I want only the value appeal of Web Service of particular external reference (link partner).

    For the limit of timeout for the particular web service (partner of external reference link):

    I saw a post at < http://www.mandsconsulting.com/asynchronous-vs-synchronous-bpel-processes > in which there is an option in 'Link partner Edit' form property tab dialog box, we can add "timeout" property but in SOA Suite11.1.1.7 I am not able to find this property form the list.

    on this post < http://abhishek-soablog.blogspot.in/2010/06/timeout-for-partnerlink.html > is also described the same way, but it's just the source code of the highest way of GUI to set the timeout property and it does not work with a new version.

    Can someone please tell me in a new version (11.1.1.7) of SOA suite, which is how to set the timeout for the particular web service (partner of external reference link).

    Thank you

    Can someone please tell me in a new version (11.1.1.7) of SOA suite, which is how to set the timeout for the particular web service (partner of external reference link).

    VR;

    Click em-> composite-> Services and references-> select need to reference and click on-> properties: 'HTTP Timeout of read' and 'HTTP timeout.

    developing composites:

    Click on a reference-> property inspector-> link properties-> plu green and add oracle.webservices.httpConnTimeout with the necessary value and oracle.webservices.httpReadTimeout with the necessary value

    for the same domain defined: oracle.webservices.local.optimization = false

    You can watch

    Administration of Web Services - 11g Release 1 (11.1.1.7)

    How to set a timeout for a Web Service in SOA 11 g (Doc ID 979683.1)

    SOA 11 g: political malpractice not to intercept 'service Endpoint unreachable' error (Doc ID 1503989.1)

  • How to increase the timeout for download on GBA?

    Hello

    We try to download a large file (50 to 75 MB) PDF to our Association. But we have always had an HTTP timeout. Send us the request typical HTTP POST to .../Packaging/Package with some parameters.

    I think there should be some options for the packaging.conf file in / etc to increase the time-out period. But unfortunality I wasn't able to find these options in the documentation. Maybe I'm blind too.

    Can you help me please? Is there a list with all the options for packaging.conf, fulfillment.conf and admin.conf? May I can find other interesting options in this list.

    Thank you in advance!

    Kind regards

    Nicolas

    I upload the file via SFTP in a location known and accessible to the service of packaging and if you send the application package using the dataPath option, not the data option.
    This will also help with the use of memory on the server package.

  • Connection timeout problems

    I have several users using smartview against Essbase, both are V11.1.1.2. They frequently experience connection timeout errors when you try to retrieve reports. WE tried to increase the NetTimeout and the NetDelay on the Essbase server and an increase of agentthreads and a few other parameters configuration of Essbase. SmartView has been configured to allow up to 20000 lines, although these queries return no more than a few hundred lines of data. Session time is set to 60 minutes. This implementation uses Websphere. Can someone suggest setting changes to stop this error from happening? Matt? Mike?

    They can run in a HTTP timeout error.

    You can get all the details of how solve it here - http://support.microsoft.com/kb/813827

  • SRW2048 and a Cisco 1841

    I am trying to Setup VLAN between a 2 and a Cisco 1841 router SRW2048 switches. I have ports that connect the 2 switches to the other and the port that connect to router as junction ports. I set 2 VLANS. VLAN 1 is just the vlan by default everyone runs and vlan will be the area demilitarized. I have no configuration of access control lists to block traffic, but when I assign vlan 2 on the port that the server is, I can not ping to the gateway. I don't know what is happening, see below for the cleaned configs.

    1841:

    Current configuration: 4282 bytes
    !
    version 12.4
    no service button
    horodateurs service debug datetime msec
    Log service timestamps datetime localtime show-time zone
    encryption password service
    !
    hostname QCSLOLURTR01
    !
    boot-start-marker
    start the system flash c1841-advsecurityk9 - mz.124 - 25B .bin
    boot-end-marker
    !
    logging buffered debugging 8192
    !
    AAA new-model
    !
    !
    AAA authentication login default group Ganymede + local
    the AAA authentication enable default group Ganymede + none
    !
    AAA - the id of the joint session
    clock timezone CST - 6
    clock to summer time recurring CDT
    IP cef
    !
    !
    property intellectual auth-proxy max-nodata-& 3
    property intellectual admission max-nodata-& 3
    !
    !
    no ip domain search
    IP domain name qcsupply.com
    !
    !
    !
    user name x

    Archives
    The config log
    hidekeys
    !
    !
    x IP ftp username
    x IP ftp password

    !
    !
    crypto ISAKMP policy 1
    BA 3des
    md5 hash
    preshared authentication
    Group 2
    ISAKMP crypto key QCSLOLU address x.x.x.x No.-xauth
    !
    !
    Crypto ipsec transform-set esp-3des esp-md5-hmac ts1
    Crypto ipsec transform-set esp - esp-md5-hmac ts2
    !
    VPN-map 10 ipsec-isakmp crypto map
    defined peer x.x.x.x
    Set transform-set ts1
    match address 101
    !
    !
    !
    interface FastEthernet0/0
    Description QCSL OLU INTERNET CONNECTION
    IP x.x.x.x where x.x.x.x
    IP access-group denied-hack-attack in
    no ip redirection
    no ip unreachable
    no ip proxy-arp
    NAT outside IP
    IP virtual-reassembly
    automatic duplex
    automatic speed
    No cdp enable
    card crypto vpn-map
    !
    interface FastEthernet0/1
    no ip address
    automatic duplex
    automatic speed
    !
    interface FastEthernet0/1.1
    encapsulation dot1Q 1 native
    IP 10.60.90.1 255.255.255.0
    IP nat inside
    IP virtual-reassembly
    !
    interface FastEthernet0/1.2
    encapsulation dot1Q 2
    IP 10.60.89.1 255.255.255.0
    IP nat inside
    IP virtual-reassembly
    !
    interface Serial0/0/0
    no ip address
    Shutdown
    !
    Router eigrp 100
    Network 10.60.89.0 0.0.0.255
    Network 10.60.90.0 0.0.0.255
    No Auto-resume
    !
    IP forward-Protocol ND
    IP route 0.0.0.0 0.0.0.0 x.x.x.x
    !
    no ip address of the http server
    23 class IP http access
    local IP http authentication
    no ip http secure server
    IP http timeout policy slowed down 60 life 86400 request 10000
    IP nat inside source map of route-nat interface FastEthernet0/0 overload
    IP nat inside source static tcp 10.60.89.10 80 80 extensible x.x.x.x
    IP nat inside source static tcp 10.60.89.10 expandable 443 443 x.x.x.x
    IP nat inside source static tcp 10.60.89.10 2021 x.x.x.x extensible 2021
    IP nat inside source static tcp 10.60.89.10 6100 6100 extensible x.x.x.x
    IP nat inside source static tcp 10.60.90.13 80 80 extensible x.x.x.x
    IP nat inside source static tcp 10.60.90.13 expandable 443 443 x.x.x.x
    IP nat inside source static tcp 10.60.90.13 1494 x.x.x.x extensible 1494
    !
    deny-hack-attack extended IP access list
    allow udp 0.255.255.255 x.x.x.x any eq snmp
    deny udp any any eq snmp
    deny udp any any eq tftp
    deny udp any any eq bootpc
    deny udp any any eq bootps
    deny ip x.x.x.x 0.15.255.255 all
    deny ip x.x.x.x 0.0.255.255 everything
    allow an ip
    !
    record 10.10.5.30
    access-list 23 allow 10.10.10.0 0.0.0.7
    access-list 99 allow 10.0.0.0 0.255.255.255
    access-list 99 allow x.x.x.x 0.0.1.255
    access-list 101 permit ip 10.60.90.0 0.0.0.255 10.10.0.0 0.0.255.255
    access-list 101 permit ip 10.60.89.0 0.0.0.255 10.10.0.0 0.0.255.255
    access-list 105 deny ip any host x.x.x.x
    105 ip access list allow a whole
    access-list 111 deny ip 10.60.90.0 0.0.0.255 10.10.0.0 0.0.255.255
    access-list 111 deny ip 10.60.89.0 0.0.0.255 10.10.0.0 0.0.255.255
    access-list 111 allow ip 10.60.89.0 0.0.0.255 any
    access-list 111 allow ip 10.60.90.0 0.0.0.255 any
    SNMP-server community no RO
    map of route-nat allowed 10
    corresponds to the IP 111
    !
    !
    RADIUS-server host x.x.x.x
    RADIUS-server key x
    !
    control plan
    !
    Banner motd ^ C

    x

    ^ C
    !
    Line con 0
    line to 0
    Modem InOut
    Discovery to automatically configure modem
    autohangup
    Speed 2400
    line vty 0 4
    location * Access Virtual Terminal allowed only from internal network *.
    access-class 99 in
    privilege level 15
    transport telnet entry
    line vty 5 15
    access-class 23 in
    privilege level 15
    transport telnet entry
    !
    Scheduler allocate 20000 1000
    end

    SRW2048 #1:

    Port 1: Trunk (to the router)

    Port 2: Trunk (SRW2048 #2)

    Prot 24: VLAN 2

    SRW2048 #2:

    Port 1: Trunk (of SRW2048 #1)

    Any ideas?

    Because the SRW is now part of Cisco Small Business, it would probably be best to ask the Cisco Small Business support community. You find people from Cisco over there.

    For SRW configuration, you added the two VLANS to your trunk ports? Configuration of a port in trunk mode adds automatically that all configured VLAN to the trunk.

    The server has a static IP address in the DMZ LAN?

  • How do reset you the time-out of the user for the connection of MISTLETOE on a 3524P?

    By default, apparently of 5 min, is too short for me.  I tried several CLI commands, I found online, but apparently not the right one.  This in particular seems like it should work, but I get a response from the unrecognized command.

    Console (config) # ip http timeout policy 1200

    Okay, I think I'm going to itt.  My mistake was misinterpreted your instructions.  I thought "console line" took care of telnet also.  I see now that I need to use "telnet line" separately.  Learn about 'Show the line' helped me understand.

    Thanks again.  If the behavior of Exchange today timeout I mark as resolved.

  • Restrict network guest/BYOD

    We received a preconfigured router, but it was not configured correctly. Initially, our guest and VLAN BYOD had no access to the internet. I added

    access-list 130 permit ip 192.168.2.0 0.0.0.255 any
    access-list 130 allow ip 192.168.3.0 0.0.0.255 any

    And as expected, there are now internet access, but there is also access to our internal network. I need to create a separate roadmap or set up access groups? Where can I I only allow traffic to 0.0.0.0 instead of somehow? Or I need to create deny rules?

    Port forwarding does not work, but I'm not sure this is the right place to ask about it.

    The config

    Building configuration...

    Current configuration: 7506 bytes
    !

    !
    version 15.4
    horodateurs service debug datetime msec
    Log service timestamps datetime msec
    no password encryption service
    !
    hostname NAME
    !
    boot-start-marker
    boot-end-marker
    !
    !
    logging buffered 51200 warnings
    !
    No aaa new-model
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    DHCP excluded-address IP 172.17.43.1 172.17.43.75
    DHCP excluded-address IP 192.168.2.1
    DHCP excluded-address IP 192.168.3.1
    !
    IP dhcp V pool
    network 172.17.43.0 255.255.255.0
    router by default - 172.17.43.1
    10.15.48.1 DNS server 172.17.42.4 8.8.8.8
    Rental 15
    !
    pool IP dhcp V2
    network 192.168.2.0 255.255.255.0
    default router 192.168.2.1
    172.17.43.7 DNS Server 8.8.8.8
    Rental 45
    !
    IP V3 dhcp pool
    network 192.168.3.0 255.255.255.0
    default router 192.168.3.1
    Server DNS 8.8.8.8
    !
    !
    !
    IP Domain.local domain name
    IP cef
    No ipv6 cef
    !
    Authenticated MultiLink bundle-name Panel
    !
    VPDN enable
    !
    VPDN-Group 1
    ! PPTP by default VPDN group
    accept-dialin
    Pptp Protocol
    virtual-model 5
    local name FS
    adjusting IP mtu
    !
    CTS verbose logging
    !
    Crypto pki trustpoint TP-self-signed-436626869
    enrollment selfsigned
    name of the object cn = IOS - Self - signed - certificate - 436626869
    revocation checking no
    rsakeypair TP-self-signed-436626869
    !
    !
    TP-self-signed-436626869 crypto pki certificate chain
    certificate self-signed 01

    quit smoking
    !
    !
    username user1 secret of privilege 15 5
    password username user2 privilege 7 0
    username secret privilege 15 user3 5
    username secret privilege 15 user4 5
    !
    redundancy
    !
    !
    !
    !
    !
    !
    !
    crypto ISAKMP policy 1
    BA 3des
    md5 hash
    preshared authentication
    Group 2
    lifetime 28800

    !
    !
    Crypto ipsec transform-set esp-3des esp-md5-hmac TRANSFORMZ
    tunnel mode
    Crypto ipsec transform-set esp-3des esp-md5-hmac TRANSFORMY
    tunnel mode
    !
    !
    !
    FMAP 10 ipsec-isakmp crypto map
    defined peer 2.3.4.5
    TRANSFORMZ transformation game
    match address 111
    FMAP 20 ipsec-isakmp crypto map
    defined peer 1.2.3.4
    game of transformation-TRANSFORMY
    match address 113
    !
    !
    !
    !
    !
    the Embedded-Service-Engine0/0 interface
    no ip address
    Shutdown
    !
    interface GigabitEthernet0/0
    Description of the WAN Interface
    IP x.x.x.x 255.255.255.0
    NAT outside IP
    IP virtual-reassembly in
    automatic duplex
    automatic speed
    No cdp enable
    FMAP crypto card
    !
    interface GigabitEthernet0/1
    no ip address
    automatic duplex
    automatic speed
    No cdp enable
    !
    interface GigabitEthernet0/1.1
    LAN Interface Description
    encapsulation dot1Q 1 native
    IP 172.17.43.1 255.255.255.0
    IP nat inside
    IP virtual-reassembly in
    No cdp enable
    !
    interface GigabitEthernet0/1.2
    BYOD LAN Interface Description
    encapsulation dot1Q 5
    IP 192.168.2.1 255.255.255.0
    IP nat inside
    IP virtual-reassembly in
    No cdp enable
    !
    interface GigabitEthernet0/1.3
    FSS-comments LAN Interface Description
    encapsulation dot1Q 6
    address 192.168.3.1 IP 255.255.255.0
    IP nat inside
    IP virtual-reassembly in
    No cdp enable
    !
    interface virtual-table 5
    IP unnumbered GigabitEthernet0/0
    ip address pool peer default PPTP-POOL
    PPP encryption mppe auto
    PPP authentication ms-chap-v2
    !
    local IP PPTP-POOL 10.20.100.1 pool 10.20.100.254
    IP forward-Protocol ND
    !
    IP http server
    23 class IP http access
    local IP http authentication
    IP http secure server
    IP http timeout policy slowed down 60 life 86400 request 10000
    !
    IP nat inside source map route SHEEP interface GigabitEthernet0/0 overload
    IP nat inside source static tcp 172.17.43.7 1194 x.x.x.x extensible 1194
    IP nat inside source static udp 172.17.43.7 1194 x.x.x.x extensible 1194
    IP route 0.0.0.0 0.0.0.0 5.5.5.1
    !
    !
    SHEEP allowed 10 route map
    corresponds to the IP 130
    !
    !
    access-list 1 permit 172.17.43.0 0.0.0.255
    access-list 23 allow 3.4.5.6
    access-list 23 allow 5.4.3.2
    access-list 23 allow 4.3.2.1
    access-list 23 permit 172.17.43.0 0.0.0.255
    access-list 23 allow 8.7.6.5 0.0.0.1
    access-list 23 allow 7.6.5.4 0.0.0.1
    access-list 23 allow 9.8.7.6 0.0.0.1
    access-list 111 allow ip 172.17.43.0 0.0.0.255 10.15.48.0 0.0.0.255
    access-list 113 allow ip 172.17.43.0 0.0.0.255 172.17.42.0 0.0.0.255
    access-list 130 deny ip 172.17.43.0 0.0.0.255 10.15.48.0 0.0.0.255
    access-list 130 deny ip 172.17.43.0 0.0.0.255 172.17.42.0 0.0.0.255
    access-list 130 allow ip 172.17.43.0 0.0.0.255 any
    access-list 130 permit ip 192.168.2.0 0.0.0.255 any
    access-list 130 allow ip 192.168.3.0 0.0.0.255 any
    !
    control plan
    !
    !
    Banner motd ^ CCCCC

    ******************************************
    * LEGAL NOTICE *.
    ******************************************

    Bonneau
    ^ C
    !
    Line con 0
    local connection
    line to 0
    line 2
    no activation-character
    No exec
    preferred no transport
    transport output pad rlogin lapb - your MOP v120 udptn ssh telnet
    StopBits 1
    line vty 0 4
    access-class 23 in
    privilege level 15
    local connection
    transport input telnet ssh
    line vty 5 15
    access-class 23 in
    privilege level 15
    local connection
    transport input telnet ssh
    !
    Scheduler allocate 20000 1000
    !
    end

    Hello

    You must use the access list 130 to control traffic between your internal network and the network BYOD. Create another list of nat access.

    Thank you

    John

  • Cisco 877W DHCP does not automatically fill the Windows/Mac customers with DNS server entries

    I have a 877W which was operational on Verizon for about 5 years. It never automatically distributed info DNS server for customers who get DHCP issued IP address. I have to manually enter the DNS entries to each client.  What happened to other sites where I've got installed on AT & T as well as 877 unified communications.

    Here is the config. Thanks in advance for the help.

    Building configuration...

    Current configuration: 7987 bytes
    !
    version 12.4
    no service button
    tcp KeepAlive-component snap-in service
    a tcp-KeepAlive-quick service
    horodateurs service debug datetime localtime show-timezone msec
    Log service timestamps datetime localtime show-timezone msec
    encryption password service
    sequence numbers service
    !
    Cod of hostname
    !
    boot-start-marker
    boot-end-marker
    !
    logging buffered debugging 51200
    recording console critical
    enable secret 5 jSwA $1$ $ 3B5lJNqm0ewh
    !
    AAA new-model
    !
    !
    AAA authentication local-to-remote login
    local remote of the AAA authorization network
    !
    AAA - the id of the joint session
    !
    resources policy
    !
    PCTime-6 timezone clock
    PCTime of summer time clock day April 6, 2003 02:00 October 26, 2003 02:00
    IP subnet zero
    IP cef
    No dhcp use connected vrf ip
    DHCP excluded-address IP 192.168.7.1 192.168.7.19
    DHCP excluded-address IP 192.168.7.70 192.168.7.254
    !
    IP dhcp pool sdm-pool1
    import all
    network 192.168.7.0 255.255.255.0
    router by default - 192.168.7.1
    DNS-server 68.238.96.12 68.238.112.12
    !
    !
    inspect the IP name DEFAULT100 cuseeme
    inspect the IP name DEFAULT100 ftp
    inspect the IP h323 DEFAULT100 name
    inspect the IP icmp DEFAULT100 name
    inspect the IP name DEFAULT100 netshow
    inspect the IP rcmd DEFAULT100 name
    inspect the IP name DEFAULT100 realaudio
    inspect the name DEFAULT100 rtsp IP
    inspect the IP name DEFAULT100 esmtp
    inspect the IP name DEFAULT100 sqlnet
    inspect the name DEFAULT100 streamworks IP
    inspect the name DEFAULT100 tftp IP
    inspect the tcp IP DEFAULT100 name
    inspect the IP udp DEFAULT100 name
    inspect the name DEFAULT100 vdolive IP
    synwait-time of tcp IP 10
    IP domain name cods.com
    name of the IP-server 68.238.96.12
    name of the IP-server 68.238.112.12
    property intellectual ssh time 60
    property intellectual ssh authentication-2 retries
    !
    !
    Crypto pki trustpoint TP-self-signed-437228204
    enrollment selfsigned
    name of the object cn = IOS - Self - signed - certificate - 437228204
    revocation checking no
    rsakeypair TP-self-signed-437228204
    !
    !
    TP-self-signed-437228204 crypto pki certificate chain
    certificate self-signed 01
    30820254 308201BD A0030201 02992101 300 D 0609 2A 864886 F70D0101 04050030
    2 060355 04031325 494F532D 53656 C 66 2 AND 536967 6E65642D 43657274 30312E30
    69666963 34333732 32383230 34301E17 303731 30313632 33333131 0D 6174652D
    395A170D 2E302C06 1325494F 03550403 32303031 30313030 30303030 5A 303031
    532D 5365 6C662D53 69676E65 4365 72746966 69636174 652 3433 37323238 642D
    06092A 86 4886F70D 01010105 32303430 819F300D 00308189 02818100 0003818D
    BF73E16C 24A3FB0B A44C83C8 45ACEC75 163C2F0A 87836F7F A43FEB72 0EF26AFA
    C7F35ED6 CBCC6853 5E82B0A6 1FD8020B F3630023 AB30B870 B3155EE6 86988910
    4ACF5121 1CBFF4DC B705DF1E 5D0D698F 06493 D 3DD8D036 42 FE450D21 E26A4DAF
    CE6BA806 81A9F451 0246698E DA7B49E3 160F115C E1104FA9 31FA3C15 CD 782 279
    02030100 01A37E30 7C300F06 03551 D 13 0101FF04 05300301 01FF3029 0603551D
    20821E63 11042230 6F64732E 6F666472 63697479 6E677370 69707069 72696E67
    732E636F 6D301F06 23 04183016 24 D 77493 80142FA3 03551D 52CF7094 B847B6EB
    1385E2E5 0F3A301D 0603551D 0E041604 142FA324 D7749352 CF7094B8 47B6EB13
    85E2E50F 3A300D06 092 HAS 8648 01040500 03818100 076EE499 12F46D79 86F70D01
    375B7EA6 C9279DA4 B32723B5 908C9FB8 D42CB978 BB24A8FE 73579A3D CA 5130, 87
    B7716644 7E13710D C6E6360C D0A36F7B F62540E2 0C33523B E50396B9 2EF66FA7
    56519E62 E55EAF3C E1D9BEC9 3AE67B59 75E61F06 B649E90A 2798F755 7A020F0A
    F8BDABFA 1EE37B6A A918560D DA45AD70 801BC66E 94D1468E
    quit smoking
    username privilege 15 secret $5 1jgO$sGD@#l4yTtLtYoEZbh/Wl steal551.
    !
    !
    door-key crypto vpn_ddaus
    pre-shared key address 0.0.0.0 0.0.0.0 - key stealthfortyfor5
    door-key crypto vpn_rmlfk
    address of pre-shared-key 205.30.134.22 key stealthfortyfor5
    !
    crypto ISAKMP policy 10
    md5 hash
    preshared authentication
    Group 2
    !
    crypto ISAKMP policy 30
    BA 3des
    preshared authentication
    Group 2
    invalid-spi-recovery crypto ISAKMP
    ISAKMP crypto keepalive 20
    !
    Configuration group isakmp crypto VPNRemote client
    key ConnectNow45
    pool ippool
    ISAKMP crypto vpnclient profile
    VPNRemote identity group match
    client authentication list for / remote
    Remote ISAKMP authorization list
    client configuration address respond
    Crypto isakmp CODS_DDAUS profile
    key ring vpn_ddaus
    function identity address 0.0.0.0
    Crypto isakmp CODS_RMLFK profile
    key ring vpn_rmlfk
    function identity address 205.30.134.22 255.255.255.255
    !
    !
    Crypto ipsec transform-set esp-3des esp-sha-hmac RIGHT
    !
    Crypto-map dynamic dynmap 10
    Set transform-set RIGHT
    vpnclient Set isakmp-profile
    Crypto-map dynamic dynmap 12
    Set transform-set RIGHT
    CODS_DDAUS Set isakmp-profile
    !
    !
    MYmap 1 ipsec-isakmp crypto map
    defined by peer 205.30.134.22
    Set transform-set RIGHT
    CODS_RMLFK Set isakmp-profile
    match address CODS_to_RMFLK
    map mymap 65535-isakmp ipsec crypto dynamic dynmap
    !
    Bridge IRB
    !
    !
    interface Loopback10
    IP 1.1.1.1 255.255.255.0
    !
    ATM0 interface
    no ip address
    route IP cache flow
    No atm ilmi-keepalive
    DSL-automatic operation mode
    !
    point-to-point interface ATM0.1
    Description $FW_OUTSIDE$ $ES_WAN$
    Check IP unicast reverse path
    inspect the DEFAULT100 over IP
    NAT outside IP
    IP virtual-reassembly
    PVC 0/35
    aal5snap encapsulation
    !
    Bridge-Group 2
    !
    interface FastEthernet0
    !
    interface FastEthernet1
    !
    interface FastEthernet2
    !
    interface FastEthernet3
    !
    interface Dot11Radio0
    no ip address
    no ip-cache cef route
    no ip route cache
    !
    encryption vlan 1 tkip encryption mode
    !
    SSID tsunami
    VLAN 1
    open authentication
    authentication wpa key management
    Comments-mode
    WPA - psk ascii 7 14231A0E01053324363F363B36150E050B08585E
    !
    base speed - 1.0 2.0 basic basic-5, 5 6.0 9.0 basic-11, 0 12.0 18.0 24.0 36.0 48.0 54.0
    root of station-role
    !
    interface Dot11Radio0.1
    encapsulation dot1Q 1 native
    no ip route cache
    no link-status of snmp trap
    No cdp enable
    Bridge-Group 1
    Bridge-group subscriber-loop-control 1
    Bridge-Group 1 covering-disabled people
    Bridge-Group 1 block-unknown-source
    No source of bridge-Group 1-learning
    unicast bridge-Group 1-floods
    !
    interface Vlan1
    Description $ETH - SW - LAUNCH, INTF-INFO-HWIC $$ $4ESW $FW_INSIDE$
    no ip address
    IP tcp adjust-mss 1452
    Bridge-Group 1
    !
    interface BVI1
    Description $ES_LAN$ $FW_INSIDE$
    192.168.7.1 IP address 255.255.255.0
    IP nat inside
    IP virtual-reassembly
    route IP cache flow
    IP tcp adjust-mss 1412
    !
    interface control2
    IP 70.14.49.134 255.255.255.0
    NAT outside IP
    IP virtual-reassembly
    crypto mymap map
    !
    local pool IP 10.10.10.1 ippool 10.10.10.254
    IP classless
    IP route 0.0.0.0 0.0.0.0 70.14.49.1
    !
    IP http server
    local IP http authentication
    IP http secure server
    IP http timeout policy slowed down 60 life 86400 request 10000
    overload of IP nat inside source list 133 interface control2
    !
    CODS_to_RMFLK extended IP access list
    IP 192.168.7.0 allow 0.0.0.255 192.168.1.0 0.0.0.255
    !
    recording of debug trap
    access-list 1 permit 192.168.7.0 0.0.0.255
    access-list 100 remark self-generated by the configuration of the firewall Cisco SDM Express
    Access-list 100 = 1 SDM_ACL category note
    access-list 100 deny ip 70.14.49.0 0.0.0.255 any
    access-list 100 deny ip 255.255.255.255 host everything
    access-list 100 deny ip 127.0.0.0 0.255.255.255 everything
    access ip-list 100 permit a whole
    access-list 101 permit ip 192.168.7.0 0.0.0.255 192.168.3.0 0.0.0.255
    access-list 133 deny ip 192.168.7.0 0.0.0.255 192.168.1.0 0.0.0.255
    access-list 133 deny ip 192.168.7.0 0.0.0.255 10.10.10.0 0.0.0.255
    access-list 133 deny ip 192.168.7.0 0.0.0.255 192.168.10.0 0.0.0.255
    access-list 133 deny ip 192.168.7.0 0.0.0.255 192.168.3.0 0.0.0.255
    access-list 133 allow ip 192.168.7.0 0.0.0.255 any
    not run cdp
    mymap permit 10 route map
    corresponds to the IP 111
    set ip next-hop 1.1.1.2
    !
    !
    control plan
    !
    Bridge Protocol ieee 1
    1 channel ip bridge
    Bridge Protocol ieee 2
    IP road bridge 2
    connection of the banner ^ CAuthorized access only!
    Unplug IMMEDIATELY if you are not an authorized user. ^ C
    !
    Line con 0
    no activation of the modem
    telnet output transport
    line to 0
    telnet output transport
    line vty 0 4
    privilege level 15
    transport input telnet ssh
    !
    max-task-time 5000 Planner
    Scheduler allocate 4000 1000
    Scheduler interval 500
    end

    Hello

    Can you try to remove the IMPORT ALL of the dhcp pool

    RES
    Paul

    Sent by Cisco Support technique iPad App

  • Cisco 881 can ping internet but computers behind the router cannot

    I have a cisco 881, which can ping internet but not of any computer behind it. Computers receive a static IP address, that is why there is no DHCP assigned to any LAN interface. Here's the running configuration:

    Building configuration...

    Current configuration: 6435 bytes
    !
    ! Last modification of the configuration at 22:15:30 UTC Friday, March 11, 2016
    !
    version 15.5
    no service button
    horodateurs service debug datetime msec
    Log service timestamps datetime msec
    no password encryption service
    !
    router host name
    !
    boot-start-marker
    boot-end-marker
    !
    !
    logging buffered 51200 warnings
    !
    No aaa new-model
    BSD-client server url https://cloudsso.cisco.com/as/token.oauth2
    iomem 10 memory size
    !
    Crypto pki trustpoint TP-self-signed-76299383
    enrollment selfsigned
    name of the object cn = IOS - Self - signed - certificate - 76299383
    revocation checking no
    rsakeypair TP-self-signed-76299383
    !
    !
    TP-self-signed-76299383 crypto pki certificate chain
    certificate self-signed 01
    30820227 30820190 A0030201 02020101 300 D 0609 2A 864886 F70D0101 05050030
    2F312D30 2B 060355 04031324 494F532D 66 2 536967 6E65642D 43657274 53656C
    69666963 37363239 39333833 31333031 33313231 30333034 301E170D 6174652D
    5A170D32 30303130 31303030 3030305A 302F312D 302B 0603 55040313 24494F53
    2D53656C D 662 5369 676E6564 2D 436572 74696669 63617465 2 373632 39393338
    3330819F 300 D 0609 2A 864886 F70D0101 01050003 818 0030 81890281 8100B39C
    1F1F1B5A 620D3DB7 E4B82486 D8A6E928 E880F817 20D8D5D8 744 HAS 6985 B48A0AEF
    072919 6ABF6428 C 9 272B2F4E 28382554 1D1CC5CD 701F9646 38EEE5CE 67F475C4
    DD5B464B ECBD78AF A5B6B36B D2791CFE E6CB886F B030E179 7A209BC4 1CDC6BA1
    711616 C 4FD6BE16 4 489DCC5F A5EE9729 365858FD 1654EA5F 3B7F90B2 19470203
    010001A 3 53305130 1 130101 FF040530 030101FF 301F0603 551 D 2304 0F060355
    18301680 1465D9D2 8C6F18DF 98EF832A 03DE7ADD 97301 06 03551D0E D45A6C59
    04160414 65D9D28C 6F18DF98 EF832A03 DE7ADDD4 5A6C5997 300 D 0609 2A 864886
    818100A 6 05050003 928BFD76 AEE144B3 540415EE 7DC2339D B6142CF6 F70D0101
    60E3A6DF 06DA321C B711183C 80755902 2D1D9407 857F05ED B987C08D 25002B5F
    F3C0F996 8CDA1830 3F85456B 6C6F2A4B 774B93DC 256AB90E 5A46126C C2D044DB
    3B76F1A2 0E98D2F0 A0D656CF 5031C7D7 1D9D2F88 188927 4 EEAA3915 E97C7B83
    ECF7239B 5B7F0FDD E4C9CA
    quit smoking
    !
    !
    !
    !
    !
    !
    !
    !

    !
    DHCP excluded-address IP 192.168.136.22 192.168.136.30
    DHCP excluded-address IP 192.168.131.22 192.168.131.254
    !
    IP dhcp Internet pool
    network 192.168.131.0 255.255.255.0
    DNS-server 70.28.245.227 184.151.118.254
    router by default - 192.168.131.157
    !
    !
    !
    name of the IP-server 70.28.245.227
    name of the IP-server 184.151.118.254
    IP cef
    No ipv6 cef
    !
    !
    !
    !
    !
    Authenticated MultiLink bundle-name Panel
    !
    !
    !
    !
    !
    !
    !
    !
    CTS verbose logging
    udi pid C881-K9 sn FGL1927224B standard license
    !
    !
    Archives
    The config log
    hidekeys
    username * 15 secret 5 privilege TOHi $1$ $ xwZvR0n8p6r00xE5nnBE11
    !
    !
    !
    !
    !
    !
    !
    crypto ISAKMP policy 1
    BA 3des
    preshared authentication
    Group 2
    isakmp encryption key * address 96.45.14.xx
    !
    !
    Crypto ipsec transform-set esp-SHA-ESP-3DES-3des esp-sha-hmac
    tunnel mode
    Crypto ipsec transform-set ESP-3DES-SHA1 esp-3des esp-sha-hmac
    tunnel mode
    Crypto ipsec transform-set esp-SHA2-ESP-3DES-3des esp-sha-hmac
    tunnel mode
    Crypto ipsec transform-set esp-3des SHA3-ESP-3DES esp-sha-hmac
    tunnel mode
    !
    !
    !
    map SDM_CMAP_1 1 ipsec-isakmp crypto
    Description Tunnel to96.45.14.xx
    the value of 96.45.14.xx peer
    game of transformation-ESP-3DES-SHA2
    match address 102
    !
    !
    !
    !
    !
    !
    interface FastEthernet0
    no ip address
    !
    interface FastEthernet1
    no ip address
    !
    interface FastEthernet2
    no ip address
    !
    interface FastEthernet3
    switchport access vlan 2
    no ip address
    !
    interface FastEthernet4
    port WAN Description
    DHCP IP address
    response to IP mask
    NAT outside IP
    IP virtual-reassembly in
    automatic duplex
    automatic speed
    map SDM_CMAP_1 crypto
    !
    interface Vlan1
    Description of control network
    IP 192.168.131.157 255.255.255.0
    IP access-group VLAN1_In in
    IP nat inside
    IP virtual-reassembly in
    !
    local pool IP VPN 192.168.131.152 192.168.131.155
    default IP gateway - 174.0.0.1
    IP forward-Protocol ND
    IP http server
    23 class IP http access
    local IP http authentication
    IP http secure server
    IP http timeout policy slowed down 60 life 86400 request 10000
    !
    IP high speed-flyers
    Top 10
    Sorting bytes
    !
    IP route 0.0.0.0 0.0.0.0 174.0.0.1 permanent
    !
    VLAN1_In extended IP access list
    Note the incoming traffic
    Note the category CCP_ACL = 1
    Note the crosstalk
    deny ip 192.168.135.0 0.0.0.255 192.168.130.0 0.0.1.255
    deny ip 192.168.136.0 0.0.0.255 192.168.130.0 0.0.1.255
    Note the crosstalk
    deny ip 192.168.130.0 0.0.1.255 192.168.135.0 0.0.0.255
    deny ip 192.168.130.0 0.0.1.255 192.168.136.0 0.0.0.255
    allow an ip
    VLAN1_Out extended IP access list
    Note for diagnosis
    Note the category CCP_ACL = 1
    Note Diag
    IP enable any any newspaper
    allow_all extended IP access list
    Note the category CCP_ACL = 1
    IP enable any any newspaper
    !
    !
    Note category of access list 1 = 2 CCP_ACL
    access-list 1 permit 192.168.1.0 0.0.0.255
    Note access-list category 2 CCP_ACL = 2
    access-list 2 permit 192.168.130.0 0.0.0.255
    Note access-list 100 category CCP_ACL = 4
    Note access-list 100 IPSec rule
    access-list 100 permit ip 192.168.131.0 0.0.0.255 192.168.125.0 0.0.0.255
    Note access-list 100 IPSec rule
    access-list 100 permit ip 192.168.131.0 0.0.0.255 192.168.120.0 0.0.0.255
    Note access-list 101 category CCP_ACL = 4
    Note access-list 101 IPSec rule
    access-list 101 permit ip 192.168.131.0 0.0.0.255 192.168.125.0 0.0.0.255
    Note access-list 102 CCP_ACL category = 4
    Note access-list 102 IPSec rule
    access-list 102 permit ip 192.168.131.128 0.0.0.31 192.168.125.0 0.0.0.255
    Note access-list 103 CCP_ACL category = 4
    Note access-list 103 IPSec rule
    access-list 103 allow ip 192.168.131.0 0.0.0.255 192.168.125.0 0.0.0.255
    !
    control plan
    !
    !
    !
    MGCP behavior considered range tgcp only
    MGCP comedia-role behavior no
    disable the behavior MGCP comedia-check-media-src
    disable the behavior of MGCP comedia-sdp-force
    !
    profile MGCP default
    !
    !
    !
    !
    !
    !
    !
    Line con 0
    no activation of the modem
    line to 0
    line vty 0 4
    access-class allow_all in
    access-class allow_all out
    privilege level 15
    password *.
    opening of session
    transport telnet entry
    telnet output transport
    !
    max-task-time 5000 Planner
    Scheduler allocate 20000 1000
    !
    !
    WebVPN WAN gateway
    IP address 192.168.126.9 port 44443
    redirect http port 80
    SSL trustpoint TP-self-signed-76299383
    development
    !
    WebVPN context PLC
    WAN gateway
    !
    SSL authentication check all
    development
    !
    default group policy
    functions compatible svc
    SVC-pool of addresses "VPN" netmask 255.255.255.224
    SVC Dungeon-client-installed
    generate a new key SVC new-tunnel method
    SVC split include 192.168.131.0 255.255.255.224
    mask-URL
    by default-default group policy
    !
    end

    Any ideas?

    Thank you.

    I see ip nat inside and ip nat outside interfaces configured on. But I don't see any translation of address configured. This would preclude anything inside the unit to be able to access the Internet.

    HTH

    Rick

  • Cisco 850 routing issues

    I am trying to configure a cisco 850 router but I can't do a ping to the outside world of Vlan1. show running-configLooks follow

    Current configuration : 5563 bytes!! Last configuration change at 15:33:02 UTC Sat Aug 13 2016 by ciscoversion 15.2no service padservice timestamps debug datetime msecservice timestamps log datetime msecno service password-encryption!hostname fw2.myfw.tld!boot-start-markerboot-end-marker!!logging buffered 51200 warnings!aaa new-model!!!!!!!aaa session-id commonwan mode ethernet!!!ip dhcp excluded-address 10.10.10.1ip dhcp excluded-address 192.168.1.1ip dhcp excluded-address 129.x.x.5!ip dhcp pool ccp-pool import all network 192.168.1.0 255.255.255.0 dns-server 8.8.8.8 8.8.4.4  default-router 192.168.1.1  lease 0 2!         !         !         ip domain name mydomain.tldip name-server 8.8.8.8ip name-server 8.8.4.4ip cef    no ipv6 cef!         !         !         !         crypto pki trustpoint TP-self-signed-1017650632 enrollment selfsigned subject-name cn=IOS-Self-Signed-Certificate-1017650632 revocation-check none rsakeypair TP-self-signed-1017650632!         !         crypto pki certificate chain TP-self-signed-1017650632 certificate self-signed 01  3082022B 30820194 A0030201 02020101 300D0609 2A864886 F70D0101 05050030   31312F30 2D060355 04031326 494F532D 53656C66 2D536967 6E65642D 43657274   69666963 6174652D 31303137 36353036 3332301E 170D3135 30343037 31303536   30375A17 0D323030 31303130 30303030 305A3031 312F302D 06035504 03132649   4F532D53 656C662D 5369676E 65642D43 65727469 66696361 74652D31 30313736   35303633 3230819F 300D0609 2A864886 F70D0101 01050003 818D0030 81890281   81008B15 A50BCE53 C1A10611 78247737 97E31A5D 653AF401 024B244B F96B48E0   0A1B41EE 16FBFDD1 46F2E1E2 1329D2C6 EEFBCF5B 217DE650 7D2729B0 266008F3   AC4565EA 53D7FA5B 35761F14 6FBDCFAC 24994667 CB0311A9 7FE25580 7D9564C3   BFE10A4A F5F57C4F C4E18EC9 19874BCA 03127F56 252D04B8 9465A23F FBB9045B   D9EF0203 010001A3 53305130 0F060355 1D130101 FF040530 030101FF 301F0603   551D2304 18301680 146EAE54 B0C95DC2 0561F596 BC47E94B EF80617E F9301D06   03551D0E 04160414 6EAE54B0 C95DC205 61F596BC 47E94BEF 80617EF9 300D0609   2A864886 F70D0101 05050003 81810014 F5B63E51 AD80D4A0 3230E94D 3D1BE457   5D7CF78D 3C911F32 C7238D24 4A8C84D5 D5D4F744 EA2FFD5C 4A40E7A1 A517BFE3   10CC6078 5F446A15 F60EA41E 08C688AF A7834485 0991C739 F3CA38FE CFAA31E2   C72031C1 BAEFA756 719E4903 705C98A7 E20CB004 6FC82D22 D4E62E0C DBA54481   F6A68B3D AA905352 DD76B19F CD4190        quit!         !         username cisco password 0 somepasswordusername admin privilege 15 secret 5 $1$JJZR$kw8yTTHkjUGKIfB8sQiyJ0!         !         controller VDSL 0 shutdown !         ip telnet source-interface Vlan1ip ssh port 2222 rotary 1ip ssh source-interface Vlan1ip ssh rsa keypair-name 1024!         !         !         !         !         !         !         !         !         !         !         !         interface ATM0 no ip address shutdown  no atm ilmi-keepalive!         interface Ethernet0 no ip address shutdown !         interface FastEthernet0 no ip address!         interface FastEthernet1 no ip address!         interface FastEthernet2 no ip address!         interface FastEthernet3 no ip address!         interface GigabitEthernet0 no ip address!         interface GigabitEthernet1 description PrimaryWANDesc_WAN interface ip address 129.x.x.5 255.255.255.0 duplex auto speed auto!         interface Vlan1 description $ETH_LAN$ ip address 192.168.1.1 255.255.255.0 ip helper-address 192.168.1.254 ip nat inside ip virtual-reassembly in ip tcp adjust-mss 1412!         ip forward-protocol ndip http serverip http access-class 23ip http authentication localip http secure-serverip http timeout-policy idle 60 life 86400 requests 10000!         !         ip dns serverip nat inside source list nat-list interface GigabitEthernet1 overloadip route 0.0.0.0 0.0.0.0 GigabitEthernet1!         mac-address-table aging-time 15no cdp run!         !         !         banner exec ^C% Password expiration warning.-----------------------------------------------------------------------
    
    Cisco Configuration Professional (Cisco CP) is installed on this device and it provides the default username "cisco" for  one-time use. If you have already used the username "cisco" to login to the router and your IOS image supports the "one-time" user option, then this username has already expired. You will not be able to login to the router with this username after you exit this session.
    
    It is strongly suggested that you create a new username with a privilege level of 15 using the following command.
    
    username <myuser> privilege 15 secret 0 <mypassword>
    
    Replace <myuser> and <mypassword> with the username and password you want to use.
    
    -----------------------------------------------------------------------^C        banner login ^C-----------------------------------------------------------------------Cisco Configuration Professional (Cisco CP) is installed on this device. This feature requires the one-time use of the username "cisco" with the password "cisco". These default credentials have a privilege level of 15.
    
    YOU MUST USE CISCO CP or the CISCO IOS CLI TO CHANGE THESE  PUBLICLY-KNOWN CREDENTIALS
    
    Here are the Cisco IOS commands.
    
    username <myuser>  privilege 15 secret 0 <mypassword>no username cisco
    
    Replace <myuser> and <mypassword> with the username and password you want to use.   
    
    IF YOU DO NOT CHANGE THE PUBLICLY-KNOWN CREDENTIALS, YOU WILL NOT BE ABLE TO LOG INTO THE DEVICE AGAIN AFTER YOU HAVE LOGGED OFF.
    
    For more information about Cisco CP please follow the instructions in the QUICK START GUIDE for your router or go to http://www.cisco.com/go/ciscocp -----------------------------------------------------------------------^C        !         line con 0 no modem enableline aux 0line vty 0 4 access-class 23 in privilege level 15 transport input telnet ssh!         scheduler allocate 60000 1000!         end   

    I am connected via the port console of the router and can ping the outside world only from port GigaEthernet1 whose IP address129.x.x.5

    Clients that connect on VLan1 get IP addresses in the range of 192.168.1.0/24 and these clients can ping each other, the gateway that is 192.168.1.1 and the GigaEthernet1 that has the intellectual property129.x.x.5

    What's not in this case?  Any suggestion is appreciated the most.

    			 
    @[email protected] / * /;
    Thanks for your post. I had a look at your configuration, and it is great that you are a few short steps on your NAT is why it does not work. Please follow the steps below in order to get this work properly.
    1. first of all, let us remove the old configuration NAT then back to a clean slate with the following commands.
    no ip nat inside source list nat-list interface GigabitEthernet1 overloadclear ip nat translation *
    2. now, we will create a list of access control allows for NAT traffic and create the new NAT statement for that tie together. * NOTE: If the version of IOS, you are running requires mask rather than generic then change 0.0.0.255 to 255.255.255.0.
    
    
    access-list 100 permit ip 192.168.1.0 0.0.0.255 anyip nat inside source list 100 interface GigabitEthernet1 overload
    3. the next step is to specify the logical role of the interfaces in question, whether they are 'inside' or ' outside'.
    
    
    interface vlan1 ip nat inside exitinterface GigabitEthernet1 ip nat outside exit
    4. Finally, save us the configuration and reload.
    
    
    copy run startreload
    After the unit is returned as a result of charging, please try again. In some cases - depending on the version of the IOS, you have to ping the outside world from a computer on the local network rather than just sourcing of the interface VLAN. Try this back and forth, and let me know how get you there. I can't wait to hear back.
    
    
    
    Kind regards
    
    
    Luke Oxley
    
    
    
    Please evaluate the useful messages and mark the correct answers.

Maybe you are looking for