PowerCLI script to list cluster name, comments, and host in the Cluster name

Greetings,

I need script to the cluster name, comments list Powercli and ESXi Hostnames in the Cluster, and then export to a csv file

Thank you

I suppose you want the name of the cluster, host name and comments for all your virtual machines. This information, you can export it to a file .csv as follows:

Get-VM |
Select-Object -Property @{N="VM";E={$_.Name}},
VMHost,
@{N="Cluster";E={$_.VMHost.Parent.Name}},
@{N="Guest";E={$_.Guest.OSFullName}} |
Export-Csv -Path VMInfo.csv -NoTypeInformation -UseCulture

Tags: VMware

Similar Questions

  • Once I do a text comment and click outside the comment, my comment fades lighter than the color of multiple shades, in which it was typed. Someone knows how to fix this?

    Once I do a text comment and click outside the comment, my comment fades lighter than the color of multiple shades, in which it was typed. Someone knows how to fix this?

    Maybe the opacity for the comments of text setting is set to a value lower than 100%... The problem is that there is no way to change it except by using a script.

    Here's how you can do it. After you have created your comment, click on it with the mouse and press Ctrl + J to open the JS Console window.

    In the lower part of the window clear the text that is there and enter this instead and then press Ctrl + Enter:

    this.selectedAnnots [0] .opacity = 1;

    This should change the level of opacity for the comment selected 100%.

    If it works then right click on the comment, go to properties and then click on the 'Make default properties' box and click OK.

    It should now be fixed for any comment that you create.

  • How to submit your comments and suggestions to the team of Keynote?

    Is it possible to send your comments and requests to the Keynote team?

    Hello Frederic,.

    Thank you for using communities of Apple Support.

    You can provide your comments and ask the team to Keynote here: http://www.apple.com/feedback/keynote.html

    Not who he says at this link, Apple does not meet the comments made here.

    Best regards.

  • PowerCLI script to list the df - hl on all ESX hosts?

    Hi Expert,

    I have more than 100 esx host, and I need to list all the df - hl out for my report. Y at - it instead of connect on each esx host to get under output, powercli script that I can use to remove similar information?

    Size of filesystem used Avail use % mounted on

    / dev/sdaa2 20G 1.5 G 17G 8%.

    / dev/CCISS/c0d0p1 1.1 G 118 M 909 M 12% / Boot

    / dev/sdaa6 9.7 G 151 M 9.0 G 2% / Home

    / dev/sdaa7 9.7 G 151 M 9.0 G 2% / tmp

    / dev/sdaa5 9.7 G 317 M 8.9 G 4% / var

    / dev/sdaa8 494M 212 M 257M 46% /vmimages

    Please advice. Thank you

    Are you allowed to enable SSH on servers ESX (i)?

    And are you allowed to establish a SSH session on each ESX (i) Server?

    You have an account and a password on each ESX (i) server that can run the command 'df '?

    If it is Yes, then you can use something like plink.exe in consequence of PuTTY to connect to each ESX (i) server, run the command "df" and retrieve the output.

    There are several available examples to use plink.

    And don't forget that you will need a fingerprint for each server ESX (i) will be stored on the client from which you are running the script.

  • Create hyperlinks with script, without increase of large size and treatment of the BP reqs resulting?

    Quick Summary: I have a script as part of a process involving a lengthy document of data merge base that creates hyperlinks by using doc.hyperlinkURLDestinations.add (). The script is simply extracted from text into clickable hyperlinks.

    The problem is, the final PDF files that emerge from this process are 300% the size of a PDF file without the running script and are very slow to deal with. Most of that extra weight from an increase of 740 000% crazy (!) in the amount of data used for "info-Structure" (and that's after you run the version with hyperlinks through the Acrobat PDF Optimizer).

    The amount of the data structure in the PDF files with hyperlinks ends up being more than twice the size of the entire file PDF files without hyperlinks added. There is also a substantial increase in the size of the "the cross reference Table.

    This sharp increase in weight becomes a quick and simple process which takes a few minutes in a slow winding which takes hours, to the creation of files with a very slow pace inflated in a process that is prone to crashing and not.

    I hope for another way to create hyperlinks that adds all this weight.

    --------------------------------

    Details: Here is my current process. It works fine except step 2 causes the final size of the PDF file and the time required for the execution of other processes to increase massively. I know there are different ways to implement hyperlinks in a PDF document - I hope that there is a different approach, that I can use to step 2 which avoids this massive expansion.

    The goal is to create 600 2 PDF pages from an indesign template using the fusion of data, with each PDF with a file name that reflects reviews and live hyperlinks which vary from one record to the next. Here is my current process (for analysis comparative, the machine is a Mac Pro, Lion, CS6, with RAM 6gbs, and all files are on a disk HARD space, no transfer of data on all networks):

    1. Implement an INDD 2 pages with placeholders for merging data and spreadsheet.
    2. Create merged INDD, import hypertext links and other content as text, then run this script in InDesign that makes hyperlinks using live doc.hyperlinkURLDestinations.add ()
    3. Export a PDF to 1 200 PDF page - file > export if step 2 was made, or the merger of data tool if it wasn't.
      • Without step 2: the PDF file is about 110mbs and takes a few minutes to create.
      • Step 2: the PDF file is about 170mbs and takes over an hour and a half to create - I do not know exactly how long I ended up leaving running from one day to the next, but he had already run 1: 20 p.m. when I left and doesn't look close to finishing.
    4. Run this script in Acrobat to chop the PDF into segments of 2 pages with names based on worksheet data.
      • Without step 2: the process takes about quarter of an hour, slightly faster than a secondcreation of PDF files, and PDF files are 700kbs.
      • Step 2: the process crashes after about 10 PDF files and takes minutes to produce each one. Even if it did not freeze, it should be about 25 hours to do all of them.
      • In step 2 and then reducing the PDF to 45mbs through optimizer PDF Acrobat and 'save in reduced format' to cut, backward, compatibility, the process takes about 4 hours, producing a PDF every 20-30 seconds, and PDF files are around 3 MB each. Through to watch the process, almost all of the extra time taken comes from step "backup PDF... "for each of them.

    Each PDF 2 pages has 14 or 15 of the hyperlinks. I do not understand how the 14 and 15 of the hyperlinks can translate into an additional 2mbs of "" and something like the processing time of more than 3500% to create each PDF file.

    Can someone suggest modifications to the script in step three, which could avoid all this overhead? Here's the complete script for convenience:

    app.findGrepPreferences = app.changeGrepPreferences = null;

    var doc = app.activeDocument;

    app.findGrepPreferences.findWhat = '(http://.*$|https://.*$)';

    var objs = doc.findGrep();

     

    for (var i = 0; i < objs.length; i++) {

        var currTarget  = objs[i];

        var lnkDest = doc.hyperlinkURLDestinations.add(currTarget.texts[0].contents);

        var lnkSrc = doc.hyperlinkTextSources.add(currTarget);

        var lnk = doc.hyperlinks.add(lnkSrc, lnkDest);

    }

    alert('Processed '+objs.length+' hyperlinks');

    Edit - Here is a side-by-side comparison of the "Use of space Audit" tool optimizer based on CSSTidy Acrobat PDF, showing where the hyperlinks add volume. I scored two sharp increases in red...

    acrobat-audit.png

    .. .so there is a massive increase going crazy in the size of the info "Structure", a tiny mbs 0.000238 to 1.76 MB - two and a half times the size of the original file, just on 'info Structure. It's a 740 000% increase...

    There is also a strong increase in fat in the cross reference table, 0,0046 mbs to 0.427 mbs - table of cross-references in the PDF with hyperlinks is more than half the size of the original file.

    The only differences between two files PDF's, we have 14 clickable hyperlinks attached to existing excerpts of the text (the "hyperlinks" are from a PDF file that comes with living aggressive optimization PDF and images are so much smaller).

    So it turns out the source of the problem was the document tags.

    Make sure that the PDF file is not created as a PDF by InDesign Tagged, and it behaves. I don't know what is it about hyperlinks and marking that makes it swell massively, but it does.

  • Drop-down list: distinguish between programming and modification of the user

    I have a drop-down list with a few options, the selected displays current status.

    The State can change programmatically I have to update the drop-down list.

    I want to distinguish between this change programme and focused on the user.

    No idea how I could do this?

    The classic solution to this problem is to add a flag (Boolean property) that you control, and which inhibits the onThingChanged response when set. You set this just before you perform a change of programming and clear right after. When the change is made by the user, the flag will be clear and the onThingChanged would do its thing.

    There may be other ways to do this in specific cases, but this approach has worked in all situations in which I have tried so far.

  • Acrobat pro XI: how to accept a comment, and then replace the old text?

    My Office Manager began a PDF for review through four managers and sent me the PDF commented to change.  In WORD, there is a button I accept and changes are corrected in the original doc.

    I see all kinds of information on the management of comments, print them etc, but none on the execution of this function which makes of the WORD.

    I try to cut and paste all (271) comments in a word doc so I don't have to do this again.

    Any suggestions before I lose half of my day?

    Hi stephens78119216,

    I'm sorry, but unlike word, there no function in Acrobat to accept changes made in the document.

    Although you can follow reviews added in the PDF file.

    Ref: Acrobat Help. Follow-up and management of PDF comments on

    Kind regards

    Ana Maria

  • HTTPS protocol between the client vpn and host of the internet through tunnel ipsec-parody

    Hello

    We have a cisco ASA 5505 and try to get the next job:

    ip (192.168.75.5) - connected to the Cisco ASA 5505 VPN client

    the customer gets a specific route for an internet address (79.143.218.35 255.255.255.255 192.168.75.1 192.168.75.5 100)

    When I try to access the url of the client, I get a syn sent with netstat

    When I try trace ASA package, I see the following:

    1

    FLOW-SEARCH

    ALLOW

    Not found no corresponding stream, creating a new stream

    2

    ROUTE SEARCH

    entry

    ALLOW

    in 0.0.0.0 0.0.0.0 outdoors

    3

    ACCESS-LIST

    Journal

    ALLOW

    Access-group outside_access_in in interface outside

    outside_access_in list extended access permitted tcp everything any https eq

    access-list outside_access_in note hyperion outside inside

    4

    IP-OPTIONS

    ALLOW

    5

    CP-PUNT

    ALLOW

    6

    VPN

    IPSec-tunnel-flow

    ALLOW

    7

    IP-OPTIONS

    ALLOW

    8

    VPN

    encrypt

    ALLOW

    outdoors

    upward

    upward

    outdoors

    upward

    upward

    drop

    (ipsec-parody) Parody of detected IPSEC

    When I try the reverse (i.e. from the internet host to vpn client), it seems to work:

    1

    FLOW-SEARCH

    ALLOW

    Not found no corresponding stream, creating a new stream

    2

    ROUTE SEARCH

    entry

    ALLOW

    in 192.168.75.5 255.255.255.255 outside

    3

    ACCESS-LIST

    Journal

    ALLOW

    Access-group outside_access_in in interface outside

    outside_access_in of access allowed any ip an extended list

    4

    IP-OPTIONS

    ALLOW

    5

    VPN

    IPSec-tunnel-flow

    ALLOW

    6

    VPN

    encrypt

    ALLOW

    My question is why this phenomenon happens and how solve us this problem?

    Thanks in advance, Sipke

    our running-config:

    : Saved

    :

    ASA Version 8.0 (4)

    !

    ciscoasa hostname

    domain somedomain

    activate the password - encrypted

    passwd - encrypted

    names of

    name 10.10.1.0 Hyperion

    name 164.140.159.x xxxx

    name 192.168.72.25 xxxx

    name 192.168.72.24 xxxx

    name 192.168.72.196 xxxx

    name 192.168.75.0 vpn clients

    name 213.206.236.0 xxxx

    name 143.47.160.0 xxxx

    name 141.143.32.0 xxxx

    name 141.143.0.0 xxxx

    name 192.168.72.27 xxxx

    name 10.1.11.0 xxxx

    name 10.1.2.240 xxxx

    name 10.1.1.0 xxxx

    name 10.75.2.1 xxxx

    name 10.75.2.23 xxxx

    name 192.168.72.150 xxxx

    name 192.168.33.0 xxxx

    name 192.168.72.26 xxxx

    name 192.168.72.5 xxxx

    name 192.168.23.0 xxxx

    name 192.168.34.0 xxxx

    name 79.143.218.35 inethost

    !

    interface Vlan1

    nameif inside

    security-level 100

    IP 192.168.72.254 255.255.255.0

    OSPF cost 10

    !

    interface Vlan2

    nameif outside

    security-level 0

    IP address 193.173.x.x 255.255.255.240

    OSPF cost 10

    !

    interface Vlan3

    Shutdown

    nameif dmz

    security-level 50

    192.168.50.1 IP address 255.255.255.0

    OSPF cost 10

    !

    interface Vlan23

    nameif wireless

    security-level 80

    192.168.40.1 IP address 255.255.255.0

    OSPF cost 10

    !

    interface Ethernet0/0

    switchport access vlan 2

    !

    interface Ethernet0/1

    !

    interface Ethernet0/2

    !

    interface Ethernet0/3

    !

    interface Ethernet0/4

    !

    interface Ethernet0/5

    switchport access vlan 3

    !

    interface Ethernet0/6

    switchport access vlan 23

    !

    interface Ethernet0/7

    !

    passive FTP mode

    clock timezone THATS 1

    clock to summer time CEDT recurring last Sun Mar 02:00 last Sun Oct 03:00

    DNS lookup field inside

    DNS server-group DefaultDNS

    domain pearle.local

    permit same-security-traffic inter-interface

    permit same-security-traffic intra-interface

    object-group Protocol TCPUDP

    object-protocol udp

    object-tcp protocol

    object-group service RDP - tcp

    Remote Desktop Protocol Description

    EQ port 3389 object

    object-group service UDP - udp VC

    range of object-port 60000 60039

    object-group VC - TCP tcp service

    60000 60009 object-port Beach

    object-group service tcp Fortis

    1501 1501 object-port Beach

    Beach of port-object 1502-1502

    Beach of port-object sqlnet sqlnet

    1584 1584 object-port Beach

    1592 1592 object-port Beach

    object-group service tcp fortis

    1592 1592 object-port Beach

    Beach of port-object 1502-1502

    1584 1584 object-port Beach

    Beach of port-object sqlnet sqlnet

    1501 1501 object-port Beach

    1500 1500 object-port Beach

    the DM_INLINE_NETWORK_1 object-group network

    object-network 192.168.50.0 255.255.255.0

    object-network 192.168.72.0 255.255.255.0

    object-network 192.168.40.0 255.255.255.0

    object-network VPN_Pool_2 255.255.255.0

    the DM_INLINE_NETWORK_2 object-group network

    object-network 192.168.50.0 255.255.255.0

    object-network 192.168.72.0 255.255.255.0

    object-group network inside-networks

    object-network 192.168.72.0 255.255.255.0

    WingFTP_TCP tcp service object-group

    Secure FTP description

    port-object eq 989

    port-object eq 990

    DM_INLINE_TCP_1 tcp service object-group

    port-object eq ftp

    port-object eq ftp - data

    Group object WingFTP_TCP

    DM_INLINE_TCP_2 tcp service object-group

    port-object eq ftp

    port-object eq ftp - data

    Group object WingFTP_TCP

    the DM_INLINE_NETWORK_3 object-group network

    object-network 192.168.72.0 255.255.255.0

    object-network VPN_Pool_2 255.255.255.0

    the DM_INLINE_NETWORK_4 object-group network

    object-network 192.168.72.0 255.255.255.0

    object-network VPN_Pool_2 255.255.255.0

    object-group network Oracle

    network-object OracleTwo 255.255.224.0

    network-object OracleOne 255.255.240.0

    network-object OracleThree 255.255.224.0

    the DM_INLINE_NETWORK_5 object-group network

    network-object Grandvision 255.255.255.0

    network-object Grandvision2 255.255.255.240

    object-network Grandvision3 255.255.255.0

    host of the object-Network Grandvision4

    host of the object-Network GrandVision_PC

    the DM_INLINE_NETWORK_6 object-group network

    network-object Grandvision 255.255.255.0

    network-object Grandvision2 255.255.255.240

    object-network Grandvision3 255.255.255.0

    host of the object-Network Grandvision4

    host of the object-Network GrandVision_PC

    the DM_INLINE_NETWORK_7 object-group network

    network-object Grandvision 255.255.255.0

    network-object Grandvision2 255.255.255.240

    object-network Grandvision3 255.255.255.0

    host of the object-Network GrandVision_PC

    the DM_INLINE_NETWORK_8 object-group network

    network-object Grandvision 255.255.255.0

    network-object Grandvision2 255.255.255.240

    object-network Grandvision3 255.255.255.0

    host of the object-Network GrandVision_PC

    object-group service DM_INLINE_SERVICE_2

    the purpose of the ip service

    EQ-3389 tcp service object

    the DM_INLINE_NETWORK_9 object-group network

    network-object OracleThree 255.255.0.0

    network-object OracleTwo 255.255.224.0

    network-object OracleOne 255.255.240.0

    object-group service DM_INLINE_SERVICE_3

    the purpose of the ip service

    EQ-3389 tcp service object

    Atera tcp service object-group

    Atera Webbased monitoring description

    8001 8001 object-port Beach

    8002 8002 object-port Beach

    8003 8003 object-port Beach

    WingFTP_UDP udp service object-group

    port-object eq 989

    port-object eq 990

    WingFTP tcp service object-group

    Description range of ports for the transmission of data

    object-port range 1024-1054

    HTTPS_redirected tcp service object-group

    Description redirect WingFTP Server

    port-object eq 40200

    Note to inside_access_in to access list ICMP test protocol inside outside

    inside_access_in list extended access allow icmp 192.168.72.0 255.255.255.0 any

    Note to inside_access_in to access list ICMP test protocol inside outside

    access-list inside_access_in note HTTP inside outside

    inside_access_in list extended access allowed object-group TCPUDP 192.168.72.0 255.255.255.0 any eq www

    access-list inside_access_in note queries DNS inside to outside

    inside_access_in list extended access allowed object-group TCPUDP 192.168.72.0 255.255.255.0 no matter what eq field

    access-list inside_access_in note the HTTPS protocol inside and outside

    inside_access_in list extended access permitted tcp 192.168.72.0 255.255.255.0 any https eq

    Note to inside_access_in to access list ICMP test protocol inside outside

    access-list inside_access_in note 7472 Epo-items inside outside

    inside_access_in list extended access permitted tcp 192.168.72.0 255.255.255.0 any eq 7472

    access-list inside_access_in note POP3 inside outside

    inside_access_in list extended access permitted tcp 192.168.72.0 255.255.255.0 any eq pop3

    inside_access_in list extended access permit udp host LifeSize-PE-HQ any object-group UDP - VC

    inside_access_in list extended access permit tcp host LifeSize-PE-HQ all eq h323

    access-list inside_access_in note video conference services

    inside_access_in list extended access permit tcp host LifeSize-PE-HQ any object-group VC - TCP

    inside_access_in list extended access permitted tcp 192.168.72.0 255.255.255.0 any

    Note to inside_access_in to access list Fortis

    inside_access_in list extended access permitted tcp 192.168.72.0 255.255.255.0 any object-group Fortis

    access extensive list ip 192.168.40.0 inside_access_in allow 255.255.255.0 any

    inside_access_in list extended access permitted tcp 192.168.40.0 255.255.255.0 any

    inside_access_in list extended access permitted tcp 192.168.40.0 255.255.255.0 any eq www

    inside_access_in list extended access permitted tcp 192.168.40.0 255.255.255.0 any https eq

    inside_access_in allowed all Hyperion 255.255.255.0 ip extended access list

    inside_access_in list extended access udp allowed any any eq isakmp

    inside_access_in list extended access udp allowed any any eq ntp

    inside_access_in list extended access udp allowed any any eq 4500

    inside_access_in list of allowed ip extended access any Oracle object-group

    inside_access_in list extended access udp allowed any any eq 10000

    access-list inside_access_in note PPTP inside outside

    inside_access_in list extended access permit tcp any any eq pptp

    access-list inside_access_in note WILL inside outside

    inside_access_in list extended access will permit a full

    Note to inside_access_in to access the Infrastructure of the RIM BES server list

    inside_access_in list extended access permit tcp host BESServer any eq 3101

    inside_access_in list extended access permit tcp any any DM_INLINE_TCP_2 object-group

    inside_access_in list extended access permit tcp any any HTTPS_redirected object-group

    access extensive list ip Hyperion 255.255.255.0 inside_access_in 255.255.255.0 allow VPN_Pool_2

    inside_access_in list extended access permit udp any host 86.109.255.177 eq 1194

    access extensive list ip 192.168.72.0 inside_access_in allow 255.255.255.0 DM_INLINE_NETWORK_7 object-group

    access extensive list ip VPN_Pool_2 inside_access_in allow 255.255.255.0 any

    inside_access_in list extended access deny ip any any inactive debug log

    Note to outside_access_in to access list ICMP test protocol outside inside

    outside_access_in list extended access permit icmp any one

    access-list outside_access_in Note SMTP outside inside

    outside_access_in list extended access permit tcp any any eq smtp

    outside_access_in list extended access udp allowed any any eq ntp disable journal

    access-list outside_access_in note 7472 EPO-items outside inside

    outside_access_in list extended access permit tcp any any eq 7472

    outside_access_in list extended access permit tcp any any object-group inactive RDP

    outside_access_in list extended access permit tcp any any eq www

    outside_access_in list extended access permit tcp any any HTTPS_redirected object-group

    outside_access_in list extended access permitted tcp everything any https eq

    access-list outside_access_in note hyperion outside inside

    outside_access_in list extended access permitted tcp Hyperion 255.255.255.0 DM_INLINE_NETWORK_4 object-group

    outside_access_in to access Hyperion 255.255.255.0 ip extended list object-group DM_INLINE_NETWORK_3 allow

    outside_access_in list extended access permit tcp any host LifeSize-PE-HQ eq h323

    outside_access_in list extended access permit tcp any host LifeSize-PE-HQ object-group VC - TCP

    outside_access_in list extended access permit udp any host group-object-LifeSize-PE-HQ UDP - VC

    outside_access_in of access allowed any ip an extended list

    outside_access_in list extended access udp allowed any any eq 4500

    outside_access_in list extended access udp allowed any any eq isakmp

    outside_access_in list extended access udp allowed any any eq 10000

    outside_access_in list extended access will permit a full

    outside_access_in list extended access permit tcp any any eq pptp

    outside_access_in list extended access permit tcp any any DM_INLINE_TCP_1 object-group

    outside_access_in list extended access allowed object-group ip DM_INLINE_NETWORK_8 192.168.72.0 255.255.255.0 inactive

    outside_access_in list extended access permit tcp any any Atera object-group

    outside_access_in list extended access deny ip any any inactive debug log

    outside_1_cryptomap list extended access allowed object-group Hyperion DM_INLINE_NETWORK_2 255.255.255.0 ip

    outside_1_cryptomap to access extended list ip 192.168.50.0 allow Hyperion 255.255.255.0 255.255.255.0

    access extensive list ip 192.168.72.0 inside_nat0_outbound allow Hyperion 255.255.255.0 255.255.255.0

    inside_nat0_outbound list of allowed ip extended access all 193.172.182.64 255.255.255.240

    inside_nat0_outbound list of allowed ip extended access all 192.168.72.192 255.255.255.192

    inside_nat0_outbound list of allowed ip extended access all 192.168.72.0 255.255.255.0

    access extensive list ip 192.168.72.0 inside_nat0_outbound allow 255.255.255.0 VPN_Pool_2 255.255.255.0

    access extensive list ip 192.168.72.0 inside_nat0_outbound allow 255.255.255.0 DM_INLINE_NETWORK_5 object-group

    inside_nat0_outbound list of allowed ip extended access all GrandVisionSoesterberg 255.255.255.0

    inside_nat0_outbound list of allowed ip extended access any Swabach 255.255.255.0

    access-list 200 scope allow tcp all fortis of fortis host object-group

    access extensive list ip VPN_Pool_2 outside_nat0_outbound allow 255.255.255.0 DM_INLINE_NETWORK_9 object-group

    outside_cryptomap_2 list extended access allowed object-group Hyperion DM_INLINE_NETWORK_1 255.255.255.0 ip

    outside_cryptomap_2 to access extended list ip 192.168.50.0 allow Hyperion 255.255.255.0 255.255.255.0

    Note Wireless_access_in of access list, select Hyperion / wifi access NAT rule.

    Access extensive list ip 192.168.40.0 Wireless_access_in allow Hyperion inactive 255.255.255.0 255.255.255.0

    Wireless_access_in list extended access deny ip 192.168.40.0 255.255.255.0 192.168.72.0 255.255.255.0

    Comment by Wireless_access_in-list of the traffic Internet access

    Access extensive list ip 192.168.40.0 Wireless_access_in allow 255.255.255.0 any

    standard access list splittunnelclientvpn allow 192.168.72.0 255.255.255.0

    splittunnelclientvpn list standard access allowed Hyperion 255.255.255.0

    standard access list splittunnelclientvpn allow Pearleshare 255.255.255.0

    splittunnelclientvpn list standard access allowed host 85.17.235.22

    splittunnelclientvpn list standard access allowed OracleThree 255.255.224.0

    standard access list splittunnelclientvpn allow 143.47.128.0 255.255.240.0

    splittunnelclientvpn list standard access allowed host inethost

    Standard access list SplittnlHyperion allow OracleThree 255.255.0.0

    Standard access list SplittnlOOD allow OracleThree 255.255.0.0

    Standard access list SplittnlOOD allow 143.47.128.0 255.255.240.0

    access extensive list ip 192.168.72.0 outside_cryptomap allow 255.255.255.0 DM_INLINE_NETWORK_6 object-group

    outside_cryptomap_1 list of allowed ip extended access all GrandVisionSoesterberg 255.255.255.0

    outside_cryptomap_3 list of allowed ip extended access any Swabach 255.255.255.0

    192.168.72.0 IP Access-list extended sheep 255.255.255.0 GrandVisionSoesterberg 255.255.255.0 allow

    192.168.72.0 IP Access-list extended sheep 255.255.255.0 VPN_Pool_2 255.255.255.0 allow

    pager lines 24

    Enable logging

    asdm of logging of information

    Within 1500 MTU

    Outside 1500 MTU

    MTU 1500 dmz

    MTU 1500 wireless

    local pool VPN_DHCP 192.168.72.220 - 192.168.72.235 255.255.255.0 IP mask

    mask 192.168.75.1 - 192.168.75.50 255.255.255.0 IP local pool VPN_Range_2

    no failover

    ICMP unreachable rate-limit 1 burst-size 1

    ICMP allow any inside

    ICMP allow all outside

    ASDM image disk0: / asdm - 613.bin

    don't allow no asdm history

    ARP timeout 14400

    Global 1 interface (outside)

    NAT (inside) 0 access-list sheep

    NAT (inside) 1 0.0.0.0 0.0.0.0

    NAT (wireless) 1 192.168.40.0 255.255.255.0

    public static tcp (indoor, outdoor) interface smtp smtp Mailsrv_Pearle_Europe netmask 255.255.255.255

    public static tcp (indoor, outdoor) interface ftp ftp netmask 255.255.255.255 Pearle-DC02

    public static 990 Pearle-DC02 990 netmask 255.255.255.255 interface tcp (indoor, outdoor)

    static (inside, outside) tcp 3389 3389 Mailsrv_Pearle_Europe netmask 255.255.255.255 interface

    public static tcp (indoor, outdoor) interface www Pearle-DC02 www netmask 255.255.255.255

    public static 40200 Pearle-DC02 40200 netmask 255.255.255.255 interface tcp (indoor, outdoor)

    public static tcp (indoor, outdoor) interface https Exchange2010 https netmask 255.255.255.255

    public static tcp (indoor, outdoor) interface h323 h323 LifeSize-PE-HQ netmask 255.255.255.255

    public static 60000 60000 LifeSize-PE-HQ netmask 255.255.255.255 interface tcp (indoor, outdoor)

    public static 60001 LifeSize-PE-HQ 60001 netmask 255.255.255.255 interface tcp (indoor, outdoor)

    public static 60002 LifeSize-PE-HQ 60002 netmask 255.255.255.255 interface tcp (indoor, outdoor)

    public static 60003 LifeSize-PE-HQ 60003 netmask 255.255.255.255 interface tcp (indoor, outdoor)

    public static 60004 LifeSize-PE-HQ 60004 netmask 255.255.255.255 interface tcp (indoor, outdoor)

    public static 60005 LifeSize-PE-HQ 60005 netmask 255.255.255.255 interface tcp (indoor, outdoor)

    public static 60006 LifeSize-PE-HQ 60006 netmask 255.255.255.255 interface tcp (indoor, outdoor)

    public static 60007 LifeSize-PE-HQ 60007 netmask 255.255.255.255 interface tcp (indoor, outdoor)

    public static 60008 LifeSize-PE-HQ 60008 netmask 255.255.255.255 interface tcp (indoor, outdoor)

    public static 60009 LifeSize-PE-HQ 60009 netmask 255.255.255.255 interface tcp (indoor, outdoor)

    public static (inside, outside) udp interface 60001 LifeSize-PE-HQ 60001 netmask 255.255.255.255

    public static (inside, outside) udp interface 60002 LifeSize-PE-HQ 60002 netmask 255.255.255.255

    public static (inside, outside) udp interface 60003 LifeSize-PE-HQ 60003 netmask 255.255.255.255

    public static (inside, outside) udp interface 60004 LifeSize-PE-HQ 60004 netmask 255.255.255.255

    public static (inside, outside) udp interface 60005 LifeSize-PE-HQ 60005 netmask 255.255.255.255

    public static (inside, outside) udp interface 60006 LifeSize-PE-HQ 60006 netmask 255.255.255.255

    public static (inside, outside) udp interface 60007 LifeSize-PE-HQ 60007 netmask 255.255.255.255

    public static (inside, outside) udp interface 60008 LifeSize-PE-HQ 60008 netmask 255.255.255.255

    public static (inside, outside) udp interface 60009 LifeSize-PE-HQ 60009 netmask 255.255.255.255

    public static (inside, outside) udp interface 60010 LifeSize-PE-HQ 60010 netmask 255.255.255.255

    public static (inside, outside) udp interface 60011 LifeSize-PE-HQ 60011 netmask 255.255.255.255

    public static (inside, outside) udp interface 60012 LifeSize-PE-HQ 60012 netmask 255.255.255.255

    public static (inside, outside) udp interface 60013 LifeSize-PE-HQ 60013 netmask 255.255.255.255

    public static (inside, outside) udp interface 60014 LifeSize-PE-HQ 60014 netmask 255.255.255.255

    public static (inside, outside) udp interface 60015 LifeSize-PE-HQ 60015 netmask 255.255.255.255

    public static (inside, outside) udp interface 60016 LifeSize-PE-HQ 60016 netmask 255.255.255.255

    public static (inside, outside) udp interface 60017 LifeSize-PE-HQ 60017 netmask 255.255.255.255

    public static (inside, outside) udp interface 60018 LifeSize-PE-HQ 60018 netmask 255.255.255.255

    public static (inside, outside) udp interface 60019 LifeSize-PE-HQ 60019 netmask 255.255.255.255

    public static (inside, outside) udp interface 60020 LifeSize-PE-HQ 60020 netmask 255.255.255.255

    public static (inside, outside) udp interface 60021 60021 LifeSize-PE-HQ netmask 255.255.255.255

    public static (inside, outside) udp interface 60022 LifeSize-PE-HQ 60022 netmask 255.255.255.255

    public static (inside, outside) udp interface 60023 LifeSize-PE-HQ 60023 netmask 255.255.255.255

    public static (inside, outside) udp interface 60024 LifeSize-PE-HQ 60024 netmask 255.255.255.255

    public static (inside, outside) udp interface 60025 LifeSize-PE-HQ 60025 netmask 255.255.255.255

    public static (inside, outside) udp interface 60026 LifeSize-PE-HQ 60026 netmask 255.255.255.255

    public static (inside, outside) udp interface 60027 LifeSize-PE-HQ 60027 netmask 255.255.255.255

    public static (inside, outside) udp interface 60028 LifeSize-PE-HQ 60028 netmask 255.255.255.255

    public static (inside, outside) udp interface 60029 LifeSize-PE-HQ 60029 netmask 255.255.255.255

    public static (inside, outside) udp interface 60030 LifeSize-PE-HQ 60030 netmask 255.255.255.255

    public static (inside, outside) udp interface 60031 LifeSize-PE-HQ 60031 netmask 255.255.255.255

    public static (inside, outside) udp interface 60032 LifeSize-PE-HQ 60032 netmask 255.255.255.255

    public static (inside, outside) udp interface 60033 LifeSize-PE-HQ 60033 netmask 255.255.255.255

    public static (inside, outside) udp interface 60034 LifeSize-PE-HQ 60034 netmask 255.255.255.255

    public static (inside, outside) udp interface 60035 LifeSize-PE-HQ 60035 netmask 255.255.255.255

    public static (inside, outside) udp interface 60036 LifeSize-PE-HQ 60036 netmask 255.255.255.255

    public static (inside, outside) udp interface 60037 LifeSize-PE-HQ 60037 netmask 255.255.255.255

    public static (inside, outside) udp interface 60038 LifeSize-PE-HQ 60038 netmask 255.255.255.255

    public static (inside, outside) udp interface 60039 LifeSize-PE-HQ 60039 netmask 255.255.255.255

    public static (inside, outside) udp interface 60040 60040 LifeSize-PE-HQ netmask 255.255.255.255

    public static Mailsrv_Pearle_Europe 7472 netmask 255.255.255.255 7472 interface tcp (indoor, outdoor)

    public static LanSweep-XP netmask 255.255.255.255 8001 8001 interface tcp (indoor, outdoor)

    public static 8002 8002 LanSweep-XP netmask 255.255.255.255 interface tcp (indoor, outdoor)

    public static LanSweep-XP netmask 255.255.255.255 8003 8003 interface tcp (indoor, outdoor)

    static (inside, outside) 193.173.12.194 tcp https Pearle-DC02 https netmask 255.255.255.255

    inside_access_in access to the interface inside group

    Access-group outside_access_in in interface outside

    Access-group Wireless_access_in in wireless interface

    Route outside 0.0.0.0 0.0.0.0 193.173.12.206 1

    Route outside OracleThree 255.255.224.0 193.173.12.198 1

    Route outside 143.47.128.0 255.255.240.0 193.173.12.198 1

    Route inside 172.27.0.0 255.255.255.0 Pearle-DC02 1

    Timeout xlate 03:00

    Timeout conn 01:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02

    Sunrpc timeout 0:10:00 h323 0:05:00 h225 mgcp from 01:00 0:05:00 mgcp-pat 0:05:00

    Sip timeout 0:30:00 sip_media 0:02:00 prompt Protocol sip-0: 03:00 sip - disconnect 0:02:00

    Timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute

    dynamic-access-policy-registration DfltAccessPolicy

    AAA authentication LOCAL telnet console

    the ssh LOCAL console AAA authentication

    Enable http server

    http 192.168.40.0 255.255.255.0 Wireless

    http 192.168.1.0 255.255.255.0 inside

    http 192.168.72.0 255.255.255.0 inside

    http GrandVisionSoesterberg 255.255.255.0 inside

    SNMP-server host inside 192.168.33.29 survey community public version 2 c

    location of Server SNMP Schiphol

    contact Server SNMP SSmeekes

    SNMP-Server Public community

    Server enable SNMP traps snmp authentication linkup, linkdown cold start

    Crypto ipsec transform-set ESP-AES-256-MD5 esp-aes-256 esp-md5-hmac

    Crypto ipsec transform-set ESP-DES-SHA esp - esp-sha-hmac

    Crypto ipsec transform-set ESP-DES-MD5 esp - esp-md5-hmac

    Crypto ipsec transform-set ESP-AES-192-MD5 esp-aes-192 esp-md5-hmac

    Crypto ipsec transform-set ESP-3DES-MD5-esp-3des esp-md5-hmac

    Crypto ipsec transform-set ESP-AES-256-SHA 256 - aes - esp esp-sha-hmac

    Crypto ipsec transform-set ESP-AES-128-SHA aes - esp esp-sha-hmac

    Crypto ipsec transform-set ESP-AES-192-SHA esp-aes-192 esp-sha-hmac

    Crypto ipsec transform-set ESP-AES-128-MD5-esp - aes esp-md5-hmac

    Crypto ipsec transform-set esp-SHA-ESP-3DES-3des esp-sha-hmac

    Crypto ipsec transform-set esp-aes-256 GRANDVISION esp-md5-hmac

    life crypto ipsec security association seconds 28800

    Crypto ipsec kilobytes of life - safety 4608000 association

    Dynamic crypto map SYSTEM_DEFAULT_CRYPTO_MAP 65535 set pfs

    Crypto dynamic-map SYSTEM_DEFAULT_CRYPTO_MAP 65535 value transform-set ESP-AES-128-SHA ESP-AES-128-MD5 ESP-AES-192-SHA ESP-AES-192-MD5 ESP-AES-256-SHA ESP-AES-256-MD5 ESP-3DES-SHA MD5-ESP-3DES ESP-DES-SHA ESP-DES-MD5

    Dynamic crypto map SYSTEM_DEFAULT_CRYPTO_MAP 65535 define security association lifetime 28800 seconds

    cryptographic kilobytes 4608000 life of the set - the association of security of the 65535 SYSTEM_DEFAULT_CRYPTO_MAP of the dynamic-map

    card crypto outside_map0 1 match address outside_cryptomap_1

    outside_map0 card crypto 1jeu pfs

    outside_map0 card crypto 1jeu peer 212.78.223.182

    outside_map0 card crypto 1jeu transform-set ESP ESP-3DES-SHA-AES-128-SHA ESP-AES-128-MD5 ESP-AES-192-SHA ESP-AES-192-MD5 ESP-AES-256-SHA ESP-AES-256-ESP ESP-3DES-MD5 MD5-DES-SHA ESP-DES-MD5

    outside_map0 map 1 lifetime of security association set seconds 28800 crypto

    card crypto outside_map0 1 set security-association life kilobytes 4608000

    card crypto game 2 outside_map0 address outside_cryptomap_2

    outside_map0 crypto map peer set 2 193.173.12.193

    card crypto outside_map0 2 game of transformation-ESP ESP-AES-128-SHA ESP-AES-128-MD5 ESP-AES-192-SHA ESP-AES-192-MD5 ESP-AES-256-SHA ESP-AES-256-MD5 ESP-3DES-SHA ESP-3DES-MD5-DES-SHA ESP-DES-MD5

    life card crypto outside_map0 2 set security-association seconds 28800

    card crypto outside_map0 2 set security-association life kilobytes 4608000

    card crypto outside_map0 3 match address outside_1_cryptomap

    outside_map0 card crypto 3 set pfs

    outside_map0 card crypto 3 peers set 193.172.182.66

    outside_map0 crypto map 3 the value transform-set ESP-3DES-SHA

    life card crypto outside_map0 3 set security-association seconds 28800

    card crypto outside_map0 3 set security-association life kilobytes 4608000

    card crypto outside_map0 game 4 address outside_cryptomap

    outside_map0 card crypto 4 peers set 213.56.81.58

    outside_map0 4 set transform-set GRANDVISION crypto card

    life card crypto outside_map0 4 set security-association seconds 28800

    card crypto outside_map0 4 set security-association life kilobytes 4608000

    card crypto outside_map0 5 match address outside_cryptomap_3

    outside_map0 card crypto 5 set pfs

    outside_map0 crypto card 5 peers set 86.109.255.177

    outside_map0 card crypto 5 game of transformation-ESP ESP-AES-128-SHA ESP-AES-128-MD5 ESP-AES-192-SHA ESP-AES-192-MD5 ESP-AES-256-SHA ESP-AES-256-MD5 ESP-3DES-SHA ESP-3DES-MD5-DES-SHA ESP-DES-MD5

    life card crypto outside_map0 5 set security-association seconds 28800

    card crypto outside_map0 5 set security-association life kilobytes 4608000

    Crypto map outside_map0 65535 ipsec-isakmp dynamic SYSTEM_DEFAULT_CRYPTO_MAP

    outside_map0 interface card crypto outside

    crypto ISAKMP allow inside

    crypto ISAKMP allow outside

    crypto ISAKMP enable dmz

    crypto ISAKMP enable wireless

    crypto ISAKMP policy 5

    preshared authentication

    3des encryption

    sha hash

    Group 2

    life 86400

    Telnet 192.168.72.0 255.255.255.0 inside

    Telnet timeout 5

    SSH 192.168.72.0 255.255.255.0 inside

    SSH GrandVisionSoesterberg 255.255.255.0 inside

    SSH 213.144.239.0 255.255.255.192 outside

    SSH timeout 5

    Console timeout 0

    management-access inside

    dhcpd dns 194.151.228.18 is 10.10.1.100

    dhcpd outside auto_config

    !

    dhcpd address 192.168.72.253 - 192.168.72.253 inside

    !

    dhcpd address dmz 192.168.50.10 - 192.168.50.50

    dhcpd enable dmz

    !

    dhcpd address wireless 192.168.40.10 - 192.168.40.99

    dhcpd dns 194.151.228.18 wireless interface

    dhcpd activate wireless

    !

    a basic threat threat detection

    host of statistical threat detection

    statistical threat detection port

    Statistical threat detection Protocol

    Statistics-list of access threat detection

    no statistical threat detection tcp-interception

    Group Policy "pearle_vpn_Hyp only" internal

    attributes of Group Policy "pearle_vpn_Hyp only".

    value of server WINS 192.168.72.25

    value of server DNS 192.168.72.25

    Protocol-tunnel-VPN IPSec l2tp ipsec

    Split-tunnel-policy tunnelspecified

    value of Split-tunnel-network-list SplittnlHyperion

    Split-dns value pearle.local

    internal pearle_vpn_OOD_only group policy

    attributes of the strategy of group pearle_vpn_OOD_only

    value of Split-tunnel-network-list SplittnlOOD

    internal pearle_vpn group policy

    attributes of the strategy of group pearle_vpn

    value of server WINS 192.168.72.25

    value of server DNS 192.168.72.25

    Protocol-tunnel-VPN IPSec l2tp ipsec svc

    Split-tunnel-policy tunnelspecified

    value of Split-tunnel-network-list splittunnelclientvpn

    Pearle.local value by default-field

    Split-dns value pearle.local

    username anyone password encrypted password

    username something conferred

    VPN-group-policy pearle_vpn_OOD_only

    type of remote access service

    tunnel-group 193 type ipsec-l2l

    tunnel-group 193 ipsec-attributes

    pre-shared-key *.

    tunnel-group 193.173.12.193 type ipsec-l2l

    IPSec-attributes tunnel-group 193.173.12.193

    pre-shared-key *.

    NOCHECK Peer-id-validate

    type tunnel-group pearle_vpn remote access

    tunnel-group pearle_vpn General-attributes

    address pool VPN_Range_2

    Group Policy - by default-pearle_vpn

    pearle_vpn group of tunnel ipsec-attributes

    pre-shared-key *.

    type tunnel-group Pearle_VPN_2 remote access

    attributes global-tunnel-group Pearle_VPN_2

    address pool VPN_Range_2

    strategy-group-by default "pearle_vpn_Hyp only".

    IPSec-attributes tunnel-group Pearle_VPN_2

    pre-shared-key *.

    tunnel-group 213.56.81.58 type ipsec-l2l

    IPSec-attributes tunnel-group 213.56.81.58

    pre-shared-key *.

    tunnel-group 212.78.223.182 type ipsec-l2l

    IPSec-attributes tunnel-group 212.78.223.182

    pre-shared-key *.

    tunnel-group 86.109.255.177 type ipsec-l2l

    IPSec-attributes tunnel-group 86.109.255.177

    pre-shared-key *.

    !

    class-map inspection_default

    match default-inspection-traffic

    !

    !

    type of policy-card inspect dns preset_dns_map

    parameters

    message-length maximum 512

    Policy-map global_policy

    class inspection_default

    inspect the preset_dns_map dns

    inspect the ftp

    inspect h323 h225

    inspect the h323 ras

    inspect the rsh

    inspect the rtsp

    inspect the skinny

    inspect sunrpc

    inspect xdmcp

    inspect the sip

    inspect the netbios

    inspect the tftp

    inspect the pptp

    !

    global service-policy global_policy

    context of prompt hostname

    Cryptochecksum:7d4d9c7ca7c865d9e40f5d77ed1238eb

    : end

    ASDM image disk0: / asdm - 613.bin

    ASDM BESServer 255.255.255.255 inside location

    ASDM VPN_Pool_2 255.255.255.0 inside location

    ASDM OracleTwo 255.255.224.0 inside location

    ASDM OracleOne 255.255.240.0 inside location

    ASDM OracleThree 255.255.224.0 inside location

    ASDM location Exchange2010 255.255.255.255 inside

    ASDM location Grandvision 255.255.255.0 inside

    ASDM Grandvision2 255.255.255.240 inside location

    ASDM Grandvision3 255.255.255.0 inside location

    ASDM Grandvision4 255.255.255.255 inside location

    ASDM GrandVision_PC 255.255.255.255 inside location

    ASDM location LanSweep-XP 255.255.255.255 inside

    ASDM GrandVisionSoesterberg 255.255.255.0 inside location

    ASDM location Pearle-DC02 255.255.255.255 inside

    ASDM location Pearle-WDS 255.255.255.255 inside

    ASDM location Swabach 255.255.255.0 inside

    ASDM GrandVisionSoesterberg2 255.255.255.0 inside location

    don't allow no asdm history

    Where is that host (inethost)? Inside of the ASA, or on the internet (on the outside)?

    If it is outside, you must configure the NAT for the pool of vpn as you turn on the SAA.

    NAT (outside) 1 192.168.75.0 255.255.255.0

  • Configure DHCP (get guest and host on the same network)

    First of all, I want to thank everyone for all the help that has given me so far.  I apologize that I'm such a newbie to virtualization, but I learn fast!

    I'll have set up a printer (HP OfficeJet J4860) wireless.  Here is my configuration:

    Computer: Dell computer Inspiron 1318 laptop

    VMPlayer Version: 3.0.0 build-203739

    Host o/s: Fedora 12 Linux 64-bit (2.6.31.12 kernel - 174.2.3.fc12.x86_64)

    Comments o/s: Windows 7 Home Premium

    Guest network settings: NAT (using DHCP)

    The problem I have is that the configuration of HP printer utility complains that the IP address of the printer (192.168.0.102) is not on the same network as the client (172.16.79.1).  So, in order to install the printer, I need to configure the VMware DHCP server to use IP addresses in the range 192.168.0. *.  I tried manually editing /etc/vmware/vmnet1/dhcpd/dhcpd.conf and /etc/vmware/vmnet8/dhcpd/dhcpd.conf (Yes, I know, the files that you are not supposed to change these, but I tried anyway).  Who broke everything (guest couldn't access anything whatsoever!), so I put the original files of dhcpd.conf.  I also tried to change the settings of the VM guest network to bridged and assigned a static IP to the map in Win7, but that does not work either.  (I did not try to use the Host parameter only because I don't have any idea what this means?)

    Could someone guide me please you through the configuration process of the range of IP addresses to the DHCP server on VM or manually assign IP addresses bridged network or host-only?  I have attached copies of my config output files and the vmnet1 and vmnet8 ifconfig in the case where it is useful.

    Thank you, in advance, for any help.

    Best regards, Chris

    P.S. If this question has already been answered, I'm sorry for the redundancy.  I'm looking through the forum, but I am come with has been set to the "NAT" VM network and map comments to "Using DHCP".  So, if this has been answered before, please point me to the thread.

    According to the ifconfig_output.txt IP address of the host is 10.41.1.111, and you say the IP address of the HP printer is 192.168.0.102 if the host cannot yet access the printer on this subnet so neither will be the guest who is on the 172.16.79.x subnet.

    How the host receives its IP address?

    Is there a router in the game?

    If so you can assign the guest Bridged to so it will then get an IP address from the router and then the host and the guest will be put on the same subnet and then you configure the HP printer to have an IP address that is on the same subnet but make it a static address that is outside the scope of the Pool of addresses IP DHCP servers as it better to have the printer to use a static address and not a single one in the range that would be affected through DHCP.

  • Comments see host on the network, but the host does not see comments

    Hi all

    I'm running Windows 7 Pro as host and have XP as a guest.  I set up a new virtual network (as I saw in another post here) and made sure both host and guest get correct IP addresses.

    The guest can ping on the host, but the host cannot ping the prompt.  I even moved the new VM adapter above the other ones on the host and which still got nothing.

    Any thoughts?

    Thank you

    Craigbert

    > Any thoughts?

    Firewall settings? (turn off for tests)

    Is it time out or say inaccessible?

  • PowerCLI script to list all the material

    Greetings,

    I'm looking for a script that will display all the material parameters for disk including my vm, USB, series and parallel ports, etc...

    Found this script for serial ports:

    $vms = get - VM

    {foreach ($vm to $vms)

    Notice-EEG - ViewType VirtualMachine. %{

    if($_.) Config.Hardware.Device | where {$_.} GetType(). Name - eq

    {'VirtualSerialPort'})

    $_. Name

    }

    }

    }

    However how to change it for all material or I need to specify each potential device?  How can I get a list of options, for example, where I find that 'VirtualSerialPort' is an option?

    Also how I got out to a csv file.

    Try this

    Get-View -ViewType VirtualMachine | %{
         $vm = $_
         $_.Config.Hardware.Device | Select @{N="VM name";E={$vm.Name}},@{N="HW name";E={$_.GetType().Name}},@{N="Label";E={$_.DeviceInfo.Label}}
    } | Export-Csv "C:\VM-HW.csv" -NoTypeInformation
    

    ____________

    Blog: LucD notes

    Twitter: lucd22

  • PowerCLI script to list all the streams

    Hello

    Want to know if there is a way to list all inbound and outbound connections with IP and port of a vcenter infrastructure.

    Try it with scale and dvs but looks delicate, as navigator of Vmware infrastructure can perhaps do.

    But for sure, I think we can do it with powercli just want to confirm if there already exists.

    Thank you!

    Hello

    Check if that shell commands can help you

    https://KB.VMware.com/kb/2051814

    https://KB.VMware.com/kb/2020669

    Or with (command shell and PowerCli)

    http://technodrone.blogspot.com/2011/09/netstat-for-ESXi.html

    I hope this can help

  • PowerCLi script to check if 2 virtual machines are on the same host

    Hello

    I'm nubby on PowerCLI and I would like to help in the construction of a script.

    The script should check if two virtual machines (named test1 and test2) are running on the same host in a vCenter and send a notification (email), if they do.

    Something similar with affinity / anti-affinite DRS rules (but not through the DRS enabled on vCenter).  My focus is on the affinity. In case this happens, I need vMotion one of them on an another ESXi host(manually or automated).

    What I have done until now is the following:

    Get - VM | Select Name, @{N = 'Cluster'; {E = {Get-Cluster - VM $_}}, '

    @{N = "ESX host"; {E = {Get-VMHost - VM $_}}, '

    @{N = 'vCenter'; E={$_. "(ExtensionData.CLient.ServiceUrl.Split('/') [2]}}, '"

    @{N = "Datastore"; {E = {Get-Datastore - VM $_}} | `

    Export-Csv - NoTypeInformation C:\Scripts\file.csv

    That becomes all the VMS and export a CSV file information:

    NameClusterESX hostvCenterData store
    test2cluster_testESXi_test1vCenter_test1:443datastore1
    Test1cluster_testESXi_test1vCenter_test1:443datastore1
    For1.localcluster_testESXi_test1vCenter_test1:443datastore1
    VM1.localcluster_test2ESXi_test2vCenter_test1:443datastore1
    VM2.localcluster_test3ESXi_test3vCenter_test1:443datastore1
    VM31.localcluster_test3ESXi_test3vCenter_test1:443datastore1

    Thank you.

    Try like this.

    $tgtVM = "test1", "test2".

    Get-VM-name $tgtVM | Group-object - property VMHost | %{

    if($_.) County - gt 1) {}

    $vm = $_. Group | Get-Random

    $esx = $vm. VMHost

    $tgtEsx = get-Cluster - $vm VM | Get-VMHost | where {$_.} Name - not $esx. Name} | Get-Random

    Move-VM - $vm - Destination $tgtEsx VM - confirm: $false

    }

    }

  • I just want my image in list in bullets paragraph, and not in the spry menu?

    http://www.kansascitycrates.com/air_packs.html

    Which property is ONLY for the image in the list in a bullet of paragraph?

    I tried several different approaches and none worked until suddenly, the image in the list is in every sense.  I don't want in my menus spry menu horizontal/sup, just paragraphs in my hand/body content.

    Forgive me, I'm lost.  Thanks in advance.

    JM

    Too much

      tags in your HTML lists.  You only need a set of tags to
        as follows:


               
        • License & insurance

        •      
        • Uniformed personnel

        •      
        • All new materials

        •      
        • Protection floor (before, during and after the service)

        •      
        • Leg guards

        •      
        • Clear invoicing

        •      
        • Crate labels (Item description, room, Crate # of #)

        •      
        • The final inventory Crate (w/Total cubic feet)

        •      
        • Status reports (w/photos)

        •      
        • DOT commercial trucks

        •      
        • Satisfaction guaranteed!

        • In your CSS, add the bottom margin between the elements of list as follows:

          .star_bullet li {}

          margin-bottom: 15px;

          }

          Nancy O.
          ALT-Web Design & Publishing
          Web | Graphics | Print | Media specialists
          http://ALT-Web.com/
          http://Twitter.com/ALTWEB

    • Comments and questions about the mixture ADF Page flows with Trinidad UI

      Hi all

      I did a few tests to see how possible it is to use Trinity to the UI (for compatibility of this stinking IE 6) as well as the ADF Page flows / controller of the ADF. My question is whether there is a sustainable configuration from the point of view of Oracle. I did things to make it work and noted the following interesting behaviors (call anaomalies, if you wish):

      (1) addition of ADF Page Flow within the reach of the technology for a project automatically adds ADF Faces. If I try to eliminate ADF Faces of the scope of technology, it automatically deletes the flow of Page of ADF as well.

      (2) if I remove the ADF Faces DURATION 11 project library and create a page of trinidad (also set up the renderkit and as appropriate skin and remove a moment-false ServletADFFilter of web.xml) I get errors MDS when running the resulting page. I can't correct the error by removing the MDS libraries either - as soon as I put ADF Faces DURATION 11 library back, things are OK.

      (3) since I've faced ADF in my scope of technology, all newly created JSPX pages end up having af:document / af:form tags and have the namespaces implemented for ADF Faces. Not useful if I want only parts of Trinidad, but not a show-stopper, either.

      (4) an interesting thing that I have reported before... If I have the ADF Page library flow into my project and then configure navigation case in faces-config. XML (I know, wouldn't do that, just an observation, even if someone who has accidentally library ADF Page Flow in their project without any intention to use the ADF Page flows will find this very annoying to debug...), the first click of button that leads to the navigation works very well. All subsequent navigation requires two clicks on the link/button to trigger navigation. This behavior does not occur if you change the case of navigation to redirect = true.

      So, in summary, I seems to be the controller of flow/ADF Page ADF working with Trinidad, with a few minor problems of productivity due to an obvious requirement to have the Library Runtime of ADF Faces and the extent of technology ADF Faces included in my project. Now Oracle - is this going to be a sustainable configuration?

      I'd also appreciate comments, suggestions and comments from anyone else who has tried or is trying to use the ADF Page flows / ADF controller with a single user Trinity interface (well, in my case, I'm going to blur more using the tag af:template with components of the Trinity, but it's another whole story).

      Best,

      John

      bump #2

      + 1). Adding the ADF Page Flow within the reach of the technology for a project automatically adds ADF Faces. If I try to eliminate ADF Faces of the scope of technology, it automatically deletes the flow of Page of ADF as well. +

      ADF task flows have to ADF Faces e around. Not sure this is documented somewhere, but I hope it's

      (2) no idea about it

      + 3). Since that I've faced ADF in my scope of technology, all newly created JSPX pages end up having af:document / af:form tags and have the namespaces implemented for ADF Faces. Not useful if I want only parts of Trinidad, but not a show-stopper, either. +

      Looks like that is facing an emergency room to have an option in the dialog creation page if create an ADF or page of Trinidad. I'll take a note

      + 4). An interesting thing that I have reported before... If I have the ADF Page library flow into my project and then configure navigation case in faces-config. XML (I know, wouldn't do that, just an observation, even if someone who has accidentally library ADF Page Flow in their project without any intention to use the ADF Page flows will find this very annoying to debug...), the first click of button that leads to the navigation works very well. All subsequent navigation requires two clicks on the button/link to trigger navigation. This behavior does not occur if you change the case of navigation to redirect = true. +

      I'm not sure how to restrict we are on the "do not use" them in combination, but to me this looks like a bug.

      Frank

    Maybe you are looking for