query to display objects for all users in the database

Hi all

I want to make a query that Lee display. result for all users in a database.

Total number of #tableau #Indexes #Packages #Procedure #Functions #Sequences #Views # other username

ABC 11 5 1 1 1

1 1 1 0

Something like this would work in 10g and before:

SELECT     OWNER
,     SUM(CNT) AS "TOTAL"
,     MAX(DECODE(OBJECT_TYPE,'TABLE',CNT,0)) AS "#TABLE"
,     MAX(DECODE(OBJECT_TYPE,'INDEX',CNT,0)) AS "#INDEX"
,     MAX(DECODE(OBJECT_TYPE,'PACKAGE',CNT,0)) AS "#PACKAGE"
,     MAX(DECODE(OBJECT_TYPE,'PROCEDURE',CNT,0)) AS "#PROCEDURE"
,     MAX(DECODE(OBJECT_TYPE,'FUNCTION',CNT,0)) AS "#FUNCTION"
,     MAX(DECODE(OBJECT_TYPE,'SEQUENCE',CNT,0)) AS "#SEQUENCE"
,     MAX(DECODE(OBJECT_TYPE,'VIEW',CNT,0)) AS "#VIEW"
,     MAX(CASE WHEN OBJECT_TYPE NOT IN ('TABLE','PACKAGE','INDEX','PROCEDURE','FUNCTION','SEQUENCE','VIEW') THEN CNT ELSE 0 END) AS "#OTHER"
FROM
(
     SELECT     OWNER
     ,     OBJECT_TYPE
     ,     COUNT(*)     AS CNT
     FROM     ALL_OBJECTS
     GROUP BY OWNER
     ,     OBJECT_TYPE
)
GROUP BY OWNER
ORDER BY OWNER;

11 g, you can use the PIVOT operator to do the same.

You can change this by changing the statements of DECODING of CASE statements if you can use the LIKE operator to catch all objects such as VIEWS and VIEWS MATERIALISEES.

For example:

MAX(CASE WHEN OBJECT_TYPE LIKE '%VIEW%' THEN CNT ELSE 0 END

HTH!

Tags: Database

Similar Questions

  • How to change the password for all users in the database

    Hi buddies!

    Could someone tell me how to change the password for all users in the database? I want to set the same password for all users.

    Thank you.

    Nith

    Published by: user645399 on March 1, 2011 14:23

    Write the file spooling
    as

    Make sure that all profiles has password_verify_function with a NULL value

    then

    Select 'edit user' | username: ' identified by ;' from dba_users;

    you will get the output... you just run.

  • Error "have sufficient privileges to complete this installation for all users of the machine. "log on as an administrator and try again the installation" when you try to install iTunes

    Original title:

    I just installed windows7, I had to uninstall itunes in order to complete the instalation of windows7. everything went well until I tried to reinstall itunes.

    During this process, I get the message "you don't have sufficient privileges to complete this installation for all users of the machine. log on as an administrator and try this installation again. ». but I am logged on as administrator.

    Hello

    To resolve this problem, use the following methods. After completing the steps in each method, check to see if the issue is resolved before you go to the next method. If the problem is resolved by any method, you do not have to use other methods.

    Method 1:

    Right click on the installer for iTunes and click Run as administrator.

    Method 2:

    Disable user account control settings and check.

    Enable or disable the User Account Control

    Note: User Account Control (UAC) can help prevent your computer from unauthorized changes. UAC notifies you when changes will be made to your computer that require administrator-level permissions. Disabling it can make your compromised computer. Please make sure that enable you UAC, once you have completed troubleshooting.

    Method 3:

    Allow the default Administrator and try to install it in this user account.

    a.Click on Start, click principally made programs, Accessories, right-click on command prompt and select run as administrator.

    b.Type in the following command and press ENTER.

    NET user administrator / active: yes

    c.Log disable the current user account and log in to the user called Administrator account.

    d.Install iTunes in this default Administrator account.

    e.Once of that installation is complete, the default administrator is disconnected.

    f. log in to your user account.

    g.Disable the default Administrator account. Follow these steps.

    i.Click on Start, click principally made programs, Accessories, right-click on command prompt and select run as administrator.

    II. type the following command and press ENTER.

    NET user administrator / active: No.

  • Is it possible to have full control for all users in the directory/files/registry?

    Can I have a lot of control (read, write, change) my specific file / registry for all users, you have any program or script for this reason?

    as 'cacls '. Because I can't use cacls.

    is it wrong?

    C:\>Cacls "program * Files\NETAS" / c/r users: «F»»»

    Displays or modifies access control (ACL) of the files lists

    CACLS filename [/ t] [/ e] [/ c] [/G user: permission] [/R user [...]]
    [/P user: permission [...]] [/D user [...]]
    the ACL file name.
    / T changes ACLs of files specified in
    the current directory and all its subdirectories.
    /E Edit ACL instead of replace it.
    /C continue on access denied errors.
    /G user: permission Grant specified user access rights.
    Perm can be: R read
    W write
    C change (write)
    F full control
    ...

    Perhaps you could elaborate a little bit on "this command is not running"...  What happens when you try?

    I'm not knowledgeable about Windows 7, but Windows XP, I found the registry permissions must be put in a file.  So in your example, you can create a file named "z.txt", and in this file, you put the line:
    [1 5 7 17] \registry\Machine\Software
    Then call you the command line:
    Regini z.txt

    HTH,
    JW

  • is there a way to tell firefox allow and remember the java plugin for all users via the command line or a script?

    Hello

    I have about 200 computers I want to push the next to parameter

    allow and remember the java plugin for firefox for all users
    

    is it possible to do this via a script or configuration file?

    You must create two files in the Firefox program folder.

    • local - settings.js file in the defaults\pref folder where you will find the channel - prefs.js
    • mozilla.cfg in the main folder of the Firefox program
  • Scanner does not work for all users on the computer Windows 7

    Photosmart 7510 Scanner does not work.  My scanner has the habit of work.   Now it does not for one of the three users on my Windows 7 desktop.

    I spent over 3 hours on the phone with HP.   They had me restart the computer, Plug and unplug the printer, reinstall the software twice under different names. The software depending on what user id, it is installed under allows access to the scanner/printer to one or more users.  The scanner works with Windows Paint software for all three nicknames.

    HP response is that some user control prevents the scanner software, who used to work on all three nicknames on the computer, which now works on one or more of the users.  They couldn't tell me which user control need changing.

    The HP solution is to restore my system when I could scan for all users of three.   I don't want to do that.   Does anyone have a better solution?

    The real problem is HP error messages.   When I click on scan a document, there is no answer.  Nothing happened.

    Then I tried to scan using Windows Fax and Scan.   I got an error message which helped me locate the source of the error.   I was able to fix the problem without creating a new user account.  I had deleted bu error the file MY Document.   Restore this file fixes the problem.

  • How to activate permanently on "Show processes for all users" in the Task Manager

    I have a facility with windows 7 installed twice.  will receive run the Task Manager in the initial installation of windows the "show processes from all users" is checked by default and visible.

    However, in the second installation on a spare drive will receive run that task manager this option is converted (boxed) and must be clicked but the machine doesn't remember this setting.

    How can I get windows 7 to continuously show me processes for all users?

    Thank you footoomsh

    Hello

    Are you logged on as ADMINISTRATOR?

    The Task Manager - create a shortcut high
    http://www.SevenForums.com/tutorials/10499-Task-Manager-create-elevated-shortcut.html

    I hope this helps.

    Rob Brown - MS MVP - Windows Desktop Experience: Bike - Mark Twain said it right.

  • A new attempt of an individual doesn't have a process task for all users of the IOM

    Hello

    We use IOM 11.1.1. One day, one of the systems was not available so all tasks in process for this system failed for a number of users. Is it possible to view the task process has failed and retry them together, there are more than 3000 users and it is not possible to pass by one by one.

    Any method via the console or programmatically do would be very useful.

    Thanks in advance.

    --
    UZ

    The ITO table has all the rejected task information. You can use it to bind to the user and the instances of the resource through the table Ouedraogo as well.

    You can then take the SCH_KEY and then use code like this to deal with them:

    public void completeTask() {}
    task of long [] = new [long] {123123,3242134,23432,43534,34656,456456};
    int counter = 0;
    for {(clé: travail très long)}
    try {}
    counter ++;
    provIntf.retryTask (key);
    System.out.println (counter + "|" + task.length);
    } catch (Exception e) {}
    }

    }
    }

    -Kevin

  • Display the default icons for all users who connect

    How can I view documents of the user, computer, network, and recycle bin icons for all users in the domain who connect?

    As journal of domain in a PC users, I want the icons is displayed as a default without having to add icons and customize the desktop.

    Hello
     
     
    As Microsoft Answers is oriented towards the level of consumer support, and since you are on a domain network, it would be preferable to view the query in the Microsoft Technet Server forums.
    http://social.technet.Microsoft.com/forums/Windows/en-us/home
     
     
    If you have other issues with the Windows operating system, please and we will be happy to help you.
  • How to disable printing depends on the location for 'all users '.

    I need to disable the "Location-Aware Printing" for "All Users" on the laptops that we use in our company.  Is there a way to do it, or is it one per user (HKCU) power only.

    Thank you

    Mike

    Hi Mike,

    The question you posted would be better suited in the TechNet Forums. I suggest that you post the query in the link.

    http://social.technet.Microsoft.com/forums/en/w7itpronetworking/threads

    Hope this information helps you.

  • How can I block the SMTP for all users but mail server

    I can't understand (1) how can I refuse port 25 for all users on the network and allow for Exchange server SMTP, also I have MS Exchange, which manages the web and smtp and in my setup below you can see that there static mapping to publick ip with http/smtp only, then (2) how can we separate the traffic entering a publc IP will outside servers inside ex : (MSexchange public ip address is x.x.x.207-> http = 172.16.2.13, 172.16.2.14 = smtp)

    Thank you

    ___________________________________________________

    6.3 (1) version PIX

    interface ethernet0 car

    Auto interface ethernet1

    ethernet0 nameif outside security0

    nameif ethernet1 inside the security100

    names of

    name 172.16.4.10 pdc

    name 172.168.4.11 llc

    name 172.16.4.11 ftp

    object-group service E-mail tcp

    port-object eq www

    EQ smtp port object

    object-group service tcp - udp terminal

    3389 3389 port-object range

    object-group service mw tcp - udp

    Beach of port-object 367 367

    radmin tcp service object-group

    RemoteAdmin description

    4899 4899 object-port Beach

    object-group service mw1 tcp

    Beach of port-object 367 367

    access-list 101 tcp refuse any any eq smtp

    access-list 101 permit tcp any host object-group x.x.x.251 terminal

    access-list 101 permit tcp any host x.x.x.214 object-group radmin

    access-list 101 permit tcp any email host x.x.x.207 object-group

    access-list 101 permit tcp any host x.x.x.212 object-group mw1

    access-list 101 permit tcp any host x.x.x.211 eq ftp

    sheep ip access-list allow any 192.168.101.0 255.255.255.240

    IP address outside x.x.x.194 255.255.255.192

    IP address inside 172.16.2.1 255.255.0.0

    IP verify reverse path to the outside interface

    IP verify reverse path inside interface

    alarm action IP verification of information

    IP audit attack alarm drop action

    IP local pool mypool 192.168.101.1 - 192.168.101.20

    don't allow no history of pdm

    ARP timeout 14400

    Global interface 10 (external)

    NAT (inside) 0 access-list sheep

    NAT (inside) 10 0.0.0.0 0.0.0.0 0 0

    static (inside, outside) x.x.x.212 172.16.4.12 netmask 255.255.255.255 0 0

    static (inside, outside) x.x.x.251 172.16.4.51 netmask 255.255.255.255 0 0

    public static x.x.x.214 (Interior, exterior) pdc netmask 255.255.255.255 0 0

    public static x.x.x.211 (Interior, exterior) ftp netmask 255.255.255.255 0 0

    "REM # 172.16.2.13's Exchange with Outlook Web servers #

    static (inside, outside) x.x.x.207 172.16.2.13 netmask 255.255.255.255 0 0

    Access-group 101 in external interface

    Route outside 0.0.0.0 0.0.0.0 x.x.x.193 1

    enable floodguard

    Sysopt connection permit-pptp

    VPDN PPTP-VPDN-group accept dialin pptp

    VPDN group PPTP-VPDN-GROUP ppp authentication pap

    VPDN group PPTP-VPDN-GROUP ppp authentication chap

    VPDN group PPTP-VPDN-GROUP ppp mschap authentication

    VPDN group PPTP-VPDN-GROUP ppp encryption mppe 40

    VPDN group VPDN GROUP-PPTP client configuration address local mypool

    VPDN group VPDN GROUP-PPTP client configuration dns 172.16.2.6 172.16.4.6

    client PPTP-VPDN-GROUP VPDN group configuration wins nymc_pdc

    VPDN group VPDN GROUP-PPTP pptp echo 60

    VPDN group VPDN GROUP-PPTP client for local authentication

    VPDN username * password *.

    VPDN allow outside

    This is your problem:

    Access-group 101 in external interface

    You link this access list to your external interface. This means that the rules are applied to incoming traffic IN your network. The implicit IP any any rule is because you have not bound to an access list on your inside interface.

    To prevent users from going out, you will need this:

    access list permit tcp host exchange_IP OUTPUT no matter what eq smtp

    access list tcp OUTPUT deny any any eq smtp

    Access-group interface inside OUT

    See how this access list is linked to the inside interface... it will affect traffic leaving your network. Note: Once you apply this inside allow any interface it will remove the implicit.

  • ldapmodify for all users

    Hello

    I want to run a ldapmodify to set an attribute of all users in ldap container. Right now, for 1 user, I'm using something like:

    DN: [email protected], cn is ED_I_USERS, cn = Users, dc = xxxxx, dc = com
    ChangeType: modify
    Add: preferredLanguage
    preferredLanguage:English

    I need it to be run for each user. So, is there a way I can put the dn in the file above, so that this ldapmodify will run for all users, instead of specifying me each user dn individually?

    Regads,
    Naomie

    You could generate ldif by performing an ldap query for all users in the container and return their dn. You need an entry for each user.

    -Kevin

  • How to disable tabs in the title bar for all users?

    I want to disable tabs in the title bar for all users, because the air ugly http://i57.tinypic.com/33nkm77.png
    I type in C:\Program Files\Mozilla Firefox\defaults\pref\local-settings.js
    Pref ("browser.tabs.drawInTitlebar", false);
    It does not work, but other options in this file works fine.
    Setting with: config works very well, but only for users perceive.

    Thank you all. Problem solved. I'd like to edit 2 files:

    C:\Program Files\Mozilla Firefox\defaults\pref\local-settings.js
    Pref ("general.config.obscure_value", 0);
    Pref ("general.config.filename", "mozilla.cfg");

    C:\Program Files\Mozilla Firefox\mozilla.cfg
    //
    lockPref ("browser.tabs.drawInTitlebar", false);

  • TypeKit disable for all users?

    We use the deployment of user name in our setup of the company. The deployment is already done, but it has come to our attention that it presents a potential problem for us to use the TypeKit, we talked with our Adobe SR account manager. Enterprise.

    We must disable centrally TypeKit for all users via the dashboard, so that it becomes disabled for all current and future users.

    How this is done?

    You can disable Typekit in a Configuration of product on your dashboard.

    Configure services for groups using Adobe Creative Cloud for business or Adobe Document Cloud for businesses

  • definition of expiration of password for all users of oracle R12 applications

    Hi,.

    I have OS RHEL 5, Oracle apps: 12.1.1
    now, I want to put the expiration of the password for all users in the oracle applications 60 days...


    can some Guide please how it could be done.


    It is urgent, your help is appreciated.

    Kind regards
    Milan ROUGIER

    Try this:

    Log in as applications

    SQL > update fnd_user set PASSWORD_LIFESPAN_DAYS = 60;

    SQL > commit;

    Thank you
    Muneer.
    http://muneer2908.WordPress.com

Maybe you are looking for

  • Skype has become completely broken - 10 Windows

    I was using the latest version of Skype when I noticed strange problems happening. For example, if I was in a Skype call with someone I couldn't type in the call window (I was able to do this very well before). If I call others and then try to 'Add'

  • FPGA - OR USB-generation analog 7855R

    Hello. In a project, I chose NEITHER-USB-7855R for a project for the generation of the analog output. According to the datasheet, 7855 have 1us update time in 16 bits Resoulation. I'm confuss always update 1. Please corrent if I'm wrong. the time of

  • External files are not deployed to target

    I'm trying to follow the example in this post where the user specifies a file in the build specification which includes no - LV files.  It contains HTML files that must be deployed with the project.  It seems to be a good idea to keep HTML and JS fil

  • Fake logo with notification of virus

    While playing the game of hunting the eggs on my computer, the logo of Microsoft came in a box with some virus names indicating that my pc has been infected and everything was red, but I Essentials protect me.  I thought it was a case of hoax, he dis

  • X 360 set spectrum: spectrum x 360 i7 set Wifi Specs

    Hello Can you please provide or point me to information on the terms of the wifi of a spectrum x 360 w / processor set. MFG, model, etc. ? Thank you