Syncronize "tags" between vcenter servers

Maybe someone already has a solution to do this, so I'll ask here until I get out all my hair.

In one of our vcenter, we started the use of the tags later. Similar to this is the way we want to go, so now the challenge is to "synchronize" tags between all of our vcenter servers.

I hope that some of you already have a way to do this, or an idea on where to start.

I suppose we could export using csv and import them to a different vcenter? Or is there a better way?

Suggestions are welcome at this stage...

Best regards

Jorgen S

You can use a CSV file to export/import of categories and labels.

Something like that.

Note that according to the number of connections that you opened, you must use the Server parameter to indicate the location of export/import.

(1) export

& {{foreach ($tCat in Get-TagCategory)

$tags = get-Tag-category $tCat

{if ($Tags)}

$tags | Select @{N = 'Category'; E={$tCat.name}},@{N='cDescription'; E={$tCat.Description}},@{N='Cardinality'; {E = {$tCat.Cardinality}}, Name, Description

}

else {}

$tCat | Select @{N = 'Category'; E={$tCat.name}},@{N='cDescription'; E={$tCat.Description}},@{N='Cardinality'; E={$tCat.cardinality}},@{N='Name'; {E = {""}}, @{N = 'Description'; E={''}}

}

}} | Export Csv C:\tag.csv - NoTypeInformation - UseCulture

(2) import

foreach ($tag in c:\tag.csv Import-Csv - UseCulture) {}

Try {}

Get-TagCategory-name $tag. Category - ErrorAction Stop

}

Catch {}

New-TagCategory-name $tag. Category Description $tag.cDescription - $tag cardinality. Cardinality-confirm: $false

}

if($tag.) {Name)

Try {}

Get-Tag-category $tag. Category-name $tag. Name - ErrorAction Stop

}

Catch {}

-Tag - new name $tag. Name - category $tag. Category Description $tag. Description-confirm: $false

}

}

}

Tags: VMware

Similar Questions

  • Is it possible to migrate a virtual machine between vcenter servers programmatically?

    Hi all

    My question is quite simple:

    -Is it possible to migrate a virtual machine between vcenter servers programmatically?

    Let's say we have two data centers:

    vcenter1

    -vm1

    -vm2

    vcenter2

    -vm3

    Is it possible to migrate vms between vcenter2 and vcenter1 programmatically? (or vice versa)?

    Also, I'm assuming that the appropriate VLAN and data warehouses across the different vcenters!

    Thank you

    Luis

    It is not possible, vMotion or migration live is in an instance of vCenter, it cannot be covered through two even if you have the data store accessible both vCenters and sets of the host. At best, you can unregister the virtual machine of vCenter 1 host and re-save as on vCenter 2 host, but once again, it is while the virtual machine is turned off.

    =========================================================================

    William Lam

    VMware vExpert 2009,2010

    VMware scripts and resources at: http://www.virtuallyghetto.com/

    Twitter: @lamw

    repository scripts vGhetto

    Introduction to the vMA (tips/tricks)

    Getting started with vSphere SDK for Perl

    VMware Code Central - Scripts/code samples for developers and administrators

    VMware developer community

    If you find this information useful, please give points to "correct" or "useful".

  • Migration between vCenter servers, publishes the setting destination folder

    I'm having a problem with a migration script, I wrote to migrate virtual machines between 2 VCs.  The first part of the script works as expected (checking tools, right-size and removes the VM of the inventory on the VC source).  The second fails.on of Part VC of destination when the folder setting:

    #The CSV should be in the following format
    #VMNAME,$MEM,$CPU,$VMHOST,$VMXFILE,$CLUSTER,$VMFOLDER,$RESPOOL,$VMNETWORK
    #Even if there's not going to be a change, the
    #cells cannot be blank use "" for blank
    
    #Import the CSV
    $vmlist = Import-CSV d:\scripts\naotest-UCSmigration.csv
    
    #Prompts user for the source and destination vCenter servers
    $SourceVC = Read-Host -Prompt 'What is the source vCenter?'
    $DestVC= Read-Host -Prompt 'What is the destination vCenter?'
    
    #connects to the source vCenter for right-sizing
    connect-viserver $SourceVC
    
    #check tools status first
    write-host ""
    write-host "Checking VMware Tools Status before proceeding." -foreground green
    write-host ""
    foreach ($item in $vmlist) {
                  $vmname=$item.vmname
                  $ToolsStatus = (Get-VM $vmname).extensiondata.Guest.ToolsStatus -eq "toolsNotRunning"
                  IF ($ToolsStatus -eq $true){
                  write-host ""
                  write-host "Tools is not installed or running on $vmname. Remediate on guest and restart the script" -foreground Yellow
                  write-host "Script will exit" -foreground yellow
                  write-host ""
                  Exit}
                  Else {
                  write-host ""
                  write-host "Tools running, script will continue" -foreground green
                  write-host ""}
    }
    
    #Power down all the VMs in the list
    write-host ""
    write-host "Powering down all VMs in the list.  Script will sleep for 2 minutes before continuing" -foreground green
    write-host ""
    foreach ($item in $vmlist) {
      $vmname = $item.vmname
      Shutdown-VMGuest -VM $vmname -Confirm:$false
    }
    
    #sleep for 2 minutes before continuing
    #may need to adjust depending upon time for
    #servers to shut down
    Start-sleep -s 120
    
    #stop VMs that haven't shut down
    write-host ""
    write-host "Stopping VMs that have hung on power-down" -foreground green
    write-host ""
    foreach ($item in $vmlist) {
      $vmname = $item.vmname
      Stop-VM -VM $vmname -RunAsync -Confirm:$false
    }
    
    #Right-size CPU and memory
    write-host ""
    write-host "Right-sizing CPU and Memory" -foreground green
    write-host ""
    foreach ($item in $vmlist) {
    
        $vmname = $item.vmname
        $cpu = $item.cpu
        $mem = $item.mem
    
        Set-VM -VM $vmname -NumCpu $cpu -MemoryGB $mem -RunAsync -Confirm:$false}
           
    #start the VMs after the vCPU/Memorychange
    write-host ""
    write-host "Restarting the VMs to enact the vCPU/Memory change"          -foreground green
    write-host ""
    foreach ($item in $vmlist) {
        $vmname = $item.vmname
        Start-VM -VM $vmname -RunAsync
        }
    
    #Wait 5 minutes for the VMs to completely Power Up
    write-host ""
    Write-host "Sleeping for 5 minutes to wait for all VMs to power up" -foreground green
    write-host ""
    Start-sleep -s 300
    
    #Power down the VMs in preparation for migration
    #NOTE:  It's necessary to power them up after the right-sizing
    write-host "Power down and sleep for 2 minutes"
    foreach ($item in $vmlist) {
      $vmname = $item.vmname
      Shutdown-VMGuest -VM $vmname -Confirm:$false
    }
    
    #Wait 2 minutes for the VMs to completely Power down
    Start-sleep -s 120
    
    #stop VMs that haven't shut down
    write-host ""
    write-host "Stop VMs that haven't shut down normally." -foreground green
    write-host ""
    foreach ($item in $vmlist) {
      $vmname = $item.vmname
      Stop-VM -VM $vmname -RunAsync -Confirm:$false
    }
    
    #disconnect CD-ROM
    write-host ""
    write-host "Disconnect any connected CD-ROM drives."
    write-host ""
    get-vm $vmname|Get-CDDrive | Set-CDDrive -nomedia -Confirm:$false
    
    #remove VMs in list from inventory on the source vCenter
    write-host ""
    write-host "Remove VMs from inventory on the source vCenter."
    write-host ""
    foreach ($item in $vmlist) {
      $vmname = $item.vmname
      Remove-VM -VM $vmname -Confirm:$false
    }
    
    #disconnect from the source vCenter
    disconnect-viserver -Confirm:$false
    
    #Connect to the destination vCenter server
    connect-viserver $DestVC
    
    #Add VMs to the new vCenter server
    write-host ""
    Write-host "Add VMs to the Destination vCenter"
    write-host ""
    foreach ($item in $vmlist) {
                  $VMXFILE = $item.VMXFILE
                  $CLUSTER = $item.CLUSTER
                  $VMHOST = Get-VMHost -location $Cluster | Sort $_.CPuUsageMhz -Descending | Select -First 1
                  $VMFOLDER = $item.VMFOLDER
                  $RESPOOL = $item.RESPOOL
                  $VMNETWORK = $item.VMNETWORK
           
        New-VM -VMFilePath "`"$VMXFILE`"" -VMHost $VMHOST -Location $VMFOLDER -ResourcePool $RESPOOL}
    
    #change the network for the new vCenter
    foreach ($item in $vmlist) {
    $vmname = $item.vmname
    get-vm $vmname | Get-NetworkAdapter | Set-NetworkAdapter -NetworkName $vmnetwork -confirm:$false
    }
    
    #Power up the VMs on the new vCenter server
    write-host ""
    write-host "Powering up VMs on the destination vCenter."  -foreground green
    write-host ""
    foreach ($item in $vmlist) {
        $vmname = $item.vmname
        Start-VM -VM $vmname -RunAsync
        }
    
    
    

    The CSV looks like this:

    vmname, cpu, mem, vmxfile, cluster, vmfolder, wrap, vmnetwork

    ATEST-VM002, 1, 4, ATEST-VM002/ATEST-VM002.vmdk,DEV-STND1,DEV\Dev\Infrastructure,DEV-root,VLAN-123 [DEV-DATASTORE]

    The error is:

    New - VM: 2015/12/16 14:46:49 New - VM can not find the folder with

    the name "DEV\Dev\Infrastructure".

    D:\scripts\vm-uscmigration.ps1:144 char: 5

    + New-VM - VMFilePath "'" $VMXFILE'"'-VMHost $VMHOST - location $VMFOLDER

    -Resources...

    + ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

    ~~~

    + CategoryInfo: ObjectNotFound: (SAT1-DEV\Dev-NAOTEST\Infrastruc

    ture:String) [New - VM], VimException

    + FullyQualifiedErrorId: Core_ObnSelector_SelectObjectByNameCore_ObjectNo

    tFound, VMware.VimAutomation.ViCore.Cmdlets.Commands.NewVM

    I pulled information from RVTOOLS path (as well as most other relevant information). Is the incorrect path information, or is it a problem in my script?  Any help would be appreciated.

    P.S. I know not that defining the network will work or not, I did not get that far!

    Thank you!

    This is because the screenshot in my post was taken in an old PowerCLI release.

    The current version shows other default properties.

    Direct the result of Select - property *, then you will see all of the properties of the Folder object.

    You can try to use the function and use the returned object file on the location setting.

  • Catalyst 3560 liaison network between two servers ubuntu 12.04

    Hello world

    I'm trying to transfer data with more than 1 Gbit/s between two servers, but I just get a card (approximately 1 Gbps) NETWORK performance. Here is my configuration:

    srvnettest1 and srvnettest2 are two 12.04 servers ubuntu with three network cards in each. management eth0, eth1 and eth2 are network cards that should work as a team. ;-) Here are the relevant parts of fit it:

    [email protected]/* */:~# less /etc/network/interfaces

    ...

    auto bond0

    iface bond0 inet static

    address 172.16.200.100

    netmask 255.255.255.0

    bond-mode 4

    bond-miimon 100

    bond-slaves none

    bond-lacp-rate 1

    bond-primary eth1 eth2

    auto eth1

    allow-bond0 eth1

    iface eth1 inet manual

    bond-master bond0

    auto eth2

    allow-bond0 eth2

    iface eth2 inet manual

    bond-master bond0

    ...

    [email protected]/* */:~# less /etc/network/interfaces

    ...

    auto bond0

    iface bond0 inet static

    address 172.16.200.200

    netmask 255.255.255.0

    bond-mode 4

    bond-miimon 100

    bond-slaves none

    bond-lacp-rate 1

    bond-primary eth1 eth2

    auto eth1

    allow-bond0 eth1

    iface eth1 inet manual

    bond-master bond0

    auto eth2

    allow-bond0 eth2

    iface eth2 inet manual

    bond-master bond0

    ...

    It's the switch configuration (btw, this is a version of IOS in course WS-C3560G-48TS 12.2 (55) SE)

    Switch#show running-config

    ...

    interface Port-channel10

    switchport access vlan 200

    switchport mode access

    !

    interface Port-channel20

    switchport access vlan 200

    switchport mode access

    !

    interface GigabitEthernet0/1

    switchport access vlan 200

    switchport mode access

    channel-group 10 mode active

    !

    interface GigabitEthernet0/2

    switchport access vlan 200

    switchport mode access

    channel-group 10 mode active

    !

    interface GigabitEthernet0/3

    switchport access vlan 200

    switchport mode access

    channel-group 20 mode active

    !

    interface GigabitEthernet0/4

    switchport access vlan 200

    switchport mode access

    channel-group 20 mode active

    ...

    This is my summary etherchannel:

    Switch#show etherchannel summary

    Flags:  D - down        P - bundled in port-channel

    I - stand-alone s - suspended

    H - Hot-standby (LACP only)

    R - Layer3      S - Layer2

    U - in use      f - failed to allocate aggregator

    M - not in use, minimum links not met

    u - unsuitable for bundling

    w - waiting to be aggregated

    d - default port

    Number of channel-groups in use: 2

    Number of aggregators:           2

    Group  Port-channel  Protocol    Ports

    ------+-------------+-----------+-----------------------------------------------

    10     Po10(SU)        LACP      Gi0/1(P)    Gi0/2(P)

    20     Po20(SU)        LACP      Gi0/3(P)    Gi0/4(P)

    My test tools are nuttcp (by transfer) and bmon (to watch what is happening during the transfer). Unfortunately, I am not able to transfer more than 1 Gbps:

    [email protected]/* */:~# nuttcp -i1 172.16.200.100

    97.1875 MB /   1.00 sec =  815.2409 Mbps     0 retrans

    98.0625 MB /   1.00 sec =  822.4763 Mbps     0 retrans

    98.0625 MB /   1.00 sec =  822.7321 Mbps     0 retrans

    98.1250 MB /   1.00 sec =  823.1001 Mbps     0 retrans

    98.0625 MB /   1.00 sec =  822.5306 Mbps     0 retrans

    98.0625 MB /   1.00 sec =  822.7560 Mbps     0 retrans

    98.1250 MB /   1.00 sec =  822.9890 Mbps     0 retrans

    98.0625 MB /   1.00 sec =  822.6753 Mbps     0 retrans

    98.0625 MB /   1.00 sec =  822.5528 Mbps     0 retrans

    98.0625 MB /   1.00 sec =  822.7058 Mbps     0 retrans

    982.5000 MB /  10.03 sec =  821.9606 Mbps 21 %TX 37 %RX 0 retrans 0.32 msRTT

    In bmon, I see that a NIC (eth1) of bond0 the uplink and the other a (eth2) made the downlink:

    #   Interface                RX Rate         RX #     TX Rate         TX #

    qqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqq

    srvnettest2 (source: local)

    0   lo                         0.00B            0       0.00B            0

    1   eth2                     269.26KiB       4175       0.00B            0

    2   eth1                     123.00B            0     102.56MiB      71030

    3   eth0                     179.00B            2     491.00B            1

    4   bond0                    269.38KiB       4176     102.56MiB      71030

    I tried a lot of things, but now I have no idea what to do or what to try next. It is true that I have no deep understanding of Cisco etherchannels yet, so I guess that my mistake is somewhere in the IOS configuration.

    Thanks a lot for your support and welcome to Germany

    Stephan

    Hello Stephan,

    With EtherChannels, a single flow (the flow of images/packages with the same source and destination) is always carried by a single link only. Implementation of Cisco implements not balancing on connections in an EtherChannel load by package, and it avoids a reason: executives could get reorganized, something this plain Ethernet never should do. This means that you will not see an improvement in bandwidth on the speed of a single link to your EtherChannel for a single stream. It is only the overall bandwidth for several stream which increases. The advantage of EtherChannel becomes therefore obvious that if your server starts many conversations and several stream handling.

    Best regards

    Peter

  • A list of virtual machines to different vCenter servers

    I am running a report that connects to the servers multiple vCenter.  Within these vCenter servers, I have a number of clusters and in each group a subset of virtual machines that I'll call acme VMs with the acmevmnaming convention 1, acmevm3, acmevm2, etc.  They all start with acmevm*.

    Is it possible to create a report that tells me how many acme VMs are in each vCenter, and how many are in each cluster?

    I suspect Re: access on behalf of the cluster of a VM answer this question on the cluster?

  • Managing 2 vsphere vcenter servers

    We have 2 each Vcenter server running data centers.  (Principal and Dr. Colo data center).  In Vcenter 4, we had our configured client vsphere where we could both stop VCenter VShpere inside servers.   I could log into my main data center and the VCenter servers were visible and manageable.  (Even with our Colo).  Somehow during our migration up to 5 VCenter, we lost that connection.

    I would like to pick it up where I can see them both again.

    Thank you

    Looks like the linked Mode must be configured again.

  • Difference between vCenter 4 Standard and Enterprise edition

    Hello

    I'm planing to upgrade my VI3 to vSphere and I found this vCenter server has 4 different edition. I tried to find the difference between vCenter 4 Standard and Enterprise edition, but not worth it.

    Can someone tell me what is the difference between the two editions. I have vCenter Standard edition license with me.

    Thanks in advance.

    Maybe this will help you?

    http://www.VMware.com/products/vSphere/buy/editions_comparison.html

  • vMotion between two servers vCenter

    From what I've read so far, it seems that this is not possible, but I just wanted to ask to make sure.

    Is it possible to live migrate a virtual machine on a host managed by 'a vCenter server' to another host managed by "vCenter Server B? All subnets and storage is exactly the same (we have our own hosts and storage, but it's just all managed under a vCenter Server now). We're just trying to completely separate our hosts and virtual machines to a subcontractor who took over the virtual environment (with the exception of what runs my team)

    I have the feeling that this requires time, which is unfortunate, because it means that it will take an extremely long time to coordinate and plan for all this work. Thought it was worth asking if...

    Thank you.

    I did something similar week last during the upgrade a 4.0 environment. I installed vCenter 5.1, then disconnected and removed the hosts the old vcenter (without first disconnecting that will prompt you to place the host in maintenance mode) and finally added to the new vCenter Server without downtime for virtual machines.

    André

  • Quick vMotioning problem between two servers HP BL460c Gen 9 when EVC enabled

    I have two HP BL460c Gen 9 blades configured exactly the same thing with 2 x Intel XEON E5-2660 v3 processors in each of them. Both running the same version ROM (I36 06/05/2015) and running the same version of ESXi (5.0.0 build 2509828). They are managed by a Server Build 2656067 vCenter 5.0.0.

    When I configure these two servers in a cluster with EVC disabled I am able to vMotion between them. However, if I activate the Intel EVC modes so I am unable to vMotion between these two identical servers.  Here is an example of the message that I get when I updated Westmere VCA mode

    Host CPU is not compatible with the requirements of the virtual machine to CPUID level 0 x 1 'ecx' register

    Bits of the host: 0000:0010:1001:1000:0010:0010:0000:0011

    Required: x 110: x01x:11 x 1: 1xx0:xx11:xx1x:xxxx:xx11

    Inconsistency detected for these features:

    * General incompatibilities

    If I disable CVS, then I can vMotion VMs between them.

    I wanted to add these hosts to an existing cluster configured with EVC Westmere mode so that I was able to vMotion between old and new guests, but was unable to vMotion VMs off the new hosts, even if I tried to vMotion to another new host.

    Configure a new cluster with only these two new hosts to so I could experiment. I can only vMotion between them if CVS is disabled. I cannot further increase the VCA mode on this new cluster, for example of Westmere to Sandy Bridge then I have virtual machines under tension within the cluster. For example: I put the VCA mode at Westmere, feeding on a virtual computer, when I go to change the CVS to Sandy Bridge mode I get the following message, I should be able to increase the VCA mode but may not lower it

    The cluster cannot be configured with the selected Enhanced vMotion

    Compatibility mode; The CPU features disabled by this mode may be currently in use

    by slot voltage or suspension of the virtual machines in the cluster.

    I get this message even if I try to set the VCA mode at the same level, that it is already.

    Anyone got any ideas on how to solve this problem?

    Hello

    Seems, your CPU supports 5.0 ESXi and vCenter 5.0, you must upgrade your vSphere vSphere 6.x for the VCA.

    See the links below and also compatibility VCA matrix attached:

    VMware KB: Enhanced vMotion compatibility (EVC) support processor

    Intel CPU VCA Matrix (Enhanced VMware vMotion compatibility) | Virten.NET

  • Laptop user moves between 2 servers the IPCC CAD problem

    Call unique Manager cluster 4.02 SR1, separate the 2 servers of the IPCC (3.5 (3)) are installed, one in each building. 100 MB ethernet between the sites.

    I have a user that moves between the 2 buildings. They have the installed CAD. How can I get the CAD turn to the IPCC correct server when the user changes buildings? Is there a. INI file that could be exchanged with a batch file or is it a bunch of registry entries that tell the CAD which server of the IPCC to connect to?

    We do this from time to time, when you work with different clients. Assuming you have the same exact versions of software, which you say that you don't have, you can do it with only changes in registry. You must exchange the content of:

    Setup HKEY_LOCAL_MACHINE\SOFTWARE\Spanlink\Site

    and then run the agent. You can pick up the right CAD clients installed registry values, or you can get them on the respective servers of IPCCX who have exactly the same inputs in the same places. Use the registry editor to export the contents of this key in a file, their two servers or two customer installs. Give these two .reg files to the user.

    Just a double click on the .reg files in Windows in the local registry (after confirmation), is important to crush what is already there. Then start the CAD and he will speak to the good LDAP directory and the server IPCCX.

  • Replication between two servers without direct connecton

    Hi all

    In this case, we have two servers without direct access between them (firewall, security requirements). In fact the two servers are stored in different VPN.
    and the question is:
    Can you build an architecture that will provide replication between them (include the server in downstream, trails in the intermediate machine bank file, or something else)?

    Much love and thanks for your suggestions))

    Hello

    In this case, your downstream server should be able to communicate to your Source and target.

    Kind regards

    Veera

  • How they handle authentication on multiple vCenter servers in a script without storing the passwords in the script?

    Hello

    How are they managing authentication on several servers of vCneter in a script without storing the passwords in the script?

    The script is run every hour.

    Here's the script:


    SE connect-VIServer NAN - vcenter - 02.utility .net - User script-user-01
    SE connect-VIServer HKG - vcenter - 01.utility .net - user administrator
    SE connect-VIServer ORY - vcenter - 09.utility .net-user special-script-user-01
    SE connect-VIServer CNF - vcenter - 06.utility .net - user administrator

    # Download info, sort, email me-VMs.csv
    Get - vm | Select name, VMHost, VApp, Powerstate, @{N = 'IP address'; E={$_. {{Guest.IPAddress [0]}}, @{N = 'DnsName'; E={$_. ExtensionData.Guest.Hostname}} | Tri - VMHost property, name. Export-Csv-path ALL - VMs.csv - NoTypeInformation
    #

    Thank you!

    Potentially, you can store your password as a string that is encrypted in a text file as I described here Powershell: securing the credentials using the PSCredential class | Deans blog

    This will allow you to recover the encrypted string and convert it into a secure string supplied and this move to the PSCredential class for authentication.

  • Strategy for the SSO with multiple vCenter servers.

    We are upgrading vSphere/SRM 5.0U1 for vSphere/SRM 5.5U1 with multiple vCenters in our environment. After reading 2058239 KB:

    VMware KB: installing vCenter Single Sign-On 5.5 on a Microsoft Windows platform

    We install SSO on a separate Windows Server and choose vCenter Single Sign-On for your first server vCenter Server for this first instance. Now my question is for the following facilities as the vCenter for MRS or vCenters which manages areas replacement fault which option, existing site or new, do we choose? Thank you


    You have therefore three sites.

    The first time, you will choose vCenter Single Sign-On for your first server vCenter Server.

    For the second one on the same site, you choose existing vCenter Single Sign-On for an additional vCenter Server in a site.

    Now, when you come to an another site vCenter and third, you will need to decide if you have a site that is your main or you want to still have a site on the second.

    If you decide to join at the elementary level, that you will yet choose existing vCenter Single Sign-On for an additional vCenter Server in a site.

    If you choose to have another site, you choose vCentre of Single Sign-On for an additional vCenter Server with a new site.

    The end of it, you will have to make the decision to design. I can only tell you what they mean. Make sure you have adequate connectivity between sites.

  • Work with multiple vCenter servers in PowerCLI

    VI the value of multiple server mode:

    Game-PowerCLIConfiguration - multiple DefaultVIServerMode - confirm: $false

    Connect to two servers vCenter:

    SE connect-VIServer-Server vc1, vc2-userid of the user

    Find the cluster and do not specify a VC:

    Get-Data Center-Cluster clusterA

    Cluster data center is displayed correctly:

    name of the data center in VC1

    name of the data center by VC2

    Try to specify what VC of query:

    Get-Data Center-Cluster cluster - server VC2

    the names of three data centers are returned which makes no sense (only one contains the cluster)

    Trying to figure out how better to work with the simultaneous connections of VC in a script and dictate what VC I want to execute a command against rather than disconnect and reconnect etc.

    I think there could be a problem with the cmdlet.

    You are using PowerCLI 5.5 R2 I guess?

    When you try like this

    Get-Data Center-Cluster (Cluster-Get-name ClusterA-Server VC1)

    is it returns 1 datacenter or 2?

  • creation and assignment of tags in vCenter via vCO

    VMware is moving away from custom attributes and categories and tags.  Currently, vCO vCenter workflows for the creation of custom attributes, however, I found nothing on the automation of the creation and assignment of tags with virtual machines.

    Finally, I should mention the category via vCAC at the time of commissioning.  tag could be billing department as well as the response or if the tag exists (IE Engineering) and then he would associate the (engineering) tag to the category (dept billing).  However if the tag does not exist, then a new tag and associated with the virtual machine.

    thoughts?

    PowerShell commands

    Since version VMware PowerCLI 5.5R1 and until there are a number of commands for working with tags, such as:

    • Get - Tag
    • New-TagAssignment

    I had similar questions about the tags quite awhile (5.1 is released at the time).  I don't think I ever got a response.  In the meantime, you could create a wrapper for PowerCLI orders or make calls directly to the api.  A little messy but it would work.

Maybe you are looking for

  • How to add boxes to the extra letters?

    I've looked and can't find where to do. Thank you.

  • LYNC 2013 to replace the PBX

    Hello, I need to know a few things about MS Lync 2013 before deciding to implement in our Organization. I'm looking for the solution of IP telephony. I currently have a Panasonic PBX. I can implement LYNC 2013 to replace the PBX. If so, how can I con

  • help to separate all of the data in the .csv file

    Hi all I have a CSV file and sometime I hv to reading one line and then set these parameters of instrument. and then second row and so on... But I always all data as in a line... I had to seprate them so I can give separate value to separate the para

  • Windows Vista: HDMI Intermittent problems

    I bought an ASUS desktop computer the month last with the intention to use it with a new flat screen TV via HDMI. The problem is that the HDMI output is not reliable. Sometimes I can hear startup sound by connecting to the computer, but it often cuts

  • New Modem caused my printer to stop working

    Recently I got a new modem installed and now I can't get my printer to work. I ran the troubleshooter and it still does not receive the signal from my wireless modem. How to reconnect the modem again? If I can't get the new modem to read my printer,