ASA5520 routing?

I connected my asa5520 as:

CAT6 (port Access)-> ASA5520 (outside)

CAT6 (trunk port)-> (inside)-> vlan101 and vlan 102

Configure asa5520 as:

interface GigabitEthernet0/0

nameif inside

security-level 100

no ip address

!

interface GigabitEthernet0/0,101

VLAN 101

No nameif

no level of security

10.1.1.1 IP address 255.255.255.0

!

interface GigabitEthernet0/0,102

VLAN 102

No nameif

no level of security

10.1.2.1 IP address 255.255.255.0

!

interface GigabitEthernet0/1

nameif outside

security-level 0

IP 10.1.3.9 255.255.255.0

on the cat6, I add static route:

Route IP 10.1.1.0 255.255.255.0 10.1.3.0

Because I don't want to use Protocol ospf/rip road. Can I use static route? If so, how can I do it?

Any comments will be appreciated

Thanks in advance

I think your static route in Cat6 must point to the IP of specific next hop of 10.1.3.x instead of 10.1.3.0 (it is subnet ID).

Anyway, you can still use static in ASA. It supports RIP OSPF.

To configure static on ASA to Cat6, use (example):

Route outside 0.0.0.0 0.0.0.0 10.1.3.1, or

external route 10.1.1.0 255.255.255.0 10.1.3.1

* assuming 10.1.3.1 is your IP of the interface Vlan Cat6 facing ASA outside interface

Otherwise, from Cat6, road to ASA inside VLan 101:

Route IP 10.1.1.0 255.255.255.0 10.1.3.9

But the other condition is that you must configure static nat for the Vlan101 to talk to the segment of the outside, inside like:

static (inside, outside) 10.1.1.0 10.1.1.0 netmask 255.255.255.0

This will allow users/guests of the outside/Cat6 side to talk to Vlan101 internal hosts.

HTH

AK

Tags: Cisco Security

Similar Questions

  • My ASA cannot ping the lan address

    I use ASA built ezvpn.   I can access the ASA and ping inside port address successfully.    But in my ping to the address of interconnection 10.100.255.2 window7 cant.     I don't know how to solve the problem.  If all goes well, can help me. Thank you...

    set it up

    ASA5520 # sh run

    : Saved

    :

    ASA Version 7.2 (3)

    !

    asa5520-host name

    sxng domain name

    activate the encrypted password of DOAXe2w/ilkXwCIz

    names of

    DNS-guard

    !

    interface GigabitEthernet0/0

    nameif outside

    security-level 0

    IP x.x.x.x 255.255.255.248

    !

    interface GigabitEthernet0/1

    nameif inside

    security-level 100

    IP 10.100.255.254 255.255.255.0

    !

    interface GigabitEthernet0/2

    nameif dmz

    security-level 50

    IP x.x.x.x 255.255.255.0

    !

    interface GigabitEthernet0/3

    nameif wireless

    security-level 10

    IP x.x.x.x 255.255.255.0

    !

    interface Management0/0

    Shutdown

    nameif management

    security-level 100

    IP 192.168.1.1 255.255.255.0

    management only

    !

    2KFQnbNIdI.2KYOU encrypted passwd

    Disk0: / pix723.bin starting system

    passive FTP mode

    DNS server-group DefaultDNS

    sxng domain name

    dmz_access_in of access allowed any ip an extended list

    dmz_access_in list extended access permit icmp any one

    tunnel of splitting allowed access list standard 10.0.0.0 255.0.0.0

    inside_nat0_outbound list of allowed ip extended access all 10.100.254.0 255.255.255.0

    inside_nat0_outbound to access ip 10.0.0.0 scope list allow 255.0.0.0 10.100.254.0 255.255.255.0

    outside_cryptomap_dyn_20 list of allowed ip extended access all 10.100.254.0 255.255.255.0

    acl_out list extended access permit icmp any one

    acl_out list extended access permit tcp any host x.x.x.x eq www

    acl_out list extended access permit tcp any host x.x.x.x eq 9000

    acl_out list extended access permit udp any host x.x.x.x eq 9000

    ........

    ......

    acl_out allowed ip extended access list any 10.1.1.0 255.255.255.0

    inside_access_in list extended access permitted tcp 10.1.10.0 255.255.255.0 any eq 5000

    acl_inside of access allowed any ip an extended list

    acl_inside list extended access permit icmp any one

    wireless_access_in of access allowed any ip an extended list

    wireless_access_in list extended access permit icmp any one

    pager lines 24

    Enable logging

    timestamp of the record

    emergency list vpn-event logging level

    log message 109001-109028 vpn-event list

    log message 113001-113019 vpn-event list

    exploitation forest-size of the buffer 5000

    information recording console

    debug logging in buffered memory

    recording of debug trap

    asdm of logging of information

    Outside 1500 MTU

    Within 1500 MTU

    MTU 1500 dmz

    MTU 1500 wireless

    management of MTU 1500

    IP local pool vpnpool 10.100.254.1 - 10.100.254.250 mask 255.255.255.0

    no failover

    ICMP unreachable rate-limit 1 burst-size 1

    ICMP allow all outside

    ICMP allow any inside

    ASDM image disk0: / asdm - 507.bin

    don't allow no asdm history

    ARP timeout 14400

    Global (outside) 1 x.x.x.x

    Global (dmz) 1 10.100.253.101 - 10.100.253.200 netmask 255.255.255.0

    Global (wireless) 1 172.16.255.101 - 172.16.255.200 netmask 255.255.255.0

    NAT (inside) 0-list of access inside_nat0_outbound

    NAT (inside) 1 10.1.1.14 255.255.255.255

    NAT (inside) 1 10.1.13.100 255.255.255.255

    NAT (wireless) 1 172.16.0.0 255.255.0.0

    static (dmz, outside) tcp x.x.x.x www 10.100.253.1 www netmask 255.255.255.255

    .......

    .........

    static (inside, dmz) 10.1.1.11 10.1.1.11 netmask 255.255.255.255

    static (inside, dmz) 10.1.1.16 10.1.1.16 netmask 255.255.255.255

    static (dmz, external) 10.100.253.20 x.x.x.x 255.255.255.255 netmask

    static (dmz, external) 10.100.253.32 x.x.x.x 255.255.255.255 netmask

    Access-group acl_out in interface outside

    acl_inside access to the interface inside group

    Access-group interface inside acl_inside

    Access-group dmz_access_in in dmz interface

    Route outside 0.0.0.0 0.0.0.0 x.x.x.x 1

    Route inside 10.0.0.0 255.0.0.0 10.100.255.1 1

    Route inside 10.0.0.0 255.0.0.0 10.100.255.2 1

    Route wireless 172.16.0.0 255.255.0.0 172.16.255.1 1

    !

    router ospf 1

    255.255.255.255 network 10.67.180.0 area 0

    network 0.0.0.0 0.0.0.0 area 1

    Journal-adj-changes

    !

    Timeout xlate 03:00

    Timeout conn 01:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02

    Sunrpc timeout 0:10:00 h323 0:05:00 h225 mgcp from 01:00 0:05:00 mgcp-pat 0:05:00

    Sip timeout 0:30:00 sip_media 0:02:00 prompt Protocol sip-0: 03:00 sip - disconnect 0:02:00

    Timeout, uauth 0:05:00 absolute

    the ssh LOCAL console AAA authentication

    Enable http server

    http 192.168.1.0 255.255.255.0 management

    http 10.0.0.0 255.0.0.0 inside

    No snmp server location

    No snmp Server contact

    Server enable SNMP traps snmp authentication linkup, linkdown cold start

    Crypto ipsec transform-set esp-SHA-ESP-3DES-3des esp-sha-hmac

    Crypto-map dynamic outside_dyn_map 20 the value transform-set ESP-3DES-SHA

    Crypto outside-dyn-map Dynamics-plan 20 reverse-drive value

    map outside_map 65535-isakmp ipsec crypto dynamic outside_dyn_map

    outside_map interface card crypto outside

    crypto ISAKMP allow outside

    crypto ISAKMP policy 1

    preshared authentication

    3des encryption

    sha hash

    Group 2

    life 86400

    Crypto isakmp nat-traversal 20

    Telnet 0.0.0.0 0.0.0.0 outdoors

    Telnet 10.0.0.0 255.0.0.0 inside

    Telnet 10.100.0.0 255.255.0.0 inside

    Telnet 10.100.255.0 255.255.255.0 inside

    Telnet 0.0.0.0 0.0.0.0 wireless

    Telnet timeout 10

    SSH 0.0.0.0 0.0.0.0 outdoors

    SSH timeout 30

    Console timeout 0

    dhcpd x.x.x.x dns

    !

    management of 192.168.1.2 - dhcpd address 192.168.1.254

    enable dhcpd management

    !

    !

    class-map inspection_default

    match default-inspection-traffic

    !

    !

    Policy-map global_policy

    class inspection_default

    inspect the ftp

    inspect h323 h225

    inspect the h323 ras

    inspect the netbios

    inspect the rsh

    inspect the rtsp

    inspect the skinny

    inspect esmtp

    inspect sqlnet

    inspect sunrpc

    inspect the tftp

    inspect the sip

    inspect xdmcp

    inspect the icmp

    !

    global service-policy global_policy

    internal sxnggroup group policy

    attributes of the strategy of group sxnggroup

    value of server DNS 202.99.192.68

    enable IP-comp

    Split-tunnel-policy tunnelspecified

    Split-tunnel-network-list value split tunnel

    username password sxtrq Y6cwK1wOhbhJ6YI / encrypted

    maboai R6eu6P1iKIwFIFjS username encrypted password

    winet FwZ0ghxvIpXOepvf username encrypted password

    tunnel-group sxnggroup type ipsec-ra

    tunnel-group sxnggroup General-attributes

    address vpnpool pool

    Group Policy - by default-sxnggroup

    sxnggroup group of tunnel ipsec-attributes

    pre-shared-key *.

    context of prompt hostname

    Cryptochecksum:119ae137eef5ed97d38b4e2f90ed46d7

    : end

    ASA5520 # route sh

    Code: C - connected, S - static, RIP, M - mobile - IGRP, R - I, B - BGP

    D - EIGRP, OSPF, IA - external EIGRP, O - EX - OSPF inter zone

    N1 - type external OSPF NSSA 1, N2 - type external OSPF NSSA 2

    E1 - OSPF external type 1, E2 - external OSPF of type 2, E - EGP

    i - IS - L1 - IS - IS level 1, L2 - IS - IS IS level 2, AI - IS inter zone

    * - candidate by default, U - static route by user, o - ODR

    P periodical downloaded static route

    Gateway of last resort is 202.97.158.177 to network 0.0.0.0

    C x.x.x.x 255.255.255.248 is directly connected to the outside of the

    C 172.16.255.0 255.255.255.0 is directly connected, wireless

    S 172.16.0.0 255.255.0.0 [1/0] via 172.16.255.1, wireless

    S 10.0.0.0 255.0.0.0 [1/0] via 10.100.255.1, inside

    [1/0] via 10.100.255.2, inside

    C 10.100.255.0 255.255.255.0 is directly connected to the inside

    S 10.100.254.2 255.255.255.255 [1/0] via x.x.x.x, outdoor

    C 10.100.253.0 255.255.255.0 is directly connected, dmz

    S * 0.0.0.0 0.0.0.0 [1/0] via x.x.x.x, outdoor

    ASA5520 # sh arp

    outside 00d0.d0c6.9181 x.x.x.x

    outside 00d0.d0c6.9181 x.x.x.x

    outside 224.0.0.5 0100.5e00.0005

    inside 224.0.0.5 0100.5e00.0005

    inside the 10.100.255.1 0000.0c07.acff

    inside the 10.100.255.2 001c.b0cb.5ec0

    DMZ 10.100.253.20 60a4.4c23.3032

    DMZ 224.0.0.5 0100.5e00.0005

    DMZ 10.100.253.1 001a.6436.6df6

    224.0.0.5 wireless 0100.5e00.0005

    Wireless 172.16.255.1 0026.98c6.41c8

    Try to use the "crypto ipsec to show his ' command to watch the program and decaps packages, I hope this isn't too fast increment. You should be able to see the two increase when you successfully and only one side increase when it fails. Check both sides of the vpn, and this should give you an idea where the problem is. If the program packages are multiplying on the ASA local to your PC Win7 and Decaps multiply on the ASA Remote and the program is not so, then the question is with packets from the remote side. I hope this will help you determine the location of the problem and then you can focus your search here.

  • How to get the ASA packets that come in and out on the same interface?

    Hi all

    How can I configure the ASA5520 routes the packets that come in and out on the same interface? I ve more than 1 network behind the camera of the SAA. It s separated by internal router. They can communicate with each other.

    I've seen it's PIX design problem. She applies to the platform of the ASA?

    Please advice.

    Thank you

    Nitass

    This golden rule remains immutable. the only exception is the vpn traffic. ASA for example (or pix v7) would act as a hub for traffic between two rays rediect vpn.

    regarding your question.

    Internet <-->asa <-->1 <-->lan router <-->lan 2

    assuming the host to lan 1 to asa as the gateway default, even asa has a static route to the internal router of the point for local network 2, the golden rule will reject this operation.

    one solution is to re - configure the dhcp on the LAN 1 scope and make the internal router as the default gateway; and the internal router has the asa as the default gateway.

  • Destination port routing

    Hello

    I was wondering if this is a way to route outbound traffic on an ASA5520 based on the destination tcp port.

    Say so my mail server must use one of the channels for smtp, and all www traffic uses another.

    Thank you

    Not yet. See the question & answer at this link.

    http://www.Cisco.com/en/us/products/HW/vpndevc/ps2030/products_qanda_item09186a00805b87d8.shtml#PBR

    It will be useful.

  • asa5520s load sharing

    Greeting

    I configure Active/active failover on two boxes.

    but, it looks like two active/standby add now. (for subnet 1 go to the first asa5520 and traffic subnet 2 second go to asa5520).

    If possible, configure a subnet share the load on the two asa5520s? If so, how can I do it?

    Comments will be apprecaited

    Thanks in advance

    Product sheet ASA5520 stipulates a flow rate up to 450Mbps and for its 225Mbps vpn, so when you create the solution, you should consider the existing network installation and also the volume of future growth.

    In your case, it's a multi context configuration, so it will not VPN, support dynamic routing, so you need not worry about the use of these features in the future.

    However, sometimes you may experience heavy traffic / firewall uses of the resource due to some malwares or show WILL scan through the firewall

    To avoid this kind of situation,

    Configure the firewall to perform anti-spoofing, prevent back attacks by limiting / control the concurrent connections/sessions.

    Here is a link for Cisco to prevent network attacks.

    http://www.Cisco.com/en/us/products/ps6120/products_tech_note09186a00809763ea.shtml

  • Remote access VPN routing

    Hello

    I'm having a problem on the VPN routing.

    The VPN client is connected correctly to ASA5510, but cannot access inside ASA and the Internet or another network. What I want to achieve is.

    [email protected] / * / -> ASA5520 (public IP)-> Inside (172.16.1.0)

    The VPN address pool uses 172.168.10.0 (I also tried 172.16.1.100 - 120 with the same network from the inside).

    interface GigabitEthernet0/0

    nameif outside

    security-level 0

    IP address a.a.a.a 255.255.255.0

    !

    interface GigabitEthernet0/1

    nameif inside

    security-level 100

    IP 172.16.1.1 255.255.255.0

    IP local pool vpnpool 192.168.10.1 - 192.168.10.254 mask 255.255.255.0

    access extensive list ip 172.16.1.0 inside_nat0_outbound allow 255.255.255.0 192.168.10.0 255.255.255.0

    NAT (inside) 0-list of access inside_nat0_outbound

    NAT (inside) 1 0.0.0.0 0.0.0.0

    Crypto ipsec transform-set esp-SHA-ESP-3DES-3des esp-sha-hmac

    Crypto ipsec transform-set ESP-AES-256-MD5 esp-aes-256 esp-md5-hmac

    Crypto ipsec transform-set ESP-DES-SHA esp - esp-sha-hmac

    Crypto ipsec transform-set ESP-DES-MD5 esp - esp-md5-hmac

    Crypto ipsec transform-set ESP-AES-192-MD5 esp-aes-192 esp-md5-hmac

    Crypto ipsec transform-set ESP-3DES-MD5-esp-3des esp-md5-hmac

    Crypto ipsec transform-set ESP-AES-256-SHA 256 - aes - esp esp-sha-hmac

    Crypto ipsec transform-set ESP-AES-128-SHA aes - esp esp-sha-hmac

    Crypto ipsec transform-set ESP-AES-192-SHA esp-aes-192 esp-sha-hmac

    Crypto ipsec transform-set ESP-AES-128-MD5-esp - aes esp-md5-hmac

    life crypto ipsec security association seconds 28800

    Crypto ipsec kilobytes of life - safety 4608000 association

    crypto dynamic-map SYSTEM_DEFAULT_CRYPTO_MAP 65535 pfs Group1 set

    Crypto dynamic-map SYSTEM_DEFAULT_CRYPTO_MAP 65535 value transform-set ESP-AES-128-SHA ESP-AES-128-MD5 ESP-AES-192-SHA ESP-AES-192-MD5 ESP-AES-256-SHA ESP-AES-256-MD5 ESP-3DES-SHA MD5-ESP-3DES ESP-DES-SHA ESP-DES-MD5

    outside_map card crypto 65535-isakmp dynamic ipsec SYSTEM_DEFAULT_CRYPTO_MAP

    outside_map interface card crypto outside

    crypto ISAKMP allow outside

    crypto ISAKMP policy 10

    preshared authentication

    3des encryption

    sha hash

    Group 2

    life 86400

    internal VPNstaff group strategy

    attributes of Group Policy VPNstaff

    4.2.2.2 DNS server value

    Protocol-tunnel-VPN IPSec

    type tunnel-group VPNstaff remote access

    attributes global-tunnel-group VPNstaff

    address vpnpool pool

    Group Policy - by default-VPNstaff

    IPSec-attributes tunnel-group VPNstaff

    pre-shared-key *.

    Hello

    A quick test, try this.

    -Turn on nat - t (if its disable)

    Command: crypto isakmp nat-traversal 20

    see if it helps.

    If not,

    -Run a continuous ping from the client to the ASA inside the interface, make sure that you run the command 'management-access to inside' before you start with the ping.

    -Time our RESPONSE ICMP or inside the interface... ?

    If time-out, then

    -Check the number of decrypts using the command "show crypto ipsec his"

    If ICMP response to inside interface is received by the VPN client.

    -Ping to an internal host behind the ASA.

    -"Show crypto ipsec his"

    IF you have received responses if first test then here you should see decrypts number increases.

    -Apply the catches on the inside of the interface

    You can consult the document below

    http://www.Cisco.com/en/us/products/ps6120/products_tech_note09186a0080a9edd6.shtml

    -If you see the package source as VPN client interface to reach the inside interface for the destination of the host behind the ASA, then its a problem with your routing internal.

    In case you have an L3 device connected to the ASA inside the interface, make sure that you have a route for GW subnet 192.168.1.x as ASA inside the interface i.e. 172.16.1.1 score

    If his L2 or a dumb device, then as a quic test, make the following statement of the road using the command-line in windows on the host computer behind the asa participant in this test.

    route add 192.168.1.0 mask 255.255.255.0 172.16.1.1

    Please let me know if it helps.

    Concerning

    M

  • Cisco ASA5520 facing ISP with private IP address. How to get the IPSec VPN through the internet?

    / * Style definitions * / table. MsoNormalTable {mso-style-name : « Table Normal » ; mso-tstyle-rowband-taille : 0 ; mso-tstyle-colband-taille : 0 ; mso-style-noshow:yes ; mso-style-priorité : 99 ; mso-style-qformat:yes ; mso-style-parent : » « ;" mso-rembourrage-alt : 0 à 5.4pt 0 à 5.4pt ; mso-para-marge-top : 0 ; mso-para-marge-droit : 0 ; mso-para-marge-bas : 10.0pt ; mso-para-marge-left : 0 ; ligne-hauteur : 115 % ; mso-pagination : widow-orphelin ; police-taille : 11.0pt ; famille de police : « Calibri », « sans-serif » ; mso-ascii-font-family : Calibri ; mso-ascii-theme-font : minor-latin ; mso-fareast-font-family : « Times New Roman » ; mso-fareast-theme-font : minor-fareast ; mso-hansi-font-family : Calibri ; mso-hansi-theme-font : minor-latin ;}

    Hello guys,.

    I have Cisco ASA5520 facing the ISP with private IP address. We don't have a router and how to get the IPSec VPN through the internet?

    The question statement not the interface pointing to ISP isn't IP address private and inside as well.

    Firewall configuration:

    Firewall outside interface Gi0 10.0.1.2 > ISP 10.0.1.1 with security-level 0

    Firewall inside the interface Ethernet0 192.168.1.1 > LAN switch 192.168.1.2 with security-level 100

    I have public IP block 199.9.9.1/28

    How can I use the public IP address to create the IPSec VPN tunnel between two sites across the internet?

    can I assign a public IP address on the Gig1 inside the interface with the security level of 100 and how to apply inside to carry on this interface?

    If I configure > firewall inside of the item in gi1 interface ip address 199.9.9.1/28 with security-level 100. How to make a safe lane VPN through this interface on the internet?

    I'm used to the public IP address allocation to the interface outside of the firewall and private inside the interface IP address.

    Please help with configuration examples and advise.

    Thank you

    Eric

    Unfortunately, you can only complete the VPN connection on the interface the VPN connection source, in your case the external interface.

    3 options:

    (1) connect a router in front of the ASA and assign your public ip address to the ASA outside interface.

    OR /.

    (2) If your ISP can perform static translation of 1 to 1, then you can always finish the VPN on the external interface and ask your provider what is the static ip address assigned to your ASA out of the IP (10.0.1.2) - this will launch the VPN of bidirectionally

    OR /.

    (3) If your ISP performs PAT (dynamic NAT), then you can only start the tunnel VPN on the side of the ASA and the other end of the tunnel must be configured to allow VPN LAN-to-LAN dynamics.

  • ASA5510 Migration of SonicWall NSA 2400 VPN/GW router

    Hello

    I'll need to migrate 1 router VPN/GW SonicWall NSA 2400 x to 2 x ASA5510 (need SSL - VPN, detection/prevention of Intrusion, Virus, Malware protection similar) behind 2 x 2921 Cisco ISR routers. He comes to office relocation and redesign of the network.

    Suggestions or comments? It's very appreciated.

    BTW:

    1. difference between ASA5510 and ASA5520?
    2. it's a good idea to use the Juniper VPN instead of ASA5510/20 box?

    Thank you

    Dengming

    Hi Dengming,

    See the data sheets for Cisco ASA 5510 and 5520. You will find all the specs of the device and there is a feature to compare devices as well.

    See you soon,.

    Nash.

  • Configure asa5520 help

    I connected my asa5520 as:

    CAT6 (port Access)-> ASA5520 (outside)

    CAT6 (trunk port)-> (inside)-> vlan101 and vlan 102

    because I need people to see inside the machines, I used "no-nat-control."

    asa5520 configured as:

    interface GigabitEthernet0/0

    No nameif

    no level of security

    no ip address

    !

    interface GigabitEthernet0/0,101

    VLAN 101

    nameif vlan101

    security-level 100

    10.1.1.1 IP address 255.255.255.0

    !

    interface GigabitEthernet0/0,102

    VLAN 102

    nameif vlan102

    security-level 100

    10.1.2.1 IP address 255.255.255.0

    !

    interface GigabitEthernet0/1

    nameif outside

    security-level 0

    IP 10.1.3.9 255.255.255.0

    access outside the permitted scope icmp a session list

    access outside the interface allowed icmp extended outside the vlan101 interface list

    outside access-group in external interface

    on the cat6, I add static route:

    Route IP 10.1.1.0 255.255.255.0 10.1.3.1

    IP route 10.1.2.0 255.255.255.0 10.1.3.1

    Currently:

    in the box to asa5520, I ping out any machine, but not inside any machine (10.1.1.12 or 10.1.2.12)

    from the outside, I can ping external interface (10.1.3.9), not in interface 10.1.1.1 and not inside the 10.1.1.12 machine

    inside the 10.1.1.12 machine, cannot ping anything.

    Please advice me what I did wrong?

    Thanks in advance

    Did you apply the "permit same-security-traffic inter-interface" command? This is to allow communication between the same interfaces of security (enabled by the inter-interface same-security-traffic command) offers the following benefits:

    ? You can configure more than 101 communication interfaces. If you use different levels for each interface, you can configure only one interface per level (0 to 100).

    ? You can allow traffic to flow freely between all the interfaces of security even without access lists.

    This is necessary because both of your interfaces Vlan101 and Vlan102 are set to use the same level of security 100:

    HostName (config) # permit same-security-traffic inter-interface

    hostname (config) #static (vlan101, vlan102) 10.1.1.0 10.1.1.0 netmask 255.255.255.0

    hostname (config) #static (vlan102, vlan101) 10.1.2.0 10.1.2.0 255.255.255.0 netmask

    http://www.Cisco.com/en/us/customer/products/ps6120/products_command_reference_chapter09186a008063f0fb.html#wp1283601

    Pls note all useful message (s)

    HTH

    AK

  • How to configure ASA5520 of Checkpoint IPsec tunnel configuration

    Hi guys and under tension, a lot of it!

    I have a problem, I set up an IPsec tunnel between my ASA5520 at a Checkpoint Firewall (PE) CONFIG below (not true FT)

    network of the ASA_MAPPED object

    4.4.4.0 subnet 255.255.255.0

    network of the CHECKPOINT_MAPPED object

    5.5.5.5.0 SUBNET 255.255.255.0

    OUT_CRYPTO extended access list permit ip object ASA_MAPPED object CHECKPOINT_MAPPED

    Crypto ipsec transform-set ikev1 CHECKPOINT_SET aes - esp esp-sha-hmac

    destination NAT (INSIDE, OUTSIDE) static source ALLNETWORKS(10.0.0.0/16) ASA_MAPPED CHECKPOINT_MAPPED of CHECKPOINT_MAPPED static

    NAT (INSIDE, OUTSIDE) source of destination ALLNETWORKS(10.0.0.0/16) static ASA_MAPPED static 4.4.4.11 5.5.5.11

    card crypto OUTSIDE_MAP 5 corresponds to the address OUT_CRYPTO

    OUTSIDE_MAP 5 set crypto map peer X.X.X.X

    card crypto OUTSIDE_MAP 5 set transform-set CHECKPOINT_SET ikev1

    card crypto OUTSIDE_MAP 5 defined security-association life seconds 3600

    CHECKPOINT_MAP interface card crypto OUTSIDE

    tunnel-group X.X.X.X type ipsec-l2l

    tunnel-group ipsec-attributes X.X.X.X

    IKEv1 pre-shared-key 1234

    ISAKMP crypto 10 nat-traversal

    Crypto ikev1 allow outside

    IKEv1 crypto policy 10

    preshared authentication

    aes encryption

    sha hash

    Group 5

    life 86400

    IPsec Tunnel is in place and I can access the server on the other side via the beach of NATTED, for example a server behind the checkpoint with the IP 10.90.55.11 is accessible behind the ASA as 4.4.4.11, the problem is that I have never worked on a Checkpoint Firewall and servers/Server 4.4.4.11 that I can't connect to my environment to that checkpoint is configured with a Tunnel interface that is also supposed to to make NAT because of the superimposition of networks, at one point, I added an access to an entire list and bidirectional routing has been reached, but I encountered a new problem, I could not overlook from my servers public became unaccessecable, since all traffic was encrypted and get dropped to VPN: ipsec-tunnel-flow... for now the Tunnel is up and I can access the server via NAT 4.4.4.11, but can't access my internal servers. What did I DO WRONG (also, I don't have access to the Checkpoint Firewall (PE)) how their installation would be or how it should be to allow bidirectional routing?

    ========================================================

    Tag crypto map: CHECKPOINT_MAP, seq num: 5, local addr: X.X.X.X

    Access extensive list ip 4.4.4.0 OUT_5_CRYPTO allow 255.255.255.0 5.5.5.0 255.255.255.0

    local ident (addr, mask, prot, port): (4.4.4.0/255.255.255.0/0/0)

    Remote ident (addr, mask, prot, port): (5.5.5.0/255.255.255.0/0/0)

    current_peer: X.X.X.X

    #pkts program: 3207, #pkts encrypt: 3207, #pkts digest: 3207

    #pkts decaps: 3417, #pkts decrypt: 3417, #pkts check: 3417

    compressed #pkts: 0, unzipped #pkts: 0

    #pkts uncompressed: 3207, model of #pkts failed: 0, #pkts Dang failed: 0

    success #frag before: 0, failures before #frag: 0, #fragments created: 0

    Sent #PMTUs: 0, #PMTUs rcvd: 0, reassembly: 20th century / of frgs #decapsulated: 0

    #send errors: 0, #recv errors: 0

    local crypto endpt. : X.X.X.X/0, remote Start crypto. : X.X.X.X/0

    Path mtu 1500, fresh ipsec generals 74, media, mtu 1500

    current outbound SPI: 5254EDC6

    current inbound SPI: 36DAB960

    SAS of the esp on arrival:

    SPI: 0x36DAB960 (920303968)

    transform: aes - esp esp-sha-hmac no compression

    running parameters = {L2L, Tunnel}

    slot: 0, id_conn: 19099648, crypto-card: CHECKPOINT_MAP

    calendar of his: service life remaining (KB/s) key: (3914999/3537)

    Size IV: 16 bytes

    support for replay detection: Y

    Anti-replay bitmap:

    0 x 00000000 0x0000000F

    outgoing esp sas:

    SPI: 0x5254EDC6 (1381297606)

    transform: aes - esp esp-sha-hmac no compression

    running parameters = {L2L, Tunnel}

    slot: 0, id_conn: 19099648, crypto-card: CHECKPOINT_MAP

    calendar of his: service life remaining (KB/s) key: (3914999/3537)

    Size IV: 16 bytes

    support for replay detection: Y

    Anti-replay bitmap:

    0x00000000 0x00000001

    unless I include any any on my access-list and the problem with that is  that my Public servers then get encrypted from the OUTSIDE interface  unless you know of a way to bypass the VPN

    No, u certainly shouldn't allow 0.0.0.0 for proxy ACL. Again, your config is very good. In addition, package account, this show that traffic is going throug the tunnel in two ways:

    #pkts program: 3207

    #pkts decaps: 3417

    Also, looking at the meter, I can guess that some of the traffic comes from the other site, but does not return back (maybe that's where you can not connect from behing Checkpoint). If you say that 0.0.0.0 solved the problem, are there no other NAT rules for subnet behind ASA, so the server IP, for which you are trying to connect behind the checkpoint, translates into something else (not the beach, included in proxy ACL), when to come back?

  • Routing with Cisco ASA 5520 VPN

    I have installed IPsec vpn remote users in the Cisco ASA 5520 using RADIUS in my main network. Works very well. I have a site to my Cisco ASA5520 tunnels going to other sites, some of the tunnels have Cisco ASA and some have SonicWalls. I wish that my users VPN remote IPSec to be able to navigate in these tunnels is a site to access remote subnets attached to these tunnels. Do I need to use a combination of routing and the ACL? Or can I just use ACL only? Or just use routing only?

    Thank you

    Carlos

    Hello

    The key to set up here is the two ACL of VPN L2L end points that determine the 'interesting' traffic to connect VPN L2L. You will also need to confirm that the connection of the VPN Client is configured so that traffic to the remote sites have sent to the connection of the VPN client. There are also other things that you should check on your ASA plant

    Here most of the things you usually have to confirm

    • Set up 'permit same-security-traffic intra-interface' if it is already present in your configuration

      • This setting will allow connections to form between the hosts that are connected to the same interface on the ASA. In this case, applies because the VPN client users are connected to the interface 'outside' of the ASA and also remote sites are connected to the ASA to "external". If the traffic between the remote VPN Client and VPN L2L sites will be to enter and exit the same interface
    • You will need to check how the customer if configured VPN connection. Split or full Tunnel tunnel
      • If the connection of the VPN Client is configured as Split Tunnel then you need to add all the networks from the remote to the Split Tunnel, so that the connections between the VPN Client is transmitted to the ASA and from there connections VPN L2L
      • If the connection of the VPN Client is configured as full Tunnel, then there no problem that all traffic is transferred to the Client VPN connection all its assets
    • Define the VPN pool in the ACL of VPN L2L
      • You should make sure that the pool network VPN Client is defined in the ACL that define 'interesting' traffic to connect VPN L2L. So, you need to add the pool VPN VPN L2L configurations on the sites of Central America and remote control
    • Configure NAT0 / NAT exempt for remote VPN Client to L2L VPN Site traffic at both ends of the VPN L2L
      • You must ensure that the NAT0 / exempt NAT rules exist for the VPN Client for Remote Site traffic. This will have to be configured on the SAA "outside" interface. Format of configuration varies naturally a bit on the ASA Central his software level.

    These should be the most common things to set up and confirm for traffic to flow between the VPN Client and Remote Sites

    Hope this helps please rate if yes or ask more if necessary.

    -Jouni

  • Traffic no routing between remotes using ezVPN with NEM

    I scoured the forums for a while now, looking for ways to solve this one but just can't find anything that helps.  I ezVPN configured on an ASA 5520 for my server with 5505 s like my clients at several remote sites.  The tunnels go up without a problem and I can hit what I need on both sides of the tunnel, but I'm not able to go to another remote network from a remote network.  Traffic shuts down the tunnel on the 5505, but on the 5520 I don't see is a bunch of scrolling tear down messages.  Any thoughts would be greatly appreciated.

    Side hub

    interface GigabitEthernet0/0

    nameif Inside_Network

    security-level 100

    the IP 10.0.0.1 255.255.255.252

    !

    interface GigabitEthernet0/3

    nameif Outside_Network

    security-level 0

    IP 192.168.32.8 255.255.255.0

    !

    permit same-security-traffic inter-interface

    !

    Router eigrp 10

    Network 10.0.0.0 255.255.255.0

    redistribute static

    !

    Crypto ipsec transform-set ikev1 my - set esp-aes-256 esp-sha-hmac

    Crypto-map dynamic ezvpn 30 set transform-set my - set ikev1

    Crypto-map dynamic ezvpn 30 the value reverse-road

    map outside_map 65535-isakmp ipsec crypto dynamic ezvpn

    outside_map Outside_Network crypto map interface

    Crypto ikev1 enable Outside_Network

    IKEv1 crypto policy 10

    preshared authentication

    aes-256 encryption

    sha hash

    Group 2

    life 86400

    !

    internal VPN_GP group policy

    VPN_GP group policy attributes

    VPN-idle-timeout no

    allow to NEM

    !

    username password encrypted Wj0QXCAEhK12A5Sp privilege 0 vpnuser

    !

    VPN Tunnel-group type remote access

    General-attributes of VPN Tunnel-group

    Group Policy - by default-JEOD_VPN_GP

    Group-tunnel VPN ipsec-attributes

    IKEv1 pre-shared-key *.

    Remote side - more than necessary here

    vpnclient Server 192.168.32.8

    vpnclient mode network-extension-mode

    vpnclient vpngroup VPN password *.

    vpnclient nickname vpnuser password *.

    vpnclient enable

    EzVPN remote clients can connect to the Headend ASA5520 but cannot communicate with each other. Is it correct to understanding?

    All guests of EzVPN are end on a different external physical interface of the ASA? If not, we will have to allow intra-interface traffic too with inter-UI that is same-security-traffic permit intra-UI.

  • VPN (remote access, ASA5520) with 2 clients, one with Internet and other without Internet

    Hello! I make a VPN with two clients, using the ASA5520 United Nations. Now I have to do what the customer has internet and the other does not. I can do using ACL? How?

    The configuration is:

    interface GigabitEthernet0/0

    nameif outside

    security-level 0

    IP 172.16.31.252 255.255.255.248

    interface GigabitEthernet0/1

    nameif inside

    security-level 100

    IP 172.16.1.237 255.255.255.240

    Access extensive list ip 172.16.1.224 ACLnonat allow 255.255.255.240 host 172.16.1.230

    Standard access list Split_tunnel allow 172.16.1.224 255.255.255.240

    IP local pool testpool 172.16.1.230 - 172.16.1.232 mask 255.255.255.240

    NAT (inside) 0-list of access ACLnonat

    Route outside 0.0.0.0 0.0.0.0 172.16.31.254 1

    Crypto ipsec transform-set esp-3des esp-md5-hmac hw_trans

    life crypto ipsec security association seconds 28800

    Crypto ipsec kilobytes of life - safety 4608000 association

    Crypto dynamic-map dyn_map 1 transform-set hw_trans

    Crypto dynamic-map dyn_map 1 the value reverse-road

    stat_map 10000 card crypto ipsec-isakmp dynamic dyn_map

    stat_map interface card crypto outside

    crypto ISAKMP allow outside

    crypto ISAKMP policy 10

    preshared authentication

    3des encryption

    sha hash

    Group 2

    life 3600

    Crypto isakmp nat-traversal 30

    internal hw_policy group policy

    attributes of the strategy of group hw_policy

    value of server DNS 193.205.160.3

    Split-tunnel-policy tunnelspecified

    value of Split-tunnel-network-list Split_tunnel

    Split-dns value 193.205.160.3

    username User1 encrypted password privilege 0 pqA3EDHB1cfLxwWn

    password username User2 FIQ1c02tX8lU1wHJ encrypted privilege 0

    attributes of user User2 name

    VPN-framed-ip-address 172.16.1.233 255.255.255.240

    allow password-storage

    type tunnel-group hwclients remote access

    tunnel-group hwclients General-attributes

    address testpool pool

    Group Policy - by default-hw_policy

    hwclients group of tunnel ipsec-attributes

    pre-shared key *.

    ISAKMP retry threshold 30 keepalive 5

    Thanks in advance.

    Hello Jose,.

    I see that you use LOCAL authentication, what you can do is, you can create another political group and link this political group for the user name, example:

    attributes of group PALLET policy

    Split-tunnel-policy tunnelall

    name of User1 user attributes

    RANGE of VPN-group-policy

    The other username will use hw_policy, since it is the default value for the tunnel-group hwclients.

    HTH

    AMatahen

  • Tips to add a VPN router to my current network configuration

    Dear all

    My apologies if the answer to this question already exists, however, I searched in many situations and none seem to match what I'm after.

    I currently have an ISP modem/router in Bridge mode connected to a TC of Apple which is my wireless router, I have 2 Express airport connected to this acting as the extensors of the range.  I have a VPN service through the MyPrivate network I activate on the desired device when required and everything works fine.

    What I want to do now is to be able to use my AppleTV and burning Amazon via the VPN as well so you need to add a VPN router in the configuration.  I want to finish with 2 wireless networks running together for these devices who need VPN and those who are not.  I don't want to lose the opportunity to extend the network to express it however airport.

    If someone could explain to me if this is possible and if so how do I set up the network.

    Thanks in advance

    Mark

    Basically you would need a device that supports VPN-passthrough and VLANS for your goals of networking. MyPrivate network, seems to be a VPN SSL, which is a user-server configuration. In other words, you install a client VPN on your Mac and you connect to the VPN network MyPrivate server to establish a VPN tunnel.

    Networking two or more "separated", should be using a router that supports VLAN services. Each segment of VIRTUAL local area network, in essence, would be a separate, she either wired or wireless network or a combination of both. This would probably be the 'easiest' part for the installation program.

    Now how combining the two would be the question, and I don't know what would be the best way, or even if it is possible.

    A few thoughts:

    • Use a router that supports VLANS. Create at least two VIRTUAL LAN segments. One for Apple TV & Burns, one for Internet access in general. Connect the device to VPN client host on the first segment, and configure for Internet sharing.
    • Download a dedicated VPN network application that supports hosting of third-party VPN clients, like yours. You would still need a router that supports VLAN to provided separate network segments.
    • Hire a consultant network. Let them know what you the goals of networking and ask them to offer potential solutions.
  • Time Capsule as a router

    Instead of the cable company router, can I use my time capsule to be a router?

    The time Capsule can function as a router, but not a modem. If what you provided your cable provider is a simple modem, then the time Capsule will work. However, if they actually you provided a combination modem and the router, also known as a gateway device, then it wouldn t.

Maybe you are looking for