How default of a multiple selection for all values setting?

I have a setting that allows the user to select multiple values.  I want the default to use all values (which means basically just ignore this parameter in the generated SQL code).  However, I can't create named on this calculation since it accepts multiple values, and the calculation supports only the first value.  Is there a way to do what I need, without selecting all the values in the list (the LOV contains hundreds and hundreds of values so it's not a viable option).  I'm not very experienced with the discoverer and don't know all the tips/solutions workaround, if you are looking for expert advice.

Thank you

Hello

You must code the parameter and the condition that he accepts the word ALL.

For example, suppose you are working with ITEM_NUMBER and you have thousands of articles. You want the user to be able to one or more key or access all THE items.

You must create a Boolean condition like this:

ITEM_NUMBER IN: ITEM_PARAMETER

OR

UPPER(:ITEM_PARAMETER) = "ALL".

So if the user key word ALL all all or or any variation of the word to be determined as true by the condition and all items will be selected. If the user does no key ALL, and then the other half of the condition will be applied and the element must be a valid element as contained in the list of all the elements. You can even create your parameter with a default value of all THE

Best wishes

Michael

Tags: Business Intelligence

Similar Questions

  • How to give the right to select for all objects of schema?

    Hello

    We have a lot of users and schemas.
    A user wants to execute 'select' for all tables in the other schema.

    For example: TEST user wishes to select the objects to TEST2. Test2 have hundreds of tables, TEST user cannot select other schema objects, so I don't want to give SELECT ANY TABLE privileges.

    How can do this at once? is it possible to give all the objects schema once subsidies?
    DB versin. 9.2.0.8

    greetings and thanks

    No, there are no subsidies. You must use hundreds of statements of grant.

    However, you can use dynamic SQL to do this automatically, i.e.

    CREATE ROLE test2_select;
    
    BEGIN
      FOR x IN (SELECT * FROM dba_tables WHERE owner='TEST2')
      LOOP
        EXECUTE IMMEDIATE 'GRANT SELECT ON test2.' || x.table_name || ' TO test2_select';
      END LOOP;
    END:
    /
    
    GRANT test2_select TO test;
    

    Justin

  • I made my largest site and how can keep the same size for all other sites?

    I did the 2 larger site and how to keep the same size for all pages when I re - open the web browser?

    You can use an extension to set a page zoom and the size of the default font on the web pages.

  • Model of multiple selection for ComboBox

    Javadoc stats

    "As in the ListView, it is possible to change the SelectionModel which is used, although this is likely to be rarely changed. The default SelectionModel used in ComboBox is a SingleSelectionModel, but that can be sorted on by developers to instead allow multiple selection occur, or to change the behavior of the various methods provided in these APIs. "

    Yet when I try to set the selection model as I would to a listview using the following
    comboBox.getSelectionModel().setSelectionMode(SelectionMode.MULTIPLE);
    I am informed that setSelectionModel is not available.

    How to enable you multiple selection in a ComboBox?

    The javadoc you cite above is in fact wrong and comes from an era where the selectionModel property of type «SelectionModel» ComboBox Since then, it has evolved to be "SingleSelectionModel. Which means, of course, you can put some instance of model selection in the ComboBox, but only choice will be always supported. We did it as multiple selection has no real meaning without drastic changes to the UI and UX, and we thought that a separate control could be developed in the future to better support this use case.

    Thanks to notice the incorrect documentation - I'll fix it shortly.

    -Jonathan

  • How to use the Multiple selection in ADF faces

    I have, I want to know how to use a multiple selection (ADF select several choices) for updating the database.

    by mentioning your exact jdev version.

    As far as I know he in not possible automatic update select a choice that she returns a list which you must map back to the lines of the table yourself.

    Timo

  • How to show the multiple declaration for an application

    How to show the multiple declaration for an application

    Thanks for your suggestions...

    Looking at the javadocs you can only save an indicator by application. You will need to do three separate applications and package them as an If you want three different indicators to be visible at a time. Or change the flag that (or which group) of the indicators you want to display.

  • How can I block the SMTP for all users but mail server

    I can't understand (1) how can I refuse port 25 for all users on the network and allow for Exchange server SMTP, also I have MS Exchange, which manages the web and smtp and in my setup below you can see that there static mapping to publick ip with http/smtp only, then (2) how can we separate the traffic entering a publc IP will outside servers inside ex : (MSexchange public ip address is x.x.x.207-> http = 172.16.2.13, 172.16.2.14 = smtp)

    Thank you

    ___________________________________________________

    6.3 (1) version PIX

    interface ethernet0 car

    Auto interface ethernet1

    ethernet0 nameif outside security0

    nameif ethernet1 inside the security100

    names of

    name 172.16.4.10 pdc

    name 172.168.4.11 llc

    name 172.16.4.11 ftp

    object-group service E-mail tcp

    port-object eq www

    EQ smtp port object

    object-group service tcp - udp terminal

    3389 3389 port-object range

    object-group service mw tcp - udp

    Beach of port-object 367 367

    radmin tcp service object-group

    RemoteAdmin description

    4899 4899 object-port Beach

    object-group service mw1 tcp

    Beach of port-object 367 367

    access-list 101 tcp refuse any any eq smtp

    access-list 101 permit tcp any host object-group x.x.x.251 terminal

    access-list 101 permit tcp any host x.x.x.214 object-group radmin

    access-list 101 permit tcp any email host x.x.x.207 object-group

    access-list 101 permit tcp any host x.x.x.212 object-group mw1

    access-list 101 permit tcp any host x.x.x.211 eq ftp

    sheep ip access-list allow any 192.168.101.0 255.255.255.240

    IP address outside x.x.x.194 255.255.255.192

    IP address inside 172.16.2.1 255.255.0.0

    IP verify reverse path to the outside interface

    IP verify reverse path inside interface

    alarm action IP verification of information

    IP audit attack alarm drop action

    IP local pool mypool 192.168.101.1 - 192.168.101.20

    don't allow no history of pdm

    ARP timeout 14400

    Global interface 10 (external)

    NAT (inside) 0 access-list sheep

    NAT (inside) 10 0.0.0.0 0.0.0.0 0 0

    static (inside, outside) x.x.x.212 172.16.4.12 netmask 255.255.255.255 0 0

    static (inside, outside) x.x.x.251 172.16.4.51 netmask 255.255.255.255 0 0

    public static x.x.x.214 (Interior, exterior) pdc netmask 255.255.255.255 0 0

    public static x.x.x.211 (Interior, exterior) ftp netmask 255.255.255.255 0 0

    "REM # 172.16.2.13's Exchange with Outlook Web servers #

    static (inside, outside) x.x.x.207 172.16.2.13 netmask 255.255.255.255 0 0

    Access-group 101 in external interface

    Route outside 0.0.0.0 0.0.0.0 x.x.x.193 1

    enable floodguard

    Sysopt connection permit-pptp

    VPDN PPTP-VPDN-group accept dialin pptp

    VPDN group PPTP-VPDN-GROUP ppp authentication pap

    VPDN group PPTP-VPDN-GROUP ppp authentication chap

    VPDN group PPTP-VPDN-GROUP ppp mschap authentication

    VPDN group PPTP-VPDN-GROUP ppp encryption mppe 40

    VPDN group VPDN GROUP-PPTP client configuration address local mypool

    VPDN group VPDN GROUP-PPTP client configuration dns 172.16.2.6 172.16.4.6

    client PPTP-VPDN-GROUP VPDN group configuration wins nymc_pdc

    VPDN group VPDN GROUP-PPTP pptp echo 60

    VPDN group VPDN GROUP-PPTP client for local authentication

    VPDN username * password *.

    VPDN allow outside

    This is your problem:

    Access-group 101 in external interface

    You link this access list to your external interface. This means that the rules are applied to incoming traffic IN your network. The implicit IP any any rule is because you have not bound to an access list on your inside interface.

    To prevent users from going out, you will need this:

    access list permit tcp host exchange_IP OUTPUT no matter what eq smtp

    access list tcp OUTPUT deny any any eq smtp

    Access-group interface inside OUT

    See how this access list is linked to the inside interface... it will affect traffic leaving your network. Note: Once you apply this inside allow any interface it will remove the implicit.

  • How to make a display virtual for all incoming messages from multiple accounts, just like in Opera Mail?

    I want to have a replica of the Opera e-mail function. This feature allows you to aggregate all shipments of all accounts of e-mail in a single virtual aggregated view.
    That is to say, we have 3 different e-mail accounts. Mozilla Thunderbird on a daily basis, I check if there is something again in the folder entering for the CPA. To do this, I click on the folder for each account. Now, what I want, is to click on a single folder where I would have a virtual aggregate view of the record entering for all these 3 accounts. I guess that, same thing can be done with different types of mail, such as:

    • Unread messages (after watching the mail, it automatically goes straight to aggregation 'Messages sent', below)
    • Read messages
    • Messages sent
    • Spam messages
    • Drafts, etc.

    There is also this interesting feature (virtual thing applies here as well) which allows to have a bird's-eye view of attachments across all accounts classified into different job descriptions, such as:

    • docs (xls, doc, ppt, etc.)
    • images (jpg, png, etc.)
    • Archives (zip, rar, etc.)

    More then that it would be even better to have characteristic labling discovers aggregation through all our. In other words, if we scored several important messages in, say, 2 accounts, those that must be considered in the same virtual aggregate view by name, for example, "important messages". Maybe even with flags, todos, etc..

    POP email accounts can be configured to use a global Inbox. Email IMAP accounts cannot.

    However, there are several 'views' in Thunderbird. I suggest you try "unified." This creates a Visual Inbox containing all messages in the Inbox with subfolders showing the individual mailbox, so you can always see them separately if necessary.

    through the menu bar;
    View > folders > unified

    Via the Menu icon
    Icon of the menu > folders > unified.

    This view would show all emails marked "Important", in order to sort by Tag.

  • How to put a common page for all users after loging on?

    Hi all
    "My dashboard" is now the default page after logon.
    I want to put a home page by default for all users. users can see the homepage after loging on.

    How to change the default dashboard "My dashboard" to the "Home page" for all users?

    Thank you
    Dan

    Hello

    Steps to follow:

    Tried to put the default dashboard for all users.
    1. creates a session init block
    "2 source of data used in select ' / shared/SH Test / _portal / Test1" double
    3. This value assigned to the variable of session CHEMINPORTAIL
    4. in presentation services > Administration > my account > default dashboard must be set to "default". Then only the dashboard specified in block init will appear otherwise my account will override the init block.
    5. save the changes to the RPD.
    5 disconnect and reconnect to see if it works well. It works perfectly fine.

    For more details, please see the document of CSG replication. But this is for all users.

    If the customer wishes to have a user/group basis homepage.
    1. they should have 2 separate tables.
    i. Group_path_tab with 2 columns. Group_id, portal_path
    Wise group path portal for all groups
    II. user map table group
    Group_id, groupname, user_id

    The user should be part of a group.

    2. then in the writing init bulk sql must be something like this

    Select A.portal_path in the Group_path_tab A, User_group_map B
    where = B.user_id: USER
    and B.Group_id = A.Group_id

    SO, based on the USER session variable, it will try to identify the group, and then the portal_path.
    Finally, set this value to the session CHEMINPORTAIL variable.

    Ref:
    http://total-bi.com/2011/01/OBIEE-11g-change-default-dashboard/
    Thank you!

  • How to permanently change the font for all emails color

    How can I change the color of the font for all my emails constantly?

    E-mail address is removed from the privacy *.

    Hello Msmouser,

    What mail client do you use?
    If you use Outlook, I suggest to look at this article:
    If you use your web mail from Verizon, I would say that to visit the Verizon Mail support page:
    If you use Windows Live Mail, please visit:
  • Accidentally by default of the same program for all programs

    I tried to open Dell Webcam central because it did not work. I have a click right and select open with, then select default opener. I have not noticed that the box that says something in the sense of "make default for all programs" was checked. Now any time I try to open any program, it opens the webcam.

    I tried to do the system restore, but received an error message about a file problem. He said to try to disable my antivirus, which I did and it still doesn't work.

    I tried to go back and select the default program for each program, but that does not change.

    Help?

    There is a cure, but it will probably a registry change to get there.

    Here are three links that might solve your problem. The first contains once also the other so if arrive you at the entrance to Amrita and use the link here to 'fix' you don't have to bother with the second link.

    Good luck

    http://social.answers.Microsoft.com/forums/en-us/w7programs/thread/6becdf43-28d2-4eb5-B3E8-a7fcd0b5c69b/

    http://support.Microsoft.com/kb/950505

    http://www.Winhelponline.com/articles/165/1/restore-the-exe-file-association-in-Windows-Vista-after-incorrectly-associating-it-with-another-application.html

  • How can I change the settings for all instances of a particular effect?

    I applied the same color correction effect to many of the components of the package. Now I want to refine the correction of the colors (the same setting for all the clips yet). How can I change all instances of the effect of color correction setting without going into each clip manually?

    Looking forward to your thoughts on this! Go on and save my winter Assembly day ...

    Two ways, change a clip and then copy it, all the other clips, right-click / Remove effects, and then select Paste attributes. Another way is to add an adjustment layer and apply the color correction to that.

  • How to hide a multiple selection of the TableRegion element dynamically

    Hi all

    I have a requirement to hide the column multipleselection area of table dynamically. Based on the id liability multipleselection column must be disabled or hide.

    I gave the following code to set the fake rendered property.

    OATableBean tabBean = (OATableBean) webBean.findIndexedChildRecursive ("SearchTable");
    Salt of OAMultipleSelectionBean = (OAMultipleSelectionBean) tabBean.getTableSelection ();

    sel.setRendered (false);

    But it's not working. Someone help me in this.

    Thank you and best regards,

    Myvizhi

    Hello

    Try using the code below:

    (I found this on the blog of Mukul

    Oracle of Mukul technology blog: dynamically change multiselect for single select statement in table of the OAF)

    Hide Multiple selection

    OAAdvancedTableBean tabBean = (OAAdvancedTableBean) webBean.findIndexedChildRecursive ("[table item id]");

    Given that multiple selection is at the end, get the total-1 to remove

    int count = tabBean.getIndexedChildCount (pageContext.getRenderingContext ());

    System.out.println ("number of children" + count);

    tabBean.removeIndexedChild(count-1);

    Sushant-

  • How to disable dafault drill report for all columns

    Someone help me how to disable the default drill down to the report.

    for some reason, if I click on any of the results column it is forest (navigating) down to a report (same).

    Ex: if I click the column totals in the area in question perticular, it navigates to a report.it sailing on the same report for all fields of the discipline.

    one got this type of problem please help me solve this problem?


    Thanks in advance.

    Hi user,

    Follow these steps

    search for the tag "Navtarget".

    Reference: http://obiee101.blogspot.com/2009/02/obiee-editing-system-wide-defaults.html

    Thank you
    Saichand.v

  • How to register ActiveX exe server for all users

    Hello

    I'm aware that with newer versions of the CVI and Windows when you generate an ActiveX exe server, it records only the server for the user profile.  I read one white papers OR who said that computer administrator may register the server for all users.  I am an administrator for the development of PC we use.  I went to the command and he ran as the administrator of the PC.  I then navigate to the path of the exe.  I published the regserver command.  Unfortunately, I am unable to distinguish if the server exe was registered for all users or if it combined again to my user profile.  Our server exe is called by another program of the CVI.  To validate if the server exe had been registered for all users, I had a user who had not built server exe on the development PC connection and try to start the server within its own CVI program exe.  When this has been attempted, the user receives an error "class not registered".  The user was not able to successfully launch the exe of the server until it has built on the PC itself.  It does not appear that the administrator regserver command worked to save the exe file of the server for all users.  Is anyone aware of any steps that I may have missed?

    I'm working on a Windows 7 with Service Pack 2 for LabWindows/CVI 2013.

    Thanks in advance.

    You will probably have to use Google.

    http://social.msdn.Microsoft.com/forums/en-us/0022ca21-CAA2-4be5-b519-757ff9daf7fb/how-to-register-3...

    or maybe http://social.msdn.microsoft.com/Forums/vstudio/en-US/4fb96971-53a1-4e25-bc75-b49cfaf4d574/problems-...

Maybe you are looking for

  • NI-VISA 5.1.2 outputs/farm right after launching it on CentOS Linux 6.2 PC, also blocks LabVIEW trying to create VISA constant REF for VISA Open.

    After installing 2011 LaBVIEW and NI-VISA 5.1.2 on CentOS 6.2 PC, I noticed a problem trying to use the LabVIEW vi VISA, basically it does not work for me, LabVIEW crashed when trying to create a control, or a constant for the open VISA vi.  Tried to

  • HP Pavilion dv8: processor speed

    The cpu speed reported in the Task Manager is 0.91 Ghz. The reported speed is always this number; or more or less quickly. The system is 1,60 Ghz with 6 GB of memory. How can I get the full speed? The system is a logical core 4 core 8 but seems rathe

  • Radeon 9600 Pro in a gx270s?

    I ordered a Radeon 9800 Pro, because I've seen this thread: en.community.dell.com/.../17363749 Well, the person of Amazon sent me the wrong card and it was a 9600 instead of the 9800. The 9600, however, fits perfectly, the lights of the computer turn

  • How disable the full row select in Windows 7 Explorer?

    Keith Miller provided that a registry change works on Vista. http://social.technet.Microsoft.com/forums/en/itprovistadesktopui/thread/7101bb56-c0b7-48af-a493-2fb8c8ea0ead but it does not work on Windows 7.I tried the two editing the registry and run

  • MY PROBLEM OF MICROSOFT WORD...;

    I was wondering if I could help me with my problem of Microsoft Word; When I type in word the cursor keep moving through the other words I already typed and make mistakes and need to cancel strike to correct their place.