QString Param passing curl - C++, type the question?

What I try to do

Pass a QString to a C++ method. The method is effective QML.

My Code

applicationui.cpp

// Default empty project template
#include "applicationui.hpp"

#include 
#include 
#include 
#include 

#include 
#include 

#include 
#include 

using namespace bb::cascades;
using namespace bb::system;
//new to text message

ApplicationUI::ApplicationUI(bb::cascades::Application *app)
: QObject(app)
{
    // create scene document from main.qml asset
    // set parent to created document to ensure it exists for the whole application lifetime
    QmlDocument *qml = QmlDocument::create("asset:///main.qml").parent(this);
    // create root object for the UI
    AbstractPane *root = qml->createRootObject();
    qml->setContextProperty("_app", this);
    // set created root object as a scene
    app->setScene(root);
}

void ApplicationUI::routeQuery(QString query)
{
     CURL *curl;
      CURLcode res;

      curl = curl_easy_init();
      if(curl){
        curl_easy_setopt(curl, CURLOPT_URL, "http://google.com/search?q="+query);
        /* example.com is redirected, so we tell libcurl to follow redirection */
        curl_easy_setopt(curl, CURLOPT_FOLLOWLOCATION, 1L);

        /* Perform the request, res will get the return code */
        res = curl_easy_perform(curl);
        qDebug() << res;
        qDebug() << "making query";

        /* Check for errors */
        if(res != CURLE_OK)
          fprintf(stderr, "curl_easy_perform() failed: %s\n",
                  curl_easy_strerror(res));
      }
        /* always cleanup */
        curl_easy_cleanup(curl);
}

applicationui. HPP

// Default empty project template
#ifndef ApplicationUI_HPP_
#define ApplicationUI_HPP_

#include 
#include 
#include 
#include 
#include 

namespace bb { namespace cascades { class Application; }}

/*!
 * @brief Application pane object
 *
 *Use this object to create and init app UI, to create context objects, to register the new meta types etc.
 */
class ApplicationUI : public QObject
{
    Q_OBJECT
public:
    ApplicationUI(bb::cascades::Application *app);
    virtual ~ApplicationUI() {}
    Q_INVOKABLE void routeQuery(QString query);
};

#endif /* ApplicationUI_HPP_ */

hand. QML

import bb.cascades 1.2
import bb.system 1.2

Page{
Container{
layout: StackLayout{
    orientation: LayoutOrientation.TopToBottom
}TextField{   id: userQuery   text: ""   hintText: "Enter your search..."}
Button{
     text: "Route"
     onClicked: {
         _app.routeQuery(userQuery.text);
      }
     }

}
}

Errors / question

The issue is the line where I spend the "query" in the url for google. Here's what says the error:

cannot pass objects of type trivially uncopyable ' class const QString "by «...» »

Notes
- QString - BBDOC

- Integration of QML/C++ - BBDOC

- Example of C++ Curl Simple HTTP (curl.haxx.se)

Been stuck on this day. Please help if you can get this to work.

Hello

Libcurl is probably waiting for style C UTF8 string Qt strings are UTF16

This product code QString:

"http://google.com/search?q=" + query

Try this conversion:

curl_easy_setopt(curl, CURLOPT_URL, ("http://google.com/search?q=" + query).toUtf8().constData());

. toUtf8() converts QString QByteArray UTF8.

. constData() returns const char *.

Tags: BlackBerry Developers

Similar Questions

  • Satellite P100-188: type the question - forgotten key & pointer jump

    Hello

    Bought my p100-188 week last to replace my toshiba PIII 2.66. After a week I noticed that when typing unless I press really hard that it does not record the keys. Also
    the mouse pointer when it moves around the screen tends to move momentarily on a point, then jump past.

    All thought is appreciated.

    Hello

    I recommend you this announcement:
    http://forums.computers.Toshiba-Europe.com/forums/thread.jspa?threadID=14317

    Check it out. It describes a similar or the same question. It should help.
    In addition, you should compare the version of the BIOS on the laptop with the version of the BIOS on Toshiba page. If there is a newer version so you can update. But be sure you use the good BIOS and the right update procedure.

  • A Quiz Question. Pass mark shows in the results; Error message displayed

    I have a quiz of a question at the end of my course of SCORM1.2. "Do mark you this course finished in the LMS?" Yes/No.

    If the user clicks on no, the present results screen notes "0". But button recovery brings back the slide 5 (a content slide), and no to the question Quiz. If the user clicks Yes, results screen shows "100" score, but display a failure message, not the message of success.

    I tried all types of settings, including not to show a result slide and cannot get this to work. On our LMS, it seems if I let you move backwards in Quiz preferences (I need so that the "previous" button to work throughout), the 'yes' mark (100%, full course) is not passed to the LMS.

    Can anyone provide guidance on what I should use for the Quiz and Quiz preferences properties settings?

    Hi Ingrid,.

    Can you check, perhaps in advanced Interactions (F9) if there is an object received from slide 5? Because this score will be added to the system variables. If it has a partition, use the accordion of Reporting in the properties panel to delete the partition.

    Lilybiri

  • How can I "automate" a question of a single line and response? the answer starts with the right margin and ending on the right margin as it is typed. The sequence would be: 1 type question 2. Tab at the right margin. 3 type the answer ending on the margin

    5.6.1 MacBook early 2015 OS X 10.11.3 pages

    Question: How can I easily format a series of "a line of questions / answers" (questions and answers on the same line.)

    How to easily create a long series of a single line of questions and answers to the question aligning it on the left and the end of the response by aligning right?

    For example

    !. Type the short question on the left margin.

    2. tab at the right margin.

    3. type the answer with the end of the answer on the right margin.

    Insert a right tab at the right margin.

    Peter

  • When I type a question in the search box, I want that my question to stay there until I checked all the results of the research

    I have Windows 7-64 bit

    When I type a Question in the search box, I want my Question to stay there, until I checked all the search results!

    Whenever I have check a result, my question goes, and then I have to type my Question even once! We don't waste any the end of time!

    My Question must stay there until I've done my research and I hit another Question!

    Thank you.

    N.Williams.

    Original title: Windows search problem

    Hello

    If you run a search in Windows 7 from the Start Menu search box, the search string is not saved in the search box. This is normal.

    However, if you are looking for using the search box on the upper right corner of the Windows Explorer window, the search string is saved in the search box and stays there until you delete it or close the Windows Explorer window.

    Reference links:

    Windows Search in Windows 7: http://Windows.Microsoft.com/en-us/Windows7/products/features/Windows-search

    Find what you are looking for: http://Windows.Microsoft.com/en-us/Windows7/help/find-what-you-are-looking-for-staying-organized-in-Windows-7

    Hope this information helps.

  • Difficulty to tear the question with all adobe products using mercury pass?

    Hello.

    I am running the latest version of the Adobe Suite CC (applications are up to date). My computer is an AMD FX 8150 with 390 R9 graphics (whose driver is also up-to-date) running newer versions of Windows 10 retail. The question that I have is a kind of 'tearing' effects on all monitors using mercury pass, any, I choose rather made hardware or software. "Tear", as long as I can describe it appear in all the images loaded in all adobe, same programs still images that are exhausted after through. It's almost like my graphics card seeks to restore the 1/4 of the screen horizontally at different times, and this translates into 4 or 5 "break points" along the sequence of the preview. This is not bad, until you have a shot that makes a horizontal pan, then it's like 4 or 5 different 'zones' of the screen trying to return at different times... Given that it is clearly not a problem with the original files (how could it be?), and it does not appear when the sequence is rendered, what it might be? There must be a problem purely with mercury pass, given that the tear does NOT appear on the workspace to preview the video in the any adobe applications... Appearing rather than on the monitors that are designated as "external" using mercury emissions. My images of viewport seems perfectly functional and free ' tear'.

    I don't see it to be a rate issue, because it is, it does not matter what film is loaded in... Even a still image with a pan of the camera it will show after effects.

    So to summarize, there seems to be a problem with mercury pass that I can't solve. No matter what I do, the tear will not disappear when you view the images on a monitor 'external', which has been designated as such in the preferences "previews". All the drivers and software are updated, and it does little matter images by selecting the software hardware rendering vs makes no difference either.

    Does anyone know of a solution to this? Someone else has the same problem? It's very annoying and almost enough to make me want to give up using Adobe products all together, it's that bad.

    My main graphics card is the I/O device.

    Ahhh.  This is probably the question on this one.  You must run a dedicated unit of I/O for companies like AJA or Blackmagic.

  • Adobe Captivate 7 - is the review of the results of the quiz based on the types of questions?

    Adobe Captivate 7 provides the function that you can review the questions, and you can see which of them have answered correctly and that one of them has responded incorrectly. In my e-learning project, there is an exercise that consists of multiple choice questions and drag and drop tasks. This question / task landslides are among the content slides, this means for example after 5 content slides are a 2 slides, it issues then 3 content slides and slide 1 question and so on. The results of all the types of questions - multiple choice questions, drag and drop - are included in the results of the quiz. At the end of the e-learning the 'quiz' results slide comes with the button "check Quiz." I tested this function after exporting the e-learning of Adobe Captivate7. I noticed the following: If you click on the button "check Quiz" the learner back to all the question slides he or she responded. For that on question slides were automatically placed the buttons 'next' and 'back' and the 'inspection' on the ground it is written what the learner has responded to the two first questions are multiple choice questions. There, it works fine the two buttons will appear. After clicking on the button 'next' on the first question slide that contains a multiple choice question, the learner is the second slide of the question, which also contains a multiple choice question. The third issue is a task of drag / move. He do not appear the buttons so the quiz review stops and there is no field 'inspection '.

    How do I review the quiz works correctly despite types of questions?

    You will need to create the buttons that you want the slide D & D and format them to look like buttons on the other Quiz slides. Then hide them by deselecting "Visible output" in the properties panel.

    For these D & D slides, you will need a conditional action advanced or shared to be triggered on enter. The action will check the value of the system variable cpInReviewMode, which is a Boolean with the value of 1 by Captivate when you're in playback mode. If its value is in fact = 1 show you the hidden buttons. If you group these buttons, you will need only a single command:

    IF cpInReviewMode is equal to 1

    See the Gr_Buttons

    Continue

    ON THE OTHER

    Continue

  • The question after having passed the VCP 4 months after class

    Yesterday, 12/23, I spent my VCP-310 on the first attempt after taking the class Fast Track V3.5 back in August ' 08. Big shout out to Mark Fei and David Johnston, who were the instructors for this category - thanks guys!

    The review was almost at the same level as the level of difficulty, I waited - some of the questions that came I was not waited, but made more educated guess efforts... Still managed to achieve a score of 85%, which I am more than satisfied.

    A few questions...

    1. my VCP number seems to be an incremental number. Which does not indicate the number of candidates for the exam, or the number of people who have passed, or is it a somewhat random number?

    2. What's included with the welcome kit? I was a little disappointed to learn that it takes 6-8 weeks to get here. I was hoping to at least get some kind of recognition of VMware - as account information secure Channel being sent to me. Instead I asked him by e-mail.

    3. can I I consider myself as a secure Channel now, or I have to wait for the welcome kit to make it official?

    Thank you and Happy holidays everyone!

    All first off the coast of congratulations for joining the world ever-increasing VCPs!

    1. my VCP number seems to be an incremental number. Which does not indicate the number of candidates for the exam, or the number of people who have passed, or is it a somewhat random number?

    Yes it is progressive but over the years, that VMware has ju, ped in the sequence is not good indication of County VCP - last article I saw said 20000 + VCPs worldwide

    2. What's included with the welcome kit? I was a little disappointed to learn that it takes 6-8 weeks to get here. I was hoping to at least get some kind of recognition of VMware - as account information secure Channel being sent to me. Instead I asked him by e-mail.

    I know it's disappointing, but you said approaching the right way - they will provide this information for you.

    3. can I I consider myself as a secure Channel now, or I have to wait for the welcome kit to make it official?

    Yes you can-

    If you find this or any other answer useful please consider awarding points marking the answer correct or useful

  • VPN site2site &amp; VPN client dailin on the question of a single interface

    Hello dear colleagues,

    First of all, the question of information subsequently:

    Setup

    C2801 race

    (C2801-ADVENTERPRISEK9-M), Version 12.4 (25f)

    ----------                                                    ----------

    | Central | Di1 IP:80.153.xxx.xxx | DISTANCE | IP: 91.218.xxx.xxx

    | Router | <----------------------------------------->     | Router |

    -IPsec via GRE Tu1 - works | Debian |

    ^                                                   |          |

    |                                                     ----------

    |    does not work

    |---------------------------------------->-------------------

    | Cisco VPN | Intellectual property: all

    | Customer |

    -------------------

    !

    AAA authentication login default local activate

    AAA authentication login local VPN_Users

    RADIUS group AAA authorization network default authenticated if

    AAA authorization VPN_Users LAN

    !

    AAA - the id of the joint session

    iomem 20 memory size

    clock timezone THIS 1

    clock summer-time EST recurring last Sun Mar 02:00 last Sun Oct 03:00

    IP cef

    !

    username myVPN secret 5

    !

    !

    crypto ISAKMP policy 1

    BA 3des

    preshared authentication

    Group 2

    life 3600

    address key crypto isakmp xauth No. 91.218.xxx.xxx

    ISAKMP crypto nat keepalive 20

    !

    Configuration group customer isakmp crypto VPN_dialin

    key

    DNS 192.168.198.4

    domain example.com

    pool VPN

    ACL VPN

    Crypto isakmp VPNclient profile

    match of group identity VPN_dialin

    client authentication list VPN_Users

    ISAKMP authorization list VPN_Users

    client configuration address respond

    !

    Crypto ipsec security association idle time 3600

    !

    Crypto ipsec transform-set esp-3des esp-sha-hmac hostb-transform

    transport mode

    Crypto ipsec transform-set ESP-AES-128-SHA aes - esp esp-sha-hmac

    Crypto ipsec transform-set ESP-AES-128-SHA-LZS, hmac-sha-esp esp - aes comp-lzs

    !

    !

    crypto dynamic-map vpn-dynamic-map 10

    game of transformation-ESP ESP-AES-128-SHA-AES-128-SHA-LZS

    Define VPNclient isakmp-profile

    !

    !

    !

    HostB-cryptomap 1 ipsec-isakmp crypto map

    the value of 91.218.xxx.xxx peer

    the transform-set hostb-transform value

    PFS group2 Set

    corresponds to hostb-address list

    !

    dynamic map crypto hostb-crytomap 65535-isakmp ipsec vpn-dynamic-map

    !

    !

    !

    !

    !

    !

    Tunnel1 interface

    bandwidth 100000

    IP vrf forwarding vl199

    IP 10.0.201.2 255.255.255.0

    IP 1400 MTU

    IP nat inside

    IP virtual-reassembly

    IP ospf network point

    source of Dialer1 tunnel

    destination 91.218.xxx.xxx tunnel

    bandwidth tunnel pass 10000

    bandwidth tunnel receive 50000

    !

    interface Dialer1

    Description # PPPoE T-Online.

    MTU 1492

    bandwidth 50000

    IP ddns update hostname it-s - dd.dyndns.org

    IP ddns update it-s-dd_dyndns_org

    the negotiated IP address

    NAT outside IP

    IP virtual-reassembly max-pumping 512

    encapsulation ppp

    IP tcp adjust-mss 1452

    no ip mroute-cache

    Dialer pool 1

    Dialer idle-timeout 0

    persistent Dialer

    KeepAlive 20

    No cdp enable

    Authentication callin PPP chap Protocol

    PPP chap hostname

    PPP chap password 7

    PPP pap sent-username password 7

    PPP ipcp dns request

    card crypto hostb-cryptomap

    Crypto ipsec fragmentation after encryption

    !

    !

    local pool IP VPN 192.168.196.30 192.168.196.60

    IP forward-Protocol ND

    IP route 0.0.0.0 0.0.0.0 Dialer1 track 1

    IP route 0.0.0.0 0.0.0.0 Tunnel1 20 Track3

    IP route 0.0.0.0 0.0.0.0 Dialer1 254

    IP route vrf vl199 0.0.0.0 0.0.0.0 192.168.1.251

    IP route vrf vl99 0.0.0.0 0.0.0.0 192.168.3.1

    !

    The dns server IP

    !

    no ip address of the http server

    no ip http secure server

    TCP-time translation nat IP 3600

    translation of nat IP udp-timeout 600

    IP nat Pat_for_192.168.198.4 192.168.198.4 pool 192.168.198.4 netmask 255.255.255.0 type

    IP nat Pat_for_192.168.200.50 192.168.200.50 pool 192.168.200.50 netmask 255.255.255.0 type

    IP nat inside source static 5060 udp interface 192.168.200.50 Dialer1 5060

    IP nat inside source static tcp 192.168.200.51 3389 3389 Dialer1 interface

    IP nat inside source static tcp 192.168.198.4 3389 interface Dialer1 3390

    IP nat inside source static tcp 192.168.198.9 interface 5000 Dialer1 5000

    IP nat inside source overload map route dialer1 interface Dialer1

    IP nat inside interface 13001 static udp 192.168.199.3 source Dialer1 13001

    IP nat inside interface 32768 static udp 192.168.179.2 source Dialer1 32768

    IP nat inside source static udp 192.168.179.2 Dialer1 49152 49152 interface

    IP nat inside interface 64206 static udp 192.168.179.2 source Dialer1 64206

    IP nat inside source static udp 192.168.179.2 interface 7597 Dialer1 7597

    IP nat inside source static tcp 192.168.179.2 9998 interface Dialer1 9998

    IP nat inside source static tcp 192.168.179.2 7597 interface Dialer1 7597

    IP nat inside source static tcp 192.168.179.2 64206 interface Dialer1 64206

    IP nat inside source static tcp 192.168.179.2 Dialer1 49152 49152 interface

    IP nat inside source static tcp 192.168.179.2 Dialer1 32768 32768 interface

    IP nat inside source static tcp 192.168.198.4 interface 443 443 Dialer1

    IP nat inside destination list Pat_for_192.168.198.4 pool Pat_for_192.168.198.4

    IP nat inside destination list Pat_for_192.168.200.50 pool Pat_for_192.168.200.50

    !

    Pat_for_192.168.198.4 extended IP access list

    Note = Pat_for_192.168.198.4 =-

    permit tcp any any eq www

    permit tcp any any eq 987

    permit tcp any any eq 143

    permit tcp any any eq 993

    permit tcp any any eq pop3

    permit tcp any any eq 995

    permit tcp any any eq 587

    permit tcp any any eq ftp

    permit tcp any any eq ftp - data

    permit tcp any any eq smtp

    Pat_for_192.168.200.50 extended IP access list

    Note = Pat_for_192.168.200.50 =-

    allow udp everything any 10000 20000 Beach

    permit tcp everything any 5222 5223 Beach

    allow udp any any eq 4569

    permit any any eq 5060 udp

    list of IP - VPN access scope

    IP 192.168.198.0 allow 0.0.0.255 192.168.196.0 0.0.0.255

    permit ip host 80.153.xxx.xxx 192.168.196.0 0.0.0.255

    list hostb extended IP access list

    permit ip host 91.218.xxx.xxx host 80.153.xxx.xxx

    permit ip host 80.153.xxx.xxx host 91.218.xxx.xxx

    permit ip host 10.0.201.2 10.0.201.1

    !

    !

    access-list 10 permit 192.168.200.6

    access-list 100 permit ip 192.168.0.0 0.0.255.255 everything

    access-list 100 permit ip 10.1.0.0 0.0.255.255 everything

    access-list 100 permit ip 10.0.0.0 0.0.255.255 everything

    access-list 101 permit ip 192.168.199.3 host everything

    access-list 101 permit ip 192.168.199.4 host everything

    access-list 101 permit ip 192.168.199.13 host everything

    access-list 101 permit ip 192.168.199.14 host everything

    access list 101 ip allow any host 204.13.162.123

    access-list 103 allow ip 10.0.1.0 0.0.0.255 any

    !

    dialer1 allowed 10 route map

    corresponds to the IP 100

    match interface Dialer1

    !

    !

    ####################################################################################################

    SH crypto isakmp his:

    status of DST CBC State conn-id slot

    91.218.xxx.xxx 80.153.xxx.xxx QM_IDLE 7 0 ACTIVE

    80.153.248.167 QM_IDLE 12 0 ASSETS

    ######################################################################################

    SH encryption session

    Current state of the session crypto

    Interface: Virtual-Access5

    The session state: down

    Peer: port of 91.218.xxx.xxx 500

    FLOW IPSEC: allowed ip host 10.0.201.2 10.0.201.1

    Active sAs: 0, origin: card crypto

    FLOW IPSEC: allowed ip host 80.153.xxx.xxx host 91.218.xxx.xxx

    Active sAs: 0, origin: card crypto

    FLOW IPSEC: allowed ip host 91.218.xxx.xxx host 80.153.xxx.xxx

    Active sAs: 0, origin: card crypto

    Interface: Dialer1

    The session state: UP-NO-IKE

    Peer: port of 91.218.xxx.xxx 500

    IKE SA: local 80.153.xxx.xxx/500 remote 91.218.xxx.xxx/500 inactive

    FLOW IPSEC: allowed ip host 10.0.201.2 10.0.201.1

    Active sAs: 0, origin: card crypto

    FLOW IPSEC: allowed ip host 80.153.xxx.xxx host 91.218.xxx.xxx

    Active sAs: 4, origin: card crypto

    FLOW IPSEC: allowed ip host 91.218.xxx.xxx host 80.153.xxx.xxx

    Active sAs: 0, origin: card crypto

    Interface: Dialer1

    The session state: IDLE-UP

    Peer: port of 55033

    ITS IKE: local 80.153.xxx.xxx/4500 distance 55033 Active

    ################################################################################################################################

    Error message:

    020932: 2 Oct 21:55:14.459 CEST: IPSEC (validate_transform_proposal): No IPSEC cryptomap is to address local 80.153.xxx.xxx

    020933: 2 Oct 21:55:14.459 CEST: IPSEC (validate_proposal_request): part #1 of the proposal

    (Eng. msg key.) Local INCOMING = 80.153.xxx.xxx, distance =,.

    local_proxy = 0.0.0.0/0.0.0.0/0/0 (type = 4),

    remote_proxy = 192.168.196.32/255.255.255.255/0/0 (type = 1),

    Protocol = ESP, transform = esp - esp-md5-hmac (Tunnel-UDP).

    lifedur = 0 and 0kb in

    SPI = 0 x 0 (0), id_conn = 0, keysize = 0, flags = 0 x 400

    020934: 2 Oct 21:55:14.459 CEST: IPSEC (validate_transform_proposal): No IPSEC cryptomap is to address local 80.153.xxx.xxx

    020935: 2 Oct 21:55:14.459 CEST: IPSEC (validate_proposal_request): part #1 of the proposal

    (Eng. msg key.) Local INCOMING = 80.153.xxx.xxx, distance = ,.

    local_proxy = 0.0.0.0/0.0.0.0/0/0 (type = 4),

    remote_proxy = 192.168.196.32/255.255.255.255/0/0 (type = 1),

    Protocol = ESP, transform = null esp esp-md5-hmac (Tunnel-UDP).

    lifedur = 0 and 0kb in

    SPI = 0 x 0 (0), id_conn = 0, keysize = 0, flags = 0 x 400

    #################################################################################################

    I tried to understand where is my mistake, can someone help me find it?

    Thank you very much

    concerning

    crypto map hostb-crytomap 65535 ipsec-isakmp dynamic vpn-dynamic-map

    is the fault of typing in the name as in your original config?

    --
    Don't stop once you have upgraded your network! Improve the world by lending money to low-income workers:
    http://www.Kiva.org/invitedBy/karsteni

  • Get the value of the question page before submitting.

    Hello all, I use the Application Express 4.2.5.00.08. I have a question on getting a value for a page element before the page is sent. I have a dynamic action:

    Action: Moving the mouse (on a region/State)

    Real Action: $('a[href*="39"]').each (function (index) {}
    lnk = $(this) .attr ('href');
    $(this) .parent)
    . Parent ('tr')
    .Attr ("href data ', lnk")
    {.mouseover (function ()}
    $(this) .css ("cursor", "pointer");
    Lrowrequired var = $(this) .closest ("tr"),.
    BLOCK = lRow.find("td[headers=BLOCK]").text ();
    $x('P39_BLOCK').value = BLOCK;
    })
    {.mouseleave (function ()}
    $(this) .css ('cursor', 'default');
    })
    });

    I am successfully able to get the value of the line while I'm hovering above the report (and P39_BLOCK is refreshing). But, in this case, the value is not set whenever it changes. My question is, if I need to use this value (say, put an another page element when P39_BLOCK is changed) without submitting the page, how is that possible?

    Kind regards
    MFadel.

    Hi Mohamed,

    That's what bothers! In my first dynamic action, I have real action 'Execute JavaScript Code', which doesn't have a property "Page items to show.". And I need this code to retrieve values from the row of the report.

    On the right, you will have the option 'page elements to present' the dynamic JavaScript actions. Only the PL/SQL. And you do not need to handle things strictly the use of javascript. JavaScript is usually used to manipulate items on the page itself, not the things on the server/session). If you need to present before your PL/SQL block, you can either use AJAX call, or you can create a dynamic action of PL/SQL that runs before your JavaScript. Put this field in the 'submit' page elements and the block of code, just put null;

    Here's a sample in javascript, ajax call. It pushes three elements of the page in the session or in the scope where APEX can access their values. You can return values through AJAX if necessary also:

    $.ajax ({type: 'POST',})

    URL: "wwv_flow.show",

    data: {}

    p_flow_id: $('#pFlowId').val (),.

    p_flow_step_id: page,.

    p_instance: $('#pInstance').val (),.

    "x 01': P39_PAGE_ITEM_1, '.

    "x 02': P39_PAGE_ITEM_2, '.

    "x 03': P39_PAGE_ITEM_3, '.

    p_request: 'APPLICATION_PROCESS = YOUR_PROCESS_NAME'

    },

    success: function (data) {}

    Console.log (Data);

    }

    });

    Then you would have a PL/SQL process called YOUR_PROCESS_NAME that can refer to variables such as

    my_var_1 VARCHAR2 (100 CHAR): = APEX_APPLICATION. G_X01; -Javascript password

    my_var_2 VARCHAR2 (100 CHAR): = APEX_APPLICATION. G_X02; -Javascript password

    my_var_3 VARCHAR2 (4000 TANK): = APEX_APPLICATION. G_X03; -Javascript password

    Can I use in my "PL/SQL procedure? Because in the end, I'm trying to use this value in a PL/SQL procedure:

    To answer your last question, Yes, you can use the P39_BLOCK in your PL/SQL, how you demonstrated above, but you must submit in the 'page' referred to submit box, otherwise it uses the last value that has been submitted.

    What I'm not clear, is do you need really value before executing the PL/SQL or you just want your PL/SQL? If you just try to pass it in PL/SQL and then just use the dynamic action of PL/SQL and pass it by using the "elements of the page to present. '' Remember, if you need a new value to publish on the page, you will need to put these fields in the box "items to display the page.

    If you only need the value of front page because you will use in javascript, somewhere, then reference it with jQuery or js and then use AJAX to continue your treatment.

    A third way, you could do, is to create a dynamic action of PL/SQL that runs before the javascript code that is null; in the body of PL/SQL, but put the P39_BLOCK in the "elements of page to submit" box. Who will just send the page element, and then take action dynamic javascript. But, I don't know why you would do that since you can't have the value submitted for javascript to use.

    Hope that all makes sense.

    Jen

  • By clicking on a link vs type the link into the address give different outputs SVG bar.

    I have a web application that uses SVG to render. There is a problem with degraded SVG rendered when I type the URL of the application that does not occur when I browse the site via a bookmark.

    If you go to https://www.draw.io?ff=1 , you will see the correct result, an SVG rect with a gradient background. If you manually type this URL, the filling will fail.

    I tested on FF 3.6, 18, 29 and 31 on Windows 7, OS X 10.9 and Linux Mint 17, they all show this behavior.

    I found this thread maybe be linked and I have tested in safe mode with disabled cache and it does not help: https://support.mozilla.org/en-US/questions/1005522?esab=a & as = aaq

    We have solved this problem, the problem is the way we have redirected to https using window.location.protocol. We are now using window.location.href and it works.

  • Version 29: Address bar is filled with static icons to Firefox. Impossible to type the URL in the address bar.

    I have never seen anything like this before and can't find a solution in support or in a general Google search.

    We have a user who has an address bar has filed with the static icons in Firefox (there's a screenshot if there is no way to predict that). If the user clicks on them, they aren't going anywhere (they shouldn't be here anyway, no?). This user is unable to type in the address bar, either. Not sure if there was an auto-update to version 29 of the next day or not, but Firefox has been uninstalled a sweet version of installed 29 - reasoning that he could be an installation problem. The question remains. This user is not having the same problem with Chrome. Have not tried to breed with another browser on that machine. Have not heard complaints from other users in the Office using version 29.

    Is there a setting being ignored with version 29? Is this a bug? Should we try to install version 28 and see if it's a question of versioning, or maybe something else? Try to eliminate possible problems and move to the next set of solutions.

    Thank you

    Hello Wudumaer, other users have reported that this error can be caused by third-party extensions like Icon RSS 1.0.6...

    Troubleshoot extensions, themes, and issues of hardware acceleration to resolve common problems of Firefox

  • Rename the question on creation of the new folder

    Dear Apple,

    To create a new folder in Photos (v 1.3 osx El capitan v 10.11.3) another folder is automatically marked for renaming.

    The newly created folder is automatically called "new folder" and does not have focus.

    Very strange as it may seem logical directly you want to rename a newly created folder.

    Thank you very much.

    Note as you've seen in these TERMS, you have accepted your registration here Apple isn't here - it is strictly a user forum to user with experienced users to help others

    Your question is not clear at all - in Photos when you create a new folder (menu, file == > new folder) it is created in the albums section (it is easier for me if the sider bar is shown - menu display == > display the sidebar) with the "new folder" name selected and all you have to do is type the name you want - if you want to rename a folder later right click on it and select Rename folder

    Please explain clearly what you are doing, what is happening and what you want to happen

    LN

  • What happened to the question/problem, that I just posted? You meet serious accidents on your servers that removes messages?

    I can't find the post I recently set up here. Have you had an accident which deleted all recent messages?
    I wanted to write comments to a suggestion that I got here, which was the use of Acronis as a backup manager...
    Manufactured by MowGreen - thank you for your comments.
    But you might have some use of the comment, what I am to do - I actually tried on the backup program you suggested; Acronis.
    I don't know if you have ever tried to restore a backup? You said that you never 'had to' restore...
    I tried to make a backup of my fresh without Norton and all windows and then tried to restore the backup.

    For me, Acronis 2010 ATI seems pretty useless!

    He could not read that a backup of my discs Inter Raid 5 - OK, can be forgiven.
    But he could not read from a SATA vanilla which contained a backup.
    And when I tried the last option to put a backup on a DVD, the program crashed when trying to read the DVD that contains the backup.
    So you better hope that you never have any of your backups - you will never be able to read from this backup.

    On the problem using Windows Update.
    You said that Norton 360 v2 Online is totally incompatible with Windows Vista (or Windows Update?). I am running Windows XP - is the same true for XP?
    Is this true for the Norton 360 Version 3 too? All products current Norton is not compatible with Windows?

    Here is the text that has been deleted on the Forum server:

    More effective than a virus - KB930494 MS update ends with true Msg that Windows cannot now work correctly

    I started to reinstall Windows XP, after he has screwed up and I discovered that all the system snapshot
    I created backups worthless - MS removes automatically after 90 days...

    But when reinstalling Windows XP Pro MCE 2005 I managed to beat or dodge the many problems - like all the
    famous error when update .NET Framework 1.1 Service Pack 1 and many others
    Suddenly I met an error generated by Microsoft of NONRECOVERABLE type!

    While trying to install Windows, I agreed that Windows was full of bugs and security flaws and
    need a large number of fixpacks installed via Windows Update.
    Such a group of patches is called KB930494 and the full name is:

    .NET framework 1.0 Service Pack 3 SYSTEM. WEB. DLL and MSCOREE. DLL Security Update for Windows XP Media Center Edition and Windows XP Tablet PC Edition

    Windows Update gave a brief error msg that this update has failed and I have tried to run this update
    manually when it produces the following error message: (note he's telling the truth when it)
    claims that "Windows may not work correctly")

    ---
    KB930494 Setup error

    Error while updating your system.
    Windows XP has been partially updated and may not work properly.

    Ok
    ---

    So, this update of Microsoft killed my system - it sure that _ 'does not properly"more.
    Lots of things off, lots of BSOD...

    Og - of course I should have used the system restore and created a backup that I should come back...!
    I did well - but this bomb of viral type of Microsoft made sure it was not possible to create
    a valid system by restoring such a backup. Probably because half the file system matches the other.

    The worst part is - even if I try to reinstall Windows again, avoiding this Virus created by MS, how can I be sure that
    This will be the only disguised bomb nothing extraordinary provided by Windows Update as necessary security patches?

    So guys, what is the best utility backup/restore partition there?

    Rgds. E. Ben

    ---

    Have you checked on the KB930494.log that is in the WINDOW to see where the installation is a failure?

    On a clean install of MCE should no problem by installing the SYSTEM .NET Framework 1.0 Service Pack 3 WEB. DLL and MSCOREE. DLL Security Update for Windows XP Media Center Edition and Windows XP Edition Tablet PC less than security software interferes with the installation and/or corrupt .NET update package.

    In addition, it can be an order of updates for .NET 1.0 SP3 installation which will avoid the problem your system knows. You install updates in the order they are presented by automatic updates?

    See also:

    More detailed for .NET Framework 1.0 SP3 and 1.1 SP1 failures troubleshooting ideas
    Questions I've seen so far with the installation of .NET Framework 1.0 SP3 and 1.1 SP1

    As for the backup and restore utilities: http://www.google.com/#hl=en&safe=off&q=Disk+backup&aq=f&aqi=g10&oq=&fp=1&cad=b
    I use Acronis image on my MCE box, but have never had to restore it... yet.

    MowGreen MVP Data Center Management - update of safety Consumer Services

    ---
    Thank you for your response.

    I didn't know about the log file, but watching her (she is very large) it seems is it can only be useful to those writing or working with
    updates...?
    You want to send me the file here? (Probably too big). Or you want I send you the file to watch?

    Only say unique error Code I find gives the following:
    Windows XP has been partially updated and may not work properly.
    29.641: Update.exe extended error code = 0xf070

    Interesting piece of info about security SW, because I have Symantec Norton 360 v2 online riddled with bugs, but I'm not
    optimist that disable Norton 360 Windows Update would do the trick, especially since I had so much
    problems with most of the time updates .NET Framework - it seems that this Windows component is full of problems...

    On the question of the "order of Installation" I initially let Windows Update handle this the way he wanted to.
    After that giving the briefest mention that only KB930494 had failed, I then tried to revive this one update.

    Do you think the system can be restored using the REPAIR, or whatever, or I have to reinstall all windows
    from scratch?

    Kind regards

    ---
    Ben,

    There is no need to send or post the log, because the whole .NET updates installation and OS stability problems are caused by Norton 360.
    Suggest you clean boot Vista as being expected to eliminate all processes and services of Norton to interfere with the installation of the update.
    In fact, you'd be much better off dumping Norton 360 and installing a Windows-compatible antivirus software.
    Then launch their removal tool for Norton ensure all remnants no longer stay or run this tool (AppRemover) as she removes a long list of security products.
    Then download and install one of the free AVs that work well with Windows Vista, Avast or Antivir .

    You can probably repair the OS running sfc/scannow from an elevated command prompt .
    If that can't do the job, then perform an upgrade on the spot .

    MowGreen MVP Data Center Management - update of safety Consumer Services
    ---

    I can't find the post I recently put up here...

    Your history of validation can be found here: http://social.answers.microsoft.com/Forums/en-US/user/threads?user=errbebe

    Always reply to your original thread, please.
    ~ Robear Dyer (PA bear); MS MVP (that is to say, mail, security, Windows & Update Services) since 2002. DISCLAIMER: I do not represent nor don't work for Microsoft

  • How can I type the characters printed in green on the keyboard of Acer aspire switch 10?

    My (Northern) keyboard on my Acer Aspire switch 10 has some characters printed in green. This includes the backslash character I need desperately. However, I can't find any information in the manual or elsewhere about access (type) these characters. Help, please!

    I tried now. With the help of the button Fn-type only the characters printed in blue. The backslash is printed in green, as is the Danish æ and 0-slash (o). Explaining the problem to my wife, she wanted to give it a go. And to my surprise it resolved in less than a minute. I had missed that the backslash WAS ALSO printed in white on the same key as + and? so, to be able to type it, all I have to do is pressed the Alt - Gr key pressing this key. Stupid of me to do not see it the first time around.

    Getting back to the question initial on the characters printed in green, I came to the conclusion that it is "conversion" of the keyboard in a Danish provision of individual countries by specifying this keyboard layout in Windows settings. Similarly, there are a few characters printed in red. I assume these are Norwegians.

    This type of complexity, that's what you get when manufacturers want to reduce country-variants for as little as possible, I guess.

    So all is well here

    For reference, I enclose a picture of my keyboard

Maybe you are looking for