question about to_date combination with sql dynamic trim

I created:
CREATE TABLE test1
(birthday DATE NOT NULL)
PCTFREE 10
PCTUSED 40
INITRANS 1
MAXTRANS 255
TABLESPACE dnvk
STORAGE)
20480 INITIAL
NEXT 20480
PCTINCREASE 10
MINEXTENTS 1
MAXEXTENTS 99
)
/

Then I insert a line:
Insert into test1
values (sysdate);

Then I do the following in sql-navigator:
DECLARE
v_test VARCHAR2 (2000): = ' update test1 set anniversary = trim (to_date ("07/07/1937","DD-MM-YYYY" "))';
BEGIN
EXECUTE IMMEDIATE v_test;
commit;
END;

The result is: 07/07/1937

When I do the same thing in sql * more:
DECLARE
v_test VARCHAR2 (2000): = ' update test1 set anniversary = trim (to_date ("07/07/1937","DD-MM-YYYY" "))';
BEGIN
EXECUTE IMMEDIATE v_test;
commit;
END;

The result is the 07/07/2037

Someone at - it an idea what is the problem?

Trim() accepts and returns the characters (see http://download.oracle.com/docs/cd/B19306_01/server.102/b14200/functions199.htm#SQLRF06149), so my guess is that filling an internal conversion somewhere along the line.

Fact interesting, when I do:

select to_date(trim(to_date('07-07-1937', 'dd-mm-rrrr')), 'dd-mm-rr') from dual

I get this:

07/07/2037

which is not what I expect to find.

select dump(trim(to_date('07-07-1937', 'dd-mm-rrrr'))) from dual

gives

Typ=1 Len=9: 48,55,45,74,85,76,45,51,55

So all I can say is: do not use trim to the dates.

Tags: Database

Similar Questions

  • I read this topic (I have a lot of questions about Xperia Z2 with lollipop)

    Hello world. I read this topic (I have a lot of questions about Xperia Z2 with lollipop) and I have posted a question, but it seems that no one saw him. That means the following: (how can I install the source application unknown to other users in my phone because it is to the unknown source menu is disabled in the settings-> Security)? This means that I can not install all the apps if I switch to the lollipop? Can someone tell me please the exact meaning of this?

    Thank you.

    It's true, but game store will not need this option checked - loading of a file manager will - but which is not say that the application will work once installed

  • A question about external authentication with PHP OCI8 using a portfolio store

    Hello
    SQL> SELECT * FROM v$version;
    
    BANNER
    --------------------------------------------------------------------------------
    Oracle Database 11g Enterprise Edition Release 11.2.0.1.0 - 64bit Production
    PL/SQL Release 11.2.0.1.0 - Production
    CORE     11.2.0.1.0     Production
    TNS for Linux: Version 11.2.0.1.0 - Production
    NLSRTL Version 11.2.0.1.0 - Production
    
    SQL> 
    OS: Linux Fedora Core 17 (x86_64)
    PHP Version: 5.4.14
    Apache version (httpd): Apache/2.2.23 (Fedora) 
    I have a question about OCI8 connection to the Oracle server via portfolio, which I understand is a good practice because we do not have to hard code the users password. I'm trying to read pages 117 and 118 of the book The Underground PHP and Oracle manual online to learn how to set up a portfolio. I proceeded by steps as explained in these two pages (except that at the end I connect, as a normal user, not a privileged user) yet, apparently PHP does not detect the user.

    Here's what I write in my script
    $connection = 
                    oci_connect 
                        (
                            "training", 
                            "", 
                            "php_ora_usr", 
                            "AL32UTF8"
                        );
    the training is the name of the user that I use in my PHP scripts to connect to the oracle database and the password is mypassword (is not true, just for the purpose of this thread :)) the code above gives me the following error:)
    Warning: oci_connect(): ORA-01005: null password given; logon denied in /var/www/html/myscript.php on line 91
    
    Fatal error: Connection step: ORA-01005: null password given; logon denied in /var/www/html/myscript.php on line 13
    But if I also provide the password which is,
    $connection = 
                    oci_connect 
                        (
                            "training", 
                            "mypassword", 
                            "php_ora_usr", 
                            "AL32UTF8"
                        );
    Obviously it works, but at the same time, this means that my wallet is not operational.

    So I'll write here, step by step, how I did according to the instructions contained in the pages 117 and 118 of the above mentioned book and I would be grateful if you could kindly tell where I made the mistake (s)

    The following text was performed under my oracle linux (so the dbagroup)

    Step 01:_
    I created and provided the password for the directory of portfolio
    mkstore -wrl /home/oracle/wallet_dir -create
    Step 02:_
    I created an entry for my oracle user that will be used in my PHP scripts to connect to oracle
    user: training
    password: mypassword
    mkstore -wrl "/home/oracle/wallet_dir" -createCredential php_ora_usr training mypassword
    I also checked that the entry was actually created for my user in the portfolio
    $ mkstore -wrl "/home/oracle/wallet_dir" -listCredential
    Oracle Secret Store Tool : Version 11.2.0.1.0 - Production
    Copyright (c) 2004, 2009, Oracle and/or its affiliates. All rights reserved.
    
    Enter wallet password:                
       
    List credential (index: connect_string username)
    1: php_ora_usr training
    $ 
    Step 03:_
    I added the following to my $TNS_ADMIN/tnsnames.ora
    .  .  .
    php_ora_usr = 
      (DESCRIPTION =
        (ADDRESS = (PROTOCOL = TCP)(HOST = localhost)(PORT = 1521))
        (CONNECT_DATA =
          (SERVER = DEDICATED)
          (SERVICE_NAME = db02)
        )
      )
    .  .  .
    Step 04_
    I added the following to my $TNS_ADMIN/sqlnet.ora
    # sqlnet.ora Network Configuration File: /u01/app/oracle/product/11.2.0/db_1/network/admin/sqlnet.ora
    # Generated by Oracle configuration tools.
    
    NAMES.DIRECTORY_PATH= (TNSNAMES, EZCONNECT)
    
    ADR_BASE = /u01/app/oracle
    
    WALLET_LOCATION =
        (SOURCE =
            (METHOD = FILE)
            (METHOD_DATA =
                (DIRECTORY = /home/oracle/wallet_dir)
            )
        )
    SQLNET.WALLET_OVERRIDE = TRUE
    SSL_CLIENT_AUTHENTICATION = FALSE
    SSL_VERSION = 0
    _ Step 05
    The TNS_ADMIN environment variable is already set correctly in * / etc/sysconfig/httpd * so I didn't need to do something for this step


    Step 06_
    I gave to access Apache (as root) in the directory of portfolio (in fact, it seems that the user oracle (dba) of linux also has the required privileges to grant this access to the apache)
    # setfacl -m u:apache:rx /home/oracle/wallet_dir
    # setfacl -m u:apache:r /home/oracle/wallet_dir/{cwallet.sso,ewallet.p12}
    Step 07_
    Restart Apache
    # service httpd restart
    Step 08_
    Finally make a test connection using the connection string php_ora_usr which the entry was created earlier. And the test was not successful, as indicated above
    $connection = 
                    oci_connect 
                        (
                            "training", 
                            "", 
                            "php_ora_usr", 
                            "AL32UTF8"
                        );
    The error message:
    Warning: oci_connect(): ORA-01005: null password given; logon denied in /var/www/html/myscript.php on line 91
    
    Fatal error: Connection step: ORA-01005: null password given; logon denied in /var/www/html/myscript.php on line 13
    I would appreciate it if you could kindly shed some light.

    Thanks in advance,
    Dariyoosh

    That gives a good clue to begin with. With your platform/Apache/DB, you might need different ACLs. Test directory and permissions. Check what euid your Apache runs as. Good luck.

  • Question about to_date() function?

    Hello
    I have a question about the to_date() function.
    I am aware that for the to_date() function, we should give the format of the input string.
    My current settings for the NLS_DATE_FORMAT parameter in the NLS_SESSION_PARAMETERS table is "DD-MON-YY."
    Then, when I give
    SELECT TO_DATE('15-DEC-2008','DD/MM/YY') it should error out because the format is not same as the format of the input string('DD-MON-YY').
    But this isn't any error out.why?
    Also please tell me if the format of SYSDATE is taken NLS_SESSION_PARAMETERS table or another table.

    Please take a look at Unexpected result with to_date

  • Question about streaming video with FMS3 live

    Thanks much for you efforts...
    I tested an exciting tutorial about streaming video with Flash Media Server 3.5 live...
    every thing went good and I could see my webcam broadcast from my computer via my web site, but unfortunately I see no any other machine

    I use Microsoft windows XP SP2
    and flash media live encoder 3
    but my UNIX web server
    is this a problem?
    Please send me your comments if its possible
    Thank you very much

    Replace localhost with the public ip address of the computer running FMS then paste the SWF on the Web server and mean it... will work, provided you rtmp string points to the computer running FMS

  • Simple question about immediate execution with cursor

    Hi all

    I have a slider that retrieves the username from dba_users. My question is how can I execute this statement (SELECT DBMS_METADATA. GET_GRANTED_DDL ('ROLE_GRANT', USERNAME) FROM DBA_USERS; ) with my cursor.  Thank you.

    DECLARE

    uname varchar2 (30);

    CURSOR c1 IS

    SELECT username from dba_users;

    BEGIN

    OPEN c1;

    LOOP

    FETCH c1 INTO uname;

    RUN IMMEDIATELY "SELECT DBMS_METADATA. GET_GRANTED_DDL ('ROLE_GRANT', uname) FROM DBA_USERS; PROBLEM HERE

    Dbms_output.put_line (uname);

    OUTPUT WHEN c1% NOTFOUND;

    END LOOP;

    CLOSE c1;

    END;

    /

    DECLARE

    uname varchar2 (30);

    CURSOR c1 IS

    SELECT username from dba_users;

    BEGIN

    OPEN c1;

    LOOP

    FETCH c1 INTO uname;

    OUTPUT WHEN c1% NOTFOUND;

    RUN IMMEDIATELY "SELECT DBMS_METADATA. GET_GRANTED_DDL ("ROLE_GRANT", "' | uname |) ') FROM DUAL';

    Dbms_output.put_line (uname);

    END LOOP;

    CLOSE c1;

    END;

    /

    But why do you need dynamic SQL statements? And why do you need PL/SQL at all? All your code is nothing but:

    SELECT user name,

    DBMS_METADATA. GET_GRANTED_DDL ('ROLE_GRANT', username)

    OF DBA_ROLE_PRIVS.

    DBA_USERS

    WHERE username = grantee

    /

    SY

  • How to get 2 out of procedure with sql dynamic param?

    Hello

    following my other question on the treatment in the ranks, so that I did a procedure defined ranges for the table I want to deal with;

    I did another procedure to obtain a particular range for treatment and that's where I have a problem;

    My data are:

    {

    CREATE THE TABLE PRECUBE. TEST_STG_TMO_RANGES

    (

    NUMBER OF GLASS FIBER,

    MIN_RID VARCHAR2 (18 BYTE),

    MAX_RID VARCHAR2 (18 BYTE)

    )

    tablespace UTI_DAT;

    Insert into TEST_STG_TMO_RANGES (GRP, MIN_RID, MAX_RID) values (0, 'AABKSxAAEAACW3pAAA', 'AABKSxAAEAADqCICcQ');

    Insert into TEST_STG_TMO_RANGES (GRP, MIN_RID, MAX_RID) values (1, "AABKSxAAEAADqCJAAA", "AABKSxAAEAAD + wICcQ");

    Insert into TEST_STG_TMO_RANGES (GRP, MIN_RID, MAX_RID) values (2, ' AABKSxAAEAAD/QJAAA', 'AABKSxAAEAAECyICcQ');

    Insert into TEST_STG_TMO_RANGES (GRP, MIN_RID, MAX_RID) values (3, 'AABKSxAAEAAEFQJAAA', 'AABKSxAAEAAEL8ICcQ');

    Insert into TEST_STG_TMO_RANGES (GRP, MIN_RID, MAX_RID) values (4, 'AABKSxAAEAAEMSJAAA', 'AABKSxAAEAAEPwICcQ');

    }

    my package:

    {

    create or replace
    PACKAGE C_UTI_BASIC AS
    procedure P_GET_RANGE (table_owner_in in varchar2
    TABLE_NAME_IN in varchar2
    range_no number
    Min_RANGE_OUT OUT varchar2
    max_range_OUT OUT varchar2
    );

    END C_UTI_BASIC;

    }

    My procedure:

    {

    procedure P_GET_RANGE (TABLE_OWNER_IN in varchar2
    TABLE_NAME_IN in varchar2
    RANGE_NO number
    MIN_RANGE_OUT OUT varchar2
    MAX_RANGE_OUT OUT varchar2
    )
    is

    DDL_STATEMENT varchar2 (4000);

    Start

    DDL_STATEMENT: ='select MIN_RID, MAX_RID in MIN_RANGE_OUT, MAX_RANGE_OUT in '. TABLE_OWNER_IN |'. ' || TABLE_NAME_IN | "_RANGES where PRV =' | RANGE_NO;

    immediately run DDL_STATEMENT;
    DBMS_OUTPUT. PUT_LINE (DDL_STATEMENT);
    DBMS_OUTPUT. Put_line ('Min_RANGE_OUT :'||) Min_RANGE_OUT);
    DBMS_OUTPUT. Put_line ('max_range_OUT :'|| max_range_OUT);
    end P_GET_RANGE;

    }

    I tried to call the procedure with:

    {

    declare

    V_MIN_RANGE_OUT varchar2 (30);

    v_Max_RANGE_OUT varchar2 (30);

    Start

    C_UTI_BASIC. P_GET_RANGE (TABLE_OWNER_IN = > 'PRECUBE')

    , TABLE_NAME_IN = > 'TEST_STG_TMO '.

    , RANGE_NO = > '4'

    , MIN_RANGE_OUT = > V_MIN_RANGE_OUT

    , MAX_RANGE_OUT = > v_Max_RANGE_OUT

    );

    end;

    }

    but it ends with the error:

    Error report:

    ORA-06510: PL/SQL: not supported by the user-defined exception

    ORA-06512: at "DWH_ADMIN. C_UTI_BASIC', line 2331

    ORA-00905: lack of keyword

    ORA-06512: at line 5

    06510 00000 - "PL/SQL: not supported by the user-defined exception.

    * Cause: A user-defined exception has been raised by PL/SQL code, but

    not been processed.

    * Action: Fix the problem that causes the exception or write an exception

    Manager for this condition. Or you may have to contact your

    Director of application or DBA.

    When I jump the "run immediately" just to see what is output through DBMS output here it is:

    {

    Select MIN_RID, MAX_RID in MIN_RANGE_OUT, PRECUBE MAX_RANGE_OUT. TEST_STG_TMO_RANGES where PRV = 4

    Min_RANGE_OUT:

    max_range_OUT:

    }

    the select statmetent seems OK for me, but the parameters are not met and have the value null;

    I would appreicate advice on where I went wrong here and how achieve a correct output

    THS

    Rgds

    Rgds

    Outside the use of SQL statements cr@p Dynamics (i.e. DML and not the DDL as implied by your code) and your total lack of variable bind...

    And that is your problem.  Your dynamic instruction seeks to select VARIABLES that are out of reach of the dynamic statement itself.  The IN such statements should be part of the EXECUTE IMMEDIATE for example

    EXECUTE IMMEDIATE ddl_statement INTO min_range_out, max_range_out;

  • How I replace perfectly my record excel sheet with ability of database? + General questions about computing distributed with LabVIEW

    Surprisingly, I'm almost finished with a full blown control-simulation application, that I've been working on for more than a year now, thanks in no small part of this community. The final step is to run on the simulations of k ~ 8 and be able to meet a simulation and overall statistics on performance. Each simulation is taking about 6 minutes of real time to run (~ 2 seconds of real time per hour of simulation time, valid for 7 days of simulation), as we seek to about 800 hours of your time to simulate. I have 5 computers available and a raspberry 2 Pi these simulations on, I'm looking to set up a kind of compute cluster at the end in about 2 weeks.

    The ability of current logging is sketchy; I got about 40 columns of data, and they are written in a spreadsheet with a .xls format tabs-delimited. This works very well for individual simulations, but it would be quite heavy to deal with if I had more than 20,000 of them. I think this must be done with a relational database sort, but my experience with databases is very limited, especially then, when it comes to LabVIEW. Here are my questions:

    -Can I create a kind of master-slave configuration where a computer (and probably the Pi) keeps track of the simulations are complete, which are running, and who have never run? Computers slaves ask for simulation settings, and IP would give them to him.

    -How should I take care of the database? Each simulation is about 500 k in .xls format, it's about 5 GB of data in all. Computers slaves synchronization from time to time to take care of the redundancy?

    -How can I refine my memory + General fresh disk I/O? How can I know which items from my point of view most of them?

    -Do you have suggestions for the implementation of clusters of databases relational/computer with LabVIEW?

    I have attached a picture of my configuration of logging + the overall structure of the application. It is a state machine with a structure of the event for the interruptions.


  • The use of bind variables (in & out) with sql dynamic

    I have a table that contains code snippets to make postings on a set of pl/sql database. what the code does is basically receives an ID and returns a number of errors found.
    To run the code, I use dynamic sql with two bind variables.

    When codes consists of a simpel query, it works like a charm, for example with this code:
    BEGIN
       SELECT COUNT (1)
       INTO :1
       FROM articles atl
       WHERE ATL.CSE_ID = :2 AND cgp_id IS NULL;
    END;
    However when I get to post more complexes that must perform calculations or run several queries I run into trouble.
    I have boiled down the problem into that:
    DECLARE
       counter   NUMBER;
       my_id     NUMBER := 61;
    BEGIN
       EXECUTE IMMEDIATE ('
          declare 
             some_var number;
          begin
          
          select 1 into some_var from dual
          where :2 = 61; 
          
          :1 := :2;
          end;
    ')
          USING OUT counter, IN my_id;
    
       DBMS_OUTPUT.put_line (counter || '-' || my_id);
    END;
    This code is not really make sense, but it's just to show you what is the problem. When I run this code, I get the error
    ORA-6537 ON bind variable linked to a position IN

    The error doesn't seem wise,: 2 is the only one IN bind variable and it is only used in a where clause clause.
    As soon as I remove this where clause, the code works again (giving me 61-61, in case you want to know).

    Any idea what goes wrong? I just use bind variables in a way that you're not supposed to use it?

    I'm using Oracle Database 11 g Enterprise Edition Release 11.2.0.3.0 - 64 bit

    Correction. With immediate execution , the binding is in position, but binds do not need to be repeated. My statement above is incorrect...

    You must link only once - but bind by position. And the connection must correspond to the use of the variable binding.

    If the connection never variable assigns a value in the code, link by in.

    If the binding variable assigns a value in the code, link as OUTPUT.

    If the binding variable assigns a value and is used a variable in another statement in the code, link as IN OUT.

    For example

    SQL> create or replace procedure FooProc is
      2          cnt     number;
      3          id      number := 61;
      4  begin
      5          execute immediate
      6  'declare
      7          n       number;
      8  begin
      9          select
     10                  1 into n
     11          from dual
     12          where :var1 = 61;       --// var1 is used as IN
     13
     14          :var2 := n * :var1;     --// var2 is used as OUT and var1 as IN
     15          :var2 := -1 * :var2;    --// var2 is used as OUT and IN
     16  end;
     17  '
     18          using
     19                  in out id, in out cnt;  --// must reflect usage above
     20
     21          DBMS_OUTPUT.put_line ( 'cnt='||cnt || ' id=' || id);
     22  end;
     23  /
    
    Procedure created.
    
    SQL>
    SQL> exec FooProc
    cnt=-61 id=61
    
    PL/SQL procedure successfully completed.
    
    SQL> 
    
  • Combinations with SQL

    Hello

    I have a table of the source with the following data:
    VAL  VALGRP
    ---  ------
     P5     100
     P6     100
     P7     200
     P8     300
     P9     300
     ..     ...
    These discs on I should form the following output strings
    P5, P7, P8
    P5, P7, P9
    P6, P7, P8
    P6, P7, P9
    Basically, it the sum of all possible combinations, as belonging to a group VALGRP VAL value can only occure once in a result string

    Example:
    OK - P5, P7, P8-> all VALGRP are represented, and they are represented only once in the string
    Twice (P5, P6) would be represented by NOK - P5, P6, P7-> VALGRP 100 and 300 VALGRP. not at all


    I can do this using a PL/SQL loop, but this approach would simply take too long to run...

    Someone already made something similar?

    Thanks in advance

    Published by: user641235 on October 26, 2009 07:43

    Published by: user641235 on October 26, 2009 07:46

    Like this?

    SQL> ed
    Wrote file afiedt.buf
    
      1  with t as (select 'P5' as VAL, 100 as VALGRP from dual union all
      2             select 'P6', 100 from dual union all
      3             select 'P7', 200 from dual union all
      4             select 'P8', 300 from dual union all
      5             select 'P9', 300 from dual)
      6  --
      7  select ltrim(sys_connect_by_path(val,','),',') as comb
      8  from (
      9        select val, valgrp, dense_rank() over (order by valgrp) as dr
     10        from t
     11       )
     12  where connect_by_isleaf = 1
     13  connect by dr = prior dr+1
     14* start with dr = 1
    SQL> /
    
    COMB
    ------------------------------------------------------------------------
    P5,P7,P8
    P5,P7,P9
    P6,P7,P8
    P6,P7,P9
    
    SQL>
    
  • Question about X 220 with 3 x 3 antennae

    I ordered a Thinkpad X 220 with the option of 3 x 3 antennae (no cam). The question is, why in the Device Manager, I see 1 x 1 in wireless adapters?

    Do I need a better wireless card than the default provided with the X 220?

    Thank you

    OK, the default map cannot use the 3 antennas. Map of 1 x 1 is invalid, it cannot do the 150mbps Wireless N-Lite, not even 300 and certainly not the 450mbps which can make a 3 x 3 card.

  • Question about backup hot with Tablespace with no logging

    Hi, we have an application that using a temporary tables (tables of work). The application maintains a persistent connection to the DB.
    During the loading of data, the application will create work tables and then remove it when the process is complete. This recommended by Oracle on this application is to create a tablespace separated with no record.

    Here's the recommendation:
    "To minimize the contention of disk and logging, you can create a tablespace with NoLogging for the.
    work tables and indexes and store data files for storage on a physical disk separate.
    Because work tables are created and dropped during the processing of data, creating a tablespace
    without connect to work tables and the indexes of the working table can improve performance. »

    I asked experts to demand that all agree to implement the above suggestion. However, our DBA is reluctant to implement the suggestion above that there are concerns about the validity of the hot backup. Here is his comment:
    "The problem is that we cannot guarantee the recovery of this database unless recover us from a cold backup. This means that if there is something on this database which is important, we will have problems with data protection. "He said, not to apply any log will affect the ability to recover the database in the event of failure, even if tables work East of temporary tables only. His opinion is that, when the backup occur at the same time when the table is created, will result not valid backup. The only way to save the database must publish a cold backup, which means that we must stop the application to make the backup.

    Is it true. What is the best backup strategy for the above case?
    From the expert point of view of the application, cold backup is not necessary that the application does not maintain a persistent connection to the database.

    Thank you.

    If it's a temporary table only that is kept in storage space, in any case the data on their part would go, either at the end of the transaction or at the end of the session. Not sure that the data your dba trying to protect? I have yet to have my first cup of coffee then maybe missing me something obvious here, but I don't see a point in the protection of temporary tables and "cold backup to use for their recovery.

    HTH
    Aman...

  • Yet another question about the update with the shutters tab

    I am quite new to this, but I've been scouring the boards and try many different things, and I decided to ask for advice.

    There are other threads similar to my problem such as:

    http://supportforums.BlackBerry.com/T5/Java-development/SetFocus-issue-with-tabbed-screen-page/m-p/6...

    http://supportforums.BlackBerry.com/T5/Java-development/how-to-delete-a-Manager-or-a-field-that-is-c...

    I have a set up tabbed pane based on the example and everything works fine until I have delete a line from a VerticalFieldManager. It is by default the focus on the first item on the screen, and I get this. My problem is trying to substitute or replacement behavior.

    My screen implements the FocusChangeListener for the buttons on the tab (custom LabelFields).

    I tried many different variations - I tried to manage the update completely manual and ended with a bit of a mess. I tried to capture the event navigationUnclick() and coding of the focusChanged() method to manually switch the update, but it seems that the focusChanged() method is called before the focusChanged(), which doesn't help me.

    As I said I am pretty new to this so I could do something very stupid, but I don't really understand the focus handling implementation. A kick in the right direction would be appreciated.

    Thank you.

    You can have a NullField in your managers before all other areas - in this way, even if you delete the rest, the NullField might keep the focus.

    If this does not help, try the substitution of sublayout for your managers, call super.sublayout and then explicitly setFocus to your NullField (the deletion of any field causes a display Manager to rearrange).

  • Question about ACL's with the 2621 when using site to site VPN

    I set up two site to site vpn. We have an ASA at our headquarters and branches will IOS routers - one is a 1811 and the other 2621. Both are running the latest versions of IOS, respectively. The two VPN site-to-site do not work. I have a list of inbound on the external interfaces of both routers, access that allows only the IP address of the ASA IP traffic. All other traffic is denied. I put NAT overload upward in the typical form, and I use ip outgoing inspection on the same interface, to allow incoming traffic back to surfing the internet. This configuration works very well with the 1811, where all traffic is blocked except traffic IP (IPSEC) coming from the ASA. Guests at our headquarters can reach hosts behind the 1811 and vice versa.

    Here's my problem: the 2621 is processing traffic encapsulated on the external interface and block this traffic because it does not match. I know because when I turn on logging / debugging on the 2621, I see inbound traffic blocked by the ACL. Technically, I guess that it does not, but to this interface, the traffic is always encapsulated so I think it fits to this access list and then go to the Cryptography decapsulation card and be sent to the destination host. Just as it does on the 1811. I have not 'wan' t to create another line in the access list for all subnets to Headquarters. Why is not it works the same way as it does on the 1811? Is there something else I need to activate?

    ------------------------------------------------------------------------

    Config of 1811:

    !
    version 12.4
    horodateurs service debug datetime msec
    Log service timestamps datetime localtime show-timezone msec
    encryption password service
    !
    hostname BranchVPN1
    !
    boot-start-marker
    boot-end-marker
    !
    logging buffered 51200 notifications
    !
    AAA new-model
    !
    !
    AAA authentication login default local
    activate the default AAA authentication no
    authorization AAA console
    AAA authorization exec default local
    !
    AAA - the id of the joint session
    no ip source route
    IP cef
    !
    !
    IP inspect the audit trail
    inspect the IP dns-timeout 10
    inspect the name IP internet udp timeout 30
    inspect the name IP internet tcp timeout 30
    inspect the name IP internet ftp timeout 30
    inspect the name IP internet http timeout 30
    inspect the name firewall tcp IP
    inspect the name IP firewall udp
    inspect the name IP firewall icmp
    IP inspect the dns name of the firewall
    inspect the name IP firewall ftp
    inspect the name IP firewall http
    inspect the name IP firewall https
    inspect the IP firewall name ftps
    property intellectual auth-proxy max-nodata-& 3
    property intellectual admission max-nodata-& 3
    !
    !
    IP domain name xxxx
    !
    !
    !
    !
    username xxxxxxxxxx
    !
    !
    !
    class-map correspondence vpn_traffic
    police name of group-access game
    !
    !
    VPN policy-map
    class vpn_traffic
    in line-action police 2000000 37500 pass drop exceeds-action
    !
    !
    !
    crypto ISAKMP policy 10
    BA aes 256
    preshared authentication
    Group 2
    ISAKMP crypto key address xxxx xxxxxx
    ISAKMP crypto keepalive 10
    !
    life crypto ipsec security association seconds 28800
    !
    Crypto ipsec transform-set esp - aes 256 esp-sha-hmac xxtransform
    !
    xxmap 10 ipsec-isakmp crypto map
    defined peer xxxx
    Set transform-set xxtransform
    PFS group2 Set
    match the address tunnelnetworks
    static inverse-road
    !
    !
    !
    interface Loopback0
    172.16.99.1 the IP 255.255.255.255
    !
    interface FastEthernet0/0
    Description Connection to Internet (DHCP)
    DHCP IP address
    IP access-group outside_in in
    no ip redirection
    no ip unreachable
    no ip proxy-arp
    inspect the firewall on IP
    NAT outside IP
    IP virtual-reassembly
    automatic duplex
    automatic speed
    No cdp enable
    xxmap card crypto
    !
    interface FastEthernet0/1
    Description of the connection to the local network
    address 172.20.1.1 IP 255.255.255.0
    no ip redirection
    no ip unreachable
    no ip proxy-arp
    IP nat inside
    IP virtual-reassembly
    automatic duplex
    automatic speed
    No cdp enable
    VPN service-policy input
    !
    interface Serial0/0/0
    no ip address
    Shutdown
    No cdp enable
    !
    interface Serial0/1/0
    no ip address
    Shutdown
    !
    IP forward-Protocol ND
    IP route 0.0.0.0 0.0.0.0 dhcp
    !
    no ip address of the http server
    local IP http authentication
    no ip http secure server
    IP nat inside source list nat - acl interface FastEthernet0/0 overload
    !
    IP nat - acl extended access list
    refuse any 10.0.0.0 0.255.255.255 ip
    allow an ip
    outside_in extended IP access list
    allow udp any eq bootps host 255.255.255.255 eq bootpc
    allow an ip host (ASA IPADDR)
    deny ip any any newspaper
    IP extended access list police
    deny ip host xxxx any
    deny ip any host xxxx
    IP 172.20.1.0 allow 0.0.0.255 10.0.0.0 0.255.255.255
    tunnelnetworks extended IP access list
    permit host 172.16.99.1 ip 10.0.0.0 0.255.255.255
    IP 172.20.1.0 allow 0.0.0.255 10.0.0.0 0.255.255.255
    !
    recording of debug trap
    logging source-interface Loopback0
    exploitation forest xxxx
    access-list 160 note t is
    not run cdp
    !
    !
    control plan
    !
    Banner motd ^ CC

    Authorized technician!

    ^ C
    !
    Line con 0
    line to 0
    line vty 0 4
    exec-timeout 5 0
    Synchronous recording
    entry ssh transport
    line vty 5 15
    exec-timeout 5 0
    Synchronous recording
    entry ssh transport
    !
    Scheduler allocate 20000 1000
    end

    ------------------------------------------------------------------------

    2621 Config:

    !
    version 12.3
    horodateurs service debug datetime msec
    Log service timestamps datetime localtime show-timezone msec
    encryption password service
    !
    hostname BranchVPN2
    !
    boot-start-marker
    boot-end-marker
    !
    logging buffered 51200 notifications
    no console logging
    !
    AAA new-model
    !
    !
    AAA authentication login default local
    activate the default AAA authentication no
    authorization AAA console
    AAA authorization exec default local
    AAA - the id of the joint session
    IP subnet zero
    no ip source route
    IP cef
    !
    !
    IP domain name xxxx
    !
    IP inspect the audit trail
    inspect the IP dns-timeout 10
    inspect the name IP internet udp timeout 30
    inspect the name IP internet tcp timeout 30
    inspect the name IP internet ftp timeout 30
    inspect the name IP internet http timeout 30
    inspect the name firewall tcp IP
    inspect the name IP firewall udp
    inspect the name IP firewall icmp
    inspect the name IP firewall ftp
    inspect the name IP firewall http
    Max-events of po verification IP 100
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    username xxxxxxxxxxxx
    !
    !
    !
    class-map correspondence vpn_traffic
    police name of group-access game
    !
    !
    VPN policy-map
    class vpn_traffic
    in line-action police 2000000 37500 pass drop exceeds-action
    !
    !
    !
    crypto ISAKMP policy 10
    BA aes 256
    preshared authentication
    Group 2
    ISAKMP crypto key address xxxx xxxxx
    ISAKMP crypto keepalive 10
    !
    life crypto ipsec security association seconds 28800
    !
    Crypto ipsec transform-set esp - aes 256 esp-sha-hmac xxtransform
    !
    xxmap 10 ipsec-isakmp crypto map
    defined peer xxxx
    Set transform-set xxtransform
    PFS group2 Set
    match the address tunnelnetworks
    reverse-road remote-peer
    !
    !
    !
    !
    interface Loopback0
    172.16.99.2 the IP 255.255.255.255
    !
    interface FastEthernet0/0
    Description Connection to Internet (DHCP)
    DHCP IP address
    IP access-group outside_in in
    no ip redirection
    no ip unreachable
    no ip proxy-arp
    NAT outside IP
    inspect the firewall on IP
    automatic duplex
    automatic speed
    No cdp enable
    xxmap card crypto
    !
    interface Serial0/0
    no ip address
    Shutdown
    No cdp enable
    !
    interface FastEthernet0/1
    Description of the connection to the local network
    IP 172.20.2.1 255.255.255.0
    no ip redirection
    no ip unreachable
    no ip proxy-arp
    IP nat inside
    automatic duplex
    automatic speed
    No cdp enable
    VPN service-policy input
    !
    interface Serial0/1
    no ip address
    Shutdown
    No cdp enable
    !
    IP nat inside source list nat - acl interface FastEthernet0/0 overload
    no ip address of the http server
    local IP http authentication
    no ip http secure server
    IP classless
    IP route 0.0.0.0 0.0.0.0 dhcp
    !
    !
    !
    IP nat - acl extended access list
    refuse any 10.0.0.0 0.255.255.255 ip
    allow an ip
    outside_in extended IP access list
    allow udp any eq bootps host 255.255.255.255 eq bootpc
    allow an ip host (ASA IPADDR)
    deny ip any any newspaper
    IP extended access list police
    deny ip host xxxx any
    deny ip any host xxxx
    IP 172.20.2.0 allow 0.0.0.255 10.0.0.0 0.255.255.255
    tunnelnetworks extended IP access list
    permit host 172.16.99.2 ip 10.0.0.0 0.255.255.255
    IP 172.20.2.0 allow 0.0.0.255 10.0.0.0 0.255.255.255
    recording of debug trap
    logging source-interface Loopback0
    exploitation forest xxxx
    not run cdp
    !
    !
    !
    !
    !
    Banner motd ^ CCC

    Authorized technician!

    ^ C
    !
    Line con 0
    line to 0
    line vty 0 4
    exec-timeout 5 0
    Synchronous recording
    entry ssh transport
    line vty 5 15
    exec-timeout 5 0
    Synchronous recording
    entry ssh transport
    !
    !
    end

    Please check if this helps:

    http://www.Cisco.com/en/us/docs/iOS/12_3t/12_3t8/feature/guide/gt_crpks.html

    Federico.

  • Question about the variable with name "

    This work is


    1. 1 package test as I said the global variable

    CREATE OR REPLACE PACKAGE test

    'TeStConsT' CONSTANT BOOLEAN: = TRUE;

    END test;

    1. 2. package sepcification

    CREATE or REPLACE PACKAGE test2 IS

    FUNCTION m)

    x in VARCHAR2) RETURN NUMBER;

    END test2;

    1. 3. package body

    CREATE OR REPLACE PACKAGE BODY test2

    FUNCTION m (x IN VARCHAR2) RETURN NUMBER IS

    b_ BOOLEAN;

    BEGIN

    b_: = TEST.testconst; return 1; -It works even if I used lower case no reason?

    END m;

    END test2;

    But it does not work

    declare

    "TeStConsT" CONSTANT BOOLEAN := TRUE ;

    Start

    if (TeStConsT) then

    dbms_output.put_line ('true');

    on the other

    dbms_output.put_line ('false');

    end if ;

    end ;

    Any thoughts why it worked on the first example. Help, please.

    See you soon,.

    Dark

    SQL language reference

    Nonquoted identifiers are not case sensitive. Oracle interprets them as letters.

    Quoted identifiers are case sensitive.

    By enclosing the names in quotes, you can give the following names to different objects in the same namespace:

    'employees '.

    'Employees '.

    'EMPLOYEES '.

    Note that Oracle interprets the following names the same, so they cannot be used for different objects in the same namespace:

    employees

    EMPLOYEES

    'EMPLOYEES '.

Maybe you are looking for