Transactions involving several RM in Tuxedo

Hi Little Todd-Oracle.

Assume a bank with server both B1 and B2 branches, each having its own database (Oracle) DB1 & DB2 (mysql).

Take the B1 branch has an A1 account & branch a A2 B2.

Suppose that a1 has 100 balance & account a2 has balance 0.

At this point all plugged balance is 100.

Assume that a transfer of 100 is launched from A1 to A2.

Suppose that during this transfer operation was only half committed i.e. the balance was reduced on DB1, another customer (customer audit) is started for the balance of the whole Bank branches.

Suppose the client verification transaction ends before the valid transfer transaction the increase in balance on DB2.

The audit client would yield a ZERO balance which is incorrect.

The pdf file attached shows the sequence diagram.

My first question is

Is there a way to Tuxedo to hold to start new operations (i.e. block to tpbegin/tx_begin calls) while a transaction is still committing (tpcommit is current)?

My second question is

Is it another way as a tuxedo configuration setting to fix this?

My third question is

This problem comes under the domain of a TM that Tuxedo?

If it's not then how this issue is resolved in Tuxedo ATMI applications?

Thanks in advance.

Best regards

Abbas

Hi Abed,

My understanding of isloation serializable is the RM will acquire both read and write locks.  Select statements would "for update" as part of the selection, which looks at the database to take an exclusive lock at this time there.  So in your sequence diagram, select statements of verification transaction will block until validations of transfer in each respective database transactions that select statements of will transfer transaction out exclusive locks.

Kind regards

Todd little

Chief Architect of Oracle Tuxedo

Tags: Fusion Middleware

Similar Questions

  • Transactions involving multiple caches and a database

    Hi all

    I'm curious to know if the following is possible thanks to the support of transaction consistency.

    I have the need to write data in two caches and a database of my Tomcat container, and the entire operation must be atomic.

    Example:

    Write in the database (it is NOT via a dumps)
    Write caching 1 (uses continuous writing to database)
    Write to the cache 2 (uses continuous writing to database)

    If all fails, the entire transaction needs to restore. This feels like an XA transaction, but looks like it doesn't work as I expect because the cache must be the last resource, but I have two caches. The order of operations is not important.

    Thank you

    Rob

    When you use write-through is here (as I know) no way to get a fully transactional behavior (assuming you have more than one cache node) since each node is responsible for the persistence of its own data items (they each will use a separate connection to the database).

    If you are using as a reason ' hiding beside of "this can be done using XA transaction. As long as the two caches belong to the same cache service they count as a resource unique "last"...

    / Magnus

  • Query SQL involving several tables

    I have a scenario in SQL where, for each position there are associated tags. A user is the one who makes the post and that he belongs to a given location. The location corresponds to a given country.

    I create tables such as
    CREATE TABLE post_table 
    (
    post_id VARCHAR(20), 
    user_id VARCHAR(20),
    PRIMARY KEY(post_id)
    );
    
    CREATE TABLE tags_table
    (
       post_id VARCHAR(20),
       tags VARCHAR(20),
       PRIMARY KEY(tags, post_id),
       FOREIGN KEY(post_id) REFERENCES post_table(post_id) ON DELETE CASCADE
    );
    
    
    CREATE TABLE location
    (
    location_id VARCHAR(20), 
    country VARCHAR(20),
    PRIMARY KEY (location_id)
    );
    
    CREATE TABLE user_info
    (
    user_id VARCHAR(20), 
    location_id VARCHAR(30), 
    PRIMARY KEY (user_id),
    FOREIGN KEY(location_id) REFERENCES location(location_id) ON DELETE CASCADE
    );
    Now, I insert values into these tables as
    INSERT INTO post_table VALUES( 'p1', 'u1' );
    INSERT INTO post_table VALUES( 'p2', 'u1' );
    INSERT INTO post_table VALUES( 'p3', 'u2' );
    INSERT INTO post_table VALUES( 'p4', 'u3' );
    INSERT INTO post_table VALUES( 'p5', 'u2' );
    
    INSERT INTO tags_table VALUES( 'p1', 'US Open' );
    INSERT INTO tags_table VALUES( 'p1', 'Real good' );
    INSERT INTO tags_table VALUES( 'p1', 'Madrid' );
    INSERT INTO tags_table VALUES( 'p2', 'Madrid' );
    INSERT INTO tags_table VALUES( 'p3', 'Rossoneri' );
    INSERT INTO tags_table VALUES( 'p4', 'Milan' );
    INSERT INTO tags_table VALUES( 'p4', 'Los Angeles' );
    INSERT INTO tags_table VALUES( 'p5', 'Rossoneri' );
    
    INSERT INTO location VALUES( 'loc1', 'Spain');
    INSERT INTO location VALUES( 'loc2', 'England');
    
    INSERT INTO user_info VALUES( 'u1', 'loc1' );
    INSERT INTO user_info VALUES( 'u2', 'loc2' );
    INSERT INTO user_info VALUES( 'u3', 'loc1' );
    Now I have to query for each country, show them more SUV tag (s)

    So, for these data, the result should be like
    Country              MostTags
    Spain                Madrid
    England              Rossoneri
    Please help me to write this query guys.

    Hello

    Something like that

    select      country
         , tags from
               (
                 select      l.country
                   , t.tags
                   , dense_rank() over (     partition by l.country
                                  order by count(*) desc) drn
              from      location l
                   , user_info u
                   , post_table p
                   , tags_table t
              where      l.location_id = u.location_id
                   and p.user_id=u.user_id
                   and p.post_id=t.post_id
              group by l.country
                   , t.tags
         )
    where drn <=1   -- rank depends on like 1,2 or 3 popular tags for each country
    

    Concerning
    Anurag

  • Transaction and transaction AppModule Taskflow both are the same or not?

    Transaction and transaction AppModule Taskflow both are the same or not? or what are the differences between these two operations.

    Workflow transaction is different from the transaction data base (I mean the transaction returned by am.getDBTransaction ()). Each workflow is associated with a data control framework. A data control framework is the container that is associated with a workflow that contains several instances of data control. The ADF Model layer exposes the DataControlFrame interface to manage a transaction involving data controls in the framework. DataControlFrame interface exposes methods such as:

    • beginTransaction()
    • Commit()
    • Rollback()
    • createSavepoint () - Note that it is the backup point maintained by the controller of Oracle ADF and it is similar to the point of backup of database
    • isTransactionDirty()

    Task Transaction flow

    There are four transaction options that a stubborn workflow can use (notice that unbounded flow task does not support transactions):

    1. No Transaction controller: delimited task called flow does not participate in the management of transactions any controller ADF.
    2. Always Begin new Transaction: A new transaction begins when the stubborn workflow is entered, regardless of whether a transaction is in progress. The new transaction ends when the stubborn workflow stops.
    3. Always Use Existing Transaction: When it is called, the stubborn workflow participate in an existing transaction already underway.
    4. Use the existing if Possible Transaction: when it is called, the stubborn workflow is involved either in an existing transaction if there is, or starts a new transaction when the entrance to the stubborn workflow, if one does not exist.
  • Best way to code structure to control several instruments

    Hello

    I am a novice but not inexperienced labview programmer. I'm writing a labview code to control a physical optical experiement. This involves writing a GUI which of your interfaces then with a variety of instruments (such as motorized turntables, lock-in amplifiers, power supplies, Renault, etc...) all connected to the computer through various means. All the instruments are delivered with their own labview drivers to complete their most important functions. Essentially, the instruments will operate independently, but occasionally, will be a set of steps involving several instruments (such as move, take a step, move again,...)

    My question is what is the best way to structure the top level VI where all GUI controls? I have currently the code structured so that each instrument has an event structure that manages keys and commands for it. Simple events like the movement are dealt with in the cases where structures themselves while queues and occurrences are then used to handle more complicated events in external loops. It is an appropriate way to handle this scenario, or is it that most commonly architecture?

    Thank you for the help

    You play with fire when using several structures of the event. My preferred method for executing an instrument that has a 'stream' mode (example: a spectrometer where you always see the spectrum), is to provide that it is a clean line, with a dequeue item. The 'element' may have a message part (or State) in the form of an enum or string, as well as some data in the form of a Variant. You want to set a parameter, you could send a cluster containing the enum "Set the parameter" as well as the value of the parameter in the form of a Variant. The default case would be to get a spectrum and update a graph (or send another message to a user interface management loop that updates the chart).

    You can open the project template QMH who comes with LabVIEW to see how a line would work, and then you can add multiple queues for different instruments. I keep the new loops in their own SubVIs and reference to the queue in a global functional to clean the main schema.

    Here is an example of what your data of the module flow record might look like (the string constant empty considered double quotes is by default to expire the message dequeue)

  • Connection of several 6248

    Hello all!

    I have currently 2 x PC6248 which are stacked with stacking YY741 module and 2 x cables Dell F4XF - F4XF 1 m between them and that's all working well.  # See the battery port shows that xg1 and xg2 are used on both switches xg3 xg4 is both down.  It's what I expected.

    I need to add more than two switches, but they will be at a distance.  The first would be about 15 meters and the second would be between 75 and 100 meters.  Can I use cables of F4XF-F4XF that eager to 'stack' switches and if so, where can I find this length cables?  If I can do that, can I go out with just 1 cable to the remote switches?  (Yes, I know that it would be only a 12 GB of interconnection).

    If the answer above is no, then I can put 2 x gbic ports xg3/xg4 on both the existing switches and and 4 x gbic in xg1 - xg4 on new switches and connect interconnect two new switches on optical fiber LC - LC, going to this length?  (Yes, I know/xg1 xg2 are not usable in the existing stack).  If I can do it this way, what gbic would I get?  Can I use any LC - LC gbic or are there specific gbic, should I use?  And how to configure all switches?  I have several VLANs in the existing stack.  My config is attached below (if you see errors, feel free to say yes lol), it's pretty basic.  All chassis #1 ports are in use with some on chassis #2.  Currently, with only 2 switches in the battery, everything works perfectly.

    console #show run
    ! Current configuration:
    ! Description of the system "PowerConnect 6248, 3.3.13.1, VxWorks 6.5.
    ! 3.3.13.1 system software version
    ! Passage mode is configured as disabled
    !
    Configure
    database of VLAN
    VLAN 2-3, 252, 254
    VLAN 1 1 routing
    VLAN routing 2 254
    VLAN 3 3 routing
    VLAN routing 252 4
    VLAN routing 2 5
    subnet of VLAN association 192.168.0.0 255.255.255.0 1
    subnet of VLAN association 192.168.1.0 255.255.255.0 2
    subnet of VLAN association 192.168.2.0 255.255.255.0 3
    subnet of VLAN association 192.168.252.0 255.255.255.0 252
    subnet of VLAN association 192.168.254.0 255.255.255.252 254
    output
    unicast SNTP client enable
    192.168.0.2 SNTP server

    clock timezone-7 minutes 0 area "MST".
    battery
    1 2 Member
    2 2 Member
    output
    IP 192.168.254.1 255.255.255.252
    IP - lhcfun.local domain name
    8.8.8.8 IP name-server
    IP-server names 8.8.4.4
    name of the IP-server 198.105.254.17
    name-server IP 192.168.0.2
    IP routing
    IP route 0.0.0.0 0.0.0.0 192.168.1.2
    IP helper-address 192.168.0.2 dhcp
    IP helper-address 192.168.0.2 ntp
    interface vlan 1
    Routing
    the IP 192.168.0.1 255.255.255.0
    output
    interface vlan 2
    the name "Firewall."

    Routing
    IP 192.168.1.1 255.255.255.0
    output
    interface vlan 3
    name "iSCSI".
    Routing
    IP 192.168.2.1 255.255.255.0
    output
    interface vlan 252
    name of the "Ports Console"
    Routing
    IP 192.168.252.1 255.255.255.0
    IP helper-address 192.168.0.2 dhcp
    output
    interface vlan 254
    name of "management".
    Routing
    output
    level of 20b269eca6cf2aa9fb7ff4f4d0460dad user name 'admin' password encrypted 15
    spanning tree priority 0
    l2relay DHCP

    !
    interface ethernet 1/g1
    switchport access vlan 252
    output
    !
    interface ethernet 1/g2
    Auto mode channel-group 2
    output
    !
    interface ethernet 1/g3
    Auto mode channel-group 2
    output
    !
    interface ethernet 1/g4
    Auto mode channel-group 1
    output
    !
    interface ethernet 1/g5
    Auto mode channel-group 1
    output
    !

    interface ethernet 1/g6
    Auto mode channel-group 1
    output
    !
    interface ethernet 1/g7
    Auto mode channel-group 1
    output
    !
    interface ethernet 1/g8
    switchport access vlan 252
    output
    !
    interface ethernet 1/g11
    Auto mode channel-group 3
    output
    !
    interface ethernet 1/g12
    Auto mode channel-group 3
    output
    !
    interface ethernet 1/g13

    Auto mode channel-group 3
    output
    !
    interface ethernet 1/g14
    Auto mode channel-group 3
    output
    !
    interface ethernet 1/g15
    switchport access vlan 252
    output
    !
    interface ethernet 1/g18
    Auto mode channel-group 4
    output
    !
    interface ethernet 1/g19
    Auto mode channel-group 4
    output
    !
    interface ethernet 1/g20
    Auto mode channel-group 4

    output
    !
    interface ethernet 1/g21
    Auto mode channel-group 4
    output
    !
    interface ethernet 1/g22
    switchport access vlan 252
    output
    !
    interface ethernet 1/g23
    Auto mode channel-group 5
    output
    !
    interface ethernet 1/g24
    Auto mode channel-group 5
    output
    !
    interface ethernet 1/g25
    Auto mode channel-group 6
    switchport access vlan 3

    output
    !
    interface ethernet 1/g26
    Auto mode channel-group 6
    switchport access vlan 3
    output
    !
    interface ethernet 1/g27
    Auto mode channel-group 6
    switchport access vlan 3
    output
    !
    interface ethernet 1/g28
    Auto mode channel-group 6
    switchport access vlan 3
    output
    !
    interface ethernet 1/g29
    switchport access vlan 252
    output
    !

    interface ethernet 1/g32
    Auto mode channel-group 7
    output
    !
    interface ethernet 1/g33
    Auto mode channel-group 7
    output
    !
    interface ethernet 1/g34
    Auto mode channel-group 7
    output
    !
    interface ethernet 1/g35
    Auto mode channel-group 7
    output
    !
    interface ethernet 1/g36
    switchport access vlan 252
    output
    !
    interface ethernet 1/g39

    Auto mode channel-group 8
    output
    !
    interface ethernet 1/g40
    Auto mode channel-group 8
    output
    !
    interface ethernet 1/g41
    Auto mode channel-group 8
    output
    !
    interface ethernet 1/g42
    Auto mode channel-group 8
    output
    !
    interface ethernet 1/g43
    switchport access vlan 252
    output
    !
    interface ethernet 1/g44
    Auto mode channel-group 9

    output
    !
    interface ethernet 1/g45
    Auto mode channel-group 9
    output
    !
    interface ethernet 1/g46
    switchport access vlan 252
    output
    !
    interface ethernet 2/g47
    switchport access vlan 252
    output
    !
    interface ethernet 2/g48
    switchport access vlan 2
    output
    !
    interface port-channel 1
    Description "nas20".
    spanning tree portfast

    output
    !
    interface port-channel 2
    Description "nas20port22".
    spanning tree portfast
    output
    !
    interface port-channel 3
    Description "vmw16".
    spanning tree portfast
    output
    !
    interface port-channel 4
    Description "vmw18".
    spanning tree portfast
    output
    !
    interface port-channel 5
    Description "nas24".
    spanning tree portfast
    output

    !
    interface port-channel 6
    Description "nas24iscsi vlan 3.
    spanning tree portfast
    switchport access vlan 3
    output
    !
    interface port-channel 7
    Description "vmw28".
    spanning tree portfast
    output
    !
    interface port-channel 8
    Description "vmw30".
    spanning tree portfast
    output
    !
    interface port-channel 9
    Description "tsm32".
    spanning tree portfast
    output

    output

    This distance is too far for stacking. Module stacking both 10GE CX4 module can be configured for each role (Ethernet or stacking). By default, each module works according to its module ID. Change the role of a module, a reboot is necessary for the change to take effect. However, I believe that the distance for stacking cables max is about 3 meters. And the limit of CX4 cable is 15 meters.

    Other modules for the back of the switch are a 10GBase-T, part # X901C. The 10GBase-T module settle only in 2 Bay (right when viewing the back Bay). And a module SFP + 10GE, part # U691D.

    Combo on the front of the switch ports ports SFP 1 GB. Combo ports have a combined input and output of the PHY chip. Only the optical port or RJ-45 port ACR be used individually, but not at the same time. Any cable is connected will first use the port PHY.

    The fiber option that should meet your needs is a SFP - 1 G - SX transceiver. This transceiver uses the LC multimode fiber and it is good to 550 m. part # 407 - BOU

    http://Dell.to/1Rok1wO

    Here is a document that passes on the available module options.

    http://Dell.to/1OtQmfD

    With switch connections involving several VLANs, you will want to use connections in Trunk mode. For the switch connections you do not use portfast.

    # interface port-channel 1

    # switchport mode Trunk

    # switchport Trunk letter vlan add 2,3,4,5,6

    I hope this helps answer some of your questions.

  • Jolt 1.2 Tuxedo 6.5 on Solaris 10 sparc is not establish connection

    Hello

    I installed Tuxedo 6.5 on Solaris10 sparc because my application was not compiled with a later version of Tuxedo. Then I installed Jolt1.2 there. I configured the tuxedo and all the application servers. While startup FINGS server starts but JSL fails with the JOLT_CAT:1008 error: could not establish connection to the server / / 10.10.100.110:9500. After that, it gives Tuxedo error 'tpsvrinit() failed '. As had been suggested in some other messages I already checked if shipping is free or not with the command "netstat - a | grep 9500» There is no coming out to the above command. But the same configuration works very well with Solaris 8 sparc. IP address of the machine is 10.10.100.110 and the hostname is "systest".

    The ULOG file extract is as below:
    092910: TUXEDO Version 6.5 SunOS 5.5.1 sun4u sparc SUNW, Ultra-1 credits.
    095316.SysTest! JSL.19863: LIBTUX_CAT:262: INFO: Standard master boot
    095316.SysTest! JSL.19863: INFO: JOLT listener version-Jolt 1.2 [08/31/1999-40]
    095317.SysTest! JSL.19863: JOLT_CAT:1563: INFO: serial number: < 1124052 >, Expiration Date: < none >
    095317.SysTest! JSL.19863: JOLT_CAT:1564: INFO: owner: Wipro >
    095317.SysTest! JSL.19863: JOLT_CAT:1008: ERROR: could not establish listening on the //10.10.100.110:9500 network address
    095317.SysTest! JSL.19863: LIBTUX_CAT:250: ERROR: tpsvrinit() failed
    095317.SysTest! tmboot.19860: CMDTUX_CAT:825: ERROR: process JSL in the main failed with / t tperrno (TPESYSTEM - internal system erro
    (r)


    When I run several version of Tuxedo JSL starts without any problem. It establishes the connection easily. But my applications cannot be recompiled with a superior version of tuxedo that's why I am forced to use 6.5. I am confused, whether all the problem of different versions of jerk and Tuxedo or it's my configuration problem. Kindly help me.

    Kind regards
    Shashi Ranjan

    Published by: user5547545 on September 28, 2010 10:39

    Published by: user5547545 on September 28, 2010 22:12

    Shashi,

    Tuxedo 6.5 needs a patch to run on versions of Solaris or the WSNAT_CAT:1008 or JOLT_CAT:1008 "error: could not establish listening on the network + netaddr address +" message may appear.
    The thread could not establish listening on the network address describes a similar problem with the WSL and the ULOG in that thread also "TUXEDO Version 6.5 SunOS 5.5.1".

    You can get the fix last roll of Oracle support. (It would be even better to move to a later version of Tuxedo, Tuxedo 6.5 being beyond its end date of life on Solaris. I hope some compilation problems, you later with Tuxedo releases can be solved rather easily.)

    Kind regards

    Ed

  • Multiple sending of transaction to the vendor

    Hi gurus B2B.

    We send only 10 transactions from business applications to back-end to the supplier through B2B, I mean

    The backend B2B application and B2B provider, but these 10 transactions sending several times by the provider.

    Our supplier complianing they receive several transactions and it screwing up their system.

    Could someone help me how to solve this problem.

    Concerning
    CNU

    Hi ALAIN,

    You use the concrete support? If Yes, then you will like increase the interval of batch, as suggested by Sahil. Please see-

    http://www.Oracle.com/technology/products/integration/B2B/PDF/B2B_TN_012_EDI_OutBound_Batching.PDF

    Kind regards
    Anuj

  • Difference between direct TCP &amp; WAP

    Hello

    I'm confused on the difference between 2 Protocol: direct TCP & WAP.

    What really happens for each protocol? What are the differences?

    (Of course the connection string for OpenConection is difference but what the architecture of the network)?

    How does WAP support roaming is not the case for direct TCP?

    Thank you

    Hai

    Ah. If I have understood correctly, you're asking about TCP and WAP as technologies, not on the programming for them.

    I recommend you to read wapforum.org technical WAP white paper to learn more about WAP technology.

    WAP is more than a communications architecture, involving several layers of the OSI model. It defines the protocols at the transport level application; It does not have the network, linking of data or physical layers. Analogue to the TCP WAP worldwide is WTP - Wireless Transaction Protocol. Similarly, WML - Wireless Markup Language - is the equivalent in WAP in HTML format. WAP 2.0 introduced the TCP, IP, and HTTP protocols to WAP.

    Carriers have invested heavily in technology WAP and generally provide strong support throughout their networks. He can't even for TCP/IP directly (although it seems change quickly).

    There is nothing inherent TCP that prevents homelessness; in fact, it has been around for years. My impression is that carriers have just does a better job of integration WAP cellular technology.

    Also, I believe that it can be added cost of data to users for direct TCP using compared to WAP 2.0.

    The sticky thread by Peter Strange looks at some of this. Others on this forum are better informed of what I am and I hope that they will quickly correct any inaccuracies and also provide you with a better answer.

  • User problem

    Dear gurus,

    I have a strange problem with the oracle DB here.

    I joined a company DBA, they have a database with 3 users.

    each runs a select statement to extract the most primarykey_id of the table.

    A user takes milliseconds to get the result.

    Other two take more than 5 currencies... sometimes timeout.

    I find it hard to tackle the issue. Can anyone guide me as to what I can check why these users of DB are on long?

    Thank you

    Saad

    Hello Saad,

    a few ideas:
    put the sessions in trace mode, run the query in each session, run tkprof on the trail.
    Also consider if there is a trigger shot "logon" which could change the settings of the optimizer at the session level.

    Are there transactions involving table when you run the instructions (example: User A has updated several lines, but has not issued a "commit", then the 3 "select max..." is cooked.) In this case, B and C have more work to find the info (they will have to go to the RETURN of copies)?

    When B and C sessions are running, control (of another session) on what they expect.

    Best regards

    Bruno Vroman.

  • How to reset the connection of the OIC during the reception of FAN events.

    Hi all

    And thanks in advance.

    We would like to use the FAN (Fast Application Notification).
    Our server configuration:
    1 service (context threaded & unique unique).
    Model notify is GIS.
    Service transaction involves / q (tmqforward) and the database to oracle using the BEAK.

    We want to reset the OCI connection when it receives the event of failover of FAN.
    Can we push (tpnotify etc.) the FAN event in the (auto) service?
    We can register and receive FAN events.

    But:
    Can we call tpbroadcast or tpnotify from the booster FAN?
    Is the same thread?
    is thread-safe tpbroadcast and tpnotify?
    do I need the thread context main service?
    How can I get the thread context main service? (save it in a global?)

    Concerning
    TechSgin

    Hello

    If you use transactions (tpbegin() or TRANSCENDING) Tuxedo, then Tuxedo will restore database automatically connecting to a failure.

    Kind regards
    Todd little
    Chief Architect of Oracle Tuxedo

  • during an update lots of my profile folder has been put in a folder on the desktop marked the old data. How to restore this data file

    During a bet to update, automatic update of windows has started and some how much my profile data has been removed and stored in a file on the desktop. There is a simple and easy way to restore this folder from the current firefox?

    You can use the contents of the Old Firefox Data folder to "roll back" the refresh, but this involves several steps. It's probably even faster than the recovery of individual files and load those into your new profile.

    Check in the folder 'Old data Firefox' update adds a folder with a random semi name on your desktop. If there is only one, that probably has your old settings and Add-ons. If there is more than one, you'll want to work with one who has been updated recently.

    Once you have identified the profile folder, that you want to restore, here is my "old profile resurrection suggested procedure:

    Overview

    Here are the steps described in more detail below:

    1. Create a new Firefox profile
    2. Delete all of this profile folder
    3. Copy in all of the old profile folder

    Create a new profile for Firefox (Windows)

    Exit Firefox completely and start up in the Profile Manager by pasting the following in the Windows search, or the Run dialog box by pressing ENTER:

    firefox.exe -P
    

    Note: any time want to switch profiles, exit Firefox and return to this dialog box.

    Click on the button create a profile, give it a name like OldSettings and skip the option to change the location of the folder. Select the new profile from the dialog box, and then start Firefox.

    Open the new profile folder in Windows Explorer

    Firefox in the new profile should look like a new installation of the plant. Open the troubleshooting information page by using either:

    • button "3-bar" menu > "?" button > troubleshooting information
    • Menu help > troubleshooting information
    • type or paste everything: in the address bar and press Enter

    In the first table, click on the view file"" button. Firefox will launch your new profile folder in Windows Explorer.

    This folder open, switch back to Firefox and get out by using either:

    • "3-bar" menu button > button "power".
    • (menu bar) File > Exit

    Firefox is closed, the profile folder must be front and Center, or you can activate it by using the taskbar.

    Copy old data instead of new

    In this new profile folder you just popped open - NOT the one on your desktop - select all content (you can use Ctrl + a) and delete (you can press Delete on the keyboard).

    Leave this window open, open or switch to your folder of old data of Firefox. Consult your old profile folder. At this level, you should see a folder named bookmarkbackups among other things.

    Select all (Ctrl + a) and copy (or right-click > copy or Ctrl + c).

    Switch to the empty profile folder in another window and paste (or right-click > paste or Ctrl + v). This may take a few minutes because some files are large.

    Launch Firefox

    Firefox should start in this 'new' profile with the old resurrected profile data. Success?

  • Establishment of Firefox urging 42.0 refreshed and now my 2 - Fav went modules! Is reversal Possible to undo changes?

    In moments, Firefox "Refresh" made a mess of my selections, custom modules, plugins, toolbars, etc and now fails, 2 - my favorite "go - to" Add - ons are (1) went 1 and (2) the other will not be installed. I would NEVER suggest that Firefox again. I was doing pretty well... Except for several months, Firefox crashes suddenly, and I have to go in to effect Firefox Task Manager, then open Firefox anew. All I can say is, I have to lose my marbles to 'Refresh' Firefox for the second time in a few years, after the first sentence of time due, and the overall results are worse now, the second time. I'm also tired of Firefox crashes.

    Anyway, is the "refresh" which took place in the last hour, reversible? Also, just noticed "old Firefox Data folder ' then he'd ever seen before... is - it related to Firefox refreshing?

    Help?

    Yes, an update moves the entire record of the settings in the folder of old data from Firefox, then Firefox creates a new folder of parameters with selected data in your old folder, not to mention most of the preferences or your extensions.

    You can use the contents of the Old Firefox Data folder to "roll back" the refresh, but this involves several steps. It takes 5 minutes, but it's perhaps faster than the recovery of individual files and load those into your new profile.

    Check in the folder 'Old data Firefox' update adds a folder with a random semi name on your desktop. If there is only one, that probably has your old settings and Add-ons. If there is more than one, you'll want to work with one who has been updated recently.

    Once you have identified the profile folder, that you want to restore, here is my "old profile resurrection suggested procedure:

    Overview

    Here are the steps described in more detail below:

    1. Create a new Firefox profile
    2. Delete all of this profile folder
    3. Copy in all of the old profile folder

    Create a new profile for Firefox (Windows)

    Exit Firefox completely and start up in the Profile Manager by pasting the following in the Windows search, or the Run dialog box by pressing ENTER:

    firefox.exe -P
    

    Note: any time want to switch profiles, exit Firefox and return to this dialog box.

    Click on the button create a profile, give it a name like OldSettings and skip the option to change the location of the folder. Select the new profile from the dialog box, and then start Firefox.

    Open the new profile folder in Windows Explorer

    Firefox in the new profile should look like a new installation of the plant. Open the troubleshooting information page by using either:

    • button "3-bar" menu > "?" button > troubleshooting information
    • Menu help > troubleshooting information
    • type or paste everything: in the address bar and press Enter

    In the first table, click on the view file"" button. Firefox will launch your new profile folder in Windows Explorer.

    This folder open, switch back to Firefox and get out by using either:

    • "3-bar" menu button > button "power".
    • (menu bar) File > Exit

    Firefox is closed, the profile folder must be front and Center, or you can activate it by using the taskbar.

    Copy old data instead of new

    In this new profile folder you just popped open - NOT the one on your desktop - select all content (you can use Ctrl + a) and delete (you can press Delete on the keyboard).

    Leave this window open, open or switch to your folder of old data of Firefox. Consult your old profile folder. At this level, you should see a folder named bookmarkbackups among other things.

    Select all (Ctrl + a) and copy (or right-click > copy or Ctrl + c).

    Switch to the empty profile folder in another window and paste (or right-click > paste or Ctrl + v). This may take a few minutes because some files are large.

    Launch Firefox

    Firefox should start in this 'new' profile with the old resurrected profile data. Success?

  • rendered savings composited files

    Hi, I'm migrating from iMovie, FCP - x 10 soon and spent time getting used to iMovie, which I see is a kind of final cut PRO - X version lite, or "limited" as it used to be called.  iMovie follows Cinestream, a versatile program, deep NLE editing style I have used for years, which ended in OS9 and are only SD, as well as his age.  However, one thing I need to know about FCP - X, which apparently cannot be done in iMovie, must be able to save a rendered composition.  By composition, I mean a sequence involving several in the form of images, (multi split screen), titles, effects, you name, often involving multiple tracks and then made into a file.  The object must be able to move this file later with any other similar complex renderings - IE, change them without having to re - create the brand-new everywhere.

    The only way I can see happening is to make the entire timeline (cannot make individual sections of iMovie - or can I?)  And I'm leaving the PCF - X is richer in features to allow registration of the various sections composed as renditions files... like I used to do in the old program.

    Sorry if this is too complicated,

    Thank you

    Keith

    YYes, you can export portions of a project.

  • How to recover or re - use a backup Time Machine disconnected?

    I had a hard drive will... "Brown" (overcooked SSD, don't know how it happened; "I think it's just a bad disk). Unfortunately, my Time Capsule (backup drive - this is not really a TC of Apple, if it matters) is also very picky. Well, I had a new SSD and cloned the old on SSD so I'm back in business on this effect, but in the process, I unplugged my wayward backup disk in Time Machine (as in, I accidentally said the temperamental player is NOT the source of archive TM). Is it possible to "bless" the backup of this wayward drive to retrieve archive it? I have access to all the files, and I recognize that I really need to get a new, reliable, drive; but in the meantime, is it possible to make the TM to accept the folder Backups.backupdb active as long as the backup plan "current", rather than simply to start with a new in this space?

    BTW, I use OS X 10.11.5. I followed the instructions to Time Machine: how to transfer backups from a current backup disk to a new backup drive - Apple Support, but am concerned about the fact that it is trying to create a new backup rather than press archives, I already. I probably missed in all care, is there a way to fix it?

    The answer might involve several steps.

    but I am concerned that it is trying to create a new backup rather than press archives

    It's still the right to go forward... Once you change the configuration of Time Machine... It will say that it will start a new backup, except if it finds an existing valid backup when it starts. If you have no other choice to the allow him to proceed... If you find it has created a new sparsebundle and started on... cancel the backup, and then try to inherit the old backup.

    See Pondini... a bit outdated but it has information not available anywhere else.

    B5 and B6 here. http://pondini.org/TM/troubleshooting.html

Maybe you are looking for