Charger (need help to convert AS2 AS3)

Because I know that this code works very well and that I use it in one of my flash AS3, I need it in one of my flash AS2 and I do not know how to adapt. I searched more than 100 threads and I can not find something similar... Thank you to help me make it work in AS2! As I need in AS2, I thought it would be the right place to post.

I posted the entire process of loading code, but I need help especially with the charger part. How to do this in AS2? Thank you!

var img = 0;
var image_total = 0;

var myImages_array:Array = new Array();
var myBitmaps_array:Array = new Array();

function Init();

{

Image URLS is loaded into a table before this call
LoadImage();

}


function LoadImage()
{
If (img, myImages_array.length) / / img is the index of the current image and myImages_array is my URL table
{

I need help with this framework, you can
var loader: Loader = new Loader();

/ / Returns the full path of the image and load it
Loader.Load (new URLRequest (my_site_url + myImages_array [img]));
loader.contentLoaderInfo.addEventListener (Event.COMPLETE, imageLoaded);

}
on the other
{
If (count == 0)
{

When everything is loaded, I'll start loading my Bitmaps in a short slide show
Count += 1;
init_slideshow();
}
}
}

function imageLoaded(e:Event):void
{
Bitmap of the image: var = e.target.content;

Bitmap manipulation (deleted) here

image_total = myBitmaps_array.push (image);

If (img < myImages_array.length)
{
IMG += 1;

Call the following image
LoadImage();
}
}

function init_slideshow (): void
{

The current index for the first Reserts
IMG = 0;

Start the slide show, since everything is loaded
animate_slideshow();
}

Look at the MoveClipLoader class and the addListener method that supports.

Tags: Adobe Animate

Similar Questions

  • Help to convert as2 as3

    Please, I need help convert this script in as3 bellow. Thank you.

    SCREEN_WIDTH = 800

    screen_height = 200

    frequency = 0

    MovieClip.prototype.serConfeti = function () {}

    This._x = Math.ceil (Math.Random () * SCREEN_WIDTH)

    This._xscale = Math.ceil (Math.Random () * screen_height)

    This ._yscale = this ._xscale

    This.Mover)

    This.coloreame)

    }

    function getPorcentaje() {}

    var number = Math.ceil (Math.random () * 100)

    return number

    }

    getOffset() {} function

    var number = Math.ceil (Math.random () * 255)

    var buleano = Math.round (Math.random () * 1)

    If (buleano == 1) {}

    number = number * 1

    }

    return number

    }

    MovieClip.prototype.coloreame = function () {}

    var color = new Color (this)

    var nuevo_color = new Object()

    nuevo_color. RA = getPorcentaje)

    nuevo_color. RB = GetOffset)

    nuevo_color.GA = getPorcentaje)

    nuevo_color. GB = GetOffset)

    nuevo_color.BA = getPorcentaje)

    nuevo_color.BB = GetOffset)

    my_color.SetTransform (nuevo_color)

    }

    MovieClip.prototype.mover = function () {}

    this.onEnterFrame = function () {}

    If (this ._y < 600) {}

    This ._y += 10

    This ._xscale = Math.random () * 200

    This ._rotation = Math.random () * 360

    } else {}

    this.removeMovieClip)

    }

    }

    }

    MovieClip.prototype.caidaConfeti = function () {}

    this.createEmptyMovieClip("caida_mc",1)

    var count = 0

    var confCount = 1

    This.caida_mc.onEnterFrame = Function () {}

    if(Count<frecuency) {}

    Count ++

    } else {}

    this.attachMovie ("conf", "conf" + confCount, confCount)

    eval("this.caida_mc.conf"+confCount).serConfeti)

    Count = 1

    confCount ++

    }

    }

    }

    //

    _root.caidaConfeti)

    see if it's what you want:

    var screen_width:int = 800;

    var screen_height:int = 200;

    var frecuency:int = 0;

    function coloreame(mc:MovieClip):void { / / can't tell what is your coloreame but try this. }

    var ct:ColorTransform = mc.transform.colorTransform;

    CT. Color = 0xffffff * Math.random ();

    mc.transform.colorTransform = ct;

    }

    function serConfeti(mc:MovieClip):void {}

    MC.x = Math.ceil (Math.random () * screen_width);

    mc.scaleX = mc.scaleY = Math.ceil (Math.random () * screen_height);

    Mover (MC);

    coloreame (MC);

    }

    function mover(mc:MovieClip):void {}

    mc.addEventListener (Event.ENTER_FRAME, moverF);

    }

    function moverF(e:Event):void {}

    var mc:MovieClip = MovieClip (e.currentTarget);

    If (mc.y<>

    MC.y += 10;

    mc.scaleX = Math.random () * 200;

    MC.rotation = Math.random () * 360;

    } else {}

    mc.removeEventListener (Event.ENTER_FRAME, moverF);

    mc.parent.removeChild (mc);

    }

    }

    function caidaConfeti(mc:MovieClip):void {}

    var caida:MovieClip = new MovieClip();

    Caida.Count = 0;

    caida.confCount = 1;

    mc.addChild (caida);

    caida.addEventListener (Event.ENTER_FRAME, enterFrameF);  / / I can't tell when it has to end.

    }

    function enterFrameF(e:Event):void {}

    var caida:MovieClip = MovieClip (e.currentTarget);

    If (caida.count<>

    Caida.Count ++;

    } else {}

    var conf_mc:MovieClip = new conf();

    caida.addChild (conf_mc);

    serConfeti (conf_mc);

    }

    }

    caidaConfeti (this);

  • Need help w / skip intro AS3 code

    Hello world!

    I'm building a site that needs an intro.

    I have everything set up for the intro and the main site on the same file; Intro is a scene and website is another.

    I made a text, converted to the symbol, the name of the instance of "skip_btn" and placed just after the start of the animation timeline.

    Shortly before the end of the animation, the "skip" button disappears, and in its place a button 'enter site'; It's in the same place, but it has a different instance name: "enter_btn."

    I use this code for the "skip" button (and by editing a little, I would like to use it for the button 'enter site' as well):

    skip_btn.addEventListener (MouseEvent.CLICK, skipIntro);

    function skipIntro(event:MouseEvent):void {}

    gotoAndPlay ("site", 1);

    }

    And I get this error:

    1067: constraint implied a value of type int to type String unrelated.

    I placed the code on the first frame of the ActionScript layer that lies on the other layers and the action 'stop' to the last image.

    I attach the project file so that everyone can check to detect the error.

    I appreciate your help.

    Thank you very much.

    JC

    If you are familiar with AS2, AS3 reverses the order of the arguments to the function gotoAndPlay...

    skip_btn.addEventListener (MouseEvent.CLICK, skipIntro);

    function skipIntro(event:MouseEvent):void {}

    gotoAndPlay (1, "site");

    }

    In addition, you can probably use the same function of skipIntro as that is for the Enter key.  You only need to create the listener for it.

  • Convert AS2 AS3

    So I made this game to base a few years ago, which was in AS2 and Flash 6.  Now I want to convert this AS2 AS3 game, but I have no idea where to start.  The code is approximalty 4 k lines long and I don't know what to change to make it work in AS3.  What do you guys suggest?

    I think you need to set the lower bar, do a few test tasks and see if you can complete them on Android. Code conversion takes a long time. You need an application view whole birds and you need to understand exactly how it works. You cannot convert random each piece to the equivalent AS3. You will need to rewrite it in a way that makes sense, using if everything going to OOPs.

    Make fun test applications on Android. Download a few buttons to make them do things, read the camera, vibrate the device, put up a StageWebView things and stick, etc.. Have fun. Otherwise, I think you're going to burn and/or will not convert the app very well.

    Believe me, I have come back to my own code a year later, with a lot more experience and didn't even know, I wrote and thought that the classic line... Who hell wrote this code? Oh... Yes, I did... What I thought?

  • need help to convert this procedure used and call in coldfusion

    Hi I'm new to coldfusion and I haed of the code with me and I need it to convert in the stored procedure and will call back within coldfusion. Can someone help me how to make these data to the stored procedure and calling in coldfusion.

    Here is the code of my

    SET NOCOUNT ON

    DECLARE
    @cpt_dpt_cd char (2)
    @cpt_com_cd char (3)
    @sub_com_cd char (5)
    @con_upc_no char (13)
    , @pid_lng_dsc_tx varchar (100)
    , @pid_sht_dsc_tx varchar (100)
    , @rev_by varchar (8)
    @rev_dt datetime


    DECLARE upc_cursor CURSOR FOR
    SELECT *.
    OF di_audit_corp_upc_ldr_tbl
    WHERE con_upc_no IN ((in English only)
    SELECT con_upc_no, COUNT (*)
    TABLE [dbo]. [di_audit_corp_upc_ldr_tbl]
    GROUP BY con_upc_no
    HAVING COUNT (*) > 1
    )
    ORDER BY con_upc_no

    OPEN upc_cursor

    -It is performed while the previous extraction is successful.
    FETCH NEXT from upc_cursor
    IN
    @cpt_dpt_cd
    @cpt_com_cd
    @sub_com_cd
    @con_upc_no
    @pid_lng_dsc_tx
    @pid_sht_dsc_tx
    @rev_by
    @rev_dt

    -Check @FETCH_STATUS to see if he has more lines to fetch.
    WHILE @FETCH_STATUS = 0
    BEGIN
    -If not exists
    IF NOT EXISTS)
    SELECT con_upc_no
    OF dbo.di_audit_corp_upc_tbl
    WHERE con_upc_no = @con_upc_no
    )
    BEGIN
    -Insert record
    PRINT "insert UPC: ' + @con_upc_no"

    INSERT INTO dbo.di_audit_corp_upc_tbl)
    rcp_dpt_cd
    cpt_dpt_cd
    cpt_com_cd
    sub_com_cd
    cas_upc_no
    con_upc_no
    con_upc_tx
    pid_lng_dsc_tx
    pid_sht_dsc_tx
    aut_vld_cd
    rev_by
    rev_dt
    ) (VALUES
    '07'
    @cpt_dpt_cd
    @cpt_com_cd
    @sub_com_cd
    '0000000000000'
    @con_upc_no
    @pid_lng_dsc_tx
    @pid_lng_dsc_tx
    @pid_sht_dsc_tx
    , 'N'
    @rev_by
    @rev_dt
    )
    END
    ON THE OTHER


    BEGIN
    -to jump
    PRINT ' UPC to jump: "+ @con_upc_no
    END
    < cftransaction action = "commit" / >
    -It is performed while the previous extraction is successful.
    FETCH NEXT from upc_cursor
    IN
    @cpt_dpt_cd
    @cpt_com_cd
    @sub_com_cd
    @con_upc_no
    @pid_lng_dsc_tx
    @pid_sht_dsc_tx
    @rev_by
    @rev_dt

    END

    CLOSE Upc_cursor
    DEALLOCATE upc_cursor

    If I understand your SQL code you select some records in the di_audit_corp_upc_ldr_tbl table.  For each record in the results, you insert di_audit_corp_upc_tbl if a matching record does not already exist in di_audit_corp_upc_tbl.  If this summary is correct, you could try rewriting your query to avoid using a cursor.

    Something like the example below might work (I have not tested this code).

    INSERT di_audit_corp_upc_tbl (rcp_dpt_cd, cpt_dpt_cd, cpt_com_cd, sub_com_cd, cas_upc_no, con_upc_no, con_upc_tx, pid_lng_dsc_tx, pid_sht_dsc_tx, aut_vld_cd, rev_by, rev_dt)
    SELECT ' 07', cpt_dpt_cd, cpt_com_cd, sub_com_cd, ' 0000000000000', con_upc_no, pid_lng_dsc_tx, pid_lng_dsc_tx, pid_sht_dsc_tx, "n", rev_by, rev_dt
    From di_audit_corp_upc_ldr_tbl
    WHERE THERE IS NO
    (
    SELECT *.
    OF di_audit_corp_upc_tbl AS B
    WHERE B.con_upc_no = A.con_upc_no
    ) - check to see if the folder already exists in the destination table
       
    AND
    (
    SELECT COUNT (*)
    FROM di_audit_corp_upc_ldr_tbl AS C
    WHERE C.con_upc_no = A.con_upc_no
    ) > 1 - replaces the HAVING clause in the original query used to select cursor

    Note that I assume you are using Microsoft SQL Server.

    For questions about the improvement of SQL queries you could be better off the coast to post this kind of question on a specific forum for the database server you are using.

  • Need help to convert DAQ traditional subvis DAQmx configuration

    I need to convert these screws (of NOR-traditional DAQ) to be used with a new data acquisition card that supports only NI-DAQmx.

    Please help me in this...

    Can I use the same traditional NI DAQ VIs with the NI PCI-6221?  If so, how? This device can be configured for NI DAQ traditional?

    NOR has several resources to help move tradtional DAQ DAQmx. A good place to start is the getting started page. There is a tutorial on how to transition. There is also the compatibility screws which replace certain traditional DAQ functions with wrappers around functions DAQmx. The DAQ example you posted is pretty trivial and really shouldn't take a lot of time to convert once you get a basic understanding of the DAQmx.

  • Need help to convert a document to PDF

    I have an active account and want to convert a word document to PDF but can't because I got a message to contact support.  How can I get in touch with a live person?

    Hi SenaW,

    I'd love to help you. I think I see what is the problem. You have an ExportPDF subscription, which allows you to convert PDF files to Word format. To convert a Word to PDF doc, you need either Acrobator Adobe PDF Pack .

    Please let us know if you have any additional questions.

    Best,

    Sara

  • Convert as2 as3 code

    Please help me to convert this code...

    for (i = 1; i < = nextballs; i ++)

    {

    nextarray [i] = new Array (0, 0, 0);

    attachMovie ("bullet", "nextballs" + i, kkk ++);

    _loc2.inGame ["nextballs" + i] ._x = xnext;

    _loc2.inGame ["nextballs" + i] ._y = ynext + i * 60;

    _loc2.inGame ["nextballs" + i] ._xscale = 140;

    _loc2.inGame ["nextballs" + i] ._yscale = 140;

    }

    :

    var nextballs:int = 4;  //<- nextballs="" needs="" to="" be="" defined,="" though="" need="" not="" be="" defined="" this="">

    for (var i: int = 1; i<= nextballs;="">

    {

    var nextarray [i]: Array = new Array (0, 0, 0);

    This ["nextballs" + i] = new balls();

    addChild (this ["ballballs" + i]);

    xnext and ynext need to be defined and should probably be updated in this loop for

    This part of your code that is absurd given your statement attachMovie().

    _loc2.inGame ["nextballs" + i] .x = xnext;

    ["nextballs" + i] _loc2.inGame there = ynext + i * 60;

    _loc2.inGame ["nextballs" + i] .scaleX = 1.4;

    _loc2.inGame ["nextballs" + i] .scaleY = 1.4;

    }

  • Need help to convert an Image Format in forms...

    So Ive worked with Flash Pro CS5 and it seems that I can't get right with image formats conversion

    in symbols of form. A few days ago I convert it correctly, but now I don't remember exactly how

    I did it lol.

    What Im trying to convert an image into a symbol of the form, and then in a format of .gls. When I import

    the symbol of work in my SoThink Flash form it show up under the stage, but now I can't recreate

    a work as it stands as an empty image.

    Ive looked and read a few tutorials but Im confused on what order I should do the steps in

    conversion of an image into a symbol.

    ID appreciate the help if possible, thank you...

    BTW... If theres an easy way to convert an image into a .gls shaped I'd like to hear it as well

    When you import a bitmap into flash, it's a bitmap in flash.  That is to say, no need for conversion.

    If you then want to create a vector of your bitmap image, add it to the scene, click on it to select it, then click on change/bitmap/trace bitmap.  Choose your settings, and then click ok.  on stage, you will have a vector.  You can then convert this vector a symbol (movieclip, button or graphic).

  • Try to convert as2 as3 mouse event

    Here is my code I have in as3 im trying to convert it to as2, and I'm having trouble getting the error that occurs. Who is

    The class or interface 'MouseEvent' could not be loaded.

    Stop();

    hide the password

    pass_txt.displayAsPassword = true;

    Add event listener for the "connect" button

    login_mc.addEventListener (MouseEvent.CLICK, loginUser);

    function loginUser(e:MouseEvent):void {}

    //if the user name and password are correct leave the connected user

    if (name_txt.text == "Woody0869" & & pass_txt.text == "Wolverine1") {}

    navigateToURL (new URLRequest ("http://www.licd.com" ' "), '_blank');

    display_txt.text = 'Welcome\nBryce Woodward;

    }

    //if the user name and password are not a proper display an error message

    ElseIf (name_txt.text! = "Graphic" & & pass_txt.text! = "Graphic") {}

    display_txt.text = "connection failed!";

    }

    }

    I tried to add to my answer, but your answer while I was deleted it... one last time...

    login_mc.onRelease = function (): Void {}

    If the user name and password are correct allow the user

    If (name_txt.text == "Woody0869" & pass_txt.text == "Wolverine1") {}

    getURL ("http://www.licd.com", "_blank");

    display_txt. Text = "Welcome\nBryce Woodward";

    }

    If the user name and password are incorrect, display an error message

    ElseIf (name_txt.text! "Graphic" = & pass_txt.text! = "Graphic") {}

    display_txt. Text = "connection failed!";

    }

    }

  • Need help to convert DAQ DAQmx hardware

    Hello

    I've struggled with traditional DAQ to DAQmx conversion for two weeks. I really need a help.

    As you can see in the image below, I tried to replace the old VI with new ones. But it does not work. Of course, the VI below is just a part of my VI. VI according to case structure are inside the while loop.

    Could you please give me who thought why it does not work?

    FYI: The strange thing is that it works without any error messages, but there is no real output (values on the graph, the data in the tables, etc.).

    Thanks in advance.

    Best,

    Jay

    Hi Jay,.

    Assuming that the code DAQmx and traditional DAQ are screenshots of screws separate, I think as the following each driver setting playback functions would explain the different behavior than you (you) see both the value - 1:

    Traditional DAQ:

    DAQmx:

    So when you give DAQmx Read - 1 "number of samples per channel" when you run a primary task, the effect is that it will return some data are available at that time DAQmx Read is called.  In your case, it's immediately after starting the task so it could very well be 0 samples available in the buffer.  I imagine you'd see data if you change the value of this parameter of-1 for the number of samples you want to read.

    That being said, if you want to continually acquire you should call DAQmx Read from inside a loop.  I agree with others that you should take a look at the DAQmx shipping examples to get started, you'll probably find something very close to what you want to do.  You can find examples at:

    Help > find examples... > input and output material > DAQmx

    Thanks for posting, hope this helps!

    -John

  • I need help to convert a PDF to Word file.

    I have Windows Vista as the operating system on all my computers.  On my PC, when I right click on a file PDF from Adobe my office, a menu appears that lists the option "Convert to Word."  However, when I do the same thing on my laptop, is not giving me the option and when I open the file in Word, the police, format, etc is in a technical language, I am not able to understand or read.  Help!

    I have Windows Vista as the operating system on all my computers.  On my PC, when I right click on a file PDF from Adobe my office, a menu appears that lists the option "Convert to Word."  However, when I do the same thing on my laptop, is not giving me the option and when I open the file in Word, the police, format, etc is in a technical language, I am not able to understand or read.  Help!

    Here is a FREE converter, pdf to doc (word).
    http://www.anypdftools.com/PDF-to-Word.html

    There is an application "convert online pdf to doc", such as...

    http://www.pdftoword.com/

    http://www.pdfonline.com/PDF-to-Word-Converter/

    You can google for more.

  • Need help with html and as3 dropdown

    First of all Hello!  I need to create a html for a company Web site. The design that I did is in photoshop... .and I need to create a menu drop-down. The first question is: can I create the drop in flash without having to use html frames? Can I connect one of the menu buttons in an html page so that it loads in the same window of the browser to another html page (If Yes... with what?)?  Please... I need to know... because I prefer simply to apply it in flash rather then html. And the second question is: If the scene in flash can be transparent? Because if I do the menu inside, it will be impossible to match all the dimensions of the stage... and I would like to integrate it in an html page, if possible without the stage color >... Thanks in advance!    Tudor

    For the opening of the pages you wish to study using the navigateToURL() function.  The help documentation provides information abiout it year how to control the appearance of the window as well.

    To make the transparent scene is more than a html one aspect of Flash element, if you can set it to publish it.  The key is to set the wmode paraemter which is located in the "transparent" html embed code  I don't know if all browsers supports this feature, but I think that many are willing to.

  • Need help with security when AS3 running inside the browser

    Hello

    I'm relatively new to flash, but a fairly skilled programmer.

    I've created a game that works perfectly and communicates with a WinSock server on port 4000 to publish his final to score. With the help of simple XMLSocket and Send.

    When I start the game in the stand-alone flash player everything works perfectly as it should

    However, when I embed in an HTML page or similar this is wrong. The game works fine, but the final display on the WinSock socket server fails. I got the error message.

    ioErrorHandler: [SecurityErrorEvent type = "securityError" bubbles = false cancelable = false eventPhase = 2 text = "Error #2048"]

    My server is a local server run me IIS 6. Everything works very well by the stand-alone flash player, so I know that the ports are clear and firewalls is not the problem.

    Searching around google and forums I discovered in 9,0,124,0 (flash I'm short) that they brought security enhancements, namely you must validate a cross-domain file.

    My file is sitting in the wwwroot in my Web server where my flash swf is hosted and looks like

    < cross-domain-policy >
    < allow-access-from domain = "" * "safe ="false"/ >"
    < / cross-domain-policy >

    I also tried adding to article 1 of the swf file

    Security.loadPolicyFile (" http://mydomainname.com/crossdomain.xml");

    I tried all the bottlenecks, but I can't get the flash to communicate with the server socket when it inside a web browser.

    If I run it in the stand-alone player, everything works perfectly.

    Can someone help me please. I've been googling and ripping my hair out for centuries. It's the last step in my project and I failed the final step.


    Just to add.

    My server and the test computer are on the same domain, the web server is a win2003 server and my tests and server coding is a XP machine running IE7. They are connected by a router ADSL, sharing the same external IP address, but rather through the DHCP addressing. Everything works fine for winsocket port port forwarding.

    Just for emphasis, I think that this configuration is correct, because everything works fine when I run in the flash player.

    Thank you very much

    I fixed it later.

    In version 9.0.124.0 flash they force now you have a server running on port 843 XML socket server somewhere if you want to use XMLSocket in a browser.

    Nothing to do with the domain or crossdomain.xml files.

    You must also call

    Security.loadPolicyFile ("xmlsocket://x.x.x.x:843") before opening the socket.

    to load into the XML file that defines what is allowed.

    Google search for AS3 and socket server port 843 and you will find examples and even a simple Java based server to use.

  • Need help to convert a config 881 in 1921

    Here's a copy of my 881 easy vpn cisco config.   Can you get it someone please let me know what I need to change to make it work on a cisco 1921.

    Thanks in advance

    hostname BTLvpn

    boot-start-marker
    boot system flash: c870-advipservicesk9 - mz.124 - 11.T3.bin
    boot-end-marker

    no set record in buffered memory
    enable secret 5 XXXXXX

    No aaa new-model
    clock timezone EASTERN - 5

    Crypto pki trustpoint TP-self-signed-733417695
    enrollment selfsigned
    name of the object cn = IOS - Self - signed - certificate - 733417695
    revocation checking no
    rsakeypair TP-self-signed-733417695

    TP-self-signed-733417695 crypto pki certificate chain
    certificate self-signed 01
    30820244 308201AD A0030201 02020101 300 D 0609 2A 864886 F70D0101 04050030
    2 060355 04031325 494F532D 53656 C 66 2 AND 536967 6E65642D 43657274 30312E30
    69666963 37333334 31373639 35301E17 303230 33303130 30313130 0D 6174652D
    355A170D 2E302C06 1325494F 03550403 32303031 30313030 30303030 5A 303031
    532D 5365 6C662D53 69676E65 642D 4365 72746966 69636174 652 3733 33343137
    06092A 86 4886F70D 01010105 36393530 819F300D 00308189 02818100 0003818D
    DB8C973C EA391850 0A1FC496 CD6DFAA8 36F72E3B 51542 HAS 05 DF0B3BD0 6080 C 367
    CE76E4AD 24EFD4D6 1562B1B8 63C27FED 2810B02A 18D5B8AF 9 735584 349BDB51
    C46B5844 A1B46B23 9C9C449C 8C61E97F 4585FB64 BA5359AC 981DFDCA 6E87B423
    B9F3269D EA9EF97E 74B0AC75 3906ED58 E87F317E 1D8CE583 2DDFFCAB 84278123
    02030100 01A36E30 6C300F06 03551 D 13 0101FF04 05300301 01FF3019 0603551D
    11041230 10820E45 41467670 6E2E7375 6E2E696E 73301F06 23 04183016 03551D
    8014638B 4C4459E4 18E06ADD 1BE39596 9834301 D 0603551 D 0E041604 8A 145115
    14638B4C 4459E418 E06ADD8A 1451151B E3959698 34300 D 06 092 A 8648 86F70D01
    01040500 03818100 8180553B 6FCFDB9F 0307DE6C F9758A0C 775D22DA B084AAEA
    8FD8C674 DC13A65D 97A76CB7 41 D 62861 6513E641 AA348740 2108A58F 68DE29A8
    9A2161FE 0B37D8C5 1FD7B9C9 540AC637 64DBC58B 3D89E8E1 C391FBDE 54ACFC4D
    7FCAE855 978ED9CA 75AED32B 19D516FB FAC6769B F9DA9892 F27EA1E9 2AF3B757
    58F84AF8 FCDB2D8E
    quit smoking

    crypto ISAKMP policy 1
    BA 3des
    preshared authentication
    Group 2

    Crypto ipsec transform-set ESP-3DES-MD5-esp-3des esp-md5-hmac

    Crypto ipsec client ezvpn VPN3000
    connect auto
    key community group XXXXX
    network extension mode
    peer default X.X.X.X
    ACL 100
    username password BTLuser XXXXX
    xauth userid local mode

    No dhcp use connected vrf ip
    DHCP excluded-address IP 172.30.86.1
    DHCP excluded-address IP 172.30.86.2
    DHCP excluded-address IP 172.30.86.31 172.30.86.255
    DHCP excluded-address IP 172.31.86.1
    DHCP excluded-address IP 172.31.86.2
    DHCP excluded-address IP 172.31.86.31 172.31.86.255
    DHCP excluded-address IP 172.31.86.3

    pool IP dhcp DHCP-voice
    import all
    network 172.30.86.0 255.255.255.0
    router by default - 172.30.86.1
    10.10.10.45 DNS server
    option 150 ip 192.168.64.4 192.168.64.3

    IP dhcp DHCP-Data pool
    import all
    network 172.31.86.0 255.255.255.0
    router by default - 172.31.86.1
    10.10.10.45 DNS server

    no ip domain search
    domain IP XXXX

    password username admin privilege 15 XXXXX
    Archives
    The config log
    hidekeys

    TFTP IP source-interface Vlan10

    class-map correspondence-any AutoQoS-VoIP-RTP-Trust
    match ip dscp ef
    class-map correspondence-any AutoQoS-VoIP-control-Trust
    match ip dscp cs3
    match ip dscp af31

    Policy-map AutoQoS-policy-Trust
    class AutoQoS-VoIP-RTP-Trust
    percentage of priority 70
    class AutoQoS-VoIP-control-Trust
    percentage of bandwidth 5
    class class by default
    Fair/fair-queue
    policy-motherboard
    class class by default
    form average 768000
    service AutoQoS-policy-Trust policy

    interface FastEthernet0
    switchport access vlan 10
    switchport mode access
    switchport voice vlan 1
    No tap

    interface FastEthernet1
    switchport access vlan 10
    switchport mode access
    switchport voice vlan 1
    No tap

    interface FastEthernet2
    switchport access vlan 10
    switchport mode access
    switchport voice vlan 1
    No tap

    interface FastEthernet3
    switchport access vlan 10
    switchport mode access
    switchport voice vlan 1
    No tap

    interface FastEthernet4
    Internet Connection Description $ ES_WAN$
    address IP dhcp client id FastEthernet4
    IP access-group 124 on
    IP virtual-reassembly
    load-interval 30
    automatic duplex
    automatic speed
    CDP enable
    Crypto ipsec client ezvpn VPN3000
    service-policy output Parent
    No tap

    interface Vlan1
    Description VLAN VoIP
    IP 172.30.86.1 255.255.255.0
    IP access-group 123 to
    Crypto ipsec client ezvpn VPN3000 inside

    interface Vlan10
    Description Data-VLAN
    IP 172.31.86.1 255.255.255.0
    IP virtual-reassembly
    IP tcp adjust-mss 1452
    Crypto ipsec client ezvpn VPN3000 inside

    IP http server
    local IP http authentication
    IP http secure server
    IP http timeout policy slowed 5 life 86400 request 10000

    access-list 100 permit ip 172.30.86.0 0.0.0.255 any
    access-list 100 permit ip 172.31.86.0 0.0.0.255 any
    access-list 123 permit ip any any ef dscp
    access ip-list 123 allow a whole
    access-list 124 permit ip any any ef dscp
    access-list 124 allow esp a whole
    access ip-list 124 allow a whole

    33333 event log RMON trap description AutoQoS 'AutoQoS SNMP traps for voice Drops' owner AutoQoS

    Line con 0
    password 7 XXXXX
    Synchronous recording
    local connection
    no activation of the modem
    line to 0
    line vty 0 4
    password 7 XXXXX
    Synchronous recording
    local connection
    length 0

    max-task-time 5000 Planner

    WebVPN cef
    end

    Overall, it seems correct, only a few small corrections:

    The comand system startup is not necessary for the loading of an image to the old router

    TFTP IP source-interface Vlan10

    must be changed to

    TFTP IP source-interface GigabitEthernet0/1.10

    ACL 123 and 124 there is no need to allow traffic in the first As if you later "license ip any any" unless you want to see the hitcounts.

    --
    Don't stop once you have upgraded your network! Improve the world by lending money to low-income workers:
    http://www.Kiva.org/invitedBy/karsteni

Maybe you are looking for