Create a user can access a single schema - please help!

Hi all

I want to create a user in an Oracle database that can only access a single schema. I did the following:



CREATE THE USER 'TEST' PROFILE 'DEFAULT.

IDENTIFIED BY 'test' TABLESPACE DEFAULT 'USERS '.

TEMPORARY TABLESPACE "TEMP".

RELEASE OF ACCOUNT;

GRANT SELECT ON "TESTDTA". "" F0007 ' TO 'TEST '.

GRANT 'CONNECT' TO THE 'TEST ';


I did a test and the TEST user can access all schemas, when I only gave the explicit permissions for the TESTDTA schema.

Any suggestion/precision?

Thanks in advance.

Victor.

Maybe worth looking at what has been given to t PUBLIC:

Select * from dba_sys_privs
where dealer = "PUBLIC";

Select * from dba_role_privs
where dealer = "PUBLIC";

Select * from dba_tab_privs
where dealer = 'PUBLIC '.
and the owner = "PRODDTA";

A.

Tags: Database

Similar Questions

  • ReadOnly user can access the other schema and change them

    Hello everyone,

    I created a readonly as this user in oracle 11g r2

    SQL > CREATE USER IDENTIFIED BY readonly readonly;
    SQL > GRANT CREATE SESSION, CREATE a SYNONYM to readonly.
    SQL > GRANT SELECT ON SA.vCustomerService TO readonly.

    But when I connect to the database and do a select like:
    SQL > SELECT * FROM ACC;
    I get the data in this table, even if I do an update on that table it works.

    What I am doing wrong that my readonly user always has full access to the other schema?

    Thank you in advance for your help!

    Best regards
    GIL GOMES Dany

    Dan_lu wrote:
    Hello everyone,

    I created a readonly as this user in oracle 11g r2

    SQL > CREATE USER IDENTIFIED BY readonly readonly;
    SQL > GRANT CREATE SESSION, CREATE a SYNONYM to readonly.
    SQL > GRANT SELECT ON SA.vCustomerService TO readonly.

    But when I connect to the database and do a select like:
    SQL > SELECT * FROM ACC;
    I get the data in this table, even if I do an update on that table it works.

    Check the permissions for this table - maybe some operations on this table are granted to the publc?

  • Can I create pages that only authorized users can access?

    I need to create pages that only authorized users can access, is - it possible to do away with the Muse?

    Site manager should be included in section admin, please give me the url of the site to take a peek.

    Regarding the other question, you want to create an intranet site for employees of the company or site of secure content where users would have to login before they can access the content?

    If its with intranet then it would not be possible with BC because that website hosting in British Colombia will be on the web and may not be restricted on the intranet site, you can create the site of Muse and upload to the server of third party or company where it can be used as intranet site.

    With a secure content, you can secure pages and the content created on end of BC and use the connection on the home page.

    Thank you

    Sanjit

  • Privacy of user account: my daughter (standard user) can access my files on my Administrators account

    My daughter (standard user) can access my files on my Administrators account via his account by clicking on the C drive, then users on my account. How can I change this to my documents remain private.

    I have now managed to do my private account managers. I'm pretty sure by default, it is created to share with my standard account of girls and no password is required to access my documents. It would be interesting to know if anyone has had this problem I only stumbled on this. Thanks for the everyone entry.

  • AnyConnect users can access internal network

    Hello!

    Just sat up a new Anyconnect VPN solution for a customer. It works almost perfect.

    Anyconnect users can reach the internal network storage. The anyconnect users can access the internet, but nothing on the network internal.

    (Deleted all the passwords and public IP addresses)

    ASA 4,0000 Version 1

    !

    ciscoasa hostname

    names of

    !

    interface Ethernet0/0

    switchport access vlan 2

    !

    interface Ethernet0/1

    !

    interface Ethernet0/2

    !

    interface Ethernet0/3

    !

    interface Ethernet0/4

    !

    interface Ethernet0/5

    !

    interface Ethernet0/6

    !

    interface Ethernet0/7

    !

    interface Vlan1

    nameif inside

    security-level 100

    IP 192.168.9.1 255.255.255.0

    !

    interface Vlan2

    nameif outside

    security-level 0

    IP address

    !

    passive FTP mode

    DNS domain-lookup outside

    DNS server-group DefaultDNS

    Server name 213.80.98.2

    Server name 213.80.101.3

    network obj_any object

    subnet 0.0.0.0 0.0.0.0

    access-list SHEEP extended ip 192.168.9.0 allow 255.255.255.0 192.168.9.0 255.255.255.0

    AnyConnect_Client_Local_Print deny ip extended access list a whole

    AnyConnect_Client_Local_Print list extended access permit tcp any any eq lpd

    Note AnyConnect_Client_Local_Print of access list IPP: Internet Printing Protocol

    AnyConnect_Client_Local_Print list extended access permit tcp any any eq 631

    print the access-list AnyConnect_Client_Local_Print Note Windows port

    AnyConnect_Client_Local_Print list extended access permit tcp any any eq 9100

    access-list AnyConnect_Client_Local_Print mDNS Note: multicast DNS protocol

    AnyConnect_Client_Local_Print list extended access permit udp any host 224.0.0.251 eq 5353

    AnyConnect_Client_Local_Print of access list LLMNR Note: link Local Multicast Name Resolution protocol

    AnyConnect_Client_Local_Print list extended access permit udp any host 224.0.0.252 eq 5355

    Note access list TCP/NetBIOS protocol AnyConnect_Client_Local_Print

    AnyConnect_Client_Local_Print list extended access permit tcp any any eq 137

    AnyConnect_Client_Local_Print list extended access udp allowed any any eq netbios-ns

    pager lines 24

    Enable logging

    logging of debug asdm

    Within 1500 MTU

    Outside 1500 MTU

    mask 192.168.9.50 - 192.168.9.80 255.255.255.0 IP local pool SSLClientPool

    ICMP unreachable rate-limit 1 burst-size 1

    don't allow no asdm history

    ARP timeout 14400

    NAT (inside, outside) source Dynamics one interface

    !

    network obj_any object

    NAT dynamic interface (indoor, outdoor)

    Route outside 0.0.0.0 0.0.0.0 1

    Timeout xlate 03:00

    Pat-xlate timeout 0:00:30

    Timeout conn 01:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02

    Sunrpc timeout 0:10:00 h323 0:05:00 h225 mgcp from 01:00 0:05:00 mgcp-pat 0:05:00

    Sip timeout 0:30:00 sip_media 0:02:00 prompt Protocol sip-0: 03:00 sip - disconnect 0:02:00

    Timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute

    timeout tcp-proxy-reassembly 0:01:00

    Floating conn timeout 0:00:00

    dynamic-access-policy-registration DfltAccessPolicy

    identity of the user by default-domain LOCAL

    AAA authentication enable LOCAL console

    AAA authentication http LOCAL console

    LOCAL AAA authentication serial console

    the ssh LOCAL console AAA authentication

    AAA authentication LOCAL telnet console

    Enable http server

    http 192.168.9.0 255.255.255.0 inside

    http 0.0.0.0 0.0.0.0 inside

    http 0.0.0.0 0.0.0.0 outdoors

    No snmp server location

    No snmp Server contact

    Server enable SNMP traps snmp authentication linkup, linkdown warmstart of cold start

    Telnet timeout 5

    SSH timeout 5

    SSH group dh-Group1-sha1 key exchange

    Console timeout 0

    dhcpd outside auto_config

    !

    dhcpd address 192.168.9.2 - 192.168.9.33 inside

    dhcpd ip interface 192.168.9.1 option 3 inside

    !

    a basic threat threat detection

    Statistics-list of access threat detection

    no statistical threat detection tcp-interception

    WebVPN

    allow outside

    AnyConnect image disk0:/anyconnect-win-2.5.3046-k9.pkg 1

    AnyConnect enable

    tunnel-group-list activate

    internal SSLClitentPolicy group strategy

    internal SSLClientPolicy group strategy

    attributes of Group Policy SSLClientPolicy

    value of server DNS 192.168.9.5

    client ssl-VPN-tunnel-Protocol

    the address value SSLClientPool pools

    attributes of Group Policy DfltGrpPolicy

    VPN-tunnel-Protocol ikev1, ikev2 ssl clientless ssl ipsec l2tp client

    VPN Tunnel-group type remote access

    type tunnel-group SSLClientProfile remote access

    attributes global-tunnel-group SSLClientProfile

    Group Policy - by default-SSLClientPolicy

    tunnel-group SSLClientProfile webvpn-attributes

    enable SSLVPNClient group-alias

    !

    class-map inspection_default

    match default-inspection-traffic

    !

    !

    type of policy-card inspect dns preset_dns_map

    parameters

    maximum message length automatic of customer

    message-length maximum 512

    Policy-map global_policy

    class inspection_default

    inspect the preset_dns_map dns

    inspect the ftp

    inspect h323 h225

    inspect the h323 ras

    inspect the rsh

    inspect the rtsp

    inspect esmtp

    inspect sqlnet

    inspect the skinny

    inspect sunrpc

    inspect xdmcp

    inspect the sip

    inspect the netbios

    inspect the tftp

    Review the ip options

    !

    global service-policy global_policy

    context of prompt hostname

    no remote anonymous reporting call

    Cryptochecksum:6a58e90dc61dfbf7ba15e059e5931609

    : end

    Looks like you got the permit vpn sysopt disable to enable:

    Sysopt connection permit VPN

    Also remove the dynamic NAT depending on whether you have already configured under the NAT object:

    No source (indoor, outdoor) nat Dynamics one interface

    Then 'clear xlate' once again and let us know if it works now.

  • How can I remove the tones created in garageband that have been uninstalled? I also installed but I can't remove it either please help thanks

    How can I remove the tones created in garageband that have been uninstalled? I also installed but I can't remove it either please help thanks

    Hello Michael,

    Welcome to Apple Support communities.

    I see that you need assistance, removal of GarageBand ringtones that were uninstalled. I know it's nice to be able to properly manage your tones. I can help you with this.

    Use the article for iOS (iPad) 2.0.x GarageBand: GarageBand share songs, more precisely, this section:

    To remove the existing ringtones follow these steps:

    • Press to select, then press the button Delete for any ringtone you want to delete.

    • Drag a ringtone in the list, and then press delete.

    Have a great day!

  • tried everyting to sort the "assertion failed" in LightroomCC, uninstall and installed it again, tried to check the photo folder in the user account, it still does not, PLEASE HELP!

    Had "assertion failure" at the launch of LightroomCC, tried everything help, uninstall and installed it again, tried to check the photo in the user account folder, still does not, PLEASE HELP!

    Thanks for the help.

    My computer scientist has created a new user in my computer and now the 6 Lightroom

    works very well.

    Thank you

  • Hello, I forgot my security questions, I want to change but the need for an aid station. And I do not add a post before rescue. How can I add now? Please help me. TNX.

    Hello, I forgot my security questions, I want to change but the need for an aid station. And I do not add a post before rescue. How can I add now? Please help me. TNX.

    You can not and need to ask Apple to reset your security questions. To do this, click here and choose a method; If this page does not list one for your country or if you are unable to call, complete and submit this form.

    (137646)

  • Windows95 CD-ROM - game Need for DCC Speed-No. pieces found - can not install the game - please help. ___

    Windows 95 CD-CD-ROM-game Need for DCC Speed-No. pieces found - can not install the game - please help.

    ------------------

  • Hello, please help me. I use a power keyboard for my laptop. I see in the new keyboard is equipped with a num lock key is turned on. I can't use on it please help me disable it. I do not use a NumLock on. Thank you

    Hello, please help me. I use a power keyboard for my laptop. I see in the new keyboard is equipped with a num lock key is turned on. I can't use on it please help me disable it. I do not use a NumLock on. Thank you

    You say that when you press the NUM LOCK key, the Numlock State does not change (if enabled to disabled and vice versa)?  Have you tried to unplug the keyboard and by ensuring that the keyboard of the laptop does not have enabled Numlock?  If so, turn it off on the laptop keyboard and reinsert the another keyboard and see if the problem is resolved.

    If you do not need the Numlock key, it can be disabled at startup with the following procedure:http://www.technipages.com/enabledisable-numlock-at-login-or-startup.html. Once this is done, I don't think he's going to turn on or off and that they the keyboard will start in the off position.  You will not be able to use the key yourself or another, but maybe the problem she is on (which is worse than it to be impossible to be turned on) will be resolved and I hope it will be enough for you.

    If the key does not work and you want to be able to use it, the keyboard may be defective.  Try the keyboard on another computer and see if you have the same problem.  If so, the keyboard is defective and must be replaced.

    I hope this helps.

    Good luck!

    Lorien - MCSA/MCSE/network + / has + - if this post solves your problem, please click the 'Mark as answer' or 'Useful' button at the top of this message. Marking a post as answer, or relatively useful, you help others find the answer more quickly.

  • I just joined the cloud and can't find another download, please help?

    I just joined the cloud and can't find another download, please help?

    Above is part of the installation of the first Pro so just install Premier Pro family for the reminder on your machine.

  • How can I create an another user to access the HR schema data

    I am new to Oracle and just downloaded the: 10 x e. I have connected as human resources and was able to modify data in tables.
    I created another user, then say ABC, when connected as SYS. But then I could not access the tables and the data even in human resources.

    I learned that every user has its own schema, but how do I create an another user to access the same tables, and the data I see in the Oracle DB?

    Log in as a user of the system (or sys as sysdba) and:
    create user identified by ;
    Grant connect, create session ;

    To see objects to a different schema from the database user must then obtain the privilege:

    Grant select on hr. à ;

  • The locked but user can access with other users

    Hi all

    I blocked a user in oracle and trying to "Account is locked out" displaying messages of connection.

    But I am able user from other users query tables. How do I block it?

    For example:

    I had blocked a user User1. When I logged in a user named USER2 and when I call SELECT * FROM USER1. Table_name, displays the data.

    I need to block this question from other USERS.

    Help, please

    Thanks in advance...

    Account lockout does not prevent others to get access on user objects. The only change is that the user won't be able to connect more.

    To block others access to objects of this scheme can be done by defining the privileges of law for other users, or with the vault of the database by creating a Kingdom

    around this blocked scheme (DV requires an additional license).

  • 2 users can access the record even

    Hi all

    I have 2 users: sales person and his assistant, they receive the same role as sales. Both have the ability to create a new record and access the other each record.

    How to create this type of user and what privilege should pay for them?

    Thank you
    HP

    Hi HP.

    You can do this by creating groups. You can add the user to the group, and whenever any user in that group will create a folder; all the other default user will receive full access to the records. You can have more group and another. But a single user can only be added to a group. This grouping will not only allow them to share files, but also allow them to share their calendar by default, so better synchronization while working.

    Here are the steps of the creation of the groups

    1. go on Admin - Business Administration - activate "Group sharing" feature
    2. go on admin - users - group of sharing Public - Management create group
    3. create the Group and add users to the Group

    Note-
    1. the records was created before activation group will not add users to the group to record team
    2. the user of the Group should be the owner of the record
    3. after activation of the Group feature, if you want to remove the user from any particular record team, you can do. Or if you want to add any user, you can also add to the team of this particular record.

    If you find any problem in that, please do not hesitate to ask

    All the best

    Nisman

  • How to create the user to access the web console to Vcenter Server Appliance

    The default console is located at https:// < ip >: 5480

    For VC apparatus, the user who has access by default is root. Can I create another user level system and grant him access to the console?

    I tried to create a user by useradd m consoleuser and changed the passwd... However, I am not able to connect to the web console with this user...

    On a similar note, can I give access to the console to a user of the AD?

    Concerning

    Girish

    It is probably not supported by VMware, but it seems they're locking access web console rules of pam.

    You must modify the /etc/pam.d/vami-sfcb file to change the reading of the line "auth required pam_succeed_if.so uid eq 0' to succeed/deny rule change.»

    For example, you can change the line to read "auth required pam_succeed_if.so uid > = 0' and then allow any user with a UID of 0 or more to connect to the console of the web."

Maybe you are looking for