Filter ActiveAutoTextEditField and phone

I have the following code for an ActiveAutoTextEditField with telephone line filter.

ActiveAutoTextEditField befPhoneVal = new ActiveAutoTextEditField("","",20,BasicEditField.FILTER_PHONE);

There is a problem with what the first push of button is always shown as alphabet and the next typing are correctly reported under the number.

Please let me how can I add phone filter to the ActiveAutoTextEditField field.

I tried to PhoneTextFilter, but the result is the same.

Thanks for the reply.

I used the following format to solve my problem.

PhoneTextFilter (PhoneTextFilter.ACCEPT_CONTROL |) PhoneTextFilter.ACCEPT_FORMATTING | PhoneTextFilter.ACCEPT_EXTENSION);

Tags: BlackBerry Developers

Similar Questions

  • When to use a DSL filter? And what is static on regular telphones?

    When to use a DSL filter? And what is static on regular telphones?

    'Computer' and voice communications through a telephone line active DSL work on different frequencies. However, there is often a frequency in these ranges overlap, that means DSL performance can be degraded and phone calls can suffer with audible interference. A DSL filter simply uses an electronic filter to keep things separate. To answer your question of when to use a DSL filter then it whenever the hardware and ordinary phones are used on the same LAN enabled phone line.

    Static on phone lines would just be crackling or other similar non desired audible signal interference.

  • Why the back my mail list, text and phone iphone 6 freeze after upgrade ios10

    Why my list of e-mail, text and phone iphone 6 freezes after upgrade ios10?  Have you tried to turn it back on.  Becomes a real pain in the uknowwhat.

    I had the same problem at first but I was testing the first version of ios 10.  but the reason may be due to the low storage? If your storage space is ok please go to settings then general try to look for the software update again just to make sure that you use the latest version of ios usually there a few times an update immediately. If none of these solve the problem, try now button the power button and the home button at the same time (the screen of your iphone turns off a few seconds) touches both simultaneously when you see the apple logo on your screen if all else fails you can try connecting your device to itunes on a pc and run a quick diagnostic test? you go to itunes on a pc if you have already installed on your pc, laptop etc... Look at the upper left side... Click the help... Go to the bottom of the list to "Start the diagnosis" (make sure that all the test boxes have a tick and click ok to run the test) PLEASE NOTE your iphone you will need to be connected to the computer before hand... hope this will help you know if there is a problem, but when I came across this problem with my camera it was because my storage was almost full on my device and in icloud if This is the case then you need to maybe buy more storage or delete applications or games, you do not use this should help solve the problem of storage (if your device is low on storage)? hope this helps somehow.

    Nice day.

  • INDIVIDUAL chat and phone compensation newspaper story

    I want to erase chat history and phone call log history of only ONE person on my contact list. I don't want to erase the history and call logs everyone on my list of ccontact. How to achieve my goal?

    harlem17darryl wrote:

    I want to erase chat history and phone call log history of only ONE person on my contact list. I don't want to erase the history and call logs everyone on my list of ccontact. How to achieve my goal?

    Currently, Skype clients do not support selective deletion of history

    About me You can also use an IP camera that your camera for Skype videoExample Instructions

  • How do I link my hp2540 of my Tablet and phone

    How can I sync my hp2540 to my Tablet and phone

    Hello @Estatebabe,

    Welcome to the Forums of HP's Support. I understand that you want to connect your Tablet and phone to your Deskjet 2540. I would like to help.

    I guess it depends if you are willing to connect through Direct wireless or use a current wireless network.

    It depends on what operating system is your Tablet and phone.

    You try to connect via Wireless direct or via a local network?

    If you try to use a local area network, the printer is connected to the network?

    Are your mobile devices using the Android Apple iOS operating system?

  • Name and phone number attached to every comment I make on facebook

    Hello, I noticed that whenever I have comment on a message or photo on facebook that my name and phone number is added, much like a signature. How to stop what is happening please?

    You will need to request support from Facebook. Nothing to do with Microsoft.

  • Delete my old address and phone number of the computer.

    I use a DELL XPS that has loaded Windows XP operating systems.

    When we first bought this computer, we lived in a State different, different home address and telephone number. But we moved to the sunny New Mexico.

    Now, whenever I fill out a form, my 'old' address and phone number fills white and I have to
    constantly to clear the form and manually type in my new address and phone number. It gets old.

    How can I delete/erase my old address and enter the memory on this computer in my new address/phone
    so it will expand sites form with updated contact information.

    Thank you

    mwhunter85

    Try this,

    Tools-internet options-content-auto complete-settings-removed automatic full-tick form data-removal only.

  • The audio files are locked after their transfer from PC to MP3 and phone

    PC transfer music to devices

    When I transfer the pc music CDs to mp3 and phone that is to show locked and when I try to open it, it says provider license unknown, how to fix this?

    Hi Desio68,

    How to transfer music to the phone?

    B. are you ripping the CD on your computer and on your device?

    C. were you able to copy successfully?

    Have d. you tried another CD?

    E. What is the exact error message you get while trying to open the file?

    F. is the CD protected by DRM?

    If the CD is DRM (Digital Rights Management) you protected will not be able to copy it to another device.

    If you use windows media player, you have an option to prevent files to be protected while ripping. Try the following steps.

    1. open windows MediaPlayer.

    2. on the Tools menu, click Options, and then click the rip music tab.

    3. clear the check box protect against copy music . The files you check out in the future will not be protected against copying.

       

    http://Windows.Microsoft.com/en-us/Windows-Vista/Windows-Media-Player-DRM-frequently-asked-questions

    http://www.Microsoft.com/windows/windowsmedia/player/FAQ/DRM.mspx

    Bindu S - Microsoft Support
    Visit our Microsoft answers feedback Forum and let us know what you think.

  • Filter paper and the Agents Web Monitor for Windows 2012

    Hi all

    We are being followed by a new requirement of filter paper and URLS to track for windows server 2012. From now on, we use foglight 5.6.4, but even in the more recent versions, I can see that these filter paper and WebMonitor agents support only Windows 2008. Could someone help me in this? What can be the workaround in the follow-up to this Windows Server 2012?

    Please suggest me as soon as POSSIBLE.

    Kind regards

    Shiva G

    Hello

    Just make sure we are not duplicate the effort on the same thread.

    There is a similar thread that has recently been opened which has had some answers

    http://en.community.Dell.com/TechCenter/performance-monitoring/Foglight-administrators/f/4788/t/19562461.aspx

    Golan

  • SG 200 - 08 p - PC connection and phones

    Hello

    We have a serious problem here with some new firmware for switches 200 - 08 p SG: 1.0.6.2

    They are installed behind layer 2 switches 2 SG - 200 50 - real firmware 1.3.2.02.

    We have 4 VLANS: 1 for 2 for the PHONE, the RPF MGMNT 10 and 20 for CUSTOMERS - and DATA on the VLAN only 08 P 1 + 2 is required. CDR protocoll is active.

    Ports 1-7 on the P-08 is configured as 'Trunk, 1U, 2 t,' setting: Auto negotiation WE. We tried FlowControl ON and - makes no difference. 8 port is configured as "Trunk, 1U, 2 t, 10 t" switch of the floor. The connection port on the floor switch configuration ist 50-switch of SG - 200 as "Trunk, 1U, 2 t, 10 t".

    One of the problem switches: on 1-4 08-p port is connected 4 phones Cisco 6921. On the 5-7 Port is connected 1 HP Z400 and 2 Elite 7200 PCs. 6921 phones is switching to a laptop DELL Latitude 6420.

    It so happens every morning, the first fixed PC ist works fine, then the switch must be turned to get the next PC connected to the network. Switching 6921 phone does not connect. But after a few more switching market of this walk.

    We thried another material 08-P with the same configuration, we tried an older firmware level... we configure ports PoE-phone as GENERAL 1U, 2 T. We gave to external power for phones that PoE is not overloaded... nothing doesn't. Only a few switching/disable help and the PC gets its address IP of the DHCP server and phones all come a discovery of the 6000 CU.

    Is there an outside person who can lend a hand on this?

    Thank you so far...

    Hi Mr. Jens-Peter,.

    I would try to disable smartports and ethernet green on SG200 switches.  Then you have to encode each of the ports to have the necessary settings.  Often when a reboot is required to restore the feature smartports is the cause.

    Regarding 6921 phones, you need to be sure to have auto voice vlan enabled.  Otherwise, the phones won't be able to pick up the VLAN correct via CDP.  Let me know, if you have any questions.

    -Good Trent

    * Please note the useful messages! **

  • 802. 1 x authentication and phones

    I have just begun to roll authentication of 802. 1 x and found that although I got the authentication for the PC the data VLAN to work, phones on the VOICE VLAN are not unless I put 'host-mode authentication' to 'stream '.

    We did turn not authenticated for 7 years with phones and both work of the PC.

    What I want to do (i.e. what management told me to move), is to have phones connect not authenticated (CDP agreeing to handle correct assignment of VLANS) but require PC to authenticate.

    I guess the simple question is; is it still possible? If this is the case, any advice is greatly appreciated.  (config switch is below).

    Thank you

    Arch

    !
    version 12.2
    no service button
    horodateurs service debug datetime localtime show-timezone msec
    Log service timestamps datetime localtime show-timezone msec
    encryption password service
    !
    switch to hostname
    !
    boot-start-marker
    boot-end-marker
    !
    emergency logging console
    emergency logging monitor
    enable secret 5 *.
    !
    AAA new-model
    !
    !
    Group AAA dot1x default authentication RADIUS
    !
    !
    !
    AAA - the id of the joint session
    clock timezone cst - 6
    clock to summer time recurring cdt
    1 supply ws-c3750g-24ps switch
    mtu 1500 routing system
    VTP transparent mode
    no ip domain-lookup
    !
    !
    interface ip igmp snooping mrouter vlan 41 item in gi1/0/27
    interface ip igmp snooping mrouter vlan 41 item in gi1/0/28
    !
    QoS omitted MLS
    !

    pvst spanning-tree mode
    spanning tree extend id-system
    !
    internal allocation policy of VLAN ascendant
    !
    VLAN 13
    name data - VLAN
    !
    VLAN 857
    name - VLAN VoIP
    !
    VLAN 1611
    name comments - VLAN
    LLDP run
    !
    !
    class-map correspondence AutoQoS-VoIP-RTP-Trust
    match ip dscp ef
    class-map correspondence AutoQoS-VoIP-control-Trust
    match ip dscp cs3 af31
    !
    !
    Policy-map AutoQoS-Police-CiscoPhone
    class AutoQoS-VoIP-RTP-Trust
    DSCP ef Set
    320000 8000 exceed-action of the police controlled-dscp-transmit
    class AutoQoS-VoIP-control-Trust
    DSCP Set cs3
    32000 8000 exceed-action of the police controlled-dscp-transmit
    !
    !
    !
    GigabitEthernet1/0/1 interface
    switchport access vlan 13
    switchport mode access
    switchport voice vlan 857
    security breach port switchport protect
    bandwidth share SRR-queue 10 10 60 20
    form of bandwidth SRR-queue 10 0 0 0
    queue-series 2
    priority queue
    authentication-sense in
    no response from the authentication event action allow vlan 1611
    stream of host-authentication mode
    Auto control of the port of authentication
    protect the violation of authentication
    MLS qos trust device cisco-phone
    MLS qos trust cos
    Auto qos voip cisco-phone
    dot1x EAP authenticator
    spanning tree portfast
    service-policy input AutoQoS-Police-CiscoPhone
    !
    interface GigabitEthernet1/0/2
    !
    interface GigabitEthernet1/0/3
    !
    interface GigabitEthernet1/0/4
    !
    interface GigabitEthernet1/0/5
    !
    interface GigabitEthernet1/0/6
    !
    interface GigabitEthernet1/0/7
    !
    interface GigabitEthernet1/0/8
    !
    interface GigabitEthernet1/0/9
    !
    interface GigabitEthernet1/0/10
    !
    interface GigabitEthernet1/0/11
    !
    interface GigabitEthernet1/0/12
    !
    interface GigabitEthernet1/0/13
    !
    interface GigabitEthernet1/0/14
    !
    interface GigabitEthernet1/0/15
    !
    interface GigabitEthernet1/0/16
    !
    interface GigabitEthernet1/0/17
    !
    interface GigabitEthernet1/0/18
    !
    interface GigabitEthernet1/0/19
    !
    interface GigabitEthernet1/0/20
    !
    interface GigabitEthernet1/0/21
    !
    interface GigabitEthernet1/0/22
    !
    interface GigabitEthernet1/0/23
    !
    interface GigabitEthernet1/0/24
    !
    interface GigabitEthernet1/0/25
    !
    interface GigabitEthernet1/0/26
    !
    interface GigabitEthernet1/0/27
    !
    interface GigabitEthernet1/0/28
    switchport trunk encapsulation dot1q
    switchport trunk allowed vlan 13,857,1611
    switchport mode trunk
    bandwidth share SRR-queue 10 10 60 20
    form of bandwidth SRR-queue 10 0 0 0
    queue-series 2
    MLS qos trust cos
    Auto qos voip trust
    !
    RADIUS-server host 10.1.2.10 auth-port 1645 acct-port 1646
    Server RADIUS 7 key *.
    RADIUS vsa server send authentication
    end

    Hello

    authentication with PC and phone needs "multi-domain of authentication host mode. You con use MAC address or 802. 1 X (username & password) for authentication of IP phone.

    Profile authenticatipo must send "device-traffic-class = voice" to the switch. PC fits the DATA cross-domain and phone VOICE-field.

    See attachment:

  • BlackBerry 8120 BlackBerry Pearl Smartphones: is it possible to have different tones for messages and phone calls?

    Hey all.

    My dad just got a BlackBerry & would like to have a different tone to his alert message and phone calls.

    Is this possible?

    If so... do we do it?

    Thanks in advance.

    Oh Yes... your alerts, ringtones and notifications are very customizable.

    1. Select the profiles icon

    2. a box will appear where you can quickly choose between Loud, vibrate, quiet, normal, phone only, and outside. If you like quick-change device profiles and select the one you want and get out.

    3. If you want to change the tones assigned to the applications in the device, and then select the last option, advanced options
    (some older models and 'Advanced' OS 4.1 and below will not step - so advanced is not present go directly to step 4 below).

    4. Select the profile you want to change. (Loud, vibrate, quiet, Normal (default), phone only, Off)
    Note: on the 8100, 8800 and 8300 models: do not click on the trackball. Instead of this, click on the menu button to the left of the trackball).
    Note: The profile that is in use will tell: (active)

    5. you will now see a list of all applications that can have an assigned tone (browser, calendar, level 1 Messages, Messages ([email protected]), Messenger, MMS, phone, SMS, job ect..)

    6. Select the application you want to change the tone / notification for

    7. you can now edit the tones of the case and Holster / notifications.
    (a) select between: none, Tone, vibrate, vibrate + tone
    (b) select the range that you want to use
    (c) Select Volume (the options are mute, low, medium, high, climbing)
    (d) to select the number of beeps (the options are 1, 2, 3)
    (e) select Repeat Notification (options are None, flashing LED)
    (f) if value vibrator or vibrate + tone and select number of Vibrations (the options are 1, 2, 3)

    8. repeat a to e for each of the applications set out in number 5 above

  • tried to activate my windows 7 since the time that I change my motherboard trying online and phone how can I activate it

    been trying to activate my windows 7 since the time I change my card mother try online and phone when it comes to giving the confirmation ID it say due to an error could not proceed. When you try to install Windows 7 I enter my product key and get Windows error repeatedly warns me that my product is a counterfeit. I tried to activate Windows 7 online, only to be returned with the error Code how can I activate it now because I bought at a retail store and not had this problem then this started from the day my motherboard was cause of change that it was under warranty how to activate now.

    Have you tried to restart by phone?

    How to activate Windows 7 manually (activate by phone)
     
    1) click Start and in the search for box type: slui.exe 4
     
    (2) press the ENTER"" key.
     
    (3) select your "country" in the list.
     
    (4) choose the option "activate phone".
     
    (5) stay on the phone (do not select/press all options) and wait for a person to help you with the activation.
     
    (6) explain your problem clearly to the support person.
     
    http://support.Microsoft.com/kb/950929/en-us

  • BlackBerry smartphones, I have a flashing red light and phone does not illuminate

    I have a red flashing light and phone not turn on what do I do now...

    Yes, the Office Manager and BlackBerry Desktop software are the same.

    Restart your PC and you reconnect and try again the instructions.

  • What happened to the Office Tablet and phone buttons?

    What happens if I don't want to make a sensitive site?  The tablet of office and phone buttons disappeared (except on sites I've used on).  Not interested in learning how to use breakpoints until I complete my current project which has a time - help!

    Look in the menu "Page!

Maybe you are looking for

  • 189 45 Mbps Wireless and wired

    I have a Huawei recently installed (Optical Network Terminal). When my ISP technician moved, he received 191 Mbps and upload 19.50 Mbps, it worked well for two days... I have a Time Capsule 37 b for a Wi Fi network. And now 45Mbps wireless...   Wired

  • address bar is no longer work

    When I try to look for something in the main address bar I always the next come upwards with my entry at the end jar:file:///usr/lib/Firefox-3.6.13/extensions/[email protected]/firefox-3.6-en-GB.jar!/locale/browser-region/region.p

  • Satellite L650 - seeing WiFi is always enabled

    Hello I just bought a Toshiba satellite L650 and I realized that the WiFi led is always on (with orange) and I can't turn off the WiFi using the Fn + F8 combination. Can someone tell me if it is a software problem (I had to install all the drivers, b

  • MFP HP LaserJet Pro M126nw: Clarification of the use of HP Laser Jet MFP M126 nw Pro Page

    Hi support them. Recently, we bought a new HP Laserhet MFO M126nw Pro. The cartridge came with the new printer. I need a clarification of the HP Laserjet Pro MFP M126nw on the usage Page. We want to know how many pages that the printer has taken so f

  • problems with windows that open Download Manager home

    I have original (the new EA download manager) and since I downloaded it, I can't seem to open. I tried as admin. but it is not good. If anyone knows how to help, I'd appreciate it. Thank you.