How to stream data in series for a user specified using LabVIEW?

Hi all

I need to send data continuously using serial communication to the microcontroller for a user specified time... Any suggestions please?

And here's one that I like and is easy to modify.  You can copy the snippet directly in your block diagram:

http://forums.NI.com/T5/LabVIEW/reading-time-interval-of-serial-port/m-p/1529140#M568806

In the case where I did not provide this link, it has some interesting things...

http://forums.NI.com/T5/LabVIEW/change-baud-rate/m-p/276265#M146432

Tags: NI Software

Similar Questions

  • How can I block the SMTP for all users but mail server

    I can't understand (1) how can I refuse port 25 for all users on the network and allow for Exchange server SMTP, also I have MS Exchange, which manages the web and smtp and in my setup below you can see that there static mapping to publick ip with http/smtp only, then (2) how can we separate the traffic entering a publc IP will outside servers inside ex : (MSexchange public ip address is x.x.x.207-> http = 172.16.2.13, 172.16.2.14 = smtp)

    Thank you

    ___________________________________________________

    6.3 (1) version PIX

    interface ethernet0 car

    Auto interface ethernet1

    ethernet0 nameif outside security0

    nameif ethernet1 inside the security100

    names of

    name 172.16.4.10 pdc

    name 172.168.4.11 llc

    name 172.16.4.11 ftp

    object-group service E-mail tcp

    port-object eq www

    EQ smtp port object

    object-group service tcp - udp terminal

    3389 3389 port-object range

    object-group service mw tcp - udp

    Beach of port-object 367 367

    radmin tcp service object-group

    RemoteAdmin description

    4899 4899 object-port Beach

    object-group service mw1 tcp

    Beach of port-object 367 367

    access-list 101 tcp refuse any any eq smtp

    access-list 101 permit tcp any host object-group x.x.x.251 terminal

    access-list 101 permit tcp any host x.x.x.214 object-group radmin

    access-list 101 permit tcp any email host x.x.x.207 object-group

    access-list 101 permit tcp any host x.x.x.212 object-group mw1

    access-list 101 permit tcp any host x.x.x.211 eq ftp

    sheep ip access-list allow any 192.168.101.0 255.255.255.240

    IP address outside x.x.x.194 255.255.255.192

    IP address inside 172.16.2.1 255.255.0.0

    IP verify reverse path to the outside interface

    IP verify reverse path inside interface

    alarm action IP verification of information

    IP audit attack alarm drop action

    IP local pool mypool 192.168.101.1 - 192.168.101.20

    don't allow no history of pdm

    ARP timeout 14400

    Global interface 10 (external)

    NAT (inside) 0 access-list sheep

    NAT (inside) 10 0.0.0.0 0.0.0.0 0 0

    static (inside, outside) x.x.x.212 172.16.4.12 netmask 255.255.255.255 0 0

    static (inside, outside) x.x.x.251 172.16.4.51 netmask 255.255.255.255 0 0

    public static x.x.x.214 (Interior, exterior) pdc netmask 255.255.255.255 0 0

    public static x.x.x.211 (Interior, exterior) ftp netmask 255.255.255.255 0 0

    "REM # 172.16.2.13's Exchange with Outlook Web servers #

    static (inside, outside) x.x.x.207 172.16.2.13 netmask 255.255.255.255 0 0

    Access-group 101 in external interface

    Route outside 0.0.0.0 0.0.0.0 x.x.x.193 1

    enable floodguard

    Sysopt connection permit-pptp

    VPDN PPTP-VPDN-group accept dialin pptp

    VPDN group PPTP-VPDN-GROUP ppp authentication pap

    VPDN group PPTP-VPDN-GROUP ppp authentication chap

    VPDN group PPTP-VPDN-GROUP ppp mschap authentication

    VPDN group PPTP-VPDN-GROUP ppp encryption mppe 40

    VPDN group VPDN GROUP-PPTP client configuration address local mypool

    VPDN group VPDN GROUP-PPTP client configuration dns 172.16.2.6 172.16.4.6

    client PPTP-VPDN-GROUP VPDN group configuration wins nymc_pdc

    VPDN group VPDN GROUP-PPTP pptp echo 60

    VPDN group VPDN GROUP-PPTP client for local authentication

    VPDN username * password *.

    VPDN allow outside

    This is your problem:

    Access-group 101 in external interface

    You link this access list to your external interface. This means that the rules are applied to incoming traffic IN your network. The implicit IP any any rule is because you have not bound to an access list on your inside interface.

    To prevent users from going out, you will need this:

    access list permit tcp host exchange_IP OUTPUT no matter what eq smtp

    access list tcp OUTPUT deny any any eq smtp

    Access-group interface inside OUT

    See how this access list is linked to the inside interface... it will affect traffic leaving your network. Note: Once you apply this inside allow any interface it will remove the implicit.

  • How to set the default printer for the user in 11i

    How to set the default printer for the user in 11i, please let me know how to set the new printer to the user, its Linux OS EBS 11i.

    Please see these documents.

    How to install the default printer for a user. [153927.1 ID]
    How to set up a default printer for a user in Oracle Applications [ID 1018856.102]
    How to set a default printer? [1237254.1 ID]
    How to configure the default printer for Applications [ID 184109.1]

    Thank you
    Hussein

  • How can I connect from a PC to another PC using LabVIEW

    New IAM for LabVIEW and need help. How can I connect from a PC to another PC using LabVIEW. IE how to connect to the IP of the PC, another address using LabVIEW. Thanking you.

    There are a few methods of network communications in LabVIEW.

    Some of them, in no particular order:

    -Network shared Variables

    -Flow network

    -Screw HTTP and Web Services client

    -TCP

    -UDP

    (There are also libraries of pre-written e-mail based on UDP/TCP)

    Which the decision to go for depends on many factors (e.g. should you read the last value of variables, flow without any loss of data, data dissemination or send messages/packets of data, etc.). I suggest take you a look at some examples in the finder of the example (help-> find examples...). If you are really new to LabVIEW, I suggest you take some free LabVIEW tutorials - take a look at the links at the bottom of the first post in this thread.

  • Impossible to retrieve the password for the user FUSION_APPS_WSM_APPID using ldapsearch

    Dear all,

    I'm unable to retrieve the password for the user FUSION_APPS_WSM_APPID using the ldapsearch command

    Is the correct command extract the password for the user FUSION_APPS_WSM_APPID below?

    $ORACLE_HOME/bin/ldapsearch - h < hostname > Pei 3060 d 'cn = sleep '' w < password > base b s 'orclCSFKey = basic.credentials, cn = oracle.wsm.security, cn = CredentialStore, cn is FusionDomain, cn = JPSContext, cn is FAPolicies' objectclass = * orclcsfname orclcsfpassword

    Kindly help me in this problem.

    Kind regards

    Vinayak K

    Can you clarify why you need recover the password? Application identities are designed for internal processing and never to be exposed outdoors or used for other purposes only lift access to the code in some scenarios within the system. So only the administrator must have access to the account and the password of access they would reset it in the store of credentials if necessary. That said I think that the admin can retrieve the password using the command listCred wlst something like:

    listCred(map="oracle.wsm.security",key="FUSION_APPS_WSM_APPID-KEY")

    --

    Jani Rautiainen

    Relationship with the developers of Applications in fusion

    https://blogs.Oracle.com/fadevrel/

  • How to find dates of purchase for Portege R200?

    We currently start laptop computer ownership with our machines Portege R200 and need to know the dates of purchase for these. We have our serial numbers and we owe it to the place where or what website to go to type the serial number and to know the purchase date of the machine with this serial number. How is that possible?
    Please email [email protected] with any help. Thank you!

    Hello

    I think that this can be managed by the Service of Toshiba partner.
    If the user has saved the unit so usually the service partner should be able to verify the date of purchase.

  • How to write data I read frequency bands in excellent using the tools for the generation of reports.

    Hi all

    I wrote the code to read data from the Analyzer of spectrum and also for writing in excel using report generation tools. When I run the program values get read and excellent sheet also opens but I don't see anything written in.

    So if anyone can help me in that I'm very gald. I am attaching the screenshot of my program and also attach file .vi. As I use the drivers you can see some of vi.

    Thanking you,

    Patricia

    @tobid,

    Thank you and sorry long back only I got my error and its job well now... again thanks and sorry that I have not mentioned here...

    Patricia

  • How to send data from the client to the server using tcp

    1. as I am new to watch I need help with sending data from client to server. I went through various examples of labview, but each of them also explains transfer of data to the client server. But I need help regardng send data from the server to the client.

    2.i would use the data type variant for sending my data.

    Can someone help me please. Thank you

    Regardless of the meaning. Once you have a connection each end allows it to send data to another. Just create what you want to look like interaction.

    Do you want the client sends a command that request data?
    How do you think the response data to look like?

    You can send variants, but probably not worth the effort.

    Mike...

  • How to import data in Excel sheet to the database using ADF BC

    Hello

    Can someone help me in suggesting how to import data from excel to database.

    Thank you

    Kunal Sharma

    Hello

    You can use the API to read each line of the file excel with your application and the creation of lines for each line that you read.

    See link

    http://www.codejava.NET/coding/how-to-read-Excel-files-in-Java-using-Apache-POI

  • How to put a common page for all users after loging on?

    Hi all
    "My dashboard" is now the default page after logon.
    I want to put a home page by default for all users. users can see the homepage after loging on.

    How to change the default dashboard "My dashboard" to the "Home page" for all users?

    Thank you
    Dan

    Hello

    Steps to follow:

    Tried to put the default dashboard for all users.
    1. creates a session init block
    "2 source of data used in select ' / shared/SH Test / _portal / Test1" double
    3. This value assigned to the variable of session CHEMINPORTAIL
    4. in presentation services > Administration > my account > default dashboard must be set to "default". Then only the dashboard specified in block init will appear otherwise my account will override the init block.
    5. save the changes to the RPD.
    5 disconnect and reconnect to see if it works well. It works perfectly fine.

    For more details, please see the document of CSG replication. But this is for all users.

    If the customer wishes to have a user/group basis homepage.
    1. they should have 2 separate tables.
    i. Group_path_tab with 2 columns. Group_id, portal_path
    Wise group path portal for all groups
    II. user map table group
    Group_id, groupname, user_id

    The user should be part of a group.

    2. then in the writing init bulk sql must be something like this

    Select A.portal_path in the Group_path_tab A, User_group_map B
    where = B.user_id: USER
    and B.Group_id = A.Group_id

    SO, based on the USER session variable, it will try to identify the group, and then the portal_path.
    Finally, set this value to the session CHEMINPORTAIL variable.

    Ref:
    http://total-bi.com/2011/01/OBIEE-11g-change-default-dashboard/
    Thank you!

  • How can I create a series of blocks of text using the Excel list values?

    It is first of all, the first script I am trying to write from scratch. I'm completely green at the script and I picked up a few bits of ID Adobe scripting guide, but nothing has really stuck still relating to this particular goal.

    My supervisor maintains a master list of advertising space, with the name of the account, is the width of the space, and how space is the height, in an Excel sheet. These spaces can number in the hundreds, and I'm stuck manually drawing a rectangle for each space, which takes a lot of time.

    I would like to create / helped to create a script that will take these values and "magically" to draw these spaces in the form of blocks of text, with the width (in columns) and the height (in inches) defined by the values in the main list, as well as the name of each account in the subsequent text frames.

    The script didn't necessarily need to be able to pull the values directly from the Excel sheet; Can I transfer a file text if necessary, or directly in the script, values he change because I need it. A great thing (if she is not able to pull directly from an Excel sheet) which is the number of spaces a week changes, and so do the accounts and the width and height. Accordingly, it would be ideal that values of the sheet could be modified easily, in order to create a new set of spaces as necessary.

    Positioning for each space is not crucial, only the height and width. If they were all on top of each other on the same page, it is a result for me. The main idea is to not have to draw them all manually, one by one.

    For me, this looks like a command, but I hope that some experienced there Scripting Guys can help me, because I want to become experienced as well.

    Thus, the TL; DR version:

    -Script to draw a series of text blocks.

    -Size of the text boxes should be defined by the values width and height of spreadsheet Excel.

    -Text blocks must have the account name as content (from account in the Excel worksheet names).

    -Accounts, width and height changes every week in the Excel sheet, so must be relatively easy to exchange all values.

    -Width values on the Excel worksheet columns. It would be ideal that the script could turn those numbers into multiples of columns as necessary.

    -Script (optionally) can take values directly from Excel sheet.

    -Script (option) can set the fill color for the gray text frame. (If it works as I think, I could just select all the resulting images of the text myself and put them all to grey at the same time... I'm not lazy as )

    Thanks in advance to anyone who can help in any way possible, even if it's just a little push in the right direction. This script will save 1 to 2 hours of boredom every week.

    Look like the perfect thing for the InDesign scripting.

    I copy content from Excel to a text file, for a format easily read in InDesign, and there will automatically be a TAB for each 'cell', just using copy and paste.

    Here is a piece of code, perhaps you could go on with (the addition of variable to change pages and the location on the page and other things).

    The readFileLineByLine function, can be easily reused with any function using "recall". You simply tell the function what you want to be executed for each line of text that reads:

    const COLUMN_WIDTH = 2; // Define the column width in inch
    
    var pageIndex;
    var textFramesExported; // not implemented.
    
    // Add a new dokument. Set myDoc to app.activeDocument to use
    // the current document instead of creating a new one.
    var myDoc = app.documents.add();
    
    // The doSomethingWithTextRow function is called upon for every line of text read.
    readFileLineByLine('c:\\test.txt', doSomethingWithTextRow);
    
    function doSomethingWithTextRow(row){
        // We expect the text line to be TAB separated (\t = TAB). We get that from just copying the contents of an
        // excel file into a text document.
        var cells = row.split('\t');
        var companyName = cells[0]; // The Company name in the first slot of the array
        var width = COLUMN_WIDTH * cells[1];
        var height = cells[2];
    
        // Create a new text frame for every row handled
        if (pageIndex==undefined) pageIndex = 0; // Count up when you have exported a number of texts, I leave this for you to do.
        var newTextFrame = myDoc.pages[pageIndex].textFrames.add();
        newTextFrame.contents = companyName;
    
        // The text frame is created in the top left corner.
        newTextFrame.geometricBounds = [0, 0, height + ' in', width + ' in']; // Top, Left, Bottom, Right 
    
        // You might want to move the textframes to other positions, keeping track of how many you put out per page.
        newTextFrame.move( [10, 10] );
    }
    
    function readFileLineByLine(path, callbackFn){
        var myFileIn = new File(path);
        if (File.fs == 'Windows'){
            // This was probably added to recognize UTF-8 (even without its start marker?)
            myFileIn.encoding = 'UTF-8';
        }
        myFileIn.open('r');
        var myEncoding = myFileIn.encoding;
        try{
            if (!myFileIn.exists){
                throw('Missing file: ' + myFileIn.fsName)
            }
            var ln = '';
            while(!myFileIn.eof){
                // Read the lines from the file, until an empty line is found [now as a remark].
                ln = myFileIn.readln()
                // if(ln !='' && ln!='\n'){
                   // Call the function supplied as argument
                   callbackFn(ln);
                // }
            }
        }catch(e){
            alert(e);
            gCancel = true;
        }
        finally{
            myFileIn.close();
        }
    }
    

    The file in C:\ in my example was recorded in UTF-8 format and looks like this (showing hidden characters):

    Post edited by: Andreas Jansson

  • How to transfer data from oracle to the web service using ODI with axis2 tech

    Hi all

    Can someone cause a document or markets about 'How to transfer data from oracle to the web service with the help of ODI with AXIS2 technology'
    If any person with a document or markets, please share it with me

    Thank you
    Phani

    I can give you a few examples of web services in ODI, perhaps that you find them useful?
    Try: -.
    http://John-Goodwin.blogspot.com/2009/04/ODI-series-Web-services.html
    http://John-Goodwin.blogspot.com/2009/05/ODI-series-Web-services-part-3.html
    http://John-Goodwin.blogspot.com/2009/05/ODI-series-Web-services-part-4.html

    See you soon

    John
    http://John-Goodwin.blogspot.com/

  • How gray on Intel Graphic Media for local users?

    does anyone know how to gray on the options to prevent users, change the graphics options from Intel graphics media for Mobile?
    So if anyone knows what's different in the BIOS updates, any possibility to cancel boot devices (not only change the order)

    Hello

    You can create a limited user account, but I n t think that this option disables the function to change the graphics options.

  • How to register ActiveX exe server for all users

    Hello

    I'm aware that with newer versions of the CVI and Windows when you generate an ActiveX exe server, it records only the server for the user profile.  I read one white papers OR who said that computer administrator may register the server for all users.  I am an administrator for the development of PC we use.  I went to the command and he ran as the administrator of the PC.  I then navigate to the path of the exe.  I published the regserver command.  Unfortunately, I am unable to distinguish if the server exe was registered for all users or if it combined again to my user profile.  Our server exe is called by another program of the CVI.  To validate if the server exe had been registered for all users, I had a user who had not built server exe on the development PC connection and try to start the server within its own CVI program exe.  When this has been attempted, the user receives an error "class not registered".  The user was not able to successfully launch the exe of the server until it has built on the PC itself.  It does not appear that the administrator regserver command worked to save the exe file of the server for all users.  Is anyone aware of any steps that I may have missed?

    I'm working on a Windows 7 with Service Pack 2 for LabWindows/CVI 2013.

    Thanks in advance.

    You will probably have to use Google.

    http://social.msdn.Microsoft.com/forums/en-us/0022ca21-CAA2-4be5-b519-757ff9daf7fb/how-to-register-3...

    or maybe http://social.msdn.microsoft.com/Forums/vstudio/en-US/4fb96971-53a1-4e25-bc75-b49cfaf4d574/problems-...

  • How to read the data from a channel named in windows using labview

    Hello

    I need to read the channel named in windows data. The pipe is created by python by another application. This application post permanent data on the pipe. But I don't know how to read data using labview. is it possible to read the data from different application? If possible, how to start?

    Thanks in advance

    concerning

    RJ

    Hi Rolf,.

    It's just, because of driving is not initialized completely, pipe read returns error 42, I added 2 seconds late, then its work perfect.

    Thank you very much.

    Concerning

    RJ

Maybe you are looking for