Working with tags Batch PowerCLI

I recently started in a new position and began working on cleaning things up in the VMWare environment. A bit of history, we are a hosting company that hosts virtual machines for various Auto factory. We currently have about 1400 VMs. One of the things I wanted to do is to add tags to all of our virtual machines, so we can better organize our virtual machines.

The purpose of this code is to apply tags in a CSV master in the VMWare environment.

The current challenges, I am confronted with are:

-The tags that currently exist, but is incorrect not updated

-I can't seem to find a clean way to check if a tag is already applied to a virtual machine and if so go try to apply it.

I'm trying to make possible more flexible code by calling don't no categories to tag explicitly, so if one category is added in the future, the code does not need to be re-written.

The WB currently has 4 columns (name, customer, environment, project)

Here is the code, any suggestions would be greatly appreciated.

# Connect-viserver [email protected] user-pass Pa$ $w0rd

$VMWareInfo = import-CSV C:\Temp\VMWareInfo.csv

# Get the header names to use as the category of tag names

$TagCatNames = $VMWareInfo | Get-Member. Where {$_.} MemberType - eq "NoteProperty"} | Select - expand name | Sort-Object

$TagCatNames = $TagCatNames.trim)

# Get the tags currently assigned for virtual machines

$CurrentTagAssignment = get-Tagassignment | Select the entity tag

# Create the tag category if it does not exist

Foreach ($CatName in ($TagCatNames |)) Where {$_ - don't 'name'})) {}

If (Get-TagCategory $CatName) {Write-Host "Category" $CatName "exists, jump..."} »}

If (-not (Get-TagCategory $CatName - ea SilentlyContinue)) {}

Write-Host 'create Category $CatName tag '.

New-TagCategory-name $CatName - Description "$CatName via host naming Convention.

}

}

# Create tags in the tag categories

Foreach ($CatName in ($TagCatNames |)) Where {$_ - don't 'name'})) {}

$Uniquetags = $VMWareInfo | Select - enlarge $CatName.Trim () | Tri-objet-Unique

#Assign tags for categories

{Foreach ($TagName in $UniqueTags)

#Error looking for empty tags, or null

If ($TagName - eq ""-or $null) {Write-Host "entry blank:"$CatName '«» $TagName' $TagName '}

#Adding New tags to each category

Else if (-not (Get-Tag-category $Catname - name $TagName - ea SilentlyContinue)) {}

Write-Host "create a new Tag under $TagName $CatName.

-Tag - new name $TagName - category $CatName - Description "$TagName via host naming Convention.

}

#Skip added if the tag already exists in category

ElseIf (Get-Tag-category $CatName - name $TagName) {Write-Host "input tag already Exists:"$CatName '«» $tagName' $tagName '}

}

Tags #Assigning to host VMs

$VMwareinfo | Where {$_.} (() $Name) - eq $TagName} | {Foreach}

#Error looking for empty tags, or null

If ($Name - eq ""-or $null) {Write-Host "White name"}

ElseIf ($TagName - eq ""-or $null) {Write-Host "Empty tag to" $($_.)} Name)}

else {Write-Host "... $TagName yielding in the category of the $CatName $ ($_.)"} (Name) ".

$TagAssignment = get-Tag-category $Name - name $TagName

New-TagAssignment-entity $($_.) The name) - Tag $Tagassignment | out-null

}

}

}

}

so after a lot of fussing and fighting, I finally managed to get the tags working. It is not the cleanest script, but it works. so, in the effort to make sure that everyone in the same situation that I can actually find an answer here is the script.

The entry only this file is CSV file that is in the format

VMName | Category 1 | Category 2 | Category 3 | Category 4 |

---------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------

# Connect-viserver [email protected] user-pass Pa$ $w0rd

# Import CSV of Tags VM (in the format VMName, Tag, Tag, Tag, etc. with headers of columns for categories of the tag)

Write-host "Import CSV File now... »

$VMWareInfo = import-CSV C:\Temp\VMWareInfo.csv

# Collect all VMs in vCenter to find those missing tags

Write-Host "gathering all virtual machines.

$AllVMs = get - VM | Select name. name sort

# Get the header names to use as the category of tag names

Write-Host "Gathering Tag categories"

$TagCatNames = $VMWareInfo | Get-Member. Where {$_.} MemberType - eq "NoteProperty"} | Select - expand name | Sort-Object

$TagCatNames = $TagCatNames.trim)

# Get the tags currently assigned for virtual machines

Write-Host "Gathering current VM Tag Information"

$CurrentTagAssignment = get-Tagassignment | Select the entity tag | Tri-objet entity

# Create the tag category if it does not exist

Foreach ($CatName in ($TagCatNames |)) Where {$_ - don't 'name'})) {}

If (Get-TagCategory $CatName) {Write-Host "Category" $CatName "exists, jump..."} »}

If (-not (Get-TagCategory $CatName - ea SilentlyContinue)) {}

Write-Host 'create Category $CatName tag '.

New-TagCategory-name $CatName - Description "$CatName via host naming Convention.

}

}

# Create tags in the tag categories

Foreach ($CatName in ($TagCatNames |)) Where {$_ - don't 'name'})) {}

$Uniquetags = $VMWareInfo | Select - enlarge $CatName.Trim () | Tri-objet-Unique

# Assign tags to categories

{Foreach ($TagName in $UniqueTags)

# Null or empty tags check error

If ($TagName - eq ""-or $null) {}

Write-Host "entry in white:" $CatName "«»" $TagName} "."

# Added new tags to each category

Else if (-not (Get-Tag-category $Catname - name $TagName - ea SilentlyContinue)) {}

Write-Host "create a new Tag under $TagName $CatName.

-Tag - new name $TagName - category $CatName - Description "$TagName via host naming Convention.

}

# Skip adding if the tag already exists in category

ElseIf (Get-Tag-category $CatName - name $TagName) {Write-Host "input tag already Exists:"$CatName "'«» $tagName «Sauter... $tagName"jump... "} »

}

}

}

# Control tags against tags currently entered

# Control against each category

Foreach ($CatName in ($TagCatNames |)) Where {$_ - don't 'name'})) {}

# Creation of tag to check for the current category list

$Uniquetags = $VMWareInfo | Select - enlarge $CatName.Trim () | where {$_-notlike $null} | Tri-objet-Unique

# Add line for empty entries

$Uniquetags += «»

# Check each tag

{foreach ($TagName in $uniquetags)

Write-Host "working on" $CatName "/" $TagName

# List all virtual machines with the currently selected tag

$VMList = $VMwareinfo | Where {$_.} (() $CatName) - eq $TagName}

{foreach ($VMName to $VMList)

# Find all the virtual machines that the current tag applies to

$CurrentVMTags = $CurrentTagassignment | Select entity, tag | where {$_ .entity - like $- VMName.name and _.tag $.} Category-as $CatName}

# If the tag is blank on the worksheet

If ($VMName. $CatName - like ""-or $VMName.) $CatName - as $null) {}

# Check to see if the is empty on the virtual machine

If ($CurrentVMTags - like ' "- or $CurrentVMTags - eq $null) {}

Write-Host 'Entry blank for the category' $CatName 'on VM' $VMName.name 'ignorant '.

}

# If the tag was written by mistake to vCenter

ElseIf ($CurrentVMTags-notlike ' "- or $CurrentVMTags - notlike $null) {}

Write-Host "Tag erroniously wrote to VM" $VMName.Name "Removing entry incorrect".

Get-TagAssignment-$VMName.Name entity-category $CatName | Delete-Tagassignment-confirm: $false

}

}

# If a tag already exists in vCenter

If (($CurrentVMTags-ne ""-ou $CurrentVMTags-ne $null) - and ($VMName.) $catname - don't ' "- or $VMname.catname - not $null)) {}

# Do not tag if it is already

If (($currentVMTags.Tag.Category-comme $catname-et $CurrentVMTags.Tag.name-aime $VMname. $catname) - or ($vmname. $catname - like ' "-or $vmname. $catname - as $null)) {}

Write-Host "Writing the Tag" $CurrentVMTags.Tag "Matches" $CatName "/" $TagName for $Vmname.name "entry...". »

}

# Tag re - write if she does not

ElseIf ($CurrentVMTags.Tag.name-$VMname notlike. $catname - and $currentVMTags.tag.name - not $null - and $VMname. $canname - not $null) {}

Write-Host 'Put-Match for the Tag' $VMname.Name "Tags to write" $CatName "/" $TagName $CurrentVMTags.tag.Category"/"$CurrentVMTags.tag.name "writing the tag".

Write-Host 'Removing the old tag' $CurrentVMTags.tag.Category"/"$CurrentVMTags.tag.name

Get-TagAssignment-$VMName.Name entity-category $CatName | Delete-Tagassignment-confirm: $false

Write-Host 'Add new Tag' $CatName ' / ' $TagName 'to VM"$VMName.Name

New-TagAssignment-$VMName.Name entity-Tag $TagName

}

}

# If the tag does not exist, if the virtual machine has no tag or that there is no

If (($CurrentVMTags-like ""-ou $CurrentVMTags-eq $null) - and ($Vmname.) $catname-notlike ' "-or $VMname. $catname - notlike $Null)) {}

$VMExist = $AllVMs | where {$_ .name - like $VMName.Name} | Measure

# If the virtual machine no longer exists in vSphere

If ($VMExist.count - eq 0) {}

$VMName.Name Write-Host 'not found in vCenter. "Please remove the spreadsheet.

}

# If the virtual machine exists, but has no assigned tags

} ElseIf ($VMExist.count - eq. 1)

Write-Host 'VM Tag' $CatName ' / ' $Tagname ' missing from ' $VMName.name 'now add... '. »

New-TagAssignment-$VMName.Name entity-Tag $TagName

}

# If there are multiple virtual machines with the same name in vSphere

ElseIf ($VMExist.Count - gt 1) {}

Write-Host "multiple virtual machines with the same name exists. Is' $VMName.Name 'a model '?

}

}

}

}

}

Tags: VMware

Similar Questions

  • Work with metadata vCloud in PowerCLI

    Based on the post of Jake Robinson to GeekAfterFive - Infrastructure as a Code, it seems that the sample scripts in Alan Renoufof March 30, 2012 post on the Blog of VMware PowerCLI, working with metadata in PowerCLI vCloud, won't work with vCloud Director 5.1. Nobody has changed the Get-CIMetaData function to return the value of the TypedValue element? After removing the Select-Object cmdlet (to select all the properties and see what is returned):

    PS > Get-Org-name CloudSandbox | Get-CIVM | Get-CIMetaData

    Domain: VMware.VimAutomation.Cloud.Views.MetadataDomainTag

    Key: Test key

    Value:

    TypedValue: VMware.VimAutomation.Cloud.Views.MetadataStringValue

    Client: VMware.VimAutomation.Cloud.Views.CloudClient

    HREF: [removed]/metadata/SYSTEM/Test%20Key

    Type: application/vnd.vmware.vcloud.metadata.value+xml

    Link            : {, , }

    Get_anyattr:

    VCloudExtension:

    The type of the value is provided (MetadataStringValue), but so far I could not get the value of TypedValue element. What Miss me?

    After walking away from it for a bit, I realized that a simple update to the process of the Alan code block would get me what I'm after:

    {In process

    {Foreach ($Object in $CIObject)

    If {($Key)

    ($Object.ExtensionData.GetMetadata ()). MetadataEntry | Where {$_.} Key - eq $key} | Select @{N = "CIObject"; {E = {$Object.Name}}, ExpandProperty - TypedValue of key

    } Else {}

    ($Object.ExtensionData.GetMetadata ()). MetadataEntry | Select @{N = "CIObject"; {E = {$Object.Name}}, ExpandProperty - TypedValue of key

    }

    }

  • Work with multiple vCenter servers in PowerCLI

    VI the value of multiple server mode:

    Game-PowerCLIConfiguration - multiple DefaultVIServerMode - confirm: $false

    Connect to two servers vCenter:

    SE connect-VIServer-Server vc1, vc2-userid of the user

    Find the cluster and do not specify a VC:

    Get-Data Center-Cluster clusterA

    Cluster data center is displayed correctly:

    name of the data center in VC1

    name of the data center by VC2

    Try to specify what VC of query:

    Get-Data Center-Cluster cluster - server VC2

    the names of three data centers are returned which makes no sense (only one contains the cluster)

    Trying to figure out how better to work with the simultaneous connections of VC in a script and dictate what VC I want to execute a command against rather than disconnect and reconnect etc.

    I think there could be a problem with the cmdlet.

    You are using PowerCLI 5.5 R2 I guess?

    When you try like this

    Get-Data Center-Cluster (Cluster-Get-name ClusterA-Server VC1)

    is it returns 1 datacenter or 2?

  • clientListener does not work with my rich input Custom tag

    Hello

    clientListener does not work with my rich input Custom tag

    I have a custom tag myInputText and here are some details abt it...

    MyInputText extension of RichInputText
    MyInputTextTag extension UnifiedInputTextTag (Tag Handler)
    AjaxTextFieldRenderer extension SimpleInputTextRenderer (for purposes of rendering)

    So, when I use

    < mc:myInoutText id = 'test100' >
    < af:clientListener method = "clientMethodCall" type = "keyUp" / >
    < / mc:myInoutText >

    < af:inputText id = "test101" label = "test101Label" >
    < af:clientListener method = "clientMethodCall" type = "keyUp" / >
    < / af:inputText >

    in my page and run the clientMethodCall page is called for test101 but NOT for test100.

    Don't know why,
    Could someone help me please...

    Thank you
    Murali

    Hello

    I still think you're missing one rendering engine, else your rendering engine would not be called, because it must be returned by a method protected createFormInputRenderer (FacesBean.Type type) FormInputRenderer.

    In addition, renderScript does exactly? Its positioning can be really messy in this case since the element root dom was not yet written in the Responsewriter and can also be dangerous in a PPR request (if not more). The correct way to do this would be to create a custom JavaScript counterpart and place the code in the InitDomElement function.

    Kind regards

    ~ Simon

  • HyperSnap Textsnap works with Firefox 3.6.12 but not the latest version: ideas?

    Under XP Pro sp3. TextSnap has worked with almost all of the screens presented by Firefox 3.6.12 - what is telling, not pdf - but upgrading to the latest version of Firefox has left Textsnap almost totally disabled. So how is different from the presentation of text/display again Firefox, and is there a workaround?
    Thank you

    Hello, cor - El thanks for your response. Unfortunately, she does not - but I have marked your answer 'useful', because even if an idea doesn't work, it is always useful!
    Thank you. HR

    And I just saw that your response to mark as 'useful' automatically tag the problem as "resolved" - even if there is another "fact that solves... button". " I'll know next time.

  • R7000-can not get to work with iptv

    Hi, I have problems to make my r7000 working with plusnets iptv... Recently signed to it and they sent me their shitty router that feeds their iptv perfectly but I can't figure out how to get the nighthawk for this...

    Current firmware 1.0.4.30. in advanced settings, there is an option allowing to the VLAN / bridge I had some success using: iptv works for a bit, but not internet traffic outside of iptv is passed to the youview box - so can't watch netflix etc. It stops also work after I have change the channel so it does not seem in any case the right fix

    PlusNet cannot provide me details for tag vlan, so don't know not where to go from there... every time I have activate the Internet is not just connect - tried VLAN 10, 101, 301 and the thing that I could think of...

    I read that there is an option to enable the VLAN / IPTV on some firmwares, but I don't see "enable VLAN / Bridge" on mine.
    This feature is still supported on the R7000? or would be running DD - WRT work?
    I hope someone can help
    Thank you

    bill1228 wrote:
    Cannot talk about DD - WRT and IPTV, but later XVortex firmware supports IPTV and is made to work. Of course, there is the matter of that will work with your provider?
    Link to this info:
    http://www.linksysinfo.org/index.php?threads/asuswrt-Merlin-on-NETGEAR-r7000.71108/page-11#post-2636...

    Link to the news of the firmware:
    http://www.linksysinfo.org/index.php?threads/asuswrt-Merlin-on-NETGEAR-r7000.71108/

    Works fine on my r7000.
    -Bill

    And we have a solution! Flashed the CFW, a quick reboot of the router, and a bit of higgery pokery - work with enabled IPTV YouView.

    Here's a note in case others run into this forum and fall into the same obstacle. These are the settings you need once you have flashed the CFW:

    You must configure 'Enable VPN + connection DHCP' to 'No' to the terms of the WAN option.

    Parameters used were:

    -Have the router to the latest firmware: 3.0.0.4.374.130

    -Use the following settings in the LAN > IPTV:

    -"Select the ISP profile" = None

    'Choose the Port STB IPTV' = None

    -"Use DHCP routes" = Microsoft

    -"Enable routing multicast (IGMP Proxy) = enable".

    'Enable the effective transfer of multicast (IGMP Snooping) = enable ".

    -' UDB Proxy (Udpxy) = 0

    I hope this proves use for others in the future and thank you for all your help.

  • Photoshop Elements is able to work with 100,000 photos? Or Lightroom is better?

    Photoshop Elements is able to work with 100,000 photos? Or Lightroom is better?

    Lightroom is better. The most powerful over the catalogue, research capacity becomes. Import of batches can be quickly analyzed by using the pick and reject flags and photos can be marked with color labels, but also stars; or copy names that can be assigned to virtual copies. Best of all, presets can be applied in bulk lots of selected images and a good range of plug-ins are available, including publishing services like Flickr, Smugmug and others.

  • Using ss12 on WIN10 just bought the new camera (7DM 2). The first does not work with my new camera. How can I update / install my brute last version (9.2 or at least 8.7)?

    Read most of the articles on raw on the website but can not find how to download and update my raw ss12 file. Website says 8.7 or later includes Canon 7DM 2. Anyone have any suggestions?

    GL2U wrote:

    Read most of the articles on raw on the website but can not find how to download and update my raw ss12 file. Website says 8.7 or later includes Canon 7DM 2. Anyone have any suggestions?

    If you've read this faq:

    FAQ: Photoshop Elements will work with my camera, or why does not open my raw files?

    You cannot switch to more than 8.5 ACR PSE12.

    As explained in this faq, if you do not upgrade to the current PSE14, your free choice is to download DNGconverter Adobe. This allows independent software you batch convert a whole folder of your raw files to DNG format raw that your PSE12 can read and modify.

  • VMnet bridge cannot not labeled past 1500 byte frames (1504 bytes with tag) - is there a solution?

    Hello

    I set up a Windows 7 with VMware Workstation 10 host.  I am running 3 guests: 2 Linux and Windows XP 1.  These individuals are bound by local network segments.  A Linux host (let's call it 'A') brudges network interface 1 to an Ethernet USB adapter attached to the host.

    The other invited Linux (let's call it 'B') bridges 4 network interfaces on the host of Win 7.  I do this Setup VLAN b (eth2.30, eth2.60, eth2.29, eth2.220) and bypass eth2 interface integrated on the host of Win 7.  I had to create a registry entry "MonitorMode" (http://www.intel.com/support/network/sb/CS-005897.htm) on the Windows 7 host in order to move the frames marked between the guest and the outside world (Win 7 strips incoming tags by default).  NIC integrated on the Win 7 host is connected to a Cisco switch as a 802. 1 q trunk.  Other hosts are connected to the switch via these VLANs on the trunk.  Applications on these hosts communicate with guests on the host of Win 7 on the VLAN, it is necessary.

    It works fine until I have try to get through the VMnet bridge frames that have an MTU greater than 1496.  These frameworks are interrupted whehter they are incoming or outgoing.  I suspect that the reason is an acceptable framework normally 1500 bytes is, when the tag, 1504 bytes and is therefore stripped on the VMNet bridge.  I tried to adjust the MTU on the NIC host and eth2 comments to 1496 and 1504.  No effect, as I expected.  Packet Capture one side of the bridge as these large frames MTU vmnet show are ignored at the bridge.

    I have control over some of the external systems (and of course all the guests) and I adjusted the MTU on these systems at 1496 bytes.  This works very well for these systems.  But for traffic from external guests that I can't change it, 1500 (1504 with tag) frames is ignored at the vmnet bridge.

    I have read that I need jumbo frames support so that it works.  I found documentation indicating extended frames are not supported in workstation 7.  I guess that has not changed in 10 WS.

    I tried an alternative approach: Create VLANs on the host of Win 7 using Intel PROset, remove the VLAN eth2 the Linux prompt and instead create multiple virtual NICs (eth2, 3, 4, 5) and fill each virtual NETWORK adapter to a host of Win 7 VLAN.  Although VMWare network Editor allows me to create these bridges, I can't pass any traffic through them regardless of the MTU.

    So, my questions:

    (1) are extended frames supported in 10 Workstation?  If so, how can I activate them?

    (2) I would be able to bridge a guest virtual NETWORK adapter to a VIRTUAL host LAN interface?

    (3) is there another way to do this?

    Thank you and best regards,

    Steve

    Solved!

    The other approach, I described in the previous post (creation of VLANs on the host of Win 7 using Intel PROset, remove the VLAN eth2 the Linux prompt and instead create multiple virtual NICs (eth2, 3, 4, 5) and fill each virtual NETWORK adapter to a host of Win 7 VLAN) works if I REMOVE the setting of registry MonitorMode I also described in the previous post.

    Wireshark showed that with the Win 7 host VLAN enabled and the value of MonitorMode tags VLAN were being stripped.  Eliminating MonitorMode allows the NIC to tag/UNTAG as needed by the configuration of VLAN PROset.  Since the frames are not marked as they are bridge to/from the comments, all the interfaces of my spend management full size in both feel.

  • I work with a third-party provider that adds agricultural markets that will update every 10 minutes on my site of muse. I'm a designer by trade, and they are the html code. They have problems with my original design elements being pushed around when they

    I work with a third-party provider that adds agricultural markets that will update every 10 minutes on my site of muse. I'm a designer by trade, and they are the html code. They have problems with my original design elements being pushed around when they add the js include. They recommend at this time that I use another program like Wordpress, but I won't do that, because a large part of the site is designed and just add the markets. Here is the link to the site. At this point, the home page is the question. I can also provide a screen shot of how markets are supposed to look like

    This part does not seem too difficult.

    I bet they are now trying to "knit" their share of data right in your Muse- generated page, and they tell you that your code is terrible (and their smells like daisies). The usual clash...

    But it might be easier for you (and many others) if they offer their content as a separate page of small, so you can incorporate it as an iframe tag in an HTML object in Muse. No matter what code for permission to host the iframe, could be inserted as a simple script in Panel of Options of Page of Muse.

  • Work with items from ExtendScript

    Hello!

    I have a few questions about working with elements form ExtendScript via API FM.

    (1) how to assign a value to text in an element?

    (2) can I insert a new element to an existing element? If it is possible then what objects or functions should be used for this? They write in a reference that the object of the element has the Delete() method, but I did not find the method Insert() or anything resembling it.

    Thank you!

    Michael,

    These samples do not contain specific examples for what you want to do. To complete, here's a function that inserts a new element and adds text. The arguments are:

    doc (object) - a document object is valid.

    parentElem (object) - the element where you want to insert the new item. The new item is inserted at the beginning.

    newElemTag (String) is the tag for the new item.

    newElemText (String) = the text for the new item.

    Note that:

    -This function has no control of errors, which would be a good idea for a more robust script.

    -When adding items and inserting text, you deal with text and item locations. These can be complex for a beginner to understand.

    Russ

    function insertElementAndAddText(doc, parentElem, newElemTag, newElemText)
    {
        //Get the element definition from the EDD for a 

    element. var elementDef = doc.GetNamedElementDef(newElemTag); //Set up the element location for the insertion... //the beginning of the current element branch. var elementLoc = new ElementLoc(); elementLoc.parent = parentElem; elementLoc.child = parentElem.FirstChildElement; elementLoc.offset = 0; //Insert the new element var newElem = elementDef.NewElementInHierarchy(elementLoc); //Adjust the element location to be at the beginning of the //new element branch elementLoc.parent = newElem; elementLoc.child = newElem.FirstChildElement; elementLoc.offset = 0; //Set up the text location required to add the text, then add it. textLoc = doc.ElementLocToTextLoc(elementLoc); doc.AddText(textLoc, newElemText); }

  • Safe on Etherchanel / 802.3ad, it works with vmware esx?

    Trunk etherchanel in cisco switch configuration, it works with vmware esx?

    Configuration of the Cisco switch like that (I don't have a switch, can not test it):

    src-dst-ip port-channel load-balance
    the interface vlan 4094
    no ip address
    Interface Port - Channel 1
    switchport
    switchport mode trunk
    switchport trunk encapsulation dot1q
    switchport trunk allowed all the VLANs
    switchport trunk vlan 4094 native
    no ip address
    interface GigabitEthernet1/1
    switchport
    switchport mode trunk
    switchport trunk encapsulation dot1q
    switchport trunk allowed all the VLANs
    switchport trunk vlan 4094 native
    no ip address
    Chanel-Group 1 mode on
    interface GigabitEthernet1/2
    switchport
    switchport mode trunk
    switchport trunk encapsulation dot1q
    switchport trunk allowed all the VLANs
    switchport trunk vlan 4094 native
    no ip address
    Chanel-Group 1 mode on
    end

    What you have should work OK, because it is not too different from the example of work from my lab:

    ocs4948-1 #sh int item in gi1/2nd round

    Building configuration...

    Current configuration: 536 bytes
    !
    interface GigabitEthernet1/2
    switchport trunk encapsulation dot1q
    switchport trunk allowed vlan 2.10
    switchport mode trunk
    MTU 9198
    channel-group 64 mode on
    spanning tree portfast
    spanning tree enable bpduguard
    end

    ocs4948-1 #sh run int item in gi1/6

    Building configuration...

    Current configuration: 536 bytes
    !
    interface GigabitEthernet1/6
    switchport trunk encapsulation dot1q
    switchport trunk allowed vlan 2.10
    switchport mode trunk
    MTU 9198
    channel-group 64 mode on
    spanning tree portfast
    spanning tree enable bpduguard
    end

    ocs4948-1 #sh run int in64

    Building configuration...
    Current configuration: 291 bytes
    !
    Interface Port-channel64
    Description esx402 LACP link
    switchport
    switchport trunk encapsulation dot1q
    switchport trunk allowed vlan 2.10
    switchport mode trunk
    MTU 9198
    load-interval 30
    Storm-control broadcasts 5.00
    spanning tree portfast
    spanning tree enable bpduguard
    end

    ocs4948-1 #sh int trunk

    VLAN Mode Encapsulation native port State
    In64 on 802. 1 q trunking 1

    Port VLAN allowed on trunk
    In64 2.10

    Port VLAN authorized and active in the field of management
    In64 2.10

    VLAN port extending on transmission State and no tree pruned
    In64 2.10

    The only thing to look at will be the VLANs that you got set up on the vSwitch. You have defined VLAN native example, the VLAN untagged on the switch to be 4094, any traffic sent on the aura tags trunk VLAN, which will be removed by the vSwitch.

    In my setup, I have established groups of ports using VLANS and VLAN 2 10. Traffic to the virtual machines on these VLANs are .1Q marked by the physical switch, which is then stripped by the vSwitch.

    Take a look at the section "VLAN in VMware Infrastructure" on page 7 the concepts of virtual networking André already mentioned, but also the other interesting reading material is http://www.vmware.com/pdf/esx3_vlan_wp.pdf.

    Finally, for the side of the switch of things, look at the examples on Scott Lowe's blog at http://blog.scottlowe.org/2006/12/04/esx-server-nic-teaming-and-vlan-trunking/.

    Concerning

  • Cftransactions works with MS Access databases?

    The project I'm working on that accesses its data from a MS Access database. When you create a new person in the database there are several tables where the data is to be inserted and updated.

    I had the problem, that when the second, third... insertion fails, one is already done. Then I wanted to wrap the insertions in a cftransaction, so when a call fails the other ones get restored.

    But now no insertion takes place, even when there is no error. I have not found a reliable information it is possible to use with MS Access dbs cftransactions. Is it a definitive statement if it works with MS Access at all or it will work with what version?

    Hope you can help out me.

    I doubt that cftransaction will do you good with MS Access.  The main objective of the cftransaction tag is to use the functionality of the underlying database transactions.  In general, link operations several query statements together as an atomic unit such as if one of the statements fails, the entire transaction is rolled back and the database is left intact.  Access does not have a transaction log, so there is no way so he could process transactions (and thus to perform restorations).  If you find yourself with incremental updates that you see.

    This is another reason you will see recommendations of other ColdFusion developers DON'T use MS Access in ColdFusion applications.

    -Carl V.

  • ACROBAT STARTUP SCRIPT NOT WORK (with extendscript Tooklkit CS6)

    Hello

    I lived in programming, but beginning in the JS script in CS6.

    I developed some scripts in the Acrobat XI Pro console, now I wan't to install this global script that can be called by a menu.

    I'm working on Windows 7, with 64-bit:

    The path of the script is:

    C:\Program Files (x 86) \Adobe\Acrobat 11.0\Acrobat\Javascripts

    the script name is Confg.js

    The script is created with editor Extendscript Tooklkit CS6

    only contains this line:

    App.Alert ("Hey, since a script running in the world");

    I expect that an alert is poping up, when I opened Acrobat Pro XI with any PDF file:

    for a change

    app.addMenuItem ({cName: 'Test Menu', cParent: 'Help', cExec: "app.alert ('Menu Item Test'); '" "});

    does not work either

    After the opening of PDF Pro XI with an arbitry PDF, I get an error in the console:

    Acrobat Version mit integrierten EScript-Funktionen 11.0

    Acrobat SOAP 11.0

    SyntaxError: illegal character

    1:folder - Level: App:Config.js

    If I created the file with a text editor, things work perfectly, as expected.

    If I change this own file with Extendscript Tooklkit CS6 editor , even after the file is corrupted. This is Jean-Claude clumsy. Any solution, so I can work with Extendscript Tooklkit CS6 editor?



    Without seeing the file 'text' produced by Extendscript Toolkit in a hex editor, it is rather difficult to say. If there is a code of control buried in the text file.

    Acrobat supports all UI development because most of the scripts are quite small.

    Another problem may be that Extendccript does not add tags suitable scripts when editing Acrobat JS in Acrobat.

    Acrobat is not one of the programs listed, which is accompanied by Extendscript.

  • I can always download Adobe 9 Pro Extended and it'll work with 64-bit Windows 8?

    I can always download Adobe 9 Pro Extended and it'll work with 64-bit Windows 8?

    We don't know what application you mean when you say Adobe 9 Pro Extended, so he ois not sure if it is available for you to download.  If you diownload, it will be valid for a 30 day trial except if you already own it and have a serial number to activate the trial with.

    You can search the following site and see if you can find the trial version to download... this site is likely place only you might find the software available for download.

    If there is, don't forget to follow the steps described in the Note: very important article Instructions on the pages to download to this site or the download may not work properly.

    http://prodesigntools.com/tag/DDL

Maybe you are looking for

  • I'll be updating to iOS 10?

    I have 2 iPad 2 Air... He was recenfly replaced by Apple when the problem, connect to the router home after update to iOS 10. WiFi see link Ipad does not connect to internet 2 returned by Apple iPads have iOS 9 and application to update. After the pr

  • I have 66 updates that have failed to install

    I have a Toshiba laptop with windows vista. I tried to load automatically and manually. It always download and then asks me to restart the computer when you are finished. I restart and then get a message that the installation has failed. Any ideas?

  • you have been disconnected from gamespy, you have connected on another computer

    on fsx im having truble with lifting a session with a friend we can just connect to fly together and we always get connected to fsx as long as this message (you have been disconnected from gamespy, you have connected on another computer) also noticed

  • How to install windows 7 on vista 64-bit with USB key or usb hard drive

    I use windows vista 64 bit on HP Pavilion dv9925nr. HL-DT-ST DVDRAM GSA-T40L ATA Devicedisappeared 'my computer' and 'Device Manager' list a few days ago. There is no upper and lower filter. Device is that in the "boot order" Start menu device someti

  • Can not send emails

    I added an account to my windows mail, but it won't work. under incoming mail, I added: imap.aim.com under outgoing mail, I added: smtp.aim.com AOL is tell me in their instructions to change "the port 587" and maybe that's the problem since I have no