Dynamic expression in interface

Hi all

Could someone share a way how to create the dynamic expression in ODI interface. For example. I metadata and want to build an expression box on its base and use it in the interface.


I tried several possibilities:

(1) Java use in expression mapping program.
But during the stages of the interface creation getJDBCConnection() method returns NULL for SRC and DEST.
It is a way to connect to the database?

(2) generate the expression in the procedure and use it in the interface
Is there a way how to pass the string interface procedure?

(3) use variable to generate the expression
Pure SQL is not enough to generate my expression, I need to cycles, ifs etc.

(4) use special IKM that replace some symbols of substitution with generated expression.
Well, if there is no other choice I'll pick this up but don't want to have extra KM special.

Could someone suggest another solution or workaround for referred?

Thanks in advance!

Oleg Ivanov

Here is the solution

Step 1. Java ODI procedure
Create a new procedure in the
Command on Source - technology - Oracle, and schema-

Target - technologies - Java Bean shell command and paste the following code

 

<@
import java.sql.Connection;
import java.sql.Statement;
import java.sql.DriverManager;
import java.sql.ResultSet;
import java.sql.ResultSetMetaData;

conn=odiRef.getJDBCConnection("SRC");
Statement stmt=conn.createStatement();
String result="CASE ";
char delimiter=(char)13; 

my_query= "select 'WHEN '||SRC_TAB_COLUMN||' = '||SRC_TAB_COLUMN_VALUE||' THEN '''||PRODUCT_NAME||'''' AS OUTPUT FROM ODI_TEMP.metadata";
ResultSet rs=stmt.executeQuery(my_query);
while (rs.next()) {
String  output=rs.getString("OUTPUT")+ delimiter;
result+=output;
}
result+="END";

stmt.close();
conn.close();
@>

[Note: Please change the name of the Table, column, as required]
In the interface where you want to call the condition had the following code

 <@=result@> 

and set it to put in domain.
I tested the java code and I get after sample case condition

CASE WHEN Call_Type = 10 THEN 'SMS'
WHEN Call_Type = 20 THEN 'MMS'
WHEN Call_Area = -1 THEN 'Unknown'
END

In the package call first ODI then Interface procedure and run as a set only.
Hope this fixes your requirement for dynamic business condition.

Tags: Business Intelligence

Similar Questions

  • Dynamic expression of follow-up in interface

    I created this thread so I can give credit to anyone help me on this.

    I tried to follow the following thread and have some errors.

    Dynamic expression in interface

    When I run the only interface with Java procedure (< @ result = @ >) his work.

    In the package, the first step is Java procedure. The second step is the interface. When I execute the package its failure at the level of the interface even if I do not call the outcome of the procedure in the interface. Any idea.

    Dev - Yes, I use the same context

    -app

    To do this.

    Step 1. Run the procedure, add odioutfile and there in the text of appeal<@=result@>
    Step 2. Copy your I have select $ query and use the box file instead of variable result and executed in the SQL Editor.
    This way you can be sure that everything works correctly, since it looks like the case before java generates is having some problem causing SQL fails with invalid identifier. I think once you this part completed. He should have success.

  • call an express vi interface programmatically

    What I'm trying to do is to use scripture to interface configuration measurement file express vi (and features) at run time.  I want to allow changing the settings onfiguration during execution of the vi.  I tried to open the interface directly from the DLL (in vi library) and it opened, but reported bad reference of vi.  Can I extract all the vi of the dll to use in my program?  Is there an easy way to grab all the vi dependent libraries?  Please advise if I take the wrong approach.

    Thank you

    Scott

    ScottAdon-

    What configuration settings to make adjustable? You can right click on the writing of measure File.VI and click Open the front panel. This converts the Express VI subVIs that are configurable. You will have to go to sift through the subVIs to find the settings you want, and then add in as parameters in the component of connector but then after that you will be able to plug in control over what can be adjustable. This is not supported, but it can be easily done if you just look at the code and understand how each parameter. Hope this helps!

  • Dynamically loading the interface from a remote source implementation class

    Hello guys,.

    I'm kind new to AS3, please bear with me.

    I'm working on a project were I want to implement some sort of MVC. The idea is this: have an application Viewer that connects to a database and reads the object to display (based on some ID); have an app Setter that connects to the database and sets the object to display for a particular ID.

    What I'm trying to do is to have an interface that declares the common methods for the object class (like the draw, etc.) and have implementations of this interface be dynamically loaded from the database in the Viewer.

    Is this possible? I still think about it in the right way?

    I'd appreciate any suggestions really.
    Thank you

    If you check the book by peldi et al., u would have found what you're talking about. The principle u want to talk is easy to do. This might get u started (it is FMS but the idea is the same): http://help.adobe.com/en_US/FlashMediaServer/3.5_SS_ASD/flashmediaserver_3.5_sslr.pdf - p.28 - application.registerClass () method.

  • Control the layout in a dynamic graphical user interface

    I have a main panel using BorderLayout with two sub-panels, a control panel to the North, and a billboard in the centre. The control panel contains a set of controls, and this set of orders grows and shrinks dynamically when the user interacts with the application.

    I have this stated control panel using FlowLayout. My problem is that when the set of controls is too long to fit on one line, the next control to add never appears, because the Panel does not grow to two lines. I like control panel to develop at the expense of the main display panel in the Center (and shrink again when controls are removed so that the rest fit again in one line).

    Essentially, the behavior I want is analogous to how JTabbedPane: it adds and removes tabs in a JTabbedPane, the tab region shrinks and grows dynamically.

    Of course, there is an extra step that I have to run every time that I add or remove a control, to force the various layout managers to do their work. I tried various combininations to invalidate and revalidation of the Control Panel, the main panel and so on, but I have nothing seems to have the desired effect.

    Thanks for your suggestions.

    The code that I provided was really useful? So, what is your final solution? I'm sure that others in the forum would like to see your solution.

    If the answer to the question marks, he said. You don't want to ask another question and that people trying to answer.

  • Dynamic interfaces for Cisco 2106

    Greetings, I've configured the 4400 front controllers and I am familiar with the terms used, ive recently acquired a controller 2106, I have assigned an AP Manager and management address to Port 1 on the same subnet, and can test the device.

    Subsequently, I have several different VLAN with different subnets I want to provide services as wireless as well as a network of comments.

    So I configured the WIFI network and each its own dynamic interfaces associated with. Each dynamic interface is in turn associated with its own port of the controller.

    Port 1 - AP Manager/Management

    2 - Dynamic interface - the WLAN port has

    Port 3B - dynamic Interface - WLAN

    Port 4 - dynamic Interface - WLAN C

    And so on, unfortunately where configure this I lose connection to the controller, if I put all dynamic and static interfaces on a single port it works fine.

    IM current rapid PVST + on my switches and I'm thinking it may be a matter of spanning tree but necessarily clarification if what im doing is actually possible?

    Concerning

    See this post for more details.

    http://forums.Cisco.com/eForum/servlet/NetProf?page=NetProf&Forum=Wireless%20-%20Mobility&topic=General&TopicId=.ee6e8b8&fromOutline=&CommCmd=MB%3Fcmd%3Ddisplay_location%26location%3D.2cc0608c

    HTH.

  • FPGA Interface Cast question

    I play with a VST 5644 and model VST streaming.  On the FPGA VI, I added the code, then added an indicator of the face before of the FPGA VI and compiled.  Executes the FPGA VI in interactive execution mode, the indicator works well.  Side host, however, I can't access the new indicator with read/write control.

    Coming out of the open FPGA VI reference I can see the indicator on the wire, but in the Dynamic Cast of Interface FPGA function is have rooted out the refnum somehow.  If I connect to control read/write directly to the output of the function of open reference I can access the indicator very well.

    No idea what I am doing wrong?

    Thank you.

    You re-configured your FPGA VI reference with the new bitfile interface?  The cast of dynamic interface defines the lead as all methods and indicators according to the type of wire connected.  You can right click on the constant of type and select "Configure the FPGA VI... of reference".  In the pop up window that follows, select "import of bitfile...". "and select the new bitfile you've built.

    You must update the fpga reference type in the "Device Session.ctl" type def as well.  This is the type that you will be able to access throughout the project.

  • Installation of a card PCI-Express for e-SATA Support Ports?

    Hello Experts,

    I would buy a card PCI-Express to Support 2 x e-SATA Port. The card can only installed in a PCI-Express Slot Interface. Windows Vista Ultimate German, 32-bit Version with SP1, real drivers and patches on my XPS PC.

    I'm not sure, that the card can be installed on my XPS 720 desktop computer.

    Currently work driving my Seagate FreeAgent Pro on the IEE1394 (e.g. Firewire) Port, but the speed is currently very poor.

    Sorry for my bad English, I live in Germany... ;)

    For more Questions for me - thanks to all the experts here...


  • RA VPN doesn't work is not on the second external interface

    I've temporarily came from two Internet service providers in our ASA 5510.  Which works very well.  I tried to configure the VPN to our second outside interface (outside-XO) and who does not.  The first/original VPN works great.  Can someone look at the config and tell me if I did something wrong.  It is not a customer number, because it is able to connect fine on the first interface.  Thank you.

    ASA Version 7.1 (2)
    !
    hostname FW01
    dot.com domain name
    activate the password * encrypted
    names of
    !
    interface Ethernet0/0
    nameif outside
    security-level 0
    IP address *.229.200 255.255.255.192
    !
    interface Ethernet0/1
    Speed 100
    full duplex
    nameif inside
    security-level 100
    IP 192.168.2.3 address 255.255.255.0
    !
    interface Ethernet0/2
    nameif outside-XO
    security-level 0
    IP address *.157.100 255.255.255.192
    !
    interface Management0/0
    nameif management
    security-level 100
    IP 192.168.14.254 255.255.255.0
    management only
    !
    passwd * encrypted
    banner login attention is a private network. Unauthorized intruders will BE prosecuted to the extent of the ACT!
    boot system Disk0: / asa712 - k8.bin
    passive FTP mode
    clock timezone PST - 8
    clock summer-time recurring PDT 2 Sun Mar 2:00 1 Sun Nov 02:00
    DNS server-group DefaultDNS
    dot.com domain name
    permit same-security-traffic intra-interface
    object-group service tcp Server
    HTTPS and www description
    EQ object of the https port
    port-object eq www
    object-group service tcp Mail
    SMTP POP3 access description
    EQ Port pop3 object
    EQ smtp port object
    port-object eq 32000
    non-standard tcp service object-group
    Port Description 1429 and 1431
    port-object eq 1431
    port-object eq 1429
    object-group service DNS tcp - udp
    Description to allow outside DNS resolution
    area of port-object eq
    object-group service FTP tcp
    FTP description
    port-object eq ftp
    SMTPMail tcp service object-group
    Description SMTP only access
    EQ smtp port object
    IQWebServer tcp service object-group
    Www and port 8082 description access
    port-object eq www
    EQ object Port 8082
    EQ object of the https port
    port-object eq 8999
    SFTP tcp service object-group
    Description SFTP_SSH
    EQ port ssh object
    outside_access_in list extended access permit tcp any host *. *.229.201 - a group of Web server objects
    outside_access_in list extended access permit tcp any host *. *.229.202 object-group Mail
    outside_access_in list extended access permit tcp any host *. *.229.202 - a group of Web server objects
    outside_access_in list extended access permit tcp any host *. *.229.202 object-group DNS
    outside_access_in list extended access permit tcp any host *. *.229.203 - group of non-standard items
    outside_access_in list extended access permit tcp any host *. *.229.204 - a group of Web server objects
    outside_access_in list extended access permit tcp any host *. *.229.205 - group of non-standard items
    outside_access_in list extended access permit tcp any host *. *.229.208 - a group of Web server objects
    outside_access_in list extended access permit tcp any host *. *.157.101 - a group of Web server objects
    outside_access_in list extended access permit tcp any host *. *.157.102 object-group Mail
    outside_access_in list extended access permit tcp any host *. *.157.102 - a group of Web server objects
    outside_access_in list extended access permit tcp any host *. *.157.102 object-group DNS
    outside_access_in list extended access permit tcp any host *. *.157.103 - group of non-standard items
    outside_access_in list extended access permit tcp any host *. *.157.104 - a group of Web server objects
    outside_access_in list extended access permit tcp any host *. *.157.105 - group of non-standard items
    outside_access_in list extended access permit tcp any host *. *.157.108 - a group of Web server objects
    access-list 150 extended permit tcp any any eq smtp
    access-list sheep extended ip 192.168.0.0 allow 255.255.0.0 10.1.1.0 255.255.255.0
    access-list sheep extended permits all ip 10.1.1.0 255.255.255.240
    Splt_tnl list standard access allowed 192.168.0.0 255.255.0.0
    Splt_tnl list standard access allowed 10.1.1.0 255.255.255.0
    access-list extended webcap permit tcp any host *. * eq.164.210 smtp
    access-list extended webcap permit tcp host * smtp eq.164.210 all
    pager lines 24
    Enable logging
    logging asdm-buffer-size 200
    buffered logging critical
    exploitation forest asdm errors
    Outside 1500 MTU
    Within 1500 MTU
    management of MTU 1500
    outside-XO MTU 1500
    mask 10.1.1.1 - 10.1.1.15 255.255.255.0 IP local pool VPNpool
    mask 192.168.14.244 - 192.168.14.253 255.255.255.0 IP local pool VPNCisco
    ICMP allow any inside
    ASDM image disk0: / asdm512.bin
    enable ASDM history
    ARP timeout 14400
    Global (outside) 1 *. *.229.194
    Global (outside-XO) 1 *. *. 157.66
    NAT (inside) 0 access-list sheep
    NAT (inside) 1 192.168.0.0 255.255.0.0
    public static tcp (indoor, outdoor) * domaine.229.202 192.168.14.166 netmask 255.255.255.255 area
    public static tcp (indoor, outdoor) *.229.202 www 192.168.14.2 www netmask 255.255.255.255
    public static tcp (indoor, outdoor) *.229.202 smtp smtp 192.168.14.2 mask 255.255.255.255 subnet
    public static tcp (indoor, outdoor) *.229.202 192.168.14.2 pop3 pop3 netmask 255.255.255.255
    public static tcp (indoor, outdoor) *.229.202 32000 192.168.14.2 32000 netmask 255.255.255.255
    static (inside, outside) *. * 192.168.14.6.229.203 netmask 255.255.255.255
    static (inside, outside) *. * 192.168.14.28.229.204 netmask 255.255.255.255
    static (inside, outside) *. * 192.168.14.205.229.205 netmask 255.255.255.255
    static (inside, outside) *. * 192.168.14.29.229.208 netmask 255.255.255.255
    static (inside, outside) *. * 192.168.14.3.229.201 netmask 255.255.255.255
    TCP static (inside, outside-XO) *. * domaine.157.102 192.168.14.166 netmask 255.255.255.255 area
    TCP static (inside, outside-XO) *. *.157.102 www 192.168.14.2 www netmask 255.255.255.255
    TCP static (inside, outside-XO) *. *.157.102 smtp smtp 192.168.14.2 mask 255.255.255.255 subnet
    TCP static (inside, outside-XO) *. *.157.102 192.168.14.2 pop3 pop3 netmask 255.255.255.255
    TCP static (inside, outside-XO) *. *.157.102 32000 192.168.14.2 32000 netmask 255.255.255.255
    static (inside, outside-XO) *. * 192.168.14.3.157.101 netmask 255.255.255.255
    static (inside, outside-XO) *. * 192.168.14.6.157.103 netmask 255.255.255.255
    static (inside, outside-XO) *. * 192.168.14.28.157.104 netmask 255.255.255.255
    static (inside, outside-XO) *. * 192.168.14.205.157.105 netmask 255.255.255.255
    static (inside, outside-XO) *. * 192.168.14.29.157.108 netmask 255.255.255.255
    Access-group outside_access_in in interface outside
    Access-group outside_access_in in interface outside-XO
    Route outside 0.0.0.0 0.0.0.0 *. * 1.229.193
    Route inside 192.168.0.0 255.255.0.0 192.168.2.1 1
    Route outside-XO 0.0.0.0 0.0.0.0 *. * 2.157.65
    Timeout xlate 03:00
    Timeout conn 01:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
    Sunrpc timeout 0:10:00 h323 0:05:00 h225 mgcp from 01:00 0:05:00
    Timeout mgcp-pat 0:05:00 sip 0:30:00 sip_media 0:02:00
    Timeout, uauth 0:05:00 absolute
    attributes of Group Policy DfltGrpPolicy
    No banner
    WINS server no
    DNS server no
    DHCP-network-scope no
    VPN-access-hour no
    VPN - connections 3
    VPN-idle-timeout 480
    VPN-session-timeout no
    VPN-filter no
    Protocol-tunnel-VPN IPSec
    disable the password-storage
    disable the IP-comp
    Re-xauth disable
    Group-lock no
    disable the PFS
    IPSec-udp disable
    IPSec-udp-port 10000
    Split-tunnel-policy tunnelall
    Split-tunnel-network-list no
    by default no
    Split-dns no
    disable secure authentication unit
    disable authentication of the user
    user-authentication-idle-timeout 30
    disable the IP-phone-bypass
    disable the leap-bypass
    disable the NEM
    Dungeon-client-config backup servers
    the firewall client no
    rule of access-client-none
    WebVPN
    url-entry functions
    HTML-content-filter none
    Home page no
    4 Keep-alive-ignore
    gzip http-comp
    no filter
    list of URLS no
    value of customization DfltCustomization
    port - forward, no
    port-forward-name value access to applications
    SSO-Server no
    value of deny message connection succeeded, but because some criteria have not been met, or because of a specific group policy, you are not allowed to use the VPN features. Contact your administrator for more information
    SVC no
    SVC Dungeon-Installer installed
    SVC keepalive no
    generate a new key SVC time no
    method to generate a new key of SVC no
    client of dpd-interval SVC no
    dpd-interval SVC bridge no
    deflate compression of SVC
    Cisco strategy of Group internal
    Cisco group policy attributes
    value of server WINS 192.168.14.4 192.168.14.11
    value of 192.168.14.4 DNS server 192.168.14.11
    Split-tunnel-policy tunnelspecified
    value of Split-tunnel-network-list Splt_tnl
    field default value *.com
    username * password * encrypted
    username * password * encrypted privilege 0
    username * password * encrypted
    username * password * encrypted
    username * password * encrypted
    username * password * encrypted privilege 15
    username * password * encrypted privilege 15
    the ssh LOCAL console AAA authentication
    Enable http server
    http 0.0.0.0 0.0.0.0 outdoors
    http 192.168.0.0 255.255.0.0 inside
    http 192.168.1.0 255.255.255.0 management
    http 192.168.14.0 255.255.255.0 management
    http 0.0.0.0 0.0.0.0 outside-XO
    SNMP-server host within the public 192.168.14.27 of the community
    location of the SNMP server *.
    contact SNMP Network Admin Server
    Server enable SNMP traps snmp authentication linkup, linkdown cold start
    Crypto ipsec transform-set esp-SHA-ESP-3DES-3des esp-sha-hmac
    Crypto-map dynamic outside_dyn_map 20 the value transform-set ESP-3DES-SHA
    dynamic-map of crypto-XO_dyn_map 10 outside the value transform-set ESP-3DES-SHA
    map outside_map 65535-isakmp ipsec crypto dynamic outside_dyn_map
    outside_map interface card crypto outside
    outside-XO_map 65535 ipsec-isakmp crypto map outside Dynamics-XO_dyn_map
    card crypto outside-XO_map interface outside-XO
    ISAKMP allows outside
    ISAKMP enable outside-XO
    part of pre authentication ISAKMP policy 10
    ISAKMP policy 10 3des encryption
    ISAKMP policy 10 sha hash
    10 2 ISAKMP policy group
    ISAKMP life duration strategy 10 86400
    ISAKMP nat-traversal 20
    IPSec-attributes tunnel-group DefaultL2LGroup
    ISAKMP keepalive retry threshold 600 10
    IPSec-attributes tunnel-group DefaultRAGroup
    ISAKMP keepalive retry threshold 600 10
    tunnel-group, type Cisco ipsec-ra
    attributes global-tunnel-group Cisco
    address pool VPNpool
    Group Policy - by default-Cisco
    tunnel-group Cisco ipsec-attributes
    pre-shared-key *.
    ISAKMP keepalive retry threshold 600 10
    Telnet 192.168.0.0 255.255.0.0 inside
    Telnet 192.168.14.109 255.255.255.255 inside
    Telnet 192.168.14.36 255.255.255.255 inside
    Telnet timeout 5
    SSH 0.0.0.0 0.0.0.0 inside
    SSH timeout 5
    Console timeout 10
    management-access inside
    dhcpd lease 3600
    dhcpd ping_timeout 50
    !
    INSPECT class-map
    class-map inspection_default
    match default-inspection-traffic
    !
    !
    Policy-map global_policy
    class INSPECT
    inspect the dns
    inspect the http
    inspect the icmp
    inspect the tftp
    inspect the ftp
    inspect the h323 ras
    inspect h323 h225
    inspect the snmp
    inspect the sip
    inspect esmtp
    class inspection_default
    inspect the ftp
    !
    global service-policy global_policy
    TFTP server inside 192.168.14.21 TFTP-root /.
    192.168.14.2 SMTP server
    Cryptochecksum:5eedeb06395378ed1c308a70d253c1b6
    : end

    Hello

    Should work.

    What I think is the routes:

    Route outside 0.0.0.0 0.0.0.0 *. * 1.229.193
    Route outside-XO 0.0.0.0 0.0.0.0 *. * 2.157.65

    If the first interface is ok, the ASA does not go to route packets via the second interface, so VPN will be not through this interface.

    On the client, can you PING the two IPs outside of ASA or only the first?

    Try to add a static route on the SAA to secondary education outside interface pointing to the address of the customer and try to connect via VPN and see if it works.

    Orders:

    HS cry isa his

    HS cry ips its

    Will be a big help as well, when the VPN connection attempt failed.

    Federico.

  • L2L dynamic peers with no dynamic peers

    Hi all

    Can't see to fight my way out of this configuration.  We have a router configured with the dynamic IPSec L2L counterparts and remote access to (pretty much using this configuration: LINK ).  I'm not use to the keychain / configuration profile.  But try adding a tunnel without a profile, perhaps 'non-dynamique' peer?

    Here is the configuration:

    crypto keyring spokes 
      pre-shared-key address 0.0.0.0 0.0.0.0 key PSK1
    !
    crypto isakmp policy 10
     encr aes
     authentication pre-share
     group 2
    !
    crypto isakmp policy 20
     encr 3des
     hash md5
     authentication pre-share
     group 2
    crypto isakmp key L2L-PSK2 address 76.113.24.103
    crypto isakmp keepalive 10 10
    crypto isakmp nat keepalive 10
    !
    crypto isakmp client configuration group VPN-Users
     key PSK1
     pool ippool
     acl 171
    !
    crypto isakmp profile VPNclient
       match identity group VPN-Users
       client authentication list default
       isakmp authorization list groupauthor
       client configuration address respond
    crypto isakmp profile L2L
       keyring spokes
       match identity address 0.0.0.0 
       
    crypto ipsec transform-set ESP-3DES-MD5 esp-3des esp-md5-hmac 
    crypto ipsec transform-set transform-1 esp-3des esp-md5-hmac 
    crypto ipsec transform-set testset esp-3des esp-md5-hmac 
    crypto ipsec transform-set ESP-AES-SHA esp-aes esp-sha-hmac 
    !
    crypto dynamic-map DynIPSecMap01 2
     set transform-set ESP-3DES-MD5 
     set isakmp-profile VPNclient
    crypto dynamic-map DynIPSecMap01 5
     description tunnel_to_EEUU
     set transform-set testset 
     match address 110
    !
    !
    crypto map IPSecMap01 10 ipsec-isakmp 
     description REMO_ST_VPN
     set peer 76.113.24.103
     set transform-set ESP-AES-SHA 
     match address REMO_ST_VPN
    crypto map IPSecMap01 10000 ipsec-isakmp dynamic DynIPSecMap01 

    interface Serial0/0/0:0
     ip address 178.31.76.1 255.255.255.252
     ip flow ingress
     ip flow egress
     ip nat outside
     ip virtual-reassembly
     crypto map IPSecMap01
     
    ip access-list extended REMO_ST_VPN
     permit ip 172.18.38.0 0.0.0.255 172.16.202.0 0.0.0.255
    !
    access-list 10 permit 65.122.15.2
    access-list 110 permit ip 172.18.35.0 0.0.0.255 10.1.2.0 0.0.0.255
    access-list 110 permit ip 172.18.38.0 0.0.0.255 10.1.2.0 0.0.0.255

    We are failing on Phase 1 because the PSK does not match.  And this error:

    ISAKMP: (3134): key not found in the profile key, abandonment of exchange rings

    Can someone point me in the right direction?

    Thanks for your time and support,

    Nick

    Try to create a new crypto isakmp profile to match the INVESTIGATION period off the coast of the L2L counterpart.  Then create a new door-key crypto for this peer instead of using the command "isakmp crypto key.

  • Physical networks VPN multiple interfaces of the ATA.

    Hello all and thanks in advance for any advice you can provide.

    I have a 5220 ASA set up with 3 networks. I have a off-grid, one inside the network and a network of "DSL". Everything works great, except that I'm trying to clean up the way we connect with VPN client.

    At the moment, if we are outside our network, we use the external IP address of the router (x.x.A.1). When we are on the LAN subnet, we are unable to VPN to the external IP address, so we are forced to use a completely separate identification information together and to connect to the IP address of the subnet LAN (x.x.B.1).

    Is it possible to configure the VPN so that we would be able to use the same credentials to connect to the interface either? I can use DNS selective so that requests are sent to the correct IP address... but as it is, it does not accept one set of credentials on each interface.

    Any help would be appreciated.

    Question:

    Have you tried to set up a separate crypto for the LAN interface card input.

    Lets say you have an entry like this crypto map...

    Crypto-map dynamic dynmap 65534 transform-set RIGHT

    cry map outside_map 65536-isakmp ipsec dynamic dynmap

    interface card cry out outside_map

    Can you try to create another entry card crypto under a different name for the LAN interface.

    Let me know.

    See you soon

    Gilbert

  • Dynamic model AMX in ADF Mobile

    Hi guys,.

    As seen in file AMX to design the user interface for ADF Mobile, but I just need to have a dynamic flow user interface
    for example. When choosing fall down in the page (A) and jump to the next page (b) with the value control to show some of < amx:inputText > in the page (b)

    How to make dynamic in amx?

    Hello

    have a bean managed in the Workflow page range. Bind the property made of components on the page to the same successful bean and have the bean by assigning the value of the field that is rendered true or false. That's how I'd do. A similar use case is here: http://www.oracle.com/technetwork/developer-tools/adf/learnmore/m02-dynamicallyshowhidecomponents-1915399.pdf

    Frank

  • Reiterative Loadvars (dynamic)

    It seems that once a new LoadVars object is used, it cannot be re-used to send POST data again.

    For example, I have 40 questions on a test.

    Whenever the student answers a question, the information uses SendAndLoad by MAIL (see below) to insert a new record in mySQL of the data for that question.

    The test goes through the same routine of 40 times and so should insert 40 unique records representing the answer of the student for each question.

    I can't create a _global or table loadvars object and then reallocate the array elements in each issue (which would be reused in another setting an array element or the object _global. Flash doesn't let me do.

    Any ideas? Forum adobe and google search have not turned to the top of anything yet that this routine below (thread is also below in the section: dynamic loadvars)

    for (i = 0; i < maxnumbersinlist; i ++) {}
    _root ["display" + i] = myLoadVar ['show' + i];
    }

    Please explain how this would work, would it? I can't design a send_lv [ques1], [ques2] send_lv.

    Where you need to understand what I'm trying to do, here is the site:
    http://www.4themax.com/education/regents_quest/quiz-home.html

    With the example below, I want to reuse send_lv and result_lv then

    Question 1: send_lv.nme = "John";

    Question 2: send_lv.nme = "test server 234;

    Question 3: send_lv.nme = '3 '. etc.

    (data are fictitious, but the data will be different every time the send_lv is mailed to a php file to insert the mySQL data)

    Otherwise, I would create 40 objects loadvars different, i.e. the send_lv1.nme in question 1, send_lv2.nme for question 2, etc., which is very heavy.


    -the thread of the previous post-
    This is WHAT WORKS! THANKS kglad - I also put a kudo to you on my screen.
    Tip: I had to make the php file to write the contents of the variable in a file, because it doesn'tdisplay on the screen with echo so that the variable passed from flash to php.

    Adobe document source: http://livedocs.adobe.com/flashlite/2/main/00000572.html

    var submitListener:Object = new Object();
    submitListener.click = {function (evt,:Object)}
    var result_lv:LoadVars = new LoadVars();
    /*
    result_lv. OnLoad = {function (success:Boolean)}

    If (success) {}
    result_ta. Text = ' sent successfully! ";
    } else {}
    result_ta. Text = 'Error connecting to server.';
    }

    };
    */
    var send_lv:LoadVars = new LoadVars();
    send_lv. NME = "Test Server2."
    Sending.Text = send_lv.nme;
    send_lv.sendAndLoad ("loadvars.php", result_lv, "POST");
    //};
    submit_button.addEventListener ("click", submitListener);

    <? PHP
    $contents = $_POST ['nme'];
    echo $contents; DISPLAYS NO CONTENT
    Open the file write-only - used to view the contents of the _POST variable sent by LoadVars
    $file = fopen ('loadvars.txt', 'w');

    write content
    fwrite ($file, $contents);

    Close the file
    fclose ($file);

    ? >
    -forum thread is less: -.
    Arfa
    The user is in offline mode
    View profile

    Junior member posts: 3
    Joined the: 25/03/2003
    2008-01-26 01:01:02
    Response | City | Top | Bottom

    Hi all

    I write actionscript to get variables in a database using php. I used the LoadVars object and you can set a variable using the following line of code that works

    _root. Show1 = myLoadVar.display1

    In this case, myLoadVar is an instance of the Loadvars class and name1 is part of a series of variables sent from php.

    I need to make the right part of the dynamic expression for example (name1, display2, display3 etc.)

    I tried to use eval, but it does not work.

    Thanks for any help.

    ANSWER:
    for (i = 0; i < maxnumbersinlist; i ++) {}
    _root ["display" + i] = myLoadVar ['show' + i];
    }

    your code does the trick! Once more, kglad is the man!

    I changed to show that you can add multiple variables (tabular) which represents the fields in the questions, and I removed the "_" which gives a urlencoded thing into the mix.

    send_lv object includes ALL the fields for ALL the questions in the form of name-pair values, which is what I wanted! Happy! Happy me!

    var send_lv:LoadVars = new LoadVars();

    totalquestions = 40; whatever number you want

    for (var i: Number = 1; i<>

    response, lastname, firstname is the mySQL database table fields to insert into

    send_lv ["answer" + i] = response ;
    send_lv ["lastname" + i] = LastName As String
    ;
    send_lv ["firstname" + i] = name ;
    send_lv.totalquestions = 5;
    }

    send_lv.sendAndLoad ("LoadVars.php", result_lv, "post");

    ----------------
    The for loop can include as many fields as you need! I have set up in the SWF file of sendAndLoad to the php file for Totalquestions = 5, as a prototype. I have created several fields and reached to the POSTER in a php file inserted 5 records.

    The psedocode for the php file is:

    $variable1 = username; Repeat password, localhost, etc..

    $variable2 = $_POST_ {"totalquestions"];}

    for ($i = 1; $i<= variable2;="" $i++)="">
    $variable3 = $_POST_ {'field1'].} Field1 $i
    $variable4 = $_POST_ {'Field2'].} //field2 $i repeat this for all your fields

    Open the database

    $qry_val1 = ' SELECT * from yourtablename (Field1, Field2) VALUES ("'.") $variable3.' «, (« '. $variable3. » ")';
    $result - mysql_query ($qry_val2) or die ('could not query the database'. mysql_error());

    } //for loop ends

    //close the database mysql_close(dB$)
    }

    I take the time to put it here to help others if they are looking for the forum instead of asking the same thing again.
    I have to admit that dealing with databases is REALLY hard the first time.

    Thank you once again together, especially kglad!

  • Satellite T230D PST4LA - 00R008 Atheros AR9285 WiFi / BT driver issues

    Hello

    I replaced the HARD drive in satellite T230D pst4la-00r008 because of Vegetto HDD.
    I tried to win 7 x 86 sp1, win8 and 8.1 x 64 and I'm currently setting up win 7 x 64 sp1,.

    I have installed all the drivers such as recommended by toshiba and can't connect to wifi or install bluetooth.

    adapter is an atheros AR9285. (installed the wifi (from toshiba, MS and atheros Web sites) followed by BT pilot filter a monitor then BT Stack).

    installation of drivers WiFi ok and wifi networks are available, but no error message unable to connect.
    When you install the bluetooth stack he asks me to connect bluetooth devices.

    will post more information that I organize all errors/accidents of different combinations of operating system driver.

    could someone please inform me of what the default windows and your driver for laptop in regards to WIFI as the sticker on the bottom was rubbed by far.

    Thanks in advance

    Hello

    I found the chip Atheros AR9285 specifications and this wireless Mini-PCI network card doesn't support BT
    http://www.QCA.Qualcomm.com/wp-content/uploads/2013/11/AR9285.PDF

    _ * AR9285 specifications * _

    Frequency band: 2.4 GHz
    Network Standard: 802. 11 b, 802. 11 g, 802.11n
    Technology of modulation: OFDM with BPSK, QPSK, 16 QAM, 64 QAM; DBPSK, DQPSK, CCK
    Coding of FEC: 1/2, 2/3, 3/4, 5/6
    Hardware encryption: AES, TKIP, WEP
    Quality of Service: 802.11e
    Access to Technical Support: CSMA/CA
    Communication interface: PCI Express
    Device interface: GPIO, LEDs
    Data rates supported: b 11: 1-11 Mbps 11g: 6-54 Mbps 11n: 6.5 to 150 Mbps
    Voltage: 1.2V +/-5% 3.3 v +/-10%
    Packaging dimensions: 8 x 8 mm
    Package: 68 pins CISA

  • Does support PCI Satellite A100-812 (PSAAR) standard MXM slot

    Hello

    I have a Satellite A100-812 at the moment and I was wondering if the PCI-e slot is 1 on the mxm standarts.

    And if so, could it be replaced by another graphics card, say a 8600M GT?

    Hi Marien

    The Satellite A100 does not support the MXM (Mobile PCI Express Module) interface and the graphics card or upgrade replacement is certainly not possible!
    The graphics card is fixed and welded on the map and you can not delete it!

    If you want you can use the advanced search option forum and could search for similar topics to this topic.
    But I guess that you will always find the same info that is; GPU upgrade is not possible

    Best regards and have a nice day!

Maybe you are looking for

  • Qosmio X 300-SATA need driver for Vista

    I would greatly appreciate any help you can offer. I have a Qosmio X 300 148, that I had to install a new hard drive and I try to install Vista Ultimate but when I get to choose where to install windows indicates that it can not install to this place

  • Z61m: Replacement of LCD Panel (WSXGA + WUXGA)

    I own ThinkPad Z61m (Type 9450-HAG). Unfortunately the LCD does not any more (only the first third of the works of the display). I consider replacing the LCD screen (WSXGA +, FRU No.: 13N7020). Is it possible to replace the original panel with WUXGA

  • Microsoft sales techniques

    Using my computer yesterday and a pop told me to ring Microsoft because they detected a dangerous virus. Could not get rid of the window I did, they took control at a distance and tried to sell me a bunch of virus protection. Is it Microsoft or not?

  • Z10 Z10 blackBerry screen does not black out during call

    My screen Z10 won't black during the call when I place the phone to my ear, which causes unwanted press icons or sometimes call disconnects because my ear touches the end call icon. I have to manually lock the screen using button lock, which is irrit

  • CPD Watchdog Violation Windows 8 [SOLVED]

    Hello! Occasionally I get the DPC_WATCHDOG_VIOLATION. Used when I play games. I use the laptop Asus n56vz and SSD OCZ vector 512 GB. I tried to update all drivers, BIOS, and Firmware of the SSD, but I still get the error.  I have used NOD32 Antivirus